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1. Introduction 

 
 
To see the main contents of the help guide, press the F1 key while using a command or while in any 
mode. The F1 key by default will open the contents help guide. This will display the help document 
for the particular command or mode that is being used. 
 

Note:  

You must be in an active command or in an activate mode to use the F1 function. Otherwise, 
either the intro document page will be displayed if the F1 function is used for the first time, or 
the last help page viewed. 
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1.1. Welcome to Geomagic Design X 
 

 
 

Parametric CAD Models from 3D Scan Data 

Thank you for choosing Geomagic Design X, the most comprehensive 3D Scan-To-CAD Software 
Solution. 3D Systems, Inc. is the leader in providing technologies that make 3D scanning a powerful 
tool for a variety of applications including manufacturing, R&D, quality inspection, medical research, 
civil engineering and more, and is now presenting the future of 3D scanning software technology 
with its next generation 3D scan data processing platform, Geomagic. Geomagic Design X makes 
the process of creating parametric CAD models from real world parts faster and easier by utilizing a 
design process and user interface that are instantly familiar to CAD users. 
 
 

Parametric CAD Models from 3D Scan Data 

Geomagic Design X allows engineers to capture the design intent and design parameters of real 
world parts that may have lost their defining features during the manufacturing process or may not 
have ever had a CAD model. 3D scanning technology and Geomagic Design X provide 
manufacturers with the freedom and flexibility to extract the design parameters from any real world 
part, including prismatic features and freeform surfaces. CAD models created in Geomagic Design X 
are fully parametric, so designers and engineers are able to modify the design parameters of the real 
world part to perfect the model for mass production within Geomagic Design X in a downstream 
CAD system. 
 

• Intelligent tools for extracting design parameters from 3D scan data – Redesign Assistant 

• Redesign within user-defined deviation tolerances – Accuracy Analyzer™ 

• Intelligently identify and align 3D scan data to an ideal design coordinate system – Align 
Wizard™ 

• Reduce design time by using 3D scan data as a design foundation 

• Use outputted data, with modeling history intact, in CAD, CAM and CAE 

• Modeling history and parameter management 

• Mesh, freeform surface and parametric solid hybrid modeling functions 

• Standard solid & surface modeling workflows such as extrude, round, revolve, sweep and loft 

• Update existing CAD models to reflect changes in the as-build part - CAD-to-Scan Refit 

• Seamless interoperability with full modeling history to other CAD applications 

 
 

Immediately Realize the Benefits of 3D Scanning 
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The design tools used to create models in Geomagic Design X are immediately recognizable to those 
already familiar with CAD applications. Engineers capable of designing with SolidWorks, CATIA, 
Pro/ENGINEER or Siemens NX can immediately begin modeling in Geomagic Design X. The design 
process in Geomagic Design X utilizes common CAD modeling features and processes such as 
extrude, round, revolve, sweep and loft. These features serve to make both Geomagic Design X and 
3D scanning technology readily accessible to engineers, while the ease of use of the product allows 
3D scan-based to be institutionalized within the manufacturing process to increase the overall 
quality of products. 
 

• Intelligent Design process which eliminates the need for complete scans of parts 

• Create high quality CAD models from imperfect scan data 

• Save processing time by eliminating the need for polygon mesh cleanup and surfacing 

• Models are instantly editable in both Geomagic Design X and major CAD systems 

 
 

A Comprehensive Scan-To-CAD Software Solution 

Geomagic Design X is an entirely new software solution that provides a new approach, yet with a 
familiar process, to build a parametric CAD models from 3D scan data. Geomagic Design X creates 
highly usable models for a variety of applications that include rapid prototyping, CNC machining, 
CAE and export into CAD applications for further modifications. The values of these applications are 
now available in a simple software application that is readily accessible to a wider group of people 
by utilizing the common design tools of most CAD applications.  
 

• End-to-end functional coverage – from mesh operations to CAD modeling 

• Supports every possible reverse modeling workflow – Reflect design intent (design parameter 
extraction) or Generate and exact duplicate (surface fitting) 

• Instant mesh optimization for direct use in RP, CAM, CAE and visualization 

• Highly sophisticated yet familiar modeling capabilities utilizing universal solid and surface 
modeling features 

• One-button quick B-rep surfacing or design analysis & verification applications 

• Automatic re-meshing for generating CAE functional models – Scan-to-CAE 
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1.2. Key Themes of Geomagic Design X 
 

DO MORE WITH 3D SCAN DATA 

 
Create parametric CAD models from 3D scan data 

Send full history-based models to SolidWorks and other CAD System 
Capture design intent and define design parameters 

Design parts faster using familiar CAD modeling concepts 
 
 

An Innovative Design Process 

Geomagic Design X is absolutely unique in the market. Geomagic Design X is powerful software that 
provides an innovative and unique philosophy for building CAD models from 3D scan data. It 
supports every possible reverse engineering workflow and is suited to both polygon-based and 
CAD-based applications. Geomagic Design X provides the best way to utilize 3D scanning 
technology as a “mission-critical” solution for innovation in the product design and manufacturing 
process. 
 
The design process and user interface in Geomagic Design X have been developed to be instantly 
familiar to users of popular CAD applications, leading to incredible time savings over traditional 
reverse engineering software while simultaneously creating output in the form of parametric CAD 
solid models. Time savings can be realized through: 
 

• A reduced learning curve through the use of a familiar CAD interface and design process 

• A design process that removes the time consuming requirement of cleaning the scan data of a 
part 

• A single software solution that fulfills the scan data processing, mesh healing and CAD modeling 
needs 

• A built in, real time deviation analysis tool 

 
The interface and design process of Geomagic Design X were developed to be similar to popular 
CAD applications, so users can utilize their existing CAD modeling skills to immediately begin 
designing in Geomagic Design X. Internal benchmarking tests have shown a time savings of up to 
80% when using Geomagic Design X over traditional surface fitting methods in great part because 
the design process removes the need to clean the scan data of a part. A complete scan of a part is 
unnecessary, provided there is enough data to recognize design parameters. 
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Massive Point Cloud Handling 

Geomagic Design X’s point cloud data processing has been innovated to handle massive point 
clouds. The data structures and some of the functions are optimized and enhanced for working with 
hundreds of millions of point clouds. 
 
 

Unlimited Point Cloud Capacity 
When large point clouds are imported that exceed the physical memory limitation of a 
computer, the application will automatically use a cache folder (hard disk drive) and load data 
onto it. While working with a point cloud, the application intelligently divides the point cloud 
and performs functions within the memory capacity. Therefore, almost unlimited point cloud 
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data sizes can be imported based on the storage size of the hard disk drive. 

 
 

Real-Time Visualization of Massive Point Clouds 
Geomagic Design X’s auto frame rate function selectively displays necessary points with 
adaptable density to the 3D view of current your viewpoint. By utilizing a quick rendering 
algorithm of the point cloud, you can see and operate a complex and large point cloud in an 
optimized environment. Geomagic Design X automatically changes the display frame rate 
according to the data size of the point clouds to create the best working environment without 
cutting off display functionality. 

 

To maximize the visualization of point clouds, Geomagic Design X supports three shading 
methods which help to analyze and visualize complex point clouds. 

 

Depth – The closer points are displayed in black and the farther points are display in gray in 
relation from the view direction. If you click the Set button, you can define the depth range by 
using the slider bar. If points are out of the depth range, they will disappear from the Model 
View. This can be used to focus on specific areas by removing outer areas from the depth range. 

  

None Depth 
 

X Ray – This mode shows specifically targeted areas by making areas closer and farther from 

the targeted area transparent. To define the transparent area, click the Set button. The Near 

and Far areas will be transparent and the Middle area will be clearly displayed. 

For example, if a scanner scans the inside of a building, it can be difficult to see inside because 
of the outer walls. You can use the X-Ray function to make the outer walls transparent, thus 
letting you see inside clearly. 
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X-Ray Default After Adjusting X-Ray Depth 
 

This shading method makes points transparent in a certain range. When trying to select points, 
points nearer to the viewing direction will be selected first even though they are invisible. 
Therefore, this method should be used for data viewing purposes. 

 

Height – The color of displayed points will change based on its height from the Z direction. 
Using this shading method, you can easily distinguish ground and other features. If you click 
the Set button, you can modify colors as well as height. 

   

Height Color Bar 
 

For easier inspection of scan data from long range scans such as construction fields, buildings, 
factories, etc, Geomagic Design X includes a walk-through mode. In the previous version, the 
camera (viewpoint) was always fixed and model was rotated, zoomed and panned in the Model 
View. However this new walk-through mode enables the camera to travel through and position 
the viewpoint inside of the model. 

 
 

Fully Editable Point Clouds 
Geomagic Design X supports not only the visualization of point clouds like other point cloud 
software but also includes editing and generating CAD tools for massive point clouds.  

 

Selecting points 

Selecting only desired areas with as few steps as possible is important in massive point cloud 
handling. Geomagic Design X’s selection tools, Extend To Similar and Extend To Sudden Change, 
which expands similar features from the seed point, enables the quick and easy selection of 
areas from complex point clouds. 
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Editing point cloud 

The functions under Point Cloud Tools are fully optimized for handling large point clouds. When 
generating a mesh from a point cloud, the Mesh Construction method in Triangulation and the 
Mesh Buildup Wizard has no data size limitation and the 2D/3D Triangulation methods enable 
the reduction of the data input size with the Sampling option.    

For the convenience of working with large point clouds in the application, a mesh can be 
generated with chosen selections from a point cloud. Copy and pasting the point cloud is 
possible for defining the working area and for dividing parts.  

 

Modeling from point cloud 

2D sketch entities can be generated from section polylines on point clouds or projected points 
within a defined range. Pipe modeling on the point cloud can also be done by directly picking 
seed points on the pipe feature. This Pipe Wizard is an easy and powerful function for fast 
modeling from complex point clouds with many pipe features. 

 
 

New File Format for Massive Point Clouds 
As well as new point cloud process methods, Geomagic Design X has added a new file format, 
XPC, and updated the existing format, XRL. These formats are not only optimized for minimizing 
file size, but also to include optimized data structures for massive point clouds. 

For the publication of point clouds to a website, .icf and .rps files can be reduced in file size by 
sampling the point cloud. 
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1.3. Features of Geomagic Design X 
 
New Key Features and Enhancements 

 
Align Wizard™ 

Redesign Assistant™ 
Accuracy Analyzer™ 

Hybrid Modeling – Solid, Surface & Mesh 
Best-in-class Mesh Operation 

Sophisticated Curve/Sketch Tools 
 
 

Parametric CAD Models from 3D Scan Data 

Geomagic Design X is an innovative new software solution that allows engineers to create fully 
parametric CAD solids and freeform surfaces from 3D scan data and polygon mesh data with a best-
in-class user interface. In addition to its ability to create parametric CAD solids, Geomagic Design X 
differentiates itself from existing reverse engineering software by offering a design process that 
utilizes the skill sets that engineers already possess. The end result is a software solution that requires 
minimal training, reducing the time necessary to process 3D scan data. Users are provided with high 
quality results that are unavailable through other current reverse engineering options. Geomagic 
Design X enhances the functionality of both 3D scanning technology and existing CAD applications 
by sharing common technologies and processes. Geomagic Design X features powerful tools such 
as: 
 

• Redesign Assistant 

• Accuracy Analyzer 

• True Hybrid Modeler - Solid, Surface & Mesh 

• Align Wizard 

• Best-in-class Mesh Operations  

• Sophisticated Curve/Sketch Tools 

• Scan-to-CAD Synchronization 

• Quick Mesh-to-Surface 

• Seamless Data Transfer 

• Mesh Cleanup 

 
 

Redesign Assistant 

The Redesign Assistant intelligently extracts the design intentions and design parameters 
throughout the process of generating a CAD model from 3D Scan Data through the following 
features. 
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• Unprecedented tools for extracting design parameters from 3D scan data 

• Utilizing meshes as redesign parameters 

• Automatic mesh region segmentation 

• Automatic extraction of design feature parameters from meshes 

 
Filet radius and center, sketch plane & profile (automatic sketching), sweep path curve, extrusion 
axis, mirroring plane, revolving center axis, pipe center axis, drafting angle, 3D section curve for 
lofting, feature curve, offset/thickening distance, cylinder/cone axis, slot axis, pattern axis and 
direction, silhouette-curve, parting line, bead line, etc 

• Creating sketch profiles from mesh models 

• Automatic extraction of 3D design features from mesh 

• Intelligent real-time 2D/3D geometry recognition and snapping 

 

 

Redesign Assistant™ 
 
 

Accuracy Analyzer™ 

The Accuracy Analyzer™ tool provides users with real time deviation analysis based on user defined 
tolerances to ensure that a model is within specified allowable tolerances. 
 

• Polygonal mesh deviation (comparison with original scan data and previous step model) 

• Sketch/curve/surface/solid deviation (comparison with original scan data) 

• Geometric property analysis (curvature, continuity, quality, normal vector, etc) 

• Redesign within user-defined allowable tolerances 

• Automatic and real-time error visualization 

• Diverse object sensitive analysis tools 
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Accuracy Analyzer 
 
 

True Hybrid Modeler 

Geomagic Design X is a truly comprehensive 3D scan data processing application that offers 
parametric solid modeling capabilities, NURBS surfacing capabilities, and a hybrid modeling process 
that utilizes both capabilities for the creation of parametric CAD models that contain freeform 
features. 
 

• Highly sophisticated yet familiar by utilizing widely accepted solid and surface modeling 
features 

• Solid Features: extrude, sweep, revolve, pipe, thicken, draft, round with various radii, chamfer, 
hollow (shell), linear/circular/curve pattern, Boolean modeling  

• Surface Features: drape, blend, extrude, revolve, sweep, loft, ruled, offset, mirror, fill face, extend, 
trim/untrim, match, heal 

• Modeling history management (feature rebuild, reroute & reorder) 

• Parametric feature management 

 
 

Align Wizard™ 

Geomagic Design X includes the Align Wizard™, a proprietary tool that intelligently identifies the 
coordinate system in a file that the original designer had used. The user can either choose the 
coordinate system recommended by the Align Wizard™, or manually determine the coordinate 
system that is believed to be the most appropriate for the part by using an intuitive coordinate 
system setup tool. 
 

• Wizard for aligning 3D scan data to an ideal design coordinate system 

• Highly interactive toolset for coordinate alignment 

• Quick fit, best fit, 3-2-1, Datum, By Ref. coordinates, etc 
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Align Wizard™ 
 
 

Best-in-class Mesh Operations 

Geomagic Design X produces Class-A meshes in a single step. The mesh models generated by 
Geomagic Design X can be directly used as input data for target CAE and CAM software for reverse 
engineering or manufacturing. Geomagic Design X features a powerful mesh optimization tool that 
generates a mesh from 3D scan data that meets the specific requirements for CAE. 
 

• Instant mesh optimization for direct use in RP, CAM & CAE 

• Detail resolution controls (decimate & subdivide) 

• Mesh smoothness controls (global & subdivide) 

• Automatic re-meshing for CAE functional models 

• Comprehensive interactive mesh region editing tools 

• Advanced mesh modeling & optimization 

 
Global remesh, remove, de-feature, hole filing, fix boundary, smooth boundary, fit boundary, fit 
region to analytic shape, split & trim, divide, thicken, offset are some of advanced mesh operations 
available. 
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Best-in-class Mesh Optimization 
 
 

Sophisticated Curve and Sketch Tools 

Geomagic Design X provides users with highly sophisticated curve/sketch tools so that users can 
extract sketch profiles and feature curves from mesh automatically for comprehensive reverse 
modeling. 
 

• Automatic extraction of sketch profiles and feature curves from mesh 

• Automatic dimensioning & constraining 

• Variety of 2D drafting tools 

• Comprehensive 3D curve design tools 

• Intelligent real-time geometry recognition 

• Curvature-based curve network design 

 
 

Scan-To-CAD Synchronization 

Geomagic Design X offers the best solutions to synchronize with CAD applications for parametric 
CAD modeling from 3D scan data.  
 

• Update of the original CAD model to represent the changes in the as-built part 

• The import of CAD data in a variety of CAD file formats 

• Fast and automatic CAD & mesh model coordinate alignment 

• Refitting of CAD models to mesh models 

 
 

Quick Mesh-To-Surface 

• Automatic shrink wrapped surface model generation 

• Optimized representations of original mesh data with negligible deviation errors 

• Interface mesh-fit surfacing (region & boundary fit) 

 
 

Seamless Data Transfer 

• Transfer output model with full history to CAD system 

• Export models in a variety of standard file formats 

 
 

Mesh Cleanup 
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• Automatic mesh healing & cleaning 

• Professional yet easy to use mesh cleaning & editing tools 
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2. Getting Started  
 
This section lists the system requirements to run the application and the licensing information 
software. 
 
 

2.1. System Requirement 
 

 32-bit Edition 64-bit Edition 

OS 
- Windows Vista (32-bit or 64-bit SP1 or above) 
- Windows 7 (32-bit or 64-bit) 
- Windows 8 (32-bit or 64-bit) 

- Windows Vista (64-bit SP1 or above) 
- Windows 7 (64-bit) 
- Windows 8 (64-bit) 

CPU 
- Intel® and AMD® processors. 
- Recommended: Multiple core processors. Hyper-threading and clock speeds above 3ghz 
can be beneficial but should be paired with a good balance of cores. 

RAM 

- Minimum: 1 GB 
- Recommended: 2 GB 
- Virtual Memory: 
Vista, Win7: recommended to use the default 
option; “Automatically manage paging file 
size for all drives” 

- Minimum: 2 GB 
- Recommended: 8-16 GB (Based on version 
of Windows used) 
- Virtual Memory: 
Vista, Win7: recommended to use the 
default option; "Automatically manage 
paging file size for all drives" 

Hard Disk 

- 30 GB or more recommended 
- Temporary file cache requires about 3 GB free disk space for every 100 million points 
- Recommended: a SSD with more than 256GB of space, or a 10,000RPM HDD 
- Recommended: using multiple hard drives and assigning one as a “cache” drive for 
Geomagic temporary storage and paging files and assigning the other for the operating 
system 

Display 
- OpenGL 1.2 or above, 32 bit true color required 
- Recommended 24-inch wide screen monitor, 1920X1280 resolution 

GPU - Recommended: NVidia GTX series with 1GB of RAM or more 

Certified  
Graphics 
Card 

Intel Intel G45 
Intel G645GM 
Intel G965 
Intel HD 2000/3000 

Intel Intel G45 
Intel G645GM 
Intel G965 
Intel HD 2000/3000 

AMD 
 

Rage XL 
Radeon 7500  
Radeon 9600 
Radeon 9600 XT 
Radeon X600 
Radeon X600SE 
Radeon X700 
Radeon X1650 
Radeon X1600 
Radeon X1800 GTO 
Radeon HD 2600 XT 
Radeon HD 3670M 
Radeon HD 3870 

AMD 
 

Rage XL 
Radeon X600SE 
Radeon 7500 
Radeon 9600 
Radeon X600 
Radeon X1600 
Radeon X1800 GTO 
Radeon HD 2600 XT 
Radeon HD 3870 
Radeon HD 4770 
Radeon HD 4800 1G 
Radeon HD 5700 
Radeon HG 5770 
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Radeon HD 4770 
Radeon HD 4800 1G 
Radeon HD 5700 
Radeon HG 5770 
Radeon HD 5800 
Radeon HD 6470M 
Radeon HD 6850 
Radeon HD 6870 
Radeon HD 6950 
Radeon HD 6970 
Radeon HD 7850 
Radeon HD 7770 

Radeon HD 5800 
Radeon HD 6470M 
Radeon HD 6850 
Radeon HD 6870 
Radeon HD 6950 
Radeon HD 6970 
Radeon HD 7850 
Radeon HD 7770 

AMD 
 

FireGL Z1 
FireGL V3100 
FireGL V3600 
FireGL V5600 
FireGL V7300 
FireMV V2250 
FirePro V2260 
FirePro V2450 
FirePro V3750 
FirePro V3800 
FirePro V4800 

AMD 
 

FireGL V3100 
FireGL V3600 
FireGL V5600 
FireGL V7300 
FireMV V2250 
FirePro V2260FirePro V2450 
FirePro V3750 
FirePro V3800 
FirePro V4800 

NVIDIA 
 

GeForce2 MX 100/200  
GeForce4 Ti 4400 
GeForce FX 5200 
GeForce FX 5500 
GeForce FX 5600 
GeForce FX 5600XT 
GeForce FX 5700 
GeForce FX Go 5200 
GeForce FX Go 5700 
GeForce Go 5200 
GeForce Go 7400 
GeForce Go 7600 
GeForce 6200 
GeForce 6600 
GeForce 6800 
GeForce 7600GS 
GeForce 7600GT 
GeForce 7800GTX 
GeForce 7900GS 
GeForce 640M 
GeForce 8300GS 
GeForce 8400M 
GeForce 8400GS 
GeForce 8500 
GeForce 8500GT 
GeForce 8500GTS 
GeForce 8600 
GeForce 8600GT 
GeForce 8600GS 
GeForce 8600GTS 
GeForce 8600M 
GeForce 8800GT 
GeForce 8800GTS 
GeForce 9200M 

NVIDIA 
 

GeForce2 MX 100/200 
GeForce FX Go 5200 
GeForce Go 5200 
GeForce Go 7400 
GeForce Go 7600 
GeForce 6200 
GeForce 6600 
GeForce 6800 
GeForce 7600GS 
GeForce 7600GT 
GeForce 7900GS 
GeForce 8300GS 
GeForce 8400M 
GeForce 8400GS 
GeForce 8500 
GeForce 8500GT 
GeForce 8600 
GeForce 8600GS 
GeForce 8600GT 
GeForce 8600GTS 
GeForce 640M 
GeForce 8600M 
GeForce 8800GT 
GeForce 8800GTS 
GeForce 9200M 
GeForce 9300M 
GeForce 9300GE 
GeForce 9500GT 
GeForce 9600GT 
GeForce 9800GT 
GeForce 9800GTX 
GeForce G105M 
GeForce GT 220 
GeForce GT 630 
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GeForce 9300M 
GeForce 9300GE 
GeForce 9500GT 
GeForce 9600GT 
GeForce 9800GT 
GeForce 9800GTX 
GeForce G105M 
GeForce GT 220 
GeForce GT 630 
GeForce GTS 250 
GeForce GTX 260 
GeForce GTX 285 
GeForce GTS 335M 
GeForce GT 310M 
GeForce GT 360M 
GeForce GT 425M 
GeForce GTX 485M 
GeForce GT 520M 
GeForce GT 525M 
GeForce GT 540M 
GeForce GT 550M 
GeForce GT 555M 
GeForce GT 8600M 
GeForce GS 8600M 
GeForce GTX 550TI 
GeForce GTX 560TI 
GeForce GTX 465 
GeForce  GTX 560 
GeForce GTX 570 
GeForce GTX 580 
GeForce GTX 670 
GeForce GTX 680 

GeForce GTS 250 
GeForce GTX 260 
GeForce GTX 285 
GeForce GT 310M 
GeForce GTS 335M 
GeForce GT 360M 
GeForce GT 425M 
GeForce GTX 465 
GeForce GTX 485M 
GeForce GT 520M 
GeForce GT 540M 
GeForce GT 550M 
GeForce GT 555M 
GeForce GT 8600M 
GeForce GS 8600M 
GeForce GTX 550TI 
GeForce GTX 560TI 
GeForce GTX 560 
GeForce GTX 570 
GeForce GTX 580 
GeForce GTX 670 
GeForce GTX 680 

NVIDIA 
 

Quadro NVS 120M 
Quadro NVS 135M 
Quadro NVS 140M 
Quadro FX 350M 
Quadro FX 360M 
Quadro FX 500 
Quadro FX 540 
Quadro FX 570M 
Quadro FX 580 
Quadro FX 880M 
Quadro FX Go 1400 
Quadro FX 1400 
Quadro FX 1500 
Quadro FX 3500 
Quadro FX 4500 
Quadro FX 5200 
Quadro FX 5700 
Quadro 600 
Quadro 1500 
Quadro 1800 
Quadro 2000 
Quadro 2000D 
Quadro 3000 
Quadro 3500 
Quadro 3800 
Quadro 4000 
Quadro 4500 

NVIDIA 
 

Quadro FX 350M 
Quadro FX 360M  
Quadro FX 570M 
Quadro FX 580 
Quadro FX 880M 
Quadro FX Go 1400 
Quadro FX 1400 
Quadro FX 1500 
Quadro FX 3500 
Quadro FX 4500 
Quadro FX 5200 
Quadro FX 5700 
Quadro 600 
Quadro 1500 
Quadro 1800 
Quadro 2000 
Quadro 2000D 
Quadro 3500 
Quadro 3800 
Quadro 4000 
Quadro 4500 
Quadro 3000M 
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Quadro 3000M 

- Not Recommended 
ATI Mobility Radeon 7000 IGP DDR 
ATI Radeon X800 GTO 
ATI Radeon X1600 

 

- Not Recommended 
ATI Mobility Radeon 7000 IGP 
DDR 
 

- If you use the AMD Radeon series, the panning or rotation in the application might not 
operate correctly. To solve this problem uncheck the Use Custom Settings option under 3D 
> Standard Settings in the Catalyst Control Center dialog box and move the slider to the left. 

It is recommended to set the anti-aliasing value lower than 8. Otherwise, detection of 3D 
edges may not work properly or there may be problems with panning or rotating within the 
application. If anti-aliasing is disabled, the edges and boundaries of shaded objects can be 
jagged if displayed at angles close to 0 or 90 degrees. 

Other 

- DVD drive 
- 3 button mouse with scroll wheel 
- Sound card 
- Keyboard 
- Network card 
- Internet Explorer version 7.x or higher 
- Adobe Acrobat version 5.x or higher 
- Third Party Application:  Microsoft.NET 4.0 

 
 
 

2.2. Installation 
 
1. Insert the installation DVD into the DVD-ROM drive. 
 
2. The installation program should appear automatically. If the autorun installation does not start 
automatically, browse the DVD-ROM directory and then double-click on the autorun.exe file to start 
the installation program. 
 
3. Follow the instructions provided by the installation program. 
 
4. After installation is complete, run the application. 
 
5. After activating your license, you will see a dialog box which enables you to set the initial settings 
for Geomagic Design X. 
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Enable Multi-thread – When set to True, multi-threading is utilized to speed up the calculation 
time of some functions. This is highly recommended. On a single processor, multithreading 
generally occurs by the processor switching between different process threads one at a time.  
On a multiprocessor or multi-core system, threads will process simultaneous, with each processor 
or core running a particular thread. Depending on how many cores the processor has, the same 
number of progress bars will be displayed when multithread is enabled and utilized. 
 
User Name – The PC’s name 
 
Update Product Automatically – If it is set to True, whenever you launch the program, it will 
check if there are any updates. 
 
Preferred CAD – Choose one of your CAD systems: None, SolidWorks, Siemens NX, PTC 
Creo(Pro/E), Autodesk AutoCAD or Autodesk Inventor. It is linked to View Manipulation Style and 
CAD Compatibility in the Error List. 

 
 
View Manipulation Style – You can select one of the view manipulation style (zooming, 
panning, rotating); Rapidform, SolidWorks, Siemens NX, Creo(Pro/E), CATIA, PolyWorks, or 
Geomagic. 
 
Preferred Scanner File Format –Select a scanner format that you frequently use, so that when 
you import a scanner file, you will see only the chosen format. 
 
Preferred Scanner Direct Control –You can set your favorite scanners as True so that when you 
run Insert > Scanner Direct Control > LiveScan(TM), you will see only your favorite scanners in 
the Device pull down menu. To apply this change, close and rerun the application. 
 
Unit – Select default units which will be used in the application. 
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Use Configurations Of Previous Version – When you install a new version of the application, 
you can preserve customized settings. 
 

 
 
 

2.3. What Can Geomagic Design X Do? 
 

Scan to CAD 

To make a CAD model suitable for manufacturing, Geomagic Design X employs a straightforward 
workflow that parallels today’s well-known solid modeling process. Instead of modeling from 
scratch, Geomagic Design X’s feature wizards and other automatic tools help you build the features 
directly from 3D scan data. 

 
• Align scan shots 
• Merge into single model 
 

 • Extract design intent 
• Build CAD model 
• Confirm accuracy 

Transfer to your CAD 
software as a native 
model 

 
 

Scan to Surface 

Geomagic Design X also supports NURBS surface fitting, for when you need a verbatim copy of what 
you’ve scanned, and don’t need to edit it later on. Geomagic’s powerful automatic surfacing 
technology can do all the work, or the surface network can be created manually. 

 
• Align scan shots 
• Merge into single 
model 
 

• Smooth 
• Fill holes 
• Optimize/reduce size 

• Autosurfacing 
• Interactive surfacing 

Save as IGES, STEP or 
other surface format for 
non-parametric use 

 
 

Scan to Mesh 
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For archiving, animation, measurement, 3D printing and other polygon-based applications, 
Geomagic Design X includes a full suite of mesh processing tools. With the Mesh Buildup Wizard™, 
you can step through the entire scan alignment, merge and mesh optimization process with just a 
few clicks. 

 
• Align scan shots 
• Merge into single 
model 
 

• Smooth 
• Fill holes 
• Optimize/reduce size 

• Autosurfacing 
• Interactive surfacing 

Save as IGES, STEP or 
other surface format for 
non-parametric use 

 
 
 

2.4. Basic Entity Terminology 
 
The application handles many different types of entities ranging from scan data to CAD data. Entities 
can be an end result of modeling, or the by-products of a final model. This chapter explains what 
kinds of entities are used in the application, and its terminology definitions. 
 
 

Point Cloud 

A set of 3D points represents a real part or environment. Each point represents a digitized point on 
the object or in the environment, and collectively describes its shape and measurements. It usually 
comes from a 3D scanner or a coordinate measuring machine (CMM). A point cloud can be built up 
as a mesh in software by generating triangles between points, a process known as triangulation. 
Point clouds are used for the visualization of real parts or environments in reverse engineering to 
make a CAD model. 
 
A point cloud may or may not have normal information, depending on the scanner and scanning 
type. Even if a point cloud does not have normal information, it can be generated within the 
application after importing the data. 

 
Point cloud data from a real bottle 
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Mesh 

A mesh is a polygonal model that represents a physical object. A mesh consists of many triangles 
which connected and can be generated from a point cloud or CAD data. 
A scanned part usually consists of several scans from different directions, which necessitates 
alignment of the scans by overlapping and aligning common areas in software. Once aligned, 
several meshes can be converted into a single mesh by merging. When merging multiple scans, 
overlapping areas will be removed. 
 

 
Mesh from a point cloud of a real bottle 

 
In the application, the following terminologies are used to separate similar entities between a mesh 
and a body. 
 

• Poly-Face: Triangles enveloped by three poly-edges. 

• Poly-Edge: Connecting edge between two poly-vertices. 

• Poly-Vertex: A point which represents a position in 3D space. 

• Boundary: Any opening in the mesh, where there are no triangles. 

 
Terminology of mesh 

 
 

Region Group 

Region segmentation is a way to group sets of poly-faces that belong to one feature. Regions assist 
in the alignment of the mesh data to the global coordinate system and in selecting a region of 
interest for extracting the design intent, and converting it to a surface. 
 
Regions can be automatically generated by analyzing curvature on the mesh. Afterwards regions 
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can then be modified manually if needed. 

 
Classified regions from a mesh 

 
 

Ref. Geometry 

Reference geometries are used in the assistance of creating other features. These include basic 
geometric entities, such as planes, vectors, coordinates, points, and polygons. 

 

A Plane, vector and polyline from a mesh 
 
There are various types of ref. geometries that can be created. They include: 
 

• Ref. Plane 

• Ref. Vector 

• Ref. Coordinate 

• Ref. Polyline 

• Ref. Point 

 
 

Sketch and Mesh Sketch 
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Most features start from generating a sketch. Sketch entities are drawn on a plane known as the base 
plane. The base plane can be a ref. plane, a planar body face or a planar region. 
There are two kinds of sketches in the application. One is a Sketch and the other is a Mesh Sketch. A 
Sketch is used for freely drawing on a base plane in a similar fashion to other CAD software. A Mesh 
Sketch is used for drawing sketch entities onto section polylines by fitting lines, arcs, and splines 
onto selected polylines. 

 

Sketch entities from a mesh 
 
When a Mesh Sketch is generated, a suffix "(Mesh)" will be added to the end of the sketch entity's 
name in the Feature Tree and the Model Tree. For example see: Sketch1 (Mesh), Sketch2 (Mesh), 
Sketch3 (Mesh), etc. 
 

 
 
 

Section Polyline 

When a Mesh Sketch is used, the base plane is used to extract a sectional profile from the mesh or 
point cloud, the section polyline. Section Polylines are made from several small line segments, where 
the section would intersect a triangle; the resolution of the polyline is dependent on the quality of 
the mesh or point cloud. The application can automatically determine what areas of the polyline 
should be lines and arcs, and users can control the resolution by using the Segment Section 
Polyline option in the tool palette of Mesh Sketch. 
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Section polyline from a mesh 
 
 

Loop 

A loop is an area closed by lines or arcs on the sketch. Loops can be used for generating a closed 
solid body. If several loops exist on a sketch, a single loop or multiple loops can be selected for solid 
body generation. 

 
 
The following example shows various solid extrusion features generated from multiple loops on a 
sketch. 

   

 
 
 

Chain 

A chain is a group of sketch entities forming a boundary or shape. A chain can be either a closed or 
opened boundary. Chains can be used for generating surface bodies. If several chains exist on a 
sketch, a single chain or multiple chains can be used to generate a surface body. 

 
 
The following example shows various surface extrusion features generated from multiple chains on 
a sketch. 
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3D Sketch 

 
3D Sketch uses spline curves which can be drawn anywhere (3D Sketch) in 3D space or drawn 
directly on a mesh (Mesh 3D Sketch). 3D Sketch is commonly used for the path of a loft or sweep 
body. 3D Mesh Sketch is mainly used for generating a curve network on a mesh. Then surfaces can 
be generated within the network boundaries. 

 

Curve network by using 3D mesh 
sketch 

 
If you generate a Mesh 3D Sketch, a suffix "(Mesh)" will be added to the end of the 3D sketch entity's 
name in the Feature Tree and the Model Tree. For example, 3D Sketch1 (Mesh), 3D Sketch2 (Mesh), 
3D Sketch3 (Mesh), etc. 

 
 
 

Surface Body 

A body that represents a part with a set of opened surfaces, with no volume. A surface body is usually 
used to represent a complex shape. Surface bodies can be made with two kinds of surfaces. The first 
is a parametric surface which can be generated by using the extrude, loft, sweep, or revolve 
commands. The second is a fitting surface which fits directly to a mesh by using the mesh fit, 
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boundary fit, or auto surfacing commands. The fitting surface is used for making freeform shapes 
which are not parametric features, such as an organic natural object. 

 

 
 

 

 
 

 

Parametric Surface Bodies Surface Bodies Generated Using 
Boundary Fitting 

Surface Bodies Generated Using 
Auto Surfacing 

 
 

Solid Body 

 
A body that represents a part with a set of closed surfaces, enclosing a volume. A solid body is usually 
used to represent a combination of simple base features. In the application, bodies made by using 
commands in the Insert > Solid menu are registered as solid bodies. 

 
Solid body 

 
The following terminologies are used for a solid body and a surface body. 
 

• Face: A single, contiguous shape. 

• Edge: Defines the boundary of a face. 

• Vertex: The Points at a corner of a face. 
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Terminology of a solid body 

 
 
 

2.5. Introduction to the Interface 
 
This guide is designed to help beginners understand the basic and essential usage of the user 
interface of Geomagic Design X. 
 
 
 

2.5.1. User Interface Overview 
 
The user interface of Geomagic is designed to be easy to learn and use because it functions similarly 
to other CAD software. It uses familiar tools for modeling with the addition of other unique tools for 
an efficient and confidence-inspiring modeling process. 

 
 
 
The following images shows elements which are frequently used in the application. 
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Menu Bar 

All functions in the application are contained in the menu bar. 
 

 
 

Tool Palette 

The application features different modes that allows for the generation and editing of entities with 
only the appropriate functions displayed. Multiple modes are featured because the application can 
handle and manipulate many different types of entities that normal CAD programs cannot.  To 
simplify and streamline the process there are different modes that can be used to handle the types 
of entities that are being worked with. 

 
 
For more detail, see the chapter User Interface > Mode. 
 
 

Toolbar 

A group of icons is called a toolbar. When icons are dimmed, they will not be available. 

 
 
Toolbars can be customized by selecting Customize... in the menu that appears when the toolbar 
area is right-clicked. 

 

 
 
 
 

 

Opening Customize Customized toolbar 
 
 

Feature Tree 

Geomagic uses a method known as parametric history modeling. Parametric history modeling 
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allows the creation of objects by storing the operations used to construct the geometry, as well as 
the order of the operations and their relationships to each other. 

 
 
 
Whenever a feature such as a sketch, solid body, surface body, etc., is generated, it will be stacked in 
the Feature Tree in chronological order. The Feature Tree shows all changes and created entities in 
chronological order as well as the history for each change or creation. The order of features can be 
altered by dragging and dropping features. It is also possible to go back to a certain point in the 
modeling history by using the Rollback, Roll Forward, Roll To End commands. This type of modeling 
is known as history modeling. 

 
Changing the feature history by dragging and 

dropping 
 
 

Model Tree 

The Model Tree shows all created entities by categories. This pane can be used for selecting and 
controlling the visibility of an entity. 
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Clicking the  show / hide icon next to an entity will toggle between showing and hiding the entity. 
If a parent entity is hidden, its child entities will also not be displayed even if they are toggled to be 
shown. 

 

Hiding the 3D Sketch1 entity 
 
 

Display, Help, Viewpoint 

Display, Help, and Viewpoint are located in the same window as Feature and Model Tree. Navigate 
between using the tabs at the bottom. 

 
 

Display – The Display pane is used to manage how entities are displayed. For example, a model 
can be set to be transparent or brightly lit. Textures, normals, faces, boundaries, etc., can be 
shown or hidden as well. 
 
Help – The Help pane shows the table of contents of the user guide. It can be navigated through 
by selecting a title on the table of contents in the Help pane or by pressing the F1 key when a 
command dialog tree is floating on the Model View. 
 
Viewpoint – The Viewpoint pane can save the view states that are currently being used. It works 
much like taking a picture. If a viewpoint is taken, the visible state entities and viewing direction 
are saved. 

 
 

Selection Toolbar 

When poly-faces and poly-vertices are to be selected, the application offers various selection 
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methods to use. For example, poly-faces can be chosen by dragging a line, circle, or rectangle. 
Painting the desired area on the mesh is also possible, and can be expanded to connect all poly-
faces. The selection method can be changed in this toolbar. 

 
 
 

Accuracy Analyzer(TM) 

The Accuracy Analyzer™ pane is very useful for checking the quality of bodies, meshes and sketches. 
After a surface body is created, deviation between the scan data and the generated body can be 
immediately checked. The Accuracy Analyzer™ is available in default mode, Mesh mode and all 2D / 
3D Sketch modes. 

 
 

 

In this image the deviation of created bodies to 
the original mesh is shown. The green color is 
the desired user-defined ideal deviation and 
the red and blue colors are deviations outside 
of the desired range. 

 
 

Properties 

After an entity is selected, its properties can be viewed and changed. For example, after a mesh is 
selected, its bounding box size can be checked in the Properties pane. The mesh color can be 
changed as you desired. 
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2.5.2. Understanding User Interface Philosophy 
The following chapters introduce general rules when you use the application. 
 
 

Dialog Tree Convention  
 

How to use a Dialog Tree 

 

Selecting Entities to Actively Control 

If a command is executed, a dialog tree will appear in the Model view. Some dialog trees require the 
user to select entities for various fields in order to proceed. The active control is a box highlighted in 
a yellow color by default. It indicates that the currently selected control is ready for the selection of 
entities. When an entity is selected the name will be registered under the active control. To select 
entities for another control, just click the desired control box to make it active. 

  
 
Below are examples of what a user might typically see in a dialog tree. Each command or tool has its 
own set of options in its dialog tree so the images are used as a general guideline on the layout and 
different functions a user might see. 
 

 
The name of the command will be at the top of the 
dialog tree. In this example there are multiple stages 
and the first two buttons are the Previous Stage and 
Next Stage buttons that will go forward and 
backward through stages. The next two buttons are 
the OK and Cancel buttons to apply the command 
or exit out of it. 

 
This second example shows a command that has 
two more useful buttons. The first is the Lock 
button. It is used when there are multiple changes 
that need to be made using the same tool. With this 
button pressed, the OK button will not quit the 
command, but instead restart the command again. 
The button with the magnifying glass is the Preview 
button which allows the user to preview changes 
made to a model in real-time without actually 
applying the changes. 
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This shows what stage a command or tool is in. A 
command must have more than one stage for this 
type of dialogue box to appear. The first button is the 
OK button which applies changes made in the 
current stage without exiting the entire command, 
and the second button is the Undo button which 
will deselect the last selection made. 

 

Some options will have selection buttons that allow 
selection for different parameters. This example has 
two selectable parameters, but commands will vary 
in how many they might have. 

 

Option check boxes toggle different parameters on 
or off. 

 

Radio buttons are used in a dialog tree to select an 
option. Only one radio button can be chosen at a 
time. 

 

This is a selection area. The input box is used to make 
a selection in the viewing area. In this example an 
entity labeled "teeth" has been selected. There are 
two buttons next to the input box. The first is the 
Select None button will delete all selected entities 
and the second button is the Undo button which 
will deselect the last chosen entity. 

 
 

Dialog Tree Controls 

The dialog tree is designed intuitively allow you complete a task; through the use of common tools. 
All tools have icons; the icons are only shown if needed in a specific dialog. The following icons can 
be found in the dialog tree. 
 

 Lock(Don’t Quit Command With OK) – If this icon is toggled the dialog tree will remain open 
even if the OK icon for the command is selected. It is designed for commands that are 
consecutively applied several times in a row. 
 

 Break – If an operation is executing, it can be stopped by using this button. The keyboard 
shortcut is the Esc key. 
 

 Delete Selected Entities – This button will remove chosen entities. 
 

 Preview – If this button is clicked, the result of the command will be displayed without 
executing it. 
 

 Enable Realtime Preview – If this button is toggled, the results of the command will be 
displayed in real-time, whenever an input condition is changed. 
 

 

Measure Distance, Radius, and Angle – After clicking these icons, points on the model can 
be picked to extract distance, radius, and angle, respectively. The measured value is directly 
inputted into the text or spin box. 
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 Estimate – If selected, the application will automatically recommend an appropriate value. 
 

 Flip Direction – This button reverses the direction of a control. 
 

 Add – This button adds an additional entity set. 
 

 All – This button selects all entities which are available. 
 

 Auto – Some text boxes have the value of Auto. If the value is set as Auto, the application will 
estimate and use an appropriate value by analyzing the size of meshes and poly-faces. If the 

 estimate button is selected, the estimated value can be seen. A numerical value can be 
used instead of Auto. To reset to the Auto value, enter “0” as a numerical value. 

 
 
 

Selection Convention  
 

How to Select Entities 

 

Look at the Cursor Icon 

In the Model View, the mouse cursor has two modes. One is for the selection mode , and the other 

is for the viewing mode . These can be switched by clicking the middle mouse button. Entities 
can only be selected when the mouse curse is in the selection mode. 
 
 

How to select entities 

Dragging Selection – Clicking then dragging can be used to select a single entity or multiple 
entities. 
 
Picking Selection – A single entity can be chosen by single clicking on it. 
 
From Feature, Model Tree – An entity or entities can be selected directly from the Feature Tree 
or Model Tree. 
 
Selecting Multiple Entities – Multiple entities can be chosen by using the Shift key during 
selection. To de-select entities, use the Ctrl key. 

 
 

Using Select Modes 

To select a specific area to edit (or remove) poly-faces or poly-vertices can be difficult because the 
mesh can be complicated and can consist of thousands or millions of vertices and faces. The Select 
Mode tool bar located at the bottom left of the application enables the selection of poly-faces and 
poly-vertices in a variety of ways. This tool bar can accelerate working speed while managing mesh 
or point cloud data. 

 
 
The last icon on the toolbar is the  Visible Only selection mode that allows for only the selection 
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of visible poly-faces and poly-vertices in the model view. It is useful for avoiding the selection of 
back-side poly-faces and poly-vertices. 
 
 

Using the Select Filter 

The application can create and manipulate various types of entities. For example, the application 
can utilize and create meshes, regions, bodies, faces, edges, sketches, dimensions, etc. The Select 
Filter command enables the selection of only desired entities and intelligently works within a 
command or a chosen mode. For example, if the Smooth command is executed, only the Regions, 
Poly-Faces and Poly-Vertices filters will be offered in the Select Filter toolbar based on the selectable 
entities for the current input condition.  

 
 
Filters can also be directly accessed by clicking the right mouse button in the Model View. 

 
 
 
 

Mode Convention 
 

Understanding Mode Convention 

 

Accept and Cancel a Mode 

When a mode is entered, two buttons will be shown in the right bottom corner of the Model view. 
 

 Accept – This button applies all changes made in the current mode, and then exits the mode. 
 

 Cancel – This button cancels all changes made in the current mode, and then exits the mode. 

 
 

Undo and Redo 

Undo can be applied step-by-step in a mode but if the mode is exited, the undo history will be reset. 
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Docking Bar Convention  
 

Docking Bars 

Docking bars are located at the left, right, and bottom sides of the application. Docking bars are 
used to hide frequently used windows to make more room for the model view or if a user desires to 
simply make the look of the program cleaner and more organized. These docking bars can be 
repositioned by dragging and dropping a docking bar into that particular space or into another 
docking area. There are icons that can be located on the right top side of a docking bar. 
 

 Auto Hide – This button hides the docking bar to the side frame. If the cursor is hovered over 
the name of a docking bar, it will automatically re-appear. 
 

   

 Close – This button closes the docking bar. To show the docking bar again, click the right 
mouse button on any tool bar area, and then check the desired docking bar. 
 

 

 
To hide all current docking bars, press the F12 key, which will maximize the Model View. It is a toggle 
function, so if the F12 key is pressed again, all hidden docking bars will appear. 
 
 
 

2.5.3. Navigating Entities 
 

Rotate, Zoom, and Pan 

In the Model View, the mouse cursor has two modes. One is selection mode and the other is viewing 
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mode. These modes can be switched by clicking the middle mouse button. Entities can only be 
selected when the mouse curse is in selection mode. The Rotate, Zoom, and Pan functions will be 
explained below for each mode. 
 

 In Selection Mode 

Rotate – Right mouse button 
Zoom – Shift + Right mouse button (or scroll wheel) 
Pan – Ctrl + Right mouse button (or Left and Right mouse buttons together) 

 In Viewing Mode 

Rotate – Left mouse button (or Right mouse button) 
Zoom – Shift + Left or Right mouse button (or scroll wheel) 
Pan – Ctrl + Left or Right mouse button (or Left and Right mouse buttons together) 

 

Note:  

The cursor operates similarly in viewing mode as it does in selection mode, except it does not 
have the ability to select or make changes to any entities. The purpose of viewing mode is to 
simply view the model; and avoid making any selections, or unwanted alterations. 

 
In the images below a model is shown being rotated with the cursor in selection mode. 
 

1 

 

In this image, the mouse is in selection 
mode. Entities can be selected and 
modified.  

2 

 

In this image, the right mouse button is 
pressed and held down, while the mouse 
is moved; transforming the cursor into the 
rotate mode cursor.  

3 

 

In this image, the right mouse button has 
been released, stopping the rotation of the 
model, and returning the mouse cursor 
back to its default selection state.  

 
 

Using Zoom Functions 

The Zoom functions are used to enlarge the display of an area, in order to examine it more closely 
or to fit a model to the screen. There are four types of zoom functions which can be accessed from 
the tool bar, or by using the View > Zoom menu. 
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In the first image below, the model is open in the viewing area. In the second image the PIP zoom 
function has been selected, as highlighted in red, allowing a portion of the model to be enlarged for 
examination. 
 

  
 
Below are the different Zoom commands and their functions: 

Zoom Area – Zooms to a selected area. (Shift + Z) 

Zoom Previous – Returns to previous zoom states. (Shift + X)  

Zoom Fit – Zooms to fit all shown entities. (Ctrl + F)  

Zoom PIP – Shows zoom window, picture-in-picture. (Ctrl + W)  
 
 

Changing Viewpoints 

Viewpoint functions are used to view the model from defined directions, based on the global 
coordinate system. Different viewpoints can be selected from the tool bar, or by using the View > 
Viewpoint menu. 

 
 
In the first image below, a model is shown in a random view orientation. Using the selected 
viewpoint, highlighted in red in the second image, the model view is rotated and perfectly aligned 
to the Front view, based on the global coordinate system. 

  
 
Below are the different viewpoints and their functions: 

Front Viewpoint – Changes viewpoint to the front view. (Alt + 1) 

 
Back Viewpoint – Changes viewpoint to the back view. (Alt + 2) 
 
Left Viewpoint – Changes viewpoint to the left view. (Alt + 3) 
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Right Viewpoint – Changes viewpoint to the right view. (Alt + 4) 
 
Top Viewpoint – Changes viewpoint to the top view. (Alt + 5) 
 
Bottom Viewpoint – Changes viewpoint to the back view. (Alt + 6) 
 
Isometric Viewpoint – Changes viewpoint to a standard isometric view. (Alt + 7) 
 
Rotate Viewpoint CCW – Rotates the viewpoint counterclockwise by a quarter-turn (90 
degrees). 
 
Rotate Viewpoint CW – Rotates the viewpoint clockwise by a quarter-turn (90 degrees). 
 
Flip Viewpoint – Flips the viewpoint horizontally along the vertical axis. 

 
 

Showing and Hiding Entities 

The application can handle many types of entities; but sometimes the need to filter out certain 
entities is required. The Visibility toolbar can show and hide the most frequently used entities, to 
reduce the number of on-screen elements. Entities can quickly be shown or hidden by clicking icons 
in the tool bar or by using the View > Visibility menu. 

 
 
In the first image below, only surface bodies are shown by the Visibility toolbar. In the second picture, 
meshes have also been shown.  

  
 
Below are the different visibility options and their functions: 

Meshes – Show or hide meshes. (Ctrl + 1) 

 
Point Clouds – Show or hide point clouds. (Ctrl + 3) 
 
Surface Bodies – Show or hide surface bodies. (Ctrl + 4) 
 
Solid Bodies – Show or hide solid bodies. (Ctrl + 5) 
 
Sketches – Show or hide sketches. (Ctrl + 6) 
 
3D Sketches – Show or hide 3D sketches. (Ctrl + 7) 
 
Ref. Points – Show or hide Ref. points. (Ctrl + 8) 
 
Ref. Vectors – Show or hide Ref. vectors. (Ctrl + 9) 
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Ref. Planes – Show or hide Ref. planes. (Ctrl + 0) 
 
Ref. Polylines – Show or hide Ref. polylines. 
 
Ref. Coordinates – Show or hide Ref. coordinates. 
 
Measurements – Show or hide Measurements. 
 

 
 
 

2.6. Data Processing 
 
This guide is designed to help beginners understand how to import and export data; and basic 
workflow from scan data to CAD data, which will be your final destination. 
 
 
 

2.6.1. Changing Units 
 
When installing the software, the default measurement unit will be set to "mm" when measuring in 
the software and importing scan data. If the working environment uses a different measurement 
unit than "mm", the unit type can be changed in the application.   
 
 

Setting Unit Type After Software Installation 

When running the application for the first time after installation, the Initial Setup Dialog box will 
be displayed which will enable the setup of general configurations. Unit system measurements can 
be changed under the Unit category in the dialog box. The Default Input (Scanner) Unit option is 
applied only when importing scan data but Default Measure Unit governs all measurement and 
display units shown while using the application.  
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Setting Unit Type While Using the Application 

This Initial Setup Dialog box will only be shown once during the initial start up, but you can change 
settings at anytime while the application is running. Go to File > Preferences and click the General 
tab. System units can be changed under the Unit category. 

 
 

Note:  

The software environment can be setup in the Preferences box for better performance and 
ease of use. For more detail see File > Preferences. 

 
 

Setting Unit Type While Importing Scan Data 

Scan data is usually stored in files as unit-less data, meaning no unit is specified, unlike CAD files. 
Most scanners can only capture data in either millimeters (mm) or meters (m). If your scanner 
supports measurement in another unit, you can set that unit globally from the Preferences. 
Otherwise, you can change the unit in the Import dialog box for files on a case by case basis. 

 
 
If an imported scan data part is very small or large, it could cause problems while generating features 
based on the mesh. If this occurs, the application will show the ‘Confirm Input (Scanner) Unit’ dialog 
box to verify the input measurement unit of the scan data. Normally long range scan data is very 
large in size and located very far from the global origin. If this type of file is to be imported, it is 
recommended to import the scan data with the Double Precision option to preserve the accuracy 
of the scan data. 
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Note:  

After scan data is imported you can also change the default measurement unit type. Go to Tools 
> Scan Tools > Transform Scan Data and check the Scale option to change the scan data 
default measurement unit. 

 
 
 

2.6.2. Importing Scan Data 
 

Settings for Favorite File Format 

The first step of mesh modeling and reverse engineering is to import scan data. The application 
supports not only standard mesh formats, but also various scan data formats from multiple scanner 
types and manufacturers. 
When scan data is imported, many kinds of file formats are available in the drop-down list box. If a 
scanner format is not frequently used it can be removed from the drop-down list box by setting the 
value to False in the File I/O tab in File > Preferences. Values can be changed between True and 
False at any time. 

 
 

Note:  

Some OEM products have limitations on importing other scan data formats. 

 
 

Importing Scan Data 
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To import scan data, use the Insert > Import command. The Insert menu adds features in the 
Feature Tree, and constructs a history. Importing scan data is also treated as a feature in the history 
tree.  
Single or multiple scan data files can be imported through the Import dialog box. 

 
 
 

Using Importing Options 

Certain parameters can be set during the import process. If importing mesh data as point data is 
desired, check the Use Custom Setting and the Point Only options in the Import dialog box. If a 
scan data file is very large in point density and importing it as a lower is desired, the Sampling Ratio 
option can be used. 

 
 
The following image shows imported scan data in the application. 

 
 
After importing scan data, the following workflows can be used: 
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• Basic Scan Data Processing Workflow: Generate, edit, and enhance a mesh for FEM, RP, and 
visualization. 

• Basic Reverse Modeling Workflow: Generate surface or solid bodies for reverse engineering. 

 
 
 

2.6.3. Basic Scan Data Processing Workflow 

 
 

Note:  

1. If a mesh is imported, the "Triangulation" stage can be skipped. 

2. The "Align" stage can use not only meshes, but also point clouds (for best results, mesh data 
is recommended). 

3. The "Merge" stage can only be used with point clouds, however a mesh will be generated. 

The "Triangulation" to "Optimization" commands can be completed in a single command by 
using the Mesh Buildup Wizard. (See. Tools > Scan Tools > Mesh Buildup Wizard)  

 
 

Import 

Imports scan data. The scan data can be point clouds or meshes. 
Related command: Insert > Import 
 
 

Triangulation 

Generate a polygon model by connecting neighboring points in a point cloud. The result is called a 
mesh. If scan data is already in mesh form, this stage not necessary. 
Related command: Tools > Scan Tools > Triangulate 
 
 

Align 

Align scan shots to each other, by overlapping the common. 
Related command: Tools > Scan Tools > Align Between Scan Data 
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Merge 

Uses the overlapped scan shots from the align stage and removes overlapped areas while sewing 
the remaining areas to create a single mesh. 
Related command:  Tools > Scan Tools > Merge 
 
 

Optimization 

A mesh can be modified to a desired level of optimization. Erroneous triangles and holes on a mesh 
can be removed to make a water-tight mesh and the shape of the triangles can be optimized by 
unifying them. As well, the number of triangles can be reduced or increased. A mesh also can be 
reconstructed by cutting, offsetting, re-scanning, etc.  
Related command: Tools > Mesh Tools 
 
 

CAD (Reverse Design) 

When a user desires to make a complete mesh, this stage is not necessary. However if CAD data is 
the goal, there are two methods. The first is to make a fitting surface by wrapping surfaces on a mesh. 
With this method the quality of a surface is directly related to the quality of the mesh. The second 
method is parametric CAD modeling. By extracting design intent from the features on a mesh, ideal 
solid or surface bodies can be created. With this method, the quality of the mesh is not critical but it 
needs enough details to analyze a feature. 
Related command: 

• Fitting Surface Generation: Insert > Surface > Mesh Fit, Boundary Fit, Auto Surfacing 

• Parametric CAD Generation: Insert > Solid, Surface, Modeling Wizard, Modeling Feature 

 
 
 

2.6.4. Basic Reverse Design Workflow 
 
General product design follows several processes, usually separated by job discipline. Reverse 
Design, however, is much more linear. After the scanning process, to capture the shape of a part, the 
modeling process can begin. The modeling process can be divided into three processes, Extracting 
Design Intent, Reverse Modeling, and Model Verification. Model Verification is used to check in-
progress work, and the cycle repeats often, created a closed loop system. 

 

 
Reverse Design Process 
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Extracting Design Intent Process 

Design Intent is the original idea of the designer, how he intended something to work. The best 
results are achieved by uncovering and using that Design Intent in the mode. See the examples in 
the image below. 
Any design elements extracted from the scan data will be helpful in completing the modeling 
process. For example, if a scanned 3D object has cylindrical or conical features, a rotational axis can 
be automatically or semi-automatically be extracted. A central path from a scanned pipe shape can 
also be extracted, as well as an accurate radius value from a fillet region in a scanned 3D object. 

 

Extracting design elements from 3D Scan Data 
 
 

Reverse Modeling Process 

The Reverse Modeling process is the process of creating an optimal 3D model from 3D scan data 
(Point Cloud or Mesh), that is generated during the Scan Data Processing phase. This process is the 
core of Reverse Design, where optimized mesh and 3D features, such as 3D curves, 3D surfaces, and 
3D solid bodies, are created by using various modeling methods. 
 
The Mesh Modeling method creates an optimized mesh that contains important information by 
applying various geometric and mathematical operations. 
The Feature Modeling method creates 3D geometric feature shapes based on extracted design 
intent and elements from 3D scan data 
The Fitting Surface Modeling method creates fitted freeform surfaces on complex freeform feature 
shapes. 
The Hybrid Modeling method creates a complex feature model from 3D scan data by using the 
Feature Modeling method in conjunction with the Fitting Surface Modeling method. 
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Various modeling methods based on Reverse Design intents 
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Model Verification Process 

The Model Verification process is the process of analyzing intermediate and final modes with raw 3D 
scan data and verifying the results, as shown in the image below. 
In this process, the analysis of deviation between the intermediate and final results created in the 
Reverse Modeling process and raw 3D scan data can be performed. Additionally, the model can be 
check for problems or defects that would make it undesirable for manufacturing. The analyzed 
results can be used for creating an optimal 3D model within allowable design tolerances. 

 

Model Verification 
 
 
 

2.6.5. Exporting a Model 
 

Export 

Data can be exported out of the application in a variety of formats. Many multi-platform formats are 
offered, as well as some program-specific formats. Exporting can be done through the File > Export 
command or pop-up menu on the Model Tree to save the entity as a specific file format, ready for 
manipulation in another program. 

 
 
 

LiveTransfer 

The File > LiveTransfer command which is a unique Geomagic function that allows the real-time 
transfer of data into other CAD applications. You can export not only CAD data but also its modeling 
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history which includes paramedic information.  
 
The following CAD application is supported under the LiveTransfer command. 
SolidWorks 
Siemens NX 
Creo (Pro/E) 
AutoCAD 
Inventor 
 
 
 

3. Understanding Scan Data 
 
This guide is designed to help beginners understand the basic information about the characteristics 
of scan data when deal with in the application. 
 
 
 

3.1. Why 3D Scanning? 
 
3D scanning is getting popular in various fields, and its usage is different for each purpose. This 
means that there are different kinds of scan data, and many details to understand. This guide will 
give basic information of 3D scan data for you to understand. 
 
 
 

3.1.1. Power of 3D Scan Data 
 
A 3D scanner is a device that captures a real object or environment as 3D shape data. The collected 
3D information is converted into digital data commonly called 3D scan data or scan data. 3D scan 
data is a set of points. A point represents a location on a real object and contains the X, Y, and Z 
coordinates. Numerous points can be used to describe a real object. For example, a digital photo 
with a high resolution pixel count can represent the detailed shape of a real object. 

 

3D scan data by resolution 
 
A point set, also known as a point cloud, can be converted into an informative digital model with 
software operations and used in various industrial fields. 3D scan data has the following strengths: 
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Quickly create digital versions of real objects 
Accuracy 
Capture complex freeform surfaces 
Capture small to large scale objects (depending on 3D 
scanner) 
Obtain color information (depending on 3D scanner) 
Simulate environments and situations 
Change to different scales and measurements easily 
Easily extract length, height, width, volume and position data 
Extract sectional information 
Compatibility in a general PC environment 
 

 
 
 

3.1.2. Applications of 3D Scan Data 
 
Since 3D scan data can represent a real object with high accuracy, it is used for various purposes. 
The use of scan data is also increasingly expanding to custom markets as scan technology becomes 
easier to use and more intuitive. Currently, 3D scan data is used primarily for the following purposes: 
 
 

3D Printing, Rapid Prototyping (RP) 

The technology of 3D Printing or Rapid Prototyping (RP) can create a quick physical mockup of 
digital 3D data (generally .stl data is used) by laying down successive layers of material using 
sectional information of a model. Using RP, product designers can make a mockup faster than with 
other conventional manufacturing technologies, such as NC machining. A mockup can be used to 
analyze a part, check collisions with other parts, decide ergonomic designs, and reduce design 
iterations; amongst other uses. 
 
 

Reverse Design 

The process of making CAD data from a real object is called reverse designing. A real-world model is 
not ideal to use in designing CAD environment, because it can be deformed by heat, stress and 
abrasion, causing the 3D scan data of that model to also include those deformities. Depending on 
the purpose, the decision to make a CAD file with an objects deformed shape, or redesigning it by 
extracting design intent is important to consider. 
 
 

Measurement and Inspection 

3D scan data is increasingly used for metrology or inspection. The more accurate points that are used 
to measure a feature will increase the credibility of an inspection. The scan data of a manufactured 
part can be aligned with its CAD model (nominal data), and subsequently compared to check for 
differences and whether or not they pass/fail within set tolerances. 
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Medical 

3D scan data is used in the medical field to make customized teeth, organs, and other vital parts for 
a patient. For example, a 3D scanner can scan a patient's dental features and generate a digital model, 
in order to create a treatment and to simulate tooth movement. 3D scanners are changing the 
traditional dental treatment methods used to generate dental impressions and handmade artificial 
teeth. 
 
 

Cultural Heritage 

The cultural heritage domain also uses cutting-edge 3D scanning technology. 3D scanners can 
generate accurate 3D files which can be used to restore historic buildings and objects. 3D scan data 
is also used to simulate or visualize historic places. 
 
 

Entertainment 

The entertainment and video game industry also uses 3D scanners to reduce modeling time and 
make more realistic 3D graphics. Scanning a real object or a human is much faster than modeling 
them in 3D graphics software by hand. 
 
 

Survey 

Traditionally, the construction and civil engineering fields relied heavily on surveying, but it took too 
much time and the workers would be exposed to the environment being surveyed. Even using these 
methods there was often a lack of information, which caused delays in schedules and generated 
additional costs. 3D scan technology is now used in these types of projects by removing uncertainty, 
finishing the project quickly, and reducing costs. 
 
 
 

3.1.3. Is 3D Scanning the Only Step in Creating a CAD-
Ready File? 

 
When a user has never experienced 3D scanning before they might think that after scanning an 
object, a CAD-ready data file will be generated instantly. The truth is that CAD systems cannot handle 
millions or even thousands of data points. This might confuse a first-time user because 3D scan data 
is displayed in 3D on a PC; however, 3D scanning is not the end of the design process to create a 
CAD-ready file, but just the first step. 3D scan data is merely raw information with a large number of 
points pertaining to the surface of an object, and usually not directly usable without further 
intervention. 3D scan data usually needs to be processed to be useful and can be done in scan data 
processing software, such as Geomagic Design X. This type of software is necessary to quickly and 
accurately get a high quality mesh or CAD model. Geomagic Design X is the best tool available to 
transform raw scan data into valuable CAD-ready data.  
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Geomagic Design X has the following features that are useful in processing raw scan data: 
 

Point Cloud & Mesh Cleanup – Remove unnecessary scanned areas, outliers, and heal point 
clouds and meshes. 

• Automatic point cloud/mesh healing & cleaning 

• Automatic scan data processing from multiple point clouds into qualified mesh – Mesh 
Buildup Wizard™ 

• Creation of watertight and optimized mesh from raw scan data just with one click – Rewrap™ 

• Automatic hole filling with curvature continuity 

 
Best-in-class Point Cloud & Mesh Operations – Change resolution, optimize triangle size, edit 
shape, and make a water-tight mesh. 

• Cross sectioning of freeform curve designs with point clouds and meshes 

• Instant mesh optimization for direct use in RP, CAM & CAE 

• Detailed resolution controls (decimate & subdivide) 

• Smoothness controls (global & local smoothing) 

• Professional and highly interactive point cloud/mesh editing tools 

• Powerful operations such as remove marker, de-feature, hole filling, fix boundary, smooth 
boundary, fit boundary, fit region to analytic shape, split & trim, divide, thicken, offset, etc.  

 
Direct Color Texture Editing – Add texture or modify texture for visualization. 

• Color-texture aware mesh operation and texture preservation 

• Color parameter adjustments and editing 

• Automatic color balancing between multiple scans 

• Single texture creation from multiple textures while minimizing mosaic textures 
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• 3D data compression and streaming for web publishing 

 
Align Wizard™ – Align scan data to the global coordinate system. 

• Wizard for aligning 3D scan data to an candidate design coordinate system automatically 

• Highly interactive toolset for coordinate alignment 

• Multiple alignment methods, such as Quick Fit, Best Fit, 3-2-1, Datum, By Ref. Coordinates, 
etc. 

 
Accuracy Analyzer™ – Analyze deviation between original and modified model at any time. 

• Redesign within user-defined allowable tolerances 

• Automatic and real-time error visualization 

• Diverse object sensitive analysis tools (mesh to mesh, mesh to CAD, etc.) 

 
Quick Mesh-to-Surface – Generate a CAD by fitting surfaces to a mesh. 

• Intelligent primitive (reference geometry) extraction from point clouds and meshes 

• Automatic shrink wrapped surface model generation 

• Optimized representations of original mesh data with negligible deviation error 

• Interactive mesh-fit surfacing (region fit & boundary fit) 

 
Sophisticated Curve Tools – Generate 3D curves on a mesh or 2D section curves. 

• Automatic extraction of design curve and feature curve from mesh 

• Intelligent dimensioning & constraining 

• Comprehensive 3D curve design tools e.g. section curves 

• Intelligent real-time geometry recognition 

• Curvature-based curve network design 

 
LiveScan™ & Direct Interface with 3D Scanning Devices – Direct interface with 3D scanners 
for real-time scanning. 

• Real-time scanning 

• Scan and generate design features on-the-fly 

• Allows digitizing with a hard probe 

 
 
 
 

3.2. Types of 3D Scan Data 
 
3D scan data can be a point cloud or a mesh. The point cloud is a raw file type from a scanner but 
many scanning software can convert it to a mesh data. Both data types can be used to reach a final 
goal. This guide will give you detail information regarding a point cloud and mesh. 
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3.2.1. Understanding Point Clouds 
 
A point cloud is a representative data type which is composed of a group of vertices in a three-
dimensional coordinate system. Each vertex is defined by the X, Y, and Z coordinates; and 
corresponds to one position on the surface of an object. While point clouds can be directly visualized 
on a PC, they are not generally directly usable in most 3D applications. Point clouds usually need to 
be converted into mesh models or CAD models through processes referred to as mesh modeling, or 
reverse designing. 

 
 
 

Point Cloud by Data Type 

The file type that a scanner creates will differ based on the type of scanner used. The following are 
the different classifications for internal structures of point clouds. 
 

Random-type point cloud 
This type contains only random position information (no 
relationship between points), and basic information such 
as color and normal can be added. Generally, neutral data 
(ascii format) or CMM data belong to this group type. 
 

 

Grid-type point cloud 
As measured points are extracted from a scanner's grid 
pattern, points will also be extracted from the corners of 
the grid. Points are marked with an X-Y index and each 
index has a depth to the scanning direction. This type of 
scan data can be a 2.5D image (image + distance on each 
pixel) using the projection direction and the scanning 
position. Generally, structured light and long range 
scanner produce this type of point cloud. A grid type point 
cloud can easily be converted into a mesh by projecting 
onto a planar, cylindrical, or spherical coordinate used with  
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the scanner. 
 

Line-type point cloud 
Generally, an arm-type device with a laser scanner or a 
hand held scanner produces a line type point cloud. The 
device emits dozens of lines of lasers every second and 
point clouds are gathered from the scanning trace on the 
surface of an object. The point density will be different 
depending on the line direction and the scanning speed, 
therefore the post processing to generate a mesh from the 
point cloud can be more difficult. 
 

 
 
 

Point Cloud with Normal 

The normal is a perpendicular vector to a plane. In the case of a rounded surface, the normal is a 
perpendicular vector to a tangential plane on a position of the rounded surface. 

 
 
If a point cloud has normal information, it can be very helpful for visualizing a model. Normal 
information is used for shading a model by analyzing the incidence angles and reflection angles of 
light on a point. Normal information is also used to determine the front or back of a surface. This is 
very important to accurately find and calculate face pairs between scan data and CAD data, 
especially in the inspection software. The following image shows a shaded point cloud in the 
software. 



Geomagic Design X | Understanding Scan Data  57 
 

 
Display of Point Cloud with Normal 

Information 
 
If a point cloud does not include normal information, the scan data will only be a group of points 
displayed in a single color. Recognizing features and working with such scan data can be difficult 
and tedious. The following image shows a point cloud without normal information. 

 
Display of Point Cloud without Normal 

Information 
 
A point cloud without normal information also can be visualized by the “depth shading” method, 
but the effect is not as effective as a point cloud with normal information. The closer points are 
displayed in black and the points farther away are display in gray in relation from the viewing 
direction. This method cannot determine the front or back of a surface but is still more helpful for 
feature recognition than displaying with no shading at all. The following image shows the depth 
shading method on a point cloud which does not have normal information. 

 
Display of Point Cloud without Normal 

Information - Depth Shading 
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Point Cloud with Textures 

A point cloud has not only three-dimensional coordinates, but also R, G, and B color information for 
each point. Geomagic uses this color information as a texture. A point cloud with color information 
can be used to generate realistic visuals and help users to recognize complex features. A textured 
point cloud is very efficient and easy to use for a continuous work flow. 

  
Point Cloud with Textures Point Cloud without Textures 

 
 
 

3.2.2. Understanding Mesh 
 
A mesh is polyhedron-based 3D digital data which consists of points, edges, and faces (usually 
triangles). The mesh is frequently used in CAD/CAM/CAE and 3D computer graphics programs. A 3D 
scanning application generally uses a mesh which is created from a scanned point cloud. 

 
 
Modern graphic cards are not optimized for rendering point clouds but have advanced technology 
to display meshes. Therefore meshes often more advantages in regards to a smooth visualization of 
complex surfaces and structures of an object. The triangulation, or meshing, is a process to connect 
3 points and construct surface. When connecting points, the edge length can be an important 
parameter to make a correct object shape. 



Geomagic Design X | Understanding Scan Data  59 
 

 
 
 

What is a Perfect Mesh? 

 
Erroneous Data 
A mesh represents a surface by successively connected triangles. However, erroneous triangles 
such as non-manifold, redundant, crossing, and reversed triangles cannot make a complete mesh. 
These errors should be removed because they will affect the downstream workflow, i.e. RP, NC 
machining, FEM (finite element method), and fitting surfacing for reverse design. The following 
examples show errors on a mesh. 
 

• Non-manifold Triangle – a single edge shared by three or more triangles 

• Redundant Triangle – ignoring boundaries, a point must have an identical number of triangles 
and connecting edges 

• Crossing Triangle – edges sharing a poly-vertex intersection with one another 

• Reversed Triangle – opposite normal direction to neighboring triangles 

 

  
Non-manifold Triangle Redundant Triangle 

  
Crossing Triangle Reversed Triangle 

 
 
Proper Shape of Triangle 
The shape of a triangle is important for quality results. The aspect ratio, or the width to height on 
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a single triangle, should not be large. A triangle with a high aspect ratio will appear as a very thin 
and sharp triangle, and can produce errors when using a model for RP, NC machining, FEM and 
fitting surfacing. The ideal shape for a triangle is an equilateral triangle. 

 
 
Noise on Mesh 
The scan data may have noise produced by a scanner. For example when you scan a very shiny 
object, the reflection generates noise. The noisy data generate a rough surface on the mesh. These 
noises can be reduced by the smoothing algorithm in the software, that removes spiky points by 
averaging with surrounding points. However, strong smoothness may removes sharp edges and 
change feature accuracy. 

 
Removing noise by smoothing 

 
 
Mesh and Resolution 
A high resolution mesh generates a large file size and using it in software is not easy. Conversely, 
a low resolution mesh is easy to use in software but cannot adequately represent the feature 
information of an object. An ideal mesh should sufficiently express features with the minimum 
amount of triangles within a desired tolerance. A high curvature area will usually have a dense 
triangles structure and a low curvature area will usually have a sparse triangle structure. Noise and 
defects should also be removed from the mesh. 
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Resolution is too low, making the model lack information and causing uniformity issues. 
 
 
Is an ideal mesh always necessary? 
Is an ideal mesh always necessary? Not always. Depending on what the end goal is for mesh, the 
modeling result can be different. For example, if the purpose of modeling is for RP, NC machining 
and fitting surfaces; holes and twisted, erroneous triangles should be removed. If the purpose of 
modeling is for FEM, uniform triangles are ideal. If parametric modeling or inspection is the goal, 
obtaining a mesh from raw data with as few deformities is ideal, and significant features should be 
present on the mesh. 

 
 

Mesh and Texture 

As a point cloud can include texture information, a mesh can also include texture information. In 
the following image, the left example shows a mesh without texture and the right example shows 
a mesh with texture. The image illustrates how a mesh with color information can generate realistic 
visuals. 

 
Mesh only and colored mesh 

 
There are two methods to express colors on a mesh. The first one is to use an image file (jpg, bmp, 
etc) since each point has mapping information on a bit map, allowing color to be smoothly filled 
between points. The second method is using the R, G and B color values of points or triangles. In the 
case of a dense mesh, it can be sufficient for visualization, but for sparse areas color information will 
be missing and the displayed output will not look natural. If a mesh has texture information, it can 
be converted from an image to a point color, and vice versa. 
 
 

What Can Generate a Mesh? 

A mesh can be converted from scan data by the triangulation process and is commonly used in CAD, 
CAM, CAE and computer graphics. The following software can generate a mesh. 

• Scan bundle software can often generate a mesh from a point cloud. 

• Special scan data software, such as Geomagic Design X, can generate and modify a mesh. 

• CAD, CAM, CAE software can generate mesh such as .stl format file. 

• 3D computer graphics software can generate and do mesh modeling. 
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3.2.3. Mesh vs. Point Cloud 
 

Mesh 

Scan data is basically a collection of 3D points (point cloud). It can be converted into a mesh by 
connecting adjacent points with triangles, which are the simplest unit of a face. Generally mesh 
has the following advantages over using a point cloud: 

• Can recognize features intuitively 

• Can distinguish front and back faces 

• Can measure the curvature of a surface 

• Can apply environment mapping 

• Can measure volume 

• Can easily extract neighboring point and triangle information 

• Can accurately calculate alignment between scan data 

• Can be directly used in RP, FEM, and NC machining 

• Can be used for reverse design 

• Can be used for metrology or inspection 

• Can be used for visualization and documentation 

• Can be used for animation  

 

 
Mesh for a complex model 

 
 

Point Clouds 

A point cloud can contain additional normal or color information for each point or the information 
can be omitted. Constructing a shape from a lower resolution point cloud may be difficult due to 
the lack of data, however using a high resolution point cloud can actually aide in the visualization 
of an object in comparison to using mesh. If a point cloud is converted to mesh, the advantages of 
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a mesh can be used. However long range scan data is usually a very large file size and triangulation 
can be very difficult. The processing time may be lengthy, and the results can be difficult to predict. 
If the purpose of using long range scan data is for CAD modeling, it is more efficient to do 
parametric CAD modeling with a point cloud instead of mesh or partially convert a point cloud 
into a mesh. The benefits of using point clouds are as follows: 

• Can handle larger data files  

• Can do simple measuring 

• Can be used for reverse design 

• Can be used for surveying 

• Can be used for metrology or inspection 

• Can be used for visualization and documentation 

 

 

Visualization of Point Cloud 
 
 
 

4. Understanding Reverse Design 
 
 
 

4.1. What is Reverse Design? 
 
Reverse Design is the technology of creating digitized design data to be used for the creation of 
products from a real object as shown in the image below. 
 
The Reverse Design shown below was internally done by leading technology manufacturers as a 
unique design technique. The traditional design process is the creation of a final product through a 
chosen design process, such as concept designing or detailed designing used to create "something" 
from "nothing". The Reverse Design process can create valuable design data by capturing digitized 
shape information from a real object by using 3D scanning technologies, such as CMMs (Coordinate-
Measuring Machine), laser scanners, structured light digitizers, or Industrial CT Scanning (computed 
tomography). Design intent can be extracted from shape information. 
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Reverse Design from a Real Object 
 
Reverse Designing is widely used in manufacturing fields such as automotive, aerospace, medical, 
etc., as well as graphics fields such as game design, animation, computer graphics, etc. In the field of 
manufacturing, reverse design is being effectively applied to product design, development, 
production, and quality management, and has seen a key role in reducing overall product 
development cycle times. 
 
Reverse Design is used in: 
 

• Duplicating a target product for which no drawings or CAD data exists 

• Manufacturing of a new product with enhanced functions based on an existing product 

• Designing a new product from a mock-up model or clay model in the automotive industry, 
where aesthetic design factors are critical 

• Customizing products fitted for the human body (Mass Customization) 

• Reconstructing damaged cultural assets 

• Using digitized shape information for animation 

• Manufacturing a products in the medical or dental fields 

• Analyzing design elements from competitors' products 

 
 
 

4.2. Reverse Modeling Strategy 
 
The Reverse Modeling process is the process of creating the best 3D model from the 3D scan data 
(Point Cloud or Mesh) generated in the Scan Data Processing phase. 
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Various modeling methods in Reverse Modeling process 
 
These methods can be used solely or mixed with the other methods depending on the desired 
output. 
 

Mesh Modeling 

Purpose 
Creating an optimized mesh from 3D scan data 
 
Benefit 
You can create the best mesh from 3D scan data by cleaning defects, filling missing holes, 
modifying its shape, and optimizing mesh structure, according to the purpose of utilizing. 
 
What is it useful for 

• Analyzing the model shape 

• Creating a reference prototype model by using Rapid Prototyping technologies 

Parametric Feature Modeling 

Purpose 
Creating a 3D feature model based on the analyzed design intent and elements from 3D scan 
data 
 
Benefit 
You can define features with parameters based on the analyzed design intent and elements from 
3D scanned object. The created features can be reused, redefined, modified, and translated by 
controlling parameters. 
 
What is it useful for 

• Manufacturing a new product with enhanced functions based on existing product 

• Duplicating the target product which does not have a CAD model 

• Analyzing design elements of another part or product 
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Fitting Surface Modeling 

Purpose 
Creating a 3D freeform model based on the optimized mesh from 3D scan data 
 
Benefit 
You can effectively and rapidly extract an accurate freeform surface from the shape of a 3D 
scanned object, by using various tools; such as Auto Surfacing, Mesh Fitting, and Boundary 
Fitting.  
 
What is it useful for 

• Creating outer forms of aesthetic model, such as car bodies and outer cover of consumer 
products 

• Customizing a new product to be fitted for the human body (Mass Customization) 

• Manufacturing a new product based on the human body shape in the medical or dental 
fields 

• Reconstructing the damaged cultural assets  

• Creating animations from digitized shapes 

 

Hybrid Modeling 

Purpose 
Creating a complex 3D model from 3D scan data 
 
Benefit 
You can rapidly create a complex 3D feature model by mixing parametric features created by 
using Parametric Feature Modeling method and freeform surfaces created by using Fitting 
Surface Modeling method. The resulting 3D feature model can be reused, redefined, modified, 
and translated by controlling parameters maintaining its outer freeform shape. 
 
What is it useful for 

• Designing a new product from a mock-up or clay model 

• Designing a new product for assembly 

 
 
 

4.2.1. Mesh Modeling 
 
The Mesh Modeling method can be used to create an optimized mesh from a 3D scan of an object. 
 

When can I use this modeling method? 

The Mesh Modeling method can be used for analyzing the shape of a model and creating a reference 
prototype model with Rapid Prototyping technologies.  It can also be used to optimize mesh for use 
as a graphic model in animations, or for use as raw data in creating 3D feature models. 
 
The tools that are used for creating optimized meshes from 3D scan data can be divided into 4 
different types, as listed below: 
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Cleaning Tool – Used for deleting data and healing defects (abnormal poly-faces) from 3D scan 
data (Point Cloud or Mesh) 

 
Cleaning Mesh 

 
 

Editing Tool – Used for filling missing holes that could be generated by shadows from other 
features, to smooth the roughness of a mesh, or to re-arrange its boundaries. 

 
Editing Mesh 

 
 

Modifying Tool – Can be used to add thickness to a model or to modify its shape (like split, 
mirror, merge, subtract, intersect, etc.) 

 
Modifying Mesh 

 
 



Geomagic Design X | Understanding Reverse Design  68 
 

Optimizing Tool – Used to optimize the topology of faces on a mesh or to create a watertight 
mesh. 

 
Optimizing Mesh 

 

 
These tools can be used by themselves or in conjunction with other tools to optimize mesh based 
on the desired outcome during the Mesh Modeling process. 
 
 
 

4.2.2. Parametric Feature Modeling 
 
The Parametric Feature Modeling method can be used to create 3D feature models based on design 
intent and elements from 3D scanned objects. 
 

When is this modeling method useful? 

The Parametric Feature Modeling method based on Parametric Modeling Technology (see: Note) is 
used for manufacturing a new product with enhanced functions based on an existing product. It 
can also be used to duplicate a target product which does not have a drawing. 
 
This method consists of 3 different sub-methods for creating a 3D feature model. The methods are: 
 

2D/3D Sketching method – Extracts 2D section profiles or 3D curves from 3D scan data. 
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Extracting 2D Section Sketch Profiles From Mesh 
 
 

Feature Modeling method – Creates a 3D CAD-ready feature model by using sketch profiles. 

 

Creating Features by using the Extracted Sketch Profiles 
 
 

Editing method – Combines created features or subtracts features by using geometric and 
mathematic operations, and modifies the created features by controlling the defined 
dimensions. 

 

Completing a 3D CAD feature model by combining the created features 
 

 

Note:  
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Parametric Modeling Technology 

Parametric Modeling Technology is based on design intent, and is a unique technique in the 
Reverse Design process. It sets the parameters required for defining features based on the 
design intent and creates 3D features using those parameters.  

Design data can be prepared for a final product by modifying design iterations, trying out, and 
reviewing the results throughout the design process. The design data is managed in the same 
database throughout the product development process from the manufacturing stage through 
the analyzing stage; and finally ending with the evaluation stage. Design data modeled with 
Parametric Modeling Technology can be easily modified and reviewed according to the results 
of the product development process. The features managed by the parameters in the design 
data can be reused, redefined, modified, translated, and updated by controlling the parameters 
for each one. With parametric Modeling Technology, development time and cost can be 
effectively reduced in the creation of a product. 

 
 
 

4.2.3. Fitting Surface Modeling 
 
The Fitting Surface Modeling method can be used for creating a 3D freeform model based on an 
optimized mesh from a 3D scanned object. 
 

When can I use this modeling method? 

This Fitting Surface Modeling method with Surface Fitting Technology (See Note 1.) is mainly used 
for quickly and effectively creating outer forms of aesthetic models, such as car bodies and outer 
covers of consumer products. It is also used for customizing new products to be fitted for the human 
body (Mass Customization), manufacturing new products based on the human body shape in the 
medical or dental fields, reconstructing damaged cultural assets, using digitized shape information 
for animations, etc. 
 
The Fitting Surface Method consists of 3 different sub-methods.  
 
The 3 sub-methods are: 

Curve Networking method – Constructs a curve network by connecting 3D curve loops 
projected onto freeform regions on a mesh. 

 
Constructing curve network on the mesh 
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Surface Fitting method – Fits surface patches within a constructed curve network and creates 
a freeform surface body by connecting the surface patches. 

 

Fitting Surface on the mesh 
 
 

Editing method – combines created surface bodies or subtracts surface bodies by using 
geometric and mathematic operations. 

 

Editing Features 
 
 

 

Note:  

Surface Fitting Technology 

Surface Fitting Technology is a unique technique in the Reverse Design process that provides 
an effective way to easily and quickly create 3D freeform surface bodies from a freeform mesh 
shape. It creates surface patches by projecting uniform points within curve loops constructed 
on a freeform mesh shape, and fitting to the projected points. A 3D freeform surface body is 
created by connecting fitted surface patches. This technique is usually used for creating a highly 
accurate 3D freeform surface body from 3D scan data. 

 
 
 

4.2.4. Hybrid Modeling 
 
The Hybrid Modeling method is used to create complex 3D models based on the design intent and 
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elements of a 3D scanned object or 3D mesh shape. 
 
 

When can I use this modeling method? 

The Hybrid Modeling method mixes with both Parametric Modeling Technology and Surface Fitting 
Technology; and can be used for managing overall feature shape information as well as design 
parameters from complex models. It can also be used when designing new products for assembly 
or designing new products from mock-up models or clay models, especially in the automotive 
industry or other industries where aesthetic design factors are critical. 
 
This method consists of 5 different sub-methods. The 5 sub-methods are: 
 

• 2D/3D Sketching method: Extracts 2D section profiles or 3D curves from the 3D scan data. 

• Feature Modeling method: Creates a 3D CAD feature model by using the sketch profiles. 

• Curve Networking method: Constructs a curve network by connecting 3D curve loops projected 
on the freeform region in the mesh. 

• Surface Fitting method: Fits surface patches within a constructed curve network and creates a 
freeform surface body by connecting the surface patches. 

• Editing method: Combines the created features or subtracts features, using geometric and 
mathematic operations. 

 

 

Creating a complex 3D Model by using the Hybrid Modeling method 
 
 
 

4.3. Powerful Tools for Reverse Modeling 
 
Geomagic Design X provides various tools to quickly and effectively create the best 3D parametric 
CAD model from the 3D scan data. 
 
These tools are unique, innovative, and intelligent; and provide the best reverse design process. You 
can automatically extract design intent; process parameters, and geometric information from the 
3D scan data by using these tools, and quickly create a 3D parametric feature model. Furthermore, 
the created 3D parametric model with history and design parameters can be transferred to the other 
CAD systems, and it can be managed in the CAD system. 
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The following tools are innovative and intelligent tools provided in Geomagic Design X: 

• Automatic scan data processing tool for creating a watertight mesh from raw 3D scan data - 
Mesh Buildup Wizard™ 

• Automatic coordinate alignment tool for CAD modeling from 3D scan data - Align Wizard™ 

• Innovative and intelligent tool for extracting design parameters and elements from 3D scan 
data - Redesign Assistants™ 

• Innovative and intelligent tool for extracting 2D/3D sketch profiles and feature information from 
3D scan data - Modeling Wizard™ 

• Real-time analysis tool for creating the best 3D feature model from 3D scan data within the 
design tolerance - Accuracy Analyzer™ 

• Automatic process for transferring 3D parametric models with the modeling history and design 
parameters to other CAD systems - LiveTransfer™ 

 
 
 

4.3.1. Mesh Buildup Wizard(TM) 
 
The Mesh Buildup Wizard is used in the Scan Data Processing phase, and is a wizard style interface 
for creating defect-free and watertight mesh models from raw 3D scan data. 
 
The Mesh Buildup Wizard tool employs the most advanced mesh technology; but is user-friendly, so 
even a novice user can easily create complete mesh from 3D scan data. This tool consists of 5 stages. 
Each stage can be executed in just few clicks, enabling the speedy creation of optimal mesh for use 
in the final reverse design stages. The 5 stages are: 
 

• Data Preparation stage: Analyzes the state of scan data and defining the next process 
according to the type of target scan data 

• Data Editing stage: Remove noisy clusters and unnecessary point clouds or meshes 

• Data Pre-Aligning stage: Aligns multiple scan data files quickly. 

• Best-Fit Aligning stage: Aligns multiple scan data files by using geometry shape information. 

• Data Merging stage: Merges scan data and creates an optimized mesh 
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Creating optimal mesh through each stage in the Mesh Buildup Wizard 

 
 

When can I use this tool? 

When creating an optimized mesh from multiple 3D scan data files that have not been aligned, 
optimal mesh for the final reverse design process can be made by using this tool. An optimal mesh 
can be created by applying this tool after importing multiple 3D scan data files and clicking the "Run 
Mesh Buildup Wizard" button. 
 
 

Where is this tool? 

• Insert > Import (By clicking "Run Mesh Buildup Wizard" button) 

• Tools > Scan Tools > Mesh Buildup Wizard  

 
 

How do I use this tool? 

Refer to the following topic below: 
Tools > Scan Tools > Mesh Buildup Wizard 
 
 
 

4.3.2. Auto Surfacing 
 
Auto Surfacing is used in the Modeling phase and is an innovative and automatic tool for fitting 
surface patches onto a mesh and creating a surface body. This is important when designing a 
complex freeform part, creating model data for manufacturing a freeform shape, or for analyzing a 
geometric shape. This tool creates a surface body that can envelope an entire geometric shape of a 
target mesh. 
 
The Auto Surfacing tool provides 2 different methods: 
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• Evenly Distributed Network - Generates a surface body from a target mesh by projecting an 
evenly distributed curve network 

• Feature Following Network - Generates a surface body from a target mesh by constructing a 
feature following curve network 

 
These two methods are used differently based on desired results and how the final model will be 
utilized. 

 

Creating Surface Body by using Auto Surfacing Tool 
 

Where is this tool? 

Insert > Surface > Auto Surfacing 
 
 

How do I use this tool? 

Refer to the following topic below: 
Insert > Surface > Auto Surfacing 
 
 
 

4.3.3. Align Wizard(TM) 
 
The Align Wizard is used in the Modeling phase and is a wizard style interface used to quickly and 
accurately align 3D meshes to a Global Coordinate system, based on design intent. 
 
The Align Wizard tool employs the most advanced alignment technology; but is user-friendly, so 
even a novice user can easily align 3D mesh to a Global Coordinate system. The tool consists of 2 
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stages. Aligning target 3D mesh to the Global Coordinate system without manually selecting and 
setting each element can be done with the following 2 stages:  
 

• Defining Target Mesh stage: Defines the target mesh which is not aligned to the global 
coordinate 

• Choosing Best Coordinate stage: Chooses the best coordinate from the coordinate candidates 
sorted by analyzing geometric feature information 

 

 

Aligning by using the Align Wizard tool 
 
 

When can I use this tool? 

If understanding a complex feature shape and manually defining a coordinate for it is difficult, easily 
align the 3D mesh of the target to the Global Coordinate system by using the Align Wizard tool. 
 
 

Where is this tool? 

Tools > Align > Wizard 
 
 

How do I use this tool? 

Refer to the following topic below: 
Tools > Align > Wizard 
 
 
 

4.3.4. Redesign Assistant(TM) 
  
The Redesign Assistant is used in the Modeling and Extracting Design Intent phases, and is an 
innovative and intelligent tool for extracting design parameters and elements from 3D scan data. 
This tool helps users to easily define feature shapes with accurate parameters and design elements. 
 

When can I use this tool? 
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When extracting design intent and parameters from 3D scan data, this tool is widely used within the 
other tools provided by Geomagic Design X in the following cases: 
 

• Extracting Distance from 3D scan data 

When extruding a defined sketch profile to create an extruded shape or subtracting a feature from 
other existing features, this tool makes it possible to extract distance information from the 3D 
scan data without the need for manual measurement. 

• Extracting Radius from 3D scan data 

When creating a fillet shape in a fillet region that has a constant radius or variable radius, this tool 
makes it possible to extract radius information from 3D scan data without needing to measure on 
the section. 

• Extracting Thickness from 3D scan data 

If a model is being thickened, this tool makes it possible to extract thickness information from 3D 
scan data. 

• Extracting Draft Angle from 3D scan data 

When extracting an accurate sketch profile from the scanned object which has an amount of taper, 
this tool makes it possible to extract draft angle information from 3D scan data. 

 
Furthermore, when creating a revolved shape or a spiral shape like a drill, it is possible to extract 
important design parameters such as height, radius, pitch, and revolving ratio as well as design 
elements such as section profile, 3D sweeping patch, rotational axis, etc. The extracted design 
parameters and elements will be used for defining an accurate 3D feature shape as reference 
information. 

 

Parametric Feature Modeling by using the Redesign Assistant 
 
 
 

4.3.5. Auto Sketch 
Auto Sketch is used in the Modeling phase and is an innovative and automatic tool for creating a 
sketch profile based on section polylines.  
The sketching process extracts lines and arcs from complex section polylines and connects them to 
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create a sketch profile that may otherwise be difficult and time consuming. While creating a sketch 
profile, Auto Sketch intelligently recognizes a relationship between lines and arcs and automatically 
sets constraints to the sketch profile.  
You can completely create a sketch profile by using the Auto Sketch tool only. 

 

Creating a Sketch Profile from Section Polyline by using Auto Sketch Tool 
 
 

Where is this tool? 

Go to: Tools > Sketch Entities > Auto Sketch 
 
 

How do I use this tool? 

Refer to the following topic below: 
Tools > Sketch Entities > Auto Sketch 
 
 
 

4.3.6. Various Modeling Wizards(TM) 
 
The Modeling Wizard is used in the Modeling phase and is an innovative and intelligent tool for 
extracting 2D and 3D sketch profiles and feature information from 3D scan data. 
 
The Modeling Wizard provides 5 different wizard tools: 
 

• Extrusion Wizard: Creates an extruded feature. 

• Revolution Wizard: Creates a revolved feature. 

• Sweep Wizard: Creates a swept feature along a 3D path curve. 

• Loft Wizard: Creates a lofted surface by connecting 3D section curves. 

• Pipe Wizard: Creates a pipe feature by using a section profile and 3D path curve.   
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Extrusion Wizard / Revolution Wizard / Sweep Wizard 

Extrusion Wizard 
From a mesh region, the Extrusion Wizard intelligently generates an extruded solid/surface and 
its 2D/3D section sketch profile, while satisfying given deviation error automatically. 
 
Revolution Wizard 
From a mesh region, the Revolution Wizard intelligently generates a revolved solid/surface and 
its 2D/3D sketch profile and revolving axis, while satisfying given deviation error automatically. 
 
Sweep Wizard 
From a mesh region, the Sweep Wizard intelligently generates a swept solid/surface and its 
2D/3D sketch profile and 3D path curve, while satisfying given deviation error automatically. 

 

Feature Modeling by using the Extrusion Wizard / Revolution Wizard / Sweep Wizard 
 
 

Loft Wizard 

From a mesh region, the Loft Wizard intelligently generates a smooth lofted surface and its 
profile curves, while satisfying given deviation error automatically, as shown in the image below. 

 

Creating a smooth lofted surface by using the Loft Wizard 
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Pipe Wizard 

Using 3D scan data (Point Cloud or Mesh Region), the Pipe Wizard intelligently generates a swept 
solid/surface and its 2D/3D sketch profile and 3D path curve, while satisfying given deviation 
error automatically. 

 
Creating a Pipe Feature by using the Pipe Wizard 

 

 
 
 

Where is this tool? 

• Insert > Modeling Wizard > Extrusion Wizard  

• Insert > Modeling Wizard > Revolution Wizard 

• Insert > Modeling Wizard > Sweep Wizard 

• Insert > Modeling Wizard > Loft Wizard 

• Insert > Modeling Wizard > Pipe Wizard 

 
 
 

4.3.7. Accuracy Analyzer(TM) 
 
The Accuracy Analyzer is used in the Model Verification phase, and is a real-time analysis tool for 
creating the best 3D feature model from 3D scan data within design tolerances. This tool analyzes 
deviations between the intermediate or final model with the raw 3D scan data and verifies the 
results. And also, the quality and continuity of the faces of a model can be checked in order to 
ascertain whether the final model can be manufactured without any problems. The analyzed results 
can be used for creating an optimal 3D model within allowable design tolerances. 
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When can I use this? 

Whenever the analysis of intermediate/final result is required, this tool can be used during the 
modeling process in the following cases: 
 

Aligning between scan data 

You can check the deviation between each scan after alignment is performed in the scan data 
processing phase, and get the best result by using the analysis feedback 

 

Accuracy Analyzer during the scan data processing phase 
 
 

Extracting design intent or elements 

You can check how the extracted elements and feature information compare to the original scan 
data. 

 

Accuracy Analyzer during the modeling phase 
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Confirming final modeling result  

You can finally check the accuracy and quality of the model. 

 

Accuracy Analyzer of the final result 
 

 
 
 

4.3.8. LiveTransfer(TM) 
 
LiveTransfer is an automatic tool in Geomagic for transferring 3D parametric models and their 
modeling history and design parameters to another CAD system. It is a unique and powerful tool 
and is used after completing the modeling process. 
 
After completing data model in Geomagic Design X, the3D parametric model, with its modeling 
history and design parameters can be transferred to other CAD systems, such as SolidWorks, PTC 
Creo (Pro/Engineer), Siemens NX, Autodesk Inventor, CATIA V4/V5, and AutoCAD. This process 
creates a native and parametric model in the target CAD system. Then the file can be used as normal 
for all downstream applications; such as manufacturing, drafting, tooling, assembly, etc. 
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Transferring final results to other CAD system by using LiveTransfer 
 
 

Where is this tool? 

• File > LiveTransfer(TM) > To SolidWorks 

• File > LiveTransfer(TM) > To Siemens NX 

• File > LiveTransfer(TM) > To Creo(Pro/E) 

• File > LiveTransfer(TM) > To AutoCAD 

• File > LiveTransfer(TM) > To Inventor 

• File > LiveTransfer(TM) > Save As CATIA V4/V5 

 
 
 

5. Getting Help 
 
 

To get technical support: 

If you have any problems or suggestions, you can contact support@rapidform.com. 
 
 

To access FAQ, Technical Tips, and other resources: 

Go to the Support tab. 
 
 

To access the online help documentation: 

• While in that operation, press F1. The documentation will be displayed in the Help tab of the 
viewing window. 

• Look at the .chm file that contains a search function. It is available in the Help subdirectory of a 
root directory. 

• Also a PDF version of the documentation is available in the User Guide subdirectory of the root 
directory. 

 
 

To check the version of the application and the Product ID: 

• Click Help > About 

• When you send your request to technical support, include this information. 

 
 

mailto:support@rapidform.com
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To view the Quick Start Guide 

Click Help > Quick Start Guide. 
 
 

To activate a Product license: 

Click Help > Activate License. 
 
 

To Deactivate a Product license: 

Click Help > Deactivate License. 
 
 

To view the performance of a system 

Click Help > Launch Performance Profiler. 
 
 

To obtain the latest information: 

• Click www.rapidform.com 

• Online resources includes up-to-date product information, frequently asked questions (FAQ’s), 
software downloads, and technical support contact information. 

 
 
 

6. User Interface 
 
The user interface of Geomagic Design X is intuitive and easy to use. It is a flexible and dynamic 
interface that is simple to learn. The user interface windows and toolbars can be modified so that 
they are always shown, dynamically hidden, or never shown, via the right mouse button menu in 
the toolbar area. 

http://www.rapidform.com/


Geomagic Design X | User Interface  85 
 

 
 
 
 

6.1. Title Bar 
The title bar shows the full path of the model currently being worked on at the top of the application. 
For example, if the file “~<Product Installation Path>\Sample\xxx.xrl” is imported, you can see its 
name in the title bar, but only after it is saved. 
 
 
 

6.2. Menu Bar 
The menu bar shows the top level of all of the menus. These include File, Select, Edit, Insert, Tools, 
Measure, View, Add-Ins and Help menus. 

 
 
 

Moving menu bar 

The pull-down menu bar can be freely docked anywhere and some commands have icons for 
quicker referencing. 
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Menu types 

There are three types of objects in a menu: 

 
 

• Arrow (  ) 

If there is an arrow beside a menu option, there is a sub menu. 

• Shortcut key ( ) 

Often used commands also have shortcut keys to the right of the command name. 

• Ellipsis ( ) 

If there is an ellipsis "..." beside a dialog box or dialog tree, the command name has been shortened 
and will be shown after it is clicked. 

 
 
 

6.3. Mode 
 
The application features different modes that allows for the generation and editing of entities with 
only the appropriate functions displayed. Multiple modes are featured because the application can 
handle and manipulate many different types of entities that normal CAD programs cannot.  To 
simplify and streamline the process there are different modes that can be used to handle the types 
of entities that are being worked with. 

 
 
When you enter a mode the working environment (tool palette, toolbars, selection toolbar, and 
options under the Accuracy Analyzer pane) is automatically set to the current mode state. The 
application has the following modes. 

 Mesh – The Mesh mode contains functions to edit, heal, enhance and optimize meshes. To 
enter the Mesh mode, select a mesh and then click the Mesh icon or double-click the mesh 
in the Feature / Model tree or in the Model View. 
 

 Region Group – The Region Group mode contains functions to classify features by colors 
and groups. After region segmentation is performed a feature on a mesh can easily be 
selected instead of selecting a feature by dragging or painting it. To enter the Region Group 
mode, first select a mesh and then click the Region Group icon. 
 

 Point Cloud – The Point Cloud mode contains functions to clean and edit point clouds; and 
to generate meshes. To enter the Point Cloud mode click the Point Cloud icon. Functions in 
the Point Cloud mode apply to all point clouds in the model view. 

 Mesh Sketch – The Mesh Sketch mode contains functions to draw and edit sketch entities 
such as lines, arcs, and splines; by fitting a section polyline onto the model that can be 



Geomagic Design X | User Interface  87 
 

extracted from point clouds or meshes. To enter the Mesh Sketch mode, a base plane which 
can be a ref. plane, planar face, or planar region needs to be defined. These sketches are used 
to generate a surface / solid body. 
 

 Sketch – The Sketch mode contains functions to draw and edit sketch entities such as lines, 
arcs and splines; with or without a mesh or point cloud. Tools in the Sketch mode are the 
same as those found in Mesh Sketch mode, however fitting is not available. To enter the 
Sketch mode, a base plane must be defined. It can be a planar entity. These sketches are used 
to generate additional surfaces / solid bodies without using the section information from 
point clouds or meshes. 
 

 3D Mesh Sketch – The 3D Mesh Sketch mode contains functions to draw and edit 3D curves 
based on point clouds or meshes. Whenever a curve is drawn or edited, it will be projected 
onto the point cloud or mesh. To enter the 3D Mesh Sketch mode, select a mesh and then 
click the 3D Mesh Sketch icon. Curves created in this mode can be used for generating fitting 
surfaces. 
 

 3D Sketch – The 3D Sketch mode contains functions to draw and edit 3D curves as featured 
in the 3D Mesh Sketch mode, but differs in that any curves created in 3D Sketch mode are 
not projected onto a mesh. 3D curves can be freely drawn in space or on any entities. To enter 
the 3D Sketch mode click the icon. Curves created in this mode can be used to get a center 
line of a pipe or to create a path for a 3D loft or sweep body. 

 
 
 

Activating and exiting a mode 

How to activate and escape a mode is below. 

• Activating mode 

Click a mode. When a mode is activates, the corresponding toolbars are also activates. 

• Exiting a mode 

To accept all changes in the mode click the  icon or the mode button (e.g. ) again. If the  
icon is clicked, all changes in the mode will be canceled. 

 
 
 

6.4. Toolbar 
You have menus or commands that are used frequently. Toolbar is a collection of the menus and 
commands.  

 
 
 

Customizing the toolbar 

To customize the toolbar, right-click on it and choose Customize. 
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The Commands tab 

All commands are listed. When a command is selected, there will be a short description about it. You 
can drag-and-drop a command into a toolbar. 

 
 
 

The Toolbars tab 

If you check the toolbar in the toolbars list, the toolbar will be shown immediately. 
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To add a new toolbar, click the New button and enter a name for the new toolbar. 

 
 
When you click OK, you will notice the newly created toolbar which is empty. 

 
 
Now you can drag and drop icons from the Command tab to customize the toolbar. 
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If you click Reset All, the icons on the toolbar will reset to default. Reset All does not move the 
position of the toolbar immediately. To finish resetting, close and open the program. To change the 
name of a toolbar, click the Rename button. To delete a toolbar, click the Delete button. When the 
Show text option at the bottom is checked, the names of icons will be displayed at the bottom. 
 
 

The Keyboard tab 

 
 
In the Keyboard tab, you can bind keys to a command to create a shortcut. First, you need to select 
a Category and a Command in it, then press the New Shortcut Key (for example, pressing Ctrl and 
X). Then when you click Assign, the shortcut key is bonded to the selected command. To take away 
the shortcut keys of a command, select it in the Current Keys box, and click Remove. To return 
everything to the original default state, click the Reset All button. 
 
 

Note:  

When a shortcut key is already bonded to a command, you cannot assign another command to 
it at the same time. It is also not possible to assign Windows level shortcuts, such as Ctrl + P. 

 
 

The 3D Mouse tab 
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In the 3D Mouse tab, you can define the shortcut keys for the buttons of a 3D mouse. Click the 
number of the button and double-click a command from the list box. To remove allocated shortcuts, 
select the number and click the Delete button. 
 
 
 

6.5. Docking Bars 
 
You can change the behavior of a docking bar to Floating, Docking, Auto Hide, or Hide. 
The application includes dockable property bars for the following: Tree, Display, Console, Properties, 
Accuracy Analyzer(TM), Color Bar, Image Folder, Support, Help, Error List, Device Manager, Viewpoint, 
and Shader Control. 
 
 

Showing/hiding docking bars 

When a docking bar you want to see is not shown, right-click on the toolbar panel. 

 
Icon Status 
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(Checked) The docking bar is shown on screen. 

Unchecked The docking bar is not shown. 

 
Check desire docking bars to display them. Recheck the check box to hide the docking bar. 
The  icon on the docking bar also hides it. 
 
 

Folding/unfolding docking bars 

There are two ways to fold docking bars. 

• F12 key 

The F12 key hides all docked bars and only shows the model view. Clicking F12 again restores 
them. 

•  (pin) icon 

Sets a window to hide automatically. The window will be shown when a mouse cursor hovers over 
the appropriate tabs for the window. 

      
 
 

Floating/docking bars 

Double-clicking on the title of a docking bar enables it to be moved. Double clicking again docks it. 
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Note:  

If you right-click on any of the docking bars, the following pop-up menu appears in the view. 

 
 
 
 

6.5.1. Tree 
 

Feature Tree 

Geomagic uses a method known as parametric history modeling. Parametric history modeling 
allows the creation of objects by storing the operations used to construct the geometry, as well as 
the order of the operations and their relationships to each other. 
 

 
 
Whenever a feature such as a sketch, solid body, surface body, etc., is generated, it will be stacked in 
the Feature Tree in chronological order. The Feature Tree shows all changes and created entities in 
chronological order as well as the history for each change or creation. The order of features can be 
altered by dragging and dropping features. It is also possible to go back to a certain point in the 
modeling history by using the Rollback, Roll Forward, Roll To End commands. This type of modeling 
is known as history modeling. 

 
Changing the feature history by dragging and 

dropping 
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Selecting several items in a tree 

You can select a feature or multiple features by using the Ctrl or Shift buttons on the keyboard. You 
can then change the order of the features if desired. 
 

Note:  

You can track and select an entity by typing the name of the entity on the keyboard in the 
Feature Tree. 

 
 

Pop-up menu 

If you right-click on any entity in the Feature Tree, the following pop-up menu will be displayed. 

 
 

 Edit – Edits data based on a selected data type. For example if you select mesh and click edit, 
you can edit mesh data. 
 

 Delete – Deletes features 
 

 Suppress - Suppresses a feature so you can work on the model with the selected feature 
temporarily removed. 
 

 Rollback - Temporarily reverts the model to an earlier state. You can add new features or edit 
existing features while the model is in the rollback state. When a feature is in the rollback 
state, any feature created will be added above the selected rollback feature. You can select 
Roll Forward to roll forward or select Roll To End to go to the end feature. 
 

 Hide – Hides features 
 

 Zoom To This – Zooms an entity to fit the screen 
 
 

Model Tree 

The Model Tree shows all created entities by categories. This pane can be used for selecting and 
controlling the visibility of an entity. 
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Showing/hiding entities on Model View 

If the icon next to an entity appears as a closed eye  , the entity will be invisible in the Model View. 
For example, in the scenario below, the Top would not be visible in the Model View. 

 
 
If the parent node is made invisible, all the child entities are invisible irrespective of their status. For 
example see the tree below, although Front, Top and Right are set to be visible, the Ref. Planes parent 
node is invisible, therefore no Ref. Planes will be shown in the Model View. 

 
 

Note:  

When the mouse cursor hovers over an entity in the Model View, the entity will be highlighted 
in the Model Tree. It is useful for recognizing a specific entity in the Model Tree when many 
entities exist. 

 

Pop-up menu 

If you right-click on any feature, the following menu will be displayed. 

  
 

 Show This Only - If selected, only the feature will be shown in the viewing window 
 

 Hide – If selected, the feature will be hidden. 
 

 Zoom To Selection - If selected, the entity is zoomed to fit the screen. 
 

 Delete - If selected, the feature will be deleted. 
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 Export - If selected, a dialog box will appear and you can specify the path and the type of file 
to which the feature will be exported. 
 

 Property - If selected, properties will be shown on the right hand side. 

 
 
 

6.5.2. Display 
In the Display tab, you can change the settings related to viewing and displaying. 

 
 
 

All View - If you set the viewport (View > Viewport) to display more than two viewing panes and the 
All View option is checked, all changes made to the viewing and display settings apply to all the views. 
 
Current View – If you set the viewport (View > Viewport) to display more than two viewing panes and 
the Current View option is checked, all changes made to the viewing and display settings apply only 
to the current view. 
 
World Axis & Scale - If the World Axis & Scale option is checked, a world axis will be shown at bottom 
left corner in the Model View. 
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Scene Grid - If the Scene Grid option is checked, a grid will be shown in the Model View. It is located 
at the bottom of the model in the X-Y plane of the global coordinates. You can view the size of the grid 
as shown in the image below. This is useful for estimating the measurements of entities while 
sketching. 

 

  
Enabled Scene Grid option  Disabled Scene Grid option  

 
 
Gradient Background - If the Gradient Background option is checked, the background color of the 
workspace window will be set to a gradient. 
 
Label – If this option is enabled, the labels of the ref. geometries such as planes and vectors are shown 
in the Model View. 

 
 

General 

Dynamic Draw - To simplify the model when it is in motion, check Dynamic Draw. 

  
Dynamic Draw option enabled Dynamic Draw option disabled 
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Front Face – Determines the surface material of meshes and bodies in the Model View. As Is displays 
each entity as a separate color, however All The Same displays all of the entities in gray.  

  
As Is All The Same 

 
 
Back Face - If checked, the Back Face Color drop-down box will be activated. Within it, there are 3 
options. If Complement is selected, a complementary color of the front face color will be used for back 
faces. If As Is is selected, the color of the front and back faces become the same. If User Defined is 
selected, a user defined color will be used for back faces. User Defined colors can be set in the Display 
tab in File > Preferences.  

   
Complement As is User Defined 

 
 
Transparency - If checked, you can select an entity type and the selected type will be transparent in 
the Model View. 

  
Transparency enabled Transparency disabled 

 
 
Projection Method - If Perspective is selected, the model is projected with parallax. In this case, the 
part at the foreground appears bigger, while the part at the background appears smaller. If Parallel is 
selected, the model is projected parallel to the viewing plane. 
 
Viewpoint – You can set the viewpoint mode as Front, Back, Left, Right, Top, Bottom and Isometric. 
They are assigned to the following shortcut keys: Alt + 1, Alt + 2, Alt + 3, Alt + 4, Alt + 5, Alt + 6 and Alt 
+ 7.  
 
Lock – If checked, data cannot be rotated in the Model View. 
 

Note:  

If you cannot rotate model data, check to see if this option has been activated. 

 
 
Synchronize All View - If this option is checked, all open view ports in the Model View will be 
synchronized to that in the current view.  
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Light - To turn Lights 1, 2, 3 or 4, on or off, check the corresponding box next to the number. If you click 
the Set button, you can change properties for lighting conditions. It can also be accessed through: 
View > Light Properties. 
 
 
View Clip – If this option is checked, you can see clipped views of model data. To set the clipping 
properties, click the Set button. It can also be accessed through: View > View Clip. 
 

Mesh/Point Cloud 

Mesh Display Mode – When Vertex is selected, only poly-vertices from a mesh are shaded. When 
Smooth Face is selected, poly-faces will be shaded and connected poly-faces will be blended 
smoothly. When Flat Face is selected, every triangular face will be shaded using one color and 
connected poly-faces will not be blended. When Curvature is selected, roundness will be analyzed 
and shown using a color range. This color range can be set from the color bar that appears in the right 
pane. When Region is select, region colors will be displayed. The mesh should have regions created in 
the Region mode in advance. When Estimated Feature is selected from regions, similar geometry 
types will have the same color. This color is editable in Preferences. 

   
Vertex Smooth Face Flat Face 

 
  

Curvature Region Estimated Feature 
 
 
Point Shader – Defines shading methods for point clouds. These shading methods can be used to 
effectively view scan data. 
 

  
Mesh Shader: Vertex Normal Display: On 
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Depth Point Shading X-Ray Point Shading 

 

None – If a point cloud has color or normal information and the Texture or Normal option is 
checked, the point cloud is shaded from the direction of the light source. If you turn off Texture 
or Normal, all points are displayed as the same color without shading. 

 
 

 
 

None with Normal None without Normal 
 

Depth – This is the default shading method. From the origin viewpoint, the closer a point is, the 
darker the color of the point will be. If the point is located farther away, the color of the point 
will become lighter. If you click the Set button, you can define the range of depth by using the 
adjustable slider. If points are out of the specified range of depth, they will disappear from the 
Model View. The Depth function can be used to focus on a particular area by removing other 
unwanted areas from the range of depth. 

 
 

 
 

None Depth 
 

When the point cloud has normal information, depth shading is available along with vertex 
shading. Depth shading and vertex shading display the point cloud with enhanced three-
dimensional effects so that you can easily distinguish the front of the solid body from the back. 

 
 

 
 

Depth Shading without Vertex 
Normal 

Depth Shading without Vertex 
Normal 
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Note:  

To create normal information for point clouds during importing, check the Normal 
checkbox in the Import dialog box. 

You can enable or disable vertex shading by checking or unchecking the Normal 
checkbox in the Display tab. 

 

  
X Ray – Using this point shader setting helps to focus on an area of interest by making closer 
and farther areas transparent. To define the transparent areas, click the Set button. The Near 
and Far areas will be transparent and the Middle area will be clearly displayed. For example, if a 
scanner scans a building, it can be difficult to see the inside because of the outer walls. You can 
use the X-Ray function to make the outer walls transparent, thus letting you see inside clearly. 

  
X-Ray Default After Adjusting X-Ray Depth 

 
The X-Ray shading method makes points transparent in a certain range. When trying to select 
points, points nearer to the viewing direction are selected first even if they are invisible. 
Therefore, this method should be only be used for data viewing purposes. 

 
Height – With the Height option enabled, as the height increases on the Z axis, the color of data 
points change. Using this shading method, you can easily distinguish where the ground is as 
well as other height-specific features. If you click the Set button, you can modify the colors 
shown. 

 
Height 

 
Color Bar 

 
 
Vertex - If the Vertex option is checked, poly-vertices are drawn. 
 
Edge - If the Edge option is checked, poly-edges are drawn. 
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Face - If the Face option is checked, poly-faces are drawn. 
 
Texture - If the Texture option is checked, textures are drawn on a mesh. 
 
Normal - If the Normal option is checked, normal information is used for shading point clouds. 
 
Boundary – Shows or hides the boundaries of meshes. If you choose User Defined, you can display 
boundary colors as set in Preferences. This option is available only for open meshes. 

  

Boundary Enabled Boundary Disabled 

  
As Is User Defined 

 
 
Suppressed - This option enables you to show / hide suppressed scan data. 
 
Vertex size – Determines the display size of the vertex. 

  
Vertex Size: 1 Vertex Size: 2 

 

Note:  

When trying to see a more detailed image of a point cloud, increasing the point size will cause 
the points to overlap, looking more like a mesh. 

 
 
Dynamic Display Ratio - To change the amount of data displayed when a model is in motion, select a 
value in the Dynamic Display Ratio box. This option is enabled only when Dynamic Draw is checked. 

  

Dynamic Display Ratio: 5% Dynamic Display Ratio: 50% 
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Static Display Ratio - To change the amount of the data displayed when a model is static, select a 
value in the Static Display Ratio box. 
 

Region 

Geometry Type – If All is selected from the drop-down box, all geometry types are displayed. If 
Selected only is selected only selected geometry types are displayed. 

  

All Selected Only (Cylinders) 
 
 

Body 

Display Mode – Determines how the body is displayed. Wireframe draws only edges of faces. Hidden 
Line draws all hidden lines. Shaded draws shaded faces. Shaded With Edges draws shaded faces with 
edges. 

  
Hidden Line Wireframe 

  
Shaded Shaded With Edge 

 
 
Resolution – You can set the display resolution of bodies with this option. You can set the resolution 
level from 0 to 10. 
 

   

Resolution: 0 Resolution: 5 Resolution: 10 
 

Note:  
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CAD objects may be displayed as a low resolution graphical mesh. If faceting occurs, then the 
resolution may need to be increased to display the CAD object correctly. 

 
 

Sketch & 3D Sketch 

Constraint – If this option is checked, sketch constraints are displayed while drawing. 

  
Enable Constraint Disable Constraint 

 
Constraint Options 

 Coincidence  Parallel 
 Perpendicular  Constraint Fix 
 Concentric  Conversion 
 Tangent  Horizontal 
 Mid Point  Vertical 
 Equal Length  Linear Pattern 
 Equal Radius  Circular Pattern 
 Cordial  Symmetry 
 Collinear  Angular 
 Pierce   

 

Note:  

The color of the constraint icon’s background will be different based on its condition. If you 
can only snap on the entity, the icon background color will be displayed in white . If you 
can snap and give a constraint to the entity, the icon background will be displayed in yellow 

. After creation of an entity, the icon background will be displayed in blue . If the entity 
is overly constrained, the background color of the icon will be displayed in red . 

 
 
Control Polygon – If this option is checked, control points are displayed on splines. 

 
 
3D Spline Node – If this option is checked, node points are displayed on 3D splines. 

 
 

Enable 3D Spline Node Disable 3D Spline Node 
 
 
2D Section Points – If this option is checked, points which are extracted by the Mesh Sketch function 
with the Silhouette option are displayed. 
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Show 2D Section Points Hide 2D Section Points 

 
 
2D Section Polylines – If this option is checked, polylines which are extracted by the Mesh Sketch 
function are displayed. 

  
Show 2D Section Polylines Hide 2D Section Polylines 

 

 
 
 

6.5.3. Accuracy Analyzer 
The patent-approved Accuracy Analyzer™ shows real time deviation analysis while you are 
designing, so you can ensure your finished model is faithful to the original 3D scan. It also saves time 
because you never have to leave the application to check your modeling accuracy.  
 
Accuracy Analyzer(TM) works in any mode except the Region Group mode. You can compare 
designed bodies, curves, sketches or meshes with a base entity such as a base mesh or a base point 
cloud. The options enable you to analyze curvature, torsion, environment mapping, iso-line, and 
continuity to generate high quality surfaces and curves. 
 
 

How to open the Accuracy Analyzer (TM) panel 

If the Accuracy Analyzer(TM) panel is closed, use the pop-up menu on the tool palette and choose 
Accuracy Analyzer(TM). 
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Options in Detail 

 

Type 

None - If None is selected, nothing is analyzed. This is the default state. 
 
Deviation – Shows a deviation map between a created entity (body, sketch, curve or mesh) and its 
base (mesh or point cloud). For example, if you design a body based on scan data, you can select the 
Deviation option to check the deviation between the created body and actual scan data. You can 
easily confirm the accuracy of your body. 

 
 
The Deviation has two options: Color Map and Vector. 
If Color Map is selected, results will be displayed as a colored map on the created entity (body, 
sketch, modified mesh). If the Deviation Type is Vector, the results will be displayed as 
displacement vectors. 

  
Deviation color map in the Default 

mode 
Deviation vector in the Default mode 

  
Deviation in the 3D Mesh Sketch mode Deviation in the Mesh mode 

 

Note:  

If you try to create a concave fillet and check the deviation while previewing the fillet in Default 
mode, the deviation may not be shown because the fillet is under the body. In this case, make 
the body transparent or display it as a wireframe. 
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If you are in Mesh mode, you can see the following drop down option list. You can compare edited 
mesh with specified mesh using an option from the list. 

 
 
Curvature - Displays the curvature flow. Curvature is the amount by which a geometric object 
deviates from being flat. This is available for curve, body and mesh. 

 

  
Curvature on a Curve Curvature on a Body Curvature on a Mesh 

 
The position on the 2D curve has a single curvature value. However, the position on 3D surface has 
many curvature values according to its sectional the direction on the position. 

  
Curvature on 2D Curvature on 3D 

 
If the Min. option is selected, the minimum curvature value at each position will be displayed. If the 
Max. option is selected, the maximum curvature value at each position will be displayed. If the Mean 
option is selected, the mean value of Min. and Max. Curvature value at each position will be 
displayed. If the Gaussian option is selected, the multiplication of Min. and Max. will be displayed. 
 
Torsion - The torsion of a curve measures how sharply it is twisting. This option is available only in 
the 3D Mesh Sketch and 3D Sketch modes. 

 
 
Continuity - This method is useful when inspecting how smoothly connected faces are. If this option 
is checked, analyzed results are displayed on the edges using color. If Position is selected, the 
positional continuity is displayed on the edges. You can check G0 continuity which defines that 
positions are continuous. If Tangency is selected, the tangential continuity is displayed on the edges. 
You can check G1 continuity which defines positions and face normals as continuous. If Curvature 
is selected, the curvature continuity is displayed on the edges. You can check G2 continuity which 
defines that positions, face normals and curvatures are all continuous. 
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Iso Line - If this option is enabled, Iso lines are displayed on body faces. The flow of Iso lines on a 
face determines its surface quality. 

 
Disable Iso Line 

 
Enable Iso Line 

 

Note:  

Fewer isolines will result in a smoother surface; while increasing the number of isolines could 
introduce noise or waviness. 

 
Environment Mapping - Environment mapping is used to examine the quality of body faces or 
meshes. You can use different textures for mapping to examine surface quality. The Sphere type 
uses a single texture containing the image reflected by a ball-shaped mirror. The Cube type uses a 
single texture or six square textures containing the reflected image on six faces of a cube. Under the 
Texture option, you can choose an image which will be used for environment mapping. True Sphere 
shows black and white stripes and it is normally used for inspection of surface quality. 

 
 
Disjoined Ends - Highlights unconnected points on a sketch as shown in the image below. This 
option is available only in the Mesh Sketch and Sketch modes. 

 
 
 

Allowable Tolerance 

Allowable Value - You can define the Low, High and Color values for the tolerance range. If you do 
not check the Hide Allowable Tolerance option, areas within the tolerance range will be colored 
green by default. 
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Deviation Option 

Deviation Option - Deviation is calculated within specified Max. Distance and Max. Angle values. 
Max. Distance sets the deviation distance within a specified distance between a target entity and a 
base entity. The  icon automatically recommends a maximum distance. Max. Angle limits the 
angle deviation between the normals of target entities and a base entity at a position. 
 
Fine Sampling – Calculates deviation more accurately but may increase calculation time. 
 
 

Color Map Resolution 

Color Map Resolution - You can adjust color map resolution from low to high with the slider. 

 
Resolution: Low 

 
Resolution: High 

 
 

Vector Resolution 

Vector Resolution – Defines the amount of vectors. This option is available when Deviation 
method is set to Vector. 

  
Vector Resolution: Low Vector Resolution: High 

 
 

Vector Multiplier 

Vector Multiplier - Vector multiplier is used to adjust vector length. This option is available when 
Deviation method is set to Vector. 

  
Vector Multiplier Value: 1 Vector Multiplier Value: 2 

 
Auto – Automatically sets the multiplier value to the same value as the current model zooming level. 
 
 

Auto Adjust Color Bar Range 

Auto Adjust Color Bar Range – Automatically adjusts the minimum and maximum values of the 
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color bar within a suitable range. 

  
Before Auto Adjust After Auto Adjust 

 

Note:  

If you have multiple solid or surface bodies and want to check the accuracy of each 
individually, select a body in the Model Tree and use the Accuracy Analyzer. 

 
 
 

6.5.4. Help 
In this tab, you can find the online help file separated into two tabs for Contents and Index. In the 
Contents tab, you can find information on all of the commands in the application. To quickly find a 
command, go to the Index tab, and input key words related to it.  
 
To see the main contents of help guide, press the F1 key while using a command or in any mode. 
The F1 key by default will open the contents help guide. This will display the help document for the 
particular command or mode that is being used. 
 

Note:  

You must be in an active command or in an activate mode to use the F1 function. Otherwise, the 
intro document page will be displayed if the F1 function is used for the first time or the last help 
page viewed. 

 
If you want to go back to the working area, click the Model View tab at the bottom of the workspace 
window. 
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6.5.5. Viewpoint 
 
Viewpoint manages user-defined points of view with models and shown entities. It is useful for 
going back to certain viewpoints. When a viewpoint is selected, entities that exist in the selected 
viewpoint are displayed in Model In Viewpoint. The following images shows when Viewpoint5 is 
chosen in the Viewpoint panel that its entity state is also shown in the Model In Viewpoint panel. 

           
 
 

Options in Detail 

 Add Viewpoint - Adds a new viewpoint to capture the current view state. 
 

  Apply Viewpoint - Changes the viewpoint to a selected viewpoint. Double-clicking a 
viewpoint will have the same results. 
 

 Show Only Selected Viewpoint - Changes the visibility of entities to the selected viewpoint. 
 

 Reassign Viewpoint – Reassigns a selected viewpoint to the current view state. 
 

 Delete Viewpoint - Deletes the selected viewpoint. 
 

 Zoom - Determines the size of the thumbnail image. 
 

 Export Viewpoint - Exports the selected viewpoint to an image file. 
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6.5.6. Properties 
 
The Properties window displays the properties of a selected object. The properties of the object can 
be modified using this window. 

 
 
The Calc. buttons are used to calculate the volume, area and mass center of an object. The following 
list shows the calculation buttons available for each entity. 
Mesh: Area, Volume, Mass Center (when the volume of an open mesh is measured, the title will be 
shown as ‘Approx. Volume’) 
Point Cloud: Mass Center 
Region: Area 
Region Group: Area 
Poly-Face: Area 
Solid Body: Area, Volume, Mass Center 
Surface Body: Area, Mass Center 
Body Face: Area 
 
When a mesh/point cloud is selected, its geometry information (scanner position, scanner direction 
or scanner center) can be confirmed as its scanner type in its Properties panel. 

 
 
When the position of a mesh/point cloud is transformed to another position, the transformation 
matrix can be exported in the .trm file format and used for other applications by clicking the Export 
button in the Result section.  
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The exported transformation matrix can be used with other scan data files that have been scanned 
in the same position or to model bodies into desired positions easily. For more information, see Tools 
> Scan Tools > Transform Scan Data. 
 
 

6.5.7. Color Bar 
 
The Color bar is used to view the deviation in created entities. The color bar looks like the following 
image. 

 
 
 

Editing Color Bar 

 
The color bar can be edited based on the current project and its tolerances. 
 
 

Changing limits 

A color segment is the area of the color scale between two cursors. Within a color segment, 
numerical values are mapped linearly to colors. They are the color scale’s limits to define the value 
range of colors used for deviation. These limits can be modified by double-clicking the numerical 
values and entering new values through their related text boxes. New values are made effective by 
pressing the Enter key.  
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Splitting a color segment 

A color segment can be subdivided by selecting the Split pop-up menu on the color segment. A new 
segment is then created on top of the current segment. 

 
 

Deleting a color segment 

A color segment can be deleted by selecting the Delete pop-up menu on the color segment. 
 
 

Copying a color segment 

A color segment can be copied by selecting it, right-clicking, choosing Copy, and then Pasting it into 
another color segment. Alternatively, a color segment can be copied and pasted by using the Ctrl + 
C and Ctrl + V shortcut keys. 

 
 

Inspect Color Picker 

If you select Edit Color from the pop-up menu on a color segment or double-click it, a Color Picker 
dialog box will appear. Note that a tolerance color cannot be edited by the color picker.  
 
 

Construction 

The Color Picker consists of a color mode, a grayscale mode, Option, RGB and HSB; the color mode 
and the grayscale mode can be changed by left-clicking in the appropriate control sector. 

 

• Color mode 

In pinwheel-shaped color mode, the Hue, Saturation, and Brightness properties are defined by 
moving two squares using the left mouse button and mapping them to the currently-selected 
segment.  

The Hue property is defined by choosing a color section. The Saturation property is defined by 
moving the squares to the outside of the section from the center, and the Brightness property is 
defined by moving the squares to the inside of the section from the center. 

 



Geomagic Design X | User Interface  115 
 

 
 

• Grayscale mode 

In the grayscale mode, the Brightness property is defined by positioning two squares by using the 
left mouse button. After positioning, the white-black gradient will be mapped to the currently-
selected segment. 

 
 

• Option 

In the Option section, the editable box next to the Colors option defines the number of colors and 
gradients of the currently-selected segment. You can change it by typing in the box and 
confirming with the ENTER key or by dragging the slide bar. The maximum number is 100.  

The Reverse checkbox makes the color gradient of the currently-selected segment inverse. The 
first and last segments of the color bar can only use one color each, so you must select them by 
using the square selectors in both the color and grayscale modes. 

 

• RGB and HSB 

The RGB and HSB sections show the current color properties. The properties can be changed by 
editing the number boxes. 
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Making a color bar 

For a single color gradient, position one of the squares to define the Hue and Saturation properties. 
If you move the mouse cursor around the line of the selected color, the other square will be 
automatically snapped to the line. Finally, position the snapped square on the line to define the 
Brightness property. Both squares can then be moved along the created line to fine tune if necessary. 

 
 
For the fixed brightness gradient, first position a square to define the Hue and Saturation properties 
and position the other square to define the Brightness property. If you position the other square 
while holding down the Shift key, the color can be changed while keeping the brightness at a fixed 
value. 

 
 
 
 

6.5.8. Support 
 
The Online Support Page of the Support panel provides direct access to Geomagic’s web-based 
support data base. It contains useful technical tips, tutorials, FAQs and other information. 
Feedback and comments can be left for Geomagic products which are useful for enhancing 
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performance and functionality. 
You can also access the Online Support Page via your web browser at: 
http://rapidform.zendesk.com 
 

 
 

Note:  

If you want to see this Support page when the application starts, go to the General tab in File > 
Preferences, and set ‘Show Support At Startup’ to True. 

 
 

Reporting a log file 

The log file records all actions while using the application. If you meet a sudden error, this file can be 
helpful for the developers in troubleshooting. Sometimes it is necessary to send this file with a bug 
report. 
 
To generate a log file; 
1. Run Log_rfXORedesign.bat located in the installation folder of the application. 
2. Use the software and try to recreate the event that you experienced. 
3. Once finished, the log file is generated in the Logs folder under C:\Documents and 
Settings\system name\My Documents\product name. 
 
 
 

6.5.9. Image Folder 
The Image Folder stores images that are captured in the application. You can capture images by 
using File > Capture Screen. 
 

http://rapidform.zendesk.com/
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Display Types 

In the Image Folder, you can choose between two display types; Thumbnail View and Filmstrip View. 

 
Thumbnail view 

 
Filmstrip view 

 

Images can be navigated through by using the forward and backward  buttons. They 
can also be rearranged by dragging and dropping them between other images. 
 
If you right-click on a thumbnail, the following pop-up menu will appear. 

 
 
Delete – Deletes the captured image. 
 
Export –Exports the thumbnail to another format like jpg, bmp etc. 
 
Copy to clipboard – Copies the image to the clipboard. 
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6.5.10. Console 
 
The Console panel shows you the detailed results of an operation. For example, the results of the 
Tools > Mesh Tools > Healing Wizard operation shows detailed information about healed poly-
faces. 

 
 
If you click the right mouse button on the Console window you can select one of the following 
commands:  
Copy Selection Only – You can copy a selected list. 
 
Copy All – You can copy all lists. 
 
Clear – You can clear all selections. 
 
 
 

6.5.11. Error List 
 
The Error List lists errors that occurred during a modeling process as well as errors that occurred 
while exporting models to other CAD systems. The errors can be confirmed by using the Edit > 
Rebuild command or by using the File > LiveTransfer(TM) command. The descriptions of the errors 
in the Error List can be used to diagnose and correct them. 

 
 
Show Rebuild Failure – Shows errors or warnings that occurred during a modeling process. This 
option is enabled by default. 
 
Show live Transfer Failure – Shows unsupported features that cannot be directly transferred (File 
> LiveTransfer(TM)) to other CAD systems. This option is enabled by default. 

 
 
These errors are marked in the Feature tree: 
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CAD Compatibility – Select one of the applications to check for errors when performing the 
LiveTransfer operation to selected applications. 
 

Note:  

When the “Show LiveTransfer Failure” option is on and “CAD Compatibility” is chosen, you can 
check for failures while adding or editing features. If there is an error, you might get a dialogue 
box stating the error, such as the one shown below: 

 
 

 
 
 

6.5.12. Profile View 
 
The Profile View enables you to interactively edit the modeling parameters of an executed 
command. The Profile View appears when you run the Fillet (Variable and Conic Option), Helix and 
Spiral commands. 
 
 

Editing Parameters 

You can see a line or connected lines in the Profile View and edit them by adding and manipulating 
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control points or manually input values by clicking the value directly. To add a control point, click a 
point on the line. To remove a control point, select the control point and use the Delete key or drag 
it outside of the line. You can also Undo (Ctrl + Z) or Redo (Ctrl + Y) an operation in the Profile View. 

 
 
 

Control Viewing 

Zoom – Scroll the mouse wheel. 
 
Pan – Use the LMB, or the Scroll Bar. 
 
Scale (Y Direction) – Use Shift + LMB or move the top or bottom edges of the scroll bar. 

 
 

Note:  

If you click the down arrow  button at the right top corner of the Profile View, you can access 
additional functions. 

 
 
 
 

6.6. Viewing Window 
 
The View Window is the main workspace. A model is displayed and manipulated in this area. It 
supports multiple views, which can include 4 different views in four layouts of 3 views and two 
layouts composed of 2 views. At the bottom of the view window, there are several Tabs such as 
Model View, Support, Help, Image Folder, etc. 
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6.7. Dialog Tree 
 
When a command name including an ellipsis “…” is selected, a corresponding dialog tree appears in 
the viewing window. According to prerequisite conditions, some controls might be enabled or 
disabled. 
 
 

Common Style Command 

The following is common format of dialog tree. 

 
 
 

Expand or Collapse 

The drop down arrow  Icon or the Tilde ( ~ ) button on the keyboard can be used to expand or 
collapse a dialog tree. 
 
 

Auto Hide 

If the pin button  is enabled, whenever the user moves the mouse cursor away from the dialog 
tree, it is automatically collapsed. When the mouse cursor is near the dialog tree it is expanded. This 
behavior is useful as you can maximize available space to view the model. If the button is disabled, 
the dialog tree is always expanded irrespective of the mouse position.  
 
 

Reuse Command 

The Don’t’ Quit Command With OK Button  preserve the opened command even you click the 
OK button so that you can continuously use that command. 
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Preview 

The Preview button  enables you to preview the result of an operation before you apply the 
command to a model. If it is clicked, the Accept button  and Restore button  are enabled.  
 
 
 

OK 

When you directly click the OK button , the command is accept and quit the command. Unser 
some commands it is automatically changed to the Break button   so that you can stop the 
command while it is being performed. Also you can use the ESC key to stop the process. While the 
command is being performed, the dialog tree is disabled and you cannot modify any options or 
parameters. 
 
 

Stage Style Command 

 
Click the Next Stage button  to go to the next phase of the procedure. Click the Previous Stage 
button  to go to the previous phase again. 
 
Under the some stage style commands, Apply button  enabled and this button just applies the 
sub-method under the command. If you click the OK button  on the top level, settings in each 
stage will be applied and quit the command. 
 
 

Folded Style 

 
The plus and minus icons,  and , allow the dialog tree to be folded or unfolded or to control 
various parameters. Click the plus icon  in front of More Options to access more options. 
 
 

Input Values Manually 

 
Click the Flip Direction icon  to flip the direction of a parameter. Click the Measure Distance 
icon  to measure distance and input an alternate value if necessary. Click the Measure Radius 
icon   to measure radius and input an alternate value if necessary. The Measure Distance and 
Measure Radius commands are the same as Measure > Distance and Measure > Radius in the top 
menu. To select a position on a line or plane, hold the Ctrl key and pick a point. To average a 
measured value, use the Shift key and measure. 
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Input Values Automatically 

 
When the value is set to Auto, the application automatically estimates the adaptable value 
considering of the model size and the noise. If you set to “0”, it will be the same as Auto. 
 
When you click the magic wand Estimate icon , the input value will be recommended by the 
application.  
 
 

Selection 

 
The yellow boxed button  is currently activated button that is ready to accept your 
selected entities. If you change the selection on another button, click another button and this button 
will be activated. 
 
To reset all selected entities, click the Select None button . To cancel the selected entity one by 
one, click the Deselect Last button . 
 
 

Add and Remove 

  
Click the Add icon   to add an additional instance of controls. Click the Remove icon   to 
remove an instance of controls. 
 

 
Click the All icon  to select all entities. 
 
 

Operation 

 
The Edit Control box for a floating-point number allows you to input a numerical value or a numerical 
formula. The available symbols and functions are as follows: 
-  A numerical formula that starts with an equal “=”. 
- plus(+), minus(-), multiplication(*), division(/), power(^), factorial(!), square root(sqrt), absolute 
value(fabs), trigonometrical function(sin, cos, tan, sec, cosec, cot, sinh, cosh, tanh, asin, acos, atan), 
exponential(exp), or logarithmic(log, ln) function. 
- No distinction between capital letters and lowercase letters. 
- Spacing is ignored. 
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6.8. Monitoring 
 
 
 

6.8.1. Status Bar 

 
 
The Status Bar shows an explanation of a selected command and the progress of an executed 
command. 
 
 
 

6.8.2. Progress Bar 
 

 
Progress of the current operation is shown in the Progress Bar. The progress will be displayed as a 
numerical percentage. 
 
 
 

6.8.3. Time Indicator 
 
You can check the Total Time, Operation Time, Current System Time, as well as Reset Time for 
the application by right-clicking on the time indicator. 

 

 
The total time is the time spent in a session. Operation Time is the time spent on one specific 
operation. Current System Time is the computer clock time. If Reset Time is clicked, the time is 
changed to 0:0:0. 
 
 
 

6.9. Esc Key 
 
To cancel a current operation, press the Esc key. It is same as clicking the Break button .  
The Esc key cancels the command execution and deselects all the currently selected entities. 
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6.10. Mouse Control 
 
The mouse is the main device for controlling the application. Clicking buttons or objects with or 
without certain keyboard “modifier” keys alters the way you create, select, move, edit or view models 
on the screen. For simplicity, we have used specific instruction conventions within this manual: 
 
Left-click means press and release the Left mouse button. 
 
Middle-click means press and release the middle mouse button. 
 
Right-click means press and release the right mouse button. 
 
Double-click means rapidly click the left mouse button twice. 
 
Drag means click and hold down the left mouse button and move the mouse while continuing to 
hold the button down. 
 
The mouse actions and mouse action modifiers appear in the following table. 
 

Mouse Button Action Usage 

Left 

 

Left-click - selects a single item, button or icon 
- run menus and select options 

Double-click - open the properties of the node in the model. 
- make a docking window float, or vice  versa 

Shift + Left-click - select multiple items 

Ctrl + Left-click - deselect items 

Drag 
- rotate (in viewing mode after middle-clicking) 
- select multiple items 
- move toolbar, window, dialog tree or dialog box 

Shift + Drag - zoom (in viewing mode after middle-clicking) 

Ctrl + Drag - pan (in viewing mode after middle-clicking) 

Middle 

 

Middle-click - run the Pause command for switching selection 
mode to viewing mode, or vice versa 

Scroll wheel - dynamic zoom in/out 

Right 

 

Right-click - access pop-up menus which contain a context-
sensitive set of frequently used functions 

Drag - rotate 
Left + Right-click + 
Drag  - pan 

Ctrl + Drag - pan 
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If your mouse position is near a border in the Model View and the model can be rotated, the cursor 

changes to the rotate icon;   

 
 
 
 

6.11. Shortcut Keys 
 
The shortcut keys provide quick access to the most commonly used commands. Keyboard shortcuts 
offer an alternative method of performing actions for users who prefer the keyboard to the mouse. 
Some of the commands in the application have default shortcut keys. You can define your own 
shortcut keys using the Customize menu on the toolbar. 
The following is a list of default shortcut keys in the application. 
 

File menu Shortcut Key 

New Ctrl + N 

Open Ctrl + O 

Save Ctrl + S 

Print Ctrl + P 
 

Select menu Shortcut Key 

All Shift + A, Ctrl + A 

None Shift + N, Ctrl + D 
 

Inverse Shift + I, Ctrl + Shift + I 
 

Edit menu Shortcut Key 

Undo Ctrl + Z 

Redo Ctrl + Y 

Repeat Last Command Ctrl + Space 

Cut Ctrl + X 

Copy Ctrl + C 

Paste Ctrl + V 

Delete Delete 
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View menu Shortcut Key 

Zoom Area Shift + Z 

Zoom Previous Area Shift + X 

Zoom Fit Ctrl + F 

Zoom PIP Ctrl + W 

Mesh Display Mode > Point Set F5 

Mesh Display Mode > Wireframe F6 

Mesh Display Mode > Shaded F7 
Mesh Display Mode > Shaded 

Wi h Ed  
F8 

Mesh Display Mode > Region F9 

View > Viewpoint > Front Alt + 1 

View > Viewpoint > Back Alt + 2 

View > Viewpoint > Left Alt + 3 

View > Viewpoint > Right Alt + 4 

View > Viewpoint > Top Alt + 5 

View > Viewpoint > Bottom Alt + 6 

View > Viewpoint > Isometric Alt + 7 

View > Viewpoint > Align View Ctrl + Shift + A 

View > Visibility > Meshes Ctrl + 1 

View > Visibility > Regions Ctrl + 2 

View > Visibility > Point Cloud Ctrl + 3 

View > Visibility > Surface Bodies Ctrl + 4 

View > Visibility > Solid Bodies Ctrl + 5 

View > Visibility > Sketches Ctrl + 6 

View > Visibility > 3D Sketches Ctrl + 7 

View > Visibility > Points Ctrl + 8 

View > Visibility > Vectors Ctrl + 9 

View > Visibility > Planes Ctrl + 0 

View > Visibility > Smart Visibility Alt + Space 
 

Etc Shortcut Key 

Auto Hide Docking Bar F12 

Help Context F1 

Break Command Esc 

Apply Command Return 

Repeat Latest Command Ctrl + Space 

Shrink Dialog Tree `( Single Quote) 
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6.12. Pop-up Menus  
 
In the application view, if you right-click you can see access pop-up menus. The pop-up menu that 
appears is based on the mode and current view. 
 

Viewing mode ( ) 

If you are currently in the viewing mode ( ) and right-click the mouse, you can see the following 
menu. 

 
 

Zoom Fit - If selected, fits the model to the entire viewing window. 
 
Zoom Area - If selected, zooms the viewing area in on a selected rectangular region. 
 
Zoom PIP – If selected, enlarges a view at the position of the mouse cursor . 
 
Zoom To Selection – If selected, selected entities are fitted in the graphic area. 
 
Align View – If selected, you can align the view respective to the selected planar 
entity. 

 
 

Selection mode ( ) 
If you are currently in the selection mode ( ) and if you right-click in an empty area, you will see 
the following pop-up menu. 

 
 

 
 

Filter Only – You can directly access to Select Filter and limits the entity type. 
 
All – (Entity Type) - If selected, all entities of the current type will be selected. 
 
None - If selected, all selections will be released. 
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Inverse – If selected, current selection of the current entity type will be inversed. 
 
Edit View Clip – You can directly access to View > View Clip. 

 
 

After Entity Selection 

However, if you select a certain entity and access the pop-up menu, the command list as shown in 
the image below will be seen. The following image is the menu for Poly-Faces. 

 
 

Note:  

If you hold the Ctrl button and access a pop-up menu for the selection of an edge, you can see 
the Deselect Tangent Edges command instead of Select Tangent Edges. 

 
 
 

Selection on overlapped entities 

When there are overlapping entities in the Model View, it could be difficult to select an entity. In such 
cases, if you hold a left-click on an entity and release, the pop-up menu can be accessed. 
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6.13. 3D Mouse 
 

The application supports a 3D hardware device that can help in the modeling process. 
(3Dconnexion, http://www.3dconnexion.com) 
 
A 3D Mouse is a device similar to a joystick that allows intricate adjustments of camera views and 
models without repeatedly stopping to change direction, zoom, or rotate. It also provides 
movement controls with 6 degrees of freedom. Tilt up or down to move a model up or down. Tilt 
left or right to move a model left or right. Pull towards you or push away to move a model nearer 
or farther away. Orientate a model on the screen by simply twisting in any direction to rotate it 
around the X, Y or Z axes (pitch, roll, and yaw). 
 
The Customize dialog box by can be opened by using the RMB (Right Mouse Button) on the 
toolbar. Commands can be assigned to each button on the device, 

 
 
Configurations will be saved at the following location; C:\Documents and Settings\User 

http://www.3dconnexion.com/
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Name\My Documents\Product Name\Configure\configure\rfSpaceball.cfg 
 

Note:  

Depending on the device and the pre-set settings of some buttons, you may not be able to 
customize them. 

 

 
 
 

6.14. Quick Modeling  
 
Quick modeling is an semi-automated modeling process where the application analyzes geometric 
features and creates extrusions and revolutions from a mesh. Using this information a user can then 
decide to add new solid or surface bodies or cut existing bodies.  
 
A feature consists of regions, sketches, axes of extrusion or revolution, extrusion distances, or 
revolution angles. Geomagic Design X can find all elements of a feature automatically and generate 
it as a solid or surface body. The elements of a feature are registered as a normal sketch and body 
feature in the Feature tree, so they can be modified easily at any time. 
 
 

Quick Modeling Workflow 

 
 

• Import Mesh: 

Imports scan data which must be a mesh 

 

• Classify Region:  

Applies auto segmentation to classify regions 

 

• Analyze Features: 

Analyzes features internally after region grouping 

 

• Create Feature by User Choice: 
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Automatically creates extrusions, revolutions, fillet features and mesh fit surfaces from a selected 
area of a region. By adding or removing features details of a part can be created. Combined with 
other general surface or solid tools, a complete part can be made. 

 
 

How to Access the Quick Modeling UI 

General modeling processes can be accessed by targeted a region and using the pop-up menu. An 
appropriate wizard function will automatically initialize and the application will also intelligently 
provide sub-operations such as the merge or cut commands if there are existing bodies. 
 
The following functions are available: 

Insert/Merge – Creates a new solid or surface body or merges existing bodies 

Cut – Removes a feature from existing features 

Fillet – Applies filleting to features 

 

 
 
 

How to Recognize Feature Shapes and Create a Solid or Surface 

Body 

The application will choose and run a Modeling Wizard based on the feature shapes analyzed from 

selected regions. 

Extruded Feature Shape 
When an extruded feature shape is recognized from selected regions, the Extrusion Wizard will 
automatically run and it will find target regions on all sides. A proper extrusion direction will be 
recommended from extrusion direction candidates. For more information, see Insert > Modeling 
Wizard > Extrusion Wizard. 
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Revolved Feature Shape 

When a revolved feature shape is recognized from selected regions, the Revolution Wizard will 
automatically run and find target regions. A proper revolution axis will be automatically 
extracted from the target regions. For more information, see Insert > Modeling Wizard > 
Revolution Wizard. 

 
 
Freeform Feature Shape 

When a freeform feature shape is recognized from selected regions, the Mesh Fit command will 
automatically run and find target regions for creating features. For more information, see Insert 
> Surface > Mesh Fit. 
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7. Menu 
 
The topmost menus in Geomagic Design X are: File, Select, Edit, Insert, Tools, Measure, View, Add-
Ins and Help.  
 
Click on one of the menus. You may notice some of the menu choices are grayed-out and 
unselectable rather than in black and selectable. There are two possible reasons for this:  
-That particular command is not available for the current operation. 
-The appropriate prerequisite operations have not been performed. It’s sometimes necessary that 
you perform operations in a certain order. 
 
 
 

7.1. File 
The File menu is the first menu on the menu bar and includes commands to open new or existing 
files, import additional files into the application, save files, and take screen captures of models and 
the application. In the File menu, the default model settings and global options that affect all the 
objects in the viewing window can be altered. The Exit command, which closes the application, is 
also located in the File menu. 
 
 
 

7.1.1. File > New 
 

What 

The New File command creates a new file to use within the application. 
 
 

Why 

The New File command is useful for: 

• Creating a new file for a new project 

 
 

How to Use 

How to create a new file 
1. Go to File > New, click the icon in the toolbar, or use the Ctrl + N keyboard shortcut. 

 
2. A save file confirmation dialog box will appear for any existing open models that have 

been changed. A save confirmation box will not appear for models that had only simple 
changes made to it such as a view rotation. 
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3. Click Yes to save any open models. To proceed without saving any open models, click 
No. To cancel the New File operation, click Cancel. 

 
 

See Also 

File > Exit 
 
 
 

7.1.2. File > Open 
 

What 

The Open File command opens an existing xrl file. 
 
 

Why 

The Open File command is useful for: 

• Opening files native to the application 

• Opening files compatible with the application 

 
 

How to Use 

How to open a file 
1. Go to File > Open or click the icon in the toolbar, or use the Ctrl + O keyboard shortcut. 

 

Note:  

The application cannot open an .xrl file that was created in a newer version of the software. 

 
 

2. A save file confirmation dialog box will appear for any existing open models that have 
been changed. A save confirmation box will not appear for models that had only simple 
changes made to it such as a view rotation. 
 

3. Click Yes to save any open models. To proceed without saving any open models, click 
No. To cancel the New File operation, click Cancel. 
 

4. The Open dialog box will appear. Select the path of the file in the File Name box.  
 

5. Click Open to open the selected file or click Cancel to quit the command. 
 
 

Options in Detail 
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Include Display Preference – Includes the display preferences stored with an .xrl file that can 
also be accessed by going to File > Preferences. 
 
Show Preview & Info. – Shows a thumbnail preview of the last saved view of a selected .xrl file. 
 
Summary Information – Displays all entity information for a model being opened. 
 

Note:  

The summary information for a file can be set in the File Summary information box. 
 

 
 

See Also 

File > Save 
File > Save As 
File > Recent Files 
File > Exit 
 
 
 

7.1.3. File > Save 
 

What 

The Save File command saves an existing xrl file. 
 
 

Why 

The Save File command is useful for: 

• Saving files native to the application 

• Saving files compatible with the application 

 
 

How to Use 

How to save a file 
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1. Go to File > Save or click the icon in the toolbar, or use the Ctrl + S keyboard shortcut. 
 

Note:  

To save a copy of the current model use the File > Save As command. 

 
 

2. A dialog box will appear for any existing open models that are a format other than 
the .xrl format. This dialog box will not appear if the model was originally created in 
the .xrl. 
 

Note:  

The directory of the last saved file will be remembered and shown when the Save File 
command is executed. 

 
 

3. Input a name for the file and click Save to save the model or click Cancel to quit the 
command. 
 

Note:  

If a command is not finished, a rollback is being executed, or the model is in any mode, a 
prompt box will appear asking if the changes for that command want to be discarded. Finish 
the current command, rollback or exit the current mode to save, or click Cancel to cancel the 
save command. 

 

 
 

See Also 

File > Save As  
 
 
 

7.1.4. File > Save As 
 

What 

The Save As command saves a copy of the existing .xrl file. 
 
 

Why 

The Save As command is useful for: 

• Saving a file without closing it 

• Saving a file as a different file type 
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How to Use 

How to save a file using the Save As command 
1. Go to File > Save As or click the icon in the toolbar. 

 

Note:  

To save the current model without a copy use the File > Save command. 

 
 

2. A save as dialog box will appear 
 

3. Input a name for the file and click Save to save the model or click Cancel to quit the 
command. 
 

Note:  

The directory of the last saved file will be remembered and shown when the Save File 
command is executed. 

 
 

 
 

See Also 

File > Save 
 
 
 
 

7.1.5. File > TeamPlatform 
 

What 

The TeamPlatform command allows users to upload and download .xrl files to TeamPlatform, 
Geomagic’s web collaboration system. 
 
 

Why 

The TeamPlatform command is useful for: 

• Saving a project to the TeamPlatform system for sharing with other team members 

• Allowing collaboration on projects independent of time and space restrictions 

 
 

How to Use 
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How to upload a project to TeamPlatform 
1. Go to File > TeamPlatform > Upload. 

 

Note:  

To upload a file to TeamPlatform it must first be saved to the local PC. If a project 

is being uploaded for the first time a Save Model File dialog box will be displayed. 

 

 
 

2. Enter a valid email address and password then click the Sign In button. 
 

 
 

Note:  

Click the Sign Up link to create a new account if you do not have an existing account. 

 
 

3. Select a workspace to upload the file to after logging in. Navigate available workspaces 
and their subfolders using the left-hand navigation pane. 
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4. If necessary, click the To… button and select workspace members to send a comment 
to and input a comment in the comment box. 
 

 
 

Note:  

By default, all people in the workspace will receive any comments made. 

 
 

 
5. 

Click the Upload button to upload the project file to the selected workspace. The 
Cancel button can be used to stop an upload. 
 

Note:  

If the same file already exists in the TeamPlatform workspace and you try to upload the file 
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from another location a warningdialog box will be displayed. 

  
 

 

 

How to download a file from TeamPlatform and open it in the 
application 
1. Go to File > TeamPlatform > Download. 

 
2. Enter a valid email address and password then click Sign In. 

 

 
 

Note:  

If it is the first time signing into TeamPlatform, clikc the Sign Up link to create a new account. 

 
 

3. After logging in a dialog box will be displayed for selecting a Local Working Folder and 
parts from a workspace. Select a Local Working Folder. 
 

 
 

Note:  

All files in the Local Working Folder will have an accompanying .TP file with the same name. 
They are used to maintain TeamPlatform association and if a project file is moved to 
another location it is important to also move the associated .TP file with it. 

 

4. After selecting a Local Working Folder, navigate to the TeamPlatform workspace on the 
left pane of the dialog box and select a file to download. 
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5. 
 

Click the Download button. 
 

Note:  

If a file with the same name exists in the specified local folder, a dialog box asking to overwrite 
the local copy will be displayed. 

  
 

6. The file will be saved in the Local Working Folder then opened in the application. 
 

 
 

 
 

See Also 

File > Save 
File > Save As 
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7.1.6. File > Export 
 

What 

The Export command saves selected entities in various formats.  
 
 

Why 

The Export command is useful for: 

• Exporting a file into a different file type 

• Exporting a file into another program 

 
 

How to Use 

How to export a file 
1. Go to File > Export or click the icon in the toolbar. The application will show the default 

extension automatically in the Export dialog box which can be changed. Entities can be 
first selected then exported. 
 

Note:  

Supported extensions for selected entities are listed in the following table: 

Export File Entity 

Ex
te

ns
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n 

Fo
rm

at
 

Po
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t C
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/3

D
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r F
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Te
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xt
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Fa
ce

 

xdl XO Model Yes Yes Yes Yes Yes Yes    

mdl 
Rapidform 

Model 
Yes Yes Yes Yes Yes Yes Yes Yes Yes 

xpc 
Rapidform 

Extreme 
Point 

Yes         

pts 
Geomagic 

Point 
Yes Yes    Yes    

fcs 
Geomagic 
Polygon 

 Yes    Yes Yes   

icf 
INUS 

Compressio
n File 

Yes Yes    Yes Yes Yes Yes 

asc Ascii Points Yes Yes    Yes    
stl Binary STL  Yes        
stl Ascii STL  Yes        
obj OBJ  Yes    Yes  Yes Yes 
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dxf 
AutoCAD 

DXF 
Yes Yes  Yes 

Yes  
(Ref. 

Polyline 
Only) 

    

3ds 3D Studio Yes Yes      Yes  
wrl VRML 1.0 Yes Yes      Yes Yes 
wrl VRML 97 Yes Yes    Yes  Yes Yes 

ply 
CyberWare 

Binary 
Yes Yes    Yes    

ply 
CyberWare 

Ascii 
Yes Yes    Yes    

ptc Kubit Yes Yes    Yes    
ptc Leica Yes Yes    Yes    
igs IGES   Yes Yes Yes     
stp STEP   Yes Yes Yes     

x_t 
Parasolid 

Text 
  Yes Yes      

X_b 
Parasolid 

Binary 
  Yes Yes      

sat ACIS Text   Yes Yes Yes     
sab ACIS Binary   Yes Yes Yes     

model CATIA V4   Yes Yes Yes     
catpart CATIA V5   Yes Yes Yes     

 

 
 

Note:  

To export the file formats listed in the table below a Geomagic Exchange™ License must be 
installed: 

CAD File Extension 
Default 
Export 
Version 

Comments 

CATIA V4 .model CATIA 4.1.9   

CATIA V5 .CATPart, .CATProduct CATIA V5 R6 Unsupported assembly non-
ASCII character in the file name 

 

 
 

2. Click the OK button to export the selected entity or click the Cancel button to quit the 
command. 
 

 
 

Options in Detail 

 
 

Export Accuracy Analyzer Color Map Of Body As Mesh Format – Exports a body as a colored 
mesh. This option is available in the Export dialog tree when the Accuracy Analyzer™ is activated 
and a body has been selected. This option will not appear from the pop-up menu on the Model 



Geomagic Design X | Menu  146 
 

tree. 

  
 
Point or Polyline – Creates a poly-face mesh for AutoCAD. This option is available when 
exporting a mesh in the .dxf format. 
 
3D Face – Creates a 3D face mesh for AutoCAD. This option is available when exporting a mesh 
in the .dxf format. 
 
Use Custom Setting – Enables the Unit and Precision options. 
 

Unit – Defines a measurement unit for the entity to be exported. 
 

Precision – Sets the precision for exported files. This option is enabled when the 
precision of an imported point cloud or mesh is Double and exported in the ASCII format. 

 
Export Each Mesh As Separate File – Saves several meshes as individual files instead of a 
single file. 
 
Use Mesh Name – Saves each file with the name of the mesh. 
 
ICF Geometry Compression Ratio – Defines the resolution of a saved model. When Lossless 
is selected, geometry will be preserved as it is, but this can increase the size of a file. 

 
 

See Also 

File > Save 
File > Save As  
 
 
 

7.1.7. File > Publish  
 
The Publish menu publishes mesh through Internet Explorer by using the Point Stream and ICF 
publishing commands. 
 
 
 

File > Publish > Point Stream 
 

What 

The Publish Point Stream command publishes selected meshes and point clouds as a stream of 
points that can be viewed using the Internet Explorer browser. The RPS internet explorer viewer 
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plug-in is automatically installed when a PC is connected to the internet. 

 
 
 

Why 

The Publish Point Stream command is useful for: 

• Publishing a file into a Point Stream to be viewed in an Internet Explorer web browser 

 
 

How to Use 

A. How to publish a file as a point stream 
1. Go to File > Publish > Point Stream and select a mesh or a point cloud to publish.  
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2. Click the OK button to publish the mesh. An .html and .rps file will be created that is 

viewable in an Internet Explorer browser window. The same mouse and keyboard 
controls used to rotate, pan and zoom in the application are also used in the browser. 
 

3. To see the saved file, open the .html file. 
 
If this file is being used for the first time a dialog box used to install the RPS viewer plug-
in will be displayed. Click Install to install and proceed. 
 

Note:  

This plug-in is not supported on 64-bit Internet Explorer. 

 
 

4. To control viewing: 
Rotate: Left mouse button 
Pan: Ctrl + Left mouse button 
Zoom: Shift + Left mouse button or mouse wheel 

 
 

B. How to share a generated file 
Uploading on a website 
The simplest way is to upload both the RPS and HTML files to a webhost, usually with an FTP client, 
in the same folder. Then link to the HTM file's location 
 
To store the RPS and HTML file in a different folder, open the HTML file with a text editor and change 
the RPSFilePath parameter’s value to correct location. (Relative path from the directory of the HTML 
file is in). 
 
Inserting into another html file 
To insert the RPS view of your model into another web page, just copy tags everything in the HTML 
file from "<OBJECT>" to "</OBJECT>", and paste them into another HTML source file. 
 
 

Options in Detail 

Plug-in – Shows the download path for the plug-in. 
 
Version – Shows the current version of the RPS viewer. 
 
Width and Height – Shows the width and height of the viewing area of a file. 
 
HTML File Path – Specifies the name and directory of a HTML document to be generated. 
 
Background – Specifies the background color of the RPS viewer. The RGB value can be between 
0 and 255. The Use Texture option assigns a specific image as the background. 
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Without Texture With Texture 
 
Antialiasing – Enables or disables anti-aliasing when a model is in a static state in the RPS 
viewer. 
 
Zoom Limit – Controls the range of zoom-in. No Limit allows infinite zoom, Bounding Sphere 
allows zooming up to the boundary of a boundary sphere, Nearest Distances allows zooming 
to a nearest distance and Limit Factor scales zooming distance for the Bounding Sphere and 
Nearest Distance options. 
 
Launch Internet Explorer – Specifies if a .html file will be opened in Internet Explorer upon 
publishing. 
 

Using the Point Stream Viewer 

 
Shader Mode – Sets various shader mode settings. For more information, see Display tab page. 
 
Point Size – Defines the drawing size of points. 
 
Reset View – Resets the view to the default view. 
 
Model Information – Displays the Number Of Points and Size Of Model. 

 
 
Help – Displays the help panel. 
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About RPS Viewer – Displays the RPS Viewer information. 

 
 

See Also 

Tools > Publish > ICF 
 
 
 

File > Publish > ICF 
 

What 

The Publish ICF command publishes selected entities (point cloud, mesh, surface or solid body) in 
the .icf file format, enabling them to be viewed by the Internet Explorer browser. The ICF internet 
explorer viewer plug-in is automatically installed when a PC is connected to the internet. 
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Why 

The Publish ICF command is useful for: 

• Publishing a file into a .icf file to be viewed in the Internet Explorer web browser 

• Measuring distances on a model in a web browser 

 
 

How to Use 

A. How to publish a file as an .ICF file 
1. Go to File > Publish > ICF and select point cloud, mesh, surface or solid body to publish.  

 

 
 

2. Click the OK button to publish the mesh. A .html and .icf file will be created that is 
viewable in an Internet Explorer browser window. The same mouse and keyboard 
controls used to rotate, pan and zoom in the application are also used in the browser. 
 
Display properties of the web browser can be altered by changing the .html file that is 
created. 

 
 
The following table shows the parameter list you can use in the html code. 

PARAM NAME VALUE Default Value 
IcfPath Location of ICF file  
EnableDynamicDr "true" or "false"  "true" 
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aw 
DynamicDisplayR
atio  

"100", "50", "25", "10", "5", "1", "0.5", 
"0.1", “auto” (identical with the 
value of xo) 

"25" 

StaticDisplayRatio "100", "50", "25", "10", "5", "1", "0.5", 
"0.1"  (identical with the value of 
xo) 

"100" 

SHowColorBar "true" or "false"   “true” 
 
 

3. To see the saved file, open the .html file. 
 
If this file is being used for the first time a dialog box used to install the ICF viewer plug-
in will appear. Click Install to install and proceed. 
 

Note:  

This plug-in is not supported on 64-bit Internet Explorer. 

 
 

4. To control viewing: 
Rotate: Right mouse button 
Pan: Right + Left mouse button 
Zoom: Right + Left mouse button or mouse wheel  

 
 

B. How to share a generated file 
Uploading on a website 
The simplest way is to upload both the ICF and HTML files to a webhost, usually with an FTP 
client, in the same folder. Then link to the HTM file's location 
 
To store the ICF and HTML file in a different folder, open the HTML file with a text editor and 
change the "IcfPath" parameter’s value to correct location. (Relative path from the directory of 
the HTML file is in). 
 
Inserting into another html file 
To insert the ICF view of your model into another web page, just copy tags everything in the 
HTML file from "<OBJECT>" to "</OBJECT>", and paste them into another HTML source file. 

 
 

Options in Detail 

Plug-in – Shows the location of the plug-in codebase. 
 
Version – Shows the current version of the .icf viewer. 
 
Width and Height – Shows the width and height of the viewing area of the file. 
 
Fit Screen Size to Window on Resize – The viewer size is fully fit to the Explorer window size. 
When you adjust the Explorer window size, the viewer size is adjusted according to the Explorer 
window size. 
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HTML File Path – Specifies the name and directory of a HTML document to be generated. 
 
Enable Dynamic Draw – If checked, the Dynamic Display Ratio will be enabled. 
 
Dynamic Display Ratio – Changes the amount points drawn while a model is in motion. 
 
Static Display Ratio – Changes the amount points drawn while a model is static. 
 
Geometry Compression Ratio – Defines the resolution of the saved model. If Lossless is set, 
the geometry will be preserved as it is. However its file size will be much bigger than the reset 
settings. 
 
Launch Internet Explorer – Specifies if the .icf file will be opened in Internet Explorer upon 
publishing. 
 

Using the ICF Viewer 

 
Reset View – Resets the view to the default view. 
 
Fit Zoom – Fits the view to the screen. 
 
Show Model Tree – Shows the model tree. 
 
Auto Show / Hide Model Tree – Shows the collapsible model tree at left side. When you hover 
mouse cursor on the Show Model Tree, the tree appears. 
 
Viewpoint – Changes the viewing direction of the model. 
 
Point Size – Defines the drawing size of points. 
 
About ICFViewerXO2 Control – Displays the ICF Viewer information. 

 
 

See Also 

File > Publish > Point Stream 
 
 
 

7.1.8. File > Capture Screen 
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What 

The Capture Screen command creates a screen shot using a variety of methods. The captured 
images are registered in the Image folder. 

 
 
 

Why 

The Capture Screen command is useful for: 

• Capturing a model in its current state 

• Capturing an image of a model to use in another program 

 
 

How to Use 

How to capture a file 
1. Go to File > Capture Screen or click the icon in the toolbar. The Capture Screen dialog 

box will appear. 
 

Note:  

The captured images saved to the Image Folder can be set to be shown as thumbnails or 
filmstrip view. 

 
 

2. Select Current View as the Target method. 
 

3. Click the OK button to save the image to the Image Folder. 
 
 

Options in Detail 
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Current View – Captures the current view. 

 
 
Entire Model View – Captures the entire model view. 

 
 
Mouse Dragging Area – Captures the area defined by a mouse drag. 
 
Selected Window – Captures a selected window. 
 
Application Window – Captures an entire application window. 
 
White Background – Sets the background of the capture to white and is available if the Target 
is Current View, Entire Model View, or Mouse Dragging Area. 
 
Transparent Background – Sets the background of the capture to transparent and is available 
if the Target is Current View, Entire Model View, or Mouse Dragging Area. Transparent 
background is preserved when the exported image format is .tiff or .png. 
 
Custom Resolution – Sets a custom resolution with values between 20 and 8192 and is 
available if the Target is Current View, Entire Model View, or Mouse Dragging Area. 
 
Show Dialog Tree – Captures the dialog tree and is available if the Target is Current View, 
Entire Model View, or Mouse Dragging Area. 
 
Copy To Windows Clipboard – Copies a captured image to the windows clipboard, allowing 
pasting into other applications. 

 
 

See Also 

Docking Bars > Image Folder  
 
 
 

7.1.9. File > Print 
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What 

The Print command prints the active document.  
 
 

Why 

The Print command is useful for: 

• Printing a current project 

 
 

How to Use 

How to print a file 
1. Go to File > Print or click the icon in the toolbar, or use the Ctrl + P keyboard shortcut. 

 
2. Select the Printer, Print range and Number of copies. 

 
3. Click OK to complete the command. 

 
 

See Also 

File > Print Preview  
File > Print Setup  
 
 
 

7.1.10. File > Print Preview 
 

What 

The Print Preview command previews an active document before printing. 
 
 

Why 

The Print Preview command is useful for: 

• Previewing what a print-out will look like before printing 

 
 

How to Use 

How to print preview a file 
1. Go to File > Print Preview or click the icon in the toolbar. 
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2. A preview of the active document will be shown. 

 
3. Click Print to print the document or Close to exit without printing. 

 
 

See Also 

File > Print 
File > Print Setup  
 
 
 

7.1.11. File > Print Setup 
 

What 

The Print Setup command sets printer settings. 
 
 

Why 

The Print Setup command is useful for: 

• Changing printers 

• Changing printer properties 

• Changing paper size 

 
 

How to Use 

How to use print setup 
1. Go to File > Print Setup or click the icon in the toolbar. 

 
2. A preview of the active document will be shown. 
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3. Change settings and click OK to accept or Cancel to exit Print Setup. 
 
 

See Also 

File > Print 
File > Print Preview  
 
 
 

7.1.12. File > LiveTransfer(TM) 
 

What 

The LiveTransfer™ command directly exports whole or partial data created in the application to 
target CAD systems using the API (Application Programming Interface) for many different CAD 
systems. 

The LiveTransfer™ command transfers the geometries, topologies, modeling histories, and 
parameters of a modeling job to a CAD system that can then be edited. 

If features cannot be transferred into a CAD system while using the LiveTransfer™ command, the 
transfer will pause so that the features can be manually added into the CAD system. The transfer can 
be resumed afterward. 

The following figure shows the work flow of the LiveTransferTM function. 
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Pause

Is Last Feature?

Get Feature Properties

Get Next Feature

XOR First or Specified
Feature

Is there Entity-Type Parameter?

Find Matching Entity in CAD

Create Feature into CAD

Succeeded?

Yes

No

Yes

Yes

No

No
Stop

Create Matching Feature Manually in
CAD

Resume CAD IF in XOR

Is Suppressed?
Yes

No

 
 

Note:  

Setting the Preferred CAD as one of the following CAD systems: (SolidWorks, Siemens NX, Creo(Pro/E), 
AutoCAD, Inventor), or checking the Show LiveTransfer™ option in the Error list will allow the real-time 
analysis of feature compatibility. 

 
 

Why 

The LiveTransfer™ command is useful for: 

• Transferring data within the application to CAD systems 

• Transferring data easily using native CAD API’s 

 
Summary of CAD Compatibility in LiveTransfer™ 
Geomagic Design X LiveTransferTM supports SolidWorks 2006~2013, SIEMENS NX4~8, Pro/E 
Wildfire3.0~5.0, Creo Parametric 1.0~2.0, Creo Elements/Pro 5.0, AutoCAD 2007~2011 and 
Inventor 2010~2013. 
 
Table Legend: 
Yes: fully supported 
Possible: supported, but not all options 
Object: supported, but non-parametric as imported dummy feature 
Not Now: not support now, but will be supported in a future release 
No: downstream CAD software does not support the related API 
 

APPLICATION SolidWorks  
2006 + 

SIEMENS 
NX4 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 

Sketch 
2D (Mesh) Sketch Possible Possible Possible Possible Possible 
3D (Mesh) Sketch Object Object Object Object Object 

Solid 
Extrude Possible Possible Possible Possible Possible 
Revolve Possible Possible Possible Possible Possible 
Loft Possible Possible Object Possible or Possible or 
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Object Object 

Sweep Possible Possible Object Possible or 
Object 

Possible or 
Object 

Cut Possible Possible Possible Possible Possible 
Hollow Yes Yes Yes No Possible 
Offset No Yes No No Yes 
Thicken Yes Possible Possible No Yes 
Boolean Possible Possible No Possible Possible 

Surface 

Surface Extrude Possible Possible Possible Possible Possible 
Surface Revolve Possible Possible Possible Possible Possible 

Surface Loft Possible Possible Object Possible or 
Object 

Possible or 
Object 

Surface Sweep Possible Possible Object Possible or 
Object 

Possible or 
Object 

Reverse Normal No Yes No No Object 
Sew Possible Possible No No Possible 
Trim No Possible Possible No Yes 
Untrim Possible No No No No 
Trim & Merge Object No No No No 
Surface Offset No Possible Object No Object 
Extend Surface Object Object Object Object Object 
Auto Surfacing Object Object Object Object Object 
Fit Boundary Object Object Object Object Object 
Mesh Fit Object Object Object Object Object 
Fill Face No No No No Possible 

Modeling 
Feature 

Fillet Possible Possible Possible Possible Possible 
Chamfer Possible Possible Possible Possible Possible 
Draft Possible Possible Possible No Possible 
Mirror Possible Possible Object Object Possible 
Delete Face Possible No No No Possible 
Move Face Possible Possible No No Possible 
Refit Face No No No No No 
Replace Face Possible Possible Possible No Object 
Linear Pattern Possible Object Object Object Possible 
Circular Pattern Possible Object Object Object Possible 
Curve Pattern Possible Object Object Object Object 
Transform Body Possible No No No Possible 
Duplicate Body Yes Object No No Object 
Remove Body Yes No No No Yes 
Split Face Possible Possible No No Possible 
Helix Object Object No No Object 
Spiral Object Object No No Object 
Emboss Possible Possible No No Possible 

Reference 
Geometry 

Ref. Point No Possible or 
Object 

Possible or 
Object No Object 

Ref. Vector Possible or 
Object 

Possible or 
Object 

Possible or 
Object No Possible or 

Object 

Ref. Plane Possible or 
Object 

Possible or 
Object 

Possible or 
Object No Possible or 

Object 

Ref. Coordinate No Possible or 
Object 

Possible or 
Object No Possible or 

Object 
Ref. Polyline No No No No No 

Object Body Object Object Object Object Object 

 
 

Details of CAD Compatibility 

 
Table Legend: 
Yes: supported 
Possible: supported, but not exact same parameters 
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Object: supported, but non-parametric as imported dummy feature 
 

Note:  

Sketch/Mesh Sketch features are transferred as parametric features, however, “Imported” 
entities inside features are non-parametric. When the “Region” option is an “Object” in the table, 
the feature will be transferred as a parametric feature, but only the Region option will be non-
parametric. 

 
Not now: not support now, but will be supported in a future release 
No: downstream CAD software does not support the related API 
 
Sketch/Mesh Sketch 

APPLICATION 
SolidWorks 

2006 + 
Siemens 
NX 4 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 

Base Plane 

Ref. Plane Yes Yes Yes Yes Yes 
Face Yes Yes Yes Yes Yes 
Sketch Chain Object Object Object Yes Object 
Curve Object Object Object Yes Object 
Sketch Object Object Object Yes Object 
3D Sketch Object Object Object Yes Object 
Edge Object Object Object Yes Object 
Loop Object Object Object Yes Object 
Region Object Object Object Yes Object 

Entity 

Point Yes Yes Yes Yes Yes 
Line Yes Yes Yes Yes Yes 
Arc Yes Yes Possible Yes Yes 
Circle Yes Yes Yes Yes Yes 
Ellipse Yes Yes Possible Yes Yes 
Partial Ellipse Yes Yes Possible Yes Yes 
Interpolated 
Spline Object Object Possible Object Object 

Canonical Spline Yes Yes Possible Yes Object 
Text Object Object Possible Object Object 
Fit Spline Object Object Possible Object Object 
Parabola Object Object Object Object Object 

Property “Constructive” 
option Yes Yes No No Yes 

Constraint 

Coincidence Yes Possible No No Yes 
Concentric Yes Possible No No Yes 
Perpendicular Yes Yes No No Yes 
Parallel Yes Yes No No Yes 
Tangent Yes No No No Yes 
Equal Length Yes Yes No No Yes 
Equal Radius Yes Yes No No Yes 
Equal Curvature No No No No No 
Coradial Yes Possible No No Yes 
Colinear Yes Yes No No Yes 
Fix Yes Possible No No No 
Horizontal Yes Yes No No Yes 
Vertical Yes Yes No No Yes 
Linear Aligned 
Dimension Yes Yes Yes No Yes 

Linear Horizontal 
Dimension Yes Yes Yes No Yes 

Linear Vertical 
Dimension Yes Yes Yes No Yes 

Radial Dimension Yes Yes Yes No Yes 
Angular 
Dimension Yes Possible Yes No No 

Mid Point No Possible No No No 
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Normal No No No No No 
Conversion No No No No No 
Equal Distance No No No No No 
Linear Pattern No No No No Object 
Circular Pattern No No No No Object 
Symmetry No No No No Object 
Offset No No No No Object 
Removed Original 
Offset 

No No No No Object 

 

3D Sketch/3D Mesh Sketch 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Curve Object Object Object Yes Object 
 

Extrude 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Profiles 

Sketch Yes Yes Yes Yes Yes 
3D Sketch No No No No No 
Whole Sketch Yes Yes Yes Yes Yes 
Part Of Sketch No No No No No 
Multi Profiles Yes Yes Yes Yes Yes 

Custom Direction 

Ref. Vector Yes Yes No Possible Possible 
Ref. Plane No Yes No Possible Possible 
Sketch Chain No No No Possible Possible 
Curve No Yes No Possible Possible 
Sketch No Yes No Possible Possible 
Region No No No Possible Possible 
3D Sketch No Yes No Possible Possible 
Edge Yes Yes No Possible Possible 
Loop No No No Possible Possible 
Face No Yes No Possible Possible 

Blind 
Length(Flip) Yes Yes Yes Yes Yes 
Draft(Angle/Flip) Yes Yes No Yes Yes 

Through All 
No Option Yes Possible Yes Yes Yes 
Draft(Angle/Flip) Yes Yes No Yes Yes 

Up To Vertex 
Vertex 

Ref. Point No Possible No Possible Possible 
Ref. 
Coordina
te 

No Possible No Possible Possible 

Curve 
Point No Possible No Possible Possible 

Body 
Vertex Yes Possible Possible Possible Possible 

Offset(Dist/Flip) No Yes No Possible Possible 
Draft(Angle/Flip) Yes Yes No Possible Yes 

Up To Region 
(Trim with …) 

Region Object Object Object No Object 
Offset(Dist/Flip) Yes No No No No 
Trans(Dist/Flip) Yes No No No No 
Draft(Angle/Flip) Yes Yes No No Yes 

Up To Region 
(Max.Mean.Min.) 

Min, Max, Mean Possible Possible Possible No Possible 
Draft(Angle/Flip) Yes Yes No No Yes 

Up To Surface 

Surface 
Ref. 
Plane Yes Yes Yes No Yes 

Face Yes Yes Yes No Yes 
Offset(Dist/Flip) Yes No No No No 
Trans(Dist/Flip) Yes No No No No 
Draft(Angle/Flip) Yes Yes No No Yes 

Up To Body 
Body 

Surface 
Body Yes Yes No No Yes 

Solid Body Yes Yes No No Yes 
Draft(Angle/Flip) Yes Yes No No Yes 

Mid Plane Length(Flip) Yes Possible Yes Yes Yes 
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Draft(Angle/Flip) Yes Yes No Yes Yes 

Result Operations 
Solid Yes Yes Possible Yes Yes 
Cut Yes Possible Yes Possible Yes 
Merge Yes Possible Yes Possible Yes 

Opposite  Yes Possible Yes Yes Yes 
 

Revolve 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Profiles 

Sketch Yes Yes Yes Yes Yes 
3D Sketch No No No No No 
Whole Sketch Yes Yes Yes Yes Yes 
Part Of Sketch No No No No No 
Multi Profiles Yes No Yes Yes Yes 

Axis 

Ref. Vector Yes Yes Yes Possible Yes 
Curve Yes Yes Yes Possible Yes 
Region No Object No Possible No 
Edge Yes Yes Yes Possible No 
Face No Yes No Possible No 

One Direction Angle(Flip) Yes Yes Yes Yes Yes 
Mid Plane Angle(Flip) Yes Yes Yes Yes Yes 

Both 
Directions 

Angle(Flip) Yes Yes Yes Yes Yes 
Opposite Angle Yes Yes Yes Yes Yes 

Result 
Operations 

Solid Yes Yes Possible Yes Yes 
Cut Yes Possible Yes Possible Yes 
Merge Yes Possible Yes Possible Yes 

 

Loft 
Not supported in NX4 and Pro/E 3.0+. 

APPLICATION SolidWorks 
2006 + 

SIEMENS 
NX5 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 

Profiles 

Composite Profile No No No No No 
Sketch Yes Yes No Yes Yes 
3D Sketch Yes Yes No Yes Yes 
Whole Sketch Yes Yes No Yes Yes 
Part Of Sketch No No No No No 
Edge Not now Not now No No No 
Loop No No No No No 
Face Not now Not now No No Yes 

Constraint 

None Yes Yes No Yes Yes 
Direction Vector Not now No No No No 
Normal 
To Profile Not now No No No Possible 

Tangency 
To Face 

No No No No Yes 

Curvature 
to Face 

No No No No Yes 

Guide Curves 

Composite Profile No No No No No 
Sketch Yes Yes No Yes Yes 
3D Sketch Yes Yes No Yes Yes 
Whole Sketch Yes Yes No Yes Yes 
Part Of Sketch No No No No No 
Edge Not now No No No No 

Merge Tangent Faces No No No No Yes 
Close Loft Yes No No No Yes 

Result 
Operations 

Solid Yes Yes No Yes Yes 
Cut Yes Possible No Possible Yes 
Merge Yes Possible No Possible Yes 

 

Sweep 
Not supported in NX4 and Pro/E 3.0+. 

APPLICATION SolidWorks 
2006 + 

SIEMENS 
NX5 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 
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Profiles 

Composite Profile No No No No No 
Sketch Yes Yes No Yes Yes 
3D Sketch Yes Yes No Yes No 
Whole Sketch Yes Yes No Yes Yes 
Part Of Sketch No No No No No 
Edge Not now Not now No No No 
Loop No No No No No 

Path 

Composite Profile No No No No No 
Sketch Yes Yes No Yes Yes 
3D Sketch Yes Yes No Yes Yes 
Whole Sketch Yes Yes No Yes Yes 
Part Of Sketch No No No No No 
Edge Not now Not now No No No 

Method 

Follow Path Yes Yes No Yes Yes 
Keep Normal Constant Not now No No No Yes 
Follow Path And First 
Guide Curve 

Not now No No No Yes 

Follow First And Second 
Guide Curves Not now No No No No 

Twist Along Path Not now No No No No 
Twist Along Path With 
Normal Constant Not now No No No No 

Path 
Alignment 
Type 

None Yes Yes No Yes Yes 

Direction Vector Not now No No No No 

Guide Curves 

Composite Profile Not now No No No No 
Sketch Chain Not now No No No Possible 
Curve Not now No No No Yes 
Sketch Not now No No No Yes 
Sketch Loop Not now No No No Possible 
3D Sketch Not now No No No Yes 
Edge Not now No No No No 

Improve Curvature Flow Along Sweep 
Path No No No No No 

Merge Tangent Faces Not now No No No No 

Result 
Operations 

Solid Yes Yes No Yes Yes 
Cut Yes Possible No Possible Possible 
Merge Yes Possible No Possible Possible 

 

Cut 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Tool Entities 

Region Object Object Object Not Now Object 
Ref. Plane Yes Yes Yes Not Now Yes 
Sketch Chain No No No No No 
Curve No No No No No 
Sketch No No No No No 
3D Sketch No No No No No 
Edge No No No No No 
Surface Body Yes Yes Yes Yes Yes 
Multiple Tool Entities No Yes No No Yes 

Target Bodies Solid Body Yes Yes Possible Yes Yes 
 

Hollow 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Body Solid Body Yes Yes Yes No Yes 
Depth Yes Yes Yes No Yes 
Hollow Outward Yes Yes Yes No Yes 
Remove Faces Faces Yes Yes Yes No Yes 

Multi-Thickness Faces 
Face Yes Yes Yes No No 
Thickness Yes Yes Yes No No 

 

Offset 
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APPLICATION SolidWorks 
2006 + 

SIEMENS 
NX4 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 

Solid Bodies No Yes No No Yes 
Offset Distance(Flip) No Yes No No Yes 

 

Thicken 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Surface Body Yes Yes Yes No Yes 
Thickness Yes Yes Yes No Yes 

Direction 
Direction1 Yes Yes Yes No Yes 
Direction2 Yes Yes Yes No Yes 
Both Yes Yes Yes No Yes 

Result Operator 
Solid Yes Possible Possible No Yes 
Cut Yes Possible Yes No Yes 
Merge Yes Possible Yes No Yes 

 

Boolean 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Merge Tool 
Bodies 

Surface 
Body No No No No No 

Solid Body Yes Possible No Possible Yes 

Cut 

Tool 
Bodies 

Surface 
Body No No No No No 

Solid Body Yes Possible No Possible Yes 
Target 
Bodies Solid Body Yes Possible No Possible Yes 

Multiple Target Bodies No No No No No 

Intersect 

Tool 
Bodies 

Surface 
Body No No No No No 

Solid Body Yes Possible No Possible Yes 
Target 
Body Solid Body Yes Possible No Possible Yes 

 

Surface Extrude 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Profiles 

Sketch Yes Yes Yes Yes Yes 
3D Sketch No No No Yes No 
Whole Sketch Yes Yes Yes Yes Yes 
Part Of Sketch No No No No No 
Multi Profiles Yes Yes No Yes No 

Custom 
Direction 

Ref. Vector No Yes No Possible Possible 
Ref. Plane No Yes No Possible Possible 
Sketch Chain No No No Possible Possible 
Curve No Yes No Possible Possible 
Sketch No Yes No Possible Possible 
Region No No No Possible Possible 
3D Sketch No Yes No Possible Possible 
Edge No Yes No Possible Possible 
Loop No No No Possible Possible 
Face No Yes No Possible Possible 

Blind 
Length(Flip) Yes Yes Yes Yes Yes 
Draft(Angle/Flip) Yes Yes No Yes Yes 

Through All 
No Option Yes Possible No Yes Object 
Draft(Angle/Flip) Yes Yes No Yes Yes 

Up To Vertex 
Vertex 

Ref. Point No Possible No Possible Possible 
Ref. 
Coordinate No Possible No Possible Possible 
Curve Point No Possible No Possible Possible 
Body Vertex Yes Possible Possible Possible Possible 

Offset(Dist/Flip) No Yes No Possible Possible 
Draft(Angle/Flip) Yes Yes No Possible Yes 

Mid Plane Length(Flip) Yes Possible Yes Yes Yes 
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Draft(Angle/Flip) Possible Yes No Yes Yes 
Opposite Yes Possible Yes Possible Yes 

 

Surface Revolve 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Profiles 

Sketch Yes Yes Yes Yes Yes 
3D Sketch No No No No No 
Whole Sketch Yes Yes Yes Yes Yes 
Part Of Sketch No No No No No 
Multi Profiles Yes No No Yes Yes 

Axis 

Ref. Vector Yes Yes Yes Possible Yes 
Curve Yes Yes Yes Possible Yes 
Region No No No Possible No 
Edge Yes Yes Yes Possible No 
Face No Yes No Possible No 

One Direction Angle(Flip) Yes Yes Yes Yes Yes 
Mid Plane Angle(Flip) Yes Yes Yes Yes Yes 

Both Directions 
Angle(Flip) Yes Yes Yes Yes Yes 
Opposite Angle Yes Yes Yes Yes Yes 

 

Surface Loft 
Not supported in NX4 and Pro/E 3.0+. 

APPLICATION SolidWorks 
2006 + 

SIEMENS 
NX4 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 

Profiles 

Composite Profile No No No No No 
Sketch Yes Yes No Yes Yes 
3D Sketch Yes Yes No Yes Yes 
Whole Sketch Yes Yes No Yes Yes 
Part Of Sketch No No No No No 
Edge Not now Not now No No Yes 
Loop No No No No No 
Face Not now Not now No No No 

Constraint 

None Yes Yes No Yes Yes 
Direction Vector Not now No No No No 
Normal To 
Profile Not now No No No No 

Tangency 
To Face No No No No Possible 

Curvature 
to Face No No No No Possible 

Guide Curves 

Composite Profile No No No No No 
Sketch Yes Yes No Yes Yes 
3D Sketch Yes Yes No Yes Yes 
Whole Sketch Yes Yes No Yes Yes 
Part Of Sketch No No No No No 
Edge Not now No No No No 

Merge Tangent Faces No No No No Yes 
 

Surface Sweep 
Not supported in NX4 and Pro/E 3.0+. 

APPLICATION SolidWorks 
2006 + 

SIEMENS 
NX4 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 

Profiles 

Composite Profile No No No No No 
Sketch Yes Yes No Yes Yes 
3D Sketch Yes Yes No Yes No 
Whole Sketch Yes Yes No Yes Yes 
Part Of Sketch No No No No No 
Edge Not now Not now No No No 
Loop No No No No No 

Path 
Composite Profile No No No No No 
Sketch Yes Yes No Yes Yes 
3D Sketch Yes Yes No Yes Yes 
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Whole Sketch Yes Yes No Yes Yes 
Part Of Sketch No No No No No 
Edge Not now Not now No No No 

Method 

Follow Path Yes Yes No Yes Possible 
Keep Normal 
Constant Not now No No No Yes 

Follow Path 
And First Guide Curve Not now No No No Possible 

Follow First 
And Second Guide Curves Not now No No No No 

Twist 
Along Path Not now No No No No 

Twist 
Along Path 
With Normal 
Constant 

Not now No No No No 

Path Alignment 
Type 

None Yes Yes No Yes Yes 
Direction Vector Not now No No No No 

Guide Curves 

Composite Profile Not now No No No No 
Sketch Chain Not now No No No Possible 
Curve Not now No No No Yes 
Sketch Not now No No No Yes 
Sketch Loop Not now No No No Possible 
3D Sketch Not now No No No Yes 
Edge Not now No No No No 

Improve Curvature Flow 
Along Sweep Path No No No No No 

Merge Tangent Faces Not now No No No No 
 

Reverse Normal 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Surface Bodies No Yes No No Object 
 

Sew 
APPLICATION 

SolidWorks 
2006 + 

SIEMENS 
NX4 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 

Surface Bodies Yes Yes No No Yes 
Continuity Constraint No No No No No 

 

Trim 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Tool 

Sketch Chain No No No 

No 

Yes 
Ref. Plane No Yes Yes Yes 
Region No Object Object Object 
Surface Body No Yes Yes Yes 
Solid Body No No No Yes 

Target Surface Body No Yes Yes No Yes 
 

Untrim 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Tool 
Edge Yes No No 

No 
No 

Loop Yes No No No 
Face No No No No 

 

Surface Offset 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Faces 
Face No Yes Object No Object 
Surface Body No Yes Object No Object 

Offset Distance(Flip) No Yes Object No Object 

More 
Option 

Make Side Wall No No Object No No 
Remove 
Original Faces No No Object No No 
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Fillet 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Constant 
Fillet 

Entities 
Edge Yes Yes Yes Yes Yes 
Loop Not now Not now Not now Not now Not now 
Face Yes Yes No No Yes 

Radius Yes Yes Yes Yes Yes 
Tangent Propagation Yes Yes Yes No Yes 
Multiple Set Yes Yes Yes Yes Possible 

Variable 
Fillet 

Entities Edge Yes Yes Yes 

No 

Yes 
Radius Possible Yes Yes Yes 
Tangent 
Propagation Yes Yes No No 

Transition 
Method 

Smooth 
Transition Yes No No Yes 

Linear 
Transition Yes Yes No Yes 

Conic Fillet No No No No No 

Face Fillet 

Faces/Faces Face Yes Yes Yes 

No 

Yes 
Radius Yes Yes Yes Yes 

Hold Line 

Edge No Yes No No 
Curve No Yes No No 
Sketch 
Chain No No No No 

Asymmetric No Possible No No 

Help Point 
Ref. Point No No No No 
Curve Point No No No No 
Vertex Yes No No No 

Tangent Propagation Yes Yes Yes No 
Constant Curvature Yes No No No 
Constant Width Yes No No No 

Conic 
Radius2 No Yes No No 
Rho No Yes No No 

Full Face 
Fillet 

Fillet Entity 
Set 

Left Yes No No 
No 

Yes 
Right Yes No No Yes 
Center Yes No No Yes 

 

Chamfer 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Entities 

Edge Yes Yes Yes Yes Yes 
Loop Not now Not now Not now Not now Not now 
Face Yes Yes No No No 
Multiple 
Entities 

No No No No No 

Angle & 
Distance 

Distance Yes Yes Yes 

No 

Yes 
Angle Yes Yes Yes Yes 
Flip Direction Yes Yes No No 
Tangent 
Propagation Yes Yes Yes Yes 

Distance & 
Distance 

Distance Yes Yes Yes Yes Yes 
Distance2 Yes Yes Yes Yes Yes 
Flip Direction Yes Yes No Yes Yes 
Tangent 
Propagation Yes Yes Yes No Yes 

 

Draft 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Neutral Plane 

Neutral 
Plane 

Ref. Plane No Yes Yes No Yes 
Region No No No No No 
Face Yes Yes Yes No Yes 

Draft Faces Yes Yes Yes No Yes 
Angle(Flip) Yes Yes Yes No Possible 
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Parting 
Line Draft 

Pull 
Direction 

Ref. Vector Not Now Yes Yes No Yes 
Ref. Plane Not Now Yes No No Yes 
Sketch Chain Not Now No No No No 
Curve Not Now Yes No No No 
Sketch Not Now Yes No No No 
Region Not Now No No No No 
3D Sketch Not Now Yes No No No 
Edge Not Now Yes Yes No Yes 
Loop Not Now No No No No 
Face Not Now Yes No No  

Parting 
Lines Edge Not Now Yes Yes No Yes 

Angle Not Now Yes Yes No Yes 
Flip Direction Not Now Yes Yes No Yes 
Allow Reduced Angle Not Now No No No Yes 

Step Draft 

Neutral 
Plane 

Ref. Plane Not Now No No No No 
Region Not Now No No No No 
Face Not Now No No No No 

Parting 
Lines Edge Not Now No No No No 

Angle Not Now No No No No 
Direction Not Now No No No No 

Step Type 
Tapered Steps Not Now No No No No 
Perpendicular 
Steps Not Now No No No No 

 

Mirror 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Bodies 
Surface Body Yes Yes Object Object No 
Solid Body Yes Yes Object Object Yes 

Symmetry Plane 
Ref. Plane Yes Yes Object Object Yes 
Face Yes Possible Object Object Yes 

Trim & Merge No No Object Object No 
 

Delete Face 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Delete Yes No No 
No 

Yes 
Delete And Heal No No No Yes 
Delete And Fill No No No No 

 

Move Face 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Translate 

Faces Yes Yes No No Yes 

Direction 

Ref. Vector Yes Yes No No Yes 
Ref. Plane Yes Yes No No No 
Curve No Possible No No No 
Edge Yes Yes No No Yes 
Face Yes Yes No No Yes 

Distance(Flip) Yes Yes No No Yes 

Rotate 

Faces Yes Yes No No Yes 

Axis 
Ref. Vector Yes Yes No No Yes 
Curve No Possible No No No 
Edge Yes Yes No No Yes 

Angle(Flip) Yes Yes No No Yes 
 

Replace Face 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Target Faces Face Yes Yes Yes No Object 

Tool Body 
Region Object Object No No Object 
Surface Body Yes Yes Yes No Object 
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Linear Pattern 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Bodies 
Solid Body Yes Object Object Object Yes 
Surface Body Yes Object Object Object No 

Direction 

Ref. Vector Yes Object Object Object Yes 
Ref. Plane No Object Object Object Yes 
Sketch Chain No Object Object Object No 
Curve No Object Object Object No 
Sketch No Object Object Object No 
3D Sketch No Object Object Object No 
Edge Yes Object Object Object Yes 
Loop No Object Object Object No 
Region No Object Object Object No 
Face No Object Object Object Yes 

Skip Instances Yes Object Object Object No 
 

Circular Pattern 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Bodies 
Solid Body Yes Object Object Object Yes 
Surface Body Yes Object Object Object No 

Rotation Axis 

Ref. Vector Yes Object Object Object Yes 
Curve No Object Object Object No 
Edge Yes Object Object Object Possible 
Region No Object Object Object No 
Face No Object Object Object No 

Equal Spacing Yes Object Object Object Yes 

Rotate About Axis True: Yes 
False: No 

Object Object Object True: Yes 
False: No 

Skip Instances Yes Object Object Object No 
 

Curve Pattern 
APPLICATION 

SolidWorks 
2006 + 

SIEMENS 
NX4 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 

Bodies 
Solid Body Yes Object Object Object Object 
Surface Body Yes Object Object Object Object 

Path Curve 
Curve 1 Curve: Yes Object Object Object Object 
Edge Yes Object Object Object Object 

Equal Spacing Yes Object Object Object Object 

Align Method 
Align To Seed Yes Object Object Object Object 
Rotate Along Curve Yes Object Object Object Object 

Skip Instances Yes Object Object Object Object 
 

Transform Body 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Bodies 
Solid Body Yes No No No Yes 
Surface Body Yes No No No Yes 

Duplicate Yes No No No No 

Method 

Rotate And Translate Yes No No No Yes 

Scale: 
Scale 
Center 

Global Origin Yes No No No No 
Body Center No No No No No 
Custom No No No No No 

By Matrix No No No No Possible 
Datum Alignment No No No No Object 
Align To Scan No No No No Object 

 

Split Face 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Projection Tool Sketch Yes Yes No No Yes 
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Entities 3D Sketch No Yes No No No 
Target 
Entities Face Yes Yes No No Yes 

Options 
Single 
Direction(Flip) Yes Yes No No No 

Bi-Direction Yes No No No Yes 

Silhouette 

Pull 
Direction 

Ref. Vector No No No No No 
Region No No No No No 
Ref. Plane No No No No No 
Sketch 
Chain No No No No No 

Curve No No No No No 
Sketch No No No No No 
3D Sketch No No No No No 
Edge No No No No No 
Loop No No No No No 
Face No No No No No 

Target 
Entities Face No No No No No 

Options Draft Angle No No No No No 

Intersection 

Tool 
Entities 

Face No Yes No No No 
Surface 
Body No Yes No No Yes 

Solid 
Body No Yes No No Yes 

Target 
Entities 

Face No Yes No No Yes 
Surface 
Body No Yes No No Yes 

Solid 
Body No Yes No No Yes 

 

Helix/Spiral 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Curves Object Object No No Object 
 

Emboss 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Pad/Pocket Yes Yes No No Yes 

Profile 

Sketch Yes Yes No No Yes 
Sketch Chain No No No No Yes 
Sketch Loop No No No No Yes 
3D Sketch No Yes No No No 
Loop No No No No No 

Target 
Face Yes Yes No No Yes 
Solid Body No Yes No No Yes 
Surface Body No Yes No No No 

End Cap 

Offset Surface Yes Yes No No Yes 

Translate 
Surface 

Ref. Vector No Yes No No No 
Region No No No No No 
Ref. Plane No Yes No No No 
Sketch Chain No No No No No 
Curve No Yes No No No 
Sketch No Yes No No No 
3D Sketch No Yes No No No 
Edge No Yes No No No 
Loop No No No No No 
Face No Yes No No No 

End Cap 
Surface 

Region No Object No No No 
Face No Yes No No No 
Surface Body No Yes No No No 
Solid Body No Yes No No No 

Side Wall 
Face Normal Yes Yes No No No 
Profile Direction No Yes No No Yes 



Geomagic Design X | Menu  172 
 

Direction 
Vector 

Ref. Vector Yes Yes No No No 
Region No No No No No 
Ref. Plane No Yes No No No 
Sketch Chain No No No No No 
Curve No Yes No No No 
Sketch No Yes No No No 
3D Sketch No Yes No No No 
Edge Yes Yes No No No 
Loop No No No No No 
Face No Yes No No No 

Draft Angle (Flip) No Yes No No No 
 

Ref. Point 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Definition Position No Object Object No Object 

Extract No Object Object No Object 

Find Circle Center No Object Object No Object 

Find Slot Center No Object Object No Object 

Find Rectangle Center No Object Object No Object 

Find Polygon Center No Object Object No Object 

Find Sphere Center No Object Object No Object 

Projection No Object Object No Object 

Pick 
Multiple 
Points 

Entities 

Ref. Point No Object Object No Object 
Curve Point No Object Object No Object 
Poly-Vertex No Object Object No Object 
Curve No Object Object No Object 
Region No Object Object No Object 
Region 
Group No Object Object No Object 

Vertex No 1 Vertex: Yes 
Else : Object 

1 Vertex: Yes 
Else : Object No 1 Vertex: Yes 

Else: Object 
Edge No Object Object No Object 
Face No Object Object No Object 

N Division No Object Object No Object 

Between 2 Points No Object Object No Object 

Intersect 2 Lines No Object Yes No Object 

Intersect Line and Face No Object Yes No Object 

Intersect 3 Planes No Object Yes No Object 
 

Ref. Vector 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Definition 

Position & 
Direction 

Position (XYZ) 
Direction 
(+-XYZ, XYZ 
(value)) 

Object Object Object No Object 

Start & 
End 
Position 

Start Position 
(XYZ) 
End Position 
(XYZ) 

Object Object Object No Object 

Extract Entities 

Poly-Vertex Object Object Object No Object 

Ref. Polyline Object Object Object No Object 

Curve Object Yes Object No Yes 

Poly-Face Object Object Object No Object 

Region Object Object Object No Object 

Region Group Object Object Object No Object 

Edge 
1 Linear 

Edge : Yes 
Else : Object 

1 Linear 
Edge : Yes 

Else : Object 

1 Linear 
Edge : Yes 

Else : Object 
No 

1 Linear 
Edge : Yes 

Else : Object 
Face Object Yes Object No Object 

Mesh Object Object Object No Object 
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Fitting 
Options  Object Object Object No Object 

Constraint 
Options 

Project On 
Plane Object Object Object No Object 

Find 
Slot Axis Object Object Object No Object 

Find 
Cylinder Axis Object Object Object No Object 

Find 
Cone Axis Object Object Object No Object 

Projection Object Object Object No Object 

Pick 
Multiple 
Points 

Entities 

Ref. Point Object 2 Point : Yes 
Else : Object 

2 Point : Yes 
Else : Object No 2 Vertex : Yes 

Else : Object 
Curve Point Object Object Object No Object 
Poly-Vertex Object Object Object No Object 
Curve Object Object Object No Object 
Region Object Object Object No Object 
Region Group Object Object Object No Object 

Vertex 2 Vertex : Yes 
Else : Object 

2 Vertex : Yes 
Else : Object 

2 Vertex : Yes 
Else : Object No 2 Vertex : Yes 

Else : Object 
Edge Object Object Object No Object 
Face Object Object Object No Object 

Pick 
Point & Line Entities 

Ref. Point Object Yes Object No Object 
Ref. Vector Object Yes Object No Object 
Poly-Vertex Object Object Object No Object 
Curve Point Object Object Object No Object 
Ref. Plane Object Yes Object No Object 
Curve Object Yes Object No Object 
Sketch Object Possible Object No Object 
Region Object Object Object No Object 
Region Group Object Object Object No Object 
Vertex Object Yes Object No Object 
Edge Object Yes Object No Object 
Face Object Yes Object No Object 

Intersect 
2 Planes Entities 

Ref. Plane Yes Yes Yes No Yes 
Sketch Object Object Object No Object 
Region Object Object Object No Object 
Region Group Object Object Object No Object 
Face Yes Yes Yes No Yes 

Average Object Object Object No Object 

Cross 2 Lines Object Object Object No Object 

Revolving Axis Object Object Object No Object 

Extrusion Axis Object Object Object No Object 

Pattern Revolving Axis Object Object Object No Object 

Pattern Translation Axis Object Object Object No Object 
 

Ref. Plane 
APPLICATION SolidWorks 

2006 + 
SIEMENS 

NX4 + 
Pro/E 

Wildfire 3 + 
AutoCAD 

2007 + 
Inventor 
2010 + 

Definition 

Position & 
Normal 

Position (XYZ) 
Normal (+- XYZ, 
XYZ (value)) 

Object Object Object No Object 

3 Positions 
Position1 (XYZ) 
Position2 (XYZ) 
Position3 (XYZ) 

Object Object Object No Object 

Coefficients 

A (value) 
B (value) 
C (value) 
D (value) 

Object Object Object No Object 

Extract Entities 

Poly-Vertex Object Object Object No Object 

Ref. Polyline Object Object Object No Object 

Ref. Plane Object Object Yes No Object 

Curve Object Object Object No Object 

Poly-Face Object Object Object No Object 
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Region Object Object Object No Object 

Region Group Object Object Object No Object 

Edge Object Yes Object No Object 

Face 
1 Planar 

Face : Yes 
Else : Object 

1 Planar 
Face : Yes 

Else : Object 

1 Planar 
Face : Yes 

Else : Object 
No 

1 Planar 
Face : Yes 

Else : Object 
Mesh Object Object Object No Object 

Fitting Options Object Object Object No Object 
Constraint 
Options Axis Constraint Object Object Object No Object 

Projection Entities Object Object Object No Object 

Pick Multiple 
Points Entities 

Ref. Point Object 3 Point : Yes 
Else : Object 

3 Point : Yes 
Else : Object No 3 Point : Yes 

Else : Object 
Poly-Vertex Object Object Object No Object 
Curve Point Object Object Object No Object 
Curve Object Object Object No Object 
Region Object Object Object No Object 
Region Group Object Object Object No Object 

Vertex Object 
3 Vertex : 

Yes 
Else : Object 

3 Vertex : 
Yes 

Else : Object 
No 

3 Vertex : 
Yes 

Else : Object 
Edge Object Object Object No Object 
Face Object Object Object No Object 

Pick Point & 
Normal Axis Entities 

Ref. Point Object Yes Yes No Object 
Curve Point Object Object Object No Object 
Poly-Vertex Object Object Object No Object 
Ref. Vector Object Yes Yes No Object 
Curve Object Yes Object No Object 
Ref. Plane Object Yes Object No Object 
Sketch Object Possible Object No Object 
Region Object Object Object No Object 
Region Group Object Object Object No Object 
Vertex Object Yes Yes No Object 
Edge Object Yes Yes No Object 
Face Object Yes Object No Object 

Pick Point & 
Coplanar Axis Entities 

Ref. Point Object Yes Yes No Object 
Curve Point Object Object Object No Object 
Poly-Vertex Object Object Object No Object 
Ref. Vector Object Yes Yes No Object 
Curve Object Yes Object No Object 
Region Object Object Object No Object 
Region Group Object Object Object No Object 
Vertex Object Yes Yes No Object 
Edge Object Yes Yes No Object 
Face Object Object Object No Object 

N Division 
Entities Object Object Object No Object 
Pattern Option Object Object Object No Object 

Offset 

Entities 

Ref. Plane Yes Yes Yes No Yes 

Sketch Object Object Object No Object 

Region Object Object Object No Object 

Region Group Object Object Object No Object 

Face Yes Yes Yes No Yes 

Offset Options 
Number (Value) Yes Yes Yes No Yes 
Distance 
(Value/Flip) Yes Yes Yes No Yes 

Rotation 
Entities Object Object Object No Object 

Rotate 
Options 

Number (Value) Object Object Object No Object 
Angle (Flip) Object Object Object No Object 

Average Entities Object Object Object No Object 
View 
Direction Entities Object Object Object No Object 

Tangent Entities Object Object Object No Object 
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Orthogonal Entities Object Object Object No Object 

Draw Cutting Entities Object Object Object No Object 

Mirror Entities Object Object Object No Object 

Extreme 
Position 

Entities Object Object Object No Object 

Direction Object Object Object No Object 
 

Ref. Coordinate 
APPLICATION 

SolidWorks 
2006 + 

SIEMENS 
NX4 + 

Pro/E 
Wildfire 3 + 

AutoCAD 
2007 + 

Inventor 
2010 + 

Definition 
Origin & Axes 

Origin (XYZ) 
Axis 1, 2 (+- XYZ, 
XYZ (value)) 
Order 

No Object Object No Object 

Origin & 
Rotation 

Origin (XYZ) 
Rotation No Object Object No Object 

Extract 
Entities 

Poly-Vertex No Object Object No No 
Ref. Polyline No Object Object No No 
Curve No Object Object No No 
Poly-Face No Object Object No No 
Region No Object Object No No 
Region Group No Object Object No No 
Edge No Object Object No No 
Face No Object Object No No 
Mesh No Object Object No No 

Fitting Options No Object Object No No 

Pick Multiple 
Points 

Entities 

Ref. Point No 
3 Point : Yes 

Else : 
Object 

Object No No 

Poly-Vertex No Object Object No No 
Curve Point No Object Object No No 
Curve No Object Object No No 
Region No Object Object No No 
Region Group No Object Object No No 

Vertex No 

3 Vertex : 
Yes 

Else : 
Object 

Object No Object 

Edge No Object Object No No 
Face No Object Object No No 

More Option Order No 
Possible 
Only XY 

Order 
Object No Possible 

Pick Point & 
Line 

Entities 

Ref. Point No Yes Object No No 
Ref. Vector No Yes Object No No 
Poly-Vertex No Object Object No No 
Curve Point No Object Object No No 
Ref. Plane No Yes Object No No 
Curve No Yes Object No No 
Region No Object Object No No 
Region Group No Object Object No No 
Sketch No Yes Object No No 
Vertex No Yes Object No No 
Edge No Yes Object No No 
Face No Yes Object No No 

More Option Order No 
Possible 
Only XY 

Order 
Object No No 

Pick Point & 
Coordinate Entities 

Ref. Point No Yes Object No No 
Ref. Coordinate No Yes Object No No 
Poly-Vertex No Object Object No No 
Curve Point No Object Object No No 
Curve No Object Object No No 
Region No Object Object No No 
Region Group No Object Object No No 
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Vertex No Yes Object No No 
Edge No Object Object No No 
Face No Object Object No No 

Intersect 3 
Plane 

Entities 

Ref. Plane No Yes Yes No No 
Sketch No Object Object No No 
Region No Object Object No No 
Region Group No Object Object No No 
Face No Yes Yes No No 

 

Intersection 
Options Check Orthogonal No 

Possible 
Only 

Orthogonal 
Object No No 

More Options Flip Z 
Flip X No Object Object No No 

Tangent Entities 

Ref. Point No Object Object No No 
Poly-Vertex No Object Object No No 
Curve Point No Object Object No No 
Vertex No Object Object No No 

 
 

See Also 

File > LiveTransfer(TM) > To SolidWorks 
File > LiveTransfer(TM) > To Siemens NX 
File > LiveTransfer(TM) > To Creo(Pro/E) 
File > LiveTransfer(TM) > To AutoCAD 
File > LiveTransfer(TM) > To Inventor 
File > LiveTransfer(TM) > Save As CATIA V4 
File > LiveTransfer(TM) > Save As CATIA V5 
 
 
 
 
 
 
 
 
 

File > LiveTransfer(TM) > To SolidWorks 
 

What 

The LiveTransfer™ To SolidWorks command is used to directly export features and modeling 
histories to the SolidWorks application. 
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Why 

The LiveTransfer™ To SolidWorks tool is useful for: 

• Transferring data into the SolidWorks application 

 
 

How to Use 

How use the LiveTransfer™ To SolidWorks command 
1. Go to File > LiveTransfer(TM) > To SolidWorks. 

 

Note:  

The application currently supports SolidWorks 2006, 2007, 2008, 2009, 2010, 2011, 2012, and 
2013. 

 
 

2. Go to Start From First Feature in the dialog tree. 
 

Note:  

The creation method is different in SolidWorks and there are some limitations to the Cut 
command. 

 
If a Tool Entity completely cuts a body, it will be transferred without any barriers. 

 
 

  
Cut Result in Geomagic Design X LiveTransfer™ to SolidWorks 

 
However, if a Tool Entity completely cuts a body and crosses into another body, it may 
generate an error message within SolidWorks. To avoid this error message, uncheck the 
Auto-select option in the Cut With Surface command in SolidWorks, and then 
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manually cut the body. 

 
 

 
 

Cut Result in Geomagic Design X LiveTransfer™ to SolidWorks 
 
If a Tool Entity completely cuts a target body and completely crosses another body, the 
other body will also be cut in SolidWorks. To avoid this situation, uncheck the Auto-
select option in the Cut With Surface command in SolidWorks, and then manually cut 
the target body. 

 
 

  
Cut Result in Geomagic Design X LiveTransfer to SolidWorks 

 
If a Tool Entity cuts a single body and creates two or more remaining bodies, remaining 
bodies can be selected in the application. After using the LiveTransfer™ To SolidWorks, 
command however, the remaining bodies will be determined to be in the normal 
direction of the Tool Entity. In this case the body needs to be cut manually in 
SolidWorks. 
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Cut Result in Geomagic Design X LiveTransfer to SolidWorks 
 
 

3. Click OK to finish the command. 
 
 

Options in Detail 

Methods 

This tool features 3 different methods: 

• Start From First Feature 

All features starting from the first feature in the Feature Tree will be exported into SolidWorks 

• Resume From Selected Feature 

All features starting from a selected feature in the Feature Tree will be exported into SolidWorks 

• Only Selected Entities 

Only selected features will be exported into SolidWorks 
 

Options 

SolidWorks (Version) – Chooses a dedicated software version. 
 

Note:  

When different SolidWorks versions are installed in the same PC, the SolidWorks (Version) option will 
be displayed. 

 
Prefix For Feature Name – Defines the prefix for a feature name. 
 
Try To Transfer Sweep/Loft As Parametric Feature – Transfers Sweep and Loft features as 
parametric features into SolidWorks, however if the sweeping and lofting algorithms are 
different between the applications then the features will be transferred as dummy objects. 
 
Feature – Selects a feature to start transferring. 
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Entities – Selects entities only to transfer. 
 
Specify Face Or Plane Of Sketch Inside Of SolidWorks – Allows a Face or Plane to be selected 
to be used as a 2D sketch plane. 
 

SolidWorks Option 

Use Custom SolidWorks Execution File Path – Manually defines the path of a SolidWorks 
application execution file. 

Pause At … 

Pause At – Pauses transfer before a selected command is performed. 
 
 

See Also 

File > LiveTransfer(TM) > To Siemens NX 
File > LiveTransfer(TM) > To Creo(Pro/E) 
File > LiveTransfer(TM) > To AutoCAD 
File > LiveTransfer(TM) > To Inventor 
File > LiveTransfer(TM) > Save As CATIA V4 
File > LiveTransfer(TM) > Save As CATIA V5 
 
 
 

File > LiveTransfer(TM) > To Siemens NX 
 

What 

The LiveTransfer™ To Siemens NX command is used to directly export features and modeling 
histories to the Siemens NX application. 

 
 
 

Why 

The LiveTransfer™ To Siemens NX tool is useful for: 
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• Transferring data into the Siemens NX application 

 
 

How to Use 

How use the LiveTransfer™ To Siemens NX command 
1. Go to File > LiveTransfer(TM) > To Siemens NX. 

 

Note:  

The application currently supports Siemens NX4, 5, 6, 7, 7.5, and 8. 

 
 

2. Choose Start From First Feature in the dialog tree. 
 

3. Click OK to finish the command. 
 
 

Options in Detail 

Methods 

This tool features 3 different methods such as: 

• Start From First Feature 

All features starting from the first feature in the Feature Tree will be exported into Siemens NX 

• Resume From Selected Feature 

All features starting from a selected feature in the Feature Tree will be exported into Siemens NX 

• Only Selected Entities 

Only selected features will be exported into Siemens NX 

 
 

Options 

Siemens NX (Version) – Chooses a dedicated software version. 
 

Note:  

When different Siemens NX versions are installed in the same PC, the Siemens NX (Version) option will 
be displayed. 

 
Prefix For Feature Name – Defines the prefix for a feature name. 
 
Try To Transfer Sweep/Loft As Parametric Feature – Transfers Sweep and Loft features as 
parametric features into Siemens NX, however if the sweeping and lofting algorithms are 
different between the applications then the features will be transferred as dummy objects. 
 
Feature – Selects a feature to start transferring. 
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Entities – Selects entities only to transfer. 
 
Use Selected Face Or Plane In NX For 2D Sketch Plane – Allows a Face or Plane to be selected 
to be used as a 2D sketch plane. 
 

Siemens NX Option 

Use Custom NX Execution File Path – Manually defines the path of a Siemens NX application 
execution file. 
 

Pause At … 

Pause At – Pauses transfer before a selected command is performed. 
 
 

See Also 

File > LiveTransfer(TM) > To SolidWorks 
File > LiveTransfer(TM) > To Creo(Pro/E) 
File > LiveTransfer(TM) > To AutoCAD 
File > LiveTransfer(TM) > To Inventor 
File > LiveTransfer(TM) > Save As CATIA V4 
File > LiveTransfer(TM) > Save As CATIA V5 
 
 
 

File > LiveTransfer(TM) > To Creo(Pro/E) 
 

What 

The LiveTransfer™ To Creo(Pro/E) command is used to directly export features and modeling 
histories to the Creo(Pro/E) application. 
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Why 

The LiveTransfer™ To Creo(Pro/E) tool is useful for: 

• Transferring data into the Creo(Pro/E) application 

 
 

How to Use 

How use the LiveTransfer™ To Creo(Pro/E) command 
1. Go to File > LiveTransfer(TM) > To Creo(Pro/E). 

 

Note:  

The application currently supports Pro/E Wildfire 3.0, 4.0, 5.0, Creo Elements/Pro 5.0, and Creo 
Parametric 1.0, 2.0. 

 
 

2. Choose Start From First Feature in the dialog tree. 
 

3. Click OK to finish the command. 
 
 

Options in Detail 

Methods 

This tool features 3 different methods: 

• Start From First Feature 

All features starting from the first feature in the Feature Tree will be exported into Creo(Pro/E) 

• Resume From Selected Feature 

All features starting from a selected feature in the Feature Tree will be exported into Creo(Pro/E) 

• Only Selected Entities 

Only selected features will be exported into Creo(Pro/E) 

 
 

Options 

Prefix For Feature Name – Defines the prefix for a feature name. 
 
Try To Transfer Sweep/Loft As Parametric Feature – Transfers Sweep and Loft features as 
parametric features into Creo(Pro/E), however if the sweeping and lofting algorithms are 
different between the applications then the features will be transferred as dummy objects. 
 
Feature – Selects a feature to start transferring. 
 
Entities – Selects entities only to transfer. 
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Use Selected Face Or Plane In Creo(Pro/E) For 2D Sketch Plane – Allows a Face or Plane to be 
selected to be used as a 2D sketch plane. 
 

Cre-(Pro/E) Options 

Use Custom Creo(Pro/E) Execution File Path – Manually defines the path of a Creo(Pro/E) 
application execution file. 
 
Use Creo(Pro/E) Template File – Uses a template Creo(Pro/E) file in the .prt format. 
 

Pause At … 

Pause At – Pauses transfer before a selected command is performed. 
 
 

See Also 

File > LiveTransfer(TM) > To SolidWorks 
File > LiveTransfer(TM) > To Siemens NX 
File > LiveTransfer(TM) > To AutoCAD 
File > LiveTransfer(TM) > To Inventor 
File > LiveTransfer(TM) > Save As CATIA V4 
File > LiveTransfer(TM) > Save As CATIA V5 
 
 
 

File > LiveTransfer(TM) > To AutoCAD 
 

What 

The LiveTransfer™ To AutoCAD command is used to directly export features and sketches to the 
AutoCAD application. 

 
 
 

Why 

The LiveTransfer™ To AutoCAD tool is useful for: 

• Transferring data into the AutoCAD application 
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How to Use 

How use the LiveTransfer™ To AutoCAD command 
1. Go to File > LiveTransfer(TM) > To AutoCAD. 

 

Note:  

The application currently supports AutoCAD 2007, 2008, 2009, 2010, and 2011. AutoCAD 
LT is not supported 

 
 

2. Choose Start From First Feature in the dialog tree. 
 

3. Click OK to finish the command. 
 
 

Options in Detail 

Methods 

This tool features 3 different methods: 

• Start From First Feature 

All features starting from the first feature in the Feature Tree will be exported into AutoCAD 

• Resume From Selected Feature 

All features starting from a selected feature in the Feature Tree will be exported into AutoCAD 

• Only Selected Entities 

Only selected features will be exported into AutoCAD 

 
 

Options 

AutoCAD (Version) – Chooses a dedicated software version. 
 

Note:  

When different AutoCAD versions are installed in the same PC, the AutoCAD (Version) option will be 
displayed. 

 
Try To Transfer Sweep/Loft As Parametric Feature – Transfers Sweep and Loft features as 
parametric features into AutoCAD, however if the sweeping and lofting algorithms are different 
between the applications then the features will be transferred as dummy objects. 
 
Feature – Selects a feature to start transferring. 
 
Entities – Selects entities only to transfer. 
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AutoCAD Options 

Use Custom AutoCAD Execution File Path – Manually defines the path of a AutoCAD 
application execution file. 
 

Pause At … 

Pause At – Pauses transfer before a selected command is performed. 
 
 

See Also 

File > LiveTransfer(TM) > To SolidWorks 
File > LiveTransfer(TM) > To Siemens NX 
File > LiveTransfer(TM) > To Creo(Pro/E) 
File > LiveTransfer(TM) > To Inventor 
File > LiveTransfer(TM) > Save As CATIA V4 
File > LiveTransfer(TM) > Save As CATIA V5 
 
 
 

File > LiveTransfer(TM) > To Inventor 
 

What 

The LiveTransfer™ To Inventor command is used to directly export features and modeling histories 
to the Inventor application. 

 
 
 

Why 

The LiveTransfer™ To Inventor tool is useful for: 

• Transferring data into the Inventor application 
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How to Use 

How use the LiveTransfer™ To Inventor command 
1. Go to File > LiveTransfer(TM) > To Inventor. 

 

Note:  

The application currently supports Inventor 2010, 2011, 2012, and 2013. 

 
 

2. Choose Start From First Feature in the dialog tree. 
 

3. Click OK to finish the command. 
 
 

Options in Detail 

Methods 

This tool features 3 different methods: 

• Start From First Feature 

All features starting from the first feature in the Feature Tree will be exported into Inventor 

• Resume From Selected Feature 

All features starting from a selected feature in the Feature Tree will be exported into Inventor 

• Only Selected Entities 

Only selected features will be exported into Inventor 

 
 

Options 

Inventor (Version) – Chooses a dedicated software version. 
 

Note:  

When different versions of Inventor are installed in the same PC, the Inventor (Version) option will be 
displayed. 

 
Prefix For Feature Name – Defines the prefix for a feature name. 
 
Try To Transfer Sweep/Loft As Parametric Feature – Transfers Sweep and Loft features as 
parametric features into Inventor, however if the sweeping and lofting algorithms are different 
between the applications then the features will be transferred as dummy objects. 
 
Feature – Selects a feature to start transferring. 
 
Entities – Selects entities only to transfer. 
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Inventor Options 

Use Custom Inventor Execution File Path – Manually defines the path of an Inventor 
application execution file. 
 

Pause At … 

Pause At – Pauses a transfer before a selected command is performed. 
 
 

See Also 

File > LiveTransfer(TM) > To SolidWorks 
File > LiveTransfer(TM) > To Siemens NX 
File > LiveTransfer(TM) > To Creo(Pro/E) 
File > LiveTransfer(TM) > To AutoCAD 
File > LiveTransfer(TM) > Save As CATIA V4 
File > LiveTransfer(TM) > Save As CATIA V5 
 
 
 
 

File > LiveTransfer(TM) > To Solid Edge 
 

What 

The LiveTransfer™ To Solid Edge command is used to directly export solid and surface bodies to 
the Solid Edge application. 
 

 
 

Note:  

The Boolean option in the import function of Solid Edge must be turned off before using this command if a 
user wants to transfer multiple bodies without the bodies getting merged. 
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Why 

The LiveTransfer™ To Solid Edge tool is useful for: 

• Transferring data into the Solid Edge application 

 
 

How to Use 

How use the LiveTransfer™ To Solid Edge command 
1. Go to File > LiveTransfer(TM) > To Solid Edge. 

 

Note:  

The application currently supports Solid Edge ST4, ST5, and ST6. Only one version of Solid 
Edge can be installed on a computer at one time. 

 
 

2. Select solid bodies or surface bodies as the Entities in the dialog tree. 
 

Note:  

Only solid and surface bodies can be transferred. 
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3. Click OK to finish the command. 

 

 
 
 

Options in Detail 

Options 

Prefix For Feature Name – Defines the prefix for a feature name. 
 
Entities – Selects entities only to transfer. 
 

Solid Edge Options 

Use Custom Solid Edge Execution File Path – Manually defines the path of a Solid Edge 
application execution file. 

 
 

See Also 

File > LiveTransfer(TM) > To Siemens NX 
File > LiveTransfer(TM) > To Creo(Pro/E) 
File > LiveTransfer(TM) > To AutoCAD 
File > LiveTransfer(TM) > To Inventor 
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File > LiveTransfer(TM) > Save As CATIA V4 
File > LiveTransfer(TM) > Save As CATIA V5 
 
 
 

File > LiveTransfer(TM) > Save As CATIA V4 
 

What 

The LiveTransfer™ Save As CATIA V4 command is used to save files in the CATIA 4.1.9 format. 
Sketches and Bodies can be saved in the .model format. 
 
 

Why 

The LiveTransfer™ Save As CATIA V4 tool is useful for: 

• Saving data as the CATIA V4 file format 

 
 

How to Use 

How use the LiveTransfer™ Save As CATIA V4 command 
1. Go to File > LiveTransfer(TM) > Save As CATIA V4. 

 

Note:  

To use this command the Geomagic Exchange™ License must be purchased and installed 

 
 

2. Type a File name and select Except Hidden Entities and Use Custom Settings option 
boxes if desired. 
 

3. Click Save to finish the command. 
 
 

Options in Detail 

Options 

Except Hidden Entities – Will not export hidden sketches and bodies. 
 
Unit – Defines the measurement unit of the entity to be saved. 

 
 

See Also 

File > LiveTransfer(TM) > To SolidWorks 



Geomagic Design X | Menu  192 
 

File > LiveTransfer(TM) > To Siemens NX 
File > LiveTransfer(TM) > To Creo(Pro/E) 
File > LiveTransfer(TM) > To AutoCAD 
File > LiveTransfer(TM) > To Inventor 
File > LiveTransfer(TM) > Save As CATIA V5 
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File > LiveTransfer(TM) > Save As CATIA V5 
 

What 

The LiveTransfer™ Save As CATIA V5 command is used to save files in the CATIA V5 R6 format. 
Sketches and Bodies can be saved in the .model format. 
 
 

Why 

The LiveTransfer™ Save As CATIA V5 tool is useful for: 

• Saving data as the CATIA V5 file format 

 
 

How to Use 

How use the LiveTransfer™ Save As CATIA V5 command 
1. Go to File > LiveTransfer(TM) > Save As CATIA V5. 

 

Note:  

To use this command the Geomagic Exchange™ License must be purchased and installed 

 
 

2. Type a File name and select Except Hidden Entities and Use Custom Settings option 
boxes if desired. 
 

3. Click Save to finish the command. 
 
 

Options in Detail 

Options 

Except Hidden Entities – Will not export hidden sketches and bodies. 
 
Unit – Defines the measurement unit of the entity to be saved. 

 
 

See Also 

File > LiveTransfer(TM) > To SolidWorks 
File > LiveTransfer(TM) > To Siemens NX 
File > LiveTransfer(TM) > To Creo(Pro/E) 
File > LiveTransfer(TM) > To AutoCAD 
File > LiveTransfer(TM) > To Inventor 
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File > LiveTransfer(TM) > Save As CATIA V4 
 
 
 

7.1.13. File > Batch Process 
 

What 

The Batch Process commands execute a series of programs or “jobs” on a computer without manual 
intervention. 
 
 

Why 

The Batch Process commands are useful for: 

• Processing jobs when computer resources are less busy 

• Avoiding idling computing resources with minute-by-minute intervention and supervision 

• Sharing optimized processing with others 

• Fully utilizing computing resources, helping to amortize the cost of the machine 

 
 

See Also 

File > Batch Process > Run  
 
 
 

File > Batch Process > Design 
 

What 

The Batch Process Design command is used to plan a series of commands and set parameters for 
a batch process. 
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Why 

The Batch Process Design tool is useful for: 

• Easily and intuitively designing a batch job 

 
 

How to Use 

How design a Batch Process 
1. Go to File > Batch Process > Design or click the icon in the toolbar. 

 
2. Click the New Batch Process button  to create a new batch job. 

 
3. Drag and drop the Align icon into the right panel. 

 
 

4. Add more commands using the same method. The processing order can be changed by 
dragging the icons in the right panel. The process will start from the top to the bottom. 

 
 

Note:  

Copy, Paste, and Delete commands using the pop-up menu for each command 
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5. Click added commands in the right panel to set its parameters. A dialog tree will appear 
and parameters for methods and detail options can be defined. 

 
 

6. The batch process automatically saves and when the Batch Process Design command 
is executed the last batch state will be show. The batch process can be exported using 

the  Export Batch Process button. To execute the batch process, go to File > Batch 

Process > Run or click the  Run Batch Process button. 
 
The batch file is automatically saved as an .xml formatted file at the following location: 
..\Users\User Name\Documents\Product Name\Configure\BatchProcess 

 
 

How to use a batch template 
When you run the Batch Process Design or Run commands, you can use or edit default batch 
template files. 
 
Auto Surfacing (Mesh only, XDL out)-[General] – Generates fitting surfaces using Auto Surface 
with the Feature Following Network options based on a mesh and saves the final data in the .xdl 
format. 
 
Data Conversion_Any Scan Format to ICF-[General] – Used to reduce the file size of point clouds 
or meshes. Files are saved in the .icf format. 
 
General Mesh Generation (XDL out)-[Object Scan] – Generates a single complete mesh from non-
aligned multiple meshes and saves the final data in the .xdl format. 
 
MeshBased_1 Data Polishing (XDL out)-[Long Range] – From MeshBased_1 to 4 are continuous 
processes used to generate mesh from a long range scan data. This batch file removes noise in a 
point cloud and saves the final data in the .xdl format. 
 
MeshBased_2 Alignment (XDL out)-[Long Range] – The second step for long range scan data 
processing. It aligns multiple point clouds using the Local Based On Auto Guess and Global And 
Fine options. The final data is saved in the .xdl format. 
 
MeshBased_3 Triangulation (XDL out)-[Long Range] – The third step for long range scan data 
processing. It generates meshes using 2D Triangulation with the Spherical option. The final data is 
saved in the .xdl format. 
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MeshBased_4 Single Mesh Generation (XDL out)-[Long Range] – The forth step for long range 
scan data processing. It merges meshes creating a single mesh. The final data is saved in the .xdl 
format. 
 
PointBased_1 Data Polishing (XDL out)-[Long Range] –PointBased_1 to 4 are continuous 
processes used to generate a single point cloud from long range scan data. This batch file removes 
noise in a point cloud and saves the final data in the .xdl format. 
 
PointBased_2 Alignment (XDL out)-[Long Range] – The second step for long range scan data 
processing. It aligns multiple point clouds using the Local Based On Auto Guess and Global And 
Fine options. The final data is saved in the .xdl format. 
 
PointBased_3 Single Point Cloud Generation (ICF out)-[Long Range] – The third step for long 
range scan data processing. It generates a single combined point cloud. The final data is saved in 
the .xdl format. 
 
Watertight Mesh Generation for FEM (XDL out)-[Object Scan] – Generates a single watertight 
mesh from non-aligned multiple meshes and saves the final data in the .xdl format.  
 
 

Options in Detail 

 New Batch Process – Creates a new batch process. 
 

 Import Batch Process – Imports a batch process saved in the .xml format. 
 

 Export Batch Process – Exports a batch process in the .xml format. 
 

 Delete Batch Process – Removes a selected batch process. 
 

 Delete All Batch Processes – Removes all batch processes. 
 

 Run Batch Process – Executes a selected batch process which can also be accessed by 
going to File > Batch Process > Run. 

 
 

See Also 

 
File > Batch Process > Run  
 
 

File > Batch Process > Run 
 

What 

The Run Batch Process command is used to execute a designed batch job. 
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Why 

The Run Batch Process tool is useful for: 

• Running designed batch jobs 

 
 

How to Use 

How run a Batch Process 
1. Go to File > Batch Process > Run or click the icon in the toolbar. 

 
2. Choose a designed batch job. 

 
 
The processes for the selected job will be displayed in a dialog box. 

 
 

3. Choose the Run Process With Each Folder option to process all scan files in a specific 
folder. 

 
 

4. Click Add and insert scan files 

 
 

5. Define the location and folder name to output to. 
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6. Click the Start Batch Process button. 
 
 

Options in Detail 

Methods 

Run Process With Each Folder – Runs the batch process using folders. 
 
Run Process With Each File – Runs the batch process using individual files. 
 

Source Data 

Add – Adds source data. 
 
Delete – Deletes source data. 
 
Filter – Filters the source data. 
 

Output Data 

Source Data Folder – Saves output files in the same folder as the source files. 
 
User Specified Folder – Saves output files to a user-specified folder. 
 
Sub Folder Name – Creates a sub-folder in a user-specified folder. 
 
Save Final Model File As XRL File – Saves output files as .xrl formatted files. 
 

Same Name As Source Data – Saves output .xrl file with the same name as the source 
data file. 

 
User Specified Name – Saves output .xrl file with a user-specified name. 

 
Generate Log File – Creates a log file of the batch process in a .txt formatted file. 
 

File Path – Chooses a file path for a log file. 
 

Action When Error Occurs 

Ignore Error And Continue Batching All Source Data – Continues batching if an error is 
detected. 
 
Stop Batching Current Source Data And Skip to Next Source Data – Skips the current batch 
process if an error is detected. 
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Stop Entire Batch Process – Stops the entire batch process if an error is detected. 

 
 

See Also 

File > Batch Process > Design  
 
 
 

7.1.14. File > Preferences  
 

What 

The Preferences commands manage global options that affect all objects in the viewing window. 
Options are saved to each .xpf file and can be used later. 

Note:  

After updating the application, customized settings files from older versions of the application such as 
the Template, MaterialInfo.xmt.rfPreference.xpf, rfSpaceball.cfg, and rfToolBarInfo.cfg can be used again. 
These files are located at: ..\Users\User Name\Documents\Product Name 

 
 

Why 

The Preferences commands are useful for: 

• Changing colors 

• Changing line, point, and edge sizes 

• Changing global tolerances 

• Changing hardware settings 

• Changing input/output settings 

• Changing general settings 

 
 

How to Use 

How to set up Preferences 
1. Note:  

When starting the application for the first time the Initial Setup Dialog box will be displayed. 
True or False can be selected for the option to Use Previous Version of customized settings. 
To enable the option make sure the setting file of previous versions is located at: 
C:\Documents and Settings\User Name\My Documents\Product Name. 

The settings for toolbars and customized toolbars can be imported, however the position of 
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customized toolbars cannot be imported and will be in a hidden state by default. 

 
Go to File > Preferences. 
 

2. The Preference dialog box will be displayed. Change the Background color to light 
green in the Dialog Tree section in the Display tab. 

 
 

3. Click Apply to apply changes without closing the dialog box. The color of the dialog 
tree will become green. 

 
 

4. Change preferences as desire and click OK to accept or Cancel to exit Preferences. 
Preferences can be exported as a .xpf file by using the Export button, and can also be 
imported by using the Import button. The Reset button will return the Default 
Decimal Place, Default Measure Unit, Thousand Separators preferences as well as all 
entities in the display tab to their default states. 

 
 

Options in Detail 

General Tab 

Enable Multi-thread – Enables multiple core or multiple thread enabled processors to utilize 
multiple threads, speeding up the modeling process. 
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Template XRL File – Specifies the xrl file that is used as the template. 
 
Update Product Automatically – Updates the application automatically when the option is set 
to True and the program is launched. 
 
Cache Folder For Unloading And Backup – Specifies a directory for temporary file caching and 
is located in the user's temporary directory assigned by the system environment variables by 
default. 
 

Note:  

When working with large files it is recommended that the cache folder is set to a separate dedicated 
hard disk drive. Setting the virtual memory to a separate dedicated hard disk drive can also improve 
performance, especially when using Microsoft Windows Vista OS. 

 
Show Support At Startup – Show the Support tab whenever the application is launched when 
set to True. 
 
Auto Save Reminder In Every X Minutes – Sets the amount of time in-between save dialog box 
reminders. 
 
View Manipulation Style – Selects a view manipulation style (zooming, panning, and rotating) 
from either Rapidform, SolidWorks, Siemens NX, Creo(Pro/E), CATIA, PolyWorks, or Geomagic. 
 
Zooming Center Of Mouse Wheel Scroll – Sets the zooming center to the position of the mouse 
cursor or the center of the screen. 
 
Rotation Angle Of Down/Up Arrow Key (degree) – Sets the rotation angle in the model view   
when using the arrow keys on the keyboard. 
 
Undo Depth (times) – Sets the maximum amount of actions saved for the Undo command. 
 
Default Decimal Place – Sets the number of digits displayed after a decimal point between 1 
and 10. 
 
Default Input (Scanner) Unit – Sets a default input unit. If different unit has been defined in the 
files, prompt will be displayed and ask to change the unit while importing files. 
 

Note:  

The specified default scanner unit will be used for the file unit if the scanner files do not have an internal 
unit definition. This is different than the Default Measure Unit parameter. 

 
Default Measure Unit – Sets the default measurement units for models. 
 
Thousand Separators – Separates thousands from hundreds for Real Value and Integer Value 
numbers that have four or more places to the left of the decimal separator when set to True. 
 
Sound – Specifies the sounds used when command completes, breaks, or sends a message and 
can be either the default application sound or a user-specified sound. 
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Display Tab 

Draw Properties – Sets the color, size, width, backgrounds, and other draw properties for 
entities within the application. 
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Color Mesh – Sets the color of mesh face with Ambient, Diffuse, Specular, and Shininess. 



Geomagic Design X | Menu  205 
 

 
 
Dialog Tree – Sets the color, font, and transparency for dialog trees. 

 
 
Geometry Type Material – Sets the default colors for geometry type materials. 

 
 
 
Body – Sets the default body material colors. 

 
 
Ref. Geometry – Sets the default properties for ref. geometry. 
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Sketch – Sets the default properties for sketches. 
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3D Sketch – Sets the default properties for sketches. 

 

 
 
Manipulator – Sets the default properties for manipulators. 
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Widget – Sets the font if text in widgets. 

 
 
Accuracy Analyzer™ – Sets the default properties for the Accuracy Analyzer™. 

 

 
 
OpenGL – Sets the default properties for OpenGL. 
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Triangle Offset – Displays the offset value of triangles when overlapping with other 
entities. 
 
Line Offset – Displays offset values of lines when overlapping with other entities. 
 
Point Offset – Displays offset values of points when overlapping with other entities. 

 
The value range can be set from -1.0 to 1.0. If the value is set as -1.0, the entities closer to 
the viewer will be displayed. If the value is set as 1.0, entities farther from the viewer will 
be displayed. Using this option can define the overlapping order of entities. 

 
 

Picking Window Size (pixel) – Sets how many pixels from the mouse cursor the selection range 
will consider. This is used to fine-tune the selection of a position when picking target entities. 
 
Enable Animation – Enables animation effects. When this option is set to True, animation effects 
will be applied when changing viewpoints or zooming a model. 
 

Tolerance Tab 

Mesh – Sets the Outlier For Allowable Deviation % value. 
 

Outlier For Allowable Deviation (%) – Ignores the poly-vertices that cause the largest 
deviations within a given value while creating fitting surfaces from mesh data. After 
creating fitting surfaces, the area that will be less than this value. 

 
Geometry Type Checking Control – Sets the criteria of geometry type classification. 
 

Outlier For Geometry Type Checking (%) - Ignores poly-vertices that cause the largest 
deviations within a given value when fitting mesh regions to analytic geometry. After 
creating analytic geometry, the area will be less than this value. 

 
Geometry Type Checking Tolerance (mm) – Tries to fit selected regions to specific 
analytic geometry after removing outliers by the value of the Outlier For Geometry Type 
Checking. If the maximum deviation is within this value, the application will recognize that 
analytic geometry. 

 
Maximum Radius Of Analytic Shape (mm) – Accepts estimated analytic regions if their 
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radius values are less than a given value when the application estimates selected regions 
to be analytic geometry. This value prevents the application from estimating a selected 
region as a meaningless analytic geometry. 

 
Geometry Fitting Control – Sets the geometry fitting control properties. 
 

Set Maximum Point Number For Geometry Fitting And Type Finding – Limits the 
number of points used for fitting when this option is True. When it is False, all points inside 
of the searching zone will be used for fitting. 

 
Maximum Point Number – Defines the maximum number of points to be used for fitting. 

 

Hardware Tab 

Processor Feature Support – Sets processor feature support properties. SSE2 (Streaming SIMD 
Extensions), SSE3 or SSSE3 can be enabled which are provided by a CPU for higher processes. 
These optimized settings are automatically set by the application after installing or running the 
Performance Profiler (Help > Launch Performance Profiler). 
 
OpenGL Renderer Setup – Sets OpenGL rendering properties. 
 

Use Trackball Depth Average – Determines whether OpenGL depth buffer is used for 
calculating rotation center. 
 
Trackball Depth Average Resolution – Sets the resolution of queries of OpenGL depth 
buffer for calculating rotation center. 
 
Frame Buffer Save/Restore – Chooses which routine is used for saving and restoring the 
frame buffer. The rendering and speed settings are automatically set by the application 
after installing or running the Performance Profiler (Help > Launch Performance Profiler). 
 
Off-Screen Rendering Mode – Determines which graphic acceleration is used while 
capturing view. If a graphic device supports hardware acceleration, it is recommended 
setting this option as Hardware. 
 
Hardware Multi-thread Rendering Support – Sets multi-threaded rendering support 
when Hardware is selected in the Off-Screen Rendering option by selecting true or false. 
Set to false when hardware cannot support this option. 
 
Use Video RAM For Rendering Acceleration – Loads data into video memory and speeds 
up rendering performance when this option is set to True. The default setting is False, 
however, it is recommended to turn on this option for most graphic cards when handling 
millions of meshes to prevent any abnormal display problems. 
 
Use Shader Programs For Rendering Acceleration - Determines whether shader 
programs are used for enhancing rendering speed. 
 

Scanner Direct Control – Sets frequently used scanners so when the LiveScan™ command is 
used only those scanners will be displayed in the Devices pull down menu. 
 

File I/O 

Default Import File Formats – Sets True/False values for importing commonly used file formats. 
Only commonly used formats will be displayed in the Import dialog box. 
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Locale 

Language – Sets the display language of the application. Installed language packs will be listed. 
 

Locale Format – Sets the numbers and time display format. 

 
 

See Also 

Docking Bars > Display  
 
 
 

7.1.15. File > Summary Info 
 

What 

The Summary Info command allows for the input of summary information for a model. 

Note:  

While opening a saved file, the summary information shows if the Show Preview & Info Box option is 
checked in the Open dialog box.  

 
 

Why 

The Summary Info command is useful for: 

• Changing basic file summary information 

 
 

How to Use 

How to change summary information 
1. Go to File > Summary Info. 

 
2. The Summary Information dialog box is displayed. 
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3. Change summary information as desire and click OK to accept or Cancel to exit the 
Summary Information command. 

 
 
 

7.1.16. File > Recent Files 
 

What 

The Recent Files command lists the recently used files in the application. 
 
 

Why 

The Recent File command is useful for: 

• Conveniently viewing recently used files 

 
 

How to Use 

How to view and open recent files 
1. Go to File > Recent Files. Mouse-over the command and a black arrow pointing to the 

right will be displayed showing recently opened files.  
 

2. Select a file to open it. 
 
 

See Also 
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File > Open  
 
 
 

7.1.17. File > Exit 
 

What 

The Exit command closes the application. 
 
 

Why 

The Exit command is useful for: 

• Closing the application after a project is finished 

• Closing the application when the system is not in use to free computing resources 

 
 

How to Use 

How to exit the application 
1. Go to File > Exit.  

 
2. If there are unsaved changes a dialog box will be displayed. 

 
3. Save files as desire and click OK to accept or Cancel to exit the Exit command. 

 
 

See Also 

File > Save  
File > Save As  
 
 
 

7.2. Select 
 

Selection 

When most of commands are executed, the selection mode is automatically activated. The Select 
menu features advanced selection tools, which allows the selection of various entities in the Model 
View. 
 
 

Select Filter 
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Select various kinds of entities within in the application. 
 

 (Filter Meshes) - Allows the selection of meshes only. 

 (Filter Regions) - Allows the selection of regions only. 

 (Filter Poly-faces) - Allows the selection of poly-faces only. 

 (Filter Poly-vertices) - Allows the selection of vertices and points only. 

 (Filter Mesh Boundaries) - Allows the selection of mesh boundaries only. 

 (Filter Bodies) - Allows the selection of bodies only. 

 (Filter Faces) - Allows the selection of faces only. 

 (Filter Loops) - Allows the selection of loops only. 

 (Filter Edges) - Allows the selection of edges and curves only. 

 (Filter Vertices) - Allows the selection of vertices and points only. 

 (Filter Ref. Geometries) - Allows the selection of ref. geometries only.  

 (Filter Sketches) - Allows the selection of sketches only. 

 (Filter Constraints & Dimensions) - Allows the selection of constraints and dimensions only. 

 (Clear All Filters) - Clears all selection filters (Shift + F). 
 
 

Note:  

When a selection filter is on but the cursor is over an empty area, an icon (  ) beside the cursor will 
appear. 

-  When the Mode is changed, the Selection Filters will be reset. 

-  Selection Filters can be quickly accessed by the pop-up menu. 

 
 
 
  



Geomagic Design X | Menu  215 
 

 

7.2.1. Select > Mode 
 

What 

The Select Mode command configures the shape of the selection tool. 
 
 

Why 

The Select Mode command is useful for: 

• Changing the shape of the selection tool to provide flexibility in selecting entities 

 
 

How to Use 

How to use the selection tool 
1. Go to Select > Mode or click the icon in the toolbar.  

 
2. Choose the selection mode type.  

 
3. Drag the selection tool over entities to select. To add a current selection to selections 

already made, use the Shift button. To remove a current selection from selections 
already made, use the Ctrl button. 

 
 

Options in Detail 

Note:  

All selection modes are able to select poly-vertices and poly-faces. The Rectangle selection is the 
default selection mode in the application and can select any entities.  

 
Line – Selects a straight line by clicking at one end of a supposed line and dragging to another. 

  
 

Note:  

The width of a line can be edited by using Alt + left mouse buttons together. 

 
Rectangle – Selects a region by dragging from one corner of an imaginary box to the opposite 
diagonal corner. 
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Circle – Selects a circular region by clicking in the center of a supposed circle and dragging 
outward. 

  
 

Note:  

The radius of a circle can be edited by using Alt + left mouse buttons together 

 
Polyline – Selects the inside of a polygon by picking points in the viewing window and clicking 
the RMB or double-clicking the LMB to finalize. 

  
 
Freehand – Selects an irregularly shaped region by tracing a perimeter with the mouse while 
dragging. 

  
 
Paint Brush – Selects regions that the mouse cursor covers during the dragging. 

  
 

Note:  

The range of the paint brush can be edited by using Alt + left mouse buttons together 
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Flood Fill – Selects poly-faces within same boundary. 

  
 
Extend To Similar – Select areas that consist of similar features. 

  
 
Extend To Sudden Change – Selects areas that have similar curvatures. 

  
 
Box – Configures the shape of the selection tool as a box. 

  
 
Cylinder – Configures the shape of the selection tool as a cylinder. 

  
 
Sphere – Configures the shape of the selection tool as a sphere. 

  
 
Visible Only – Decides whether selecting can take place on a visible area only or in space. 
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Position Snap – Snaps to meshes or bodies when an object is picked. The snap distance and 
snap plane can be defined in the bottom toolbar. 

 
 
 

See Also 

Mode  
 
 
 

7.2.2. Select > All 
 

What 

The Select All command selects all entities. 
 
 

Why 

The Select All command is useful for: 

• Selecting all entities in the model view 

 
 

How to Use 

How to select all entities 
1. Go to Select > All – Poly-Faces in the Mesh mode, click the icon in the toolbar, or use 

the Shift + A keyboard shortcut. All poly-faces can also be selected by using the RMB 
(Right Mouse Button) and selecting all in the pop-up menu. 

 
 

2. All poly-faces will be selected. 
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See Also 

Select > None  
Select > Inverse 
 
 
 

7.2.3. Select > None 
 

What 

The Select None command de-selects all entities. 
 
 

Why 

The Select None command is useful for: 

• Selecting all entities in the model view 

 
 

How to Use 

How to de-select all entities 
1. Select poly-faces in the model. 

 
 

2. Go to Select > None, click the icon in the toolbar, or use the Shift + N keyboard shortcut. 
All poly-faces can also be de-selected by using the RMB (Right Mouse Button) and 
selecting none in the pop-up menu. 
 

3. No poly-faces will be selected. 

 
 
 

See Also 

Select > All 
Select > Inverse 
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7.2.4. Select > Inverse 
 

What 

The Select Inverse command selects the inverse of selected entities. 
 
 

Why 

The Select Inverse command is useful for: 

• Selecting the inverse of already selected entities 

 
 

How to Use 

How to select the inverse of entities 
1. Select poly-faces in the model. 

 
 

2. Go to Select > Inverse, click the icon in the toolbar, or use the Shift + I keyboard 
shortcut. The inverse can also be selected by using the RMB (Right Mouse Button) and 
selecting the inverse in the pop-up menu. 
 

3. The inverse of the originally selected poly-faces will be selected. 

 
 
 

See Also 

Select > All 
Select > None  
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7.2.5. Select > Custom Region 
 

What 

The Select Custom Region command selects an area made by user selected vertices. 
 
 

Why 

The Select Custom Region command is useful for: 

• Selecting or de-selecting complex regions 

 
 

How to Use 

How to select a custom region 
1. Go to Select > Custom Region or click the icon in the toolbar.  

 

Note:  

The Custom Region command can only be used in the Mesh mode. 

 
 

2. Select the Add option. Pick poly-vertices to form a region. 

 
 

3. Click on the starting node or use the Close Path button to close the path. 

 
 

4. Click OK to finish the command. 
 
 

Options in Detail 

Custom Path – Creates a custom path. 
 

Note:  
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A custom path drawn in a counterclockwise direction selects an inner region, but creating a custom 
path in a clockwise direction selects an outer region. The Undo Last Path button is used to cancel the 
last selection made, the Close Path button to close and finalize the custom path, and the Reset 
button to discard all selections made 

 
Add – Adds a selected region to existing selections. 
 
Remove – Removes a selected region from the existing selections. 
 
Inverse – Selects the inverse regions of existing selections. 

 
 

See Also 

Select > All 
Select > None  
Select > Inverse 
 
 

7.2.6. Select > Boundary Entities 
 

What 

The Select Boundary Entities command selects poly-vertices or poly-faces around selected 
boundaries.  
 
 

Why 

The Select Boundary Entities command is useful for: 

• Selecting complex regions around a boundary 

 
 

How to Use 

How to select boundary entities 
1. Go to Select > Boundary Entities or click the icon in the toolbar. 

  
 

2. Change the Type To Select to Poly-Faces and select the boundary. 
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3. Click OK to finish the command. Poly-faces around the boundary will be selected. 

 
 
 

Options in Detail 

Type To Select – Chooses whether to select poly-faces or poly-vertices around a boundary. 
 
Seed Boundaries – Selects boundaries on a mesh in the model view. 

 
 

See Also 

Select > All 
Select > None  
Select > Inverse 
 
 
 

7.2.7. Select > Entities Around Edges/Faces 
 

What 

The Select Entities Around Edges/Faces command selects poly-vertices or poly-faces around 
selected entities. 
 
 

Why 

The Select Entities Around Edges/Faces command is useful for: 

• Selecting entities around created edges and faces 

 
 

How to Use 

How to select entities around poly-faces 
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1. Go to Select > Entities Around Edges/Faces or click the icon in the toolbar. 

  
 

Note:  

The Entities Around Edges/Faces command can only be used in Mesh, Region Group, and 
Point Cloud modes. 

 
 

2. Select a face on a body for the Seed Entities. Change the option to Poly-Faces. 

 
 

3. Click OK to finish the command. Poly-faces around the face will be selected. 

 
 
 

Options in Detail 

Seed Entities – Selects entities (curves, edges, faces) that will be used to find poly-vertices or 
poly-faces in the model view. 
 
Options – Chooses Poly-Faces or Poly-Vertices are the final selected entity type. 

 
 

See Also 

Select > All 
Select > None  
Select > Inverse 
 
 
 

7.2.8. Select > Enlarge 
 

What 
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The Enlarge command enlarges a selection by a specified depth or angle. Depending on the type 
of selected entity, the options in the dialog tree will be shown differently. The command will not be 
available until entities have been selected. 
 
 

Why 

The Enlarge command is useful for: 

• Selecting areas that would be difficult to select manually 

 
 

How to Use 

How to select entities using the Enlarge command 
1. Select faces. Poly-faces, Poly-vertices, Faces, Edges and Regions can be selected for the 

Enlarge command. 

 
 

2. Go to Select > Enlarge or click the icon in the toolbar. Change the Angle to 15 degrees. 

 
 

3. Click OK to finish the command. Poly-faces around the face will be selected. 

 
 
 

Options in Detail 

Type To Select – Chooses entity type to select. 
 
Poly-Faces/Poly-Vertices/Faces/Edges/Region – Shows currently selected entities. 
 
Depth – Expands the selection of entities by a specified depth. 
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Depth 2 

 
Angle – Enlarges regions by a specified angle for poly-faces and poly-vertices. 

   
Initial Selection Angle: 25 Angle: 60 

 
Angle Tolerance – Limits the angle tolerance when comparing other neighboring entities 
when an edge or face has been selected. 
 
Forward Depth – Selects more edges when an edge or face is selected. 

 
Forward Depth from the Initial Selection 

 
Backward Depth – Selects more edges in the opposite direction from Forward Depth when 
an edge or face is selected. 

 
Forward Depth from the Initial Selection 

 

 
 

See Also 

Select > All 
Select > None  
Select > Inverse 
Select > Shrink 
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7.2.9. Select > Shrink 
 

What 

The Shrink command shrinks selected poly-faces by a specified depth. The command will not be 
available until entities have been selected.  
 
 

Why 

The Shrink command is useful for: 

• Shrinking a selected area that might otherwise be difficult to do manually 

 
 

How to Use 

How to select shrink entities 
1. Go to Select > Shrink or click the icon in the toolbar. The pop-up menu can also be used 

after selecting poly-faces. 

 
 

2. Change Depth to 1. 

 
 

3. Click OK to complete the command. 

 
 
 

Options in Detail 

Type To Select – Chooses entity type to select. 
 
Poly-Faces/Poly-Vertices – Shows currently selected entities. 
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Depth – Shrinks the selection of entities by a specified depth. 

 
 

See Also 

Select > All 
Select > None  
Select > Inverse 
Select > Enlarge 
 
 
 

7.2.10. Select > Convert Current Selection 
 

What 

The Convert Current Selection command converts entities to another entity type. The command 
will not be available until entities have been selected.  
 
 

Why 

The Convert Current Selection command is useful for: 

• Converting one type of entity to another quickly and effectively 

 
 

How to Use 

How to convert entities 
1. Select an edge to convert to a vertex. 

 
 

2. Go to Select > Convert Current Selection or click the icon in the toolbar. The pop-up 
menu can also be used after selecting poly-faces or poly-vertices. 
 

3. Click OK to complete the command. The edge will be changed to a vertex. 
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Options in Detail 

From – Shows selected entity type. 
 
To – Shows entity type for conversion. 
 

Conversion List 

From To 
Poly-Vertex Poly-Face 

Region Poly-Face 
Mesh Loop(Boundary Loop) Poly-Face 

Modeling Feature Body Face 
Body Face Body Edge 
Body Edge Body Vertex 

2D/3D Curve 2D/3D Node Point 
 

 
 

See Also 

Select > All 
Select > None  
Select > Inverse 
 
 
 

7.2.11. Select > By Criteria 
 

What 

The Select By Criteria command selects components of a model, 2D and 3D sketch entities based 
on criteria such as edge, length, angle, area, or other components. 
 
 

Why 

The Select By Criteria command is useful for: 

• Selecting large amounts of components based on type quickly 

 
 

How to Use 

A. How to select components by criteria in Mesh or Region Group 
mode 
1. Go to Select > By Criteria or click the icon in the toolbar. 
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2. Check the Larger Than option under the Max. Edge Length option to select all faces 
larger than a specified value. Click the Estimate button and the application will 
recommend a reasonable value. 
 

3. Click OK to complete the command. Mesh that is larger than the recommend value will 
be highlighted. 

 
 
 

B. How to select components by criteria in Sketch or Mesh Sketch 
mode 
1. Go to Select > By Criteria or click the icon in the toolbar. 

 
 

2. Select the Entity Type(s) for selection and Larger Than for the Length and click the 
Estimate button. The application will recommend a reasonable value. 

 
 

3. Click OK to complete the command. Sketch entities that are larger than the recommend 
distance will be highlighted. 
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Options in Detail 

Max. Edge Length – Sets criteria as length. 
 

Smaller Than – Sets length criteria for a maximum length. 
 

Larger Than – Sets length criteria for a minimum length. 
 
Area – Sets criteria as area. 
 

Smaller Than – Sets area criteria for a maximum area. 
 

Larger Than – Sets area criteria for a minimum area. 
 
Max./Min. Edge Length Ratio Is Larger Than – Selects all poly-faces that have a ratio between 
the length of the longest edge and length of the shortest edge that is larger than a specified 
value. 
 
Max. Edge Length/Max. Height Ratio Is Larger Than – Selects all poly-faces that have a ratio 
between the length of the longest edge and height of the longest edge that is larger than a 
specified value. 
 
Angle Deviation From Plane Is Larger Than – Selects faces that have an angle deviation from 
a plane that is larger than a specified value and is useful for detecting sharp faces on a smooth 
surface. 
 
Crease Angle Is Larger Than – Selects faces that have a crease angle larger than a specified 
angle. 
 
Entity Type – Sets entities as criteria from Lines, Circles, Arcs, Ellipses, Partial Ellipses, and 
Parabolas. 
 
Major Radius – Sets criteria as major radius. 
 

Smaller Than – Sets major radius criteria for a maximum length. 
 

Larger Than – Sets major radius criteria for a minimum length. 
 
Minor Radius – Sets criteria as minor radius. 
 

Smaller Than – Sets minor radius criteria for a maximum length. 
 

Larger Than – Sets minor radius criteria for a minimum length. 
 
 

See Also 

Select > All 
Select > None  
Select > Inverse 
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7.2.12. Select > By Color 
 

What 

The Select By Color command selects poly-faces or poly-vertices by color. The command is enabled 
when poly-faces or poly-vertices include color or texture information and can be used in Mesh, 
Region Group, or Point Cloud mode. 
 
 
 

Why 

The Select By Color command is useful for: 

• Selecting poly-faces or poly-vertices by color 

 
 

How to Use 

How to select entities by color 
1. Enter Mesh mode. 

 
 

2. Go to Select > By Color or click the icon in the toolbar. 
 

3. Change the Type To Select option to Poly-Faces. Click the Pick Color button  and 
extract a color from the mesh. Change the Fuse option to 200. 

 
 

4. Click the Add Color  button to extract similar colors on the mesh. 
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5. Click OK to complete the command. 
 
 

Options in Detail 

Type To Select – Selects a type of entity to be selected. 
 
Color – Selects colors allows the use of the Pick Color, Add Color, and Remove Color buttons 
to select colors. 
 
Fuse – Selects the level of diffusion when selecting similar colors. 
 
Add – Adds a selection when Poly-Faces or Poly-Vertices are selected before using the Select 
By Color command. 
 
Remove – Removes a selection when Poly-Faces or Poly-Vertices are selected before using the 
Select By Color command. 
 
Replace – Replaces a current selection when Poly-Faces or Poly-Vertices are selected before 
using the Select By Color command. 

 
 

See Also 

Select > All 
Select > None  
Select > Inverse 
 
 
 

7.2.13. Select > Exterior Poly-Face 
 

What 

The Select Exterior Poly-Face command selects exterior regions of poly-faces on mesh data. It can 
be used on volume reconstructed mesh or mesh with multiple layers. It can be used in Mesh or 
Region Group modes with mesh data.  
 
 

Why 

The Select Exterior Poly-Face command is useful for: 

• Separating exterior poly-faces from interior poly-faces 

 
 

How to Use 

How to select exterior poly-faces 
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1. Go to Select > Exterior Poly-Face or click the icon in the toolbar. Mesh that has poly-
faces inside and outside such as a model captured by a CT scanner can be used. 

 
 

2. Set Initial Radius to 10, Expand Radius to 5, and Tolerance to 0.3. 

 
 

3. Click OK to complete the command. 
 

4. Copy the selected outside surface by going to Edit > Copy. 
 

5. Exit Mesh mode and go to Edit > Paste to paste the exterior poly-face mesh. 

 
 
 

Options in Detail 

Initial Radius – Changes the initial radius value used to detect exterior poly-faces. 
 
Expand Radius – Changes the expanded radius value from a seed region, which is an initially 
selected point or face. 
 
Tolerance – Changes the interruption areas caused by noise on mesh. 

 
 

See Also 

Select > All 
Select > None  
Select > Inverse 
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7.3. Edit 
 
The Edit menu features commands to handle entities and operation.  
 

Repeating Operation 

• Undo & Redo 

Whenever you want to cancel the applied operation, use the Undo command. If you want to 
restore the operation from Undo, use the Redo command. 

 

• Repeat Last Command 

Quickly apply the operation that you used previously. 

 
 

Editing Entities 

• Cut, Copy, Paste and Delete 

The Cut, Copy, Paste and Delete operations are available to the selected entities. 

 
 

Navigating Modeling History  

• Rebuild 

Rebuilds a model with the current version of the application based on the model history. 

 

• Rollback, Roll Forward, Roll To End 

Navigates modeling history to return to a certain point of modeling feature. 

 
 

Showing or Hiding Features in History 

• Suppress and Unsuppress 

Temporarily removing features from the model. 

 
 

Editing Feature 

• Feature 

Edits a selected feature. 
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7.3.1. Edit > Undo 
 

What 

The Undo command undoes previous operations. 
 
 

Why 

The Undo command is useful for: 

• Reversing mistakes made 

• Going back to a previous point 

 
 

How to Use 

How to undo an action 
1. Go to Edit > Undo or use the Ctrl + Z keyboard shortcut. 

 

Note:  

The depth of the Undo command can be changed by going to File > Preferences. The default 
depth is 50. 

 

 
 

See Also 

Edit > Redo  
 
 
 

7.3.2. Edit > Redo 
 

What 

The Redo command reverses the Undo command or advances operations to a more current state 
step-by-step. This command is opposite of undo command. 
 
 

Why 

The Redo command is useful for: 
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• Advancing operations to a more current state 

• Reversing the Undo command 

 
 

How to Use 

How to undo an action 
1. Go to Edit > Redo or use the Ctrl + Y keyboard shortcut. 

 
 

See Also 

Edit > Undo  
 
 
 

7.3.3. Edit > Repeat Last Command 
 

What 

The Repeat Last Command repeats the last used command. 
 
 

Why 

The Repeat Last Command command is useful for: 

• Repeating the last command made if it is going to be used often in a row 

 
 

How to Use 

How to repeat the last command 
1. Go to Edit > Repeat Last Command or use the Ctrl + Space keyboard shortcut. 

 
 

See Also 

Edit > Undo  
Edit > Redo  
 
 
 

7.3.4. Edit > Cut 
 



Geomagic Design X | Menu  238 
 

What 

The Cut command deletes an entity and copies it, saving it to the clipboard to be pasted. 
 
 

Why 

The Cut command is useful for: 

• Removing an entity to use for another time or place 

 
 

How to Use 

How to cut an entity 
1. Select an entity to cut. 

 
2. Go to Edit > Cut or use the Ctrl + X keyboard shortcut. 

 
 

See Also 

Edit > Paste 
Edit > Copy 
 
 
 

7.3.5. Edit > Copy 
 

What 

The Copy command copies a selected entity, saving it to the clipboard to be pasted. 
 
 

Why 

The Copy command is useful for: 

• Creating a copy of an existing entity to be used at a later time or place 

 
 

How to Use 

How to copy an entity 



Geomagic Design X | Menu  239 
 

1. Select an entity to copy. 
 

Note:  

Mesh, Point Cloud, 2D sketches, 3D sketches and Ref. Geometries can be copied in the default 
mode. 

 
 

2. Go to Edit > Copy or use the Ctrl + C keyboard shortcut. 
 
 

See Also 

Edit > Cut 
Edit > Paste 
 
 
 

7.3.6. Edit > Paste 
 

What 

The Paste command copies a selected entity, saving it to the clipboard to be pasted. 
 
 
 

Why 

The Paste command is useful for: 

• Pasting a cut or copied entity 

 
 

How to Use 

How to paste an entity 
1. Select an entity and use the Cut or Copy command. 

 
2. Go to Edit > Paste or use the Ctrl + V keyboard shortcut. 

 
 

See Also 

Edit > Cut 
Edit > Copy 
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7.3.7. Edit > Delete 
 

What 

The Delete command deletes selected entities. 
 
 

Why 

The Delete command is useful for: 

• Removing unnecessary entity 

 
 

How to Use 

How to delete an entity 
1. Select an entity. 

 
2. Go to Edit > Delete or use the Delete key on the keyboard. 

 
 

See Also 

Edit > Undo  
Edit > Redo  
 
 
 

7.3.8. Edit > Rebuild 
 

What 

The Rebuild command rebuilds a model with the current version of the application based on the 
model history. 
 
 

Why 

The Rebuild command is useful for: 

• Updating and rebuilding a model using any changed algorithms or commands in the 
application 

 
 

How to Use 
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How to rebuild a model 
1. Go to Edit > Rebuild or use the icon in the toolbar. 

 
 
 
 

7.3.9. Edit > Rollback 
 

What 

The Rollback command temporarily reverts a model to an earlier state. New features can be added 
or existing features can be edited. 
 
 

Why 

The Rollback command is useful for: 

• Going back to previous step in the modeling process 

 
 

How to Use 

How to rollback a model 
1. Select an entity in the feature tree. 

 
2. Go to Edit > Rollback or use the icon in the toolbar. All entities after the rollback entity 

will be dimmed in the model tree. 
 
 

See Also 

Edit > Roll Forward 
Edit > Roll To End  
 
 
 

7.3.10. Edit > Roll Forward 
 

What 

The Roll Forward command rolls a model forward step-by-step after executing the Rollback 
command. New features can be added or existing features can be edited. 
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Why 

The Roll Forward command is useful for: 

• Going forward step-by-step after using the Rollback command to see changes 

 
 

How to Use 

How to Roll Forward a model 
1. After executing the Rollback command, select an entity in the feature tree. 

 
2. Go to Edit > Roll Forward or use the icon in the toolbar. 

 

See Also 

Edit > Rollback  
Edit > Roll To End  
 
 
 

7.3.11. Edit > Roll To End 
 

What 

The Roll To End command rolls a model to the end of the modeling history after executing the 
Rollback command. 
 
 

Why 

The Roll To End command is useful for: 

• Going to the end of the modeling history after using the Rollback command 

 
 

How to Use 

How to roll a model to the end 
1. After executing the Rollback command, go to Edit > Roll To End or use the icon in the 

toolbar. 
 
 

See Also 

Edit > Rollback  
Edit > Roll Forward 



Geomagic Design X | Menu  243 
 

 
 
 

7.3.12. Edit > Suppress 
 

What 

The Suppress command suppresses a feature, temporarily removing it from the model. 
 
 

Why 

The Suppress command is useful for: 

• Seeing and working with a model without a specific feature 

 
 

How to Use 

How to suppress a feature 
1. Select an entity in the feature tree. 

 
2. Go to Edit > Suppress, or click the icon in the toolbar. 

 
 

3. Suppressed entities will be dimmed in the Model Tree. 

 
 
 

See Also 

Edit > Unsuppress 
 
 
 

7.3.13. Edit > Unsuppress 
 

What 

The Unsuppress command unsuppresses a feature after using the Suppress command. 
 
 

Why 
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The Unsuppress command is useful for: 

• Unsuppressing a feature 

 
 

How to Use 

How to unsuppress a feature 
1. Select a suppressed entity in the feature tree. 

 
2. Go to Edit > Unsuppress, or click the icon in the toolbar. 

 
 

See Also 

Edit > Suppress 
 
 
 

7.3.14. Edit > Feature 
 

What 

The Feature command allows the editing of a selected feature. 

 
 

Why 

The Feature command is useful for: 

• Selecting and editing a feature 

 
 

How to Use 

How select a feature 
1. Select an entity in the feature tree. 

 
2. Go to Edit > Feature, or click the icon in the toolbar. The entity will now be editable. 

 
 
 
 

7.4. Insert 
 
The Insert menu features various commands used to generate or import entities and register them 
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as features with a generation history in the Feature Tree. 
 
The Insert menu provides tools used to: 
 

Import 

• Import Scan Data or CAD Data 

Imports entities that are also treated as features in the application with an importing and editing 
order that reflects the compositions in the modeling history 

 

Mesh 

• Edit meshes 

Fixes errors, optimizes surface quality, and re-constructs the structure of mesh which is normally 
polygonal data from scanners or other software 

 

Region Group 

• Classify Regions 

Generates, edits and optimizes region groups that are groups or regions made up of poly-faces 
that assist in the alignment of mesh data to the global coordinate system and in the selection of 
a region of interest used for extracting design intent and converting to a surface 

 

Point Cloud 

• Edit Point Clouds 

Enables editing and optimizing of point clouds which are a set of vertices in the three-dimensional 
coordinate system. These vertices are usually defined by the X, Y, and Z coordinates 

Solid 

• Generate Solid Bodies 

Generates and edits solid bodies which are A B-rep entities that have both geometry and topology 
information based on a mesh or point cloud 

 

Surface 

• Generate Surface Bodies 

Generates and edit solid bodies which are zero-thickness 3D entities with edge boundaries based 
on a mesh or point cloud 

 

Mesh Sketch 

• Generate Sketches Based on Scan Data 

Generates and edits sectional profiles that consist of a set of 2D objects (lines, rectangles, circles, 
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arcs, ellipses, splines, etc) on a plane, a face, or a planar cross-section, based on a mesh or point 
cloud 

 

Sketch 

• Generate Sketches 

Generates and edits sketch entities that consist of a set of 2D objects (lines, rectangles, circles, arcs, 
ellipses, splines, etc) on a planar entity such as those created in other CAD software 

 

3D Mesh Sketch  

• Generate Splines Based on Scan Data 

Generates a curve network which is a set of 3D curves and lines on mesh faces used for boundary 
fitting surfaces or extracting character curves on a mesh 

 

3D Sketch  

• Generate Splines 

Freely draws splines which are a set of 3D curves and lines in space regardless of a mesh 

 
 
 

7.4.1. Insert > Import 
 

What 

The Insert > Import command imports scan data or CAD data. Imported data is added and 
managed under the Feature Tree. 
 
 
Supported file formats are shown in the following table: 
 

Extension Application Import Export Color Texture Property 

xdl, xrl, rwl XO Model Yes Yes Yes  
Point, Polygon, Curve, 
Surface, Solid 

xpc 
Rapidform 
Extreme Point 
Cloud 

Yes Yes Yes  Point 

mdl Rapidform2006 Yes Yes Yes Yes 
Point, Polygon, Curve, 
Surface, Solid 

asc, xyz, txt Ascii Points Yes Yes Yes  
Point (ASCII), xyz or 
xyzrgb 

pts Geomagic Point Yes  Yes  Point file (ASCII) 

fcs 
Geomagic 
Polygon 

Yes Yes Yes  Polygon file (ASCII) 

stl 
Stereolithograph
y 

Yes Yes   
Polygon (ASCII or 
Binary)  
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obj OBJ  Yes Yes Yes Yes 
Point (Import only), 
Polygon 

ply CyberWare Yes Yes Yes  
Polygon (ASCII or 
Binary) 

3ds 3D Studio  Yes Yes  Yes Point or Polygon 

wrl VRML 1.0/97 Yes Yes Yes Yes Point or Polygon 

icf 
INUS 
Compression File 
Format 

Yes Yes Yes Yes Polygon file 

igs, iges IGES Yes  Yes  Point, Curve, Surface 

stp, step STEP Yes  Yes  Point, Curve, Surface 

x_t, x_b 
Parasolid 
Text/Binary 

Yes  Yes  Solid or Surface 

sat, sab, 
asat, asat 

ACIS Text/Binary 
Part/Assembly 

Yes    
Solid, Surface, Curve, 
Point 

model CATIA V4 Yes Yes   
Solid, Surface, Curve, 
Point 

catpart, 
catproduct 

CATIA V5 
Part/Assembly 

Yes Yes   
Solid, Surface, Curve, 
Point 

prt, prt.*, 
asm, asm.* 

Creo(Pro/Enginee
r) Part/Assembly  

Yes    
Solid, Surface, Curve, 
Point 

prt Siemens NX Yes    
Solid, Surface, Curve, 
Point 

sldprt, 
sldasm  

SolidWorks Yes    
Solid, Surface, Curve, 
Point 

dxf AutoCAD DXF Yes Yes   Point, Polygon, Curve 

scn  NextEngine Yes   Yes 
Polygon, Curve, 
Surface 

ac Steinbichler Yes  Yes  Point or Polygon 
Bre, ctr Breuckmann Yes  Yes  Point 
vvd, cdm,  
cdk 

VIVID Yes   Yes Polygon 

rgv, rvm Range7 Yes    Point, Polygon 

pix PICZA (Roland) Yes    Point, Polygon 

g3d 

GOM 

Yes  Yes  Point or Polygon 

cloud Yes  Yes  Point 

surf Yes  Yes  Point 

pmj, pmjx 3D Digital Corp. Yes    Point 
pts, ptx, 
ptg 

Leica Yes  Yes  Point 

fls 
FARO 

Yes  Yes  Point 

fws Yes  Yes  
The information of 
corresponding fls files 

iqscan iQvolution Yes  Yes  Point 

3dd, rxp Riegl Yes  Yes  Point or Polygon 

xyz, crs, lin, 
smh, bin 

Opton Yes    Point 

soi MENSI Yes  Yes  Point 

btx Surphaser Yes  Yes  Point, Polygon 

stb Scantech Yes    Point 
3pi ShapeGrabber Yes    Point 
sab, sab2 Nikon Metrology Yes  Yes  Point or Polygon 
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swl, swb, 
bin 

Perceptron Yes    Point 

rtpi, xyzi, 
xyzrgb 

DeltaSphere Yes  Yes  Point 

psl, scn, 
pcn 

LDI Yes    Point 

cbk, grk, 
cwk 

Kreon Yes    Point 

icv 
Solutionix 

Yes  Yes  Polygon 
snx Yes    Polygon 

tfm 
Wicks and 
Wilsons 

Yes  Yes  Point 

m3d Steintek Yes    Point, Polygon 
hym Hymarc Yes    Point 
xyz, xyzn Cognitense Yes    Point, Polygon 
opd Optimet Yes  Yes  Point, Polygon 
mpc Mantis Vision Yes  Yes  Point, Polygon 
dat, nas NASTRAN Yes    Polygon 
ans ANSYS Yes    Polygon 
iv Inventor Yes  Yes Yes Point, Polygon 

vda VDA-FS Yes    Curve, Surface 

3dm 
OpenNURBS(Rhin
o) 

Yes    Curve, Surface 

cls Topcon Yes  Yes  Point 
ptc Kubit Yes  Yes  Point 
lsf LiveScan Yes    Point 
i3d Imetric Yes   Yes Point, Polygon 
rge Shining 3D Yes    Point, Polygon 
csd Fujifilm Yes   Yes Point, Polygon 

Color means colors on Poly-Vertex/Face and Texture means an image file such as .jpg. 
 
 

Note:  

The application supports standard file formats (IGES, STEP, VDA-FS, ACIS and Parasolid) without any 
licenses, but for the file formats listed in the table below, the Geomagic Exchange™ License is needed to 
use them. 

CAD File Extension Version Supported Comments 
CATIA V4 .model CATIA 4.1.9 to CATIA 4.2.4 - Geometry Only 

CATIA V5 .CATPart, .CATProduct CATIA V5 R6 through R22 (V5-6 
R2012) 

- Geometry Only 
- Unsupported non-
ASCII character in the 
file name 

Creo(PRO/E) .prt, .prt.*, .asm, .asm.* Pro/E 16 to Wildfire 5, Creo 1.0 to 
2.0 

- Geometry Only 

Siemens NX .prt Unigraphics 11 to 18 and NX1 to 
NX8 

- Geometry Only 

SolidWorks .sldprt, .sldasm SolidWorks 98 to 2013 - Geometry Only 

 
 

 

Note:  

The .icv and .snx Solutionix file formats are supported in the 32-bit version of Geomagic Design X only. 
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Note:  

The following point cloud formats can be converted into polygons with its grid information or 2D 
triangulation processes during the importing process: Ac, Bre, cloud, surf, opton, 3pi, stb, pmj/pmjx, grk, 
tfm, m3d. 

 

Note:  

It is possible to import multiple files at once. To do so, hold down Ctrl or Shift key while selecting files in 
the importing dialog box. 

 

Note:  

The following formats can be imported without loss of color information: 

WRL, OBJ, PLY, Geomagic (fcs, icf, mdl, xdl). 

 

Note:  

If the Import dialog box is opened to import files, all of the supported files may not be listed under “File 
Format” because of the limitations of the OS. Favorite file formats can be shown by choosing True next to 
the file format in the File I/O tab in File > Preferences and only these formats will be shown in the Import 
dialog box. 

 
 

How to Use 

A. How to import scan data 
1. Go to Insert > Import. 

 
2. Select the files to import by click-dragging the mouse cursor over them, or by using the 

Shift or Ctrl key and selecting them one by one. 
 

3. Click Import Only to import the files without executing any operations or use the Run 
Mesh Buildup Wizard to generate a single mesh from multiple scan shots. The Mesh 
Buildup Wizard can be executed any time after importing scan data (Tools > Scan 
Tools > Mesh Buildup Wizard). 
 

Note:  

If an imported scan data part is very small or large, it can be problematic to generate features 
based on the mesh. If this type of data is imported, the application will show the ‘Confirm 
Input (Scanner) Unit’ dialog box to verify the input unit of the scan data. Normally long range 
scan data files are very large and entities in the file can span far away from the global origin. 
In this case it is recommended to import the scan data with the Double Precision option to 
preserve the accuracy of the scan data. 
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If importing a large scan data with Double Precision, the Transform the data close to the 
global origin option will appear. This option aligns the scan data to the global origin while 
importing. 

 
 

 
 

B. How to use the ASCII Converter to import an unknown scan format 
(text file) 
1. Go to Insert > Import or click the icon in the toolbar and select a text file. To import 

scan data formatted similarly to the image below, follow the steps. 

 
2. Check the Use ASCII Convert option. 

 
3. Click Import Only. 

4. The Convert ASCII dialog box will appear and columns and rows can be selected to be 
imported. 
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5. Define the separator in the Separator section. Since different files may use different 
separators to separate data, a suitable separator in the Separator section may need to 
be defined. If a space or a tab is used as the separator, the Whitespace (space, tab) box 
will need to be checked. Otherwise, check the Other Character box and input a 
suitable character. If “,” is used for a decimal point, check the Comma ( , ) For Decimal 
Point option to distinguish the separator and the decimal point. 

 
 

6. Change the Ignore columns to Red, Green and Blue, if color information is included in 
the text file. 

 
 
 

Note:  

When the title of the column is clicked, a pull-down menu appears. X, Y, Z characters define 
coordinate information, R, G, B characters define color information and I, J, K characters 
define normal information on each point. Ignore ignores the content in a selected column. 

 

Normally a file contains X, Y, Z or X, Y, Z, R, G, B information. If only one of the R, G, B color 
attributes has a value, it will not be the color information, but the intensity value. However, 
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if more than 2 of the R, G, B color attributes have values, they will be the color information. 

Since different files may use different values to represent color information, a suitable 
Multiplier value may be needed. The range of colors is 0-255. For example, if the R, G, B values 
in a file are between 0 and 255, the Multiplier value will simply be ignored. But if the R, G, B 
values on a file are between 0 and 1, 255 will be needed for the Multiplier value. 

 
 

7. Uncheck the first and second rows to ignore them. 

 
 

8. Click OK. The scan data will be imported into the application. 

 
 

Note:  

To define columns and save them, use the Edit Template button. A pre-defined template 
can be loaded again without editing columns. 

 

 
 

C. How to import CAD data 
1. Go to Insert > Import or click the icon in the toolbar. 

 
2. Select a CAD file. 

 
3. Click Import Only. After the importing process, the CAD data and the feature named 

Imported Body1 in the Feature tree can be viewed. 

 
 



Geomagic Design X | Menu  253 
 

Note:  

If an IGES, VDA, STEP or 3DM(OpenNurbs) file containing holes and erroneous faces is 
imported, the application will ask “Do you want to run healing imported body process?” click 
“Yes” and the healing process will be performed with the Heal Imported Body dialog tree. 

  

Try To Heal Discontinuous Faces – Attempts to heal faces that are internally (C1) 
discontinuous. If these faces are not healed, they cannot be extended, lofted, or swept. 

Show Discontinuous Faces – Highlights discontinuous faces in red 

 

Heal Selected Gap – Fills selected gaps in the list box 

Try Heal All Gap – Attempt to heal all gaps. 

Restore The Healed Imported Bodies – Resets all changes 
 

 
 

Options in Detail 

 
 

Fix Erroneous Data – Checks non-manifold faces, coincident vertices and degenerated faces 
and fixes them if needed. 
 
Use ASCII Convert – Used for unknown text formats. The Convert ASCII dialog box will appear 
and columns, rows and separators can be defined. 
 
Import Hidden Bodies – Imports bodies which state is hidden from other CAD software. 
 
Use Custom Setting – Specifies sub-options that will be preserved when importing scan data 
again. If this option is not checked, the settings of sub-options will be changed to a selected 
file type. 
 
Points Only – Imports point clouds without poly-faces. 
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Mesh Data Points Only 
 
Suppress Mesh – Suppresses scan data during importing which loads meshes onto the hard 
disk helping to deal with large files efficiently. The Suppress/Unsuppress mechanism manages 
data and memory by swapping the data dynamically between the physical memory and the 
hard disk. The swapping time for Load / Unload is very short, so the calculation overhead is 
negligible. After importing the meshes the Unsuppress (load on the memory) command can 
be used in the pop-up menu in the Feature tree. 

 
 
Unit – Defines a scan data file measurement unit. 
 
Include Vertex Normal – Preserves normal information. 
 
Combine Point Clouds – Combines multiple point clouds into a single point cloud. 
 
Precision – Indicates how many decimal places a position in space will carry with it throughout 
calculations. The float precision is the default setting and it is appropriate for most cases, but 
double precision can be specified for large scale data or for higher accuracy. 
 
Include Texture – Ignores texture information when None is selected. When As It Is is selected, 
texture information will be preserved in its original status (an image or color points). When As 
Color Point is selected, texture information from an image will be converted to color points. 

  

Include Texture Exclude Texture 
 

Note:  

After importing a texture, it can be shown or hidden in the Display panel. 
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Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all selected 
data will be used. When the ratio is 50%, half of the selected data will be used. 
 
Triangulation Cutoff Angle – Filters noisy vertices that have a normal angle compared to 
neighboring vertices whose angles are larger than a specified value during triangulation. 
Normally side walls cannot clearly be scanned from a scanning direction. This data can be 
defined as noise. 
This option is available when selecting a scan file format that includes scan direction 
information. 

 
 
 

See Also 

File > Preferences 
Tools > Scan Tools > Mesh Buildup Wizard 
Docking Bars > Display 
 
 
 

7.4.2. Insert > Mesh 
 
Going to Insert > Mesh from the menu and clicking the Mesh mode icon in the tool palette produce 
different results. Going to Insert > Mesh enables only the addition of mesh features in the Feature 
tree, however, entering the mesh mode with the icon enables full editing of a mesh entity. 
 
 

Insert Mesh 

 
Using Insert > Mesh enables the addition of mesh feature in the Feature tree. 
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A. How to add a mesh by converting CAD data 
1. Go to Insert > Mesh. 

 
2. Go to Tools > Mesh Tools > Convert Body. 

 
3. Select a solid or surface body. 

 
4. Set the slider of Quality to define resolution. 

 
5. Click OK to complete the command. 

 
 

B. How to add a mesh by copying a part of a mesh 
1. Go to Insert > Mesh. 

 
2. Show other meshes. 

 
3. Select poly-faces from other meshes. 

 
4. Go to Edit > Copy or use the Ctrl + C shortcut key. 

 
5. A message box will appear to confirm the copied entities. Click OK to complete the 

command. 

 
 

6. Go to Edit > Paste or use the Ctrl + V shortcut key. 
 

Note:  

Copying a whole mesh using Insert > Mesh is not necessary. In the default mode, select a 
mesh and copy and paste it. 

 

 
 

Mesh Mode 
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The Mesh mode features functions to edit, heal, enhance and optimize mesh. To enter the Mesh 
mode, select a mesh and then click the Mesh icon or double-click the mesh in the Feature or Model 
tree or in the Model View. 
 
Mesh functions for a whole mesh or partial mesh can be performed by selecting partial areas on the 
mesh. 
 

Navigation Palette 

The navigation palette in the Mesh mode finds and navigates through holes, regions and erroneous 
poly-faces. If the Find Defect command is executed and the application finds errors, the errors are 

listed in the pull-down menu. Errors on the mesh can be cycled through by clicking the  or  
buttons. 

 
 
The middle button changes depending on the function. For example with the Fill Hole command, 

the middle button changes to  , but with the Find Defect command, the middle button 

changes to . 
 
 

How to Use 

How to delete poly-faces 
1. Select a mesh and click the Mesh Mode button on the toolbar, or double click the 

mesh. 
 

2. The toolbar will show functions related to mesh tools. 
 

3. Select poly-faces on the mesh. 
 

 
 

4. Go to Edit > Delete or press the Delete key on the keyboard to remove them. 

 
 

5. Click the Apply button at bottom right corner of the Model View or click the mesh 
mode icon again to apply all changes and exit the Mesh mode. 
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Note:  

Clicking the cancel button , will exit the mesh mode and cancel all changes made 
in the mode. 

 

 
 

See Also 

Tools > Mesh Tools > Convert Body 
Edit > Copy 
Edit > Paste 
 
 
 

7.4.3. Insert > Region Group 

 
 

Region Group classifies areas of mesh based on geometry features. The Region Group mode 
automatically or manually classify and edit regions on a mesh with the following 
characteristics: 
 
- Generating and editing region history will not register in the feature tree. 
- The Region Group mode icon will be dimmed if more than one mesh exists until one of them 
is selected. 
- The Region Group mode can be exited by clicking the Region Group icon or the Apply button 
at bottom right corner. 
- Clicking the Cancel button at the bottom right corner removes all changes in the region group 
mode. 
 

Geometry Classification Option 

This option classifies geometry types such as plane, cylinder, and cones as a specified input 
condition. For example, to classify regions of very small object it is necessary to judge geometry 
types due to the small geometry of the object. 
 

 
 
Tolerance – Judges an analytic shape. When a large value is set, a shape that is not a circle can 
be registered as one. 
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Outlier – Data that is far from the standard deviation which may include unreliable information 
that can deform results from ideal geometry. 

  

Outlier in Statistic Outlier in Cylinder Geometry 
 
Allow Invasion – Allows expanding regions to invade other regions. If this option is unchecked, 
regions cannot be overflowed into other regions. 

 
 
 

7.4.4. Insert > Point Cloud 
 

Insert Point Cloud 

The Insert > Point Cloud command inserts point clouds by converting other entities into point 
clouds or copying poly-vertices from existing mesh. 
 

A. How to add a point cloud by converting a curve 
1. Prepare a curve and go to Insert > Point Cloud or click the icon in the toolbar. 

 
 

2. Go to Tools > Point Cloud Tools > Convert Entities. 
 

3. Select a curve. 
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4. Set the slider of Quality to define the resolution. 
 

5. Click OK to complete the command. 

 
 
 

B. How to add a point cloud from other meshes 
1. Go to Insert > Point Cloud or click the icon in the toolbar. 

 
2. Show other meshes. 

 
3. Select poly-vertices from other meshes. 

 
4. Go to Edit > Copy or use the Ctrl + C shortcut key. 

 
5. A message box will appear to confirm the copied entities. Click OK. 

 
 

6. Go to Edit > Paste or use the Ctrl + V shortcut key. 
 
 

Point Cloud Mode 

 

 
 
Point Cloud mode features functions to add and optimize point clouds and create meshes. To enter 
the Point Cloud mode, select a point cloud and then click the Point Cloud icon or double-click the 
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point cloud in the Model tree or in the Model View. 
 
Point cloud functions can be performed for a whole point cloud or only for a part of the point cloud 
by selecting partial poly-vertices. Point Cloud mode has the following characteristics: 
 
- All functions are available on the toolbar and in the Tools > Point Cloud Tools menu. 
- Generating and editing point cloud will not create any history or features in the feature tree. 
- Allows functions to be applied to any existing point clouds. 
- Clicking the Point Cloud icon or Apply button at bottom right corner will exit the mode. 
- Clicking the Cancel button at the bottom right corner removes all changes in the Point Cloud 
mode 
- Commands under Tools > Scan Tools can directly apply to point clouds without entering the Point 
Cloud mode. 
 
 

See Also 

Tools > Point Cloud Tools > Convert Entities 
Edit > Copy 
Edit > Paste 
 
 

7.4.5. Insert > Ref. Geometry 
 
The Ref. Geometry menu features various commands used to generate primitive geometry and edit 
other entities. The description of reference geometries are for normal situations. In some situations 
the geometries can be used for different purposes. 
 

Ref. Geometries 

• Plane 

Used for a sketch plane and a cutting plane 

• Vector 

Used for an axis of a feature 

• Coordinate 

Used for local coordinate of an object 

• Polyline 

Used for a reference to extract design indent from a mesh 

• Point 

Marks a position 

 
 

Note:  

After generating ref. geometries, they can be exported by using the File > Export command or the pop-
up menu on selected ref. geometry in Model Tree. 
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Insert > Ref. Geometry > Plane 
 

What 

A reference plane is a virtual plane that has a normal direction but an infinite size. The ref. plane is 
not a surface body. They are used to generate other features. The following images show some 
examples of reference plane usage. 

 

Fitting Plane from Scan Data Sketch Plane Mirror Plane 
 
 

Why 

The Ref. Plane command is useful for: 

• Setting a sketch plane 

• Extracting a plane by fitting scan data’s planar area 

• Cutting object to trim meshes or bodies 

• Generating mirrored features 

• Finding the middle plane of a symmetry mesh 

 
 

How to Use 

A. How to extract a sketch plane from a mesh 
1. Prepare a mesh. A mesh with region groups is ideal. 
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2. Go to Insert > Ref. Geometry > Plane or click the appropriate icon in the toolbar. 
 

3. Change the method to Extract. 
 

4. Select poly-vertices or a region. The top face of hexagonal object is selected in the 
following image. 

 
5. When a region is selected the preview plane is shown with highlighted poly-vertices 

which are used for fitting. 

 
6. Use other options or click OK to complete the command. 

 
 

Note:  

The Extract method is available not only for mesh but also for point clouds, bodies, faces, 
edges, sketch entities, curves, boundaries, etc. 

 

 
 

B. How to offset a plane 
1. Select an existing plane. 

 
2. Press the Ctrl key and drag a plane. 
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3. Release the mouse button. 

 
4. To edit the offset distance, double click the offset plane and change the distance. This is 

the same method as Offset in Ref. Plane command. 
 
 

Options in Detail 

Target Entities 

Entities – Selects target entities. The required target entities are different depending on the 
method. 
 

Methods 

The following methods are available in this command: 

• Definition 

• Extract 

• Projection 

• Pick Multiple Points 

• Pick Point & Normal 

• Pick Point & Coplanar Axis 

• Convert 

• N Division 

• Offset 

• Rotation 

• Average 

• View Direction 

• Tangent 

• Orthogonal 

• Draw Line 

• Mirror 

• Extreme Position 

 
Definition – Creates a ref. plane by using the mathematical definition of the plane. The value can 
be input numerically or interactively picked by a point in the Model View. 
 

Position & Normal – Creates a ref. plane using Position and Normal values. 
 

Position – Specifies the values of X, Y and Z, or manually selects a point where the 
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normal value will be automatically acquired. 
 

Normal – Selects a point on the model to acquire a normal value of a picked object 
or used to specify a numerical value. By clicking the X, Y, or Z buttons, a normal can 
be aligned to a selected direction. 

 
 

3 Positions – Creates a plane which intersects with three positions. 
 

Position 1 and Position 2 and Position 3 – Chooses a position on the model or 
directly inputs a X,Y and Z value. 

 
 

Coefficient - Creates a plane using specified A, B, C and D values which are coefficients of 
the plane equation (Ax + By + Cz + D = 0). 
 

A, B, C, D – Inputs the numerical value of coefficient of a plane. 

 
 
Extract – Extracts a plane from selected entities by using a fitting algorithm. 

 
 

Fitting Type – Creates a best-fitted value by the least square fitting method when the Best 
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Fit option is selected. The least squares method is the approximate solution from 
distributed data. 

 

Least Square Method 
 

The lowest value which is parallel to Best Fit will be created from the minimum bounded 
box of selected entities when Min Boundary is selected. 
The highest value which is parallel to Best Fit will be created from the maximum bounded 
box of selected entities when Max Boundary is selected. 

   

Best Fit Min Boundary Max Boundary 
 

Remove Outlier – Removes outlier data to achieve more accurate fitting results. 
The N*Sigma method requires an N value and excludes data that is larger than N times 
the standard deviation, also known as the sigma. 
The Ratio method requires a ratio value and only data that falls into the selected value 
will be used. 
The Absolute Distance method requires a distance and the fitting will be done by 
excluding any data outside of that distance. 

 

N Sigma 
 

Use Normal – Excludes points that have a normal angle larger than the normal of 
fitted ref. geometry. After removing points, the application will internally generate 
fitted ref. geometry again from the refined points. 

 
Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 

 
Use Only Effective Data – Uses only effective data when fitting. Effective data is the actual 
data points used in fitting after sampling and outlier removal. 

 
Axis Constraint – Constrain the direction of an axis. 
 

Use Specified Direction As Initial Guess – Defines an initial axis that can be used 
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for finding the direction of a fitting shape. 
 
Use Specified Direction As It Is – Manually define the direction of an axis. The 
direction of an axis can be defined by selecting an entity that has a vector property 
or manually typing the values. 

 
Projection – Creates a plane by projecting a planar entity onto a linear entity.  
To make a plane using the Projection method: 

1. Select a planar entity such as a plane, face, or region. 
2. Select a linear entity such as a line, vector, or edge. 
3. Click OK. 

 
 
Pick Multiple Points – Creates a plane by picking three or more points. 
To make a plane using the Pick Multiple Points method: 

1. Pick three or more points. 
2. Click OK. 

 
 
Pick Point & Normal Axis – Creates a plane by picking a point (position) and selecting a normal 
axis. 
To make a plane using the Pick Point & Normal method: 

1. Select a linear entity for normal of the plane. 
2. Pick a point for the position of the plane. 
3. Click OK. 

 
 
Pick Point & Coplanar Axis – Creates a plane on a coplanar axis. 
To make a plane using the Pick Point & Normal method: 

1. Select a linear entity for coplanar axis. 
2. Pick a point for the position of the plane. 
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3. Click OK. 

 
 
Convert – Creates plane on a selected planar entity. 
To make a plane using the Convert method: 

1. Select a planar entity (plane, face, region, etc). 
2. Click OK. 

 
 
N Division – Creates planes by dividing selected entities. Multiple planes will be created evenly 
and perpendicularly to the selected entity. 
To make a plane using the N Division method: 

1. Select a line, curve, edge or etc. 
2. Define sub option. 
3. Click OK. 

 
Uniform – Creates planes by evenly dividing a selected entity by specified number. 

 
 

Offset – Creates planes by a specified offset distance and total number on a selected 
entity. 

 
 
Offset – Creates a specified number of planes by offsetting them from a selected planar entity. 
To make a plane using the Offset method: 
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1. Select a planar entity such as a plane, face, or region. 
2. Set the total number and distance. 
3. Click OK. 

 
 

Note:  

A ref. plane can be offset by using the Ctrl key and mouse drag an existing ref. plane. 

 
Rotation – Creates multiple planes by rotating a planar entity. 
To make a plane using the Rotation method: 

1. Select a planar entity such as a plane, face, or region. 
2. Select a linear entity such as a line, vector, or edge which will be the rotation axis. 
3. Set the total number of planes and the rotation angle. 
4. Click OK. 

 
 
Average – Creates a plane by averaging two selected planar entities. The planar entities do not 
need to be parallel. 
To make a plane using the Average method: 

1. Select two planar entities such as a plane, face, or region. 
2. Click OK. 

 
 
View Direction – Creates a plane in the current view direction. 
To make a plane using the View Direction method: 

1. Pick a point , also known as a position, on the Model View. 
2. The plane normal will be the viewing direction. 
3. Click OK. 
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Tangent – Creates a plane that is tangent to a picked entity.  
To make a plane using the Tangent method: 

1. Pick a point also known as a position, on a curve point, poly-vertex, vertex, face or ref. point. 
2. Click OK. 

 
 
Orthogonal – Creates an orthogonal plane from a selected point (point-element entity) on a 
mesh. A point and two body faces can also be used. 
To make a plane using the Orthogonal method on a mesh: 

1. Pick a point on a mesh. 
2. Click OK. 

 
 
To make a plane using the Orthogonal method on a body: 

1. Pick a vertex on a body. 
2. Select two body faces. 
3. Click OK. 

 
 
Draw Cutting – Creates a plane by drawing a line on the screen. 
To make a plane using the Draw Cutting method on a body: 
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1. Draw a linear line on the screen. 
2. Click OK. 

 
 
Mirror – Finds and creates a symmetrical plane of a mesh automatically. An initial plane which 
roughly indicates the normal direction of the plane is necessary.  
Lock Normal Direction Of Mirror Plane As Selected Planes’ uses the normal of the initial plane 
as it is. 
To make a plane using the Mirror method: 

1. Select an initial plane. 
2. Select a mesh. 
3. Click OK. 

    
 
Extreme Position – Creates a plane at a maximum or minimum position of a selected entity in a 
specified direction.  
To make a plane using the Extreme Position method: 

1. Click the Direction button and select a linear entity such as a line, or vector. 
2. Select a target entity. 
3. Click OK. 

 
The following images show generated planes at the extreme position to the Z direction on an 
entity. 
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See Also 

Insert > Ref.Geometry > Vector 
Insert > Ref.Geometry > Coordinate 
Insert > Ref.Geometry > Polyline 
Insert > Ref.Geometry > Point 
 
 
 

Insert > Ref. Geometry > Vector 
 

What 

A reference vector is a virtual axis with a direction and infinite size. A ref. vector is not a line entity 
and is used just to generate other features. 

 

Cylinder Axis Intersecting Two Planes 
 
 

Why 

The Ref. Vector command is useful for: 

• Setting an axis of a revolving body 

• Creating a rotation axis for a circular pattern 

• Finding the axis of a cylinder 

• Finding the axis of a cone 

• Finding revolving and extruding axes 

 
 

How to Use 

How to extract a cylinder axis from a mesh 
1. Prepare a mesh. A mesh with region groups is ideal. 
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2. Go to Insert > Ref. Geometry > Vector or click the icon in the toolbar. 
 

3. Change the method to Find Cylinder Axis. 
 

4. Select cylindrical regions.  

 
 

5. Click OK to complete the command. The application will find an axis from the cylindrical 
regions. 

 
 
 

Options in Detail 

Target Entities 

Entities – Selects target entities. 
 

Methods 

The following methods are available in this command: 

• Definition 

• Extract 

• Find Slot Axis 

• Find Cylinder Axis 



Geomagic Design X | Menu  274 
 

• Find Cone Axis 

• Projection 

• Pick Multiple Points 

• Pick Point & Line 

• Convert 

• Intersect 2 Planes 

• Average 

• Tangent 

• Cross 2 Line 

• Revolving Axis 

• Extrusion Axis 

• Pattern Revolving Axis 

• Pattern Translation Axis 

 
Definition – Creates a vector using the mathematical definition of a vector. A numeric value can 
be input or a point can be picked manually in the Model View. 

 
 

Position & Direction – Creates a ref. vector with Position and Direction values. 
 

Position – Selects a point in the Model View or allows the manual input of specific 
values for X, Y and Z. 

 
Direction – Selects a linear entity to acquire a directional value or allows the manual 
input of a specific numerical value. The X, Y or Z buttons align the direction to a 
selected direction. 
 

 
 

Start & End – Creates a vector by defining the Start Position and the End Position. 
 

Start Position and End Position – Creates a vector by connecting two positions. 
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The positions can be selected in the Model View or manually input into the X, Y, Z 
boxes. 

 
 
Extract – Extracts a vector from selected entities by using a fitting algorithm. 

  
 

Remove Outlier – Removes outlier data to achieve more accurate fitting results. 
The N*Sigma method requires an N value and excludes data that is larger than N times 
the standard deviation, also known as the sigma. 
The Ratio method requires a ratio value and only data that falls into the selected value 
will be used. 
The Absolute Distance method requires a distance and the fitting will be done by 
excluding any data outside of that distance. 

 

N Sigma 
 

Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 

 
Use Only Effective Data – Uses only effective data when fitting. Effective data is the actual 
data points used in fitting after sampling and outlier removal. 

 
Project On Plane - Projects a created vector onto a selected planar entity such as a plane, 
face, region, or sketch. 

 
Find Slot Axis – Creates a vector of a slot on a selected entity using a fitting algorithm. The fitting 
option is the same as the Extract method. 
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Fitting Type – Creates a best-fitted value by the least square fitting method when the Best 
Fit option is selected. The least squares method is the approximate solution from 
distributed data.  

 

Least Square Method 
 

The lowest value which is parallel to Best Fit will be created from the minimum bounded 
box of selected entities when Min Boundary is selected. 
The highest value which is parallel to Best Fit will be created from the maximum bounded 
box of selected entities when Max Boundary is selected. 

   

Best Fit Min Boundary Max Boundary 
 
Find Cylinder Axis – Creates a cylinder axis from a selected entity by using the fitting algorithm. 
The fitting option is same as the Extract method. 

 
 

Use Normal – Excludes points that have a normal angle larger than the normal of 
fitted ref. geometry. After removing points, the application will internally generate 
fitted ref. geometry again from the refined points. 

 
Fix Radius – Specifies the value of the radius of a cylinder if it is already known. 

 
Axis Constraint – Constrain the direction of an axis. 
 

Use Specified Axis As Initial Guess – Defines an initial axis that can be used for 
finding the direction of a fitting shape. 
 
Use Specified Axis As It Is – Manually define the direction of an axis. The direction 
of an axis can be defined by selecting an entity that has a vector property or 
manually typing the values. 

 
Find Cone Axis – Creates a cone axis from selected entities by using a fitting algorithm. The 
fitting option is same as the Find Cylinder Axis method. 



Geomagic Design X | Menu  277 
 

 
 
Projection – Creates a vector by projecting a planar entity onto a linear entity.  
To make a vector using the Projection method: 

1. Select a planar entity such as a plane, face, or region. 
2. Select a linear entity such as a line, vector, or edge. 
3. Click OK. 

 
 
Pick Multiple Points - Creates a vector by picking two or more points. 
To make a vector using the Pick Multiple Points method: 

1. Pick two or more points. 
2. Click OK. 

 
 
Pick Point & Line – Creates a vector by picking a point as the position and a linear entity as the 
direction. 
To make a vector using the Pick Point & Line method: 

1. Select a linear entity for the direction of a vector. 
2. Pick a point for the position of the vector. 
3. Click OK. 

 
 
Convert – Creates a vector as an axis of a selected entity or on a selected entity. 
To make a vector using the Convert method: 

1. Select a cylindrical entity such as a face or a region, or a linear entity such as a line or an 
edge. 
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2. Click OK. 
 
Intersect 2 Planes – Creates a vector from intersecting two planes.  
To make a vector using the Intersect 2 Planes method: 

1. Select two planar entities such as planes, faces, regions. 
2. Click OK. 

 
 
Average – Creates a vector by averaging two linear entities. 
To make a vector using the Average method: 

1. Select two linear entities such as lines, edges, vectors. 
2. Click OK. 

 
 
Tangent – Creates a vector that is tangent to a selected entity. 
To make a vector by using the Tangent method: 

1. Pick a point on an entity such as a curve, edge, or poly-vertex. 
2. Click OK. 

 
 
Cross 2 Lines – Creates a vector from crossing two linear entities. 
To make a vector using the Tangent method: 

1. Select two linear entities such as lines, edges, or vectors. 
2. Click OK. 

 
 
Revolving Axis – Creates a vector that is an axis from a revolved mesh feature. The fitting option 
is same as the Extract method. 
To make a vector using the Revolving Axis method: 

1. Select a revolved area on a mesh. 
2. Click OK. 
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Extrusion Axis – Creates a vector in an extrusion direction from an extruded mesh feature. The 
fitting option is the same as the Extract method. 
To make a vector using the Extrusion Axis method: 

1. Select extruded area on a mesh. 
2. Click OK. 

 
 

Use Specified Axis As Initial Guess – Defines an initial axis used to find the axis of the 
plane. A linear entity or a user defined direction can be chosen as a vector. 

 
Pattern Revolving Axis – Creates a vector from the center axis of a revolved pattern feature.  
To make a vector using the Pattern Revolving Axis method: 

1. Select two or more pattern features on a mesh. 
2. Click OK. 

 
 

Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 

 
Pattern Translation Axis – Creates a vector in a pattern direction from pattern features. 
To make a vector using the Pattern Translation Axis method: 

1. Select two or more pattern features on a mesh. 
2. Click OK. 
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Sampling Ratio – See the Pattern Revolving Axis option. 
 
 

See Also 

Insert > Ref.Geometry > Plane 
Insert > Ref.Geometry > Coordinate 
Insert > Ref.Geometry > Polyline 
Insert > Ref.Geometry > Point 
 
 
 

Insert > Ref. Geometry > Coordinate 
 

What 

A reference coordinate is a local coordinate system that a user can use to define additional 
coordinates. 

 

 
 

Why 

The Ref. Coordinate command is useful for: 

• Transforming scan data 

• Aligning scan data 

 
 

How to Use 
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How to add a coordinate using the intersection of 3 planes 
1. Go to Insert > Ref. Geometry > Coordinate. 

 
2. Change the method to Intersect 3 Planes. 

 
3. Select three defined ref. planes. 

 

 
 

4. Click OK to complete the command. A ref. coordinate at the corner of the 3 ref. planes 
will be created. 

 
 
 

Options in Detail 

Target Entities 

Entities – Selects target entities. 
 

Methods 

The following methods are available in this command: 

• Definition 

• Extract 

• Pick Multiple Points 

• Pick Point & 2 Lines 

• Pick Point & Coordinate 

• Insert 3 Planes 

• Tangent 

 
Definition – Creates a ref. coordinate by the mathematical definition of the coordinate. 
 

Origin & Axis – Creates a coordinate using the Origin and Axis1 value. 
 

Origin – Selects a point in the Model View or allows the manually input of the X, Y 
and Z values. 
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Axis1 / Alxis2 – Pick a point on the model to acquire the direction of the picked 
object or specify numerical value. If you click X, Y or Z button, you can align normal 
to the selected direction. 

 
Order – Defines the order of Axis1 and Axis2 as X, Y or Z. If the order is XY, Axis1 
will be set to X direction and Axis2 will be set to Y direction. 

 
Origin & Rotation – Creates a coordinate with the Origin and Rotation value. 

 
Origin – Selects a point in the Model View or allows the manually input of the X, Y 
and Z values. 

 
Rotation – Specifies the degree of an angle of an axis that a coordinate will rotate 
around. 

 
Extract – Extracts a coordinate from selected entities by using a fitting algorithm.  

Remove Outlier – Removes outlier data to achieve more accurate fitting results. 
The N*Sigma method requires an N value and excludes data that is larger than N times 
the standard deviation, also known as the sigma. 
The Ratio method requires a ratio value and only data that falls into the selected value will 
be used. 
The Absolute Distance method requires a distance and the fitting will be done by 
excluding any data outside of that distance. 

 

N Sigma 
 

Use Normal – Excludes points that have a normal angle larger than the normal of 
fitted ref. geometry. After removing points, the application will internally generate 
fitted ref. geometry again from the refined points. 

 
Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 

 
Use Only Effective Data – Uses only effective data when fitting. Effective data is the actual 
data points used in fitting after sampling and outlier removal. 

 
Pick Multiple Points – Creates a coordinate by picking points more than 3 points. 
To make a coordinate using the Pick Multiple Points method: 

1. Pick 3 points. 
2. Click OK. 
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Order – Refer to the Definition method. 
 

Direction – Flips the directions of  defined axes by clicking the Flip button  
 
Pick Point & 2 Lines – Creates a coordinate from a point used for an origin and two lines used 
for directions. The direction of the coordinate on the first and second line will follow the settings 
in the Order option. For more about the Order option, see the Definition method. 

 
 

Order – Refer to the Definition method. 
 

Direction – Refer to the Pick Multiple Points method. 
 

Pick Point & Coordinate – Creates a coordinate from a point used for an origin and another 
coordinate. 

 
 
Intersect 3 Planes – Creates a coordinate from three planar entities. 

 
 

Direction – Refer to the Pick Multiple Points method. 
 
Tangent - Creates a coordinate tangent to a manually picked entity using a point on a mesh or a 
body face. 
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See Also 

Insert > Ref.Geometry > Plane 
Insert > Ref.Geometry > Vector 
Insert > Ref.Geometry > Polyline 
Insert > Ref.Geometry > Point 
 
 
 

Insert > Ref. Geometry > Polyline 
 

What 

A reference polyline is a connected series of line segments. The polyline is used to extract the design 
intent or character lines from a mesh. 

 

Silhouette Beadline 
 
 

Why 

The Ref. Polyline command is useful for: 

• Extracting silhouette lines 

• Extracting parting lines 

• Extracting fillet center lines 

• Extracting pipe center lines 

• Extracting bead center lines 

• Extracting boundaries from selections 

• Extracting revolving and extrusion profiles 
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• Extracting sharp edges on rounded shapes 

 
 

How to Use 

How to find the curve in the center of pipe using mesh 
1. Go to Insert > Ref. Geometry > Polyline or click the icon in the toolbar. 

 
2. Change the method to Pipe. 

 
3. Select the pipe area. 

 
 

4. Click OK to complete the command. The application will find the pipe line. 

 
 
 

Options in Detail 

Target Entities 

Entities – Selects target entities 
 

Methods 

The following methods are available in this command: 

• Intersection 

• Silhouette 

• Parting 

• Fillet 

• Sweep 

• Pipe 

• Bead Line 

• Boundary 
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• Projection 

• Revolving Profile 

• Extrusion Profile 

• Extract Virtual Sharp Edge 

 
Intersection – Creates polylines at an intersection between a mesh and a planar entity. 
To make a polyline using the Intersection method: 

1. Select a mesh. 
2. Select a planar entity such as a plane, face, or region. 
3. Click OK. 

 
 
Silhouette – Creates silhouette polylines using a mesh and a plane or vector 
To make a polyline using the Silhouette method: 

1. Select a mesh. 
2. Select a planar entity or linear entity for the projection direction 
3. Click OK. 

 
2D Silhouette – Creates a 2D polyline on a plane. 

  

Check 2D Silhouette Uncheck 2D Silhouette 
 

Outer Loop Only – Creates only outermost silhouette polylines 
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Check Outer Loop Only Uncheck Outer Loop 
Only 

 
Parting– Creates parting lines from mesh  
To make a polyline using the Parting method: 

1. Select a mesh. 
2. Select a planar entity or linear entity for the projection direction 
3. Click OK. 

 
 

Draft Angle – Poly-faces within the draft angle will be removed to calculate a parting line 
after a draft angle is specified 

 

 

Draft Angle: 0 Draft Angle: 10 
 
Fillet – Creates polylines in the center of a fillet feature 
To make a polyline using the Fillet method: 

1. Select fillet areas on a mesh. 
2. Click OK. 

 
 

Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 
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Thinning – Removes noisy polylines to generate a single line. A Search Depth value must 
be specified and is used to clean a polyline with the inputted search depth value. 

 

 

Uncheck Thinning Check Thinning 
 
Sweep – Creates a sweep path from a sweep feature 
To make a polyline using the Sweep method: 

1. Select sweep areas on a mesh. 
2. Click OK. 

 
 

Thinning – See the Fillet method’s sub-option under Ref. Polyline. 
 
Pipe – Creates a pipe center path from a pipe feature 
To make a polyline using the Pipe method: 

1. Select pipe areas on a mesh. 
2. Click OK. 

 

 
 

Thinning – See the Fillet method’s sub-option under Ref. Polyline. 
 

Inner / Outer – Selects the normal direction of a pipe. 
 
Bead Line – Creates bead center polylines from a bead feature. 
To make a polyline using the Bead Line method: 

1. Select bead areas on a mesh. 
2. Click OK. 
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Radius – Specifies the radius of a virtual ball that rolls over the surface of a mesh that is 
used to detect the boundaries of bead lines. The radius of the virtual ball needs to be larger 
than bead lines because if it is set as a very small value it might follow the shape of bead 
lines instead of detecting their boundaries. A value of 0 will allow the application to 
automatically set the radius. 

 
 

Tolerance – Areas within a given distance will be treated as noise and ignored. 

 
 

Thinning – See the Fillet method’s sub-option under Ref. Polyline. 
 

Convex / Concave – Chooses a bead shape. 
 
Boundary – Creates boundary polylines from a selected area. 
To make a polyline using the Boundary method: 

1. Select areas on a mesh. 
2. Click OK. 

 
 
Projection – Projects a polyline onto a planar entity. 
To make a polyline using the Projection method: 

1. Select an existing polyline. 
2. Select a planar entity such as a plane or face. 
3. Click OK. 

 
 
Revolving Profile – Creates a revolving profile from a selected area. 
To make a polyline using the Revolving Profile method: 

1. Select a mesh or areas on a mesh. 
2. Select a ref. vector as the revolution axis. 
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3. Select a planar entity such as a plane or face for the sketch plane. 
4. Click OK. 

 
 

Use Normal – Excludes points that have a normal angle larger than the normal of fitted 
ref. geometry. After removing points, the application will internally generate fitted ref. 
geometry again from the refined points. 

 
Thinning – See the Fillet method’s sub-option under Ref. Polyline. 

 
Extrusion Profile – Creates an extrusion profile from a selected area. 
To make a polyline using the Extrusion Profile method: 

1. Select a mesh or areas on a mesh. 
2. Select a ref. vector which will be the extrusion direction. 
3. Select a planar entity such as a plane or a face for the sketch plane. 
4. Click OK. 

 
 

Use Normal – See the Revolving Profile method’s sub-option under Ref. Polyline. 
 

Thinning – See the Fillet method’s sub-option under Ref. Polyline. 
 
Extract Virtual Sharp Edge – Creates sharp edges on rounded features on a mesh or a body 
To make a polyline using the Extract Virtual Sharp Edge method: 

1. Select a side area around a rounded feature. 
2. Select an opposite side area around the rounded feature. 
3. Click OK. 

 
 

Fit Surface From Region – Internally creates fitting surfaces to find intersections between 
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surfaces 
 
Expand Ratio – Sets a value for the expand ratio used to find virtual edges. This option expands 
a selected region. To find a virtual edge between far distance regions, set a large enough value 
to make an intersection. 
 

More Options 

Delete Small Cluster – Removes noisy polylines that have less than a specified number of 
connected lines. 

 
 

See Also 

Insert > Ref.Geometry > Plane 
Insert > Ref.Geometry > Vector 
Insert > Ref.Geometry > Coordinate 
Insert > Ref.Geometry > Point 
 
 
 

Insert > Ref. Geometry > Point 
 

What 

A reference point is a zero-dimensional entity. A reference point is used to mark a specific position 
on a model or in space. 

 

Ref. Point on Mesh Intersection between curve and plane 
 
 

Why 
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The Ref. Point command is useful for: 

• Finding a the center of a circle, slot, rectangle, polygon, or sphere 

• Finding an average point from multiple points 

• Finding the intersection point of two lines 

• Finding the intersection point of a line and a face 

• Finding the intersection point of three planes 

• Importing positions 

 
 

How to Use 

How to make an average point from a region 
1. Go to Insert > Ref. Geometry > Point or click the icon in the toolbar. 

 
2. Change the method to Extract. 

 
3. Select a region. 

 
 

4. Click OK to complete the command. The application will extract an average point from 
the selected region. 

 
 
 

Options in Detail 

Target Entities 

Entities – Selects target entities. 
 

Methods 

The following methods are available in this command: 

• Definition 

• Extract 

• Find Circle Center 
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• Find Slot Center 

• Find Rectangle Center 

• Find Polygon Center 

• Find Sphere Center 

• Projection 

• Pick Multiple Points 

• Convert 

• N Division 

• Between 2 Points 

• Intersect 2 Lines 

• Intersect Line(Curve, Axis) & Face 

• Intersect 3 Planes 

• Import 

 
Definition – Creates a point by using the mathematical definition of a point. The value can be 
input numerically or interactively picked by a point in the Model View. 
 
Extract – Creates a point from selected entities by using a fitting algorithm. 

 
 

Remove Outlier – Removes outlier data to achieve more accurate fitting results. 
The N*Sigma method requires an N value and excludes data that is larger than N times 
the standard deviation, also known as the sigma. 
The Ratio method requires a ratio value and only data that falls into the selected value will 
be used. 
The Absolute Distance method requires a distance and the fitting will be done by 
excluding any data outside of that distance. 

 

N Sigma 
 

Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 

 
Use Only Effective Data – Uses only effective data when fitting. Effective data is the actual 
data points used in fitting after sampling and outlier removal. 
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Find Circle Center – Creates a circle center point from selected entities. 

 
 

Fitting Type – When Best Fit is selected, the least squares fitting method is used. 
Minimum separation is a fitting method that uses a pair of concentric fitting shapes that 
contains all data points to extract both a Min. Bound and Max Bound.  
When Min. Bound is selected for a circle, the smallest value of the radial distances 
between a pair of concentric circles of minimum separation is used. 
When Max. Bound is selected the largest value from minimum separations is used. Min. 
Bound and Max. Bound share the same center point. 

  

Best Fit Min / Max Boundary  
from Minimum Separation 

 
The Hole method is available under the Find Circle Center option. This method is useful 
for finding the center of a hole in a model by locating a candidate area around a hole from 
a selection and generating a fitting circle based on the center of the hole. 

   

1. Selection 2. Candidate area for 
circle fitting 

3. Find a center of a hole 

 
Remove Outlier, Sampling Ratio, Use Only Effective Data – Identical to the Extract 
method. 

 
Project On Plane –- Projects a created vector onto a selected planar entity such as a plane, 
face, region, or sketch. 

 
Fix Radius – Specifies the value of the radius of a cylinder if it is already known. 

 
Find Slot Center – Extracts the center point of a slot from selected entities using a fitting 
algorithm. The sub-options are the same as the Find Circle Center method under Ref. Point. 
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Find Rectangle Center – Extracts the center point of a rectangle from selected entities using a 
fitting algorithm. The sub-options are the same as the Find Circle Center method under Ref. 
Point. 

 
 

Rounded Corner – Finds the center point of a rounded corner rectangle. 
 
Find Polygon Center – Extracts the center point of a polygon center from selected entities using 
a fitting algorithm. The sub-options are the same as the Find Circle Center method under Ref. 
Point. 

 
 

Rounded Corner – Used for polygon corners that are round. 
 

Num. Of Edges – Specifies the number of edges of a polygon. 
 
Find Sphere Center - Extracts the center point of a sphere from selected entities using a fitting 
algorithm. The sub-options are the same as the Find Circle Center method under Ref. Point. 

 
 
Projection – Extracts a point by projecting onto another entity. 
To make a point using the Projection method: 

1. Select points such as ref. points, curve points or vertices. 
2. Select a target entity that selected points will be projected onto. 
3. Click OK. 

 
 
Pick Multiple Points – Creates an average point by choosing one or more points. 
To make a point using the Pick Multiple Points method: 

1. Pick points on scan data or select points such as ref. points, vertices or circles. 
2. Click OK. 
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Convert – Create a center point from a selected entity. 
To make a point using the Convert method: 

1. Select a circle or an arc. 
2. Click OK. 

 
 
N Division – Creates multiple points by dividing a selected curve, vector, or mesh data. 
To make a point using the N Division method: 

1. Select a curve. 
2. Click OK. 

 
Uniform – Creates planes by evenly dividing a selected entity by a specified number. 

 
Offset – Creates planes by a specified offset distance and total number on a selected 
entity. 

 

 

Uniform Offset 
 
Between 2 Points – Creates a point between two points using a Ratio value to decide the 
position. 
To make a point using the Between 2 Points method: 

1. Select two points. 
2. Set the ratio of position between two selected points. 
3. Click OK. 

   

Ratio: 0.2 Ratio: 0.5 Ratio: 0.8 
 
Intersect 2 Lines– Creates a point from the intersection of two linear entities. 
To make a point using the Intersect 2 Lines method: 

1. Select two linear entities such as a line, edge, or vector. 
2. Click OK. 
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Intersect Line (Curve, Axis) & Face - Creates a point from the intersection of a curve or an axis 
of a geometric entity and a face. 
To make a point using the Intersect Line(Curve, Axis) & Face method: 

1. Select a curve such as a line, edge, vector, 2D or 3D curve. 
2. Select a face. 
3. Click OK. 

 
 
Intersect 3 Planes – Creates a point from the intersection of three selected planar entities. 
To make a point using the Intersect 3 Planes method: 

1. Select three planar entities such as a face, region, or plane. 
2. Click OK. 

 
 

Check Orthogonality – Allows the creation of a point only if three planes are orthogonal. 
 
Import – Creates points by importing an ASCII file. A text file containing X, Y and Z coordinates 
separated by tabs or commas can be imported through the ASCII converter. 
 
When a text file is opened the ASCII Converter will appear. Column definition, separators such as 
white space or user defined characters, and commas for decimal point in the ASCII Convert dialog 
box can be set. 
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See Also 

Insert > Ref.Geometry > Plane 
Insert > Ref.Geometry > Vector 
Insert > Ref.Geometry > Coordinate 
Insert > Ref.Geometry > Polyline 
 
 
 

7.4.6. Insert > Solid 
 
The Insert Solid menu features various commands used to generate and edit solid bodies and 
surfaces. 
 

Generating Solid Bodies from Sketches 

• Extrude 

Creates extruded bodies with a sketch, direction and length 

• Revolve 

Creates revolved bodies with a sketch, axis and revolution angle 

• Sweep 

Creates swept bodies with a sketch and path 

• Loft 

Creates lofted bodies with a set of sketches 

 

Generating Solid Bodies from Other Bodies 

• Offset 

Creates offset faces from existing body faces 
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• Thicken 

Creates a constant thickness solid body from a surface body 

• Hollow 

Creates a constant thickness solid body from a solid body 

• Cut 

Creates a solid body by cutting an existing solid body 

• Boolean 

Creates a solid body by merging, cutting or intersecting with another body 

 
 
 

Insert > Solid > Extrude 
 

What 

The Extrude command stretches an object section in a straight direction and then generates a 
closed solid body. The object section is expressed by a single profile or multiple profiles on a sketch. 
A profile is drawn by sketch entities such as a single circle or a spline or the combination of lines, arcs 
or splines. 

 

Sketch Direction and Length Extrusion Body 
 

Note:  

To generate an extruded solid feature, a profile must be closed. The Surface > Extrude command can be 
used to generate an extruded feature by using an open profile. 

 
 

Why 

The Extrude command is useful for: 

• Creating a body for a straight object 

• Creating a boss or rib on a plastic part 

• Creating a hole in an object 

• Creating a straight pipe 

• Creating the outside of a building 

• Creating a pillar for a building or bridge 
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How to Use 

A. How to generate an extrusion solid body 
1. Draw a sketch or a mesh sketch. 

 
 

2. Go to Insert > Solid > Extrude or click the icon in the toolbar. Select the sketch as the 
Base Sketch. Specify the Length for the extrusion. 

 
 

3. The Draft option generates a tapered body. Specify the value as 10 degrees. 

 
 

4. Click OK to complete the command. 

 
 

 
 

B. How to generate holes on a solid body 
1. Draw a sketch or a mesh sketch. 
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2. Go to Insert > Solid > Extrude or click the icon in the toolbar and then select the 
sketch as the Base Sketch. 

 
3. Click the Flip Direction button to reverse the extrusion. Choose the Cut option under 

Result Operator to cut holes in the main solid body. 
 

 
4. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Base Sketch – Selects a Sketch of the Mesh Sketch as a base sketch. The base sketch is a 2D 
sectional profile of an extrusion object. 
 
Profiles – Select or deselect loops used to extrude a desired profile. Multiple profiles can be 
drawn on a sketch. 

  

Extrude Loop 1 Extrude Loop 2 & 3 
 
Custom Direction – Specifies a different extrusion direction as the default direction for a linear 
entity with a normal. The default extrusion direction will be the normal of the sketch plane. 
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Default Extrusion Custom Direction Extrusion 
 

Methods 

The following methods are available in this command: 

Blind 
Defines the extrusion height. 

Through All 
Defines the extrusion height to the end of another body. 

Up To Vertex 
Defines the extrusion height to a vertex. 

Up To Region 
Defines the end condition to a region. 

Up To Surface 
Defines the end condition to a surface. 

Up To Body 
Defines the end condition to a body. 

Mid Plane 
Defines the symmetry extrusion feature from a sketch. 

 
Blind – Extends a profile to a specified distance. 

 
 
Through All – Extends a profile through all existing solid or surface bodies in the extrusion 
direction. 

 
 
Up To Vertex – Extends a profile to a selected vertex. 

  
 
Up To Region – Extends a profile to a selected region on a mesh. A fitting surface is created from 
the region during the process and cuts the extruded body at the intersection. The sub-option 
Region Fitting Option can be used in this command: see Insert > Surface > Mesh Fit. 
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Up To Surface – Extends a profile to a selected surface body that cuts the extruded body at the 
intersection. 

  

 
Up To Body – Extends a profile to a selected surface or solid body used when extruding an 
assembly part to another body. 

  

 
Mid Plane – Extends a profile in both directions leaving a selected sketch in the middle of the 
extrusion. 

   

More Options 

Draft – Applies a draft angle to a model that can be flipped by using the Flip Direction button 
. Draft angles are used for a mold to ease in the removal of a molded part. 

 

  
Draft: 0 Draft: 10 

 
Opposite Direction – Extrudes a body shape from a base sketch in the opposite direction of the 
default direction. 
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Result Operator 

The Result Operator option is available when one or more bodies exist. The Boolean command 
can be used to cut or merge with other bodies later. 

 

Without Cut and Merge 
 
Cut – Cuts bodies that intersect with a created extruded body. 

 

With Cut Option 
 
Merge – Merges bodies that intersect with a created extruded body. 

 

With Merge Option 
 

 
 

See Also 

Insert > Modeling Wizard > Extrusion Wizard 
Insert > Surface > Extrude 
 
 
 

Insert > Solid > Revolve 
 

What 

The Revolve command turns an object section around a revolution axis and generates a closed solid 
body. The object section can be expressed by a single or multiple profiles on a sketch and is drawn 
by circle, spline, lines and arc sketch entities. 
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Sketch Axis and Angle Revolution Body 
 

Note:  

To generate a revolved solid feature, a profile must be closed. To generate a revolved feature by using an 
open profile, use the Surface > Revolve command. 

 
 

Why 

The Revolve command is useful for: 

• Creating a fully revolved object 

• Creating a half or angled revolved object 

 
 

How to Use  

How to generate a revolved body using a revolution angle 
1. Draw a sketch or a mesh sketch that includes a profile and a revolution axis. 

 
 

Note:  

A revolution axis can be a construction line in a sketch or other linear entities out of a sketch 
such as a vector or an edge on the sketch. 

 
 

2. Go to Insert > Solid > Revolve or click the icon in the toolbar. 
 

3. Select a sketch as a Base Sketch. If a sketch has a construction line, or axis, the application 
will automatically recognize it as the Axis. 
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4. Select the desired Method. Enter 180 degrees as the Revolving Angle.  

 
 

5. Click OK to complete the command.  

 
 
 

Options in Detail 

Select Entities 

Base Sketch – Selects a sketch to revolve. 
 
Profiles – Selects desired loops to revolve from multiple loops. 

  

Revolve Loop 1 Revolve Loop 1, 2 & 3 
 
Axis – Selects a linear entity to revolve a sketch around an axis. 
 

Methods 

The following methods are available for this command: 

• One Direction 

Revolution direction in a single direction 

• Mid Plane 

Symmetrical revolution directions to both side of a sketch 

• Two Direction 

Two different revolution directions 

 
One Direction – Creates a revolved feature in one direction from a sketch. 
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Mid Plane – Creates a symmetry revolved feature in both the clockwise and counterclockwise 
directions from a base sketch. 

 
 
Two-Direction – Creates a revolved feature in the clockwise and counterclockwise directions 
from a sketch plane with different angle values. The total of the two angles cannot exceed 360 
degrees. 

 
 

More Options 

Angle – Specifies the revolution angle from a base sketch. 
 
Opposite Angle – Specifies the revolution angle of the side opposite to the main angle and is 
available only using the Both Directions method. 
 

Result Operator 

The Result Operator option is available when one or more bodies exist. The Boolean command 
can be used to cut or merge with other bodies later. 

 

Without Cut and Merge 
 
Cut – Cuts bodies that intersect with a created extruded body. 

 

With Cut Option 
 
Merge – Merges bodies that intersect with a created extruded body. 



Geomagic Design X | Menu  308 
 

 

With Merge Option 
 

 
 

See Also 

Insert > Modeling Wizard > Revolution Wizard 
Insert > Surface > Revolve 
 
 
 

Insert > Solid > Sweep 
 

What 

The Sweep command traces the path of an object section and then generates a closed solid body. 
The object section can be expressed by a single or multiple profiles on a sketch and is drawn by 
circle, spline, lines and arc sketch entities. 

 

Sketch Profile and Path Sweep Body 
 

Note:  

To generate a sweep solid feature, a profile must be closed. To generate a revolved feature by using an 
open profile, use the Surface > Sweep command. 

 
 

Why 

The Sweep command is useful for: 

• Creating a bent object with a constant section 

• Creating a twisted object with a constant section 

 
 

How to Use 

How to generate a sweep feature using a profile and a path  
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1. Draw a sketch or a mesh sketch. 

 
 

2. Go to Insert > Solid > Sweep or click the icon in the toolbar. 
 

3. Select a Profile and Path. 

 
 

4. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Profiles – Selects a profile such as a sketch, 3D sketch, or edge that will be used to create a sweep 
body. The profile should be closed profile. To make a composite profile, select edges or curves 
with the Shift button. A profile should not self-intersect.  
 
Path – Selects a path for a profile to follow. An opened or closed loop can be used. The starting 
point of a path must lie on the plane of the profile and a path should not self-intersect. 
 

Methods 

The following methods are available for this command: 

• Follow Path 

• Keep Normal Constant 

• Follow Path And First Guide Curve 

• Follow First And Second Guide Curves 

• Twist Along Path 

• Twist Along Path With Normal Constant 

 
Follow Path – Keeps a profile at the same angle as a path. 
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Keep Normal Constant – Keeps a profile parallel to the beginning of a section. 

 
 
Follow Path and First Guide Curve – Selects a guide curve to control the intermediate shape of 
a profile. Click the  button and select a guide curve. 

 
 

 
Follow First and Second Guide Curve – Selects two guide curves to control the intermediate 
shape of a profile. Click the  button and select guide curves. 

  
 
Twist Along Path – Twists a section along a path by a specified number of degrees. 

 
 
Twist Along Path With Normal Constant – Twists a section along a path keeping the section 
parallel to the beginning section as it twists along a path. 
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Path Options 

Path Alignment Type – Stabilizes a profile when small and uneven curvature fluctuations along 
a path causes a profile to misalign. This option is available when the Follow Path option is 
selected 

 
None – Aligns a profile normal to a path with no corrections applied. 

  
 
Direction Vector – Aligns a profile in the direction of a selected linear entity vector. 

   

Guide Curves 

Guide Curves – Guides a profile as it sweeps along a path. 
Click the  button and select a guide curve. 
 

Options 

Improve Curvature Flow Along Sweep Path – Smoothly connects the curvature flow of faces 
along a sweep path 
 
Merge Tangent Faces – Merges tangentially connected faces to reduce the total number of faces. 

  

Without Merge Tangent 
Faces 

With Merge Tangent Faces 
 

Result Operator 

The Result Operator option is available when one or more bodies exist. The Boolean command 
can be used to cut or merge with other bodies later. 
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Without Cut and Merge 
 
Cut – Cuts bodies that intersect with a created extruded body. 

 

With Cut Option 
 
Merge – Merges bodies that intersect with a created extruded body. 

 

With Merge Option 
 

 
 

See Also 

Insert > Modeling Wizard > Sweep Wizard 
Insert > Surface > Sweep 
 
 
 

Insert > Solid > Loft 
 

What 

The Loft command connects multiple object sections and generates a closed solid body from them. 
The object sections are expressed by a single profile or multiple profiles on a 2D or 3D sketch and 
can be drawn by circles, splines, lines and arc sketch entities. 

 

Sketch Section Profiles Loft Body 
 

Note:  
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To generate a lofted solid feature, a profile must be closed. To generate a lofted surface feature using an 
open profile, see Surface > Loft. 

 
 

Why 

The Loft command is useful for: 

• Creating an object connected by multiple sections 

• Creating different starting and ending profile objects 

 
 

How to Use 

How to generate a loft feature from profiles 
1. Go to Insert > Solid > Loft or click the icon in the toolbar. 

 
 

2. Select Profiles to loft. 

 
 

Note:  

The alignment between loft profiles can be modified by manipulating the handles (spheres) 
that appear on the selected profiles as part of the connector. The connector is the poly line 
connecting corresponding points in both directions. 

 
 

Note:  

The lofting order of profiles in the dialog tree can be changed by using the Up  and Down 
 buttons after selecting a profile in the list. 
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3. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Profiles – Selects a profile such as a sketch, 3D sketch, or edge that will be used to create a sweep 
body. The profile should be closed profile. To make a composite profile, select edges or curves with 
the Shift button. A profile should not self-intersect. 
 

Constraints 

Start Constraint – Selects the starting constraint type. 
 

None – Applies no tangency constraints or zero curvatures. 

 
 
Direction Vector – Applies a tangency constraint based on a selected entity. Click the 
Direction Vector button and select a linear entity such as a vector, line, edge, etc, or a planar 
entity such as a plane, region, or face. 
 

Tangent Length – Controls the amount of tangency influence on a loft by setting the 
value or manipulating the blue arrow in the Model View. The tangency direction can 
be reversed by using the Flip Tangent button . 

  

Tangent Length: 1 Tangent Length: 2 
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Use Same Tangent Length To All Vertices - Applies the same tangency to all vertices 
on a profile. Tangent length can also be applied individually on each vertex. 

  
Use Same Tangent Length Individual Tangent Length 

 
Normal To Profile - Applies a tangency constraint normal to a starting profile. 

 
Tangent Length – Refer to the Direction Vector option. 

 
Use Same Tangent Length To All Vertices – Refer to the Direction Vector option. 

 
Tangency To Face – Creates a tangency constraint that follows a selected face and is 
available if a face is selected as a profile. Clicking the Next Face button will find the next 
candidate face. 

 
 

Tangent Length – Refer to the Direction Vector option. 
 

Use Same Tangent Length To All Vertices – Refer to the Direction Vector option. 
 
Curvature To Face – Creates a curvature constraint that follows a selected face and is 
available if a face is selected as a profile. Clicking the Next Face button will find the next 
candidate face. 

 
 

Tangent Length – Refer to the Direction Vector option. 
 

Use Same Tangent Length To All Vertices – Refer to the Direction Vector option. 
 

End Constraint – Selects the ending constraint type. The sub-options are the same as the Start 
Constraint options. 
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Guide Curves 

Guide Curves – Selects a guide curve to control the intermediate shape of a sweep body. 

  
Without Guide Curve With Guide Curve 

 

Options 

Merge Tangent Faces – Merges tangentially connected faces to reduce the total number of faces. 

  
Without Merge Tangent Faces With Merge Tangent Faces 

 
Close Loft – Creates a closed body along a loft direction. 

  
Without Close Loft With Close Loft 

 

Result Operator 

The Result Operator option is available when one or more bodies exist. The Boolean command 
can be used to cut or merge with other bodies later. 

 

Without Cut and Merge 
 
Cut – Cuts bodies that intersect with a created extruded body. 
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With Cut Option 
 
Merge – Merges bodies that intersect with a created extruded body. 

 

With Merge Option 
 

 
 

See Also 

Insert > Modeling Wizard > Loft Wizard 
Insert > Surface > Loft 
 
 
 

Insert > Solid > Offset  
 

What 

The Offset command enlarges or shrinks a solid body with a constant distance. 

 
 
 

Why 

The Offset command is useful for: 

• Creating a model in a different size 

 
 

How to Use  

How to offset a solid body  
1. Go to Insert > Solid > Offset or click the icon in the toolbar. 
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2. Select a solid body and specify the Offset distance. 

 
 

Note:  

To reverse the offset direction, use the Flip Direction button  . 

 
 

3. Click OK to complete the command.  

 
 
 

Options in Detail 

Bodies – Selects target solid bodies to offset. 
 
Offset Distance – Specifies the distance to offset from a solid body. To reverse the offset 
direction, use the Flip Direction button. 

  
 
 

See Also 

Insert > Surface > Offset 
 
 
 

Insert > Solid > Thicken 
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What 

The Thicken command offsets a surface body and generates a solid body with a constant thickness. 

 
 
 

Why 

The Thicken command is useful for: 

• Creating an object with constant thickness 

• Creating a sheet metal part 

 
 

How to Use  

How to generate a constant wall thickened feature from a surface 
body 
1. Prepare a surface body. 

 
2. Go to Insert > Solid > Thicken or click on the icon in the toolbar. 

 
3. Select a surface body to thicken. Enter 3 mm as the Thickness and set the offset 

direction. 

 
 

4. Click OK to complete the command. 
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Options in Detail 

Select Entities 

Body– Selects a surface body. 
 

Note:  

When a surface body is comprised of multiple adjacent faces, the surfaces must be sewn together 
before applying the Thicken command. 

 
Thickness – Specifies a thickness value. 
 

Direction 

Direction 1 – The default positive direction to thicken. 

 
Direction 2 – The opposite, negative direction from Direction1. 

 
 
Both – Thickens in both directions. 

 
 
 

See Also 

Insert > Solid > Hollow 
Insert > Surface > Offset 
 
 
 

Insert > Solid > Hollow 
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What 

The Hollow command removes selected faces from a solid body and generates a constant thin-
walled model with the remaining faces. 

 
 
 

Why 

The Hollow command is useful for: 

• Creating a constant thickness object 

• Creating an injection molded part 

 
 

How to Use 

How to generate a constant wall thickened feature from a solid body 
1. Prepare a solid body. 

 
 

2. Go to Insert > Solid > Hollow or click on the icon in the toolbar. 
 

3. Select a body to Hollow and a bottom face for Remove Faces. Specify a Depth. 

 
 

4. Click OK to complete the command. 
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Options in Detail 

Select Entities 

Body – Selects a body to hollow. 
 
Depth – Specifies a global wall-thickness of a hollow feature. 

 
 
Hollow Outward – Applies hollowing to the outward direction from a solid body. 
 

Remove Faces 

Remove Faces – Selects faces to remove. 

 

 
 

Multiple Thickness 

Multi-Thickness Faces – Specifies multiple thicknesses for each face by adding a face using 
the Add Face button  and setting its depth. To remove the last added face setting, click the 
Remove Face button . 

 
 

See Also 

Insert > Solid > Thicken 
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Insert > Solid > Cut 
 

What 

The Cut command cuts a solid body by removing material with a surface or plane. The remaining 
material can be chosen manually. 

 
 
 

Why 

The Cut command is useful for: 

• Creating a feature cut using a surface or plane 

• Dividing an object 

 
 

How to Use  

How to cut a solid body with a surface body 
1. Prepare a solid body (gray color) and a surface body (yellow color). 

 
 

2. Go to Insert > Solid > Cut or click the icon in the toolbar. 
 

3. Click the Tool Entities button and select a surface body. Click the Target Bodies button 
and select a solid body. 
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4. Click the Next Stage button and select a remaining body.  

 
 

5. Click OK to complete the command and hide the surface body. 

 
 
 

Options in Detail 

Select Entities 

Tool Entities – Selects entities as tool entities to cut a solid body. A ref. plane, region, sketch, 
sketch chain, curve, 3D sketch, edge and surface body can be selected as tool entities. 
 
Target Bodies – Selects target bodies. Only solid bodies can be selected as target bodies. 
 

Result 

Remaining Bodies – Select bodies to remain after cutting. 

 

Solid Body (Target) and Regions (Tool) 
 

 

 

Remaining Body: Bottom Remaining Body: Top 
 

 
 

See Also 

Insert > Solid > Boolean 
Insert > Surface > Trim 
Insert > Surface > Trim & Merge 
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Insert > Solid > Boolean 
 

What 

The Boolean command combines two or more solid bodies to generate a single body or multiple 
bodies by using one of three methods: Merge, Cut and Intersect. 

 

Merge (A+B) Cut (A-B) Intersect (between A, B) 
 

Note:  

The cut and merge methods can be used while generating a solid body. When a solid body already exists 
and a new solid body is generated using the Extrude, Revolve, Sweep or Loft commands, the Result 
Operator option will appear at the bottom of the command dialog tree. 

 
 

Why 

The Boolean command is useful for: 

• Combining solid bodies 

• Splitting solid bodies 

• Obtaining a shared area between overlapped solid bodies 

 
 

How to Use  

How to create a negative solid body 
1. Prepare two overlapped solid bodies. 
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2. Go to Insert > Solid > Boolean or click the icon in the toolbar. 
 

3. Choose Cut as the Operation Method. Select bodies as Tool Bodies and Target 
Bodies.  

 
 

4. Click OK to complete the command. 

 
 
 

Options in Detail 

Methods 

Merge – Combines all selected bodies, creating a single body. 

  
Before Merge After Merge 

 
Cut – The tool bodies remove overlapping material from the target bodies. 

  
Before Cut After Cut 

 
Intersect – Removes all material between the tool and target bodies except the area of shared 
material. 
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Before Intersect After Intersect 

 

 
 
 

7.4.7. Insert > Surface 
 
The Insert Surface menu features various commands used to generate and edit surfaces. The 
Surface menu features functions such as Surface Primitives, Mesh Fit, Boundary Fit, Auto 
Surfacing, Extrude, and, Revolve. 
 
 

Generating Surface Bodies by Fitting a Mesh 

• Mesh Fit 

Generates fitting surfaces based on regions of a mesh 

• Boundary Fit 

Generates a fitting surface inside of a curve network based on a mesh 

• Auto Surfacing 

Generates a curve network and a fitting surface based on a mesh 

 
 

Generating Surface Bodies from Sketches 

• Extrude 

Extrudes bodies using a sketch, direction and length 

• Revolve 

Revolves bodies using a sketch, axis and revolution angle 

• Sweep 

Sweeps bodies using a sketch and path 

• Loft 

Lofts bodies using a set of sketches 

 
 

Generating Surface Bodies from Other Entities 

• Offset 

Offsets faces from existing body faces 
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• Fill Face 

Creates surfaces inside of boundary curves or edges 

• Trim & Merge 

Creates a solid body by completely cutting a material with other surfaces 

 
 

Editing Surface Bodies 

• Extend 

Creates a surface body by extending existing bodies 

• Trim 

Creates a surface body by cutting surfaces 

• Untrim 

Restores a surface previously trimmed by other surfaces or curves 

• Sew 

Merges two or more adjacent surfaces 

• Reverse Normal 

Flips surfaces 
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Insert > Surface > Mesh Fit 
 

What 

The Mesh Fit command generates surfaces by using a fitting algorithm based on a mesh. Surface 
Fitting Technology is a unique technique in the Reverse Design process that provides an effective 
way to easily and quickly create a 3D freeform surface body from a freeform mesh shape. 

 

Mesh Fitting Region Surface 
 
 

Why 

The Mesh Fit command is useful for: 

• Creating a smooth surface from a coarse mesh surface 

• Creating a freeform surface (not analytic shape) on a part 

• Creating an aesthetic model 

 
 

How to Use 

How to generate freeform surface on a mesh 
1. Prepare a mesh with regions. 

 
 

2. Go to Insert > Surface > Mesh Fit or click the icon in the toolbar. 
 

3. Select a region to generate a fitting surface. 
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4. Change the Resolution option to By No. Of Control Points to define U and V 

directional control points on the surface. Set the U control points to 5 and V control 

points to 10.  
 

Note:  

The preview has controllers at each edge and corner. They can be resized and rotated by 
dragging them to completely cover the target region. 

 
 

5. Click the Next Stage button. 
 

6. In the second stage, the flow of iso-lines can be changed. Set the Control Net Density 
option and deform controllers on the preview to enhance the iso-line flow. 

 
 

7. Click the Next Stage button. 
 

8. In the third stage, the density of iso-lines can be changed. Create additional iso-lines on 
high curvature areas by clicking an existing iso-line while holding down the Ctrl key to 
create a copy of that line and dragging it to a desired location. 

 
 

Note:  

When the Deviation option is used in the Accuracy Analyzer™ panel, deviations can be 
checked in real-time whenever iso-lines are modified. 
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9. Click OK to complete the command. The fitting surface will be created. 

 
 
 

Options in Detail 

Stage 1/3: Default Setting 

This stage defines the default settings for generating a fitting surface such as target areas on a mesh, 
resolution, fitting options and surface extension options. 
 

Regions / Poly-Faces – Selects target regions or poly-faces on a mesh to generate a fitting 
surface. 
 
Create Single Surface – Selects multiple regions to create a single surface. 

 

 

 

 

 
Select Two Regions Disable Option Enable Option 

 
Resolution – Controls resolution to determine the overall accuracy and smoothness of a fitting 
surface. 
 

By Allowable Deviation – Sets the resolution of a fitting surface by the deviation between 
the mesh and the fitting surface. Use this option when deviation is the most important 
criteria of a fitting surface. 

 

Note:  

When a region classified as a primitive feature such as a plane, cylinder, cone or sphere is selected 
as a target region and the resolution option is defined as By Allowable Deviation, a primitive 
surface will be generated as a fitting result. For example, when a conical region is selected as a 
target region and the resolution option is defined as By Allowable Deviation, the fitting result 
will be a conical surface body. 

  

Conical Target Region Created Conical Surface Body 
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Allowable Deviation – Specifies the allowable deviation distance between a mesh 
and a fitting surface. 

 
 

Outlier % For Allowable Deviation – Sets the percentage value used to remove 
outliers from a mesh. The value can be set under the Tolerance tab in File > 
Preference. 

 
Maximum No. Of Control Point – Creates control points by specifying a maximum 
number. The number relates to the iso-lines in the third stage. 

 

 

Max. Number: 6 Max. Number: 10 
 

By No. Of Control Points – Specifies the number of control points for the U and V 
directions which control the resolution of a fitting surface. When a large number of control 
points are specified, deviation can be minimized but smoothness may also be lost. 

 
No. Of U Control Points –Specifies the number of control points in the U direction 
on a surface. 

 

U Number: 5 
 

No. Of V Control Points – Specifies the number of control points in the V direction 
on a surface. 
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V Number: 7 
 
Smoothness – Determines the smoothness level of a fitting surface. 

  

Smoothness: Less Smoothness: More 
 
Resample Mesh –Creates regular iso-lines of a fitting surface. This option may generate twisted 
or poorly fitted surfaces on complicate shapes or multiple regions. 

 
 
Manipulate U-V Axes – Enables the red or green controllers used to resize a fitting area in the U 
or V directions. The blue controller is used to resize both the U and V directions at the same time. 
The handle is used to rotate a fitting area. 

 
 
Extend – Extends a fitting surface. 
 

Linear – Linearly extends a surface from the original fitting surface. 

 
 

Curvature – Extends a surface by maintaining curvature from the original fitting surface. 
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Same Surface – Extends a surface by mirroring the original fitting surface. 

 
 

U Extend Ratio – Specifies the extension ratio in the U direction. 
 
V Extend Ratio – Specifies the extension ratio in the V direction. 

 
 

Stage 2/3: Iso-Line Flow Control 

This stage controls the flow of Iso-lines which determines the quality of a fitted surface. To make Iso-
lines that follow the flow of a surface on a mesh is the purpose in this stage, however, excessive 
editing may generate twisted fitted surfaces. 

Reset Manipulator – Clears all changes made to manipulators. 

 
 
Control Net Density – Determines the density of control points for manipulators. A lower 
density, will allow for control of the overall iso-line flow and a higher density will better control 
iso-line flow in detail. 

 
 

 
 

Control Density: Less Control Density: More 
 

Note:  

The control net density does not have relationship with the iso-line number. The number of iso-lines 
is determined by the Resolution option in the first stage. 

 
Control Degree Of Deformation – Controls points individually. The editing zone can be 
resized by holding down the Alt key and dragging with the left-mouse button. 
 
Fix Boundary Points – Prevents control points from moving over a boundary. 
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With Fix Boundary Points Without Fix Boundary Points 
 

 
 

Stage 3/3 Iso-Line Density Control 

In the third stage iso-lines can be moved, added and deleted to improve surface quality and fitting 
accuracy. Additional iso-lines can be added on high curvature areas to satisfy desired fitting 
deviations. On lower curvature areas, iso-lines can be removed or moved if a few curves are enough 
to express the flat area. 
 
The following actions can be applied to iso-lines: 
Move – Select and drag. 
Add – Hold down the Ctrl key and drag. 
Delete – Select and press the Delete key. 
 

Note:  

While manipulating control curves, the Accuracy Analyzer™ can be used. The image below shows real-
time deviation maps as control curves are adjusted. 

  

 
 

See Also 

Insert > Surface > Boundary Fit 
Insert > Surface > Auto Surfacing 
 
 
 

Insert > Surface > Boundary Fit  
 

What 

The Boundary Fit command generates surfaces inside of boundaries using a fitting algorithm based 
on a mesh. The boundaries are defined by a 3D spline curve network in the 3D Mesh Sketch mode. 
Surface Fitting Technology is a unique technique in the Reverse Design process that provides an 
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effective way to easily and quickly create a 3D freeform surface body from a freeform mesh shape. 

 

Mesh Boundaries (3D Mesh Sketch) Surface 
 
 

Why 

The Mesh Fit command is useful for: 

• Creating CAD-like fitting surfaces 

• Creating higher quality fitting surfaces than auto surfacing 

• Quickly making CAD data from a mesh 

 
 

How to Use 

How to generate fitting surface using a curve network 
1. Prepare a mesh and curve network. 

 
2. Go to Insert > Surface > Boundary Fit or click the icon in the toolbar. 

 
3. Select all curves or select the 3D Sketch (Mesh) under the Feature or Model Trees as 

Mesh Curves. 

 
 

Note:  

Clicking the Curve Loops button and picking loops on the curve network will remove them 
from a fitting surface. Selecting a curve again will re-add it. 
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4. Click the Next Stage button. Red coloring represents the U direction and the green 
color represents the V direction. 

 
 

5. Set the surface resolution method to By Allowable Deviation or By No. Of Control 
Points. 
If By No. Of Control Points is selected then set the values for the U and V points. 

 
 

6. To change control point numbers locally, click the Set Manually button, and select a 
curve to change and set the value in the box that appears near the curve. 

 
 

7. Click OK to complete the command. 

 
 

Note:  

The quality of a boundary fit surface is directly affected by the mesh quality and curve network. 

To improve mesh quality: 

Remove errors in the mesh such as folded, dangling, small, non-manifold and crossing poly-faces. See 
Tools > Mesh Tools > Healing Wizard (hyper link) 

Remove unnecessary features from the mesh. See Tools > Mesh Tools > Defeature 

Remove unnecessary holes. See Tools > Mesh Tools > Fill Holes 

Improve the balance of poly-faces. See Tools > Mesh Tools > Optimize Mesh 

 

To optimize a curve network: 

Create a curve network that equalizes the formation of the structure. 

A rectangular feature with four similar curve boundaries will result in a better fitting surface. 
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If the shape of a feature has a sudden narrow area or is twisted then a twisted and self-intersected face 
could be created when the surface is generated. 

 

Avoid creating T-Junctions when creating curve networks. 

 

 

No T-Junctions Undesired T-Junction 

Anything except a 4 sided curve boundary will create a trimmed fitting surface. 

Adjust the same number of control point in each matching boundary for surface patches to improve 
surface matching continuity. 

Set a curve boundary using appropriate control point. 

 
 

Options in Detail 

Stage 1/2: Select Entities and Loop Options 

Mesh Curves – Selects a curve network. 
 
Curve Loops – Selects loops in a curve network. 

 
 
Use Mesh Normal To Evaluate Loop Winding – Evaluates a mesh normal to decide a loop to 
be filled when boundaries create two loops. 
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Enable Option Disable Option 
 
Allow Hole (Boundary) – Fills a loop that includes holes with a trimmed surface. 

 
 

Enable Option Disable Option 
 
Allowable Convex Ratio – Sets the ratio for an allowable convex or concave ratio for a loop 
used to wrap a feature between a loop and inside a mesh shape. 

 
 

 
 

Ratio: 10: possible to wrap the feature Ratio: 2: impossible to wrap the feature 
 
 

Stage 2/2: Control Surface Quality 

Resolution – Controls resolution to determine the overall accuracy and smoothness of a fitting 
surface. 
 

By Allowable Deviation – Sets the resolution of a fitting surface by the deviation 
between the mesh and the fitting surface. Use this option when deviation is the most 
important criteria of a fitting surface. 

 
Allowable Deviation – Specifies the allowable deviation distance between a 
mesh and a fitting surface. 

 
 

Outlier % For Allowable Deviation – Sets the percentage value used to remove 
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outliers from a mesh. The value can be set under the Tolerance tab in File > 
Preference. 

 
Maximum No. Of Control Point – Creates control points by specifying a 
maximum number. The number relates to the iso-lines in the third stage. 

 

 

Max. Number: 6 Max. Number: 10 
 

By No. Of Control Points – Specifies the number of control points for the U and V 
directions which control the resolution of a fitting surface. When a large number of 
control points are specified, deviation can be minimized but smoothness may also be 
lost. 

 
No. Of U Control Points –Specifies the number of control points in the U direction 
on a surface. 

 

U Number: 5 
 

No. Of V Control Points – Specifies the number of control points in the V direction 
on a surface. 

 

 



Geomagic Design X | Menu  341 
 

V Number: 7 
 

Set Manually – Changes control point values locally on a curve network. Click the 
Set Manually button, select a curve to change, and set a value in the box that will 
appear near it. 

 
 
Smoothness – Determines the smoothness level of a fitting surface. Moving the slider towards 
More will create a smoother surface but can diminish accuracy. 

  

Smoothness: Less Smoothness: More 
 
Set Sharp Edge – Removes the tangent constraint between adjacent surfaces of selected 
curves to create a sharp edge. 

  

Disable Sharp Edge Enable Sharp Edge 
 
Regularize Overall Control Point Count – Attempts to propagate the control point number 
to a neighboring surface and is only available if the By Allowable Deviation method is 
selected. 

  

Disable Option Enable Option 
 
Resample Mesh – Creates iso-lines of equal values and works best for simple surfaces. 
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See Also 

Insert > Surface > Mesh Fit 
Insert > Surface > Auto Surfacing 
 
 
 

Insert > Surface > Auto Surfacing 
 

What 

The Auto Surfacing command generates fitting surfaces that mathematically fit CAD surfaces to 
mesh. During the auto surfacing process the application will automatically create a curve network 
that envelops the entire mesh and fills fitting surfaces for each patch of the curve network. 

 

Mesh Auto Curve Network Surface 
 
This command is available if a mesh is already imported or has been generated from a point cloud. 
As the fitting surface is affected by the quality of a mesh, it should be pre-processed without 
erroneous poly-faces. 
 

Note:  

When a mesh is modified after generating auto surfaces, the surfaces will be updated in the Feature Tree 
but may take time to rebuild. 

 
 

Why 

The Auto Surfacing command can be used to: 
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• Generating surfaces from a mesh 

• Assisting in surfacing a complicated part 

• Defines surface models that cannot be defined in CAD such as organic or natural objects 

 
 

How to generate quality auto surfaces 

The quality of the Auto Surfacing command directly depends on the mesh and curve network. The 
following guidelines can be utilized to successfully generate auto surfaces: 

• Remove sharp patches 

• Remove T-junctions* 

• Maintain similar mesh densities 

• Remove noise around boundaries by using the Tools > Mesh Tools > Edit Boundaries command 

• Fill holes 

• Split patches to make the size of patches standard 

 
*T-junctions are junctions where one spline joins another but does not cross it and is marked by 
thick lines at intersecting node such as the image below. Surface matching around T-junction may 
not be satisfactory for auto surfacing, so it is better to remove them or add a spline to make a 
completed junction. 

 
 
 

How to use Auto Surfacing command 

A. How to generate CAD like auto surfaces 
1. Go to Insert > Surface > Auto Surfacing or click the icon in the toolbar. 

 
 

2. Choose the Feature Following Network option. 
 

3. Adjust the slider for the Level of Patch Complexity option to the middle. 
 

4. Click the Next button. The curve network will be modified in the second stage. 
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5. A node position can be relocated by using the Deform option and click-dragging node 
points. 

 
 

Note:  

To resize the editing zone represented by circle comprised of yellow dots, press the Alt key and 
move the mouse left or right while holding down the left-click button. 

 

6. To remove a spline from a T-junction, choose the Remove option and removable splines 
will be highlighted in green. 

 
 

7. Click OK to complete the command. 

 
 
 

B. How to generate auto surfaces on an organic model 
1. Go to Insert > Surface > Auto Surfacing or click the icon in the toolbar. 

 
 

2. Choose the Evenly Distributed Network option. 
 

3. Specify the total number of surface for the No. Of Surfaces option. In this example 300 is 
used. 
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4. Click the Next button. The curve network will be modified in the second stage. 

 
 

5. Click OK to complete the command. 

 
 
 

Options in Detail 

Stage 1 

Mesh – Select a mesh. 

Methods 

Evenly Distributed Network – Generates a curve network with evenly sized patches. This 
method can apply to any object shape, especially those that cannot be defined as CAD objects 
like organic or natural objects. To generate a CAD like network, use the Feature Following 
Network option. 

 
 
Feature Following Network – Follows character lines on high curvature areas of a mesh. This 
method creates a smaller number of patches than the Evenly Distributed Network method 
and expresses the model similarly to CAD data. 

 
 

Patch Network Options 

No. of Surfaces – Controls the total number of patches in a network. A higher value more 
accurately represents a mesh but increases the number of patches and the file size. The 
Estimate button  will automatically recommend a value. 
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Patch Size Regularity – Controls the regularity of patches. When the slider is moved to 
Adaptive, the application will generate an appropriate patch shape around areas of high 
curvature and when the slider is moved to Uniform, patches will be regular size regardless of 
the curvature area. 

 

 

Adaptive Uniform 
 
Hole Filling By Area – Generates fitting surfaces when small holes that normally disturb the 
creation of fitting surfaces exist in a mesh. When the slider is moved to Large, holes with areas 
up to 20% of the entire mesh areas will be filled. 
 
Remove Sharp Patches – Removes sharp patches in a curve network. 

 
 
Relax Initial Mesh – Internally modifies a mesh to make regular size poly-faces and generates 
patches with lines that are close to 90 degree angles. 
 
Level of Patch Complexity – Adjusts the level of patch complexity in a mesh using the slider. 
The number of patches will be increased by adjusting towards "More". 
 
Optimize Patch Network – Minimizes irregular patches such as narrow and long patches. 
 

Fitting Options 

No. of Control Points / Surface – Determines the number of control points along the U and V 
directions for each surface. The values are simultaneously changed and the control points are 
internally set and cannot be displayed. The higher the number of control points, the more 
degrees of freedom for changing the shape and accurately following areas of high curvature 
areas but at the loss of surface smoothness. 

 

Control Points 
 
Smoothness – Controls the smoothness of a fitting surface. A strong smoothness will remove 
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spikes and wrinkles but will also lose fitting accuracy. 

  

Smoothness: Less Smoothness: More 
 
Geometry Capture Accuracy – Defines geometry capture accuracy. When the slider is moved 
towards Loose, less poly-faces will be used to create a shape. When the slider is moved 
towards Tight, more poly-faces will be used to create a shape. 

  

Loose Tight 
 
Remove Self-intersecting Patches – Remove self-intersecting patches. 
 

Stage 2 of Evenly Distributed Network 

The following editing methods appear when the Evenly Distributed Network method is 
chosen in Stage 1. You also can quickly access the editing methods from the pop-up menu. 
 
Deform Curve Network (D) – Deforms a preview network by moving a node of a curve within 
in an editing zone. To adjust the editing zone, hold down the Alt key and left-click and drag the 
mouse left or right. The shortcut key of this method is D. 

 
 
Subdivide Vertex (S) – Previews subdivided curves when the mouse positions on an 
intersection node. The shortcut key of this method is S. 

 
 
Merge Vertex (G) – Previews merged curves to help reduce the number of network curves 
when the mouse positions inside of a network area. The shortcut key of this method is G. 
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Rotate Edge (R) – Previews rotated curves to flip an edge direction when the mouse positions 
on a network curve. The shortcut key of this method is R. 

 
 
Relax Patches – Smooths entire patches. 

  

Before Relax Patches After Relax Patches 
 
 

Stage 2 of Feature Following Network 

The following editing methods appear when the Feature Following Network method is 
chosen in Stage 1. You also can quickly access the editing methods from the pop-up menu. 
 
Deform (D) – Deforms a spline by moving a node of a curve within in an editing zone. To adjust 
the editing zone, hold down the Alt key and left-click and drag the mouse left or right. The 
shortcut key of this method is D. 

  

Before Deform After Deform 
 
Split (S) – Adds a spline and splits a patch to generate an additional patch by picking a point 
on a spline and then picking a second point on another spline that will be displayed in green. 
The shortcut key of this method is S. 

  

Before Split After Split 
 
Slide (E) – Repositions the start or end point of a spline to another position. Pick a spline first 
and then pick the position on another green spline. The shortcut key of this method is E. 
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Before Slide After Slide 
 
Merge (G) – Removes a patch in a network by merging patches together. Patches that are able 
to be merged will be displayed in green and when the mouse cursor is placed over a green 
patch, a preview of the merged patch will be displayed. The shortcut key of this method is G. 

  

Before Merge After Merge 
 
Remove (R) – Deletes a spline. Only highlighted splines can be removed. The shortcut key of 
this method is R. 

  

Before Remove After Remove 
 
Swap Y and T Junction (W) – Swaps the properties of a Y junction and a T junction. Splines 
able to be swap will be displayed in green. When a green spline is selected, the T junction mark 
will be swap to the Y junction. The shortcut key of this method is W. 
 
Y junction consists of three splines and T junction consists of two splines. 

  

Y Junction T Junction 
 
If a patch is consist of Y and T junction but T junction is located at a corner of a rectangle, the 
rectangle does not consist of right four edges. By swapping Y and T junction this rectangle can 
have correct four edges.  

  

Before Swap After Swap 
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Define Sharp Edges (H) – Defines a spline as a sharp edge which prevents a spline from 
matching with neighboring surfaces. Splines defined as sharp edges will be highlighted. 

  

Defining Sharp Edges Defined Sharp Edges 
 

  

Fitting Result with Sharp 
Edge 

Fitting Result without Sharp 
Edge 

 
Quick Preview – Displays preview results without matching and sewing. 
 
Show Erroneous Patches – Highlights erroneous patches (gaps between patches or missed 
patches after generating fitting surfaces) in red. The thin red patch shows errors created when 
fitting or sewing. The thick red patch shows errors created when generating surfaces. 
Erroneous patches can be navigated through by clicking the Previous   or Next  
buttons. 
 
Show Nodes And T-junctions – Displays interesting nodes and T junction on patches. 

   

Show Nodes and T Junctions Hide Nodes and T Junctions 
 
Show Defined Sharp Edge – Displays sharp edges defined by the editing method “Define 
Sharp Edges (H)”. 
 
Deform With Stiffening Around Crossing Nodes – Maintains tangency after deforming 
splines around an intersecting node, otherwise, sharp edges will be formed. 

   
With Option Without Option 
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See Also 

Insert > Surface > Mesh Fit 
Insert > Surface > Boundary Fit 
 
 
 

Insert > Surface > Extrude 
 

What 

The Extrude command stretches an object section in a straight direction and then generates an 
open solid body. The object section is expressed by a single profile or multiple profiles on a sketch. 
A profile is drawn by sketch entities such as a single circle or a spline or the combination of lines, arcs 
or splines. 

 

Sketch Direction and Length Extrusion Body 
 

Note:  

To generate an extruded surface feature, it is not necessary for a profile to be closed. If an extruded solid 
feature generated from a closed profile is desired use the Solid > Extrude command. 

 
 

Why 

The Extrude command is useful for: 

• Creating a body for a straight object 

• Creating a boss or rib on a plastic part 

• Creating a hole in an object 

• Creating a straight pipe 

• Creating the outside of a building 

• Creating a pillar of a building or bridge 

 
 

How to Use 

How to generate an extrusion surface body 
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1. Draw a sketch or a mesh sketch. 

 
 

2. Go to Insert > Surface > Extrude or click the icon in the toolbar and select the sketch 
as the Base Sketch. Specify the desired Length for the extrusion. 

 
 

3. Check the Draft option and specify the value as 10 degrees to generate a tapered body. 

 
 

4. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Base Sketch – Select a base sketch, or a 2D sectional profile of an extrusion object. 
 
Profiles – Selects closed-loop profiles in a sketch to extrude. 

  

Extrude Loop1, 2 & 3 Extrude Loop 2 & 3 
 
Custom Direction – Specifies a different extrusion direction as the default direction for a linear 
entity with a normal. The default extrusion direction will be the normal of the sketch plane. 
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Default Extrusion Custom Direction Extrusion 
 
 

Methods 

The following methods are available in this command: 

• Blind 

Defines the height of an extrusion 

• Through All 

Defines the height of an extrusion to the end of all bodies 

• Up To Vertex 

Defines the height of an extrusion to a vertex. 

• Mid Plane 

Defines the symmetry extrusion feature of a sketch 

 
Blind – Extends a profile to a specified distance. 

 
 
Through All – Extends a profile through all existing solid or surface bodies in an extrusion 
direction. 

 
 
Up To Vertex – Extends a profile until a selected vertex. 

  
 
Mid Plane – Extends a profile in two directions from a sketch. The sketch will become the middle 
of the extrusion. 
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More Options 

Draft – Applies a draft angle to a model that can be flipped by using the Flip Direction button 
. Draft angles are used for a mold to ease in the removal of a molded part. 

  

Draft: 0 Draft: 10 
 
Opposite Direction – Extrudes a body shape from a base sketch in the opposite direction of the 
default direction. 

 
 
 

See Also 

Insert > Modeling Wizard > Extrusion Wizard 
Insert > Solid > Extrude 
 
 
 

Insert > Surface > Revolve 
 

What 

The Revolve command turns an object section around a revolution axis and then generates a 
surface body. The object section is expressed by a single profile or multiple profiles on a sketch. A 
profile is created by sketch entities such as a circle, spline, or the combination of lines, arcs and 
splines. 
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Sketch Axis and Angle Revolution Body 
 

Note:  

To generate a revolved surface feature, it is not necessary for a profile to be closed. If a revolved solid 
feature generated from a closed profile is desired use the Solid > Revolve command. 

 
 

Why 

The Revolve command is useful for: 

• Creating a fully revolved object 

• Creating a half revolved or angled object 

 
 

How to Use 

How to generate a revolved surface from a revolution angle 
1. Draw a sketch or a mesh sketch that includes profile and revolution axis. 

 
 

Note:  

A revolution axis can be a construction line or another linear entity from a sketch such as a 
vector or an overlapping edge. 

 
 

2. Go to Insert > Surface > Revolve or click the icon in the toolbar. 
 

3. Select a Base Sketch. If a sketch has an axis as a construction line the application will 
automatically recognize it as the Axis. 
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4. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Base Sketch – Selects a sketch to revolve. 
 
Profiles – Selects desired loops to revolve from multiple loops. 

  

Revolve Loop 1 Revolve Loop 1, 2 & 3 
 
Axis – Selects a linear entity as an axis to revolve a sketch around. 
 

Methods 

The following methods are available for this command: 

• One Direction 

Sets the revolution direction to a single direction 

• Mid Plane 

Sets symmetrical a revolution direction for both side of a sketch 

• Two Direction 

Creates a revolution in both direction with different angle values 

 
One Direction – Creates a revolved feature in one direction from a sketch. 

 
 
Mid Plane – Creates a symmetrical revolved feature in both the clockwise and counterclockwise 
directions from a base sketch. 
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Two-Direction – Creates a revolved feature in the clockwise and counterclockwise directions 
from a sketch plane with different angle values. The total of the two angles cannot exceed 360 
degrees. 

 
 

More Options 

Angle – Specifies the revolution angle from a base sketch. 
 
Opposite Angle – Specifies the revolution angle of the side opposite the default side. This option 
is available only for the Both Directions method. 

 
 

See Also 

Insert > Modeling Wizard > Revolution Wizard 
Insert > Solid > Revolve 
 
 
 

Insert > Surface > Sweep 
 

What 

The Sweep command traces the path of an object section and generates a surface body from it. The 
object section is expressed by a single profile or multiple profiles on a sketch. A profile is created by 
sketch entities such as a circle, spline, or the combination of lines, arcs and splines. 

 

Sketch Profile and Path Sweep Body 
 

Note:  

To generate a swept surface feature, it is not necessary for a profile to be closed. If a swept solid feature 
generated from a closed profile is desired use the Solid > Sweep command. 

 



Geomagic Design X | Menu  358 
 

 

Why 

The Sweep command is useful for: 

• Creating a bent object with a constant section 

• Creating a twisted object with a constant section 

 
 

How to Use 

How to generate a sweep surface feature using a profile and a path 
1. Prepare sketches that include a profile and a path. 

 
 

2. Go to Insert > Surface > Sweep or click the icon in the toolbar. 
 

3. Select a Profile and a Path. 

 
 

4. Change the Method to Keep Normal Constant. 
 

5. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Profiles – Selects a profile such as a sketch, 3D sketch, or edge that will be used to create a sweep 
body. To make a composite profile, select edges or curves with the Shift button. A profile should 
not self-intersect.  
 
Paths – Selects a path on which the profile follows. You can use the opened or closed loop. The 
start point of the path must lie on the plane of the profile. The path should not be self-
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intersection. 
 

Methods 

The following methods are available in this command: 

• Follow Path 

• Keep Normal Constant 

• Follow Path AND First Guide Curve 

• Follow First And Second Guide Curves 

• Twist Along Path 

• Twist Along Path With Normal Constant 

 
Follow Path – Keeps a profile at same angle with respect to path at all times. 

 
 
Keep Normal Constant – Keeps a profile parallel to the beginning section at all times. 

 
 
Follow Path and First Guide Curve – Selects a guide curve to control the intermediate shape of 
a profile. Click the  button and select a guide curve. 

 
 

 
Follow First and Second Guide Curve – Selects two guide curves to control the intermediate 
shape of a profile. Click the  button and select guide curves. 
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Twist Along Path – Twists a section along a path. Define the twist angle by degrees. 

 
 
Twist Along Path With Normal Constant – Twists a section along a path keeping the section 
parallel to the beginning section as it twists along the path. 

 
 

Path Options 

Path Alignment Type – Stabilizes a profile when small and uneven curvature fluctuations along 
the path cause the profile to misalign. This option is available when Follow Path is selected. 
 

None – Aligns a profile normal to a path. No correction is applied. 

  
 

Direction Vector – Aligns a profile in a selected direction. Select a linear entity to set the 
direction vector. 

   

Guide Curves 

Guide Curves – Guides a profile as it sweeps along a path. Click the  button and 
select a guide curve on the screen. 
 

Options 

Improve Curvature Flow Along Sweep Path – Smoothly connects curvature flow of faces along 
a sweep path. 
 
Merge Tangent Faces – Merges tangentially connected faces and reduces the total face 
numbers. 
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Without Merge Tangent 
Faces 

With Merge Tangent Faces 
 

 
 

See Also 

Insert > Modeling Wizard > Sweep Wizard 
Insert > Solid > Sweep 
 
 
 

Insert > Surface > Loft 
 

What 

The Loft command connects multiple object sections and generates a surface body from them. The 
object sections are expressed by a single profile or multiple profiles on a 2D or 3D sketch and can be 
drawn by circles, splines, lines and arc sketch entities. 

 

Sketch Section Profiles Loft Body 
 

Note:  

To generate a lofted solid feature, a profile must be closed. For more information, see Insert > Solid > Loft. 

 
 

Why 

The Loft command is useful for: 

• Creating an object connected by multiple sections 

• Creating different starting and ending profile objects 

 
 



Geomagic Design X | Menu  362 
 

How to use Loft command 

How to generate a loft feature using profiles 
1. Go to Insert > Surface > Loft or click the icon in the toolbar. 

 
 

2. Select Profiles to loft. 

 
 

Note:  

The alignment between loft profiles can be modified by manipulating the handles (spheres) 
that appear on the selected profiles as part of the connector. The connector is the poly line 
connecting corresponding points in both directions. 

 
 

Note:  

The lofting order of profiles in the dialog tree can be changed by using the Up  and Down 
 buttons after selecting a profile in the list. 

 

 
 

3. Click OK to complete the command.  
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Options in Detail 

Select Entities 

Profiles – Selects a profile such as a sketch, 3D sketch, or edge that will be used to create a 
sweep body. To make a composite profile, select edges or curves with the Shift button. A profile 
should not self-intersect. 
 

Note:  

- Non-planar profiles can be used for a loft surface. 

- To make a composite profile, select multiple edges or curves with the Shift key. 

 

 
 

Constraints 

Start Constraint – Selects the starting constraint type. 
 

None – Applies no tangency constraints or zero curvatures. 

 
 

Direction Vector – Applies a tangency constraint based on a selected entity. Click the 
Direction Vector button and select a linear entity such as a vector, line, edge, etc, or a 
planar entity such as a plane, region, or face. 
 

Tangent Length – Controls the amount of tangency influence on a loft by setting 
the value or manipulating the blue arrow in the Model View. The tangency 
direction can be reversed by using the Flip Tangent button . 
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Tangent Length: 1 Tangent Length: 2 
 

Use Same Tangent Length To All Vertices - Applies the same tangency to all 
vertices on a profile. Tangent length can also be applied individually on each 
vertex. 

 

 

Use Same Tangent Length Individual Tangent Length 
 

Normal To Profile - Applies a tangency constraint normal to a starting profile. 
 

Tangent Length – Refer to the Direction Vector option. 
 

Use Same Tangent Length To All Vertices – Refer to the Direction Vector option. 
 

Tangency To Face – Creates a tangency constraint that follows a selected face and is 
available if a face is selected as a profile. Clicking the Next Face button will find the next 
candidate face. 

 
 

Tangent Length – Refer to the Direction Vector option. 
 

Use Same Tangent Length To All Vertices – Refer to the Direction Vector option. 
 
Curvature To Face – Creates a curvature constraint that follows a selected face and is 
available if a face is selected as a profile. Clicking the Next Face button will find the next 
candidate face. 
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Tangent Length – Refer to the Direction Vector option. 
 

Use Same Tangent Length To All Vertices – Refer to the Direction Vector option. 
 
End Constraint – Selects the ending constraint type. The sub-options are the 
same as the Start Constraint options. 

 
 

Guide Curves 

Guide Curves – Selects a guide curve to control the intermediate shape of a sweep body. 

  
Without Guide Curve With Guide Curve 

 

 
Without Guide Curve 

 
With Guide Curve 

 

Options 

Add Side Curve Influence – Sets the side edges of a loft surface tangent to the side edges of 
references. This option is available for Direction Vector, Tangency To Face, or Curvature To 
Face constraints. 

  

Without Side Curve Influence With Side Curve Influence 
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Merge Tangent Faces – Merges tangentially connected faces to reduce the total number of 
faces. 

  

Without Merge Tangent Faces With Merge Tangent Faces 
 
Close Loft – Closes a lofted body. 

   

 
 

See Also 

Insert > Modeling Wizard > Loft Wizard 
Insert > Solid > Loft 
 
 
 

Insert > Surface > Offset 
 

What 

The Offset command enlarges or shrinks a surface body by a constant distance. 

 
 
 

Why 

The Offset command is useful for: 

• Creating a model in a different size 

• Offsetting faces on a surface or solid body 

• Copying faces on a surface or solid body 
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How to Use 

A. How to offset faces on a surface or a solid body 
1. Prepare a solid or surface body. 

 
 

2. Go to Insert > Surface > Offset or click the icon in the toolbar. 
 

3. Select faces on a body and specify the Offset distance. 

 
 

4. Click OK to complete the command. 

 
 
 

B. How to copy faces on a body 
1. Go to Insert > Surface > Offset or click the icon in the toolbar. 

 
 

2. Select a face to copy. 

 
 

3. Change the offset distance to 0. 
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4. Click OK to complete the command and then hide the body. A copied face can be seen. 

 
 
 

Options in Detail 

Faces – Selects faces on a body or an entire surface body. 
 
Offset Distance – Specifies the distance to offset from a solid body. To reverse the offset 
direction, use the Flip Direction button. 

 
 
Make Side Wall – Creates side walls between an offset face and a body. 

 

 

Disable Option Enable Option 
 
Remove Original Faces – Removes original faces used to offset. 

 
 

Disable Option Enable Option 
 

 
 

See Also 

Insert > Solid > Offset 
Insert > Surface > Fill Face 
Insert > Surface > Trim 



Geomagic Design X | Menu  369 
 

 
 
 

Insert > Surface > Fill Face 
 

What 

The Fill Face command generates a surface patch with any number of sides within a boundary 
defined by edges, sketches or curves. 

 

Empty Face Define Boundary Filled Face 
 
 

Why 

The Fill Face command is useful for: 

• Filling in missing faces of an imported body 

• Healing faces 

• Modifying local features 

• Filling holes for machining 

 
 

How to Use 

How to fill a missing face 
1. Prepare a body with a missing face. 

 
 

2. Go to Insert > Surface > Fill Face or click the icon in the toolbar. 
 

3. Select the edges to fill with a face. 



Geomagic Design X | Menu  370 
 

 
 

4. Click OK to complete the command. 

  
 
 

Options in Detail 

Select Entities 

Edges – Selects edges on a body to fill with a face. 
 
Fit Face To Underlying Mesh – Fits a face to an underlying mesh. This option is useful for real 
parts that are different from their originally designed CAD parts. 
 

Geometry Capture Accuracy – Defines geometry capture accuracy. When the slider is 
moved towards Loose, less poly-faces will be used to create a shape. When the slider is 
moved towards Tight, more poly-faces will be used to create a shape. 
 

Smoothness – Determines the smoothness level of a fitting surface. Moving the slider 
to More will increase smoothness but can also lower accuracy. 

  

Smoothness: Less Smoothness: More 
 
 

Matching Options 

Set Continuity Constraint – Defines a tangent or curvature constraint with adjacent faces. If 
this option is not used, sewing will be executed with the G0 position constraint. 

 

Without Continuity 
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Tangent Continuous Edges – Selects edges to connect with the G1 tangent constraint 
with adjacent faces. 

 

Tangent 
 

Curvature Continuous Edges – Selects edges to connect with the G2 curvature 
constraint with adjacent faces. This option is available if the Create Single Patch option 
is checked. 

 

Curvature 
 

Advanced Continuity Options 

This option is available when the Create Single Patch or Fit Face To Underlying Mesh options 
are used. 
 
Shape Transition To Adjacent Faces – Centralizes a modification around an edge when the 
slider is moved to Abrupt. 

 
(A) Before 

 

 
(B) The result of Abrupt 

 

 
 

(C) The result of Gradual 
 
Boundary Accuracy – Determines accuracy when sewing edges. When the slider is moved to 
Tight more tightly joined points will be created on an edge. 
 
Unconstrained Edge – Determines the deformation method for non-sewing edges that are 
unconstrained. 



Geomagic Design X | Menu  372 
 

 
 

Do Not Preserve – Does not preserve unconstrained edges which may deform them. 
 

Preserve Isolated Edges Only – Preserves isolated edges that are not adjacent to 
sewing edges. 

 
 
Preserve All – Preserves all edges without deformations. 
 

More Options 

Create Single Patch – Creates a single surface. 

  

Disable Option Enable Option 
 
Merge Result – Merges a created single surface to a body to create a single body. 

 
 

See Also 

Insert > Modeling Feature > Delete Face 
Insert > Modeling Feature > Split Face 
Insert > CAD Correct > Refit 
 
 
 

Insert > Surface > Extend 
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What 

The Extend command expands a surface boundary by an edge, multiple edges, or a face. 

 

Face Edges to Extend Extened Face 
 
 

Why 

The Extend command is useful for: 

• Expanding a face by preserving its shape 

• Creating intersections with other faces 

 
 

How to Use 

How to extend a face 
1. Prepare a surface or solid body. 

 
 

2. Go to Insert > Surface > Extend or click the icon in the toolbar. 
 

3. Select edges on a body and specify a Distance value or click-drag the green arrow on 
the graphics area to extend the face. 

 
 

4. Click OK to complete the command. 
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Options in Detail 

Select Entities 

Edges/Faces – Selects edges or faces to extend. 
 

End Conditions 

By Distance – Specifies an extension distance. 
 
Up To Point – Selects a vertex for an end position. 

 
 
Up To Body/Region – Select a face on a body or a region. The end will be cut by the selected 
body or region. 

 
 

Extension Methods 

Linear – Linearly extends the surface from the original surface. 

 
 
Curvature – Extends the surface by keeping curvature from the original surface. 

 
 
Same Surface – Extends the surface by mirroring the original surface. 
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See Also 

Insert > Surface > Trim 
Insert > Surface > Trim & Merge 
Insert > Solid > Cut 
 
 
 

Insert > Surface > Trim 
 

What 

The Trim command cuts a surface body by removing material using a surface, solid body or curve. 
The remaining material is chosen manually. 

 

Face Target (Face) and Tool (Curve) Entity Trimmed Face 
 
 

Why 

The Trim command is useful for: 

• Creating a feature by surface modeling method 

• Creating a sheet metal part 

• Trimming a surface by using a curve or another surface 

• Removing surface material with intersecting surface 

 
 

How to Use 

A. How to trim a face by a curve 
1. 
 

Prepare a face and a curve. 
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2. Go to Insert > Surface > Trim or click the icon in the toolbar. 
 

3. Select a curve as a Tools Entities and a face as a Target Bodies. 

 
 

3. Click the Next Stage button and select a face to remain after the trim. 

 
 

4. Click OK to complete the command.  

 
 
 

B. How to trim a face by another faces 
1. 
 

Prepare a face and s curve. 

 
 

2. Go to Insert > Surface > Trim or click the icon in the toolbar. 
 

3. Select two faces as Tools Entities and a main face as a Target Bodies. 

 
 

3. Click the Next Stage button and select a face to remain after the trim. 
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4. Click OK to complete the command.  

 
 
 

Options in Detail 

Select Entities 

Tool Entities – Selects tool entities such as ref. planes, regions, sketch chains, surface bodies 
and solid bodies to cut a target face. 
 

Note:  

When a tool entity does not make a complete interaction with a target entity, it will be extended and 
will make an intersection automatically. 

 

 
Target Bodies – Defines a target surface body. 

 
 

Note:  

It is possible to trim between tool entities without defining a target entity. If a target entity is defined 
then tool entities will be hidden in the following stage to aid in the selection of remaining faces. 
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Result 

Remaining Bodies – Selects remaining areas. 

 
 
 

See Also 

Insert > Surface > Untrim 
Insert > Surface > Trim & Merge 
Insert > Solid > Cut 
 
 
 

Insert > Surface > Untrim 
 

What 

The Untrim command extends a surface boundary and returns it to an untrimmed status. 

 

Trimmed Face Edges to Untrim Result Face 
 
 

Why 

The Untrim command is useful for: 

• Filling holes 

• Re-trimming an original face 

 
 

How to Use 

How to patch a hole by using the Untrim command 
1. Prepare a trimmed face. 
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2. Go to Insert > Surface > Untrim or click the icon in the toolbar. 
 

3. Select a face as Entities. 

 
 

4. Click OK to complete the command. 

 
 
 

Options in Detail 

Entities – Selects entities such as edges, loops and faces to untrim. 

 

Entity: Face 
 

 

Entity: Edge 
 

 
 

See Also 

Insert > Surface > Trim 
Insert > Surface > Trim & Merge 
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Insert > Surface > Trim & Merge 
 

What 

The Trim & Merge command trims faces leaving a common area among intersecting faces to 
generate a solid body. 

 

Intersecting Faces Trim and Merge Solid Body 
 
 

Why 

The Trim & Merge command is useful for: 

• Creating a feature from intersecting faces 

 
 

How to Use 

How to cut intersecting faces and leave a common area 
1. Prepare a set of faces that can create inner material. 

 
 

2. Go to Insert > Surface > Trim & Merge or click the icon in the toolbar. 
 

3. Select all faces as Entities. 

 
 

4. Click OK to complete the command. 
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Options in Detail 

Entities – Selects enclosed faces or regions. 
 
 

See Also 

Insert > Surface > Trim 
 
 
 

Insert > Surface > Sew 
 

What 

The Sew command combines two or more faces into a single surface body by sewing together 
boundaries. 

 

Indipendant Faces Sewing Surface Body 
 
 

Why 

The Sew command is useful for: 

• Combining faces 

• Matching faces 

 
 

How to Use 

How to sew faces with the tangent constraint 
1. Prepare faces. 



Geomagic Design X | Menu  382 
 

 
 

2. Go to Insert > Surface > Sew or click the icon in the toolbar. 
 

3. Select faces as Surface Bodies. Click the Next Stage button. 

 
 

4. To tangentially connect faces, check the Set Continuity Constraint option. Click the 
Tangent Continuous Edges button and select common edges between faces. 

 
 

5. Click OK to complete the command. Faces will be tangentially connected to form a 
single surface body. 

 
 
 

Options in Detail 

Select Entities 

Surface Bodies – Selects independent surfaces to sew. 
 

Zip Gaps 

Edge Pair – Forces the connection of gaps between faces that are larger than the internal 
tolerance for the application. While sewing gaps surface geometry can be deformed. To 
make edge pairs, select two edges in sequence or drag edges together. 
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Set Continuity Constraint – Defines a tangent or curvature constraint with adjacent faces. 
If this option is not used, sewing will be executed with the G0 position constraint. 
 

Tangent Continuous Edges – Selects edges to connect with the G1 tangent 
constraint with adjacent faces. 

 
 

Curvature Continuous Edges – Selects edges to connect with the G2 curvature 
constraint with adjacent faces. 

 
 

Note:  

When Environment Mapping in Accuracy Analyzer™ is enabled, surface matching condition 
will be displayed. When G0 continuity is used the flow of light will be split on an edge. When G1 
continuity is used it will be connected without splitting but can have a sharp peak. When G2 
continuity is used it will be smoothly connected without splitting and peaking. 

 
Original Shape 

 
G0 Continuous 

 
G1 Continuous 

 
G2 Continuous 

 



Geomagic Design X | Menu  384 
 

 
Master Faces – When faces are designated as Master Faces they will not deform 
while sewing. 

 
Without Master Faces 

 
Master Face: Side 

 

Master Face: Top 
 

Advanced Continuous Options 

Shape Transition To Adjacent Faces – Centralizes the deformation of faces around an edge 
as the slider is moved to Abrupt. 

 
(A) Before 

 
(B) The result of Abrupt 

 

(C) The result of Gradual 
 
Boundary Accuracy – Determines accuracy when sewing edges. When the slider is moved 
to Tight the application will create more points on an edge to sew. The Preview button 
shows the maximum deviation between edges. 
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Loose Tight 
 
Unconstrained Edge – Determines the deformation method for non-sewing edges that are 
unconstrained. 

 
 

Do Not Preserve – Does not preserve unconstrained edges which may deform them. 
 

Preserve Isolated Edges Only – Preserves isolated edges that are not adjacent to 
sewing edges. 

 
 

Preserve All – Preserves all edges without deformations. 
 
 

See Also 

Insert > Surface > Trim and Merge 
 
 
 

Insert > Surface > Reverse Normal 
 

What 

The Reverse Normal command flips the normal of faces. 
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Original Face Reversed Face 
 
 

Why 

The Reverse Normal command is useful for: 

• Mating normal between faces 

 
 

How to Use 

How to flip the normal of a surface body 
1. Prepare a surface body. 

 
 

2. Go to Insert > Surface > Reverse Normal or click the icon in the toolbar. 
 

3. Select a surface body. 

 
 

4. Click OK to complete the command. 

 
 
 

Options in Detail 
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Surface Bodies – Selects surface bodies to reverse the normal. 
 
 
 

7.4.8. Insert > Modeling Wizard 
 
The Modeling Wizard menu features various commands used to extract geometric features from a 
mesh model. These wizards intelligently analyze features from a mesh and automatically extract 
feature information such as feature profiles, axes, and paths. After using a wizard, features can be 
manually edited for more accurate results. 
 

Generating Primitive Features 

• Solid Primitives 

Generates the following solid features: cylinders, cones, spheres, tori and boxes 

• Surface Primitives 

Generates the following surface features: planes cylinders, cones, spheres and tori 

 

Generating CAD Features 

• Extrusion Wizard 

Generates extruded bodies 

• Revolution Wizard 

Generates revolved bodies 

• Sweep Wizard 

Generates swept bodies 

• Loft Wizard 

Generates lofted bodies 

• Pipe Wizard 

Generates swept bodies with circular profiles and paths 

 
 
 

Insert > Modeling Wizard > Solid Primitives 
 

What 

The Solid Primitives command quickly extracts simple geometry objects from a mesh. Solid 
primitives such as cylinders, cones, spheres, tori and boxes can be extracted. 
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Mesh Mesh with Region Solid Primitives 
 

Note:  

Primitive objects are extracted based on regions. To use the Solid Primitive function, a mesh must have 
region groups that can be generated by the Region Group mode in the toolbar. 

 

 
 

Why 

The Solid Primitives command is useful for: 

• Generating solid primitive features 

 
 

How to Use 

How to generate solid primitive features from a mesh 
1. Prepare a mesh. 

 
 

2. Go to Insert > Region Group or click the icon in the toolbar. Click OK in the Auto 
Segment command to classify regions. 

 
 

3. Exit the Region Group mode. 
 

4. Go to Insert > Modeling Wizard > Solid Primitives or click the icon in the toolbar. 
Choose the Automatically Extract Shapes option. Select all regions on the mesh and 
check the Cone and Sphere shape types under the Shapes To Be Extract option. 
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5. Click the Next Stage button to move to the next step. 

 
 

6. Extracted primitives will be displayed and can also be removed under the Result 
option. Click OK to confirm remaining primitives. 

 
 

7. Hide the mesh to see the final extracted primitive solid bodies. 

 
 
 

Options in Detail 

Methods 

Automatically Extract Shapes – Extracts possible primitive features from selected regions. 
Cylinder, Cone, Sphere and Torus can be selected as candidate features to be extracted. 

 
 
The next stage will show the candidate primitives. To remove candidates, select them from the 
list box, and then click the Delete key. 
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Extract Specific Shape – Extracts a specified single primitive feature such as a Cylinder, Cone, 
Sphere, Torus and Box from a selected region. The Preview button   will show extracted 
primitives without completing the command. 

 
 

Select Entities 

Regions – Selects regions on a mesh to create solid primitives. 
 

More Options 

Expand Ratio – Expands a feature by a specified ratio. 

  

Ratio: 0 Ratio: 50 
 
Merge Regions Belong To Single Shape – Generates a single primitive feature from separated 
regions as a single shape. This option is available in the Automatically Extract Shapes 
method. 

  

Disable Merge Enable Merge 
 
Use Only Regions Covering Whole Shape – Extracts only a complete shape of a primitive 
region as a primitive feature. When extracting primitive features from partial shape of regions, 
uncheck this option. This option is available in the Automatically Extract Shapes method. 

  

Whole Shape of Cylinder Partial Shape of Cylinder 
 
Get Partial Shape – Extracts only partial primitive features from partial regions. 
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Partial Shape of Sphere Enable Option Disable Option 
 

 
 

See Also 

Insert > Modeling Wizard > Surface Primitives 
 
 
 

Insert > Modeling Wizard > Surface Primitives 
 

What 

The Surface Primitives command quickly extracts simple geometry objects from a mesh. Surface 
primitives such as cylinders, cones, spheres, and tori can be extracted. 

 

Mesh Mesh with Region Surface Primitives 
 

Note:  

Primitive objects are extracted based on regions. To use the Surface Primitive function, a mesh must have 
region groups that can be generated by the Region Group mode in the toolbar. 

 

 
 

Why 

The Surface Primitives command is useful for: 

• Generating surface primitive features 

 
 

How to Use 
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How to generate surface primitive features from a mesh 
1. Prepare a mesh. 

 
 

2. Go to Insert > Region Group or click the icon in the toolbar. Click OK in the Auto 
Segment command to classify regions. 

 
 

3. Exit the Region Group mode. 
 

4. Go to Insert > Modeling Wizard > Surface Primitives or click the icon in the toolbar. 
Choose the Automatically Extract Shapes option. Select all regions on the mesh and 
check the Plane and Cylinder shape types under the Shapes To Be Extract option. 

 
 

5. Click the Next Stage button to move to the next step. 

 
 

6. Extracted primitives will be displayed and can also be removed under the Result option. 
Click OK to confirm remaining primitives. 

 
 

7. Hide the mesh to see the final extracted primitive surface bodies. 
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Options in Detail 

Methods 

Automatically Extract Shapes – Extracts possible primitive features from selected regions. 
Plane, Cylinder, Cone, Sphere and Torus can be selected as candidate features to be extracted. 

 
 
The next stage will show the candidate primitives. To remove candidates, select them from the 
list box, and then click the Delete key. 

 
 
Extract Specific Shape – Extracts a specified single primitive feature such as a Plane, Cylinder, 
Cone, Sphere, Torus and Box from a selected region. The Preview button   will show 
extracted primitives without completing the command. 

 
 

Select Entities 

Regions – Selects regions on a mesh to create surface primitives. 
 

More Options 

Expand Ratio – Expands a feature by a specified ratio. 

  

Ratio: 0 Ratio: 50 
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Merge Regions Belong To Single Shape - Generates a single primitive feature from separated 
regions as a single shape. This option is available in the Automatically Extract Shapes 
method. 

  

Disable Merge Enable Merge 
 
Use Only Regions Covering Whole Shape – Extracts only a complete shape of a primitive 
region as a primitive feature. When extracting primitive features from partial shape of regions, 
uncheck this option. This option is available in the Automatically Extract Shapes method. 

  

Whole Shape of Cylinder Partial Shape of Cylinder 
 
Get Partial Shape – Extracts only partial primitive features from partial regions. 

   

Partial Shape of Sphere Enable Option Disable Option 
 

 
 

See Also 

Insert > Modeling Wizard > Solid Primitives 
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Insert > Modeling Wizard > Extrusion Wizard 
 

What 

The Extrusion Wizard command extracts extruded objects from a mesh. The wizard intelligently 
computes sectional profiles, extrusion direction, and height based on selected regions. 

 

Mesh Mesh with Region Extrusion Feature 
 
 

Why 

The Extrusion Wizard command is useful for: 

• Generating extrusion solid or surface features 

 
 

How to Use 

How to quickly generate an extrusion feature based on a mesh 
1. Prepare a mesh with regions and go to Insert > Modeling Wizard > Extrusion Wizard 

or click the icon in the toolbar. 

 
 

2. Click the Sides button and choose regions for the side faces of an extrusion body. 
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3. Click the Top button and choose a region for the top face of an extrusion body. 

 
 

Note:  

The Extrusion Wizard can be executed without selecting a top region. The application will 
automatically define the top. 

 

4. Click the Bottom button and choose a region for the bottom face of an extrusion body.  

 
 

Note:  

The Extrusion Wizard can be executed without selecting a bottom region. The application 
will automatically define the bottom. 

 
 

5. Click the Next Stage button. To make a solid body, check the Cap Ends option. 

 
 

6. Click OK to complete the command. Hide the mesh to see the result. 

 
 

Note:  

The profile of an extrusion body is registered in the Feature Tree. Curves of the profile can 
be edited for a more fine and accurate extrusion body. 
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Options in Detail 

Select Entities 

Sides – Selects regions or poly-faces on the mesh. 
 
Top – Selects regions, poly-faces, poly-vertices or faces for the top face of an extrusion body. If a 
top face is not defined, the application will automatically find it. 
 
Bottom – Selects regions, poly-faces, poly-vertices or faces for the bottom face of an extrusion 
body. If a bottom face is not defined, the application will automatically find it. 
 

Note:  

When a seed region is selected, the Estimate button   will be enabled and can be used to 
automatically find target regions that require the creation of an extruded feature shape. 

 
Custom Extrusion Direction – Selects a custom direction for an extrusion from an entity or 
linear entity with a normal. The default extrusion direction will be calculated by the direction of 
selected regions. 

  

Default Extrusion Custom Direction Extrusion 
 

Note:  

When target regions are selected, the Custom Extrusion Direction can be automatically found from 
the selected target regions by using the Estimate button . 

 
Fix Sketch Plane With Selection – Fixes a sketch base plane by using a user-defined 
plane. 

 
Draft Angle – Specifies a draft angle for an extrusion body or automatically applies a value if 
Auto or 0 is used. The Estimate button  will recommend an adaptable draft angle. 

  



Geomagic Design X | Menu  398 
 

With Draft Angle Without Draft Angle 
 
Result Operator – Specifies results. This option offers 5 different operation methods: Solid 
Insert, Solid Merge, Solid Cut, Surface Insert, and Surface Cut.  
 

Note:  

If other bodies exist already, the Boolean operation can be used while creating extruded features. 

 
Solid Insert – Creates a new solid body. 
 
Solid Merge – Merges a resulting body into an existing solid body. 
 
Solid Cut – Cuts an existing solid body by a resulting solid body 
 
Surface Insert – Creates a new surface body. 
 
Surface Cut – Cuts an existing solid body using a resulting surface body 

 

Second Stage Options 

Draft Angle – Specifies a draft angle for an extrusion body or automatically applies a value if 
Auto or 0 is used. The Estimate button  will recommend an adaptable draft angle. 
 
Resolution – Specifies the resolution of section segments by adjusting the slider between Min. 
and Max. When adjusting the slider towards Max., more segments will be constructed.  
 

  

Low Resolution High Resolution 
 

Note:  

While adjusting the slider, results will be updated in real-time. 

 
Geometry Capture Accuracy – Specifies geometry capture accuracy by adjusting the slider 
between Loose and Tight. When moving the slider toward Tight, sketches will be extracted from 
section segments with a tight tolerance. 
 
Sewing Tolerance – Specifies a tolerance range for sewing sketches by adjusting the slider 
between Min. and Max. When adjusting the slider toward Max., sketches will be joined with 
coincidence constraint with a loose tolerance. 

  

With Tight Tolerance With Loose Tolerance 
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Note:  

When moving the slider toward Min., sketches may not be joined with coincidence constraint because 
of use of tight tolerance. 

 
Remove Small Fillet – Removes automatically generated small fillets by using a radius value. 

  
Filleted Feature Removed Fillet 

 

 
 

See Also 

Insert > Modeling Wizard > Revolution Wizard 
Insert > Modeling Wizard > Sweep Wizard 
Insert > Modeling Wizard > Loft Wizard 
Insert > Modeling Wizard > Pipe Wizard 
 
 
 

Insert > Modeling Wizard > Revolution Wizard 
 

What 

The Revolution Wizard command extracts revolved objects from a mesh. The wizard intelligently 
computes sectional profiles and revolution axis and the rotation angle based on the selected regions. 

 

Mesh Mesh with Region Revolution Feature 
 
 

Why 

The Revolution Wizard command is useful for: 

• Generating revolved solid or surface features 
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How to Use 

How to generate a revolution feature based on a mesh 
1. Prepare a mesh with regions and go to Insert > Surface > Revolution Wizard or click 

the icon in the toolbar. 

 
 

2. Choose a region for a revolution body for the Target option. 

 
 

3. Click the Next Stage button. 

 
 

4. Click OK to complete the command. Hide the mesh to see the result. 

 
 

Note:  

The profile of an extrusion body is registered in the Feature Tree. Curves of a profile can be 
edited for a more fine and accurate extrusion body. 
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Options in Detail 

Select Entities 

Target – Selects regions or poly-faces on a mesh. 
 
Custom Revolution Axis – Finds an optimized revolution axis from a selected target. 
 

Note:  

The Custom Revolution Axis can be specified by 2 planes. When specifying a custom revolution axis by 
using 2 planes, an intersecting line will be specified as the revolution axis and a sketch base plane will 
be automatically defined on a higher priority plane from the 2 specified planes. The higher priority 
plane is determined by the order of registration in the Feature Tree 

 
Use Specified Axis Direction As It Is – Uses the direction of a specified axis as it is to set 
an axis of revolution. 

 
Use Specified Axis Of Rotation As It Is – Uses both the direction and the position of a 
specified axis to set an axis of revolution. 

 
Fix Sketch Plane With Selection – Fixes a sketch base plane by using a user-
defined plane. 
 

Get Partial Shape – Defines a revolution angle to extract a partial shape of a revolution body. 
In the second stage, the angle can be set by using the appropriate manipulator or widget. 

 

 

Manipulator Widget 
 
Result Operator – Specifies results. This option offers 5 different operation methods: Solid 
Insert, Solid Merge, Solid Cut, Surface Insert, and Surface Cut.  
 

Note:  

If other bodies exist already, the Boolean operation can be used while creating extruded features. 

 
Solid Insert – Creates a new solid body. 
 
Solid Merge – Merges a resulting body into an existing solid body. 
 
Solid Cut – Cuts an existing solid body by a resulting solid body 
 
Surface Insert – Creates a new surface body. 
 
Surface Cut – Cuts an existing solid body using a resulting surface body 
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Profile Auto Generation Options 

Full Revolution – Creates a fully revolved feature. 
 
Resolution – Specifies the resolution of section segments by adjusting the slider between Min. 
and Max. Adjusting the slider towards Max. will construct more segments. 
 

  

Low Resolution High Resolution 
 

Note:  

While adjusting the slider, results will be updated in real-time. 

 
Geometry Capture Accuracy – Specifies geometry capture accuracy by adjusting the slider 
between Loose and Tight. When moving the slider toward Tight, sketches will be extracted from 
section segments with a tight tolerance. 
 
Sewing Tolerance – Specifies a tolerance range for sewing sketches by adjusting the slider 
between Min. and Max. When adjusting the slider toward Max., sketches will be joined with 
coincidence constraint with a loose tolerance. 

  

With Tight Tolerance With Loose Tolerance 
 

Note:  

When moving the slider toward Min., sketches may not be joined with coincidence constraint because 
of use of tight tolerance. 

 
Remove Small Fillet – Removes automatically generated small fillets by using a radius value. 

  
Filleted Feature Removed Fillet 
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See Also 

Insert > Modeling Wizard > Extrusion Wizard 
Insert > Modeling Wizard > Sweep Wizard 
Insert > Modeling Wizard > Loft Wizard 
Insert > Modeling Wizard > Pipe Wizard 
 
 
 

Insert > Modeling Wizard > Sweep Wizard 
 

What 

The Sweep Wizard command quickly extracts sweep objects from a mesh. The wizard intelligently 
computes sectional profiles and the path based on the selected regions. 

 

Mesh Mesh with Region Sweep Feature 
 
 
 

Why 

The Sweep Wizard command is useful for: 

• Generating swept solid or surface features 

 
 

How to Use 

How to quickly generate sweep feature based on a mesh 
1. Prepare a mesh with regions and go to Insert > Surface > Sweep Wizard or click the 

icon in the toolbar. 

 
 

2. Select a swept region as a Target. 
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3. Choose the Auto Generation option under Profile and Path. Click the Next Stage 
button. 
 

4. A preview body will be previewed. 

 
 

5. To check the accuracy, click Deviation in the Accuracy Analyzer panel. 

 
 

6. Click Ok to complete the command. 

 
 

Note:  

The profile of a swept body is registered in the Feature Tree. Curves of a profile can be edited 
for a more fine and accurate extrusion body. 

 
 

 
 

Options in Detail 

Select Entities 

Target – Selects regions or poly-faces on a mesh. 
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Profile 

Auto Generation – Automatically finds a profile. 
 

Freeform Curve(s) – Creates 2D spline curves as the result a profile auto generation. 

 
 

Gap Joining Tolerance – Connects separated sketch entities within a given 
tolerance. 

 
Use Line/Arcs When Possible – Uses 2D lines and arcs when sectional segments are 
analyzed as lines and arcs for profile entities. 

 
 

Sensitivity – Selects the tolerance used to determine arcs and lines from sectional 
segments of a mesh. A smaller value generates a higher segment resolution. 

  

Low Resolution High Resolution 
 

Max. Arc Radius – Recognizes a curve with a value lower than a specified value as 
an arc. Curves with a value higher than the specified value will be classified as lines. 

 
 
Gap Joining Tolerance – See the sub-option under the Freeform Curve(s) method. 
 
Use Geometry In Specified Sketch – Uses a sketch that already exists outside of the sweep 
area. by transforming the sketch to the sectional coordinate of the sweep body. 
 
Use Specified Sketch As It Is – Selects a sketch to use as a sweep profile without changing its 
location. 
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Path 

Auto Generation – Automatically finds a path. 
 

Freeform Curve(s) – Creates 3D spline curves as the result a profile auto generation. 

 
 

Use Line/Arcs When Possible – Extracts lines and arcs splines when sectional segments 
are analyzed as lines and arcs for profile entities. 

 
 
Use Specified Curve As Initial Guess – Specifies a curve to approximately set a correct sweep 
path. The application will generate several sectional profiles based on a selected curve to find 
the correct path. 
 
Use Specified Curve As It Is – Selects a curve to use as a sweep profile without changing its 
location. 

Second Stage Options 

Cap Ends – Closes top and bottom faces. This option is available if the profile is a closed curve. 
 
Result Operator – Cuts or merges resulting bodies with other intersecting body or bodies. This 
option is available when one or more bodies already exist. When the Cut or Merge options are 
not checked, an independent body will remain. 
 
Profile Auto Generation Options – Refer to the first stage. 
 
Path Auto Generation Options – Refer to the first stage. 
 
Deform Curve – Deforms a preview network by moving a node of a curve within in an editing 
zone. To adjust the editing zone, hold down the Alt key and left-click and drag the mouse left 
or right. 

  

Editing Zone Enlarged Editing Zone 
 
Rebuild Curve Options – Adjusts the number of node points on a freeform curve that has 
excessive node points. 
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To edit node points: 
1. Click the Target Curves button and select splines. 
2. Set the total number of points next to No. Of Interpolation Points. 
3. Click the Rebuild Curves button . 

  

No. Of Interpolation Points: 50 No. Of Interpolation Points: 20 
 

 
 

See Also 

Insert > Modeling Wizard > Extrusion Wizard 
Insert > Modeling Wizard > Revolution Wizard 
Insert > Modeling Wizard > Loft Wizard 
Insert > Modeling Wizard > Pipe Wizard 
 
 
 

Insert > Modeling Wizard > Loft Wizard 
 

What 

The Loft Wizard command extracts loft objects from a mesh. The wizard intelligently computes 
several sectional profiles and creates a loft path based on the selected regions. 

 

Mesh Mesh with Region Loft Feature 
 
 

Why 

The Loft Wizard command is useful for: 

• Generating loft surface features 
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How to Use 

How to generate a loft feature from a mesh 
1. Prepare a mesh with regions and go to Insert > Modeling Wizard > Loft Wizard or click 

on the icon in the toolbar. 
 

2. Select regions or poly-faces where a lofted surface will be created. Check the By Plane 
option to generate sectional planes on a planar area. 

 
 

3. Check the By No. Of Sections option and set the No. Of Sections to 10. Move the Slider 
to More and manipulate the size and rotation of the preview plane in the Model View. 

 
 

4. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Regions/Poly-Faces – Selects regions or poly-faces on a mesh. 
 

Path 

By Plane – Selects a planar entity for a planar loft. Profile planes will be aligned perpendicular 
to a selected plane. 
 
By Curve – Selects a curve for a blended loft. Profile planes will be aligned perpendicular to a 
selected curve. 
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Section 

By Allowable Deviation – Calculates the adaptable number of sections by the deviation 
between allowable deviation and the limited number sections. 
 

Allowable Deviation – Specifies the allowable deviation distance between a mesh and 
a loft body. 
 
Max. No. of Sections – Limits the number of created sections by a specified value. 

 
By No. Of Sections – Calculates the loft surface by the total number of sections. 
 

No. Of Sections – Specifies the total number of sections. 
 

Smoothness – Determines the smoothness level of a fitting surface. Moving the slider 
towards More will create a smoother surface but can diminish accuracy. 
 

Profile Type 

3D Sketch – Creates 3D spline curves for profile entities and registers resulting sections as a 3D 
Sketch in the Feature Tree. 
 
Ref. Planes + Mesh Sketches – Creates 2D lines and arcs for profile entities that are analyzed 
as lines and arcs and registers resulting sections as 2D Mesh Sketch with sectional planes. 
 

Second Stage 

In the next stage, section planes can be manipulated for a more accurate loft surface. The 
Accuracy Analyzer™ can be used to check deviation in real-time. 
 
The following actions are available in the second stage: 
Move – Select and Drag 
Add – Ctrl + Drag 
Remove – Select and Delete button 
Undo – Ctrl + Z 

  

 
 

See Also 

Insert > Modeling Wizard > Extrusion Wizard 
Insert > Modeling Wizard > Revolution Wizard 
Insert > Modeling Wizard > Sweep Wizard 
Insert > Modeling Wizard > Pipe Wizard 
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Insert > Modeling Wizard > Pipe Wizard 
 

What 

The Pipe Wizard command extracts pipe objects from a mesh or point cloud. The wizard 
intelligently computes the circular profile, or radius, and the path based on selected poly-faces or 
poly-vertices. 

 

Mesh Mesh with Region Sweep Feature 
 
 

Note:  

The Pipe Wizard command, unlike the other wizard commands, can use point clouds as target entities. 
When extracting pipe features, it is not necessary to generate a mesh from a point cloud. 

 
 

Why 

The Pipe Wizard command is useful for: 

• Generating pipe features 

• As-built modeling for construction 

 
 

How to Use 

How to generate a pipe feature from a mesh 
1. Prepare a mesh or point cloud and go to Insert > Surface > Pipe Wizard or click the 

icon in the toolbar. 

 
 

2. Choose the Auto Selection option and select pipe regions in the model as Target. 
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3. Click the Next Stage button to see the preview pipe. 

 
 

4. In the Adjust Pipe Path stage, the curve of a pipe path can be edited by choosing the 
Rebuild Curve option and selecting a pipe path. Set the No. Of Interpolation Points 
to 50 and click the Rebuild Curve button. The number of nodes on the points will be 
reduced. 

   
 

5. Click OK to complete the command. A pipe body will be created. 

 
 

Note:  

The profile and the path of a swept body are registered in the Feature Tree. Curves of profiles 
and paths can be edited for more accurate pipe body. 
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Options in Detail 

1/3 Select Target Data 

Auto Selection – Uses a selected seed point to automatically find a pipe shape in a mesh or a 
point cloud. For a mesh, select regions or poly-faces and for a point cloud, select poly-vertices. 
One depth of undo is allowable from multiple selections. 
 

 

 

Selection on Point Cloud Auto Searching Pipe 
 
Data Quality – Defines the quality of scan data. When scan data is clean move the slider 
towards Clean and for noisy scan data move the slider towards Noisy. 
 

Roughness – Detects the length of a pipe path. When scan data is smoothly connected 
without noise, move the slider towards Smooth and the application will detects a pipe 
area with a tight tolerance. When the slider is moved towards Rough the application 
will extend a pipe with a loose tolerance. 

 
Smooth 

 
Rough 

 
Cylinder Selection – Detects a pipe from several picked points and is useful if a pipe is split but 
a single pipe is desired. One depth of undo is allowable from multiple selections. 
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Seed Points Detected Pipe 
 
Target – Selects regions, poly-faces or poly-vertices of a pipe area. If a poly-vertex is picked, the 
application will automatically find the pipe area. 
 
Pipe Radius – Specifies a pipe radius. When the value is Auto, the application will automatically 
find the radius of a pipe. 
 

2/3 Select Remaining Pipe 

When multiple pipe areas are selected the Select Remaining Pipe stage will shows candidate 
pipes. Pipes to be generated can be selected by clicking the Bodies button. 
 

3/3 Adjust Pipe Path 

After generating a preview pipe, the path of the pipe can be edited. 
 
Cap Ends – Closes top and bottom faces and generates a solid body. This option is available if 
the profile is a closed curve. 
 
Result Operator – Cuts or merges resulting bodies with other intersecting body or bodies. This 
option is available when one or more bodies already exist. When the Cut or Merge options are 
not checked, an independent body will remain. 
 
Freeform Curve(s) – Creates 3D spline curves as the result a profile auto generation. 

 
 
Use Line/Arcs When Possible – Uses lines and arcs splines when sectional segments are 
analyzed as lines and arcs. 
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Sensitivity – Selects the tolerance used to determine arcs and lines from sectional 
segments of a mesh. A smaller value generates a higher segment resolution. 

  

Low Resolution High Resolution 
 

Max. Arc Radius – Recognizes a curve with a value lower than a specified value as an arc. 
Curves with a value higher than the specified value will be classified as lines. 

 
 
Deform Curve – Deforms a preview network by moving a node of a curve within in an editing 
zone. To adjust the editing zone, hold down the Alt key and left-click and drag the mouse left 
or right. 

  

Editing Zone Enlarged Editing Zone 
 
Rebuild Curve – Adjusts the number of node points on a freeform curve that has excessive 
node points. 
 
To edit node points: 
1. Click the Target Curves button and select splines. 
2. Set the total number of points next to No. Of Interpolation Points. 
3. Click the Rebuild Curves button  . 

  

No. Of Interpolation Points: 50 No. Of Interpolation Points: 20 
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See Also 

Insert > Modeling Wizard > Extrusion Wizard 
Insert > Modeling Wizard > Revolution Wizard 
Insert > Modeling Wizard > Sweep Wizard 
Insert > Modeling Wizard > Loft Wizard 
 
 
 

7.4.9. Insert > Modeling Feature 
 
The Modeling Features menu features various commands used for applying additional 
modifications on basic bodies to generate final features. 
 
The Modeling Features are divided into groups used to: 
 

Modify Features 

• Fillet 

Generates rounded-edge features 

• Chamfer 

Generates beveled-edge features 

• Draft 

Generates tapered features 

• Emboss 

Sculpts patterns or shapes on a body with curves 

 

Generate Patterned Features 

• Linear Pattern 

Generates linearly copied features 

• Circular Pattern 

Generates circularly copied features 

• Curve Pattern 

Generates copied features by following a curve 

• Mirror 

Generates symmetrical features 

 

Generate Special Features 

• Helix 

Generates helical features 



Geomagic Design X | Menu  416 
 

• Spiral 

Generates spiral features 

 

Edit Bodies 

• Move Face 

Transforms faces and changes the shape of a body 

• Delete Face 

Removes faces on a body. 

• Replace Face 

Replaces faces and change the shape of a body 

• Split Face 

Adds edges on a face 

• Transform Body 

Transforms or scales bodies 

• Remove Body 

Deletes bodies 

 
 
 

Insert > Modeling Feature > Fillet 
 

What 

The Fillet command generates rounded features on a solid or surface body and can be applied to 
edges or faces. 

 

Body Apply Fillet 
 
 

Why 

The Fillet command is useful for: 

• Generating a rounded edge part 
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How to Use 

A. How to generate constant fillets with different radii 
1. Go to Insert > Modeling Feature > Fillet or click the icon in the toolbar. 

 
2. Choose the Constant Fillet method. 

 
 

3. Select outer edges and set the radius to 2mm. 

 
 

4. To add a larger radius click the Add Radius button and select inner edges. Set the 
radius to 1mm. 

 
 

5. Click OK to complete the command. 

 
 
 

B. How to generate variable fillets 
1. Go to Insert > Modeling Feature > Fillet or click the icon in the toolbar. 

 
2. Choose the Variable Fillet method and select two edges. 

 
 

3. Select Edge 1 in the list box of Entities and change the end fillet radius marked as R to 
3mm in the Profile View. 
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Note:  

The Up and Down icons can be used to change the order of entities. 

 

 
A selected edge will show a preview of the fillet. 

 
 

4. Select Edge 2 in the list box. 

 
 
Click in the middle of the yellow line to add a control point and edit it by dragging or 
inputting the value: Radius: 5mm, Position: 50%. 

 
 

Note:  

To zoom in or out of a graph in the Profile View or scroll the mouse wheel. 

 
The selected edge shape will change to reflect the inputted values. 
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5. The preview will also change. 

 
 

6. Click OK to complete the command. 

 
 
 

Options in Detail 

Methods 

Constant Fillet – Creates constant radius fillets by selecting edges or faces and specifying the 
fillet radius. 
If multiple radii are required click the Add Radius button , select more edges or faces, and 
specify the new radius.  
To remove a fillet entity, click the Remove Radius button . Edges, loops or faces can be 
selected as Entities.  
Use the Estimate Radius From Mesh button   to automatically extract the approximate 
fillet radius from a mesh. This button can only be used if meshes exist. 

 
 

Tangent Propagation – Extends a selection to tangentially connected adjacent edges. 
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With Tangent Propagation Without Tangent Propagation 
 

Selection Guide – Finds candidate edges that have similar fillet radii from an input 
radius. The candidate edges will be highlighted on a body. When multiple fillet sets exist, 
only the focused set’s radius will be highlighted. The range of the total number of 
candidate edges can be modified. 

 
 
Variable Fillet - Creates variable radius fillets by specifying different radii on an edge and will 
initiate the Profile View in the console window. A control point can be added by clicking a 
specific location on the yellow line and the radius can be set and positioned by dragging a blue 
point or clicking the widget to specify a numerical value. To remove a control point, select the 
point and click the Delete key or move the point to another point and combine them. 

 
The Estimate Radius From Mesh button  automatically extracts variable radii from a mesh 
and shows the radius flow in the Profile View. To apply variable radii automatically, click the 
down arrow button  in the Profile View and choose the Fit Graph To Mesh method. 
 
The images below show an example of the Fit Graph To Mesh method. 

 

Before Fit Graph To Mesh 
 

 

After Fit Graph To Mesh 
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The Result on Body 
 

Tangent Propagation – Refer to the Constant Fillet method. 
 

Conic Fillet –Creates a blending area with different radii to each individual face. This 
option is available under the Variable Fillet and Face Fillet methods. 

 

 

Conic Fillet: R 50 and R 25 The Result of Conic Fillet 
 

Rho – Determines the shape of a blending area with a possible value between 0 
and 1. The higher the value to 1, the sharper the blending shape, and the lower 
the value to 0, the flatter the blending shape. 

  

Rho = 0.3 Rho = 0.9 
 

Transition Method – Selects the position of the start and end of a fillet. 
Smooth Transition creates a fillet which smoothly flows from one radius to another 
when matching a fillet edge to an adjacent face. 
Linear Transition creates a fillet which linearly flows from one radius to another without 
matching edge tangency with an adjacent fillet. 

  

Smooth Transition Linear Transition 
 
Face Fillet – Selects faces to fillet. Non-adjacent faces can be blended with a fillet face. 
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Tangent Propagation – Refer to the Constant Fillet method. 
 

Conic Fillet – Refer to the Variable Fillet method. 
 

Constant Curvature – Creates a smoother curvature fillet than a standard fillet. This 
method will create no jump in curvature flow at boundaries. To verify result use 
Environment Mapping under the Accuracy Analyzer™ panel. 

  

Enable Constant Curvature Disable Constant Curvature 
 

Constant Width – Creates fillet face with constant width. 

  

Enable Constant Width Disable Constant Width 
 
Trim and Merge Result – Trims and merges faces into one body after filleting. 

   

Original Faces Check Option Uncheck Option 
 

Hold Line – Selects a body edge or curve as a boundary for where a face fillet shape 
overfills a hold line. The radius of a fillet is driven by the distance between the hold line 
and the edge to be filleted. The Asymmetry option create a symmetry hold line opposite 
to a fillet shape and is useful for creating different hold lines. 
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Help Point – Resolves an ambiguous selection when it may not be clear where a face 
blend should occur. Click the Help Point button and pick a vertex on the side where a 
face fillet should be. A fillet will be created at the location closest to the Help point. 

 
Full Face Fillet – Creates fillets that are tangent to three adjacent faces. 
 

Left – Selects the left face. 
 

Center – Selects the center face. 
 

Right – Selects the right face that is opposite to the Left face. 

  
 

Tangent Propagation – Refer to the Constant Fillet method. 
 
 

See Also 

Insert > Modeling Feature > Chamfer 
 
 
 

Insert > Modeling Feature > Chamfer 
 

What 

The Chamfer command generates a beveled feature on edges or faces of a solid or surface body. 

 

Body Apply Chamfer 
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Why 

The Chamfer command is useful for: 

• Generating a beveled part 

 
 

How to Use 

How to apply chamfer to a body using the angle and distance 
conditions 
1. Go to Insert > Modeling Feature > Chamfer or click the icon in the toolbar. 

 
2. Choose the Angle And Distance method and set the Distance to 5 mm and the Angle 

to 45 degrees. 

 
 

3. Select edges to chamfer. A preview or the resulting chamfer will be shown. 

 
 

4. Click OK to complete the command. 

 
 
 

Options in Detail 

Methods 

Entities – Selects edges, faces or loops. 

 
Angle And Distance – Generates a beveled face by using Distance and Angle that are 
specified from edges. The Estimate Distance From Mesh button , automatically extracts 
an approximate value from a mesh but is only available if meshes already exist. 
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Distance And Distance – Generates a bevel face by using two Distances that are specified 
from edges. 

 
 

Common Options 

Flip Direction – Flips a chamfer direction. 

  

Before Flip Direction After Flip Direction 
 
Tangent Propagation – Extends a selection to tangentially connected adjacent edges. 

 
 

See Also 

Insert > Modeling Feature > Fillet 
 
 
 

Insert > Modeling Feature > Draft 
 

What 

The Draft command tapers faces on a solid or surface body using a specified angle. 
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Body Apply Draft 
 
 

Why 

The Draft command is useful for: 

• Tapering to ribs, bosses, walls, and other entities on a molded part 

• Generating a tapered feature 

 
 

How to Use 

How to apply a draft to a solid body 
1. Go to Insert > Modeling Feature > Draft or click the icon in the toolbar. 

 
 

2. Select a bottom face as the Neutral Plane. 

 
 

3. Select a side faces as the Draft Faces. 

 
 

4. Set the Angle to 2 degrees and click the Preview button. To change a draft direction, 
click the Flip button. When the result in the preview are satisfactory, click OK to 
complete the command. 
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Options in Detail 

Methods 

Neutral Plane Draft – Creates a draft to selected faces based on a neutral plane. 

 

 

 
Neutral Plane – Determines the pull direction of a model by using the normal of 
a selected entity’s such as a ref. plane, region or face. 

 
Draft Faces – Selects faces to be drafted. 

 
Parting Line Draft – Drafts surfaces around a parting line. The parting line can be non-
planar. 

 
 

 
Pull Direction – Determines the pull direction of a model by using a selected 
linear entity’s direction or planar entity’s normal. 

 
Parting Lines – Select edges on a body. 

 
Step Draft – Uses a variation of the parting line draft method to draft surfaces by 
creating one face rotated around the plane used as a direction of a Neutral Plane. The 
results are small faces, highlighted in red circle in the example below. 
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Neutral Plane – Determines the pull direction of a model by using the selected 
entity’s normal. 

 
Parting Lines – Selects edges on a body. 

 
Tapered Steps – Faces that have a normal that is not in the same direction as the 
pull direction of a model are generated in the same manner as tapered faces. 

 
Perpendicular Steps - Faces that have a normal that is not the same as the pull 
direction of a model are generated perpendicularly to an original main face. 

  

Tapered Steps – Highlighted faces 
are drafted 

Perpendicular Steps – Highlighted 
faces are not drafted 

 
 

Draft Parameters 

Angle – Specifies a draft angle. To change draft direction, click the Flip button .  
The Estimate Angle From Mesh button  automatically extracts an angle based on a 
mesh. 

 
 

See Also 

Insert > Solid > Extrude 
Insert > Surface > Extrude 
 
 
 

Insert > Modeling Feature > Emboss 
 

What 

The Emboss command wraps a 2D or 3D sketch onto a planar or a non-planar face and generates a 
convex or concave feature. 
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Body Apply Emboss 
 
 

Why 

The Emboss command is useful for: 

• Generating an extruded feature on a non-planar surface 

• Generating an engraved object 

• Marking a company name or a part name onto a feature 

 
 

How to Use 

How to apply an emboss to a body 
1. Go to Insert > Modeling Feature > Emboss or click the icon in the toolbar. 

 
 

2. Choose the Pad option and select curves as Profile and a solid body as Target. 

 
 

3. Set the Depth to 5 mm and click the Preview button. 
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4. Click Accept to complete the command. 

 
 
 

Options in Detail 

Methods 

Pad – Creates a convex feature. 
 
Pocket – Creates a concave feature. 

  

Pad Pocket 
 
 

Select Entities 

Profile – Selects 2D or 3D curves. Multiple loops can be selected simultaneously. 
 
Target - Selects a face on a solid or surface body. 
 

End Cap Surface 

Offset – Offsets the top face of an embossed feature from a target face. 

 
 

Depth – Specifies the height of an embossed feature. 
 
Translate – Translates the top face of an embossed feature as a selected direction from 
a target face. A linear entity or an entity which has a normal as Direction can be used. 
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Depth – Specifies the height of an embossed feature. 

 
Choose Other - Selects the top face of an embossed feature as an entity. A region, face, 
surface body or solid body can be selected as an End Cap. 

 
 

Side Wall 

Face Normal – Sets the side face of an embossed feature in the face normal direction. 

 
 
Profile Direction – Sets the side face of an embossed feature in the profile’s normal 
direction. 

 
 
Custom Vector – Sets the side face of an embossed feature in a selected direction. A 
linear entity or an entity that has the same normal as the Pull Direction can be selected. 

 
 
Draft – Specifies the draft angle of an embossed feature. The Draft option also for the 
Side Wall option. 

 

Side Wall: Face Normal 
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Side Wall: Project Direction 
 

 

Side Wall: Direction Vector 
 

 
 

See Also 

See Also 

Insert > Surface > Extrude 
 
 
 

Insert > Modeling Feature > Linear Pattern 
 

What 

The Linear Pattern command generates multiple features in a linear direction at one time. 

 

Body Direction and Instances Apply Linear Pattern 
 
 

Why 

The Linear Pattern command is useful for: 

• Generating patterned features along linear directions 
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How to Use 

How to pattern a body along two directions 
1. Prepare a body and two directional vectors. 

 
 

2. Go to Insert > Modeling Feature > Linear Pattern or click the icon in the toolbar. 
 

3. Select a body for Bodies and select a vector for Direction1. Set Instance to 3 and 
Distance to 25 mm. 

 
 

Note:  

The blue distance arrow can be manipulated. 

 

 
 

4. Select another vector as Direction2. Set Instance to 2 and Distance to 15 mm. 

 
 

5. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Bodies – Selects solid or surface bodies. 
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Direction 1 – Selects a linear entity such as an edge or vector, or an entity with a normal such 
as a plane or face, for a pattern direction. 
 

Set Instances 

No. Of Instances – Sets the total number of objects for Direction 1. 

 

No. Of Instances: 5 
 
Distance – Sets the spacing between pattern instances. The Reverse Direction button  
or the on-screen arrow will reverse the direction. 

 
 
Direction 2 – Creates a pattern in a second, opposite direction from Direction 1. 

 
 

Skip Instances 

Skip Instances – Removes pattern instances by clicking on them. To restore a removed 
instance click it again. 

   

 
 

See Also 

Insert > Modeling Feature > Circular Pattern 
Insert > Modeling Feature > Curve Pattern 
 
 
 

Insert > Modeling Feature > Circular Pattern 
 

What 

The Circular Pattern command generates multiple features around an axis at one time. 



Geomagic Design X | Menu  435 
 

 

Body Axis and Instances Apply Circular Pattern 
 
 

Why 

The Circular Pattern command is useful for: 

• Generating patterned features along an axis 

 
 

How to Use 

How to pattern a body along an axis 
1. Prepare a body and a vector for a rotational axis. 

 
 

2. Go to Insert > Modeling Feature > Circular Pattern or click the icon in the toolbar. 
 

3. Select a body for Bodies and a vector for Rotation Axis. Set No. of Instances to 6 and 
Total Angle to 360. Check Equal Spacing. 

 
 

4. Click OK to complete the command. 

 
 

 
 

Options in Detail 
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Select Entities 

Bodies – Selects solid or surface bodies. 
 
Rotation Axis – Selects a linear entity such as an edge or vector, or an entity that has an axis 
such as a cylinder, cone, or circular edge for a rotational axis. 
 

Set Instances 

No. Of Instances – Sets the total number of objects. 

 

 

No. Of Instances: 3 No. Of Instances: 5 
 
Interval Angle – Sets the angle between instances. To reverse the direction, click the Flip 
button or click the green arrow on the screen. 

 
 
Equal Spacing – Sets equal distances between instances within a total angle. 

 

 

Without Equal Spacing With Equal Spacing 
 
Rotate About Axis – Rotates instances around a rotation axis. 
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Without Equal Spacing Without Equal Spacing 
 
Skip Instances – Removes pattern instances by clicking on them. To restore a removed 
instance click it again. 

  
 

 
 

See Also 

Insert > Modeling Feature > Linear Pattern 
Insert > Modeling Feature > Curve Pattern 
 
 
 

Insert > Modeling Feature > Curve Pattern 
 

What 

The Curve Pattern command generates multiple features around a curve at one time. 

 

Body Curve and Instances Apply Curve Pattern 
 
 

Why 

The Curve Pattern command is useful for: 

• Generating patterned features along a curve 

 
 

How to Use 

How to pattern a body along a curve 
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1. Prepare a body and a curve. 

 
 

2. Go to Insert > Modeling Feature > Curve Pattern or click the icon in the toolbar. 
 

3. Select a body for Bodies and a curve for Path Curve. Set No. of Instances to 6 and check 
Equal Spacing. 

 
 

4. Click OK to complete the command. 

 
 
 

Options in Detail  

Select Entities 

Bodies – Select solid or surface bodies. 
 
Path Curve – Selects a curve or edge for the path curve. 
 

Set Instances 

No. Of Instances – Sets the total number of objects. 
 
Distance - Sets the spacing between pattern instances. The Reverse Direction button  or 
the on-screen arrow will reverse the direction. 
 
Equal Spacing – Sets equal distances between instances along a selected curve. 

  

Without Equal Spacing With Equal Spacing 
 

Options 

Align To Seed – Aligns each instance to match the original alignment of the seed feature. 
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Align To Seed Without Align To Seed 
 
Rotate Along Curve – Aligns the direction of instances to a selected face or mesh normal. Click 
the Normal Reference button and then select a face or a mesh. 

 
 
Transform Curve – Maintains the delta X and delta Y distances from the origin of the selected 
curve to the seed feature for each instance. This option is available with a 2D curve. 

 
 
Offset Curve – Maintains the normal distance from the origin of a selected curve to the seed 
feature for each instance. This option is available with a 2D curve. 

 
 

Skip Instances 

Skip Instance – Removes pattern instances by clicking on them. To restore a removed instance 
click it again. 

   

 
 

See Also 

Insert > Modeling Feature > Linear Pattern 
Insert > Modeling Feature > Circular Pattern 
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Insert > Modeling Feature > Mirror 
 

What 

The Mirror command generates copied features that are mirrored at a plane or a planar entity. 

 

Body Symmetry Plane Apply Mirror 
 
 

Why 

The Mirror command is useful for: 

• Generating a symmetrical feature 

• Copying a feature using a plane 

 
 

How to Use 

How to generate a symmetrical body 
1. Prepare a body and a ref. plane in the middle of a body. 

 
 

2. Go to Insert > Modeling Feature > Mirror or click the icon in the toolbar. 
 

3. Select a body for Bodies and a ref. plane for Symmetry Plane. 

 
 

4. Click OK to complete the command. 
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Options in Detail 

Select Entities 

Bodies – Selects solid or surface bodies. 
 
Symmetry Plane – Selects a ref. plane or a planar face as a mirroring plane. 
 

Options 

Trim And Merge – Removes overlapping areas and sews them together if a mirrored 
feature and original body are overlapping. Clicking the Tangent Continuous Face button 
and selecting faces will tangentially sew them. A trimmed area can be flipped by using the 
Reverse Clipping Direction button . 

  

Without Trim And Merge With Trim And Merge 
 
 

Advanced Continuity Options 

Shape Transition To Adjacent Faces – Centralizes the deformation of a face around an 
edge by moving the slider to Abrupt. 

 
(A) Before 

 

 
(B) The result of Abrupt 
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(C) The result of Gradual 
 
Boundary Accuracy – Determines accuracy when sewing edges. Moving the slider to 
Tight, will create more points on an edge and will attempt to tightly sew them. The Preview 
button shows the maximum deviation between edges. 

  

Loose Tight 
 
Unconstrained Edge – Determines the deformation method for non-sewing edges that are 
unconstrained. 

 
 

Do Not Preserve – Does not preserve unconstrained edges which may deform them. 
 

Preserve Isolated Edges Only – Preserves isolated edges that are not adjacent to 
sewing edges. 

 
 

Preserve All – All edges will not be deformed. 
 
 

See Also 

Tools > Sketch Tools > Mirror 
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Insert > Modeling Feature > Helix 
 

What 

A Helix is a three-dimensional curve that has a tangent line at any point that is at a constant angle 
with an axis. The Helix command easily generates a helical curve. 

 

Start Point and Axis Helical Curve 

 
 

Why 

The Helical command is useful for: 

• Sweeping or lofting a path 

• Generating screw shapes 

• Generate coil spring shapes 

 
 

How to Use 

How to generate a helical curve 
1. Prepare a point as a starting position and a vector as an axis. 

 
 

2. Go to Insert > Modeling Feature > Helix or click the icon in the toolbar. 
 

3. Choose the Constant method. Select a vector as an Axis. 
 

4.  Select a ref. point as the Start. 
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5. Click the end point on the graph in the Profile View and set the Height, Radius, Pitch 
and Revolution. The blue point can be dragged or specified by a numerical value in 
each field. 

 
 
Whenever a value changes the resulting curve will be displayed on the screen. 

 
 

6. Click OK to complete the command. 

 
 
 

Options in Detail 

Methods 

Constant – Creates a constant pitch throughout a helix. 

 
 
Variable – Creates a variable pitch based on specified parameters. 
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Select Entities 

Axis – Selects a linear entity for the axis of a helix. 
 
Start – Selects a point entity for the starting position of a helix. 

 
 
Plot Mesh Section As Guide – Uses a section profile to extract the design intent of helix 
parameters. Clicking the  button will display the section profile of a mesh in the Profile View. 
This option is available if a mesh exists already. 

 
(A) Mesh 

 

 

(B) Extracted Mesh Section 
 
 

Options 

Counter Clockwise – Sets a helical direction as counterclockwise. 
 
Clockwise – Sets a helical direction as clockwise. 
 
Extend To Opposite Direction – Extends a helix curve to the opposite direction by a specified 
number of revolutions. 

 

 

Revolution: 0.5 Revolution: 1 
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Controlling Profile View 

Used to define helix parameters in the Profile View. Clicking a node point will display editable 
parameters. 

 
 
- The horizontal axis represents Height and the vertical axis represents Radius. 
- The left blue point represents the starting position and the right blue point represents the 
ending position. 
- A node point can be dragged or directly specified on the widget by clicking it. 
- To remove an added node, move the node onto another point and overlap it or by pressing the 
Delete key. 
- The Variable option allows for the addition of more node points by clicking on the graph. 

 
(A) Variable Options Parameters 

 

 

(B) The Result of Helical Curve 
 
 

Viewing in Profile View 

Zoom – Use the mouse wheel. 
Pan – Use the left mouse button or the scroll bar in the Profile View window. 
Scale (Y Direction) – Use Shift + left mouse button or move the top or bottom edge of the scroll 
bar. 
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Note:  

The  button at the right top corner of the Profile View, displays additional functions. 

 
 

 
 

See Also 

Insert > Modeling Feature > Spiral 
 
 
 

Insert > Modeling Feature > Spiral 
 

What 

A Spiral is a two-dimensional curve which emanates from a central point, getting continuously 
farther away in a circular pattern. The Spiral command generates a spiral curve. 

 

Start Point and Axis Spiral Curve 

 
 

Why 

The Spiral command is useful for: 

• Sweeping or lofting a path 

 
 

How to Use 

How to generate a spiral curve 
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1. Prepare a point as a starting position and a vector as an axis. 

 
 

2. Go to Insert > Modeling Feature > Spiral or click on the icon in the toolbar. 
 

3. Select a vector for Axis. 
 

4.  Select a ref. point for Start. 

 
 

5. Click the end point on the graph in the Profile View and set the Height, Radius, Pitch 
and Revolution. The blue point can be dragged or specified by a numerical value in each 
field. 

 
 

6. Click OK to complete the command. 

 
 
 

Options in Detail 

Methods 

Constant – Creates a constant pitch throughout a spiral. 
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Variable – Creates a variable pitch based on specified parameters. 

 
 

Select Entities 

Axis – Selects a linear entity for the axis of a spiral. 
 
Start – Selects a point entity for the starting position of a spiral. 

 
 
Plot Mesh Section As Guide – Uses a section profile to extract the design indent of helix 
parameters. Clicking the  button will display the section profile of a mesh in the Profile 
View. This option is available if a mesh exists already. 

 
(a) Mesh 

 

 
(B) Extracted Mesh Section 

 
 

Options 

Counter Clockwise – Sets a spiral direction as counterclockwise. 
 
Clockwise – Sets a spiral direction as clockwise. 
 
Extend To Opposite Direction – Extends a spiral curve to the opposite direction by a 
specified number of revolutions. 
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Controlling Profile View 

Used to define spiral parameters in the Profile View. Clicking a node point will display 
editable parameters. 

 
 
- The horizontal axis represents the Radius. 
- A node point can be dragged or directly specified on the widget by clicking it. 
- The Variable option allows for the addition of more node points by clicking on the graph. 
- To remove an added node, move the node onto another point and overlap it or by pressing 
the Delete key. 
- Move the starting position by dragging the node. 
 

 
 

Viewing in Profile View 

Zoom – Use the mouse wheel. 
Pan – Use the left mouse button or the scroll bar in the Profile View window. 
Scale (Y Direction) – Use Shift + left mouse button or move the top or bottom edge of the 
scroll bar. 

 
 

Note:  

The  button at the right top corner of the Profile View, displays additional functions. 

 
 

 
 

See Also 

Tools > 3D Sketch Entities > Spline 
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Insert > Modeling Feature > Move Face 
 

What 

The Move Face command transforms a face and reconstructs the accompanying solid or surface 
body. 

 

Body Faces and Direction Moved Faces 
 
 

Why 

The Move Face command is useful for: 

• Moving and deforming a body 

 
 

How to Use 

How to transform a body face 
1. Prepare a body and vector as a direction. 

 
 

2. Go to Insert > Modeling Feature > Move Face or click the icon in the toolbar. 
 

3. Choose the Translate option and select a body face for Faces and a vector for 
Direction. Set the distance to 10 mm. 

 
 

4. Click OK to complete the command. 
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Options in Detail 

Methods 

Translate – Moves selected faces linearly. 

 
 
Rotate – Moves selected faces by rotating them. 

 
 

Select Entities 

Faces – Selects faces on a solid or surface body. 
 
Direction – Selects a linear entity or an entity with a normal to define a moving direction. 
Specify the Distance to define the amount of movement. 
 
Axis – Selects a linear entity or an entity with a normal to define a rotation axis. Specify the 
Angle to define the amount of revolution. 

 
 

See Also 

Insert > Modeling Feature > Delete Face 
Insert > Modeling Feature > Replace Face 
Insert > Modeling Feature > Split Face 
 
 
 

Insert > Modeling Feature > Delete Face 
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What 

The Delete Face command removes faces on a solid or surface body. 

 

Body Remove Face 
 
 

Why 

The Delete Face command is useful for: 

• Reconstructing features 

 
 

How to Use 

How to remove a body face 
1. Prepare a solid or surface body. 

 
 

2. Go to Insert > Modeling Feature > Delete Face or click the icon in the toolbar. 
 

3. Choose the Delete option and select a face to delete. 

 
 

4. Click OK to complete the command. 
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Options in Detail 

Methods 

Delete – Removes selected faces. 

   
 
Delete And Heal – Removes selected faces and automatically patches and trims the body. 

   
 
Delete And Fill – Removes selected faces and replaces them with a single face to close any 
gaps. 

   
 

Select Entities 

Faces – Selects faces on a solid or surface body to remove. 
 
 

See Also 

Insert > Modeling Feature > Move Face 
Insert > Modeling Feature > Replace Face 
Insert > Modeling Feature > Split Face 
 
 
 

Insert > Modeling Feature > Replace Face 
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What 

The Replace Face command removes a selected face, extends neighboring faces, and replaces the 
original face with a target face. 

 

Body Replaced Face 
 
 

Why 

The Replace Face command is useful for: 

• Reconstructing a body face 

• Extending a feature to a surface 

• Copying another face and applying it to a feature 

 
 

How to Use 

How to replace a body face 
1. Prepare a solid body and a surface body. 

 
 

2. Go to Insert > Modeling Feature > Replace Face or click the icon in the toolbar. 
 

3. Select a top face for Target Faces. Select a freeform surface for Tool Entity. 
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4. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Target Faces – Selects faces to replace. 
 
Tool Entity – Selects a region or surface body to replace a target face. 
 

Note:  

When a selected target face does not cover a tool face, the application will automatically extend the 
tool face tangent to a position that can touch the extruded target faces and replace the target faces. 

  
Selecting Target Faces and Tool 

Face 
Replacing Target Faces 

 
 

 
 

See Also 

Insert > Modeling Feature > Move Face 
Insert > Modeling Feature > Delete Face 
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Insert > Modeling Feature > Split Face 
 
 
 

Insert > Modeling Feature > Split Face 
 

What 

The Split Face command splits a target face by using the projection, silhouette and intersection 
methods. After splitting a face, a target entity will have several faces but will still be a single entity. 

 

Body and Curve Split Face 

 
 

Why 

The Split Face command is useful for: 

• Adding edge faces 

• Adding parting lines 

 
 

How to Use 

How to split a body face by using a curve 
1. Prepare a curve and a body. 

 
 

2. Go to Insert > Modeling Feature > Split Face or click the icon in the toolbar. 
 

3. Choose the Projection method. Select a curve for Tool Entities and a face for Target 
Entities. 
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4. Click Preview. If the face cannot be split then change the projection direction by using 
the Flip Direction button. 

 
 

5. Click OK to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Projection – Determines the projection method. When tool entities are 2D curves, a sketch 
normal will be used for a projection direction. If tool entities are 3D curves, a face normal will 
be used for a projection direction. 

  

Split with 2D Sketch Split with 3D sketch 
 

Single Direction – Projects a split line in one direction. To reverse the direction, click the 
Flip Direction button . 

 
Bidirection – Projects a split line in both directions. 

 
Silhouette – Creates a silhouette in a pull direction and splits target entities with the silhouette 
lines. 
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Pull Direction - Defines a silhouette direction. 
 

Target Entities – Selects faces on a solid or surface body. 

 

 

Pull Direction & Target Entities Split Result 
 

Draft Angle – Sets the angle between pull direction and tangential direction on a point 
of a face. 

   

Draft Angle: 0 Draft Angle: 30 Draft Angle: 60 
 
Intersection – Divides target entities by intersecting them with other faces. 

 

 

Pull Direction & Target Entities The Split Result 
 

 
 

See Also 

Insert > Modeling Feature > Move Face 
Insert > Modeling Feature > Delete Face 
Insert > Modeling Feature > Replace Face 
 
 
 

Insert > Modeling Feature > Transform Body 
 

What 
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The Transform Body command moves, rotates or scales a solid or surface body. It can also be used 
to align a body to another body or mesh by using datum pairs. 

 

Body Apply Transform 
 
 

Why 

The Transform Body command is useful for: 

• Copying and moving a body 

• Repositioning a body 

• Aligning a body to another body or a mesh 

 
 

How to Use 

How to move and rotate a body 
1. Prepare a solid or surface body. 

 
 

2. Go to Insert > Modeling Feature > Transform Body or click the icon in the toolbar. 
 

3. Select a body and check the Duplicate box to copy it. Click the Next Stage button. 
 

4. Select the Rotate And Translate method and input a Rotate and Translate value or 
drag the manipulator on the screen. 

 
 

5. Click OK to complete the command. 
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Note:  

After the transformation of a body, the transformation matrix can be exported. To export the 
transformation matrix follow the steps below: 

1. Select a Transform feature in the Feature tree. 

 

2. See the Properties panel. 

 

3. Click the  button. 

4. Use the Export button and save the matrix. The file will be saved as Transform Matrix File 
(.trm). 

 
 

 
 

Options in Detail 

Select Entities 

Bodies – Selects solid or surface bodies. 
 

Duplicate – Copies selected bodies. 
 

Methods 

Rotate And Translate – Applies rotation and translation to a body in the X, Y and Z direction and 
axis. You can interactively use the manipulator on the screen or input specific values. 
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Scale - Scales a solid or surface body along its center, a coordinate system, or a custom position. 
 

Uniform Scale – Scales a body based on the X, Y and Z directions concurrently. If this 
option is not used, scale can be applied individually in the X, Y and Z directions. 

 

 

Uniform Scale: X, Y, & Z=3 Non-uniform Scale: X=2, Y=3, Z=3 
 

Unit Converter – Converts scale values by using unit conversion. Changing unit types in 
From and To, will automatically apply the changes to the scale value. Changing the scale 
value directly will set the Unit Converter as default. 

 
Scale Center – Selects a position of a scale origin. Global Origin, or the global coordinate, 
Body Center, or the center of a body, and Custom, or the custom origin, can be chosen. 

 

                   

 
 

By Matrix – Allows for the direct input of values into a transformation matrix. After using the 
Rotation And Translate and Scale options the transformation matrix will be calculated and 
filled. If a value in the matrix is modified, the corresponding Rotate, Translate, Scale values will 
reflect those changes. 

 
A transformation matrix file can be imported by using the Matrix File Open button . 
If Set is selected the imported matrix is applied as it is. 
If Multiply is selected the imported matrix will be multiplied from the current position. 
If Inverse Multiply is selected the imported matrix will be inversed and multiplied from the 
current position. 



Geomagic Design X | Menu  463 
 

If Transpose is select the imported matrix will be transposed from the current position. 
 
Datum Alignment – Aligns a body to another body or a mesh by using datum pairs. Select a 
face that can be a datum such as a cylinder, sphere, plane, or edge on the original body and then 
select a pair of datum on another body. 

 
 

Datum Pairs – Type(Moving – Target, Flip) – Defines datum pairs in Moving and Target 
order. 
 

Note:  

A moving datum can be flipped by using the Flip button  when datum pairs are defined. 

 
Align To Scan – Aligns a body to a desired location in a scan data. 
 

By Auto Guess – Aligns a body to a desired location in a scan data by automatically 
recognizing the geometry features of target scan entities. 

 
 
By Picked Pair Points – Aligns a body to a desired location in scan data by manually 
picking points on corresponding features. 

 
 
Sampling Ratio – Samples data points in a target scan by a specified value. When the ratio 
is 100%, all selected data will be used. When the ratio is 50%, half of the selected data will 
be used. 
 
Global Coordinate – Sets constraints by using the global coordinate system 
 

Lock Translation – Locks the translation of a transform in each coordinate axis. 
 
Lock Rotation – Locks the rotation of a transform in each coordinate axis. 
 

User Defined Coordinate – Sets constraints by using a user-defined coordinate system. 
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Lock Translation – Refer to the Global Coordinate option. 
 
Lock Rotation – Refer to the Global Coordinate option. 

 

See Also 

Insert > Modeling Feature > Duplicate Body 
Insert > Modeling Feature > Remove Body 
 
 
 

Insert > Modeling Feature > Duplicate Body 
 

What 

The Duplicate command copies a solid or a surface body. 

 

Body Apply Duplication 
 
 

Why 

The Transform Body command is useful for: 

• Copying a body 

 
 

How to Use 

How to copy a body 
1. Prepare a body. 

 
 

2. Go to Insert > Modeling Feature > Duplicate Body or click the icon in the toolbar. 
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3. Select a body to duplicate. 

 
 

4. Click OK to complete the command. A new entity named Duplicated Body 1 will be 
created in the Feature Tree. 

 
 
 

Options in Detail 

Bodies – Selects bodies to copy 
 
 

See Also 

Insert > Modeling Feature > Transform Body 
Insert > Modeling Feature > Remove Body 
 
 
 

Insert > Modeling Feature > Remove Body 
 

What 

The Remove Body command deletes a solid or a surface body. 

 

Body Apply Remove 
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Why 

The Remove Body command is useful for: 

• Deleting a body 

 
 

How to Use 

How to delete a body 
1. Prepare a body. 

 
 

2. Go to Insert > Modeling Feature > Remove Body or click the icon in the toolbar. 
 

3. Select a body to remove. 

 
 

4. Click OK to complete the command. The selected body will be removed and the new 
entity named Remove Body 1 will be created in the Feature Tree. 

 
 
 

Options in Detail 

Bodies – Selects bodies to remove. 
 
 

See Also 

Insert > Modeling Feature > Transform Body 
Insert > Modeling Feature > Duplicate Body 
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7.4.10. Insert > CAD Correct 
 
The CAD Correct menu features various commands used to enables the editing and reforming of 
the geometries on a generated body or imported body based on deformed scan data. During the 
manufacturing process, a manufactured object can be different from its original CAD data because 
of design optimization after CAD modeling. 
 
 
 

Insert > CAD Correct > Refit 
 

What 

The Refit command applies a fitting algorithm to body faces to match them with a deformed mesh. 
To apply this command a body and mesh must be aligned. 

 

Refit Face 
 
 

Why 

The Remove Body command is useful for: 

• Correcting original CAD data with a final product 

 
 

How to Use 

How to refit a body to a design-changed mesh 
1. Prepare a mesh and a body. They should be aligned by using the Tools > Align > Quick 

/ Best Fit / Datum commands. 

 
 

2. Go to Insert > CAD Correct > Refit or click the icon in the toolbar. 
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3. Select a mesh for a reference Mesh and select faces on a body for Faces which will be 

target faces. 
 

 
 

 
 

4. Click OK to complete the command. 

  

Before Refit After Refit 
 

 
 

Options in Detail 

Select Entities 

Mesh – Selects a reference mesh. 
 
Faces – Selects faces on a solid or a surface body. 
 
Group Faces By Stiffness – Individually sets the weight factor for fitting to each face. The 
Loosely Fit Faces, Tightly Fit Faces and Free Faces buttons can be used to define the tightness 
for faces. 
 

Loosely Fit Faces – Selects faces that will be loosely fit to a mesh. Faces around target 
faces for refitting can be chosen and looseness can be controlled by using the slider. 

 
Tightly Fit Faces - Select faces that will be tightly fit to a mesh. Faces for refitting can be 
chosen and the tightness can be controlled by using the slider. 

 
The sliders in the Loosely Fit Faces and Tightly Fit Faces options interact together. If one 
of the slider is moved, the other slider will change automatically. 

 
The following images illustrate influence of combinations of weight values. Moving the 
slider that is next to Tightly Fit Faces to Tight, and the slider that is next to Loosely Fit 
Faces to Loose will increase the deviation of loose faces correlatively when deviation 
decreases between tight faces and a reference mesh. 
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(A) Before Refitting 
 

 

Red - Tightly Fit Faces, Blue - Loosely Fit Faces 
(B) Minimum Weight of Tight Faces 

 

 

(C) Middle Weight of Tight Faces 
 

 

(D) Maximum Weight of Tight Faces 
 

Free Faces – Selects faces that are not constrained by a reference mesh. The resulting 
shape of the free faces will be influenced by deformation from loose and tight faces only. 

 

(A) Before refit 
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(B) Result from tight face (blue) 
 

 

(C) Result from free face (green) 
 
 

Fitting Options 

Type Of Control Vertices – Selects the type of control vertices. 
The Global option will create an overall shape from a resulting body that will be better in 
smoothness. 
The Local option will create a resulting shape that will be more influenced by the local features 
on a reference mesh. 

 
(A) Before refit 

 

 

(B) After refitting with the Global option 

 

 

(C) After refitting with the Local option 
 
Geometry Capture Accuracy – Defines geometry capture accuracy. When the slider is moved 
towards Loose, less poly-faces will be used to create a shape. When the slider is moved towards 
Tight, more poly-faces will be used to create a shape. 
 
Smoothness – Determines the smoothness level of a fitting surface. 

  

Smoothness: Less Smoothness: More 
 



Geomagic Design X | Menu  471 
 

 

More Options 

Compensation Factor – Controls the amount of deformation scaling by a specified value. A 
fitting face will offset from a mesh as a scale value. The default value is 1.0 and if the value is 
negative, the deforming direction will be flipped. Positive or negative values can be toggled by 
using the Sign button. 

 
 
Shape Transition To Adjacent Faces – Centralizes a modification around edges by moving the 
slider towards Abrupt. 

 

(A) Before Refitting 
 

 
(B) Result of Abrupt 

 

 

(C) Result of Gradual 
 
Preserve Boundary Edge – Prevents boundary edge faces from being deformed. 

 
 

See Also 

Tools > Mesh Tools > Refit 
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7.4.11. Insert > Mesh Sketch 
 

 
 
The Mesh Sketch mode extracts sectional polylines or silhouette polylines based on a mesh or a 
point cloud as well as the creation of 2D geometries such as lines, circles, arcs, rectangles based on 
extracted polylines. Constraints on sketch entities can be applied to generate a fully parametric 
model. The Mesh Sketch mode extracts correct and accurate design intent from scan data. 

 

 

Mesh Sketch to Mesh Mesh Sketch to Point Cloud 
 

Note:  

The color and point size of section points that are extracted from point clouds in the Mesh Sketch mode 
can be set by going to File > Preferences. Go to Section Points under Colors under Sketch in the Display 
tab or Section Point Size under Size (pixel) under Sketch in the Display tab. 

  

Red, Size 3 Green, Size 6 
 

 
Entering the Mesh Sketch mode will display tool palettes that apply functions globally. The values 
in the tool palette will be preserved if the mode is exited and entered again. 
 

Segment Section Polyline 

Section polylines are a group of small lines extracted from a section of scan data. The extracted 
polylines can be classified as lines or arcs. 

 
 
Resolution – Determines the resolution of polylines. Moving the slider to the left will create 
fewer segments, and lines and arcs will have a loose tolerance. Moving the slider to the right 
will create more segments, and lines and arcs will have a tight tolerance. Moving the slider will 
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display classified lines and arcs in real-time. 

   

Low Resolution High Resolution 
 
 

Entity Fitting 

During the creation of 2D geometries by fitting polylines, polylines can be filtered. Set a value 
and click the OK button, and the application will apply the condition to all of the entities in the 
Mesh Sketch mode. 

 
 
Sampling – Executes a fitting by using sampled points according to a specified value. When 
section polylines are messy and large they can be sampled to accelerate calculation speeds. 
 
Remove – Remove noise on section polylines. 
The N*Sigma option requires an N value and will execute a fitting by excluding fitting data 
that has an error value larger than N times of the standard deviation.  
The Ratio option requires a ratio value and will execute a fitting by sorting fitting data only 
with the data that falls into the ratio. 
The Absolute Distance option requires an error distance value and executes a fitting by 
excluding fitting data outside of this distance. 
 

Disjoined Points Constraint 

Automatically connects disjoined sketch entities such as lines and arcs globally, or only 
selected entities. 

 
 
Angle – Connects curves and arcs with a tangent constraint that have a tangent angle between 
an arc and an arc, or an arc and a line that is less than a specified value. 

 

 

Before Applying After Applying 
 
Max. Dist. – Connects curves and arcs with a maximum distance less than a given distance 
value. 

 

 

Before Applying After Applying 
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Intersection – Connects curves and removes the lesser distance after an intersection. 

  

Before Applying After Applying 
 

 
 

How to Use 

A. How to get sectional polylines by offsetting a plane 
1. Prepare a mesh and a ref. plane. 

 
 

2. Click the Mesh Sketch mode icon in the toolbar, or go to Insert > Mesh Sketch. 
 

3. Select a ref. plane for a base plane. 

 
 

4. Drag the blue arrow to offset the plane and make an intersection with the mesh. The 
offset value can also be input next to the Offset Distance From Base Plane option. 

 
 

5. Click OK to complete the command. Hide the mesh to clearly see the section polylines. 
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B. How to get silhouette polylines from a mesh 
1. Prepare a mesh and a ref. plane. 

 
 

2. Click the Mesh Sketch mode icon on the toolbar, or go to Insert > Mesh Sketch. 
 

3. Select a ref. plane for a base plane. 

 
 

4. Change the Silhouette Range value to cover the whole mesh. 

 
 

Note:  

The silhouette range can be changed by dragging the blue arrow on the screen. 
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5. Click OK to complete the command. 

  
 
 

Options in Detail 

Methods 

Planar Method – Extracts section polylines at an intersection with a plane defined by the offset 
method. The intersecting position of a base plane can be selected by dragging the long blue 
arrow manipulator in the Model View or by directly inputting the offset value in the Offset 
Distance From Base Plane option. A planar entity can be selected for a Base Plane. 

 
 
Rotational Method – Extracts section polylines at an intersection with a plane defined by the 
rotation method. The position of a base plane can be determined by rotating the plane along 
an axis. Select a planar entity for a Base Plane and a linear entity for a Central Axis. 
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Add Section Polyline 

Section Polyline – Creates multiple section polylines by repositioning a base plane and 
clicking the Add button or removes a section polyline by selecting the section polyline in the 
list box and clicking the Delete Section button. To remove all section polylines, click the Reset 
button. 
 
Offset Distance From Base Plane – Offsets from a base plane by inputting a distance from the 
base plane or by dragging the blue arrow in the Model View. 
 
Silhouette Range – Extracts a silhouette from a mesh or point cloud as polylines by manually 
inputting a value or dragging the small blue arrow in the Model View. The value is the thickness 
used to find a silhouette range and can be resized and rotated by dragging the red, green and 
blue control points on the plane. 

 

 

Planar Method Rotational Method 
 
 

Options 

Draft Angle - Sets a draft angle when extracting a section polyline from a drafted mesh feature. 
If a draft angle is set, an un-drafted section polyline from the offset distance from the base 
plane can be extracted. 

 

Without Draft Angle 
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With Draft Angle 
 
Exclude Round Corner - Remove round polylines less than a specified value. This option can 
be used to create a sketch without filleting. 

 

Disable Option 
 

 

Enable Option 
 
Limit To Regions – Selects regions to extract section polylines from. This option is only 
available if a mesh has regions. 

 

 

Without Region Limitation With Region Limitation (front & back regions) 

 

Avg. Section – Averages sections to make a master section polyline. 

  
 

Note:  

This option will be automatically enabled when entering Mesh Sketch Setup command through the 
Insert Sketch command. For more information, see User Interface > Quick Modeling. 
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See Also 

Insert > Sketch 
 
 
 

7.4.12. Insert > Sketch 

 
 
The Sketch mode creates 2D geometries such as lines, arcs, and splines, and can edit created 2D 
geometries. 
 
Entering the Sketch mode will display a tool palette that globally applies functions to all entities or 
selected entities. The values in the tool palette will be preserved if the mode is exited and entered 
again. 
 

Disjoined Points Constraint 

Automatically connects disjoined sketch entities such as lines and arcs globally or only on 
selected entities. 

 
 
Angle – Connects curves and arcs with a tangent constraint that have a tangent angle 
between an arc and an arc, or an arc and a line that is less than a specified value. 

 

 

Before Applying After Applying 
 
Max. Dist. – Connects curves and arcs with a maximum distance less than a given distance 
value. 

 

 

Before Applying After Applying 
 
Intersection – Connects curves and removes the lesser distance after an intersection. 

  

Before Applying After Applying 
 
 

Rebuild Splines 
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Reorganizes a spline curve by changing the number of node points. 

 
 
No. of Interp. Pts – Sets the total number of interpolation points by selecting splines, 
specifying a total number of nodes, and clicking the OK button. 

 

 

Interpolation Points: 4 Interpolation Points: 8 
 
Evenly Spaced Points – Spaces dense interpolation points evenly. 

 

 

Before Evenly Spaced Points After Evenly Spaced Points 
 

 
 

How to Use 

How to create a sketch without a mesh 
1. Click the Sketch Mode button on the toolbar, or go to Insert > Sketch. 

 
2. A dialog tree will be displayed to define a sketch plane. 

 
 

3. Select a planar entity such as a ref. plane or a face on a solid or surface body. 

 
 

4. In the Sketch mode, create lines, arcs and splines. 

 
 

5. Edit the sketch by using the Trim and Fillet commands. 
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6. Click the Apply button at right bottom corner or click the Sketch mode button again to 
apply all changes and exit the Sketch mode. 
 
A solid or surface body can be generated from a sketch by using the Extrude, Revolve, 
Loft, and Sweep commands. 

 
 

See Also 

Insert > Mesh Sketch 
 
 
 

7.4.13. Insert > 3D Mesh Sketch 

 
 
The 3D Mesh Sketch creates splines on a mesh using various commands. Created splines can be 
edited with tools such as the Trim, Offset, and Project commands. 
 
Entering the 3D Mesh Sketch mode will display a tool palette that globally applies functions to 
entities in the mode. The values in the tool palette will be preserved if the mode is exited and entered 
again. 
 

Note:  

The difference between 3D Mesh Sketch and 3D Sketch modes is that curves generated in 3D Mesh 
Sketch mode always lay on a mesh but curves in 3D Sketch freely exist in space. 

 

Join 

Automatically joins disconnected splines and create intersection points. Set a value and click the 
OK button and the application will apply the value to all splines or selected splines. 

 
 
Curve Ends – Joins curve ends that have a distance smaller than a given value. 
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Before Applying After Applying 
 
Intersection – Creates intersection points between splines. 

  

Before Applying After Applying 
 
 

Rebuild 

Regenerates splines by controlling node points and deviations between splines and a mesh. This 
tool palette is available after selecting splines. 

 
 
No. Of Interpolation Pts. – Sets the total number of interpolation points by selecting splines, 
specifying a total number of nodes, and clicking the OK button. To reduce the deviation between 
spline and mesh data, increase the number of node points. 

  

Number: 4 Number: 7 
 
Allowable Deviation – Regenerates curves by a specified deviation. Node points will be 
regenerated and rearranged automatically to satisfy the deviation. 
 

Deform Smoothness 

Defines the smoothness and viewing direction when creating a spline. 

 
 
Deform Smoothness – Determines the smoothness strength when editing splines. 

 

 

 

Original Curve Smoothness: Min Smoothness: Max 
 
Dynamic View Change – Automatically centralizes the view whenever a point is picked on a 
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mesh. This option is available after generating a spline. 

 
 

See Also 

Insert > 3D Sketch 
 
 
 

7.4.14. Insert > 3D Sketch 

 
 
The 3D Sketch mode creates 3D geometries such as splines, sections and boundaries on a mesh. 
Created curves can be edited by using the Trim, Offset, and Project commands. 
 
Entering the 3D Sketch mode will display a tool palette that globally applies functions to all entities 
in the mode. The values in the tool palette will be preserved if the mode is exited and entered again. 
 

Note:  

The difference between 3D Mesh Sketch and 3D Sketch modes is that curves generated in 3D Mesh 
Sketch mode always lay on a mesh but curves in 3D Sketch freely exist in space. 

 

Join 

Automatically joins disconnected splines and create intersection points. Set a value and click the 
OK button and the application will apply the value to all splines or selected splines. 

 
 
Curve Ends – Joins curve ends that have a distance smaller than a given value. 

  

Before Applying After Applying 
 
Intersection – Creates intersection points between splines. 

  

Before Applying After Applying 
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Rebuild 

Regenerates splines by controlling node points and deviations between splines and a mesh. This 
tool palette is available after selecting splines. 

 
 
No. Of Interpolation Pts. – Sets the total number of interpolation points. Select splines and 
specify the total number of nodes and click the OK button. 

  

Number: 4 Number: 7 
 
 

Deform Smoothness 

 
 
Deform Smoothness – Determines the smoothness strength when editing splines. 

 

 

 

Original Curve Smoothness: Min Smoothness: Max 
 
 

 
 

See Also 

Insert > 3D Mesh Sketch 
 
 
 

7.4.15. Insert > Scanner Direct Control  
 
The Scanner Direct Control menu enables the use of various scanning devices directly within the 
application. 
A preferred scanner device can be set in the Initial Setup Dialog that will be displayed when the 
application is initially started or in the Device list in the Hardware table at File > Preferences. 
 
 
 



Geomagic Design X | Menu  485 
 

Insert > Scanner Direct Control > LiveScan(TM) 
 

What can LiveScan™ do? 

LiveScan™ is designed to support the collection of scan data or probing data using various devices 
to use with the Geomagic Design X application. The following are supported in LiveScan™. 
 
Calibration (Optional as device) 
- Hardware calibration can be performed. 
- The bundle software from a device must be installed. 
 
Laser and Probe Setting (Optional as device) 
- Laser and probe parameters can be set. 
- The bundle software from a device must be installed. 
 
Move Device 
- Maintains a coordinate system after moving a device. 
 
Align 
- Aligns scanning or probing coordinate to CAD’s coordinate. 
 
Scanning 
- Acquires scanning data. 
 
Probing 
- Acquires probing data. 
 
Generate Entity 
- Instantly generates from acquired scanning or probing data. 
- Ref. Geometry (Point, Vector, Plane, Polyline) 
- Point Cloud  
- Mesh 
- Surface Body 
- Solid Body 
- 2D Sketch  
- 3D Sketch 
 
 

Supported Devices in LiveScan™ 

The following table shows supported devices in the 32-bit and 64-bit versions of the application. 
Manufacturer Measurement Device 32bit 64bit Web Site 

Creaform HandyPROBE ✔ ✔ www.creaform3d.com 
FARO FaroArm/ScanArm ✔ ✔ www.faro.com 
Kreon* Zephyr/Aquilion/Solano ✔ ✔ www.kreon3d.com 
LDI SLP Series ✔ ✔ www.laserdesign.com 
Leica T-Scan TS50 ✔ ✔ metrology.leica-geosystems.com 
NDI ScanTRAK ✔ ✔ www.ndigital.com 
Nikon Metrology** Handheld ✔ ✔ www.nikonmetrology.com 
Perceptron ScanWorks ✔ ✔ www.perceptron.com 

Romer 
Absolute ✔ ✔ 

www.romer.com Infinite/Stinger ✔ ✔ 
Sigma/Omega ✔  

http://www.creaform3d.com/en/default.aspx
http://www.faro.com/
http://www.kreon3d.com/
http://www.laserdesign.com/
http://metrology.leica-geosystems.com/
http://www.ndigital.com/
http://www.nikonmetrology.com/
http://www.perceptron.com/
http://www.romer.com/
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Steinbichler T-Scan 3/CS ✔ ✔ www.steinbichler.de 

 
* Kreon users should install "Rapidform plug-in installer" which is distributed by Kreon. 
** The hardware that is supported by the Handheld API is the following: 
 - Optical CMM (K-Series system) with the laser scanners: MMD, MMC, MMDx 
 - MCA II 7-axis articulated arm with the scanners: MMD, MMC, MMDx 
 - MCA II 6-axis acrticulated arm without scanner 
 - MCA 7-axis articulated arm with the laser scanners: MMD, MMC, MMDx, LC60D 
 - MCA 6-axis articulated arm with the scanners: MMD, MMC 
 - Romer Cimcore Infinite 1.0 7-axis articulated arm with the laser scanners: MMD, MMC, MMDx 
 - Romer Cimcore Infinite 2.0 7-axis articulated arm with the laser scanners: MMD, MMC, MMDx 
 - Romer Cimcore Infinite 1.0 6-axis articulated arm with the laser scanners: MMD, MMC 
 - Romer Cimcore Infinite 2.0 6-axis articulated arm without laser scanner 
 - Faro Fusion, Titanium, Platinum 7-axis articulated arm with the laser scanners: MMD, MMC, 
MMDx 
 - Faro Fusion, Titanium, Platinum 6-axis articulated arm with the laser scanners: MMD, MMC 
 
 

How can LiveScan™ control a scanner? 

Geomagic Design X’s LiveScan™ technology contains three function controls. The functions of the 
buttons will vary between different type and manufacturers of scanners. 

Button on 
LiveScan™ 

Function 

A 
Scan - Resumes scanning and pauses scanning. 
Probe – Picks a point. 

B Scan - Stops scanning. 
Probe - Creates a scan entity. 

C 
Scan - Not Available 
Probe – Cancels the scanning. 

 
To perform the A, B and C functions of LiveScan™ as described above, use the buttons on each 
scanner device specified in the following table. 

Manufacturer Measurement Device Button 

Creaform Handy PROBE 

There are Three buttons on the hardware. 

Probing 

Function A: Click the middle button. 
Function B: Click the buttons on the left side. 

Function C: Press the buttons on the right side. 

 

FARO 
FaroArm 

ScanArm 

Scanning 
Function A: Click the green button. 
Function B: Click the red button. 

Probing 
Function A: Click the green button. 

Function B: Click the red button. 

Function C: Press the red button for a few seconds. 

 

Kreon 

Zephyr 

Aquilion 
Solano 

The function control varies according to the arm type. For a 

Cimcore arm, the function control is same with that of a 
Perceptron arm. 

http://www.steinbichler.de/en/
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Scanning 
Function A: Click the middle button. 

Function B: Click the buttons on both sides. 

Probing 
Function A: Click the middle button. 

Function B: Click the buttons on sides. 
Function C: Press the buttons on the sides for a few seconds. 

LDI SLP Series 

The function control varies according to the arm type. For a 

FARO arm, the function control is as follows: 

Scanning 

Function A: Click the green button. 
Function B: Click the red button. 

Probing 
Function A: Click the green button. 

Function B: Click the red button. 

Function C: Press the red button for a few seconds. 

Nikon Metrology Handheld  

Scanning 

Function A: Click the middle button. 
Function B: Click the buttons on both sides. 

Probing 
Function A: Click one of the four buttons on the inside. 

Function B: Click the button on the outside. 
 

 

 
 

Perceptron ScanWorks 

For a Cimcore arm, the function control is as follows: 

Scanning 
Function A: Click the middle button 

Function B: Click the buttons on both sides. 

Probing 
Function A: Click the middle button. 

Function B: Click the buttons on both sides. 
Function C: Press the buttons on both sides for a few 
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seconds. 

Romer 

Absolute There are three buttons on the hardware. 

Probing  
Function A: Click the middle button. 

Function B: Click the buttons on both sides. 
Function C: Press the buttons on both sides for a few 

seconds. 

Infinite/Stinger 

Sigma/Omega 

Steinbichler T-Scan 3/CS 

Scanning 
Function A: Hold the button to resume and release the 

button to pause. 

Probing 
Function A: Click the button on the application screen. 

Function B: Click the button on the application screen. 

 
 

LiveScan™ workflow 

Before starting LiveScan™, a hardware device must be installed with its drivers or software and be 
ready to communicate with the PC. 

Select a device supported in 
the application. 

 

Connects the device. (If 
connected, this button changes to 
“Disconnect”) 

  (Optional procedure as a 
device) Hardware parameters 
settings for Calibration, Laser 
Setting, Probe Selection.  

(Optional procedure) Software 
parameters settings for scanning 
and probing.  

 Choose “Align” or “Scan” stage. 

  Start scanning or probing. (If 
started, this button changes to 
“Stop”) 

 
 

How to Use 

A. Aligning the scan coordinate to CAD data using Best-Fit method. 
1. Import CAD data. 

 
2. Go to Insert > Scanner Direct Control > LiveScan(TM) or click the icon in the toolbar. 

 
3. Choose a device. 
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4. 
Click the Connect button . 
 

5. Set the alignment method to Best-Fit in the LiveScan™ dialog tree. 
 

6. Click the Target Body button and choose a CAD data. 
 

7. Click the Start button  to start scanning. 
 

8. Scan a real part by pushing the “A” button on the device. It must cover the entire area. 
  

9. After scanning, push the “B” button. The Best-Fit alignment calculation will be 
performed. 
 

10. To acquire additional scan data or probe data, move to the Next Stage . 
 

 
 

B. Aligning the scan coordinate to CAD data using Datum method. 
1. Import CAD data. 

 
2. Go to Insert > Scanner Direct Control > LiveScan(TM) or click the icon in the toolbar. 

 
3. Choose a device. 

 
 

4. 
Click the Connect button . 
 

5. Set the alignment method to Datum in the LiveScan™ dialog tree. 
 

6. Select datums on the CAD data such as plane, cylinder, cone and sphere. Selected 
datum types will be listed. The device type (probe or scanner) and a method for each 
datum can be configured. 

 
 

7. Click the Start button  to start scanning. 
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9. Probe a real feature by pushing the “A” button on the device. 

 
10. After acquiring probing points for a datum, push the “B” button. 

 
11. Complete the remaining datums. 

 
12. After completing the last datum the Datum alignment calculation will be performed. 

 
13 To acquire additional scan data or probe data, move to the Next Stage . 

 
 

C. Scanning a real part. 
1. Import CAD data. 

 
2. Go to Insert > Scanner Direct Control > LiveScan(TM) or click the icon in the toolbar. 

 
3. Choose a device. 

 
 

4. 
Click the Connect button . 
 

5. Move to the Next Stage  in the LiveScan™ dialog tree. 
6. Choose a device type from a Laser Scanner or Touch Probe. 

 
7. Choose a Feature Type which will be generated in the application from acquired scan 

or probe data. 
 

8. Click the Start button  to start scanning or probing. 
 

9. Click OK to complete the LiveScan™ command. 
 
 

Options in Detail of Device Manager 
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1. Device Manager 

 

 

When the Auto Connect option 
is enabled, the last connected 
device will be remembered and 
will connect automatically when 
starting LiveScan™. 
When the Hold Connection 
option is used, the application 
will not disconnect a device even 
if the LiveScan™ command is 
closed. 
 

  

Used for a scanning 
device calibration. 

 

Connects a selected device. 

  

Used for a scanning 
device settings. 

 

Used to reposition a device to 
scan or probe a part. 

  

Used for the probe 
settings of a device. 
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Move Device 
Used to when scanning a large object that requires multiple scans due to the single scan size 
limitations of a scanning device. 

 
 
How to use the Move Device command 
If Device Type is a Scanner: 
1. Click Next Step (2nd process) and then scan the part. 
2. Click Next Step (3rd process) and then move the device. 
3. Click Next Step (4th process) and then re-scan the area from the 2nd step. 
4. Click Next Step (5th process) and the application calculates the moved position of the device. 
 
If Device Type is a Probe: 
1. Click Add and create 3 or more Ref. Points (The creation method can be defined in Method) 
2. Click Next Step (2nd process) and then prove the part regarding to the Ref. Points. 
3. Click Next Step (3rd process) and then move the device. 
4. Click Next Step (4th process) and then re-prove the part from 2nd step. 
5. Click Next Step (5th process) and then the application calculates the moved position of the 
device. 
 

 
 

Options in Detail of Scanner Options Dialog 

The General tab lists general settings when scanning.  
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Display 

 

Zoom Fit – Displays an entire model during scanning. The view will be refreshed 
when the scan line is out of the screen. 

 

Dynamic Panning – Aligns a view by following a device’s front direction. 
 

Note:  

The view will be fixed if both Zoom Fit and Dynamic Panning are not selected. 

 

 

View Direction 

Fixed Top View – Fixes the top view direction by using hardware information. The Set button 
defines the Top view direction. 
 

Smart View – Intelligently recognizes a scanning direction within a system-defined view 
range and dynamically adapts the view direction to a proper viewpoint. 

 
Free View – The view direction will be automatically set according to a scanning direction. 
 

Auto Restart 

Auto Restart – Performs post processing and readys to scan without pressing the A button 
after stopping a scan by pressing the B button. 
 

Auto Save 

Auto Save - Automatically saves raw scan data in a specified location. The folder is 
automatically named by date and saved in the .lsf format.  
For example: xxx/20070704/ScanRawData1_1627_1.lsf 
 

Sound and Button 

Enable Sound While Scanning – Enables sound while scanning. 
 
Hotkey for A/B Buttons – Defines keyboard hotkeys for the A and B button. Click a box and 
enter a desired key. 
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The Data Process tab lists detailed settings when acquiring scan data. 

  
 

Filter Scan Data 

Filter Noise – Reduces the noise introduced during scanning. 
 

Smoothness of Scan Data 

Smooth – After post processing from acquired scan data, smoothing is applied. 
 

Scan Data Post Processing 

Use Original Data – For post processing of scan data, uses original scan data from scan device. 
 

Sample - Skips several points when scanning data large data that it is beyond memory 
limits. 

 
Distance – Specifies a length that the software uses to find points. 

 
Ratio - Specifies the sampling ratio to load points. 

 
Make Grid – Generates a grid type uniform scan data. 
 

Grid Size – Defines a grid resolution. High resolution of a grid will make a dense scan 
data. 
 
Max. Edge Length Of Original Data – limits the maximum length of the polygonal 
edges of the original data. 

 
Triangulate – Creates a mesh from the scan data. 

 

Setting 

 
Load - Imports saved settings for the Data Process tab. 

 
Save - Saves settings in the Data Process tab as an .ini file. 

 
Default – Resets all settings as default values. 

 
 

Options in Detail of Probe Options Dialog 
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View Direction 

Fixed Top View – Fixes the top view direction by using hardware information. The Set button 
defines the Top view direction. 
 

Smart View – Intelligently recognizes a probing direction within a system-defined view 
range and dynamically adapts the view direction to a proper viewpoint. 

 
Free View – Freely sets the view direction according to a probing direction. 
 

Auto Probe 

Auto Probe – Acquires a probe position automatically without using the A button when the 
probe tip is held still near a target position. Pressing the A button changes the acquisition 
status to Pause and Resume. In the Pause state, no probe position is acquired, even if the 
probe is held at a position. In the Resume state, the auto probing scheme will be used. The 
current status at the top right in Model View. 
 

Time - Defines the hold time when the probe tip stays near the target position.  
 
Range - Defines the allowable area of acquiring position from the target position. 

 

Drag Mode 

Drag Mode – Allows to capture multiple points while pushing the A button. 
 

Time – Every point as defined time will be acquired. 
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Distance – Every point as defined distance will be acquired. 
 

Tolerance and Sound 

RMS Tolerance – Sets an RMS tolerance value and will display any value outside of the 
tolerance during probing as red and will trigger a beeping alert from the PC in use. 
 
Enable Sound While Probing – Triggers a beeping alert from the PC in use when generating a 
probing point. 
 

Hotkey 

Hotkey for A/B/C Buttons – Defines keyboard hotkeys for the A, B and C button. Click the box 
and enter the desired key. 
 

Compensation and Generate Entity 

Use Custom Compensation - Compensates a probe radius by the direction of the X, Y, and Z 
global axes or the probe axis and is useful when a scanning part is aligned to a CAD in the 
application. Compensation is applied to a surface normal direction when the Surface option is 
chosen. 

 

 

 

Without Compensation Compensation to –Z Compensation to Probe Axis 
 
Create Ref. Points From Measured Points – Registers probed points as ref. points. 
 
Create Sketch Points From Measured Points – Creates points in the Sketch mode from 
probed points. 

 
 

Options in Detail of LiveScan(TM) Dialog Tree 

1/2 Align Stage 
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Reset to HW Coordinate System – Resets the coordinate system to the HW coordinate system. 
 

Note:  

When running the LiveScan™ command, the scanning coordinate system aligns by default to the 
previously used coordinate system by using the last used transform matrix. 

 
 

Align Type 

Best Fit – Alignment method that is applied when scanning is finished. 
 

Global – Alignment method that is applied to a selected whole body. 
 

Partial – Alignment method that is applied only to selected faces on a body. 
 

Max. Distance – Sets the maximum distance between alignment entities. 
 

Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 

 
Max. Iteration Count – Determines a value that will limit the number of times a 
registration iterates. 

 
Max. Average Deviation – Determines a value as deviation criteria used to judge if a 
registration result is satisfactory. The application will attempt to make the average 
deviation of a final model less than this value within the Max. Iteration Count. 

 
Offset – Applies the Best Fit method by offsetting at a specified distance. 

 
Anchor Type – Defines the reference position for constraints of translation or rotation. 
Selects the type of anchor used in the command. If the Scan Data Center option is 
selected, the center of the bounding box for selected scan data is shown and used as the 
anchor point. If the Model Center option is selected, the center of the target model will 
be used as an anchor point. If Local Coordinate is selected, you can define custom 
coordinate as the anchor point. If the Global Origin option is selected, the origin point in 
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the global coordinate will be used as the anchor point. 
 

Lock Translation/Rotation – Limits movement and rotation in each direction while scan 
data is aligned. 

 
Ignore Outlier – Ignores data far from the average during calculation. 

 
Datum – Used for alignment by selecting geometry such as a plane, cylinder, sphere, or vertex 
on a body, allowing the selection of a device and a method to acquire pair geometry from a 
real-part. After acquiring all geometries, the application performs Datum alignment. 

   
 

2/2 Scan Stage 

 
 

Device 

Laser Scanner – Acquires data using a scanner. 
 
Touch Probe – Acquires data using a probe. 

 

Feature Type (Laser Scanner) 

Mesh / Point Cloud – Creates meshes or point clouds after scanning. 
 
Ref. Geometries – Creates a ref. plane after scanning. 
 
Surface Body – Creates a surface body by averaging scanned points. You can create a 
plane, cylinder, cone, sphere and torus after scanning. 
 
Solid Body – Creates a solid body by averaging scanned points. You can create a 
cylinder, cone, sphere and torus after scanning. 

 

Feature Type (Touch Probe) 

Mesh / Point Cloud – Creates meshes or point clouds after probing. 
 
Ref. Geometries – Creates ref. geometries after probing. 
 

Ref. Planes – Creates a ref. plane by fitting probing points. 
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Probing Points  Ref. Plane 

 
Ref. Vector – Creates a ref. vector using one of the following methods: 

 
Intersect 2 Planes – Creates two planes by probing, and then generates a 
ref. vector at the intersecting line of the two planes. 

 

 

 

 

 
First Plane  Second Plane  Ref. Vector 

 
Fit Without Compensation – Creates a ref. vector by using use probe 
centers to average probing points without compensation. 

 

 

 
Probing Points  Ref. Vector 

 
Projection And Fit Without Compensation – Creates a projected ref. 
vector from probing points without compensation. 

 

 

 

 

 
Base Plane  Probing Points  Ref. Vector 

 
From Fitting Cylinder – Creates an axial ref. vector of a cylinder that was 
created by fitting probing points. At least seven points are required to 
create a cylinder. 

 

 

 
Probing Points  Ref. Vector 

 
From Fitting Cone – Creates an axial ref. vector of a cone that was created 
by fitting probing points. At least eight points are required to create a 
cylinder. 

 

 

 
Probing Points  Ref. Vector 

 
Ref. Polylines – Creates a ref. polyline from probing points without 



Geomagic Design X | Menu  500 
 

compensation. 

 

 

 
Probing Points  Ref. Polyline 

 
Ref. Points – Creates a ref. point using one of the following methods: 

 
Average – Internally creates a plane by fitting probing points and 
compensates a plane. The averaged proving point will be projected onto 
the compensated plane. 

 

 

 
Probing Points  Ref. Point 

 
Average Without Compensation – Creates a ref. point by averaging 
probed points without compensation. 

 

 

 
Probing Points  Ref. Point 

 
Projection And Average Without Compensation - Creates a projected ref. 
point without compensation. 

 

 

 

 

 
Base Plane  Probing Points  Ref. Point 

 
Intersect 3 Planes – Creates a ref. point at the intersecting position of three 
planes. 

 

 

 

 

 

 

 

First Plane  Second Plane  Third Plane  Ref. Point 
 

Intersect 2 Planes – Creates a center point at the intersecting line between 
two planes. 

 

 

 

 

 
First Plane  Second Plane  Ref. Point 

 
From Fitting Circle – Creates a projected ref. point from the center position 
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of a fitted circle. 

 

 

 

 

 
Base Plane  Probing Points  Ref. Point 

 
From Fitting Sphere – Creates a ref. point at the center of a fitting sphere. 

 

 

 
Probing Points  Ref. Point 

 
From An Edge Of A Plane – Creates an edge point on a ref. plane. 

 

 

 

 

 
Base Plane  Probing Points  Ref. Point 

 
Intersection Points On A Plane – Creates a ref. point at the intersecting 
position between a plane and a line generated by two points. 

 

 

 

 

 
Base Plane  Probing Points  Ref. Point 

 
Instant Point Without Compensation – Creates ref. points by a single 
acquisition of the A button. 

 

 

 
Probing Points  Ref. Point 

 
Surface Body – Creates a surface body by averaging probed points after probing. A plane, 
cylinder, cone, sphere, or torus can be created. 

 
Solid Body – Creates a solid body by averaging probed points after probing. A cylinder, 
cone, sphere or torus can be created. 

 
Sketches – Creates sketch entities after probing. A line, rectangle, circle, point, or slot can 
be created. 

 
3D Sketches – Creates a spline after probing. 

 
Set Name Prefix – Defines the prefix of an entity name. 
 
Use Device Buttons To Change LiveScan™ Option – Allows changes in options in the 
LiveScan™ dialog tree by using scanner buttons. 
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Insert > Scanner Direct Control > Geomagic Capture 
 
The Geomagic Capture 3D scanner is a structured-light scanning system that uses a blue LED light 
system.  When using the Geomagic Capture command the scanner should be installed in advance. 
 
Supported devices 

Device 32-bit 64-bit 
Geomagic Capture Yes Yes 

 
 

Note:  

Geomagic Capture is not supported on Microsoft Windows XP. 

 
 

Scanner Specifications 

 

Scan Speed 0.3 seconds per scan 
Field of View (diagonal) / Near End 
– Far End 

172 – 260 mm 

Field of View (X-Y) / Near End – Far 
End 

124 x 120 mm – 192 x 175 mm 

Clearance Distance 300 mm 
Depth of Field 180 mm 
Resolution Average Points 985,000 per scan 

Average Polygons 1.97 million per scan 
Point to Point 
Distance 

0.162 mm (At center of 
measurement volume) 

Accuracy / Near End – Far End 60 microns – 118 microns (µm) 
Calibration Pre-calibrated 

 
 

How to Use  

How to Create a Scan Using Geomagic Capture 
1. Connect a Geomagic Capture 3D scanning device to the PC. 

2. Go to Insert > Scanner Direct Control > Geomagic Capture. 

 
 

3. The command will initiate. Click the Connect button to connect to the Geomagic Capture 
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3D scanning device. 
 

4. If it’s the first time using the scanner it must be configured to the network so a dialog box 
asking to Auto-Configure the network will be displayed.  Click Yes to auto-configure or 
click No to manually configure. 

 
 

5. Adjust the Exposure setting to get an ideal scan. A scan that shows a lot of red is over-
exposed, and a scan that shows a lot of blue and black is under-exposed. 
 

   

Under-Exposed Over-Exposed Optimal 

 
 

Note:  

Scan quality can vary by the following factors: 

• Scanner calibration 

The more calibration scans you take, the better the accuracy of the scanner.  

• Environmental conditions 

Light and vibration can cause inaccuracies. Ensure the system is stable and the exposure is 
set to the conditions.  

• Stability of the scanner and the object 

If either the scanner or the object move during the scan, the data will be inaccurate. Ensure 
both are stable and secure.  

• Shape and size of the object 

If the part you want to scan has limited features, you must use markers or spheres to align 
the data. 

 
 

6. The red crosshairs show the centerpoint of the camera and the gray cross-section on the 
object shows the structure pattern. Align the structure pattern to the centerpoint of the 
camera. 
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Note:  

An exact alignment is not necessary. As long as the structure pattern and the centerpoint of 
the camera are close to each other a satisfactory scan can be created. 

 

 
 

7. Then click the Scan button. A scan will be taken and imported in the application. 

 
 

8. Reposition the model and click the Scan button again to take another scan. 
 

Note:  

If a scan was made using the Best Fit alignment method, make sure at least 30% of the original 
scan area is in the next scan. If the Target alignment method was used, make sure that at least 
three targets from the first scan area are visible in the next scan. 
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9. The second scan will be imported into the application and shown in a magenta color. 
 

 
 

Note:  

During a scanning process when a new scan is made the previous scan will change from 
magenta to blue and the new scan will be shown in magenta. 

 
 

10. Continue scanning until the project is completed and click the Accept button. The Mesh 
Buildup Wizard will initialize. 
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Options in Detail 

Options  

 
 

Scan – Takes a scan shot and sends it to the 
Geomagic application. 
 
HDR – Scans multiple times at varying 
exposure levels in order to capture objects 
with large contrast variances. 
 
High Sensitivity – Special scanning mode 
that allows for the capture of noisy surfaces 
that would otherwise be difficult to capture. 
 
Auto Exposure – Automatically controls 
the exposure setting of the 3D scanner. 
 
Exposure – Changes the level of light that 
is sent and received by the scanner. 
 
Settings – Goes to the settings menu. 
 
Status – Shows the current working status. 
 
Help – Shows the Help document. 
 

Settings  

 
 

Auto Align – Automatically aligns scans 
using either the Best Fit or Target methods. 
 

Best Fit – Aligns a current scan shot 
to the previous scan shot.  All other 
scan shots will be ignored. 

 
Target – Uses targets on a real part to 
align. 

 

Note:  

When using the Auto Align method, refer to 
the tips below: 

• Prevent the scan floor from being 
captured in a scan 

• Apply white scanning spray or powder 
evenly and make sure the object is 
adequately covered 

• Dim the lights  

• Use proper sized target markers 
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Resolution – Changes the resolution of the 
scanner. 
 

High – Constructs a high-density 
mesh (1/1 capture ratio). 
 
Medium – Constructs a medium-
density mesh (1/4 capture ratio). 

 
Low – Constructs a low-density mesh 
(1/9 capture ratio). 

 

Scanner Setup 

Auto Connect – Connects the scanning 
device by automatically configuring a 
network. 
 
Manual Setup – Connects the scanning 
device by manually setting a network 
configuration. 
 

Firmware Version 

Update Firmware – Checks for new 
firmware and updates the current firmware 
if a newer version exists. 
 

Scanner Setup  

 

Use DHCP – Uses the DHCP IP protocol 
instead of a static IP address. 
 
IP Address – Used to manually set a static 
IP address. 
 
Subnet Mask / Default Gateway – Used 
to manually set a subnet mask and a default 
gateway. 
 
Apply Settings – Applys changes made to 
the Use DHCP radio box as well as changes 
made to the IP Address, Subnet Mask, and 
Default Gateway input fields. 
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Insert > Scanner Direct Control > Creaform Portable 3D 
Scanners 
 
VXscan or VXelements should be installed in advance to directly control the Creaform Portable 3D 
Scanners. 
 
Supported devices 

Device 32-bit 64-bit 
Portable 3D Scanners Yes Yes 

 
 

Options in Detail 

1. Configure  

 

Session  
 

New – Starts a new session. 
 

Open – Opens an existing session file (.CSF). 
 

Save – Saves the current session (.CSF). 
 
Positioning Features 
 

Open – Opens a positioning target file (.TXT). 
 
Copy - Copies positioning targets to a new scan. 
 
Save - Saves positioning targets in a file (.TXT) 

 
Scan List - Shows existing scans of the current session and 
highlights the current scan. 
 

Add – Adds a scan to the current session. 
 
Rename Scan - Changes the name of the current 
scan in the Current Scan box. 

 
Remove Scan - Removes the current scan. 

 
Sensor 
 

Configuration - Shows the Sensor Configuration 
dialog box for Portable 3D Scanners. 
 
Calibration – Shows the Sensor Calibration dialog 
box for Portable 3D Scanners. 

 
Scan Backup Path – Sets the backup folder for scan data. 
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2. Scan 

 

Scan 
 

Start – Starts scanning. 
 

Stop – Stops scanning. 
 

Reset – Clears the scan data for the current scan. 
 

Surface – Gathers surface data and positioning 
features during scanning. 

 
Positioning Features – Gathers only positioning 
features during scanning. 

 
Show Current Scan Only – Shows only the scan data 
of a selected scan. 

 
Hide Positioning Features When Surface Scanning 
– Hides positioning features during scanning. 

 
Show VxScan Entity Only – Shows only meshes and 
ref. point entities related to scan data. 

 
Open VxScan Window – Opens the VxScan window 
and enables users to access all functions that VxScan 
provides. 

 

Surface Parameter - Sets scanning volume size or resolution. 
 

Volume Size – Adjust surface reconstruction settings and sets the scanning volume. 
Changing the volume size directly affects the voxel size of each resolution level. 

 
Resolution – Select High, Medium or Low resolution. 

 
Apply - Confirms settings. 

 
Cancel – Restores a previous setting. 

 
Center Volume - Centers the volume on an object being scanned. 

 
Refine - Performs an operation on a surface that decreases the impact of possible 
positioning errors that may occur during scanning. 

 
Facet Parameter 
 

Spike Filter – Determines the level of spike filtering. 
 

Fill Positioning Features – Fills holes created by the positioning features on an object. 
 

Apply – Confirms settings. 
 

Cancel – Restores a previous setting. 
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Insert > Scanner Direct Control > Z Corporation ZScanner 
700  
 
ZScan should be installed in advance to directly control a ZScanner 700 scanner. 
 
Supported devices 

Device 32-bit 64-bit 
ZScan Yes Yes 

 
 

Options in Detail 

1. Configure  

 

Session  
 

New – Starts a new session. 
 

Open – Opens an existing session file (.CSF). 
 

Save – Saves the current session (.CSF). 
 
Positioning Features 
 

Open – Opens a positioning target file (.TXT). 
 

Copy - Copies positioning targets to a new scan. 
 

Save - Saves positioning targets in a file (.TXT). 
 
Scan List - Shows existing scans of the current session and 
highlights the current scan. 
 

Add – Adds a scan to a current session. 
 

Rename Scan - Changes the name of the current 
scan in the Current Scan box. 

 
Remove Scan - Removes the current scan. 

 
Sensor 
 

Configuration - Shows the Sensor Configuration 
dialog box for ZScan. 

 
Calibration – Shows the Sensor Calibration dialog 
box for ZScan. 
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Scan Backup Path – Set the backup folder for scan data. 
 

2. Scan 

 

Scan 
 

Start – Starts scanning. 
 

Stop – Stops scanning. 
 

Reset – Clears the scan data for the current scan. 
 

Surface – Gathers both surface data and positioning 
features during scanning. 

 
Positioning Features – Gathers only positioning 
features during scanning. 

 
Show Current Scan Only – Shows only the scan data 
of a selected scan. 

 
Hide Positioning Features When Surface Scanning 
– Hides positioning features during scanning. 

 
Show ZScan Entity Only – Shows only meshes and 
ref. point entities related to scan data. 

 
Open ZScan Window – Opens the ZScan window 
and allows users to access all functions that ZScan 
provides. 

 

Surface Parameter - Sets scanning volume size or resolution. 
 

Volume Size – Adjust surface reconstruction settings and sets the scanning volume. 
Changing the volume size directly affects the voxel size of each resolution level. 

 
Resolution – Select High, Medium or Low resolution. 

 
Apply - Confirms settings. 

 
Cancel – Restores a previous setting. 

 
Center Volume - Centers the volume on an object being scanned. 

 
Refine - Performs an operation on a surface that decreases the impact of possible 
positioning errors that may occur during scanning. 

 
Facet Parameter 
 

Spike Filter – Determines the level of spike filtering. 
 

Fill Positioning Features – Fills holes created by the positioning features on an object. 
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Apply – Confirms settings. 
 

Cancel – Restores a previous setting. 
 
 

Insert > Scanner Direct Control > Konica Minolta VIVID 
 
Supported devices 

Device 32-bit 64-bit 
VIVD 910 Yes Yes 
VIVD 9i Yes Yes 

 
 

Options in Detail 

1. General  

 
 

Scan 
 

Name – Used to input the name of a scan 
shot and its suffix. 

 
Auto Align – Automatically aligns 
captured scan shots.  
Rotary Axis is used for a rotary table 
device, and Geometry performs auto 
alignment with an application algorithm.  
The With Only Last Scan option performs 
alignment between the last scan shot and 
a previous one. 

 
Save Raw Data – Saves raw scan data to a 
desired directory. 

 
Preview – Shows a preview image with a 
color map. Red represents near distances 
from a scanner and blue represents far 
distance. Anything displayed in black will 
not be seen by a scanner, because it is out 
of range. When a preview is satisfactory, 
click Accept. 

 
Scan – Starts scanning. 

 
Auto Scan – Starts auto scanning using a rotary table. Parameters can be set in the Rotary 
Table tab in the Auto Scan option. 

 
Digitizer Parameter – Applies parameters from the Standard and Advanced tab to a 
scanner device when the Set button is clicked. The Get button retrieves the parameters 
from a scanner device to the Standard and Advanced tab. 

 
Mode – Select the Standard, Extend or User mode provided by a scanner device. 
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2. Standard Tab 

 

Focus – Sets a focusing distance. Clicking Auto 
Focus, will set a scanner to find the best 
focusing distance automatically. Checking the 
Auto Focus Before Scan option will allow a 
scanner to Auto Focus whenever it scans. 
 
Exposure – Sets the exposure of scanner 
device. 
 

LD - LD (Laser Diode) Power. 
 
Gain - CCD Gain. 
 
Auto Exposure Before Scan – Sets 
exposure values automatically before 
starting a scan. 
 
Auto Exposure – Finds the best 
exposure for scanning. Checking the 
Auto Exposure Before Scan option 
allows a scanner to use Auto Exposure 
whenever it scans. 

Scan 
 

No Polygon – Gathers only point clouds. 
 

Multi-Pass – Determines the number scans. 
 

Import Raw Data – Imports .cdk and .cdm file formats. 
 
Texture 
 

Use Texture – Gathers textures. To correct a texture color, use the Dark Correct or Log 
Correction options. 
 

Dark Correction - Applies dark correction to color data. Use for striation-type noise 
in images. 

 
Log Correction - Applies logarithmic correction to color data. Used to brighten 
neutral colors. 

 
Brightness – Corrects texture brightness. 

 
Overlap Texture - Uses the texture of a current model and overlaps it onto previously 
scanned data. A non-textured model can overlap another texture in different illumination 
conditions. 

3. Advanced Tab 



Geomagic Design X | Menu  514 
 

 

Raw Data Process 
 

Reduce Ratio – Decides the sampling 
ratio used to import scan data. 

 
Filter - Decides the filtering method for 
poly-vertices. 
The None method will not filter any 
poly-vertices. 
The Noise Filter method will filter noisy 
poly-vertices. 
The High Quality method will filter 
unreliable data but is only effective for 
importing scan data obtained using a 
Vivid910. 
The Noise Filter & High Quality method 
uses both the Noise Filter and High 
Quality methods and is also only 
effective for importing scan data 
obtained using a Vivid910. 

 
Remove – Chooses a method to remove unnecessary parts while importing scan data.  
The Don't Remove method will not remove any parts 
The Bound method removes boundary points. 
The Bound & xx Degree method removes boundary points and polygons within a 
corresponding angle range between 5, 10, 15, and 20 Degrees to a view vector. 

 
Fill Holes – Fills small holes in a mesh. 

 
Multi-Depth Scan 
 

Multi-Depth Scan – Executes multiple scans while changing distances.  
For example, setting Spacing to 20 and Scan Num to 3 when the distance is 600, will scan 
at the 580, 600, and 620 positions and create three meshes in the working window with 
the names “Default - 000deg: 01”, “Default - 000deg: 02” and “Default - 000deg: 03”. 

 
Direction – Selects the direction for multi scanning. 

 
Forward – Starts scanning in the forward direction from a current focus length. 

 
Backward – Starts scanning in the backward direction from a current focus length. 

 
Both – Starts scanning in the forward and backward direction from a current focus 
length. 

 
No. of Scan – Defines how many scan shots will be captured. 

 
Spacing – Defines distance increments for focus length. 

 
VIVID 9i Calibration – Calibrates a VIVID 9i scanner which requires a calibration jig. 

4. Rotary Table Tab 
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Connection 
 

Auto Connect On Startup – 
Automatically communicates with a 
rotary table upon startup. 

 
Model – Selects a rotary table which you 
want to connect. 

 
PORT – Selects the port used to 
communicate with a rotary table. 

 
Connect – Starts communication with a 
rotary table. 

 
Disconnect – Stops communication 
with a rotary table. 

 
 

Single Scan 
 

Use Angle As Name Suffix – Uses a specified angle for the file name suffix. 
 

Auto Rotate – Automatically turns a rotary table by a specified angle after scanning. 
 

Rotary – Manually turns a rotary table.  
The Move button starts to turn a rotary table.  
The Origin button moves a rotary table to its origin position. 

 
Auto Scan – Sets the parameters used for an automated scan. 
 

No. of Scan – Sets the number of rotations. 
 

Total Angle – Sets the entire angle of scanning. 
 

Equal Spacing – Applies scanning with an equal angle decided by the No. of Scan and 
Total Angle options. 

 
Interval Waiting – Sets the value for scanning after a rotary table has been turned. A time 
can be set to prevent a model from shaking by the sudden stop of a rotary table. 

5. Calibration Tab 
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The Calibration tab contains parameters for 
calibration of a rotary table.  
Calibration State shows the calibration status 
or if a stored calibration has been successfully 
loaded. If it is not lit a calibration is necessary. 
Calibration Types chooses the method of 
calibration. The default is Plate for plates 
provided by Konica Minolta. When a 
calibration ball provided by 3D Systems is used 
the Sphere type needs to be used.  
Scan For Calib uses a jig used for calibration 
that can be scanned. The axis vector of the 
rotary table can automatically be found by 
processing the scan data of a part in the 
application.  

If the results of an axis vector are not satisfactory, it can be manually re-assign by selecting scan 
areas using the Upper Sphere, Lower Sphere, Left Plate, and Right Plate buttons. The new axis 
vector will be recalculated from the manual selection of areas. 

   
When scan data contains noise, the application may fail to calibrate and the scan data may need 
to be edited by making a reference vector in the application. After editing scan data, the Pick 
Rot Vector option can be used to set a rotation vector. Click the Pick Scan & Calib. Option and 
select a scan data to perform calibration. 
Calibration Info. shows the current calibration information. 
Load Calib Data will load calibration information previously stored in a file. 
Save Calib. Data will save the current calibration information to a file. 
Manual Clustering Criterion can be used to classify clusters for calibration purposes and if it is 
not checked, the value will be automatically calculated. 
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Insert > Scanner Direct Control > Breuckmann  
To execute the Breuckmann command, previously, Optocat should be installed on your machine. 
 
Supported devices 

Device 32-bit 64-bit 
Breuckmann Yes Yes 

 
 

Options in Detail 

1. System  

 
 

Breuckmann Optocat 
 

Version – Chooses an installed version of 
Optocat. 

 
Launcher Path – Chooses the file path of the 
Optocat .exe file. 

 
Connect & Initialization – Connects a scanner 
and defines the initial setup preferences 
supported by Optocat. The color of ‘Breuckmann 
Connection’ will change from red to green when 
successful. 

 
Rotary Table Setting 
 

Model – Chooses a type of a rotary table. 
 

COM Port – Chooses a port for the application to 
communicates with a rotary table. If a rotary table 
is connected by USB, this option will be disabled. 

 
Connect – Connects a selected rotary table. The 
color of ‘Breuckmann Connection’ will change 
from red to green when successful. 

 
Test – Tests to verify that a rotary table is working 
correctly. 

 
Data Option 
 

Including Color – Imports color information. 
 

Triangulation – Starts triangulation when scan 
data is acquired. 

 
Scanner Waiting Time – Sets the time between 
scanning intervals. 
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2. Calibration  

 

Home – Rotates a rotary table to a default position. 
 
Move Rotary Table – Rotates a rotary table by a specific 
angle. 
 
Set Scan Parameter – Opens the option dialog box of 
Optocat. 
 
Incremental Angle– Specifies an angle between scans. 
 
Scan for Calibration – Calibrates by scanning three 
times by a specified angle. 
 
Start Calibration – Opens the Calibration Window 
dialog box and calculates the rotational axis of a rotary 
table by picking markers or spheres on three images 
and clicking the Start Calibration button. 

 
 
Image Size – Selects an image size in the Calibration 
Window dialog box. 
 
Reverse Axis Direction – Flips a rotation axis. 
 
Show Axis – Displays an axis. 
 

3. Single  
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Home - Rotates a rotary table to a default position. 
 
Move Rotary Table – Rotates a rotary table by a specific 
angle. 
 
Set Scan Parameter - Opens the option dialog box of 
Optocat. 
 
Scan – Starts scanning. 
 
Auto Align – Automatically aligns scan shots. 
 

Geometry – Aligns scan data using a feature-to-
feature recognition alignment algorithm. 

 
Rotary Axis – Aligns scan data using the axis of a 
rotary table that can be found in the Calibration 
tab. 
 
With Only Last Scan – Performs alignment with 
the last scan. 

4. Batch  

 

Auto Filling – Displays the Auto Filling dialog box 
where the Start / End Angle and Count options can be 
utilized. Angles will be displayed in the Scan List box. 
 
Clear – Removes all angles in the Scan List box. 
 
Set Scan Parameter - Displays the option dialog box of 
Optocat appears. 
 
Batch Scan – Starts scanning. 
 
Align Geometry – Aligns scan data using a feature-to-
feature recognition alignment algorithm. 
 
Rotary Axis – Aligns scan data using the axis of a rotary 
table that can be found in the Calibration tab. 
 

 
 
 

Insert > Scanner Direct Control > KODEN OCM-A (32 bit 
only)  
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The default setting of KODEN OCM-A devices are included in OCM-A_Info.ini.file. The file is located 
in ~<Product Installation Path>\bin\KODEN OCM-A. 
 
Supported devices 

Device 32-bit 64-bit 
KODEN OCM-A Yes No 

 

Options in Detail 

Connect – To communicate with KODEN OCM-A devices, click this button. When connected 
to the device, the button will change to Disconnect. 
 
Auto – Automatically applies the Zoom fit function while scanning is in progress. 
 
ZoomFit – Displays and refreshes an entire model during scanning. 

 
 
 

Insert > Scanner Direct Control > Roland LPX (32 bit only) 
 
Supported devices 

Device 32-bit 64-bit 
LPX Series Yes No 

 
 

Options in Detail 

Connect – Communicate with a Roland LPX scanner. 
 
Port – Selects a port. 
 
Rotational Scan – Set scanning options for scanning a model while it is rotating. 
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A scanning area is defined by the Height and Circumferential input boxes. If a scanning size 
cannot be initially defined, click the Preview button and an approximate height will be 
generated for a Height value. 
Scanning pitch is defined in the Circumferential Pitch and Height-direction Pitch input boxes. 
After scan settings are define scanning time can be estimated by using the up arrow button. To 
start scanning, click the Scan button. 
 
Planar Scan – Makes a square of the scanning area and scans a model in several rotational 
directions. 
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A total number of scans can be defined in the Surfaces to Scan input box. If 3 is input, a model 
will be scanned 3 times. 

 
To change an initial scanning direction, click the  button. A scanning area is defined by the 
Height and Width input boxes. If a scanning size cannot be initially defined, click the Preview 
button and an approximate height will be generated for a Height value.  
Scanning pitch is defined by the Circumferential Pitch and Width-direction Pitch input boxes. 
After scan settings are define scanning time can be estimated by using the up arrow button. To 
start scanning, click the Scan button. 
 
Points Only – Imports scan data as a point cloud. 
 
Cutoff Angle - Specifies an angle between a scan direction and a normal direction of poly-face 
mesh to be generated. If the angle is larger than a user defined value, a poly face mesh will not 
be generated. This option is useful for preventing scan data from containing unwanted spikes. 

  
 
 
 

Insert > Scanner Direct Control > Konica Minolta 
RANGE5/RANGE7 (64 bit only) 
 
To execute the RANGE5 and RANGE7 command, previously, RangeViewer should be installed on 
your machine. 
 
 

Options in Detail 

Connect – Connects to a RangeViewer after setting a Path. 
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Points Only – Imports only point data from RangeViewer. 
 
Suppress – Used to suppress data when acquiring point cloud or mesh data of large sizes from 
a scanner. The suppressed data will be imported and loaded on the hard disk. 
 
RangeViewer Path – Automatically sets a default installation path when the application is first 
installed. If the installation folder is changed or move, this option can be used to set the correct 
path for RANGEVIEWER.exe. 

 
 
 

Insert > Scanner Direct Control > 3D Digital Scanner (32 
bit only)  
 
RealScan should be installed in advance to directly control a 3D digital scanner. 
 
Supported devices 

Device 32-bit 64-bit 
3D Digital Scanner Yes No 

 
 

Options in Detail 

Scanner – Chooses a scanner to directly control in the application. 
 
Gain / Threshold – Allows users to specify scan density. The number of lines is adjustable up 
to 1000 and the higher the density of points, the longer it will take to scan. Along with the 
resolution control, users can also adjust gain and stripe threshold settings. The stripe threshold 
and gain settings allow users to adjust camera sensitivity to capture more or less points on the 
surface of an object to be scanned. Darker objects will need higher gain settings so that the 
laser will appear brighter to the camera. 

  

Noisy Scan Good Scan 
 
1000 / 255 Points / Lines – Controls distribution points consisting of the number of points per 
line by the number of lines per scan. There are 2 modes for scanning, 255 Points or 1000 
Points. The resolution of a scan can be changed by adjusting the number of Points and Lines. 
The default number of points per laser stripe will be 255 in a fast scan mode. EScan models can 
only scan in modes of 255 points, while Optix series scanners can scan up to 1000 points. The 
number of lines can be increased up to 1000. 
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Z Range Cut Off – A Z Range Cut Off setting is provided to help remove the foreground and 
backdrop from a model. To eliminate the foreground and backdrop points, reduce the 
maximum Z and increase the minimum Z using the Set Cutoff Plane sliders. The Far slider sets 
the location of the far cutoff plane and the Near slider sets the location of the near cutoff plane. 
Users can adjust scan volume in real time when the Preview button is used. To open Z limits, 
click the Extend DOF button. To return back to calibrated limits, push the button again. 
 
X Range Limits – The X-Range Limits allows users to control an area being scanned in the X 
axis. A laser sweeps left to right but the length of each sweep can be narrowed if a user is 
scanning a smaller object. The Laser On button will turn on the laser to allow users to see the 
laser position. To adjust limits, move the slider bar to a desired laser position and click the L or 
R button to set either the left or right limits of scanning. Clicking the double arrow button will 
move the laser to either extreme of the scanning field. To open up the X limits again, click the 
Reset FOV button. 
 
Points Only – Creates a point cloud from a scan. To get mesh data from scanning, turn this 
option off. 
 
Preview / Scan – Toggles the preview mode or take scans. 

 
 
 

Insert > Scanner Direct Control > Shining3D  
 
To directly control a Shining 3D scanner, Shining 3D’s application should be installed in advance. 
 
Supported devices 

Device 32-bit 64-bit 
Shining3D Yes Yes 

 

Note:  

If the application cannot find a Shining 3D application, a dialog box will be displayed to manually choose 
the Shining 3D’s application execution file (.exe) when the Insert > Scanner Direct Control > Shining3D 
command is executed. 

 

Note:  

Scanner Direct Control Interface for Shining 3D is supported in the 32-bit version of Geomagic Design X 
only. 

 
 

Options in Detail 

1. Run Application  

Manually choose the directory where the Shining 3D application execution file (.exe) and 
configuration files are located. Once the directory is set, it will be preserved for when the 
application is run again. 
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2. General  

 
 

Ini Path – Shows the path where the configuration file 
(.ini) is located. 

 
  – Manually chooses the location of the 

configuration file (.ini). 
 

View – Shows the view of the Left Camera or the Right 
Camera. 

 
Camera Settings – Specifies camera settings. 

 
Exp. Time – Specifies the exposure time of 
camera. 
 
Both – Applies camera settings to both the Left 
Camera and the Right Camera. 
 
Gain – Adjusts camera sensitivity to capture more 
or less points on the surface of an object. Darker 
objects will need higher gain settings so that the 
laser will appear brighter to the camera. 

 
Projector Settings – Specifies projector settings. 
 

Stripe Test – Projects stripes on a target object. 
 
Cross – Projects a crossed center on a target 
object. 
 
Stripe Width – Sets the width of projected stripes 
by adjusting a slider. 
 
Min. / Max. Bright – Sets the range of brightness 
by adjusting a slider. (0~255) 
 

Calibration – Shows the Sensor Calibration dialog box 
for Shining 3D. 
 

Scan and Align – Scans and aligns scan data. 
 

Align – Aligns scan data. 
 

Maker – Aligns scan data by using detected markers used during scanning. 
 
Feature – Aligns scan data by using feature information. The application uses the 
Local Based On Auto Guess method for quick and accurate alignment. For more 
information, see Tools > Scan Tools > Align Between Scan Data. 

 
Import Marker Info. – Imports pre-defined markers information. 
 
Export Marker Info. – Exports detected marker information during the scanning. 
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Scan – Starts scanning. 

 
 
 

7.5. Tools 
 
The Tools menu features commands to edit existing features or create a new feature. 
 
Tools are divided into 5 tool groups used to: 
 

Managing Features 

• Create new 3D Scan Data (Related to Scan Tools) 

Creates and edits new 3D scan data from raw 3D scan data 

• Edit Mesh (Related to Mesh Tools) 

Edits mesh in the Mesh mode 

• Manage Regions (Related to Region Tools) 

Creates new regions on a mesh or edits them in the Region Group mode 

• Edit Point Clouds (Related to Point Cloud Tools) 

Edits point clouds in the Point Cloud mode 

• Manage Texture (Related to Texture Tools) 

Adds a new texture on mesh or edits it in the Mesh mode 

 

Managing 2D Sketches 

• Create 2D Sketch Entities (Related to Sketch Entities) 

Creates 2D sketch entities such as lines, arcs, circles, rectangles, and ellipses 

• Edit 2D Sketch Entities (Related to Sketch Tools) 

Edits existing 2D sketch entities by filleting, offsetting, trimming, etc. 

• Use 2D Sketch Options (Related to Sketch Options) 

Executes 2D sketch options while creating 2D sketch entities 

• Add Dimension Constraints (Related to Smart Dimension) 

Measures dimensions and sets constraints for 2D sketch entities 

 

Managing 3D Sketches 

• Create 3D Sketch Entities (Related to 3D Sketch Entities) 

Creates 3D sketch entities such as splines, sections, and boundaries 

• Edit 2D Sketch Entities (Related to 3D Sketch Tools) 

Edits existing 2D sketch entities by offsetting, trimming, extending, etc. 
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Managing Bodies 

• Manage Bodies (Related to Body Tools) 

Finds defects in existing bodies 

 

Aligning Features 

• Align Coordinates (Related to Align) 

Moves features by aligning their coordinates 

 
 
 

7.5.1. Tools > Scan Tools 
 
The Scan Tools menu features various commands used to create new meshes from raw scan data as 
well as editing existing 3D scan data. 
 
Scan Tools are divided into 2 tool groups used to: 
 

Creating a New 3D Scan Data 

• Mesh Buildup Wizard 

Creates defect-free and watertight mesh models from raw 3D scan data through mesh building 
stages 

• Triangulate 

Creates mesh from raw point clouds 

• Align Between Scan Data 

Aligns 3D scan data 

• Merge 

Merges 3D scan data into a single mesh 

• Combine 

Combines multiple 3D scan data files into a single 3D scan data file 

• Decimate Meshes 

Reduces the number of poly-faces in a mesh 

 

Editing 3D Scan Data 

• Normal Information Manager 

Manages normal information in 3D scan data 

• Transform Scan Data 
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Transforms 3D scan data 

• Average Meshes 

Creates averaged master meshes or feature shapes from 3D scan data 

• Boolean 

Creates new mesh by applying various geometric / mathematic operations 

 
 
 

Tools > Scan Tools > Mesh Buildup Wizard 
 

What 

The Mesh Buildup Wizard command is a wizard style interface for creating defect-free and 
watertight mesh models from raw 3D scan data. The command consists of 3-5 stages that can be 
executed in just few clicks, enabling the speedy creation of optimized mesh for use in final reverse 
design stages. 

 
 
 

Why 

Mesh Buildup Wizard command is useful for: 

• Creating a watertight mesh from raw 3D scan data 

• Managing large amounts of 3D scan data and generating high quality mesh from it 

• Applying proper 3D scan data processing methods to 3D scan data based on its type 

• Reducing tedious and time consuming 3D scan data processing tasks 

 
 

How to Use 

A. How to create mesh from unaligned raw point clouds 
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1. Importing 3D scan data by using Mesh Buildup Wizard 
 
Go to Insert > Import, or click the icon in the toolbar. 
Select 3D scan data and click the Run Mesh Buildup Wizard button in the Import dialog 
box. 
 

 
 

Note:  

The Mesh Buildup Wizard can be executed after importing scan data by going to Tools > Scan 
Tools > Mesh Buildup Wizard in the menu. Multiple meshes or point clouds or a single mesh 
or point cloud can be used as target 3D scan data. 

 
 

2. Stage 1/5 – Data Preparation: Defining data properties 
 
Check Small/Medium Size Object Scanner as the target 3D scanner type. 
 

Note:  

This example assumes that the target scan data is a 3D point cloud to be scanned as a 
Small/Medium Size Object scanner and not aligned. 

 
Uncheck the “Is Pre-Aligned?” option and click the Next Stage button. 

 
 

3. Stage 2/5 – Data Editing: Deleting unnecessary poly-vertices/faces 
 
Select unnecessary clusters or outer poly-vertices. 
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Press the Del key or click the Delete button to remove them. 
 

Note:  

Checking specific 3D scan data or using the Show This Only option in the pop-up menu in the 
Entity Thumbnails pane can assist in displaying only desired data while editing 3D scan data. 

 
 
Click the Next Stage button. 
 

4. Stage 3/5 – Data Pre-Aligning: Aligning 3D scan data automatically or manually 
 
Choose the Local Based On Auto Guess option to automatically align scans.  
Check if all scans are selected as Moving scans. 

 
 
Click the Apply button. 
 
All scans will be automatically aligned. 
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Note:  

If scans fail to align, use the Local Based On Picked Point option to manually align them. 

 
Click the Next Stage button. 
 

5. Stage 4/5 – Best-Fit Aligning: Using the previous rough alignment, this stage performs 
a best-fit alignment to accurately align scans. 
 
Check that all scans are selected for Moving and then click the Apply button. 

 
 
Click the Next Stage button. 
 

6. Stage 5/5 – Data Merging: Merging scans and generating a single mesh 
 
To make a watertight mesh, use the Remesh And Fill All Holes To Create Watertight 
Mesh option. 
 
Click the Apply button and check the result. 
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7. Click OK to complete the command. 
 
 

B. How to create a mesh from pre-aligned raw 3D point clouds 
1. Run the Mesh Buildup Wizard command by going to Tools > Scan Tools > Mesh 

Buildup Wizard in the menu. Multiple meshes or point clouds or a single mesh or point 
cloud can be used as target 3D scan data in the Mesh Buildup Wizard. 
 

2. Stage 1/4 – Data Preparation: Defining data properties 
 
Select Line Laser With CMM/Arm as the target 3D scanner type. 
 

Note:  

This example assumes that the target scan data are 3D point clouds to be scanned by a Line 
Laser with CMM/Arm scanner and are already pre-aligned. 

 
Check the “Is Pre-Aligned?” option and click the Next Stage button to continue. 

 
 

3. Stage 2/4 – Data Editing: Deleting unnecessary poly-vertices/faces 
 
Set the Max. Poly-Vertices/Faces Count Per Noisy Cluster option to 100 and click the 
Find Noisy Cluster button. 
Check that noisy clusters are selected and listed under the Select button. 
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Press the Del key or click the Delete button to remove them. 
Click the Next Stage button. 
 

4.  Stage 3/4 – Best-Fit Aligning: If the 3D scan data has been pre-aligned, this stage 
accurately aligns scans 
 
Select all scans for Moving. 

  
 
Click the Apply button. 
Check the results and click the Next Stage button. 
 

5.  Stage 5/5 – Data Merging: Merging scans and generating a single mesh 
 
Check the Remove Redundant Points option and reduce the ratio by adjusting the 
slider towards Less. 

 
 
To make a watertight mesh, check the Remesh And Fill All Holes To Create Watertight 
Mesh option. Click the Apply button and check the result. 
 

Note:  

If the results are not satisfactory they can be manually edited by using the Edit Tools. 

 

 
 

6. Click OK to complete the command. 
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Options in Detail 

Stages 

This command consists of the following stages: 

• Data Preparation stage 

Analyzes the state of 3D scan data and defines the next process according to the type of 
target 3D scan data 

• Data Editing stage 

Removes noisy clusters and unnecessary point clouds or meshes 

• Data Pre-Aligning stage 

Quickly aligns multiple scans 

• Best-Fit Aligning stage 

Accurately aligns multiple scans by using geometry shape information 

• Data Merging stage 

Merges scans and creates an optimized mesh. 

 

Note:  

The number of stages for this command can change depend on the target source data. 

 
 

Stage 1/5 – Data Preparation 

This stage prepares data by selecting target 3D scan data and setting its type and alignment status. 
Depending on the settings selected in this stage, future stages will be automatically organized. 
 
Select – Selects point clouds or meshes. If multiple scan data are selected as the target scan data, 
the alignment stage will be the following stage. 
 
Set Scanner Type – Chooses a type of 3D scanner for target 3D scan data that can be viewed in 
the mouse help option. Depending on the selected type the Mesh Buildup Wizard will generate 
a watertight mesh using the most appropriate mesh generation algorithms. 
 

Touch Probe With CMM/Arm – Sets Touch Probe With CMM/Arm as the scanner type for 
target 3D scan data. 

 
Line Laser With CMM/Arm – Sets Line Laser With CMM/Arm as the scanner type for 
target 3D scan data. 

 
Small/Medium Size Object Scanner – Sets Small/Medium Size Object Scanner as the 
scanner type for target 3D scan data. 

 
Long Range Scanner – Sets Long Range Scanner as the scanner type for target 3D scan 
data that is scanned by long-range 3D laser scanners. 
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Unknown – Sets a generic scanner type for target 3D scan data that cannot be defined by 
a specific scanner type or has been mixed with different scan types. 

 
Set Data Condition – Sets the current status of 3D scan data. 
 

Is Pre-Aligned? – Indicates target 3D scan data has been pre-aligned. 
 
Skip Data Editing Stage? – Skips the data editing stages. 

 

Stage 2/5 – Data Editing 

This stage removes unnecessary poly-vertices or faces manually or automatically. After selecting 
unwanted data use the Del key or click the Delete button to remove them. 
 
Remove Unwanted Data – Removes unwanted poly-vertices or faces in 3D scan data using 
various editing tools. 
 

Select – Selects unwanted poly-vertices/faces manually. 

 
 
Define Wanted Region By Box – Defines a working volume by resizing a box. After 
defining a working volume, click the Delete button to remove outer poly-vertices or faces 
from the box. 

 
 
Define Wanted Region By Scanner Range – Defines a working volume by resizing a 
cylinder. The radius of the cylinder can be manipulated by a gray circle. After defining the 
working volume, click the Delete button to remove outer poly-vertices or faces from the 
cylinder. 

 
 
Find Floor – Selects a seed point on a scan data used to expand and select flat areas. After 
finding the flat areas, click the Delete button to remove the selected poly-vertices or faces. 
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Find All Boundary – Selects all boundaries and is available for mesh data only. After 
finding boundaries, click the Delete button to remove poly-faces neighboring the 
boundaries. 

 
 
Find Noisy Cluster – Finds small groups of poly-vertices or faces that are unnecessary in 
constructing a mesh by specify a cluster size next to the Max. Poly-Vertices/Faces Count 
Per Noisy Cluster options. After finding noisy clusters, click the Delete button to remove 
the selected poly-vertices or faces. 

 
 

Stage 3/5 – Data Pre-Aligning 

This stage aligns scans manually or automatically. The Local Based On Auto Guess option 
intelligently compares features on each 3D scan data file and aligns them. If scans fail in auto-guess 
aligning, they can be manually aligned by using the Local Based On Picked Point option. 
For information about aligning between scan data, see Tools > Scan Tools > Align Between Scan 
Data. 
 

Note:  

This stage is accessed when the Is Pre-Aligned? A option has been unchecked in the first stage (Data 
Preparation). If scans have already been pre-aligned, skip this stage by clicking the Next Stage button. 

 
 

Stage 4/5 – Best-Fit Aligning 

If scans are roughly aligned or the Data Pre-Aligning stage is used, it will be necessary for scans 
to be aligned accurately. This stage uses the best-fit alignment algorithm to match scans closely 
and reduce deviation. 
 
Select – Selects point clouds or meshes. 
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Reference – Selects scans to set for Reference. Their position will be fixed and other 
Moving scans will be transformed. A reference scan is not necessary. 

 
Moving – Selects scans to set for Moving. The moving scans will be transformed to the 
Reference. 

 
Options – Sets alignment the options. 
 

Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 

 
Apply Only Small Transform – Applies only a small transform when overlapping areas are 
assumed to be well aligned or if an alignment is difficult due to lack of feature shapes that 
can be used. 

  
Lack of Feature Shapes Patterned Feature Shapes 

 
Do Not Align Between Moving Object – Applies alignment by scan groups. 

  
Reference Group Moving Group – aligned scans 

 
Update View & Histogram – Displays the alignment process and the updating histogram 
in the Model View in real-time. 

 
Edit Tools – Removes unwanted poly-vertices/faces in 3D scan data by using various editing 
tools and corrects the normal information of 3D scan data. 
 

Note:  

This command can be used in this stage as well as in the Data Pre-Aligning stage (3/5 stage) and in the 
Data Merging stage (5/5 stage). 

 
Remove Unwanted Data – Selects unwanted poly-vertices or faces that can be deleted by 
pressing the Del key or clicking the Delete button. 

 

Note:  

Unwanted scan data can be selected manually or automatically by selecting or using the Detect 
Floor and All Boundaries buttons. 
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Reverse Normal Of Entire Mesh/Point Cloud – Reverses the normal information of an 
entire target 3D scan data. 

 
Reverse Normal Of Cluster – Reverses the normal information of a poly-face cluster. 

 
Fix Normal Of Mesh – Corrects the normal information of a target mesh. 
 

Stage 5/5 – Data Merging 

This stage merges 3D scan data and generates them into a single mesh.  

Methods 

This command features 2 methods: 

• Mesh Construction 

Generates a polygonal mesh by following the geometric shape of a point cloud  

• New Mesh Construction 

Generates a polygonal mesh by using voxel data structures 

 
Mesh Construction – Generates poly-faces by following the geometric shape of a point cloud. 
This method is useful for generating polygonal mesh from a point cloud that has multiple 
combined directional scans that cannot be projected onto a virtual plane or sphere or when results 
are required to be constructed by poly-faces with uniform poly-edge lengths. 
 

Geometry Capture Accuracy – Defines geometry capture accuracy. When the slider is 
moved towards Loose, less poly-faces will be used to create a shape. When the slider is 
moved towards Tight, more poly-faces will be used to create a shape. 

  

Loose Tight 

 
Scanner Accuracy – Specifies the accuracy of a scanner. Specify a value by referring to the 
specification of a particular scanner. For example, if target 3D scan data is scanned by a 
small/medium object scanner, the default value of 0.05 mm is suitable. If target 3D scan data 
is scanned by a long-range laser scanner, increase the value based on the precision of the 
scanner. 
 

Note:  

In general, if scan data is clean with a low level of noise, has a regular density, and also has 
satisfactory align accuracy, then using the maximum value of the 'Scanner Accuracy' slider will 
preserve and use most points just as they are. 

Each decreased step in the slider will decrease the creation of meshes by approximately a half of 
the previous step. The result will not be a uniform reduction and high curvature regions will be 
preserved, which is similar to applying a 50% decimation.  
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For example, the following combinations create almost the same results:  

- 'Scanner Accuracy' is 0.05mm and 'Geometry Capture Accuracy' is at the 4th step 

- 'Scanner Accuracy' is 0.0333mm (0.05 / 1.5) and 'Geometry Capture Accuracy' is at the 3th step 

- Scanner Accuracy' is 0.075mm (0.05 x 1.5) and 'Geometry Capture Accuracy' is at the 5th step 

 
Reduce Noise – Reduces noisy poly-faces. 

  

Without Reduce Noise option With Reduce Noise option 

 
Remesh And Fill All Holes To Create Watertight Mesh – Generates a watertight mesh 
that has no holes and or defects. 

  

Non-watertight Mesh Watertight Mesh 

 
New Mesh Construction – Generates poly-faces by using voxel data structures. This method is 
useful for generating polygonal mesh from a point cloud that does not have many open 
boundaries. This method is also quicker and can produce better results than the Mesh 
Construction method. 
 

Note:  

To get satisfactory results from the New Mesh Construction method, scan data must have normal 
information and using a mesh that has few open boundaries is ideal because the algorithm 
extends boundaries beyond their initial settings. The New Mesh Construction method keeps 
normal information consistent on connected triangles and can be useful for long range scan 
data and scan data with no boundaries. 

 
Global Shape Fitting Resolution – Controls how many voxel structures are used to create 
a resulting mesh. The higher the voxel structure count, the more control points can be used 
to represent the original shape of the scan data.  

 
Shape Fitting To Source Data – Defines geometry capture accuracy. When the slider is 
moved towards Loose, less poly-faces will be used to create a shape. When the slider is 
moved towards Tight, more poly-faces will be used to create a shape. 
 
Suppress Result In Feature Tree – Suppresses results from the Feature Tree. 
 

Note:  

The Suppress and Unsuppress mechanisms manage data memory by swapping data 
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dynamically between physical memory and a hard disk. This function is useful for effectively 
managing and handling a large 3D scan data file. 

Created Features can be suppressed or unsuppressed by checking the box next to the feature 
name in the Feature Tree. 

  
Unsuppressed Suppressed 

 

 
Noise Reduction Sampling – Reduces noise using a sampling algorithm. 
 
Create Watertight Mesh – Closes boundaries using the curvature of scan data.  
 

Curved – Creates a closed curved boundary at open boundaries. 
 
Flat – Creates a closed flat boundary at open boundaries. 

 
 

See Also 

Tools > Scan Tools > Triangulate 
Tools > Scan Tools > Align Between Scan Data 
Tools > Scan Tools > Merge 
Tools > Mesh Tools > Fix Normal 
Tools > Mesh Tools > Global Remesh 
Tools > Mesh Tools > Fill Holes 
 
 
 

Tools > Scan Tools > Triangulate 
 

What 

The Triangulate command creates poly-faces by connecting points within 3D scan data to construct 
mesh. A target can be entire point clouds or individually selected poly-vertices in a point cloud. 
 
Point clouds scanned and produced by 3D scanners can be used directly for measuring and 
visualizing. Using only a point cloud can be difficult to represent a shape and lacks information for 
further design stages. Triangulation is a typical process used for creating geometric shape 
information from a raw point cloud. 
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Why 

The Triangulate command is useful for: 

• Converting point cloud to 3D mesh models with geometric shape information 

• Creating basic geometric shape information used for creating CAD model 

• Creating basic geometric shape information used for evaluating the shape of a model 

• Creating basic geometric shape information used for modifying an original feature shape 

 
 

How to Use 

A. How to create a mesh model from point cloud which side-wall 
shapes exist 
1. Go to Tools > Scan Tools > Triangulate or click the icon in the toolbar. 

 
2. Click the Point Cloud button and select a point cloud. 

 
 

Note:  

This example assumes that a target point cloud is a single point cloud combined by multiple 
scans that have been scanned in different scanning directions and that it cannot be projected 
onto any virtual plane. 

 
 

3. Choose the 3D Triangulate method. The Estimate button automatically calculates the distance 
between points and displays them in the Distance Criteria To Connect Vertices box. 
 

4. Click OK to complete the command. Check the results. 
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B. How to create a mesh model from point clouds which side-wall 
shapes doesn’t exist 
1. Go to Tools > Scan Tools > Triangulate or click the icon in the toolbar. 

 
2. Click the Point Cloud button and select a point cloud. 

 
 

Note:  

This example assumes that target point clouds are multiple scans that have been scanned in 
different scanning directions and that they can be projected onto a virtual plane. 

 
 

3. Choose the 2D Triangulate method. 

 
 

4. Click OK to complete the command. Check the results. 
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Options in Detail 

Target Entities 

Point Clouds – Selects point clouds or poly-vertices. 
 

Note:  

This option allows the selection of not only multiple point clouds, but also poly-vertices. Selected point 
clouds and poly-vertices can be used to create a polygonal mesh on partial areas of point clouds. 

 
 

Methods 

This command features 4 methods: 

• 2D Triangulate 

Generates a polygonal mesh by projecting a point cloud onto a virtual plane or sphere 

• 3D Triangulate 

Generates a polygonal mesh by connecting points in a point cloud in 3D space 

• Mesh Construction 

Generates a polygonal mesh by following the geometric shape of a point cloud  

• New Mesh Construction 

Generates a polygonal mesh by using voxel data structures 

 
2D Triangulate – Generates a polygonal mesh from a point cloud by using projection and 
repositioning. Poly-vertices in three dimensional space are projected onto a plane or sphere 
specified by a user and triangulated to projected vertices which are repositioned to their original 
position. 

 
Point Cloud Projection Triangulation Reposition 

 
Planar – Projects poly-vertices onto a virtual plane and generates poly-faces. This method 
can be used when 3D scan data is scanned in a single direction. 

 
 

Scan Direction – Projects in a scanning direction shown as an arrow on a point 
cloud in the Model View. Reverse the projection direction by clicking an arrow on 
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the model. If point clouds do not have normal information, click the Find Scan 
Direction button. 
 
Current Viewing Direction – Projects in the current viewing direction in the Model 
View. 

 
Spherical – Projects poly-vertices onto a virtual sphere from the center point of 3D scan 
data and generates poly-faces. This method is used to triangulate sphere-like 3D scan data 
files obtained by specific scanner types like long-range laser scanners. 

 
 

Input Center Manually – Specifies a center position manually. 
 

Note:  

The center point of 3D scan data follows the origin in the world coordinate system (X: 0, 
Y: 0, Z: 0) by default. In case where the 3D scan data was transformed before triangulation, 
input new X, Y, Z coordinate values according to the transformation information. 

 
Face Removal Criteria – Filters irregular poly-faces while executing 2D triangulation. 

 
Maximum Edge Length Is Larger Than – Removes poly- faces that have a longest 
edge length longer than a specified value. 
 
Area Is Larger Than – Removes poly-faces that have an area larger than a specified 
value. 
 
Max/Min Edge Length Ratio Is Larger Than – Removes poly-faces that have a 
maximum and minimum length ratio between its longest edge and shortest edge 
that is larger than a specified value. 

 
 
Angle Between Projection Direction And Face Normal Direction Is Larger Than 
–Removes poly-faces that have an angle between a projection direction and a poly-
face normal that is larger than a specified criteria. 
 

3D Triangulate – Generates a polygonal mesh from a point cloud by connecting poly-vertices. 
This method starts generating small poly-faces from closest poly-vertices and propagates 
triangulation to adjacent poly-vertices. This method is useful for generating polygonal mesh 
from a point cloud that has multiple scans combined from different directions that cannot be 
projected onto a virtual plane or sphere. 
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Point Cloud 1st Triangulation 2nd Triangulation 3rd Triangulation 
 

Distance Criteria To Convert Vertices – Specifies distances between poly-vertices to 
connect them and generate poly-faces. 

 

Note:  

The Estimate button estimates distances between poly-vertices and displays the results in a 
criteria list box. The results are representative values of average distance of a point cloud. To edit 
values, double-click it. If another value needed, click the Add button. 

 

 
Mesh Construction – Generates poly-faces by following the geometric shape of a point cloud. 
This method is useful for generating polygonal mesh from a point cloud that has multiple 
combined directional scans that cannot be projected onto a virtual plane or sphere or when 
results are required to be constructed by poly-faces with uniform poly-edge lengths. 
 

Geometry Capture Accuracy – Defines geometry capture accuracy. When the slider is 
moved towards Loose, less poly-faces will be used to create a shape. When the slider is 
moved towards Tight, more poly-faces will be used to create a shape. 

  

Loose Tight 

 
Scanner Accuracy – Specifies the accuracy of a scanner. Specify a value by referring to the 
specification of a particular scanner. For example, if target 3D scan data is scanned by a 
small/medium object scanner, the default value of 0.05 mm is suitable. If target 3D scan 
data is scanned by a long-range laser scanner, increase the value based on the precision of 
the scanner. 
 

Note:  

In general, if scan data is clean with a low level of noise, has a regular density, and also has 
satisfactory align accuracy, then using the maximum value of the 'Scanner Accuracy' slider will 
preserve and use most points just as they are. 

Each decreased step in the slider will decrease the creation of meshes by approximately a half of 
the previous step. The result will not be a uniform reduction and high curvature regions will be 
preserved, which is similar to applying a 50% decimation.  

For example, the following combinations create almost the same results:  

- 'Scanner Accuracy' is 0.05mm and 'Geometry Capture Accuracy' is at the 4th step 

- 'Scanner Accuracy' is 0.0333mm (0.05 / 1.5) and 'Geometry Capture Accuracy' is at the 3th step 

- Scanner Accuracy' is 0.075mm (0.05 x 1.5) and 'Geometry Capture Accuracy' is at the 5th step 
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New Mesh Construction – Generates poly-faces by using voxel data structures. This method is 
useful for generating polygonal mesh from a point cloud that does not have many open 
boundaries. This method is also quicker and can produce better results than the Mesh 
Construction method. 
 

Note:  

To get satisfactory results from the New Mesh Construction method, scan data must have normal 
information and using a mesh that has few open boundaries is ideal because the algorithm 
extends boundaries beyond their initial settings. The New Mesh Construction method keeps 
normal information consistent on connected triangles and can be useful for long range scan 
data and scan data with no boundaries. 

 
Global Shape Fitting Resolution – Controls how many voxel structures are used to create 
a resulting mesh. The higher the voxel structure count, the more control points can be 
used to represent the original shape of the scan data.  

 
Shape Fitting To Source Data – Defines geometry capture accuracy. When the slider is 
moved towards Loose, less poly-faces will be used to create a shape. When the slider is 
moved towards Tight, more poly-faces will be used to create a shape. 

 

More Options 

Remove Original Data – Removes original point cloud after triangulation. 
 
Suppress Result In Feature Tree – Suppresses results from the Feature Tree. 
 

Note:  

The Suppress and Unsuppress mechanisms manage data memory by swapping data dynamically 
between physical memory and a hard disk. This function is useful for effectively managing and handling 
a large 3D scan data file. 

Created Features can be suppressed or unsuppressed by checking the box next to the feature name in 
the Feature Tree. 

  
Unsuppressed Suppressed 

 

 
Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all selected 
data will be used. When the ratio is 50%, half of the selected data will be used. 
 
Assume Vertices Are Densely Placed Along A Direction – Samples redundant poly-vertices 
closed by a certain distance for better triangulation results. Check this option when target 3D 
scan data is scanned by a line laser with a CMM/Arm device. 
 
Crease Angle – Specifies a maximum angle between normal vectors of adjacent poly-faces to 
avoid generating abnormal poly-faces. 
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Angle between Normal Vectors of 

Adjacent Poly-Faces 

 
Reduce Noise – Reduces noisy poly-faces. 

  

Without Reduce Noise option With Reduce Noise option 

 
Remove Redundant Points – Removes redundant poly-vertices closed by a certain distance for 
better triangulation results. 
 
Make Single Mesh – Merges selected point clouds into a single mesh after triangulation and is 
only available if two or more point clouds exist. 

  
Without Make Single Mesh With Make Single Mesh 

 
Noise Reduction Sampling – Reduces noise using a sampling algorithm. 
 
Create Watertight Mesh – Closes boundaries using the curvature of scan data.  
 

Curved – Creates a closed curved boundary at open boundaries. 
 
Flat – Creates a closed flat boundary at open boundaries. 

 
 

 
 

See Also 

Tools > Scan Tools > Mesh Buildup Wizard 
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Tools > Scan Tools > Align Between Scan Data 
 

What 

The Align Between Scan Data command aligns two or more 3D scan data sets scanned in different 
scanning directions based on geometric feature shape information. 

 
 
 

Why 

The Align Between Scan Data command is useful for: 

• Completing a model from multiple 3D scan data files scanned in different scanning directions 

• Effectively managing a large amount of 3D scan data and re-arranging them 

 
 

How to Use 

A. How to align multiple 3D scan data files automatically 
1. Go to Tools > Scan Tools > Align Between Scan Data or click the icon in the toolbar. 

 

Note:  

To apply this command to 3D scan data, the target 3D scan data should not have child 
entities. 

 
 

2. Check the Local Based On Auto Guess option, and then select all scans for Moving. 
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3. Click the Apply button and check the results. 

 
 
 

B. How to align multiple 3D scan data manually 
1. If scans fail during auto guessing, manually align them using the Local Based On Picked 

Point method. 
 
Check the Local Based On Picked Point option and select aligned scans for Reference 
and select failed scan shots for Moving. 

 
 

 
 

2. Manually pick corresponding points on 3D scan data in the Reference and Moving 
window. To cancel the last picking point, go to Edit > Undo or use the Ctrl + Z keyboard 
shortcut. 
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3. Click the Apply button to apply manual alignment. 

 
 
 

C. How to align multiple 3D scan data files accurately 
1. Accurately align roughly aligned scans by using the Local Based On Auto Guess or 

Local Based On Picked Point methods. 
 
Check the Global And Fine option and select all scans for Moving. 

  
 

2. Click the Apply button. 
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3. Click Avg. Deviation in the Accuracy Analyzer ™ panel to confirm deviation among 
meshes. Deviation results and a histogram can be displayed by selecting entities in the 
Entity Thumbnail pane. 

   

4. Click OK to complete the command. 
 
 

Options in Detail 

Methods 

This command features 3 methods: 

• Local Based On Auto Guess 

Automatically aligns scans based on geometric feature shape information 

• Local Based On Picked Point 

Manually aligns scans by using corresponding points 

• Global And Fine 

Aligns scans based on geometric feature shape information with the lowest amount of deviation 
possible in overlapping areas 

 
Local Based On Auto Guess – Automatically aligns scans. 
 

Reference – Selects scans to define as reference entities. 
 

Moving – Selects scans to define as moving entities. One or more scans should be 
registered for Moving to execute the command. 

 
More Options 

 
Preference – Adjusts operation preferences. To quickly align scans, move the slider 
towards Speed, and if it fails, move the slider towards Quality. 
 
If Features Are Sufficient In Overlapped Regions – Used when scans have 
sufficient features in overlapped areas. If overlapped areas are flat or smooth without 
features, do not use this option. 
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Alignment Order – When the target scans are scanned in a certain scanning order, 
use this option for more accurate alignment.  
By Name aligns by naming order. 
By Selection aligns by selection order. The selection order can be changed in the list 
box under Moving using the Up and Down buttons . 
 

 
 
Do Not Align Between Moving Object – Applies alignment by scan groups. 

  
Reference Group Moving Group – aligned scans 

 
Local Based On Picked Point – Manually aligns scans. Select scans for Reference and for 
Moving, and pick corresponding points in the Reference and Moving windows. 
The corresponding points are required to be defined for Reference and Moving entities to apply 
this method. This method can be used when scans fail in the Local Based On Auto Guess method 
or when scans are needed to be aligned manually. 

 
 

Refine Alignment – Applies best-fit alignment to areas around defined corresponding 
points after the Local Based On Picked Point method is applied. 
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Global And Fine – Aligns scans based on geometric feature shape information with the lowest 
amount of deviation possible in overlapping areas. This method can be used after the Local 
Based On Auto Guess or Local Based On Picked Point methods are applied to scans for more 
accurate alignment. 
 

Partial – Selects scans to define as partial entities. 
 

Note:  

Poly-vertices selected from at least two different 3D scan data files are need as Partial to apply 
this command. The partially selected poly-vertices are used to calculating the fine alignment. 

Statistical results such as average, standard deviation, RMS for Global And Fine alignment are 
listed in the Console panel after alignment. 

 

 
Global Options 

 
Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, 
all selected data will be used. When the ratio is 50%, half of the selected data will be 
used. 
 
Max. Iteration Count – Specifies a maximum iteration value. 
 
Max. Average Deviation – Specifies a maximum average deviation. 
 

Note:  

The Max.Iteraction Count and Max.Average Deviation options interactively affect each 
other. For example, if both options are applied to the alignment, it performs until the 
defined maximum average deviation is satisfied within the maximum iteration count. 

 
Apply Only Small Transform – Applies small transform only if overlapped areas 
are assumed to be well aligned or if alignment is difficult to be performed due to 
lack of feature shapes that can be referred to on the overlapped areas. 
 
Use Only Reliable Scan Data – Uses only reliable 3D scan data or only effective 
overlapped scan areas for better alignment. 

 
Constraint Options – Fixes the translation or rotation of the X, Y, or Z axes for Moving 
entities. 
 
Update View & Histogram – Used to view the alignment process in the Model View and 
to update the histogram in real-time. 
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See Also 

Tools > Scan Tools > Mesh Buildup Wizard 
Tools > Scan Tools > Transform Scan Data 
 
 
 

Tools > Scan Tools > Merge 
 

What 

The Merge command merges multiple point clouds or meshes and creates a single mesh. During 
the merging process, overlapped areas will be removed efficiently and neighboring boundaries are 
stitched together. 

  
 
 

Why 

The Merge command is useful for: 

• Merging multiple 3D scan data into a single mesh 

 
 

How to Use 

How to merge multiple 3D scan data into a single mesh 
1. Go to Tools > Scan Tools > Merge or click the icon in the toolbar. 

 

Note:  

To apply this command to 3D scan data, a target 3D scan data should not have child entities. 

 
 

2. Click the Mesh / Point Cloud button and select entities to merge them. 
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3. Choose Surface Merge and click the OK to complete the command. 

 
 

Note:  

Deviation between original data and a merged mesh can be viewed in the Accuracy Analyzer 
™ panel. 

 

 
 

Options in Detail 

Target Entities 

Mesh / Point Cloud – Selects meshes or point clouds. 
 

Methods 

This command features 3 methods: 

• Surface Merge 

Merges scans by their boundaries by removing overlapping areas 

• Volume Merge 

Generates polygonal mesh by reconstructing geometries scans with 3D volume 

• Mesh Construction 

Generates a polygonal mesh by following the geometric shape of a target 3D scan data 

 
Surface Merge – Detects overlapping areas in target scans and merges the scans by their 
boundaries by removing the overlapping areas. This method can be applied to meshes only. It is 
useful for preserving the original position of poly-faces on a target 3D scan data and merging 
them by deleting only the overlapping areas. 



Geomagic Design X | Menu  556 
 

 
Overlapped Meshes Removing Common Area Zipping Gap 

 
Geometry Capture Accuracy – Defines geometry capture accuracy. When the slider is 
moved towards Loose, less poly-faces will be used to create a shape. When the slider is 
moved towards Tight, more poly-faces will be used to create a shape. 

  

Loose Tight 

 
Estimated Num. Of Faces – Estimates the total number of poly-faces after a merging is 
completed. 

 
Volume Merge – Divides the 3D volume of target scans by a specified resolution and generates 
a polygonal mesh by reconstructing geometries of the scans within the volume. This method can 
be applied to meshes and point clouds that have normal information. It is useful for generating 
a smooth polygonal mesh when 3D scan data has complex boundaries or has been badly 
aligned. 
 

 
Overlapped Meshes Reconstruction  

 
Current Average Edge Length – Shows the current average edge length of poly-edges 
from selected meshes. 
 
Edge Length Multiplier – Specifies an edge length multiplier. 

  

Original Edge Length Edge Length Multiplier: 2 
 
Target Average Edge Length – Defines the average length of poly-edges after merging 
using a specified value. The size of poly-faces of results will be determined according to a 
defined target average edge length. The average edge length of poly-faces can be control 
by either the Edge Length Multiplier or the Target Average Edge Length options. 
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Mesh Construction – Combines target scans and reconstructs a polygonal mesh by following 
the geometric shape of the target 3D scan data. This method can be applied to both point clouds 
and meshes. It executes the Triangulate and Merge methods simultaneously by following the 
geometric shape of scan data. 
 

Scanner Accuracy – Specifies the accuracy of a scanner. Specify a value by referring to the 
specification of a particular scanner. For example, if target 3D scan data is scanned by a 
small/medium object scanner, the default value of 0.05 mm is suitable. If target 3D scan 
data is scanned by a long-range laser scanner, increase the value based on the precision of 
the scanner. 
 

Note:  

In general, if scan data is clean with a low level of noise, has a regular density, and also has 
satisfactory align accuracy, then using the maximum value of the 'Geometry Capture Accuracy' 
slider will preserve and use most points just as they are. 

Each decreased step in the slider will decrease the creation of meshes by approximately a half of 
the previous step. The result will not be a uniform reduction and high curvature regions will be 
preserved, which is similar to applying a 50% decimation.  

For example, the following combinations create almost the same results:  

- 'Scanner Accuracy' is 0.05mm and 'Geometry Capture Accuracy' is at the 4th step 

- 'Scanner Accuracy' is 0.0333mm (0.05 / 1.5) and 'Geometry Capture Accuracy' is at the 3th step 

- Scanner Accuracy' is 0.075mm (0.05 x 1.5) and 'Geometry Capture Accuracy' is at the 5th step 

 
 

More Options 

Remove Original Data – Removes original 3D scan data after merging. 
 
Suppress Result – Suppresses results from the Feature Tree. 
 

Note:  

The Suppress and Unsuppress mechanisms manage data memory by swapping data dynamically 
between physical memory and a hard disk. This function is useful for effectively managing and handling 
a large 3D scan data file. 

Created Features can be suppressed or unsuppressed by checking the box next to the feature name in 
the Feature Tree. 

  
 

Unsuppressed Suppressed 
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Scale Of Overlap Region Deviation Criteria – Sets the scale deviation criteria for overlapping 
areas. When target 3D scan data has a thinner thickness than its average edge length, scale the 
deviation criteria down to avoid merging poly-faces between the front and back sides. 
 
Large Data Mode – Internally divides target 3D scan data into sub models and manages large 
data files by unloading and loading between the physical memory and the hard drive during 
calculation. 
 
Remove Sharp Poly-Faces – Removes sharp poly-faces that may be generated during the 
merging. 
 
Reduce Noise – Reduces noisy poly-faces. If you use clean mesh that have no noise. Uncheck 
this option to avoid noisy results. 

  

Without Reduce Noise option With Reduce Noise option 

 
Remove Redundant Points – Removes redundant poly-vertices closed by a certain distance for 
better triangulation results. 
 
Create More Dense Mesh Around Boundary – Creates dense poly-faces around the boundary 
when constructing a mesh. 
 

 
 

See Also 

Tools > Scan Tools > Mesh Buildup Wizard 
Tools > Scan Tools > Combine 
 
 
 

Tools > Scan Tools > Combine 
 

What 

The Combine command combines selected point clouds or meshes as a single point cloud or a 
mesh without reconstructing entities. 
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Why 

The Combine command is useful for: 

• Combining multiple point clouds into a single point cloud 

• Combining multiple meshes into a single mesh 

 
 

How to Use 

How to combine multiple meshes into a single mesh 
1. Go to Tools > Scan Tools > Combine or click the icon in the toolbar. 

 

Note:  

To apply this command to 3D scan data, the target 3D scan data should not have child entities. 

 
 

2. Select meshes. 

 
 

3. Click OK to complete the command. 

 
 
 

Options in Detail 
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Type To Combine 

Choose either a Point Cloud or Mesh as an entity type. 
 

Target Entities 

Selects point clouds or meshes. 
 

Remove Overlap Region – Removes overlapped areas. 
 

   
Before Combining Combine Without Remove 

Overlapped Areas 
Combine With Remove  

Overlapped Areas 
 

 
 

See Also 

Tools > Scan Tools > Mesh Buildup Wizard 
Tools > Scan Tools > Merge 
 
 
 

Tools > Scan Tools > Decimate Meshes 
 

What 

The Decimate Meshes command reduces the number of poly-faces by merging poly-vertices while 
preserving geometric feature shapes. This command can be applied to multiple 3D scan data at one 
time. 

 
 
 

Why 
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The Decimate Meshes command is useful for: 

• Reducing the number of poly-faces 

• Increasing the size of poly-faces from meshes 

• Dealing with a large number of meshes in follow-up modeling processes while maintaining an 
original shape 

 
 

How to Use 

How to reduce the number of poly-faces of a mesh 
1. Go to Tools > Scan Tools > Decimate Meshes or click the icon in the toolbar. 

 
 

Note:  

To apply this command to meshes, the target meshes should not have child entities. 

 
 

2. Check the Poly-Face Count option and set the Reduction Ratio to 70 %. 
 

3. Click OK to complete the command. 

 
 
 

Options in Detail 

Target Entities 

Target Mesh – Selects target meshes. 
 

Methods 

This command features 2 methods: 

• Poly-Face Count 

Reduces the number of poly-faces by controlling the target poly-face count 

• Allowable Deviation 

Reduces the number of poly-faces within an allowable deviation 
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Poly-Face Count – Reduces the number of poly-faces by using parameters specified by the 
Target Poly-Face Count or Reduction Ratio options. 
 

Target Poly-Face Count – Determines the target number of poly-faces. This option can 
be used only when a single mesh is selected. 

  

Original Face Count: 14,703 Target Face Count: 5,228 
 

Reduction Ratio – Determines reduction ratio. 

   

Original Data Reduction Ratio: 70% Reduction Ratio: 30% 
 
High Curvature Area Resolution – Determines resolution in high curvature areas of a 
target mesh. 

 

Original Data 
 

 

High Curvature Area Resolution: Sparse 
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High Curvature Area Resolution: Dense 
 
Allowable Deviation – Reduces the number of poly-faces within an allowable deviation 
between an original shape and decimated results. 
 

More Options 

Do Not Move Poly-Vertices – Preserves the original position of poly-vertices during 
decimation. 
 
Do Not Modify Boundaries – Preserves the original shape of boundaries during decimation. 

   

Original Data Check Option Uncheck Option 
 
Regularize Poly-Faces – Regenerates poly-faces with uniform poly-edge lengths. 
 

Note:  

The calculation time for this command may be highly increased with this option. 

 
Large Data Mode – Internally divides target 3D scan data into sub models by unloading and 
loading between the physical memory and the hard drive during the calculation. This option is 
useful when dealing with huge numbers of meshes. 

 
 

See Also 

Tools > Scan Tools > Mesh Buildup Wizard 
Tools > Mesh Tools > Decimate 
 
 
 

Tools > Scan Tools > Normal Information Manager 
 

What 

The Normal Information Manager command generates, reverses, and removes normal 
information from 3D scan data. 
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Why 

The Normal Information Manager command is useful for: 

• Correcting the normal information of scan data 

• Creating a defect-free mesh that has no abnormal poly-faces 

 
 

How to Use 

How to generate normal information into point clouds 
1. Go to Tools > Scan Tools > Normal Information Manager or click the icon in the toolbar. 

 

Note:  

To apply this command to 3D scan data, the target 3D scan data should not have child entities. 

 
 

2. Select all point clouds. 

 
 

3. Click OK to complete the command. 

 
 
 

Options in Detail 
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Methods 

This command features 3 methods: 

• Generate 

Generates normal information 

• Reverse 

Reverses the normal information of 3D scan data 

• Remove 

Removes normal information from point clouds 

 
Generate – Generates normal information into a target point cloud. 
 

Except Point Clouds Which Have Vertex Normal – Preserves existing normal information 
and is useful when target point clouds are mixed with multiple point clouds that have 
normal information and do not have normal information. 

 
Reverse – Flips the normal information of point clouds, meshes, and poly-vertices/faces. 
 
Remove – Removes normal information from a point cloud. 

 
 

See Also 

Tools > Scan Tools > Mesh Buildup Wizard 
Tools > Mesh Tools > Find Defect 
Tools > Mesh Tools > Healing Wizard 
Tools > Mesh Tools > Fix Normal 
 
 
 

Tools > Scan Tools > Transform Scan Data 
 

What 

The Transform Scan Data command transforms 3D scan data by rotating, translating, scaling or 
using a transformation matrix. 



Geomagic Design X | Menu  566 
 

 
 
 

Why 

The Transform Scan Data command is useful for: 

• Transforming scan data to a specific position 

• Scale scan data up or down 

 
 

How to Use 

How to transform 3D scan data to a specific position 
1. Go to Tools > Scan Tools > Transform Scan Data or click the icon in the toolbar. 

 

Note:  

To apply this command to 3D scan data, the target 3D scan data should not have child entities. 

 
 

2. Select point clouds or meshes. 

 
 

3. Click the Next Stage button. 
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4. Transform the scan data using the manipulator on the screen. 

 
 

5. Click the OK button to complete the command. 
 
 

Options in Detail 

Target Entities 

Target Scan Data – Selects a point cloud or mesh. 
 

Methods 

This command features 3 methods: 

• Rotate And Translate 

Transforms 3D scan data by rotating and translating 

• Scale 

Transforms 3D scan data by scaling 

• By Matrix 

Transforms 3D scan data by using a transformation matrix 

 

Rotate And Translate – Transforms target 3D scan data by rotating and translating with 
manipulators for the X, Y and Z coordinates. 
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Use Local Coordinate – Uses an existing Ref.Coordinate as a local coordinate. 

 
Rotate – Selects rotational values for the X, Y and Z coordinates. 

 
Translate – Selects translation values for the X, Y and Z coordinates. 

 

Scale – Scales scan data from its center, global origin, or by a custom position. 

 
Uniform Scale – Scales target scan data along the X, Y and Z directions concurrently. 

 
 

  
Uniform Scale Non-uniform Scale 

 
Unit Converter – Converts scale value using the From and To options. 

 

Note:  

When the Uniform Scale is manually defined, the Unit Converter will be changed by 
default. The default unit follows the Default Measure Unit defined in the General Tab within 
Preferences (File > Preferences). 

 
Scale Center – Selects a center position of scale. 

 

Note:  

Global Origin, the global coordinate, Mesh Center, the center of mesh, or Custom, the custom 
origin, can be defined. 

   
 

 
By Matrix – Defines the transformational values in a transformation matrix. 

 
 
Apply Matrix File – Import a transformation matrix file using the Matrix File Open button and 
applies it to the current coordinates of a model. 
 

Set – Applies an imported matrix. 
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Multiply – Multiplies an imported matrix. 

 
Inverse Multiply – Inverses and multiplies an imported matrix. 

 
Transpose – Transposes an imported matrix. 

 
 

See Also 

User Interface > Docking Bars > Properties 
Tools > Mesh Tools > Mirror 
Insert > Modeling Feature > Transform Body 
 
 
 

Tools > Scan Tools > Average Meshes 
 

What 

The Average Meshes command averages meshes and creates a mesh or feature shape that can be 
used as a master part. 

 
 
 

Why 

The Average Meshes command is useful for: 

• Creating a master part model from multiple 3D scans 

• Finding a master feature shape from patterned feature shapes 

 
 

How to Use 

A. How to create a master part model from multiple 3D scans 
1. Go to Tools > Scan Tools > Average Meshes or click the icon in the toolbar. 

 

Note:  
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To apply this command to meshes, the target meshes should not have child entities. 

 
 

2. Select all target meshes. 

 
 

3. Click the Next Stage button. The result will be shown with its deviation color map. 

 
 

4. Click the OK button to complete the command. Hide other meshes. 

  
 
 

B. How to find a master feature shape from patterned feature shapes 
1. Go to Tools > Scan Tools > Average Meshes or click the icon in the toolbar. 

 
2. Select all freeform regions. 

 
 

3. Check the Align Patterned Targets option and then check the Circular Pattern option. 
 

4. Click the Estimate button to define a rotation axis and its center position. 
 

5.  Check the Refine Alignment option to align selected feature shapes. 
 

Note:  

Selected feature shapes will be aligned by using a defined axis, axis center, and offset angle to 
average and create a master feature shape from them. 
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3. Click the Next Stage button. The result will be shown with its deviation color map. 

 
 

4. Click the OK button to complete the command. Hide the original mesh. 

 
 
 

Options in Detail 

Stages 

This command consists of 2 stages : 

• Define Targets stage 

Defines target meshes or feature shapes 

• Check Deviation stage 

Checks results using a deviation color map 

 
 

Stage 1/2 – Define Targets 

Target – Selects meshes or feature regions. 
 

Reference – Defines reference entities from selected entities. Otherwise, an entity that has 
a minimum deviation will be chosen as a reference entity from selected entities by default. 
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Note:  

Other selected entities will be aligned into the reference and then an averaged entity will be 
created from the reference. 

 
Max. Deviation – Specifies a maximum distance that can be deformed from a reference entity. 
 

Weighted Average – Assigns more weight to poly-vertices that are located near the same 
position among target meshes and reduces the effect of outliers. 

 
Align Patterned Targets – Transforms targets that are pattern shaped to a position and then 
calculated the averaged shape. 
 

Circular Pattern – Specifies the parameters of a circular pattern such as: Axis, Axis Center 
and Offset Angle. These parameters can be automatically calculated by clicking the 
Estimate button. 

 
 
Linear Pattern – Specifies the parameters of a linear pattern such as: Direction 1 and 
Direction 2. These parameters can be automatically calculated by clicking the Estimate 
button. 

 
 
Refine Alignment – Performs a best-fit alignment to well align meshes after targets are 
internally collected on a position. 

 
Use Selected Data Only – Defines partial areas on a reference entity. The best-fit 
alignment will be performed among target entities by using the selected partial 
areas only. 

Stage 2/2 – Check Deviation 

Target – Checks the deviations between each target entity and an averaged mesh. 
 
Statistics – Checks the statistical results calculated among selected target entities in the Target 
list. According to the Deviation Type, the statistical values and color map can be checked on a 
model. 
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Max. Error Min. Error Avg. Error 
 

 
 

See Also 

Measure > Mesh Deviations 
 
 
 

Tools > Scan Tools > Boolean 
 

What 

The Boolean command uses the Boolean operation to create a difference, intersection, or union 
between two meshes. 

 
 
 
 

Why 

The Boolean command is useful for: 

• Combining multiple scans into a single mesh model by using a Boolean operations such as 
Merge, Cut, or Intersect 

 
 

How to Use 

A. How to merge multiple 3D scans into a single mesh 
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1. Go to Tools > Scan Tools > Boolean or click the icon in the toolbar. 
 

Note:  

To apply this command to meshes, the target meshes should not have child entities. 

 
 

2. Change the method to Merge. Define Tool Mesh and Target Mesh. 

 
 

3. Check the Remove Original Mesh option to remove the original mesh after the 
operation. Click the OK button to complete the command. 

 
 
 

B. How to cut a 3D scan with another 3D scan 
1. Click Tools > Scan Tools > Boolean or click the icon in the toolbar.  

 
2. Change the method to Cut. Define Tool Mesh and Target Mesh. 

 
 

3. Click the OK button to complete the command. 
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Options in Detail 

Methods 

This command features 3 methods: 

• Merge 

Merges two meshes 

• Cut 

Cuts a target mesh by a tool mesh 

• Intersect 

Creates an intersected mesh between a tool mesh and a target mesh 

 
Merge – Merges meshes and create a single mesh. 

  
 
Cut – Cuts a target mesh by a tool mesh. 

  
 
Intersect – Creates an intersected mesh between a tool mesh and a target mesh. 
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More Options 

Remove Original Data – Removes original 3D scan data after merging. 
 
 

See Also 

Insert > Solid > Boolean 
 
 
 

7.5.2. Tools > Mesh Tools 
 
The Mesh Tools menu features various commands used to edit, heal, and generate a complete mesh 
from existing 3D scan data. 
 
Mesh Tools are divided into 4 tool groups used to: 
 

Healing 3D Scan Data 

• Find Defect 

Finds defects in mesh 

• Healing Wizard 

Heals abnormal poly-faces and cleans defects in mesh 

• Fix Normal 

Corrects normal information of poly-faces in mesh 

• Edit Boundaries 

Edits mesh boundaries 

• Sew Boundaries 

Sews mesh boundaries 

 

Optimizing 3D Scan Data 

• Retriangulate 

Regenerates poly-faces based on a mesh 

• Global Remesh 

Regenerates poly-faces with uniform poly-edge lengths on a mesh 
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• Optimize Mesh 

Optimizes mesh based on geometric feature shapes 

• Edit Poly-Edge 

Edits poly-edges on a mesh 

• Virtual Rescan 

Rescans feature shapes and regenerates mesh 

• Rewrap 

Rewraps feature shapes and regenerates poly-faces on a mesh 

 

Editing 3D Scan Data 

• Fill Holes 

Fills missing holes in mesh 

• Defeature 

Deletes feature shapes and regenerates poly-faces on a mesh 

• Remove Marker 

Removes scanned markers from a mesh 

• Add Poly-Face 

Partially adds poly-faces on a mesh 

• Smooth 

Smooths and reduces the roughness of a mesh 

• Smart Brush 

Interactively edits poly-faces by using a paint brush selection mode 

• Decimate 

Merges and reduces the number of poly-faces 

• Subdivide 

Divides and increases the number of poly-faces 

• Enhance Shape 

Enhances feature shapes of a mesh 

 

Modifying 3D Scan Data 

• Refit 

Refits a mesh to a reference entity 

• Insert 

Converts other entities and inserts into a mesh 

• Split 

Splits a mesh by a tool entity 
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• Trim 

Trims poly-faces on a mesh 

• Mirror 

Mirrors part of a mesh 

• Offset 

Increases or decreases the size of a mesh by a certain distance 

• Thicken 

Thickens mesh 

• Convert Body 

Converts bodies into mesh 

 
 
 

Tools > Mesh Tools > Find Defect 
 

What 

The Find Defect command detects four types of defects: Non-Manifold Poly-Faces, Crossing Poly-
Faces, Redundant Poly-Faces and Tangled or Reversed Poly-Faces. 

  
 
 

Why 

The Find Defect command is useful for: 

• Finding defects in a mesh and deleting them 

• Determining the quality of a generated mesh 

 
 

How to Use 

How to Find defects in a mesh and delete them 
1. Go to Tools > Mesh Tools > Find Defect or click the icon in the toolbar. 
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2. Check that detected defects have different colors and how many defects exist in the 
mesh. 
 

Note:  

To navigate defects, click the left or right     buttons. Detected defects can be 
navigated and directly deleted by using the Navigation Tool Palette. 

 

 
 

3. Click OK to complete the command. All defective abnormal poly-faces will be selected. 

 
 

4. Delete the poly-faces by pressing the Del key or go to Edit > Delete. 

 
 
 

Options in Detail 

Non-Manifold Poly-Faces – Shows the total number of detected Non-Manifold Poly-Faces and 
enables the changing of their displayed colors. 
 
Crossing Poly-Faces - Shows the total number of detected Crossing Poly-Faces and enables 
the changing of their displayed color. 
 
Redundant Poly-Faces – Shows total number of detected Redundant Poly-Faces and enables 
the changing of their displayed color. 
 
Tangled Or Reversed Poly-Faces – Shows total number of detected Tangled or Reversed Poly-
Faces and enables the changing of their displayed color. 
 

Note:  
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Non-manifold Poly-Faces, Redundant Poly-Faces, Crossing Poly-Faces and Tangled Or Reversed Poly-Faces 
are defined as below: 

Non-manifold Poly-Face – When poly-faces share three or more poly-edges, it is referred to as non-
manifold topology. In a pure mathematical term, to be a manifold topology, only two poly-faces can 
constitute a poly-edge. However, a poly-edge with only one poly-face is classified as a boundary poly-
edge in the application and considered to be normal. 

Non-manifold poly-faces may cause severe errors in various calculations, and even fatal errors in other 
applications such as NC machining.  

The right picture shows an example of the non-manifold topology, where poly-faces (V1 V2 V4), (V2 V4 
V3), and (V2 V4 V5) share poly-edges (V2 V4). 

 

Redundant Poly-Face – A redundant poly-face is a type of abnormal poly-face from the viewpoint of a 
poly-vertex. Ignoring boundaries, a poly-vertex must have an identical number of poly-faces and 
connecting poly-edges. 

A poly-face violating this rule is called a redundant poly-face. 

The following picture shows an example of a redundant poly-face (V1 V2 V3). 

 

Crossing Poly-Face – When poly-edges sharing a poly-vertex intersect with one another, they are 
geometrically incorrect and their poly-faces are called crossing poly-faces. 

The following image displays a crossing poly-face. The poly-edge (V2 V3) of poly-face (V1 V2 V3) is 
crossed with the poly-edge (V1 V4). 

Although crossing poly-face is neither a topological definition nor a possible cause of serious problems, 
it may cause errors in geometrical calculations. 

 

Tangled Or Reversed Poly-Face – Every poly-face has normal information. If the normal direction of 
poly-face is opposite to neighboring poly-face, it is a tangled or reversed poly-face. 
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See Also 

Tools > Scan Tools > Normal Information Manager 
Tools > Mesh Tools > Healing Wizard 
Tools > Mesh Tools > Fix Normal 
 
 
 

Tools > Mesh Tools > Healing Wizard 
 

What 

The Healing Wizard command detects abnormal poly-faces in a mesh and automatically heals them. 
When 3D scan data that has been scanned in different directions by using a 3D scanner are aligned 
and merged into a single mesh, some abnormal poly-faces such as folded poly-faces, dangling poly-
faces, and small noisy clusters may occur. To optimize the mesh, the defects on the mesh need to be 
healed. 

 
 
 

Why 

The Healing Wizard command is useful for: 

• Creating an optimal mesh model without any abnormal poly-faces 

• Healing defects 
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How to Use 

How to heal abnormal poly-faces and clean defects from a mesh 
1. Go to Tools > Mesh Tools > Healing Wizard or click on the icon in the toolbar. 

  
2. Abnormal poly-faces will be automatically detected in a mesh and the results will be 

displayed with different colors. Check detected abnormal poly-faces and click the OK 
button to heal them at all the same time. 

 
 

3. Check that all detected defects are healed from the mesh. 

 
 
 

Options in Detail 

Folded Poly-Faces – Automatically checks if poly-faces have been folded in the same place on a 
mesh and that the angle between poly-faces is smaller than a specified value. 
 

Angle Is Smaller Than  – Specifies angle criteria to detect folded poly-faces. 

 
Angle Between Poly-faces 

 

Note:  

When the angle criteria are changed, the number of detected folded poly-faces will be 
automatically updated. 

 
Dangling Poly-Faces – Automatically checks if 2 or 3 sided opened poly-faces exist on the 
boundaries of a mesh. 

  

2 Side Open 3 Side Open 
 
Small Clusters – Checks if a group of connected poly-faces, known as small clusters, have less 
poly-faces than a specified value exist on a mesh. 
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Small Clusters 
 

Poly-Face Count In A Cluster – Specifies count criteria used to detect small clusters. 
 
Small Poly-Faces –Checks if small poly-faces exist that have a smaller area than specified area 
criteria. 

 

Small Poly-faces 
 

Area Is Smaller Than – Specifies area criteria used to detect small poly-faces. 
 
Non-Manifold Poly-Faces – Checks if non-manifold poly-faces and redundant poly-faces exist 
on a mesh. For more information, see Tools > Mesh Tools > Find Defect. 
 
Crossing Poly-Faces – Checks if crossing poly-faces exist in a mesh. 
 

Method – Contains 3 methods used to heal crossing poly-faces. 
 

Smooth – Smooths poly-faces around crossing poly-faces. 
 
Merge Poly-Vertices – Merges poly-vertices of crossing poly-faces. 
 
Delete And Fill Hole – Deletes crossing poly-faces and fills the deleted area. 
 

Small Tunnels – Detects poly-faces shaped like a tunnel or handle, known as small handles. This 
option is automatically checked if small tunnels that have lesser poly-faces than the count criteria 
exist on the mesh. 

 

Tunnel Shape 
 

Poly-Face Count In Tunnel – Specifies the count criteria used to detect small tunnels. 
 
 

See Also 

Tools > Scan Tools > Normal Information Manager 
Tools > Mesh Tools > Find Defect 
Tools > Mesh Tools > Fix Normal 
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Tools > Mesh Tools > Fix Normal 
 

What 

The Fix Normal command harmonizes normal information of poly-faces in a mesh. 

  
 

Why 

The Fix Normal command is useful for: 

• Correcting the normal information of poly-faces to create an optimal mesh 

• Fixing the normal information of poly-faces in tessellated CAD mesh that has been imported 
from neutral file formats such as IGES or STEP 

 
 

How to Use 

How to correct normal information of poly-faces in a mesh 
1. Go to Tools > Mesh Tools > Fix Normal or click the icon in the toolbar. 

 
 

2. Choose the Automatic method and check the Propagate Topologically option. To 
reverse the normal direction manually, choose the Interactive method and pick a seed 
poly-face on the mesh. 
 

3. Pick a seed poly-face on a mesh and check the results. 
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Options in Detail 

Methods 

This tool features 3 methods: 

• Automatic 

Automatically fixes the normal information of poly-faces in a mesh 

• Interactive 

Reverses the normal information of connected poly-faces 

• Entire Mesh 

Reverses the normal information of entire poly-faces in a mesh 

 
Automatic – Fixes the normal information of poly-faces in a mesh by propagating topologically, 
propagating geometrically, or repairing tangled poly-faces. 

   

Propagate Topologically Propagate Geometrically Tangled Poly-Face 
 

Propagate Topologically – Fixes the normal information of poly-faces inside of its 
boundary. 
 

Note:  

Check the Propagate Topologically option if the mesh has no non-manifold poly-faces and the 
boundaries exist in the mesh. 

 
Propagate Geometrically – Fixes the normal information of poly-faces regardless of its 
boundaries. Check the Propagate Geometrically option of a mesh that has disjoined 
poly-edges and non-manifold poly-faces and boundaries that do not exist in the mesh. 
 
Repair Tangled Poly-Faces – Repairs twisted and tangled topology and fixes the normal 
information of poly-faces. The Repair Tangled Poly-Faces option is used to correct the 
twisted topology that may occur when triangulating 3D scan data which has thin walls. 
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Interactive – Reverses the normal information of connected poly-faces. 
 
Entire Mesh – Reverses the normal information of entire poly-faces in mesh. 

 
 

See Also 

Tools > Scan Tools > Normal Information Manager 
Tools > Mesh Tools > Find Defect 
Tools > Mesh Tools > Healing Wizard 
 
 
 

Tools > Mesh Tools > Edit Boundaries 
 

What 

The Edit Boundaries command edits the boundaries of mesh. This command features multiple 
boundary editing methods such as Smooth, Shrink, Fit, Extend, Extrude, and Fill. 

 
 
 

Why 

The Edit Boundaries command is useful for: 

• Reducing the effect of noise and roughness on mesh boundaries 

• Modifying the feature shapes of mesh 

• Creating a CAD-like mesh 

 
 

How to Use 

How to edit mesh boundaries 
1. Go to Tools > Mesh Tools > Edit Boundaries or click the icon in the toolbar. 

 
2. Choose the outer boundary of a mesh as the target Boundaries. 
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3. Choose the Fit method and define the Fitting Shape as Rectangle. 
 

4. Click the OK button and check the results. 

 
 
 

5.  Run the Edit Boundaries command again. 
 

6.  Choose the fitted outer boundary as the target Boundaries. 

 
 

7. Choose the Extrude method and set the Distance to -10mm and then check the Cap 
option to close the bottom of the mesh. 

 
 

8. Click the OK button to complete the command. 
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Options in Detail 

Target Entities 

Boundaries – Selects boundaries of mesh. The Split Boundary button splits a boundary at 
selected positions. This button is useful for partially editing boundaries of a mesh. 

  

Before splitting boundary After splitting boundary 
 

Methods 

This command features 6 methods: 

• Smooth 

Reduces the effects of roughness on a boundary 

• Shrink 

Removes poly-faces from boundary 

• Fit 

Fits a boundary to a specific feature shape 

• Extend 

Extends a boundary by a specific distance 

• Extrude 

Extrudes a boundary by a specific distance 

• Fill 

Fills poly-faces in a boundary 

 
Smooth – Reduces noises and effect of roughness in boundary of mesh. 
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Original Boundary Smooth Boundary 
 

Select N-Depth From Boundary – Specifies the influence range of the smoothing effect 
from a target boundary. The influence range will be highlighted on a mesh interactively 
with this option. 

 
Shrink – Removes poly-faces from a boundary. 

  

Original Boundary Shrink Boundary 
 

Note:  

3D scan data may have roughness and noise in the area near a boundary caused by shadows or 
vibrations during the scanning process. These defects may adversely affect the alignment between scan 
data as well as the merging process. To get better results in scan data processing, defects in the 
boundaries of mesh should be cleaned. 

 
Select N-Depth From Boundary – Specifies the influence range of the shrinking effect 
from a target boundary. The influence range will be highlighted on a mesh interactively 
with this option. 

 
Fit – Fits a boundary to specific feature shapes such as Circle, Slot, Rectangle, Polygon and 
Freeform. 
 

Fitting Shape – Defines specific features for a boundary to be fit to. 
 

Auto – Automatically recognizes a feature shape within an allowable tolerance. 

  
 
Circle – Defines a boundary fitted feature shape as a circle. 
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Slot – Defines a boundary fitted feature shape as a slot. 

  
 
Rectangle – Defines a boundary fitted feature shape as a rectangle. 

  
 
Polygon – Defines a boundary fitted feature shape as a polygon. 

  
 
Freeform – Defines a boundary fitted feature shape as a freeform shape. 

  
 

Allowable Tolerance – Specifies allowable tolerance for extracting a feature shape from a 
boundary. If any feature shape cannot be matched with a boundary a freeform shape will 
be chosen. 
 

Note:  

This option can be used only when the Fitting Shape option is set to Auto. Click the Estimate 
button and the best tolerance will be automatically calculated based on the shape of the 
selected target boundaries. 

 
Fitting Type – Creates a best-fitted value by the least square fitting method when the Best 
Fit option is selected. The least squares method is the approximate solution from 
distributed data. The Min. Bound option finds the smallest radial distance value between 
a pair of concentric circles, and Max. Bound finds the largest value. 
The Hole method is available when the fitting type is set to Auto or Circle. This option finds 
an inscribed circle from poly-vertices around a boundary. 
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Best Fit Min Boundary & Max 

Boundary 
Hole 

 
Remove Outlier – Removes outlier data to achieve more accurate fitting results. 
The N*Sigma method requires an N value and excludes data that is larger than N times the 
standard deviation, also known as the sigma. 
The Ratio method requires a ratio value and only data that falls into the selected value will 
be used. 
The Absolute Distance method requires a distance and the fitting will be done by 
excluding any data outside of that distance. 

 

N Sigma 
 

Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 
 
Use Only Effective Data – Uses only effective data when fitting. Effective data is the actual 
data points used in fitting after sampling and outlier removal. 
 
Rounded Corner – Fits a boundary to a specific feature shape with rounded corners and is 
available when the fitting type is set to Auto, Rectangle or Polygon. 

  

Non-Rounded Corner Rounded Corner 
 
No. Of Edges – Decides the number of edges for a polygonal feature shape and is available 
when the fitting type is set to Auto or Polygon. 

 
Number of edges: 3 

 
Number of edges: 5 
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User Defined Curves – Fits a boundary to user defined curves and is available when the 
fitting type is set to Freeform. 

 

Note:  

When using user-defined curves, the curves need to be prepared before the target mesh feature 
in the Feature Tree. For more information, see Getting Started > Introduction to the Interface > 
User Interface Ovrview. 

 
Smoothness – Defines the smoothness of a boundary shape by using a value between the 
Min and Max limits. It is available when the fitting type is set to Freeform and user-defined 
curves are not selected. 

  

Min. Smoothness Max. Smoothness 
 
Extend – Adds poly-faces around a boundary and extends the shape. The extending distance of 
poly-faces can be controlled using Distance under Extend Options. 

  
 

Distance – Specifies an extending distance. 
 
Refine And Smooth Extended Mesh – Refines poly-faces in an extended area by 
removing crossing poly-faces that can be generated during the extension, and smooths 
poly-faces. 

 
No. Of Smoothing Iterations – Specifies the number of smoothing iterations. 

 
Extrude – Extrudes a boundary by a specified distance or up to a specified plane. The Blind, Up 
To Plane, and Custom extrusion methods are available. 
 

Method – Defines extrusion methods. 
 

Blind – Extrudes a boundary by a specified distance. 

  
 

Cap – Closes a boundary at the end of an extrusion. 
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Up To Plane – Extrudes a boundary up to a specified plane. Ref.Plane, 2D Sketch, and 
planar face can be selected as a target plane. 

  
 
Custom – Extrudes a boundary up to a specific position. The specific position can be 
defined by using a manipulator for the X, Y, and Z coordinates. 

  

 
Fill – Fills poly-faces in a boundary. This option is similar to the Fill Hole command. For more 
information, see Tools > Mesh Tools > Fill Holes. 
 

Flat – Fills a boundary by using flat poly-faces. 
 
Curvature – Fills a boundary by following the curvature flow of poly-faces around a 
boundary. 
 
Merge Splitted Boundaries – Merges split boundaries into a single boundary. 

 ’  

Original Boundary Uncheck ‘Merge Split 
Boundary 

Check ‘Merge Split 
Boundary’ 

 
Smooth Boundary – Refines a boundary for better filling results. 
 
Flatness Of Filled Holes – Adjusts the flatness of a resulting shape in a filled boundary. 

  
Curved Flat 
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See Also 

Tools > Mesh Tools > Sew Boundaries 
Tools > Mesh Tools > Fill Holes 
 
 
 

Tools > Mesh Tools > Sew Boundaries 
 

What 

The Sew Boundaries command sews narrow line type holes in boundaries. 

  
 
 

Why 

The Sew Boundaries command is useful for: 

• Creating an optimal mesh model without any torn boundaries 

• Sewing torn boundaries in tessellated CAD mesh that have been imported from neutral file 
formats such as IGES or STEP 

 
 

How to Use 

How to sew the boundaries of a mesh 
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1. Go to Tools > Mesh Tools > Sew Boundaries or click the icon in the toolbar. 
 

Note:  

To check the boundaries of a mesh in the Model View, check the Boundary option in the Display 
tab. 

 

 
 

2. Click the Estimate button in the Sew If Gap Is Smaller Than option to calculate an 
estimated distance from boundaries. 

 
 

3. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Sew If Gap Is Smaller Than – Specifies a distance for sewing gaps. 

 

More Options 

Merge Close Vertices – Merges poly-vertices in close proximity to each other under a specified 
distance. 
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Before Merged After Merged 
 
Repair Spike Poly-Faces – Repairs spikey poly-faces. 

  
Spike Poly-Faces Repaired Spike Poly-

Faces 
 

 
 

See Also 

Tools > Mesh Tools > Edit Boundaries 
Tools > Mesh Tools > Fill Holes 
 
 
 

Tools > Mesh Tools > Retriangulate 
 

What 

The Retriangulate command removes selected poly-faces and regenerates poly-faces by equalizing 
poly-vertex balance. 

   
 
 

Why 

The Retriangulate command is useful for: 
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• Partially refining poly-faces on a mesh 

 
 

How to Use 

How to recreate poly-faces from a mesh 
1. Go to Tools > Mesh Tools > Retriangulate or click the icon in the toolbar. 

 
2. Select poly-faces on a mesh. 

 
 

3. Click the OK button to complete the command. 

 
 
 

See Also 

Tools > Mesh Tools > Global Remesh 
Tools > Mesh Tools > Optimize Mesh 
Tools > Mesh Tools > Edit Poly-Edge 
Tools > Mesh Tools > Virtual Rescan 
Tools > Mesh Tools > Rewrap 
Tools > Mesh Tools > Smart Brush 
 
 
 

Tools > Mesh Tools > Global Remesh 
 

What 

The Global Remesh command globally regenerates poly-faces with uniform poly-edge lengths on 
a mesh and improves the quality of the mesh. This command also cleans and manifolds solid mesh 
that has no boundaries. 
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Why 

The Global Remesh command is useful for: 

• Optimizing mesh so that it has poly-faces globally with uniform poly-edge lengths 

• Optimizing mesh to be used for creating a high quality surface body 

• Reducing the effects of defects and roughness on a mesh 

• Creating a high quality mesh from combined mesh that is complex and overlapped 

 
 

How to Use 

A. How to recreate high quality poly-faces with uniform poly-edge 
lengths on a mesh 
1. Go to Tools > Mesh Tools > Global Remesh or click the icon in the toolbar. 

 
 

2. Check the Make Clean And Manifold Solid Mesh option to create an optimal mesh 
without any defects and holes. 
 

3. Click the Preview button to check the results. If the results are not satisfactory, click 
Cancel and change the values in the option and try again. 
 

4. Click the OK button to complete the command. 
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B. How to optimize mesh from combined mesh that is complex and 
overlapped 
1. Go to Tools > Mesh Tools > Global Remesh or click the icon in the toolbar. 

 
 

2. Check the Make Clean And Manifold Solid Mesh option to create an optimal mesh 
without any defects and holes. When that is complete check the Assume Combined 
Multiple Scan Data Sets option to merge combined and complex overlapped scan sets 
during the optimizing process. 

 
 

3. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Current Average Edge Length Edge – Shows current average edge length of poly-edges from 
selected meshes. 
 
Length Multiplier – Specifies an edge length multiplier. 
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Original Edge Length Edge Length Multiplier: 2 
 
Target Average Edge Length – Defines average length of poly-edges after merging. 

 
 

More Options 

Make Clean And Manifold Solid Mesh – Generates a watertight mesh that has no holes or 
defects. 

  

Original Data Enable Option 
 

Assume Combined Multiple Scan Data Sets – Merges combined and complexly 
overlapped scan data sets during the optimizing process. Overlapping areas are 
removed with this option. 

  

Original Data Enable Option 
 

 
 

See Also 

Tools > Mesh Tools > Retriangulate 
Tools > Mesh Tools > Optimize Mesh 
Tools > Mesh Tools > Edit Poly-Edge 
Tools > Mesh Tools > Virtual Rescan 
Tools > Mesh Tools > Rewrap 
Tools > Mesh Tools > Smart Brush 
 
 
 

Tools > Mesh Tools > Optimize Mesh 
 

What 
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The Optimize Mesh command optimizes a mesh based on its feature shapes and improves the 
quality of the mesh. This command also offers advanced options to control the size of poly-faces and 
the effects of smoothing a model. 

 
 
 

Why 

The Optimize Mesh command is useful for: 

• Optimizing mesh based on its feature shapes 

• Optimizing mesh to be used for creating a high quality surface body 

• Creating optimized mesh to be used for Finite element analysis, also known as FEA 

 
 

How to Use 

A. How to optimize mesh based on its feature shapes to improve the 
quality 
1. Go to Tools > Mesh Tools > Optimize Mesh or click the icon in the toolbar. 

 
 

2. Choose the High Quality Mesh Conversion method and adjust options in the Size 
Option panel. 
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3. Click the OK button to complete the command. 

 
 
 

B. How to equalize poly-vertex balance in mesh 
1. Go to Tools > Mesh Tools > Optimize Mesh or click the icon in the toolbar. 

 
 

2. Choose the Equalize Poly-Vertex Balance method and set the Max. No. Of Iterations 
to 20. 
 

3. Check the Smooth option to improve the mesh quality. 
 

4.  Click the OK button to complete the command. 
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Options in Detail 

Methods 

This command features 3 methods: 

• High Quality Mesh Conversion 

Optimizes mesh based on its feature shapes and improves the quality of mesh 

• Improve Curvature Flow 

Improves curvature flow and refine the feature shapes 

• Equalize Poly-Vertex Balance 

Equalizes poly-vertex balance to create poly-faces with uniform poly-edge lengths 

 
High Quality Mesh Conversion – Optimizes mesh based on feature shapes and improves the 
quality. It can also be used to control the size of poly-faces and the effects of smoothing a model. 
 

Size Options – Choose either By Multiplier or By Length to define the target size of poly-
faces. 
 

Note:  

To easily define the size of poly-faces and the criteria for regenerating poly-faces, choose the By 
Multiplier size option. To manually define the size of poly-faces, choose the By Length size 
option. 

 

 
Current Average Edge Length – Shows the current average edge length of poly-
edges from a target mesh. 

 
Min. Edge Length Multiplier (Length) – Limits the minimum length of poly-edges 
in poly-faces. 
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Max. Edge Length Multiplier (Length) – Limits the maximum length of poly-edges 
in poly-faces. 

 
Allowable Deviation Multiplier (Deviation) – Limits the deformation of poly-faces 
within the deviation between an original mesh and optimized mesh. 

 
Increasing Mesh Size Rate – Determines the increasing size rate of poly-faces on a 
mesh from small to large poly-faces. 

  

Increasing Ratio: Less Increasing Ratio: More 
 
No. Of Smoothing Iterations – Specifies the number of smoothing iterations. The 
smoothing will be applied to the mesh after the optimizing process. 

 
Regularize The Connectivity By Edge-Flipping – Regularizes the connectivity of poly-
faces by flipping poly-edges to improve the quality of mesh and equalize poly-vertex 
balance. 

 
Preserve Boundary Poly-Vertices – Preserves the position of poly-vertices around 
boundaries. 
 
Do Not Modify Sharp Edges – Preserves sharp poly-edges and is useful for optimizing 
CAD mesh converted from CAD data. 

  

Disable Option Enable Option 
 

Sharp Edge Angle Criteria – Determines the criterion to judge shape poly-edges 
by angles. An edge is regarded as being sharp when the angle between two 
adjacent faces is bigger than a predefined value. Small is set as 40 degrees, large as 
100 degrees and the middle default value is set at 70 degrees. Moving the slider 
towards small will preserve more edges as sharp edges. 

 
Improve Curvature Flow – Improves curvature flow of poly-faces by using curvature 
information on a mesh and refines feature shapes. 
 

Max. No. Of Iterations – Specifies the maximum number of improving iterations. 
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Original Data Improved Curvature Flow 
 
Curvature Sensitivity – Determines the curvature sensitivity. When the sensitivity is set 
to High, the number of switched poly-edges will increase and sharp edges will be 
generated. 

  

Original Data Switched Edges 
 
Equalize Poly-Vertex Balance – Equalizes poly-vertex balance to create poly-faces with uniform 
poly-edge lengths on mesh. 
 

Note:  

Equalized vertex balance is when 6 poly-vertices have been uniformly organized around a center poly-
vertex and the forces of their connectivity have been balanced. 

 

Balanced Poly-Vertex 
 

 
Max. No. Of Iterations – Specifies the maximum number of equalizing iterations. 

 
Smooth – Applies smoothing to a mesh. 

 
Modified Region Only – Applies smoothing to a modified area only. 

 
 

See Also 

Tools > Mesh Tools > Retriangulate 
Tools > Mesh Tools > Global Remesh 
Tools > Mesh Tools > Edit Poly-Edge 
Tools > Mesh Tools > Virtual Rescan 
Tools > Mesh Tools > Rewrap 
Tools > Mesh Tools > Smart Brush 
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Tools > Mesh Tools > Edit Poly-Edge 
 

What 

The Edit Poly-Edge command edits poly-edges manually by swapping, merging, subdividing, 
inserting, and moving poly-vertices. 

 
 
 

Why 

The Edit Poly-Edge command is useful for: 

• Manually editing poly-edges, poly-vertices, or poly-faces 

• Manually improving the topology of poly-faces 

• Modifying mesh shapes with a low poly-faces count 

 
 

How to Use 

How to edit poly-edges on a mesh 
1. Go to Tools > Mesh Tools > Edit Poly-Edge or click the icon in the toolbar. 

 
2. Choose the Merge method and pick a point on a mesh. 

    
 

3. Choose the Move method and drag a poly-vertex on the mesh. 
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4. Click the OK button to complete the command. 
 
 

Options in Detail 

Methods 

This command features 3 methods: 

• Swap 

Flips poly-edges 

• Merge 

Merges poly-vertices 

• Subdivide 

Divides poly-faces 

• Insert 

Inserts a poly-vertex on a poly-face 

• Move 

Moves a poly-vertex 

 
Swap – Flips a poly-edge. When the mouse cursor hovers over poly-edge, a preview will be 
highlighted. Select a previewed poly-edge to flip it. 

  

Before Swap After Swap 
 
Merge – Merges poly-vertices in to a single poly-vertex. This method is useful for removing small 
poly-faces. 
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Subdivide – Divides poly-face. This method is useful when dividing large poly-faces. 

  
 
Insert – Inserts poly-vertex on poly-face. This method divides poly-faces by inserting a poly-
vertex. 

  
 
Move – Moves a poly-vertex by click-dragging. 

   

 
 

See Also 

Tools > Mesh Tools > Retriangulate 
Tools > Mesh Tools > Global Remesh 
Tools > Mesh Tools > Optimize Mesh 
Tools > Mesh Tools > Virtual Rescan 
Tools > Mesh Tools > Rewrap 
Tools > Mesh Tools > Smart Brush 
 
 
 

Tools > Mesh Tools > Virtual Rescan 
 

What 

The Virtual Rescan command regenerates a mesh by combining feature shapes captured in the 
normal direction of each virtual plane. This command can be used to clean messy poly-faces inside 
of a mesh. 
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Why 

The Virtual Rescan command is useful for: 

• Extracting exterior poly-faces from a volumetric mesh model that is mixed with inner and outer 
feature shapes 

• Optimizing poly-faces with uniform lengths on a mesh 

 
 

How to Use 

How to rescan feature shapes and recreate a mesh 
1
. 

Align a model in the Model View to define a normal direction of a virtual plane. Go to 
Tools > Mesh Tools > Virtual Rescan or click the icon in the toolbar. 

 
 

2
. 

Check the Max. Poly-Face Angle option and set the value to 75°. 
Check the Merge option to merge feature shapes captured in the normal direction of 
each virtual plane. 
 

2
. 

Set the Grid U/V Size to 0.3mm. The Grid U Size is the size of the horizontal direction in 
a grid plane. The Grid V Size is the size of the vertical direction in a grid plane. 
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3
. 

Use the Add Polyhedral Position option to surround the target mesh with virtual planes. 
 

4
. 

Change the Type to Icosahedron (20) and click the OK button. 
Check the normal direction of virtual planes surrounding the target mesh by the defined 
polyhedral formation. 

 
 

5
. 

Click the OK button to complete the command. 

  
 

Note:  

To check the inner part of a mesh, use the View Clip command. For more information, see View 
> Clip. 
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Options in Detail 

Rescan Options 

Poly-Faces – Selects target poly-faces. 
 

Note:  

If poly-faces are not selected, the Virtual Rescan command will be applied to an entire mesh. 

 
Max. Poly-Face Angle – Specifies a maximum poly-face angle between the direction of poly-
faces and the normal direction of a virtual plane to avoid capturing slanted areas and creating 
abnormal poly-faces. 

 
 
Merge – Merges poly-faces captured in the normal direction of each virtual plane. 

 
 

Note:  

If this option is disabled poly-faces will be combined. 
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Disable Merge Enable Merge 
 

 
 

Grid Plane Options 

Plane – Specifies a size for Grid U and V. To align the normal direction of a virtual plane to a view 
direction, use the View > Viewpoint > Align View command or the Ctrl + Shift + A keyboard 
shortcut. 
 

Note:  

Click the Add button to add more grid planes in a different view direction. To remove existing planes, 
change the target plane in the Plane list and click the Delete button. If the normal direction of an added 
plane needs to be reversed, click the Reverse button. The Select None button resets a selected grid 
plane. 

 
Reference – Defines the normal direction of a virtual plane by referring to the normal direction 
of an existing Ref.Plane, Sketch, or Face of a body. 
 
Draw – Draws a rectangle on the screen to define a grid plane in a view direction. 

 
 

Add Cylindrical Position 

This option creates a cylindrical formation of virtual planes surrounding a target mesh or selected 
poly-faces. Check virtual planes and their normal direction by clicking the Preview button. 

 
 
Axis – Specifies the direction of an axis of a cylindrical formation. 
 
No. Of Planes – Specifies the number of virtual planes that cylindrically surround a target mesh 
or selected poly-faces. 
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Cap – Caps a feature shape on the top or the bottom of a target mesh or selected poly-faces. 
 

Add Polyhedral Position 

Creates a polyhedral formation of virtual planes surrounding a target mesh or selected poly-
faces. 

 
 
Position – Specifies the center position of a polyhedral formation. 
 
Type – Selects a polyhedral formation type. 

 
 

See Also 

Tools > Mesh Tools > Retriangulate 
Tools > Mesh Tools > Edit Poly-Edge 
 
 
 

Tools > Mesh Tools > Rewrap 
 

What 

The Rewrap command fills missing areas on a mesh based on its geometric feature shapes. This 
command also smooths and improves the quality to a mesh. 

 
 
 

Why 
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The Rewrap command is useful for: 

• Creating a watertight mesh from raw 3D scan data that has missing areas and complex holes 

• Filling holes with poly-faces based on geometric feature shapes and cleaning defects from a 
mesh at the same time 

 
 

How to Use 

How to rewrap feature shapes and recreate poly-faces on a mesh 
1. Go to Tools > Mesh Tools > Rewrap or click the icon in the toolbar. 

 
 

Note:  

Check the normal information of a target mesh before applying the Rewrap command. The 
target mesh should have correct normal information because the normal of poly-faces are used 
during rewrapping. 

 
 

2. Increase the Geometry Capture Accuracy from Loose to Tight to tightly fit geometric 
feature shapes to a mesh and adjust the Overall Smoothness option. 

 
 

3. Click the OK button to complete the command. 

 
 
 

Options in Detail 
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Current Average Edge Length – Shows the current average edge length of poly-edges on a 
target mesh. 
 
Edge Length Multiplier – Specifies an edge length multiplier. 

  

Original Edge Length Edge Length Multiplier: 2 
 
 

Note:  

To create a mesh with dense poly-faces, set a value smaller than 1. If the value is set larger than 1, the 
results will be more sparse than the original mesh. 

  

Edge Length Multiplier = 1 Edge Length Multiplier = 3 
 

 
Target Average Edge Length – Defines the average length of poly-edges after rewrapping. 

 
 
Geometry Capture Accuracy – Defines geometry capture accuracy. When the slider is moved 
towards Loose, less poly-faces will be used to create a shape. When the slider is moved towards 
Tight, more poly-faces will be used to create a shape. 

  

Loose Tight 
 
Overall Smoothness – Applies a smoothing effect to the overall areas of a target mesh. The 
weight of the smoothness can be adjusted by moving the slider between Min. and Max. 
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Smooth: Min Smooth: 2 Step 

 
 

More Option 

Extend Boundaries – Closes large holes by extending boundaries. The tightness or looseness of 
the tension in a boundary can be adjusted by moving the slider between Min. and Max. 

   

Original Data Uncheck Extend Boundary Check Extend Boundary 
 

   
Original Data Curved Flat 

 

Note:  

A volume manipulator will be displayed when the Extend Boundaries option is enabled. It limits the 
extension area by a user-defined volume. This is useful when dealing with a mesh that has boundary 
shapes opened toward the outside. 

  
Before After 
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Mesh Density In High Curvature Region – Controls the density of poly-faces in high curvature 
areas. 

  

Uncheck Check 
 

 
 

See Also 

Tools > Mesh Tools > Retriangulate 
Tools > Mesh Tools > Global Remesh 
Tools > Mesh Tools > Optimize Mesh 
Tools > Mesh Tools > Fill Holes 
 
 
 

Tools > Mesh Tools > Fill Holes 
 

What 

The Fill Holes command fills in missing holes with poly-faces based on feature shapes of a mesh. 
This command also offers advanced editing commands to modify or remove feature shapes from 
boundaries. 

 
 
 

Why 

The Fill Holes command is useful for: 

• Manually filling in holes with poly-faces based on geometric feature shapes 

 
 

How to Use 
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How to fill missing holes in mesh 
1
. 

Go to Tools > Mesh Tools > Fill Holes or click the icon in the toolbar. 

 
 

Note:  

The Fill Hole command can be accessed in the pop-up menu by selecting a boundary and 
clicking the RMB button. When a hole is filled using the pop-up menu, the Curvature method 
will be applied. 

 

 
 

2
. 

Select holes and choose the Curvature method. 
 

3
. 

Click the OK button to complete the command. 

 
 
 

Options in Detail 

Target Entities 

Boundaries – Selects boundaries. To select all boundaries at one time, Go to Select > All – 
Boundaries in the menu, use the pop-up menu, or use the Shift + A keyboard shortcut. 
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Editing Tools 

This command features 6 editing commands: 

• Add Bridge 

Adds bridges in between boundaries 

• Fill Gulf 

Fills poly-faces on indented boundaries 

• Remove Peninsula 

Removes poly-faces on indented boundaries 

• Remove Island 

Removes small clusters 

• Smooth Boundary 

Applies smoothing to boundaries 

• Delete Poly-Face 

Removes poly-faces 

 
Add Bridge – Adds bridges between target boundaries by connecting two poly-edges. To add 
a bridge, drag a poly-edge from one side to the other. 

 
 

Note:  

If a hole is too large and complex to fill with poly-faces, use the Add Bridge editing command to make 
the hole smaller and simpler. 

 
Fill Gulf – Fills poly-faces on an indented boundary. To fill poly-faces on a gulf-like boundary, 
pick points for a starting point and ending point. 

  
 
Remove Peninsula – Removes poly-faces on an indented boundary. To remove peninsula-like 
poly-faces on a boundary, draw a trimming path by picking two points. 
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Remove Island – Removes small clusters. To remove small clusters, pick a point in the cluster. 

  
 
Smooth Boundary – Applies smoothing to a boundary. 

  
 
Delete Poly-Face – Removes poly-faces. To remove poly-faces, click this button and select poly-
faces, and then press the Delete key. 

  
 

Note:  

Using the Delete Poly-Face command to delete poly-faces will not exit the Fill Holes command. 

 
 

Methods 

Flat – Fills target boundaries with flat poly-faces. 

  
 
Curvature – Fills poly-faces in target boundaries using the curvature flow around the boundary. 

   

More Options 

Hole Size Measure 
 

Boundary Edge Count – Limits filling holes by the boundary edge count. 
 

Perimeter – Limits filling holes by the length of boundaries. 
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Do Not Fill N-Biggest Holes – Preserves large holes. The biggest holes will be preserved in order 
of size according to a specified value. If the value is set to zero, the option will be ignored. 

 
 
Do Not Fill If Hole Is Bigger Than – Preserve large holes. Holes with a boundary edge count or 
length of a boundary less than a specified value will not be filled. 
 
Smooth Boundary – Applies smoothing to target boundaries. This option is useful for reducing 
noise and the effect of roughness in a target boundary and allows easy filling of poly-faces in 
complex boundaries. 

   

Original Data Disable Smooth Boundary Enable Smooth Boundary 
 
Refine Filled Holes – Refines poly-faces with uniform edge lengths in the filled area within 
boundary. This option is available when using the Flat method. 

  

Without Refine Filled Holes With Refine Filled Holes 
 
Flatness Of Filled Holes – Adjusts the flatness of filled areas. 

 
 

See Also 

Tools > Mesh Tools > Edit Boundaries 
Tools > Mesh Tools > Global Remesh 
Tools > Mesh Tools > Optimize Mesh 
Tools > Mesh Tools > Rewrap 
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Tools > Mesh Tools > Defeature 
 

What 

The Defeature command removes feature shapes and regenerates poly-faces on a mesh. Defeature 
removes selected areas first and applies the Fill Holes operation to the removed areas. 

 
 
 

Why 

The Defeature command is useful for: 

• Removing feature shapes from a target mesh 

• Removing unnecessary feature shapes and filling in poly-faces in empty areas to smoothly 
connect with adjacent feature shapes 

 
 

How to Use 

How to delete feature shapes and recreate poly-faces on a mesh 
1. Go to Tools > Mesh Tools > Defeature or click the icon in the toolbar. 

 
2. Choose the Fill method. Select poly-faces to remove feature shapes. 

 
 

3. Click the OK button to complete the command. 
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Options in Detail 

Target Feature Shape 

Fill – Removes feature shapes and fills poly-faces in the removed areas. 

  
 
Bridge – Removes feature shapes on cylindrical areas and fills poly-faces in the removed areas 
by connecting with bridges. 

  
 
 

Methods 

Flat – Fills removed areas using flat poly-faces. 

  
 
Curvature – Fills removed areas using the curvature flow around a boundary. 
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More Options 

Smooth Boundary Of Defeatured Area – Applies smoothing to boundaries. This option is 
useful for reducing the effect of roughness around boundaries that have been manually 
selected and removed, and easily fills in poly-faces in boundaries. 

  

Disable Smooth Boundary Enable Smooth Boundary 
 

 
 

See Also 

Edit > Delete 
Tools > Mesh Tools > Retriangulate 
Tools > Mesh Tools > Fill Holes 
 
 
 

Tools > Mesh Tools > Remove Marker 
 

What 

When scanning an object in different directions, markers are used to recognize feature shapes of 3D 
scan data and align scans accurately. After aligning and merging scans to mesh, the markers are 
required to be removed for creating an optimal mesh. The Remove Marker command removes 
scanned markers from a mesh. 

  
 
 

Why 

The Remove Marker command is useful for: 

• Finding and removing scan markers 
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How to Use 

How to remove scan markers from a mesh 
1. Go to Tools > Mesh Tools > Remove Marker or click the icon in the toolbar. 

 
 

2. Manually specify the marker radius as 10 mm and then click the Find Markers button. 

 
 

3. Check the detected markers. If markers cannot be located by using Find Marker button 
with a specified marker radius, pick the boundary of a marker on the mesh to select them 
manually. 

 
 

4. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Marker Radius – Specifies the radius of a target marker. Click the Find Markers button to find 
markers with the specified radius. 
 
Markers – Shows detected markers in a list. Click the From File button to import an AICON file 
(.obc) that contains center coordinates of markers. This information will be used to find markers 
in a mesh. 
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See Also 

Edit > Delete 
Tools > Mesh Tools > Fill Holes 
Tools > Mesh Tools > Defeature 
 
 
 

Tools > Mesh Tools > Add Poly-Face 
 

What 

The Add Poly-Face command creates a new poly-face manually by picking poly-vertices on a mesh. 

 
 
 

Why 

The Add Poly-Face command is useful for: 

• Manually adding poly-faces 

• Filling poly-faces in the boundaries of mesh that has been converted from CAD data 

 
 

How to Use 

How to partially add poly-faces on a mesh 
1. Go to Tools > Mesh Tools > Add Poly-Face or click the icon in the toolbar. 

 
2. Pick the first poly-vertex. 

 
 

3. Pick the second poly-vertex. 
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4. Pick the third poly-vertex 

 
 

5. Click the OK button to complete the command. 

 
 
 

Options in Details 

Target Entities 

Poly-Vertices – Selects three poly-vertices on a mesh. To cancel all selections, click the Select 
None button. The Deselect Last button is used to cancel the last selection. 
 
New Poly-Face Count – Shows the number of newly added poly-faces. 
 

More Options 

Match Poly-Face Normal – Matches the normal direction of added poly-faces to their adjacent 
poly-faces. 
 

Note:  

The normal direction of created poly-faces follows the order of selection in either the clockwise or 
counterclockwise directions. To match a normal direction with adjacent poly-faces regardless of 
selection order, use this option. 
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See Also 

Tools > Mesh Tools > Fill Holes 
 
 
 

Tools > Mesh Tools > Smooth 
 

What 

The Smooth command reduces the effect of noise and roughness in a mesh. It can be applied to the 
entire mesh or partially selected poly-faces. 

 
 
 

Why 

The Smooth command is useful for: 

• Reducing the effects of noise and roughness in a target mesh or partially selected poly-faces 

• Improving the quality of a mesh 

 
 

How to Use 

How to smooth and reduce the roughness of a mesh 
1. Go to Tools > Mesh Tools > Smooth or click the icon in the toolbar. 

 
 

2. Adjust the Smoothness Level option to the middle and click the Next Stage button to 
continue. 
 

3. Check the results in real-time by using the Smoothness Level option. 
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4. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Smoothness Level – Adjust the iteration count of smoothness by moving the slider between 
Min and Max. 

   

Min Medium Max 
 
 

More Options 

Allowable Deviation – Specifies an allowable deviation range for the deformation of poly-
vertices during smoothing. 

 
 
Do Not Move Boundaries – Preserves the movement of poly-vertices in boundaries. 

   
Original Data Check Option Uncheck Option 

 
Feature Preservation – Preserves the deformation of features. 

   

Original Data Check Option Uncheck Option 
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See Also 

Tools > Mesh Tools > Smart Brush 
Tools > Mesh Tools > Enhance Shape 
 
 
 

Tools > Mesh Tools > Smart Brush 
 

What 

The Smart Brush command partially optimizes a target mesh and improves the quality of the mesh. 
This command uses advanced methods to interactively edit partial areas of mesh such as Smooth, 
Decimate, Clean, Enhance and Deform. 

 
 
 

Why 

The Smart Brush command is useful for: 

• Partially optimizing and improving the quality of mesh 

• Reducing the number of poly-faces in a specify area of a mesh 

• Partially deforming mesh 

 
 

How to Use 

A. How to interactively apply a smoothing effect to a partial area of a 
mesh by using the paint brush selection tool 
1. Go to Tools > Mesh Tools > Smart Brush or click the icon in the toolbar. 
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2. Choose the Smooth method. Hold down the Alt key and drag the mouse cursor with the 

left mouse button to adjust the range of the editing zone. 

    
 

3. Select an area on the mesh and check the results. 

 
 

4. Click the OK button to complete the command. 
 
 

B. How to interactively equalize poly-vertex balance 
1. Go to Tools > Mesh Tools > Smart Brush or click the icon in the toolbar. 

 
 

2. Choose the Clean method. Hold down the Alt key and drag the mouse cursor with the 
left mouse button to adjust the range of the editing zone. 
 

3. Select an area on the mesh and check the results. 

 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 

Methods 



Geomagic Design X | Menu  632 
 

This command features 5 methods: 

• Smooth 

Reduces the effect of noise and roughness in partial areas of mesh 

• Decimate 

Reduces the number of poly-faces in partial areas of mesh 

• Clean 

Equalizes poly-vertex balance 

• Enhance 

Sharpen sharp areas and smooths rounded corners 

• Deform 

Deforms feature shapes on a mesh 

 
Smooth – Interactively smooths partial areas of a mesh. For more information, see Tools > Mesh 
Tools > Smooth. 

 
 
Strength – Adjusts the weight of smoothness by moving the slider between Min and Max. 

   

Min Medium Max 
 

Allowable Deviation – Specifies an allowable deviation range and limits the deformation 
of poly-vertices within the allowable deviation during smoothing. 

 
 
Do Not Move Boundaries – Preserve the movement of poly-vertices in boundaries. 

   

Original Data Check Option Uncheck Option 
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Do Not Modify Sharp Edges – Preserve the deformation of poly-vertices in sharp edges. 

   

Original Data Check Option Uncheck Option 
 
Decimate – Interactively reduces the number of poly-faces in a partial area of mesh. For more 
information, see Tools > Mesh Tools > Decimate. 

 
 

Reduction Level – Adjusts the strength of reduction by moving the slider between Less 
and More. 
 
Do Not Move Boundaries – Preserves the movement of poly-vertices in boundaries. 

 
Clean – Interactively equalizes poly-vertex balance by flipping poly-edges. For more information, 
see Tools > Mesh Tools > Optimize Mesh. 

 
 

Smooth Cleaned Poly-Faces – Applies smoothing to cleaned poly-faces. 
 

Enhance – Makes sharp areas sharper and rounded corner areas smoother. For more 
information, see Tools > Mesh Tools > Enhance. 

 
 

Sharpness – Adjusts the sharpness of selected poly-faces by moving the slider between 
Min and Max. 
 
Overall Smoothness - Adjusts the smoothness of selected poly-faces by moving the slider 
between Min and Max. 

 
Deform – Deforms feature shapes in a convex or concave shape on a mesh. To create a convex 
shape, select a partial area on the mesh. To create a concave shape, select a partial area on the 
mesh while holding down the Ctrl key. 
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Weight – Adjust the weight of deformation by moving the slider between Min and Max. 
 
Set Weight Curve – Click the Set Weight Curve button to modify weight factor in each 
position of a paint brush. 
 

Note:  

In the dialog box, the horizontal axis on a weight curve view represents the position from the 
center to boundary of a paint brush. The vertical axis represents a user-defined weight factor for 
deformation.  

 

 
Smooth Deformed Poly-Faces – Applies smoothing to deformed poly-faces. 
 
Volume of Deformed Poly-faces – Shows the volume of deformed poly-faces. 

 
 

See Also 

Tools > Mesh Tools > Smooth 
Tools > Mesh Tools > Decimate 
Tools > Mesh Tools > Global Remesh 
Tools > Mesh Tools > Optimize Mesh 
Tools > Mesh Tools > Enhance Shape 
 
 
 

Tools > Mesh Tools > Decimate 
 

What 

The Decimate command reduces the number of poly-faces in a mesh or selected areas by merging 
poly-vertices while preserving geometric feature shapes. 
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Why 

The Decimate command is useful for: 

• Reducing the number and size of poly-faces on a mesh 

• Maintaining the original shape of large meshes in the follow-up modeling process 

 
 

How to Use 

How to reduce the number of poly-faces on a mesh 
1. Go to Tools > Scan Tools > Decimate Meshes or click the icon in the toolbar. 

 
 

2. Check the Poly-Face Count option and set the Reduction Ratio to 70 %. 
 

3. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Methods 

This command features 2 methods: 

• Poly-Face Count 

Reduces the number of poly-faces by controlling the target poly-face count 



Geomagic Design X | Menu  636 
 

• Allowable Deviation 

Reduces the number of poly-faces within an allowable deviation 

 
Poly-Face Count – Reduces the number of poly-faces by using parameters specified by the 
Target Poly-Face Count or Reduction Ratio options. 
 

Target Poly-Face Count – Determines a target number of poly-faces. This option can only 
be used with a single mesh. 

  

Original Face Count: 14,703 Target Face Count: 5,228 
 

Reduction Ratio – Determines reduction ratio. 

   

Original Data Reduction Ratio: 70% Reduction Ratio: 30% 
 
High Curvature Area Resolution – Determines resolution in high curvature areas of a 
target mesh. 

 

Original Data 
 

 

High Curvature Area Resolution: Sparse 
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High Curvature Area Resolution: Dense 
 
Allowable Deviation – Reduces the number of poly-faces within an allowable deviation 
between an original shape and decimated results. 
 

More Options 

Do Not Move Poly-Vertices – Preserves the original position of poly-vertices during 
decimation. 
 
Do Not Modify Boundaries – Preserves the original shape of boundaries during decimation. 

   
Original Data Check Option Uncheck Option 

 
Regularize Poly-Face – Regenerates poly-faces with uniform poly-edge lengths. 
 

Note:  

The calculation time for this command may be highly increased with this option. 
 

 
 

See Also 

Tools > Mesh Tools > Smart Brush 
Tools > Mesh Tools > Subdivide 
  
 
 
 

Tools > Mesh Tools > Subdivide 
 

What 

The Subdivide command subdivides poly-faces to increase the number of poly-faces on a mesh or 
selected areas while preserving feature shapes. This command also improves the curvature flow 
between adjacent poly-faces. 
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Why 

The Subdivide command is useful for: 

• Increasing the number of poly-faces on a mesh or selected areas 

• Reducing the size of poly-faces on a mesh or selected areas 

• Characterizing feature shapes 

• Working with mesh models that cannot be represented in detail with low poly-face count 

 
 

How to Use 

How to divides and increase the number of poly-faces 
1. Go to Tools > Mesh Tools > Subdivide or click the icon in the toolbar. 

 
 

2. Choose the 4x method. 
 

3. Click the OK button to complete the command. 

 
 
 

Options in Detail 
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Methods 

This command features 3 different methods: 

• 4x 

Divides poly-faces into quarters 

• 3x 

Divides poly-faces into three equal parts 

• Edge Length 

Regenerates poly-faces on a target mesh or selected areas by using specified parameters 

 
4x – Divides poly-faces into quarters. 

 
 
3x – Divides poly-faces into three equal parts. 

 
 
Edge Length – Regenerates poly-faces on a target mesh or selected areas by using specified 
parameters. This method manually controls edge lengths and is useful for refining mesh that has 
been converted from CAD data. 

  
Original Data Min: 1.0x, Max: 5.0x 

 
Current Average Edge Length – Shows the current average edge length of poly-edges 
calculated from a target mesh or selected areas. 
 
Min. Edge Length Multiplier – Specifies a minimum edge length multiplier based on the 
current average edge length. 
 
Min. Edge Length – Specifies a minimum edge length based on the current average edge 
length. 
 
Max. Edge Length Multiplier – Specifies a maximum edge length multiplier based on the 
current average edge length. 
 
Max. Edge Length – Specifies a maximum edge length based on the current average edge 
length. 
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Note:  

The size of resulting poly-faces will be determined within specified minimum and maximum 
edge lengths. The edge length of poly-faces can be control by either the Min./Max. Edge 
Length Multiplier or Min./Max. Edge Length options. 

 
 

More Options 

If Edge Length Is Longer Than – Divides poly-faces that have longest edge lengths that are 
longer than a specified value and can be used when the method is set to 4x. 
 
Restrict Target Poly-Faces – Restricts subdivision to either high or low curvature areas. 

 
High Curvature Only – Restrict subdivision to high curvature areas. 

  

Original Data High Curvature Only 
 
Low Curvature Only – Restricts subdivision to low curvature areas. 

  

Original Data Low Curvature Only 
 

Curvature Searching Sensitivity – Specifies the sensitivity of curvature searching. 
 

Note:  

When the slider is moved towards Low, curvature areas will be detected with a wide searching 
range. When the slider is moved towards High, it will be detected with a narrow searching range. 

  
Low High 
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Do Not Move Poly-Vertices – Preserves the original position of poly-vertices during subdivision. 
 
Do Not Modify Boundaries – Preserves the original shape of boundaries during subdivision. 
 
Do Not Modify Sharp Edges – Preserves original sharp edges during subdivision. 
 
Defeaturing Level – Adjust the level of defeaturing by moving the slider between Less and 
More. 
Feature regions will be classified from a target mesh or selected areas and applied starting from 
low curvature areas to high curvature areas. 

   

Less Middle More 
 
Fill Defective Holes – Refines defective holes and fills holes with poly-faces. 

 
 

See Also 

Tools > Mesh Tools > Smart Brush 
Tools > Mesh Tools > Decimate 
 
 
 

Tools > Mesh Tools > Enhance Shape 
 

What 

The Enhance Shape command enhances feature shapes by characterizing sharp areas and 
smoothing rounded corner areas. 

 
 
 

Why 

The Enhance Shape command is useful for: 
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• Enhancing feature shapes by characterizing feature areas 

• Improving the quality of a mesh by applying smoothing and sharpening at the same time 

 
 

How to Use 

How to enhance feature shapes in a mesh 
1. Go to Tools > Mesh Tools > Enhance Shape or click the icon in the toolbar. 

 
 

2. Adjust the Sharpness option to Max and the Overall Smoothness option to Min. 

 
 

3. Click the Next Stage button to continue. 
 

4. Adjust the Enhance Level option. Use the Enable Realtime Preview button to check 
results in real-time. 

 

 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 

Sharpness – Adjusts the sharpness of a target mesh or selected poly-faces. 

   

Original Data Sharpness: Min Sharpness: Max 
 
Overall Smoothness – Adjusts the smoothness of a target mesh or selected poly-faces. 
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Original Data Overall Smoothness: Min Overall Smoothness: 
Max 

 
Enhance Level – Adjusts the strength of enhancement. 

   

Original Data Level: Min Level: Max 
 

 
 

See Also 

Tools > Mesh Tools > Smooth 
Tools > Mesh Tools > Smart Brush 
 
 
 

Tools > Mesh Tools > Refit 
 

What 

The Refit command regenerates a mesh using a reference entity. A mesh, a surface body or an 
analytic shape such as a plane, cylinder, cone, sphere, torus or box, can be a reference entity. 

 
 
 

Why 

The Refit command is useful for: 

• Refitting specific areas to an analytic feature shape 
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• Creating an optimized mesh from irregular point clouds that are too complex to be triangulated 

• Refitting a mesh that has been distorted by mesh operations to the original mesh or point cloud 

• Refitting a mesh to a modeled surface body 

 
 

How to Use 

A. How to refit distorted mesh to an original mesh 
1. Go to Tools > Mesh Tools > Refit or click the icon in the toolbar. 

 
 

2. Select an original mesh as a Target Entity. 

 
 

3. Click the Preview button to check the results. 

 
 

4.  Click the OK button to complete the command. 
 
 

B. How to refit a mesh to an original point cloud 
1. Go to Tools > Mesh Tools > Refit or click the icon in the toolbar. 

 
 

Note:  

When a point cloud is too complex to be triangulated, the Refit command can be used to create 
an optimized mesh. 

When using the Refit command, prepare a base mesh by following the basic guidelines below: 

Clean noise from a point cloud by filling holes and refining poly-faces. 

Filter redundant points and sample noise from an original point cloud to create a mesh by using 
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the Triangulate command with the Mesh Construction method. For more information, see Tools 
> Scan Tools > Triangulate. 

Increase the number of poly-faces to fit to the original point cloud. 

After preparing a base mesh, refit the mesh to the original point cloud. 

 
 

2. Select an original point cloud as the Target Entity. 

 
 

3. Set the Distance to 3mm. 
 

4. Click the Preview button to check the results. 

 
 

5.  Click the OK button to complete the command. 
 

Note:  

The Tools > Mesh Tools > Smooth command can be applied to the refitted mesh to get better 
results. 

 
 

 
 

Options in Detail 

Methods 

This command features 3 methods: 

• To Analytic Shape 

Refits specific areas to an analytic feature shape 

• To Mesh/Point Cloud 

Refits a mesh to a reference mesh or point cloud 
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• To Surface 

Refits a mesh to a reference surface body 

 
To Analytic Shape – Refits selected poly-faces to a specified geometric feature shape. 

  

Original Data Fitting Shape: Sphere 
 

Poly-Faces To Be Fitted – Selects poly-faces to be fitted. 
 
Fitting Shape – Specifies a geometric feature fitting shape. 
 
Projection On Plane – Specifies a planar entity to be projected onto. 
 

Note:  

A planar region, Ref.Plane, 2D sketch chain, curve, 3D sketch, sketch edge, loop, or planar face 
can be defined as a target plane. 

 
Fix Radius – Specifies the value of the radius of a cylinder or a sphere if it is already known. 
 

User Defined – Specifies a radius to be fitted. 
 

Note:  

A user defined radius can be specified when a circular entity is not defined. 

 
Axis Constraint – Constrains the direction of an axis. 
 

Use Specified Axis As Initial Guess – Defines an initial axis that can be used for 
finding the direction of a fitting shape. 
 
Use Specified Axis As It Is – Manually defines the direction of an axis by selecting 
an entity that has a vector property or by manually typing the values. 

 
To Mesh/Point Cloud – Refits a mesh to a reference mesh or point cloud. 

  

Before Refit After Refit 
 

Distance Criterion – Specifies the distance criteria used to define the influence range of a 
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fitting. 
 
To Surface – Refits a mesh to a reference surface body. 

  

Before Refit After Refit 
 

 
 

See Also 

Tools > Mesh Tools > Retriangulate 
Tools > Mesh Tools > Edit Poly-Edges 
 
 
 

Tools > Mesh Tools > Insert 
 

What 

The Insert command inserts a mesh converted from body faces, edges or curve entities. 

 
 
 

Why 

The Insert command is useful for: 

• Inserting a mesh converted from modeled entities into an existing mesh 

 
 

How to Use 
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How to convert other entities and insert into mesh 
1. Go to Tools > Mesh Tools > Insert or click the icon in the toolbar. 

 
2. Select a solid body for target Entities. 

 
 

3. Click the Preview button to check the results. 

 
 

4. Click OK to complete the command. 
 
 

Options in Detail 

Target Entities 

Entities – Selects body faces, edges, or curves to use as target entities to insert into existing 
mesh. 
 

Note:  

If a curve is selected, poly-vertices will be relocated closer to the curve. 

   

Original Data Insert Curve Rearrange of poly-vertices 
 

 

 
 

See Also 

Tools > Scan Tools > Boolean 
Tools > Mesh Tools > Convert Body 
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Tools > Mesh Tools > Split 
 

What 

The Split command divides a mesh into multiple parts by using various tool entities such as a 
Ref.Plane, curve, face, surface Body, solid Body, or polyline. 

 
 
 

Why 

The Split command is useful for: 

• Splitting a mesh into multiple parts 

 
 

How to Use 

How to split a mesh with a tool entity 
1. Go to Tools > Mesh Tools > Split or click the icon in the toolbar. 

 
2. Choose the By Entity method and select a Ref. Plane. 

 
 

3. Click the Next Stage button to continue and select a remaining area. 
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4. Click OK to complete the command. 

 
 
 

Options in Detail 

Methods 

This command features 3 methods: 

• By Entity 

Splits a mesh by using a tool entity 

• By Drawing Polyline On Screen 

Splits a mesh by drawing a polyline on the screen 

• By User Defined Plane 

Splits a mesh by a user defined plane 

 
By Entity – Splits a mesh by using a plane, curve, or a body face. 

  
 
By Drawing Poly-Line On Screen – Splits a mesh by drawing a polyline on the screen. 
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Note:  

Hold the Shift key while drawing to create a horizontal or vertical polyline. 

 
By User Defined Plane – Splits a mesh by using user-defined virtual plane that can be 
manipulated by dragging or rotating manipulator handles. 

 
 

 
Base Plane – Splits a mesh by a selected base plane. 
 

More Options 

Cap Section Ends – Fills an open boundary to create a closed mesh. 

  
Disable Capping Enable Capping 

 

Result 

Remaining Region – Selects remaining regions. 

 
 
 

See Also 
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Tools > Mesh Tools > Trim 
 
 
 

Tools > Mesh Tools > Trim 
 

What 

The Trim command trims poly-faces on a target mesh and cuts off trimmed inner or outer regions. 

 
 
 

Why 

The Trim command is useful for: 

• Trimming poly-faces out of a mesh 

• Rearranging poly-edges to fit a reference curve 

 
 

How to Use 

A. How to trim poly-faces on a mesh 
1. Go to Tools > Mesh Tools > Trim or click the icon in the toolbar. 

 
2. Select the By Curve method and select a predefined curve as a tool Curves. 
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Note:  

To use a curve as a tool curve it should be located in the higher level of a feature structure in the 
Feature Tree. 

 

 
 

3. Choose the Rearrange Poly-Vertices sub-method. 
 

4. Click the Next Stage button. 
 

5. Select the region to remain. 

 
 

6. Click OK to complete the command. 

 
 
 

Options in Detail 

Methods 

By Custom Path – Trims a mesh by a custom path created by picking points on a mesh. 
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Trim Path – Trims a path using the Undo Last Path (Ctrl + Z), Close Path, and Reset Path 
buttons. 

   

Drawing Custom Path Undo Last Path Close Path 
 
By Curve – Trims a mesh using existing closed curves. 
 

Rearrange Poly-Vertices – Trims a mesh by projecting nearby poly-vertices onto selected 
curves. 

  

 
Rearrange Poly-Faces – The trimming will be done by dividing the poly-faces at the 
intersecting point between the curve and poly-edges. 

  

 
 

Result 

Remaining Region – Selects remaining regions. 

 
 
 

See Also 

Tools > Mesh Tools > Split 
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Tools > Mesh Tools > Mirror 
 

What 

The Mirror command creates a new mesh by mirroring an existing mesh using a cutting plane. 

 
 
 

Why 

The Mirror command is useful for: 

• Completing a mesh by mirroring one half of a mesh 

 
 

How to Use 

A. How to mirror a mesh 
1. Go to Tools > Mesh Tools > Mirror or click the icon in the toolbar. 

 
 

2. Select a plane for a mirror plane. 

 
 

3. Click the OK button to complete the command. 
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Options in Detail 

Plane Options 
 

Position – Selects an entity or an x, y and z coordinate set as a position for a mirror plane. 
 
Normal – Specifies the normal direction of a mirror plane. 
 

Remove Original Mesh – Removes original mesh after mirroring. 
 
Trim And Merge – Removes overlapping areas between an original mesh and a mirrored mesh. 

 
 

Disable Trim And Merge Enable Trim And Merge 
 

Remesh Poly-Faces Around Mirror Plane – Regenerates poly-faces around a mirror 
plane to smoothly connect two merged meshes. 

 
 

See Also 

Tools > Scan Tools > Transform Scan Data 
Tools > Mesh Tools > Split 
 
 
 

Tools > Mesh Tools > Offset 
 

What 

The Offset command creates a new mesh that has a constant distance from an original mesh using 
either the Surface or Volume method. 
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Why 

The Offset command is useful for: 

• Increasing or decreasing the size of a mesh 

 
 

How to Use 

A. How to increase the size of mesh by using distance 
1. Go to Tools > Mesh Tools > Offset or click the icon in the toolbar. 

 
 

2. Set the Distance to 3 mm. 
 

3. Click OK to complete the command. 

 
 
 

Options in Detail 

Methods 

Surface – Creates a new mesh that is offset from the original mesh. Although the operation 
appears to expand or contract the faces, it actually defines new offset faces at a specific 
distance from the original mesh. 
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Original Data Surface Offset 
 

Distance – Specifies an offset distance. 
 
Volume – Calculates the distance from a voxel node to a poly-vertex and makes a new offset 
polygon using the distance. 

  

Original Data Volume Offset 
 

Output Resolution Control – Determines the resolution of poly-faces after an offset by 
specifying a multiplier of the current poly-edge length. This option is available for the 
Volume method. 
 

Current Average Edge Length – Shows the resolution of the current average 
edge length. 
 
Edge Length Multiplier – Multiplies the average edge length by a specified value. 
 
Target Average Edge Length – Defines average edge length by a specified value. 
 

More Options 

Preview Offset Result – Displays an offset result as a point cloud. 

 

Preview 
 
Remove Crossing Region – Automatically verifies and cleans crossing regions. This option is 
available for the Surface method. 
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Make Closed Mesh – Closes and offset an open mesh. This option is available for the Volume 
method. 

   

Original Data With Closed Mesh Option Without Closed Mesh 
Option 

 

 
 

See Also 

Tools > Scan Tools > Transform Scan Data 
Tools > Mesh Tools > Thicken 
 
 
 

Tools > Mesh Tools > Thicken 
 

What 

The Thicken command changes the volume of a mesh by giving a constant thickness to each face 
to create a completely closed mesh with no boundaries. 

 
 
 

Why 

The Thicken command is useful for: 
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• Giving faces with no volume thickness 

• Creating constant thickness parts 

 
 

How to Use 

A. How to create thickness 
1. Go to Tools > Mesh Tools > Thicken or click the icon in the toolbar. 

 
 

2. Set the Thickness to 3 mm. 
 

3. Click OK to complete the command. 

 
 
 

Options in Detail 

Methods 

Surface – Defines new offset poly-faces that are a specific distance from an original mesh. 
 

Thickness – Specifies an offset distance. To change an offset direction, use the 
Direction1 or Direction2 options. To offset both directions at the same time, use Both. 

 
 

Direction 1 – Thickens in the default positive direction. 
 
Direction 2 – Thickens in the opposite, negative direction from Direction1. 
 
Both – Thickens using both Direction 1 and Direction 2 at the same time. 

 
Volume – Calculates the distance from a voxel node to a poly-vertex and makes a new 
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thickened polygon using the distance. 
 

Output Resolution Control – Determines the resolution of poly-faces after an offset by 
specifying a multiplier of the current poly-edge length. This option is available for the 
Volume method. 

 
Current Average Edge Length – Shows the resolution of the current average 
edge length. 
 
Edge Length Multiplier – Multiplies the average edge length by a specified value. 
 
Target Average Edge Length – Defines average edge length by a specified value. 
 

More Options 

Preview Thicken Result – Displays a thickened result as a point cloud. 

 
 
Remove Crossing Region – Automatically verifies and cleans crossing regions. This option is 
available for the Surface method. 

 
 
Make Closed Mesh – This option is available when you select the Volume method. If a mesh 
is not closed, the application will close and thicken a mesh. 

   

Original Data Check the Option Uncheck the Option 
 

 
 

See Also 

Tools > Mesh Tools > Fill Holes 
Tools > Mesh Tools > Offset 
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Tools > Mesh Tools > Convert Body 
 

What 

The Convert Body command converts a selected solid or surface body to a mesh. 

 
 
 

Why 

The Convert Body command is useful for: 

• Converting a solid body into mesh 

 
 

How to Use 

A. How to convert bodies into mesh 
1. Go to Insert > Mesh or click the icon in the toolbar to create a mesh feature. 

 

 

 
 

2. Click Tools > Mesh Tools > Convert Body or click the icon in the toolbar. 
 

3. Select a body to convert. 
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4. Click OK to complete the command. 

    
 
 

Options in Detail 

Target Entities 

Bodies – Selects solid or surface bodies to convert into meshes. 
 

Options 

Quality – Determines the accuracy of a mesh. Moving the slider towards High, will produce a 
more accurate mesh that contains more poly-faces. 

   

Quality: Low Quality: Medium Quality: High 
 
Advanced – Displays sub-options used to precisely limit the size of poly-faces. 
 

Max. Chord Height – Specifies how accurately a mesh represents a surface by setting the 
distance between the mesh and the part of the surface it represents. 

  
 
Max. Edge Length – Specifies the value of the maximum edge length of a poly-face. 



Geomagic Design X | Menu  664 
 

 
 
Min. Edge Length – Specifies the value of the minimum edge length of a poly-face. 

 
 

More Options 

Sew Boundary – Removes small gaps along boundaries. 

 
 
Include Accuracy Analyzer Color – Generates colored mesh from bodies. This option is available 
when selected bodies have Accuracy Analyzer™ information. 
 

Note:  

To use this option: 

1. Run Deviation in the Accuracy Analyzer panel in the Default mode. 

2. Go to Insert > Mesh. 

3. Execute the Tools > Mesh Tools > Convert Body command. 

4. Select a body. 

5. Check the Include Accuracy Analyzer Color option. 

6. Click OK to complete the command. 

 
 

Deviation Result Colored Mesh 
 

 

 
 

See Also 

Tools > Point Cloud Tools > Convert Entities 
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7.5.3. Tools > Region Tools 
 
The Region Tools menu features various commands used to generate and edit feature regions on a 
mesh. Geometry feature regions can be classified with region tools and created feature regions can 
be used for creating feature shapes. 
 
The Region Tools are divided into 3 tool groups used to: 
 

Creating Feature Regions 

• Auto Segment 

Automatically segments feature regions on a mesh 

• Resegment 

Resegments existing feature regions by using different classification criteria 

 

Editing Feature Regions 

• Merge 

Merges multiple feature regions into a single feature region 

• Split 

Divides feature regions into multiple parts 

• Insert 

Inserts a new feature region 

 

Managing Feature Regions  

• Separate 

Separates a feature region into multiple feature regions 

• Enlarge 

Enlarges feature regions 

• Shrink 

Shrinks feature regions 

 
 

Tools > Region Tools > Auto Segment 
 

What 

The Auto Segment command automatically classifies feature regions by recognizing 3D features 
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from raw scan data. Classified feature regions have geometric feature information that can be used 
for creating features quickly. 

 
 
 

Why 

The Auto Segment command is useful for: 

• Classify feature regions on a mesh 

• Using geometric feature information for easily and quickly creating features 

 
 

How to Use 

How to automatically segment feature regions on a mesh 
1
. 

Go to Insert > Region Group or click the icon in the toolbar to enter Region Group 
mode. 

 
 

2
. 

The Auto Segment command will automatically initiate. 
 

Note:  

If feature regions have been classified, manually go to Tools > Region Tools > Auto Segment or 
click the icon in the toolbar to execute the Auto Segment command. 

 
 

3
. 

While the Auto Segment command is executed, specify Geometry Classification Option. 
Tolerance is used to define the geometry type. 
Outlier removes outlier data to achieve more accurate fitting results. 

 
 



Geomagic Design X | Menu  667 
 

4
. 

Click the OK button to classify the feature regions on the mesh. 

 
 

Note:  

After classifying regions, check the geometry types on the regions by hovering the mouse cursor 
over the regions and the geometry type will be displayed. To select regions only, toggle the Filter 
Regions button in the Select Filter toolbar. 

  
 

 
 

Options in Detail 

Sensitivity – Specifies search sensitivity for feature regions. 
 

Note:  

When the slider is moved towards More, search sensitivity will increase.  A higher search sensitivity may 
generate many particle regions if a mesh is rough. 

  

Sensitivity: 100 Sensitivity: 20 
 

 
Mesh Roughness – Adjusts the roughness of a mesh depending on the noise level. If you click 
the Estimate button , the application analizes the mesh and recommends a proper value. 
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Rough Mesh Smooth Mesh 
 
Preserve Existing Region – Preserves existing regions. 
 

Note:  

If feature regions have been classified, the existing regions will be preserved using this option. This option 
is useful for managing the freeform and feature parts of a mesh. 

Select poly-faces on freeform areas by using a selection mode and manually insert new feature regions 
by going to Tools > Region Tools > Insert or click the icon in the toolbar. Apply the Auto Segment 
command to the mesh and the pre-classified freeform regions will be preserved and feature regions will 
be classified on feature parts only. 

 

 
 

See Also 

Tools > Region Tools > Resegment 
Tools > Region Tools > Merge 
Tools > Region Tools > Split 
Tools > Region Tools > Insert 
Tools > Region Tools > Separate 
Tools > Region Tools > Enlarge 
Tools > Region Tools > Shrink 
 
 
 

Tools > Region Tools > Resegment 
 

What 

The Resegment command removes selected regions then classifies them again. Sometimes the 
region segmentation criteria should have a different value from the size or detail of features in a 
model. Generally the Resegment command applies to partial areas after Auto Segmenting, which 
classifies overall areas. 

 
 
 

Why 

The Resegment command is useful for: 

• Accurately classifying geometries on a region 
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How to Use 

How to resegment feature regions on a mesh 
1
. 

Go to Tools > Region Tools > Resegment or click the icon in the toolbar.

 
 

2
. 

Select regions to resegment. 

 
 

3
. 

Set the Sensitivity and Mesh Roughness options. In this example, regions should be 
simplified. So move the Sensitivity slider to Less. 

 
 

4
. 

Click OK to complete the command. 

 
 
 

Options in Detail 

Sensitivity – Specifies the search sensitivity of feature regions. 
 

Note:  

When the slider is moved towards More, search sensitivity will be increase. Higher search sensitivity may 
generate many particle regions if a mesh is rough. 

  

Sensitivity: 100 Sensitivity: 20 
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Mesh Roughness – Adjusts the roughness of a mesh depending on the noise level. 

  
Rough Mesh Smooth Mesh 

 

 
 

See Also 

Tools > Region Tools > Merge 
Tools > Region Tools > Split 
Tools > Region Tools > Insert 
Tools > Region Tools > Separate 
Tools > Region Tools > Enlarge 
Tools > Region Tools > Shrink 
 
 
 

Tools > Region Tools > Merge 
 

What 

The Merge command merges multiple feature regions into a single feature region. This command 
performs the opposite function of the Separate command. 

 
 
 

Why 

The Merge command is useful for: 
Merging multiple feature regions into a single feature region 

• Managing separated feature regions as a single feature region 
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How to Use 

How to merge multiple feature regions into a single feature region 
1. Select two regions to merge. 

 
 

 
 

Note:  

Poly-faces of regions can be selected and merged with regions. 

 
 

2. Go to Tools > Region Tools > Merge or click the icon in the toolbar. The regions will 
be merged. 

 
 
 

See Also 

Tools > Region Tools > Resegment 
Tools > Region Tools > Split 
Tools > Region Tools > Insert 
Tools > Region Tools > Separate 
Tools > Region Tools > Enlarge 
Tools > Region Tools > Shrink 
 
 
 

Tools > Region Tools > Split 
 

What 

The Split command divides a feature region into multiple parts. 
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Why 

The Split command is useful for: 

• Manually dividing feature regions 

• Separating multiple parts of feature region 

 
 

How to Use 

How to divide feature regions into multiple parts 
1. Go to Tools > Region Tools > Split or click the icon in the toolbar. 

 
2. Pick the first point of a polyline. 

 
 

Note:  

To exit the selection status, use the Esc key on the keyboard. 

 

Note:  

When splitting regions there are two selection methods; picking and dragging. If a point on 
a region a polyline is selected a polyline will be used to divide regions. However if regions are 
selected by dragging, the current selection option method will be used. For example, if the 
current selection method is the Paint Brush, and regions are selected by dragging, the paint 
brush tool will be used. 
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3. Pick the second point of a polyline. 
If regions can be split, the polyline color will change from yellow to violet. 

 
 

4. Continue by dividing other regions. 

 
 

Note:  

When a selected area cannot be completely divided into feature regions, the selected area 
regions will be removed. 

  
Before Split After Split 

 
 

 
 

Options in Detail 

Limit to Region – Splitting is applied to only a selected single region. 

 
 

See Also 

Tools > Region Tools > Resegment 
Tools > Region Tools > Merge 
Tools > Region Tools > Insert 
Tools > Region Tools > Separate 
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Tools > Region Tools > Enlarge 
Tools > Region Tools > Shrink 
 
 
 

Tools > Region Tools > Insert 
 

What 

The Insert command manually adds new feature regions. 

 
 
 

Why 

The Insert command is useful for: 

• Manually adding new feature regions 

• Making interesting areas by grouping feature regions 

 
 

How to Use 

How to insert a new feature region 
1. Select areas by using the Paint Brush Selection Mode. Insert a new region. 

 
 

2. Go to Tools > Region Tools > Insert or click the icon in the toolbar. A new feature 
region will be inserted on the existing feature region. 
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Before Insert After Insert 
 

 
 

See Also 

Tools > Region Tools > Resegment 
Tools > Region Tools > Merge 
Tools > Region Tools > Split 
Tools > Region Tools > Separate 
Tools > Region Tools > Enlarge 
Tools > Region Tools > Shrink 
 
 
 

Tools > Region Tools > Separate 
 

What 

The Separate command creates independent feature regions. This command performs the opposite 
function of the Merge command. 

 
 
 

Why 

The Separate command is useful for: 

• Separating a feature region into multiple feature regions 

 
 

How to Use 

How to separate a feature region into multiple feature regions 
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1. Select a feature region to separate. Feature regions that have been distributed in 
separate areas can be a target feature region for this command. 

 
 

 
 

2. Go to Tools > Region Tools > Separate or click the icon in the toolbar. The feature 
regions will be individually separated. 

 
 
 

See Also 

Tools > Region Tools > Resegment 
Tools > Region Tools > Merge 
Tools > Region Tools > Split 
Tools > Region Tools > Insert 
Tools > Region Tools > Enlarge 
Tools > Region Tools > Shrink 
 
 
 

Tools > Region Tools > Enlarge 
 

What 

The Enlarge command expands a feature region. This command performs the opposite function of 
the Shrink command. 
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Why 

The Enlarge command is useful for: 

• Expanding an existing feature region 

 
 

How to Use 

How to enlarge the size of feature regions 
1. Select a feature region to expand. 

 
 

2. Go to Tools > Region Tools > Enlarge or click the icon in the toolbar. The feature 
region will be enlarged. 

 
 
 

See Also 

Tools > Region Tools > Resegment 
Tools > Region Tools > Merge 
Tools > Region Tools > Split 
Tools > Region Tools > Insert 
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Tools > Region Tools > Separate 
Tools > Region Tools > Shrink 
 
 
 

Tools > Region Tools > Shrink 
 

What 

The Shrink command shrinks a feature region. This command performs the opposite function of the 
Enlarge command. 

 
 
 

Why 

The Shrink command is useful for: 

• Shrinking a feature region 

• Reducing the roughness of feature regions around boundaries 

• Correcting geometry properties of automatically classified feature regions 

 
 

How to Use 

How to shrink the size of feature regions 
1. Select a feature region to shrink. 

 
 

2. Go to Tools > Region Tools > Shrink or click the icon in the toolbar. The feature region 
will be shrunk. 
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See Also 

Tools > Region Tools > Resegment 
Tools > Region Tools > Merge 
Tools > Region Tools > Split 
Tools > Region Tools > Insert 
Tools > Region Tools > Separate 
Tools > Region Tools > Enlarge 
 
 
 

7.5.4. Tools > Point Cloud Tools 
 
The Point Cloud Tools menu features various commands used to edit point clouds. 
 
The Point Cloud Tools are divided into 2 tool groups used to: 
 
 

 

Editing Point Clouds 

• Filter Noise 

Filters noisy clusters from point clouds 

• Sampling 

Samples point clouds 

• Smooth 

Reduces the effects of roughness in a point cloud 

• Offset 

Offsets point clouds by a certain distance 

 
 

Converting Point Clouds From/To Other Entities  

• Construct Mesh 

Constructs poly-faces from a partial point cloud 

• Convert Entities 
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Converts other entities into point clouds 

• Separate Point Cloud 

Separates point clouds from original point cloud 

 
 
 

Tools > Point Cloud Tools > Filter Noise 
 

What 

The Filter Noise command cleans noisy clusters from point clouds. 

 
 
 

Why 

The Filter Noise command is useful for: 

• Cleaning noisy clusters from point clouds 

• Removing unnecessary clusters of points 

 
 

How to Use 

How to filter noisy clusters from point clouds 
1. Go to Insert > Point Cloud, click the icon in the toolbar, or double-click a point cloud 

to enter the Point Cloud mode. 

 
 

2. Go to Tools > Point Cloud Tools > Filter Noise or click the icon in the toolbar. Check 
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the Filter Noise Clusters option and set the value to 100. 
 

3. Click the OK button to complete the command. Small noisy clusters will be removed 
from the point cloud. 

 
 
 

Options in Detail 

Filter Outlier Regions – Defines an area of interest and removes all points outside of the defined 
area. 
 

Filter With Box Volume – Defines an area of interest by the volume of a box. 

 
 

Define Box Volume After Filter Noise 
 
Filter With Scanner Range – Defines an area of interest by the volume of a cylindrical. If this 
option is used, the viewpoint will be automatically aligned to the top. 

 
 

Define Scanner Range After Filter Noise 
 

Scanner Center – Specifies the center of a cylindrical volume. 
 
Scanner Range – Specifies the radius of a cylindrical volume. 
 

Note:  

This option adjusts the radius of cylindrical volume by using the dark red-colored 
manipulator circle. 
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Filter Noise Clusters – Specifies the maximum poly-vertices number per noisy cluster. 

 
 

Max. Poly-Vertex Count Per Noisy Cluster – Specifies the maximum poly-vertices number 
per noisy cluster that can be removed. 
 

Note:  

Noisy clusters are determined by the average distance between poly-vertices and will be removed 
when the number of poly-vertices contained in noisy clusters is smaller than a specified value. 

 

 
 

See Also 

Tools > Point Cloud Tools > Sampling 
 
 
 

Tools > Point Cloud Tools > Sampling 
 

What 

The Sampling command reduces the number of poly-vertices in a model based on curvature, ratio 
or distance. 

 
 
 

Why 

The Sampling command is useful for: 

• Reducing the number of poly-vertices based on curvature, ratio, or distance 

• Reducing the number of poly-vertices based on an allowable tolerance for dealing with large 
point clouds 
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• Removing redundant poly-vertices from points clouds 

 
 

How to Use 

How to sample point clouds 
1. Go to Insert > Point Cloud, click the icon in the toolbar, or double-click a point cloud to 

enter the Point Cloud mode. 

 
 

Note:  

This command can be applied to the partial selected poly-vertices. 

 
 

2. Go to Tools > Point Cloud Tools > Sampling or click the icon in the toolbar. 
 

3. Choose the Uniform Ratio method and check the Consider Curvature option to 
sample point cloud based on its curvature flow. Set the Sampling Ratio to 40 %. 
 

4. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Methods 

Uniform Ratio – Reduces the number of poly-vertices uniformly by the ratio of poly-vertices. 
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Consider Curvature – Samples a point cloud based on its curvature flow. With this option, 
poly-vertices in a high curvature area are sampled less than poly-vertices in a low curvature 
area in order to maintain the accuracy of a curvature flow. 

  
 
Target Poly-Vertex Count – Specifies a target number of poly-vertices to remain after 
sampling. 
 
Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all 
selected data will be used. When the ratio is 50%, half of the selected data will be used. 

 
Uniform Distance – Reduces the number of poly-vertices so that poly-vertices are uniformly 
arranged by average distance. This method removes redundant poly-vertices and constructs a 
grid-type point cloud. 

  
 

Average Distance Between Poly-Vertices – Specifies an average distance between poly-
vertices. To estimate an average distance, click the Estimate button. 
To manually set the distance or radius, use the Measure Distance or Measure Radius 
buttons. 
To measure distance between poly-vertices, click the Measure Distance button and pick 
two poly-vertices. 
To measure a radius of a hole, click the Measure Radius button and pick three poly-vertices. 
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Sampling Ratio – Refer to the Sampling Ratio option in the Uniform Ratio method. 
 

More Options 

Preserve Boundary – Preserves poly-vertices around boundaries. 

 
 
 

See Also 

Tools > Point Cloud Tools > Filter Noise 
 
 
 

Tools > Point Cloud Tools > Smooth 
 

What 

The Smooth command reduces the roughness in the outer shape of point clouds. 

 
 
 

Why 

The Smooth command is useful for: 

• Reducing the effects of roughness in a point cloud 

 
 

How to Use 

How to reduce the effects of roughness in a point cloud 
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1. Go to Insert > Point Cloud, click the icon in the toolbar, or double-click a point cloud to 
enter the Point Cloud mode. 

 
 

Note:  

This command can be applied to partially selected poly-vertices. If 3D scan data is scanned by 
a long-range 3D laser scanner using a spherical measurement type, this information will be used 
for smoothing. 

 
 

2. Go to Tools > Point Cloud Tools > Smooth or click the icon in the toolbar. 
 

3. Adjust the Strength to Max and the Smoothness Level to middle. 
 

4. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Options 

Strength – Adjusts the weight of smoothness by moving the slider between Min and Max. 
 
Smoothness Level – Specifies the iteration of smoothness by moving the slider between Min 
and Max. 
 

More Options 

Allowable Deviation – Specifies an allowable deviation range and limits the deformation of 
poly-vertices within the allowable deviation during smoothing. 

 
 
Do Not Move Boundaries – Preserves poly-vertices around boundaries. 
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See Also 

Tools > Mesh Tools > Smooth 
 
 
 

Tools > Point Cloud Tools > Offset 
 

What 

The Offset command offsets a point cloud by a specified distance. 

 
 
 

Why 

The Offset command is useful for: 

• Offsetting a point cloud by a specific distance 

• Creating a new point cloud that has the same shape but a different scale from an original point 
cloud 

• Creating the opposite side of a point cloud from a partial scan of an object 

 
 

How to Use 

How to offset point clouds by a certain distance 
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1. Go to Insert > Point Cloud, click the icon in the toolbar, or double-click a point cloud 
to enter the Point Cloud mode.  

 
 

Note:  

This command can be applied to partial selected poly-vertices. 

 
 

2. Go to Tools > Point Cloud Tools > Offset or click the icon in the toolbar. 
 

3. Set the Offset Distance to 3mm. 
 

4. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Distance – Specifies an offset distance. To change the offset direction, click the Reverse 
Direction button. 
To manually set the distance or radius, use the Measure Distance or Measure Radius buttons. 
To measure distance between poly-vertices, click the Measure Distance button and pick two 
poly-vertices. 
To measure a radius of a hole, click the Measure Radius button and pick three poly-vertices. 
 

 
 
 

See Also 

Tools > Mesh Tools > Offset 
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Tools > Point Cloud Tools > Construct Mesh 
 

What 

The Construct Mesh command generates a mesh from selected poly-vertices. 

 
 
 

Why 

The Construct Mesh command is useful for: 

• Creating a mesh from partial areas of a point cloud 

 
 

How to Use 

How to construct poly-faces from a part of point clouds 
1. Go to Insert > Point Cloud, click the icon in the toolbar, or double-click a point cloud 

to enter the Point Cloud mode. 

 
 

2. Go to Tools > Point Cloud Tools > Construct Mesh or click the icon in the toolbar. 
 

3. Select poly-vertices in a point cloud. 
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4. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Point Clouds – Selects point clouds or partial poly-vertices as a target entity. 
 

Options 

Methods 

This command features 2 methods: 

• Mesh Construction 

Generates a polygonal mesh by following the geometric shape of a point cloud  

• New Mesh Construction 

Generates a polygonal mesh by using voxel data structures 

 
Mesh Construction – Generates poly-faces by following the geometric shape of a point cloud. 
This method is useful for generating polygonal mesh from a point cloud that has multiple 
combined directional scans that cannot be projected onto a virtual plane or sphere or when 
results are required to be constructed by poly-faces with uniform poly-edge lengths. 
 

Geometry Capture Accuracy – Defines geometry capture accuracy. When the slider is 
moved towards Loose, less poly-faces will be used to create a shape. When the slider is 
moved towards Tight, more poly-faces will be used to create a shape. 
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Loose Tight 

 
Scanner Accuracy – Specifies the accuracy of a scanner. Specify a value by referring to the 
specification of a particular scanner. For example, if target 3D scan data is scanned by a 
small/medium object scanner, the default value of 0.05 mm is suitable. If target 3D scan 
data is scanned by a long-range laser scanner, increase the value based on the precision of 
the scanner. 
 

Note:  

In general, if scan data is clean with a low level of noise, has a regular density, and also has 
satisfactory align accuracy, then using the maximum value of the 'Scanner Accuracy' slider will 
preserve and use most points just as they are. 

Each decreased step in the slider will decrease the creation of meshes by approximately a half of 
the previous step. The result will not be a uniform reduction and high curvature regions will be 
preserved, which is similar to applying a 50% decimation.  

For example, the following combinations create almost the same results:  

- 'Scanner Accuracy' is 0.05mm and 'Geometry Capture Accuracy' is at the 4th step 

- 'Scanner Accuracy' is 0.0333mm (0.05 / 1.5) and 'Geometry Capture Accuracy' is at the 3th step 

- Scanner Accuracy' is 0.075mm (0.05 x 1.5) and 'Geometry Capture Accuracy' is at the 5th step 

 
New Mesh Construction – Generates poly-faces by using voxel data structures. This method is 
useful for generating polygonal mesh from a point cloud that does not have many open 
boundaries. This method is also quicker and can produce better results than the Mesh 
Construction method. 
 

Note:  

To get satisfactory results from the New Mesh Construction method, scan data must have normal 
information and using a mesh that has few open boundaries is ideal because the algorithm 
extends boundaries beyond their initial settings. The New Mesh Construction method keeps 
normal information consistent on connected triangles and can be useful for long range scan 
data and scan data with no boundaries. 

 
Global Shape Fitting Resolution – Controls how many voxel structures are used to create 
a resulting mesh. The higher the voxel structure count, the more control points can be 
used to represent the original shape of the scan data.  

 
Shape Fitting To Source Data – Defines geometry capture accuracy. When the slider is 
moved towards Loose, less poly-faces will be used to create a shape. When the slider is 
moved towards Tight, more poly-faces will be used to create a shape. 

 

More Options 

Remove Original Data – Removes original 3D scan data after triangulation. 
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Reduce Noise – Reduces noisy poly-faces. 

  

Without Reduce Noise option With Reduce Noise option 
 
Remove Redundant Points – Removes redundant poly-vertices by a specified distance for 
better triangulation results. 
 
Remove Original Data – Removes original point cloud after triangulation. 
 
Suppress Result In Feature Tree – Suppresses results from the Feature Tree. 
 

Note:  

The Suppress and Unsuppress mechanisms manage data memory by swapping data dynamically 
between physical memory and a hard disk. This function is useful for effectively managing and handling 
a large 3D scan data file. 

Created Features can be suppressed or unsuppressed by checking the box next to the feature name in 
the Feature Tree. 

  
Unsuppressed Suppressed 

 

 
Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all selected 
data will be used. When the ratio is 50%, half of the selected data will be used. 
 
Assume Vertices Are Densely Placed Along A Direction – Samples redundant poly-vertices 
closed by a certain distance for better triangulation results. Check this option when target 3D 
scan data is scanned by a line laser with a CMM/Arm device. 
 
Crease Angle – Specifies a maximum angle between normal vectors of adjacent poly-faces to 
avoid generating abnormal poly-faces. 
 
Noise Reduction Sampling – Reduces noise using a sampling algorithm. 
 
Create Watertight Mesh – Closes boundaries using the curvature of scan data.  
 

Curved – Creates a closed curved boundary at open boundaries. 
 
Flat – Creates a closed flat boundary at open boundaries. 
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See Also 

Tools > Scan Tools > Triangulate 
 
 
 

Tools > Point Cloud Tools > Convert Entities 
 

What 

The Convert Entities command converts bodies, faces, and curve into point clouds. 

 
 
 

Why 

The Convert Entities command is useful for: 

• Converting other entities into a point cloud 

 
 

How to Use 

How to convert an entity into a point cloud 
1. Go to Insert > Point Cloud, click the icon in the toolbar, or double-click a point cloud 

to enter the Point Cloud mode. 

 
 

2. Go to Tools > Point Cloud Tools > Convert Entities or click the icon in the toolbar. 
 

3. Select a face on a body to convert it into a point cloud. 
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4. Click the OK to complete the command. 

 
 

5. Hide the body in the Model View to see only the point cloud. 

 
 
 

Options in Detail 

Target Entities 

Entities – Selects curves, 3D sketches, sketches, faces, and surface and solid bodies as target 
entities. 

  
Body 

 

  

Face 
 

 
 

Curve 
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Options 

Quality – Specifies the resolution of a point cloud by moving the slider between Low and High. 

   

Quality: Low Quality: Medium Quality: High 
 
Advanced – Adjusts the distance between poly-vertices in detail. 
 

Max. Chord Height – Specifies the maximum chord height of poly-faces to be converted. 
To manually set the distance or radius, use the Measure Distance or Measure Radius 
buttons. 
To measure distance between poly-vertices, click the Measure Distance button and pick 
two poly-vertices. 
To measure a radius of a hole, click the Measure Radius button and pick three poly-
vertices. 
 

Note:  

The chord height is the distance between a mesh and a face of a target body to be converted.  

 

 
Max. Edge Length – Specifies the maximum edge length of poly-faces to be converted. 
 

Note:  

This option limits the maximum edge length of poly-faces to be converted. 

 

 
Min. Edge Length – Specifies the minimum edge length of poly-faces to be converted. 
 

Note:  

This option limits the minimum edge length of poly-faces to be converted. 
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More Options 

Include Accuracy Analyzer Color – Adds a deviation color map onto a converted point cloud as 
a vertex color. 
 

Note:  

This option is useful for creating a point cloud with a deviation color map from a modeled solid or 
surface body. It is available when scan data and a modeled solid or surface bodies exist and have been 
compared using Accuracy Analyzer™. 

To use this option: 

1. Choose the Deviation option in the Accuracy Analyzer panel in the Default mode. 

2. Go to Insert > Point Cloud or click the icon in the toolbar. 

3. Go to Tools > Point Cloud Tools > Convert Entities or click the icon in the toolbar. 

4. Select modeled bodies. 

5. Check the Include Accuracy Analyzer Color option. 

6. Click the OK button. 

  
Deviation Result Colored Point Cloud 

 
 

 
 

See Also 

Tools > Mesh Tools > Convert Body 
 
 
 

Tools > Point Cloud Tools > Separate Point Cloud 
 

What 

The Separate Point Cloud command takes a single point cloud and divides it into several groups. 
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Why 

The Separate Point Cloud command is useful for: 

• Separating areas of interest from a large point clouds 

• Handling with large-sized point clouds 

• Modeling with district units 

 
 

How to Use 

How to separate a point cloud from an original point cloud 
1
. 

Go to Insert > Point Cloud, click the icon in the toolbar, or double-click a point cloud 
to enter the Point Cloud mode. 

 
 

2
. 

Go to Tools > Point Cloud Tools > Separate Point Cloud or click the icon in the 
toolbar. 
 

3
. 

Select target point clouds, then click the Next Stage button . 
 

4
. 

Choose the Grid method, and then draw a rectangle by dragging to define the separating areas. 

 
 

5
. 

Set the grid size by inputting the X and  Y values of cells. 
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6
. 

To manually adjust the distance between cells, drag the border of a cell. 

 
 

7
. 

Click the OK button to complete the command. Separated point clouds can be 
confirmed in the Model tree. 

 
 

 
 

Options in Detail 

Select Entities 

Point Clouds – Selects a point cloud or multiple point clouds as target entities. 
 

Methods 

Grid – Divides a point cloud by a grid. 
 

Draw Grid – Draws a rectangular grid by dragging on the point cloud. 
 

No. Of Cells – Defines the number of cells in the grid. Cell size can be adjusted by dragging the 
border of a cell. 

 
 
Overlap Range – Defines the overlapping area between neighboring point clouds. 

 
Ratio – Defines the overlapping area by the ratio of the cell size. 



Geomagic Design X | Menu  699 
 

 
Distance – Defines the overlapping area by the distance from border of cells. 

 
Selection – Divides a point cloud by the manual selection of points. 
 

Groups – Includes selected points in a current group. More groups can be added using 
the Add Group button . 

 
 

More Options 

Remove Original Data – Removes separated point clouds from the original data after the 
command is finished. 
 

Show Target Point Could Only – Hides remaining point clouds in Stage2 if point clouds are 
selected as a target from multiple point clouds in Stage1. If this option is unchecked all point 
clouds will be shown. 

 
 

See Also 

Insert > Point Cloud 
 
 
 

7.5.5. Tools > Texture Tools 
 
The Texture Tools menu features various commands used to edit and manage colors and textures 
on a mesh or point cloud. 
 
The Texture Tools are divided into 3 tool groups used to: 
 

Editing Texture 

• Add Texture 

Attaches texture onto a mesh 

• Edit Texture 

Edits texture on mesh 

• Remove Texture 

Removes texture mapped on a mesh 

• Export Texture 
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Exports texture to a 2D image file format 

 
 

Managing Texture And Color  

• Convert Texture To Color 

Converts a texture to a vertex color 

• Convert Color To Texture 

Converts a vertex color to a texture 

• Copy Texture/Vertex Color 

Copies a texture or a vertex color 

 
 

Matching Colors  

• Match Color 

Matches colors 

 
 
 

Tools > Texture Tools > Add Texture 
 

What 

The Add Texture command attaches 2D texture, also known as a bitmap image, onto a mesh. 

 
 
 

Why 

The Add Texture command is useful for: 

• Attaching 2D textures onto a mesh 

• Attaching a high quality 2D texture image onto 3D mesh model 

• Creating a 3D texture-mapped model from a mesh model scanned by a 3D scanner that cannot 
capture color information 
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How to Use 

How to attach texture onto a mesh 
1. Select a mesh. Go to Insert > Mesh, click the icon in the toolbar, or double-click the 

mesh to enter the Mesh mode.  

 
 

2. Go to Tools > Texture Tools > Add Texture or click the icon in the toolbar. 
 

3. Click the Import Texture button and import an image file. The imported image will be 
shown in the Texture View. 

 
 

Note:  

When Texture View is not visible, right-click on an empty area in the toolbar and choose Texture 
View in the pop-up list. 
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4. Pick points on the image and pick the corresponding points on the model. To get better 
results, cover the entire geometric shape with corresponding points. 

 
 

 

Note:  

Zooming and panning an image in Texture View is the same as manipulating a model in the 
Model View. 
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5. Click the OK button to complete the command. 

 
 

Note:  

After adding a texture it can be finely adjusted by using the Smudge method in the Edit Texture 
command. 

 
 

 
 

Options in Detail 

Method 

Entire – Applies image mapping to an entire area of a mesh. 
 
Region – Applies image mapping to the selected areas of a mesh. 
 

Load Texture 

Load Texture – Imports a texture image to be mapped on a mesh. 
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Add Texture Option 

Brightness – Specifies the brightness of a texture image between -255 and 255, or sets the 
brightness by moving the slider between Dark and Bright. 

   

Dark Medium Bright 
 
Flip & Rotate – Uses transformation buttons to flip or rotate an imported texture image. 

 
Flip 

 

 
Rotate 

 
Create Corresponding Points – Picks corresponding points on an image and mesh. 
 

Note:  

To reset all selections, click the Select None button. To remove only the last picked point, click the 
Deselect Last button. 

 
Delete Corresponding Points – Select the Select button and defined corresponding points to 
remove them. To remove selected points, click the Delete button or press the Delete key. 

 
 

See Also 

Tools > Texture Tools > Remove Texture 
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Tools > Texture Tools > Edit Texture 
 

What 

The Edit Texture command edits brightness, contrast, and U/V coordinate color balance of mapped 
texture on mesh data. This command is available with color or texture mapped mesh and point 
clouds. 

 
 
 

Why 

The Edit Texture command is useful for: 

• Editing textures on a mesh 

 
 

How to Use 

How to edit texture on mesh 
1. Select a mesh. Go to Insert > Mesh, click the icon in the toolbar, or double-click a mesh 

to enter the Mesh mode. 
 

2. Go to Tools > Texture Tools > Edit Texture or click the icon in the toolbar. 
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3. Choose the Auto Level method. 

 
 

Note:  

The Texture View will be displayed when a target mesh has texture. The Texture View shows 
all textures in mesh data and enables the interactive editing of texture.  

Zooming or panning a textured image is the same as manipulating a model in the Model View. 
To adjust the editing zone, drag the mouse cursor using the Left Mouse Button, or LMB, while 
holding the Ctrl key. 

  

In Texture View In Model View 
 

 
 

4. Click the OK button to complete the command. The overall color will be brighter. 

 
 
 

Options in Detail 

Methods 

This command features 8 methods: 

• Brightness And Contrast 

Adjusts brightness and contrast 

• Curves 

Edits the tonality of colors by a curve 

• Balance 

Edits color balance 

• Auto Level 



Geomagic Design X | Menu  707 
 

Automatically adjusts color level 

• UV Coordinate 

Edits U/V coordinates on a texture 

• Smudge 

Adds smudges onto a texture 

• Dodge 

Lightens a texture 

• Burn 

Darkens a texture 

 
Brightness And Contrast – Adjusts Brightness and Contrast. 
 

Brightness – Sets the brightness of a texture by specifying a value between -255 and 255 
or moving the slider between Min. and Max. 

   
Brightness: -100 Brightness: 0 Brightness: 100 

 
Contrast – Sets the contrast of a texture by specifying a value between -100 and 100 or 
moving the slider between Min. and Max. 

   
Contrast: -50 Contrast: 0 Contrast: 50 

 
Curves – Edits the tonality of colors by a curve. The shape of the curve can be modified in the 
Curves dialog box to adjust the tonality and color of textures.  
Bowing the curve upward lightens textures, and bowing the curve downward darkens them. 
The steeper sections of the curve represent portions of an image with more contrast. Conversely, 
flatter sections of the curve represent areas of lower contrast in a texture. Changes can be 
applied to RGB at the same time or for each value independently.  
To add control points, click on a curve. To remove control points, select a point and drag it 
outside of the graph area. 
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Balance – Edits color balance. 
 

Select Range To Modify – Selects Shadows, Midtones, or Highlights to change its tonal 
range. 
 
Modify Selected Range’s Color Levels – Sets the color balance for a range by specifying 
a value between -100 and 100 or by moving the sliders. 

   
Balanced Emphasizing Red Color Emphasizing Blue Color 

 
Preserve Luminosity – Preserve the luminosity values in a texture while changing its 
color. This option maintains the tonal balance in a texture. 

 
Auto Level – Automatically adjusts the color level of a texture. This method clips a portion of 
the shadows and highlights in each channel and maps the lightest and darkest pixels in each 
color channel to pure white (level 255) and pure black (level 0). Using Auto Levels increases the 
contrast in a texture. 
 
UV Coordinate (Texture Only) – Edits U/V coordinates on a texture by using a brush in the 
Texture View. The editing zone can be adjusted by using Alt + LMB and dragging the U/V texture 
map in the Texture View. 
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In Texture View In Model View 
 
Smudge (Texture Only) – Adds smudging on textures by simulating the action of dragging a 
finger through wet paint. The command picks up color where the stroke begins and pushes it in 
the dragging direction. The editing zone can be adjusted by using Alt + LMB and dragging the 
U/V texture map in the Texture View. 

 
In Texture View 

 
In Model View 

 
Strength – Adjusts the weight of smudging by moving the slider between Min and Max. 

 
Dodge and Burn (Texture Only) – Lightens or darkens a texture. The Dodge and Burn methods 
are based on traditional photography techniques for regulating exposure on specific areas of a 
print. The Shadows, Midtones, or Highlights options specify the tonal range to be changed. 
 
Exposure – Specifies the strength of a light by moving the slider between Less and More. 

 
 

See Also 

Tools > Texture Tools > Add Texture 
Tools > Texture Tools > Remove Texture 
 
 
 

Tools > Texture Tools > Remove Texture 
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What 

The Remove Texture command removes textures mapped on a mesh. 

 
 
 

Why 

The Remove Texture command is useful for: 

• Removing texture from a mesh 

 
 

How to Use 

How to remove textures from mesh 
1. Select a mesh. Go to Insert > Mesh, click the icon in the toolbar, or double-click the 

mesh to enter the Mesh mode. 

 
 

2. Go to Tools > Texture Tools > Remove Texture or click the icon in the toolbar. Check 
the results. 

 
 
 

See Also 

Tools > Texture Tools > Add Texture 
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Tools > Texture Tools > Export Texture 
 

What 

The Export Texture command exports mapping source textures to an image file such as a jpg, bmp, 
tip, tga, gif or png. 

 
 
 

Why 

The Export Texture command is useful for: 

• Exporting a texture into an image file 

 
 

How to Use 

How to export a texture into a 2D image file format 
1. Select a mesh. Go to Insert > Mesh, click the icon in the toolbar, or double-click the 

mesh to enter the Mesh mode.  
 

2. Go to Tools > Texture Tools > Export Texture or click the icon in the toolbar. 
 

3. The Export Image dialog box appears. Select a file format and click the Save button. 
 
 

See Also 

Tools > Texture Tools > Add Texture 
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Tools > Texture Tools > Convert Texture To Color 
 

What 

The Convert Texture To Color command converts a texture to a vertex or mesh color. 

 
 
 

Why 

The Convert Texture To Color command is useful for: 

• Converting a texture to a vertex or mesh color 

 
 

How to Use 

How to convert a texture to a vertex color 
1. Select a mesh. Go to Insert > Mesh, click the icon in the toolbar, or double-click the 

mesh to enter the Mesh mode. 
 

2. Go to Tools > Texture Tools > Convert Texture To Color or click the icon in the toolbar. 
Check that the Has Vertex Color option in the Property panel is set to True. 

 
 
 

See Also 

Tools > Texture Tools > Convert Color to Texture 
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Tools > Texture Tools > Convert Color To Texture 
 

What 

The Convert Color To Texture command converts a vertex or mesh color to a texture. 

 
 
 

Why 

The Convert Color To Texture command is useful for: 

• Converting a vertex or mesh color to a texture 

 
 

How to Use 

How to convert vertex color to texture 
1. Select a mesh. Go to Insert > Mesh, click the icon in the toolbar, or double-click the 

mesh to enter the Mesh mode. 

 
 

2. Go to Tools > Texture Tools > Convert Color To Texture or click the icon in the 
toolbar. 
Check that the Has Texture option in the Property panel is set to True. 
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See Also 

Tools > Texture Tools > Convert Texture To Color 
 
 
 

Tools > Texture Tools > Copy Texture/Vertex Color 
 

What 

The Copy Texture/Vertex Color command copies a texture or vertex color from an existing mesh 
or point cloud and pastes it into another mesh or point cloud. 

 
 
 

Why 

The Copy Texture/Vertex Color command is useful for: 

• Copying a texture or vertex color from an existing mesh or point cloud and pasting it into 
another mesh or point cloud 

 
 

How to Use 

How to copy a texture or vertex color and paste it into another mesh 
1. Select a mesh. Go to Insert > Mesh, click the icon in the toolbar, or double-click the 

mesh to enter the Mesh mode. 
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2. Go to Tools > Texture Tools > Copy Texture/Vertex Color or click the icon in the 
toolbar. 
 

3. Select a mesh that has a texture. 

 
 

4. Click the OK button to complete the command. Check that the texture is copied and 
pasted into the other mesh. 

 
 
 

See Also 

Tools > Texture Tools > Convert Texture To Color 
Tools > Texture Tools > Convert Color To Texture 
 
 
 

Tools > Texture Tools > Match Color 
 

What 

The Match Color command synchronizes the color temperature between two meshes or point 
clouds. This tool is available when point clouds or meshes have color information. 
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Why 

The Match Color command is useful for: 

• Matching color temperatures between two meshes or point clouds 

 
 

How to Use 

How to match colors 
1. Go to Tools > Texture Tools > Match Color or click the icon in the toolbar. 

 
 

2. Choose the Match Color Based On Reference option. 
 

3. Select a reference and target meshes. 

 
 

4. Click the Next Stage button to continue. 
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5. Click the OK button to complete the command. 
 
 

Options in Detail 

Choose Among Candidates – Automatically synchronizes the color temperatures of two 
meshes or point clouds and presents candidates to choose from in the second stage. 
 
Match Color Based On Reference – Manually defines the Reference and Targets. Targets will 
be compensated based on the reference color by choosing a result from the candidates in the 
second stage. 

 
 

See Also 

Tools > Texture Tools > Copy Texture/Vertex Color 
 
 
 

7.5.6. Tools > Sketch Entities 
 
The Sketch Entities menu features various commands used to make sketches such as the Line, 
Rectangle, Circle, Arc commands. 
Create sketch entities on a base sketch plane by using the various sketch drawing tools to create 
feature shapes. 
 
The Sketch Entities are divided into 6 tool groups used to create: 
 

Automatic Sketching Tool 

• Auto Sketch 

Automatically creates sketch entities based on analyzed geometric features 

 
 

Line Sketch Type 

• Lines 

Draws lines 

• Rectangles 

Draws rectangles 
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• Parallelograms 

Draws parallelograms 

• Polygons 

Draws polygons 

• Slots 

Draws slots 

 
 

Arc Sketch Type 

• Circles 

Draws circles by defining a center and radius 

• Perimeter Circles 

Draws circles by selecting 3 points 

• 3 Tangent Circles 

Draws inscribed circles that touch the edges of 3 other sketch entities 

• Centerpoint Arcs 

Draws arcs by defining a center position and radius 

• Tangent Arcs 

Draws arcs continually connected to another sketch entity by a tangent constraint 

• 3 Point Arcs 

Draws arcs by selecting 3 points 

• 3 Tangent Arcs 

Draws inscribed arcs that touch the edges of 3 other sketch entities 

 
 

Spline Sketch Type 

• Ellipses 

Draws ellipses 

• Partial Ellipses 

Draws partial ellipses 

• Parabolas 

Draws parabolas 

• Splines 

Draws splines 

 
 

See Also Sketch Type 
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• Centerlines 

Adds centerlines as a reference for drawing other sketch entities or an axis for constructing 
geometry features 

• Points 

Adds points as a reference for drawing other sketch entities or a reference point for constructing 
geometry features 

• Texts 

Add text sketch entities constructed by lines, circles and splines 

 
 

Useful Sketch Tools 

• By Fitting Polyline 

Creates circle or arc sketch entities by fitting a section polyline 

• By Import 

Imports 2D CAD drawing files as sketch entities onto a base sketch plane 

 
 
 

Tools > Sketch Entities > Auto Sketch 
 

What 

The Auto Sketch command automatically creates sketch entities such as lines, circles, and arcs on 
section polylines based on analyzed section polylines. This command is available in the Mesh 
Sketch mode only. 

 
 
 

Why 

The Auto Sketch command is useful for: 

• Quickly creating sketch entities based on scan sections. 
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How to Use 

How to automatically create sketch entities on section polyline in the 
Mesh Sketch mode 
1. Go to Insert > Mesh Sketch or click the icon in the toolbar to enter the Mesh Sketch 

mode. 
Create section polylines. For more information, see Insert > Mesh Sketch. 

 
 

2. Show section polylines only. 

 
 

3. Go to Tools > Sketch Entities > Auto Sketch or click the icon in the toolbar. 
 

4. Set the resolution of section polylines by adjusting the slider in the Segment Section 
Polyline dialogue box. 

 
 

5. The segments of the section polylines will be classified. 

 
 

6. Choose the Make All Curves option and then click the OK button to complete the 
command.  
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Note:  

The Enable Realtime Preview button displays results in real-time without leaving the 
command. 

 
 

 
 

Options in Detail 

Methods 

Make All Curves – Creates a sketch to whole polylines. 
 
Make Selected Only – Creates a sketch only to selected polylines. To cancel the selection, push 
the Cancel button on the keyboard. 
 
Resolution – Specifies the resolution of section segments by adjusting the slider between Min. 
and Max. Adjusting the slider towards Max., will construct more segments. While adjusting the 
slider, classified line and arc section segments will be updated in real-time. 

   

Low Resolution High Resolution 
 

Note:  

The Resolution option is synchronized with the value of the Resolution option in the Segment Section 
Polyline tool palette. While adjusting the resolution of section polylines, the resolution in the Segment 
Section Polyline tool palette will also be changed. 
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Geometry Capture Accuracy – Specifies geometry capture accuracy by adjusting the slider 
between Loose and Tight. When moving the slider toward Tight, sketches will be extracted from 
section segments with a tight tolerance. 
 
Sewing Tolerance – Specifies a tolerance range for sewing sketches by adjusting the slider 
between Min. and Max. When adjusting the slider toward Max., sketches will be joined with 
coincidence constraint with a loose tolerance. 

  

With Tight Tolerance With Loose Tolerance 
 

Note:  

When moving the slider toward Min., sketches may not be joined with coincidence constraint because 
of use of tight tolerance. 

 
Remove Small Fillet – Removes automatically generated small fillets by using a radius value. 

  

Filleted Feature Removed Fillet 
 

 
 

See Also 

Tools > Sketch Entities > Line 
Tools > Sketch Entities > Circle  
Tools > Sketch Entities > Centerpoint Arc 
Tools > Sketch Entities > Tangent Arc 
 
 
 

Tools > Sketch Entities > Line 
 

What 

The Line command draws lines on a base sketch plane. 
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Why 

The Line command is useful for: 

• Drawing lines on a base sketch plane 

• Creating a sketch profile to be used for creating planar features 

 
 

How to Use 

A. How to draw lines in Sketch mode 
1
. 

Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to 
draw sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2
. 

Go to Tools > Sketch Entities > Line or click the icon in the toolbar. 
 

3
. 

Pick a starting point and draw a line to an ending point. 

 
 

4
. 

Click the right mouse button to complete the construction of the line. Click the OK 
button to complete the command. 
 

Note:  

To finish drawing a line, double-click the left mouse button or single-click the right mouse 
button. If more lines are needed, continually draw lines without leaving the command. After 
drawing lines, the command can be finished by clicking the Cancel button. 

 

 
 

B. How to draw lines on section polylines in Mesh Sketch mode 
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1. Go to Insert > Mesh Sketch or click the icon in the toolbar to enter the Mesh Sketch 
mode. 
Create section polylines. For more information, see Insert > Mesh Sketch. 

 
 

2. Hide mesh to make only the section polylines visible. 

 
 

3. Go to Tools > Sketch Entities > Line or click the icon in the toolbar. 
 

4. Check the Fit Polyline option, select section polylines, and confirm the preview line by 
clicking the Accept Fitting button or double-clicking the left mouse button. 

 
Select Segment 

 
Apply 

 

5. Drag and select segments on the section polyline. Confirm the preview line by clicking 
the Accept Fitting button or double-clicking the left mouse button. 

 
Select Segments 

 
Apply 

 

6. Create more lines as they are needed. Click the OK button to complete the command. 
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Options in Detail 

Start – Shows the starting position of a line to be generated. 
 
End – Shows the ending position of a line to be generated. 
 
For Construction – Creates a line for construction. The construction line can be used as a 
reference for drawing other sketch entities or an axis for constructing revolving features. 

  

Normal Line For Construction Line 
 
Fit Polyline – Creates a line on a section polyline from a mesh or point cloud. 

 
 

 

Note:  

To accept a fitting, click the Accept Fitting button  or double-click the left mouse button. To cancel 

a fitting, click the Cancel Fitting button . To clear a selection, click the Clear Selection button . 
 

 
 

See Also 

Tools > Sketch Entities > Rectangle 
Tools > Sketch Entities > Parallelogram 
Tools > Sketch Entities > Polygon 
Tools > Sketch Entities > Slot 
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Tools > Sketch Entities > Rectangle 
 

What 

The Rectangle command draws rectangles on a base sketch plane. 

 
 
 

Why 

The Rectangle command is useful for: 

• Drawing rectangles on a base sketch plane 

• Creating 4-sided closed outline sketches constructed out of lines and direction constraints 

• Creating sketch profiles to be used for creating planar features 

 
 

How to Use 

How to draw Rectangles 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to draw 

sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Rectangle or click the icon in the toolbar. 
 

3. Pick a starting point and draw a rectangle to an ending point. 

 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 

Start – Shows the starting top-left position of a rectangle to be generated. 
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End – Shows the ending bottom-right position of a rectangle to be generated. 

 
 

See Also 

Tools > Sketch Entities > Line 
Tools > Sketch Entities > Parallelogram 
Tools > Sketch Entities > Polygon 
Tools > Sketch Entities > Slot 
 
 
 

Tools > Sketch Entities > Parallelogram 
 

What 

The Parallelogram command draws parallelograms on a base sketch plane. 

 
 
 

Why 

The Parallelogram command is useful for: 

• Drawing parallelograms on a base sketch plane 

• Creating 4-sided closed outline sketches constructed by lines 

• Creating a sketch profile used for creating planar features 

 
 

How to Use 

How to draw parallelograms 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to draw 

sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Parallelogram or click the icon in the toolbar. 
 

3. Pick a starting point and draw a parallelogram to an ending point. 
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4. Click the OK button to complete the command. 
 
 

Options in Detail 

Start – Shows the starting corner position of a parallelogram to be generated. 
 
Pass – Shows the passing corner position of a parallelogram to be generated. 
 
End – Shows the ending corner position of a parallelogram to be generated. 

 
 

See Also 

Tools > Sketch Entities > Line 
Tools > Sketch Entities > Rectangle 
Tools > Sketch Entities > Polygon 
Tools > Sketch Entities > Slot 
 
 
 

Tools > Sketch Entities > Polygon 
 

What 

The Polygon command draws polygons on a base sketch plane. 

 
 
 

Why 

The Polygon command is useful for: 

• Drawing polygons on a base sketch plane 
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• Creating multi-sided closed outline sketches constructed by lines 

• Creating a sketch profile to be used for creating planar features 

 
 

How to Use 

How to draw Polygons 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to draw 

sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Polygon or click the icon in the toolbar. 
 

3. Set the Edge Count to 5. 
 

4. Pick a center point and define a radius and an angle by picking a second point on the 
base sketch plane. 

 
 

5. Click the OK button to complete the command. 
 
 

Options in Detail 

Center – Shows the center position of a polygon to be generated. 
 
Radius – Shows the radius of a polygon to be generated. 
 
Rotation Angle – Shows the rotation angle of a polygon with respect to the U axis of a base sketch 
plane. 
 
Edge Count – Specifies the number of edges in a polygon. 

  

Edge Count: 7 Edge Count: 5 
 
Circumscribed Circle – Creates a polygon using a circumscribed circle. 
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Circumscribed Circle Inscribed Circle 

 

 
 

See Also 

Tools > Sketch Entities > Line 
Tools > Sketch Entities > Rectangle 
Tools > Sketch Entities > Parallelogram 
Tools > Sketch Entities > Slot 
 
 
 

Tools > Sketch Entities > Slot 
 

What 

The Slot command draws slots on a base sketch plane. 

 
 
 

Why 

The Slot command is useful for: 

• Drawing slots on a base sketch plane 

• Creating slot sketches constructed by lines and arcs with tangent constraints 

• Creating a sketch profile used for creating a slot boss or hole features 

 
 

How to Use 

How to draw Slots 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to draw 
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sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Slot or click the icon in the toolbar. 
 

3. Pick a starting point. Draw a line to a passing point and finish the drawing at the ending 
point. 

 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 

Start – Shows the starting corner position of a slot to be generated. 
 
Pass – Shows the passing corner position of a slot to be generated. 
 
End – Shows the ending corner position of a slot to be generated. 
 
Length – Shows the length between the center points of two arcs. 
 
Radius – Shows the radius of an arc. 

 
 

See Also 

Tools > Sketch Entities > Line 
Tools > Sketch Entities > Rectangle 
Tools > Sketch Entities > Parallelogram 
Tools > Sketch Entities > Polygon 
 
 
 

Tools > Sketch Entities > Circle 
 

What 

The Circle command draws circles on a base sketch plane. 
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Why 

The Circle command is useful for: 

• Drawing circles on a base sketch plane 

• Creating a sketch profile to be used for creating circular or cylindrical features 

 
 

How to Use 

A. How to draw circles in Sketch mode 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to 

draw sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities >Circle or click the icon in the toolbar. 
 

3. Pick a center point. 
 

4. Pick a point to define the radius of the circle to be generated. 

 
 

5. Click the OK button to complete the command. 
 
 

B. How to draw circles on a section polyline in Mesh Sketch mode 
1. Go to Insert > Mesh Sketch or click the icon in the toolbar to enter the Mesh Sketch 

mode. 
Create section polylines using the Mesh Sketch mode. For more information, see 
Insert > Mesh Sketch. 
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2. Hide mesh to make only section polylines visible in the Model View. 

 
 

3. Go to Tools > Sketch Entities > Circle or click the icon in the toolbar. 
 

4. Check the Fit Polyline option. Select section polylines and confirm the preview line by 
clicking the Accept Fitting button or double-clicking the left mouse button. 

 
 

5. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Center – Shows the center position of a circle to be generated. 
 
Radius – Shows the radius of a circle to be generated. 
 
For Construction – Creates a circle for construction. The construction circle can be used as a 
reference for drawing other sketch entities or a guide curve for constructing circular patterned 
features. 
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Normal Circle For Construction Circle 
 
Fit Polyline – Creates a circle by fitting to section polylines that are a section segment from a 
mesh or point cloud. 

  
 

Note:  

To accept a fitting, click the Accept Fitting button  or double-click the left mouse button. To cancel 

a fitting, click the Cancel Fitting button . To clear a selection, click the Clear Selection button . 
 

 
 

See Also 

Tools > Sketch Entities > Perimeter Circle 
Tools > Sketch Entities > 3 Tangent Circle 
Tools > Sketch Entities > Centerpoint Arc 
Tools > Sketch Entities > Tangent Arc 
Tools > Sketch Entities > 3 Point Arc 
Tools > Sketch Entities > 3 Tangent Arc 
 
 
 

Tools > Sketch Entities > Perimeter Circle 
 

What 

The Perimeter Circle command draws circles constructed by 3 points on a base sketch plane. 
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Why 

The Perimeter Circle command is useful for: 

• Drawing circles by picking 3 points on a base sketch plane 

• Creating a sketch profile to be used for creating circular or cylindrical features 

 
 

How to Use 

To draw circle by constructing with picking 3 points 
1. Go to Insert > Sketch or click the icon in the toolbar . Select a base sketch plane to 

draw sketches in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities >Perimeter Circle or click the icon in the toolbar. 
 

3. Pick a first point, a second point, and a third point to create a circle. 

 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 

Center – Shows the center position of a circle to be generated. 
 
Radius – Shows the radius of a circle to be generated. 

 
 

See Also 

Tools > Sketch Entities > Circle 
Tools > Sketch Entities > 3 Tangent Circle 
Tools > Sketch Entities > Centerpoint Arc 
Tools > Sketch Entities > Tangent Arc 
Tools > Sketch Entities > 3 Point Arc 
Tools > Sketch Entities > 3 Tangent Arc 
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Tools > Sketch Entities > 3 Tangent Circle 
 

What 

The 3 Tangent Circle command draws inscribed circles that touch the edges of 3 other sketch 
entities on a base sketch plane. 

 
 
 

Why 

The 3 Tangent Circle command is useful for: 

• Drawing inscribed circles that touch the edges of 3 other sketch entities on a base sketch plane 

• Creating a sketch profile to be used for creating circular or cylindrical features 

 
 

How to Use 

To draw inscribed circles that touch the edges of 3 other sketch 
entities 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to draw 

sketches in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > 3 Tangent Circle or click the icon in the toolbar. 

 
 

Note:  

To use this command, three sketch entities must exist. 

 
 

3. Pick a line and two arcs. 
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4. Click the OK button to complete the command. 
 
 

Options in Detail 

Center – Shows the center position of a circle to be generated. 
 
Radius – Shows the radius of a circle to be generated. 

 
 

See Also 

Tools > Sketch Entities > Circle 
Tools > Sketch Entities > Perimeter Circle 
Tools > Sketch Entities > Centerpoint Arc 
Tools > Sketch Entities > Tangent Arc 
Tools > Sketch Entities > 3 Point Arc 
Tools > Sketch Entities > 3 Tangent Arc 
 
 
 

Tools > Sketch Entities > Centerpoint Arc 
 

What 

The Centerpoint Arc command draws arcs on a base sketch plane. 

 
 
 

Why 

The Centerpoint Arc command is useful for: 
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• Drawing arcs on a base sketch plane 

• Creating a sketch profile to be used for creating cylindrical features 

 
 

How to Use 

A. How to draw centerpoint arcs in Sketch mode 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to 

draw sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Centerpoint Arc or click the icon in the toolbar. 
 

3. Pick a center point. 
 

4. Pick a starting and ending points for an arc. 

 
 

5. Click the OK button to complete the command. 
 
 

B. How to draw centerpoint arcs on section polyline in Mesh Sketch 
mode 
1. Go to Insert > Mesh Sketch or click the icon in the toolbar to enter the Mesh Sketch 

mode. 
Create section polylines. For more information, see Insert > Mesh Sketch. 

 
 

2. Hide the mesh to make section polylines visible only in the Model View. 
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3. Go to Tools > Sketch Entities > Centerpoint Arc or click the icon in the toolbar. 
 

4. Check the Fit Polyline option. Select section polylines and confirm the preview arc by 
clicking the Accept Fitting button or double-clicking the left mouse button. 
 

  
Note:  

Arcs can be created on partial section polylines by dragging and selecting segments with the 
Fit Polyline option. 

 
 

5. Click the OK button to complete the command. 
 
 

Options in Detail 

Center – Shows the center position of an arc to be generated. 
 
Radius – Shows the radius of an arc to be generated. 
 
Start – Shows the starting position of an arc to be generated. 
 
End – Shows the ending position of an arc to be generated. 
 
For Construction – Creates an arc for construction. The construction arc can be used as a 
reference for drawing other sketch entities or a guide curve for constructing circular patterned 
features. 

  
Normal Arc For Construction Arc 

 
Fit Polyline – Creates an arc by fitting to section polylines that are a section segment from a 
mesh or point cloud. 

  
 

Note:  

To accept a fitting, click the Accept Fitting button  or double-click the left mouse button. To cancel 

a fitting, click the Cancel Fitting button . To clear a selection, click the Clear Selection button . 
 

 



Geomagic Design X | Menu  740 
 

 

See Also 

Tools > Sketch Entities > Circle 
Tools > Sketch Entities > Perimeter Circle 
Tools > Sketch Entities > 3 Tangent Circle 
Tools > Sketch Entities > Tangent Arc 
Tools > Sketch Entities > 3 Point Arc 
Tools > Sketch Entities > 3 Tangent Arc 
 
 
 

Tools > Sketch Entities > Tangent Arc 
 

What 

The Tangent Arc command draws arc that can be continually connected to another sketch entity 
by a tangent constraint. 

 
 
 

Why 

The Tangent Arc command is useful for: 

• Drawing arcs on a base sketch plane that are continually connected with other sketch entity by 
a tangent constraint 

• Creating a sketch profile to be used for creating blended features with planar/cylindrical or 
cylindrical/cylindrical feature shapes 

 
 

How to Use 

How to draw a tangent arc that is continually connected to another 
sketch entity 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to draw 

sketches on in the Sketch mode. For more information, see Insert > Sketch. 
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2. Go to Tools > Sketch Entities > Tangent Arc or click the icon in the toolbar. 
 

Note:  

To use this command, sketch entities must exist. 

 
 

3. Pick a point on another entity to set the selected point as a Starting point of an arc to 
be generated. 

 
 

4. Pick an ending point and click the right mouse button to complete the construction of 
the arc. 
Click the OK button to complete the command. 

 
 
 

Options in Detail 

Center – Shows the center position of an arc to be generated. 
 
Radius – Shows the radius of an arc to be generated. 
 
Start – Shows the starting position of an arc to be generated. 
 
End – Shows the ending position of an arc to be generated. 

 
 

See Also 

Tools > Sketch Entities > Circle 
Tools > Sketch Entities > Perimeter Circle 
Tools > Sketch Entities > 3 Tangent Circle 
Tools > Sketch Entities > Centerpoint Arc 
Tools > Sketch Entities > 3 Point Arc 
Tools > Sketch Entities > 3 Tangent Arc 
 
 
 

Tools > Sketch Entities > 3 Points Arc 
 

What 

The 3 Point Arc command draws arcs constructed by three points on a base sketch plane. 
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Why 

The 3 Point Arc command is useful for: 

• Drawing arcs on a base sketch plane 

• Creating a sketch profile to be used for generating cylindrical features 

 
 

How to Use 

How to draw arcs by selecting 3 points 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to 

draw sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > 3 Points Arc or click the icon in the toolbar. 
 

3. Pick a starting and ending point. 
 

4. Pick a final point to set the radius of an arc. 

 
 
 

Options in Detail 

Center – Shows the center position of an arc to be generated. 
 
Radius – Shows the radius of an arc to be generated. 
 
Start – Shows the starting position of an arc to be generated. 
 
End – Shows the ending position of an arc to be generated. 
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See Also 

Tools > Sketch Entities > Circle 
Tools > Sketch Entities > Perimeter Circle 
Tools > Sketch Entities > 3 Tangent Circle 
Tools > Sketch Entities > Centerpoint Arc 
Tools > Sketch Entities > Tangent Arc 
Tools > Sketch Entities > 3 Tangent Arc 
 
 
 

Tools > Sketch Entities > 3 Tangent Arc 
 

What 

The 3 Tangent Arc command draws arcs using an inscribed circle that touches the edges of 3 other 
sketch entities on a base sketch plane. 

 
 
 

Why 

The 3 Tangent Arc command is useful for: 

• Drawing inscribed arcs that touch the edges of 3 other sketch entities on a base sketch plane 

• Creating a sketch profile to be used for generating cylindrical features 

 
 

How to Use 

How to draw inscribed arcs that touch the edges of 3 other sketch 
entities 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to draw 

sketches on in the Sketch mode. For more information, see Insert > Sketch. 
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2. Go to Tools > Sketch Entities > 3 Tangent Arc or click the icon in the toolbar. 

 
 

Note:  

To use this command, sketch entities must exist. 

 
 

3. Pick a line and two arcs. 

 
 

4. Pick a starting and ending position on the preview of the inscribed circle. 

 
 

5. Click the OK button to complete the command. 
 
 

Options in Detail 

Center – Shows the center position of an arc to be generated. 
 
Radius – Shows the radius of an arc to be generated. 
 
Start – Shows the starting position of an arc to be generated. 
 
End – Shows the ending position of an arc to be generated. 

 
 

See Also 

Tools > Sketch Entities > Circle 
Tools > Sketch Entities > Perimeter Circle 
Tools > Sketch Entities > 3 Tangent Circle 
Tools > Sketch Entities > Centerpoint Arc 
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Tools > Sketch Entities > Tangent Arc 
Tools > Sketch Entities > 3 Point Arc 
 
 
 

Tools > Sketch Entities > Ellipse 
 

What 

The Ellipse command draws ellipses on a base sketch plane. 

 
 
 

Why 

The Ellipse command is useful for: 

• Drawing ellipses on a base sketch plane 

 
 

How to Use 

How to draw ellipses 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to 

draw sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Ellipse or click the icon in the toolbar. 
 

3. Pick a center point of an ellipse to be generated. 
 

4. Specify the radius of a major arc by picking a Major point and then specifying the 
radius of a minor arc by picking a Minor point. 
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5. Click the OK button to complete the command. 
 
 

Options in Detail 

Center – Shows the center position of an ellipse to be generated. 
 
Major Point – Shows the major arc position of an ellipse to be generated. 
 
Minor Point – Shows the minor arc position of an ellipse to be generated. 
 
Radius – Shows the major and minor arc radius of an ellipse to be generated. 
 
For Construction – Creates an ellipse for construction. The construction ellipse can be used as a 
reference for drawing other sketch entities or a guide curve for constructing patterned features. 

  

Normal Ellipse For Construction Ellipse 
 
Fit Polyline – Creates an ellipse by fitting to section polylines that are a section segment from a 
mesh or point cloud. 

  
 

Note:  

To accept a fitting, click the Accept Fitting button  or double-click the left mouse button. To cancel 

a fitting, click the Cancel Fitting button . To clear a selection, click the Clear Selection button . 
 

 
 

See Also 

Tools > Sketch Entities > Partial Ellipse 
Tools > Sketch Entities > Parabola 
Tools > Sketch Entities > Spline 
 
 
 

Tools > Sketch Entities > Partial Ellipse 
 

What 

The Partial Ellipse command draws a partial ellipse on a base sketch plane. 
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Why 

The Partial Ellipse command is useful for: 

• Drawing a partial ellipses on a base sketch plane 

 
 

How to Use 

To draw partial ellipses 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to 

draw sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Partial Ellipse or click the icon in the toolbar. 
 

3. Pick a center point of an ellipse to be generated. 
 

4. Specify the radius of a major arc by picking a Major point and then drag mouse cursor 
to specify the radius of a minor arc. 
 

5. Pick a starting position and an ending position on the preview ellipse. 

 
 

6. Click the OK button to complete the command. 
 
 

Options in Detail 

Center – Shows the center position of an ellipse to be generated. 
 
Major Point – Shows the major arc position of an ellipse to be generated. 
 
Minor Point – Shows the minor arc position of an ellipse to be generated. 
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Radius – Shows the major and minor arc radius of an ellipse to be generated. 
 
Start – Shows the starting position of a partial ellipse. 
 
End – Shows the ending position of a partial ellipse. 
 
For Construction – Creates an ellipse for construction. The construction ellipse can be used as a 
reference for drawing other sketch entities or as a guide curve for constructing patterned 
features. 

  
Normal Partial Ellipse For Construction Partial Ellipse 

 
Fit Polyline – Creates a partial ellipse by fitting to section polylines that are a section segment 
from a mesh or point cloud. 

 
 

 

Note:  

To accept a fitting, click the Accept Fitting button  or double-click the left mouse button. To cancel 

a fitting, click the Cancel Fitting button . To clear a selection, click the Clear Selection button . 
 

 
 

See Also 

Tools > Sketch Entities > Ellipse 
Tools > Sketch Entities > Parabola 
Tools > Sketch Entities > Spline 
 
 
 

Tools > Sketch Entities > Parabola 
 

What 

The Parabola command draws a parabola on a base sketch plane. 
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Why 

The Parabola command is useful for: 

• Drawing parabolas on a base sketch plane 

 
 

How to Use 

How to draw parabolas 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to 

draw sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Parabola or click the icon in the toolbar. 
 

3. Pick a center point of a parabola to be generated. 

 
 

4. Pick an apex position while previewing the parabola. 

 
 

5. Pick a starting position and an ending position on the preview parabola. 
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6. Click the OK button to complete the command. 
 
 

Options in Detail 

Center – Shows the center position of a parabola to be generated. 
 
Apex – Shows the apex position of a parabola to be generated. 
 
Start – Shows the starting position of a parabola to be generated. 
 
End – Shows the ending position of a parabola to be generated. 
 
For Construction – Creates a parabola for construction. The construction parabola can be used 
as a reference for drawing other sketch entities or as a guide curve for constructing patterned 
features. 

  

Normal Parabola For Construction Parabola 
 

 
 

See Also 

Tools > Sketch Entities > Ellipse 
Tools > Sketch Entities > Partial Ellipse 
Tools > Sketch Entities > Spline 
 
 
 

Tools > Sketch Entities > Spline 
 

What 

The Spline command draws splines on a base sketch plane. 

 
 
 

Why 
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The Spline command is useful for: 

• Drawing splines on a base sketch plane 

• Creating a sketch profile to be used for creating freeform features 

 
 

How to Use 

A. How to draw splines in Sketch mode 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to draw 

sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Spline or click the icon in the toolbar. 
 

3. Pick a starting point and draw a spline by picking more points. 

 
Note:  

Use the Ctrl + Z shortcut to cancel the last picked position. 

 
 

4. Press the right mouse button to complete the construction of the spline. Click the OK 
button to complete the command. 

 
 

Note:  

After drawing a spline, double-click the spline to manually edit it in the Sketch mode. Edit 
tangent conditions by dragging an arrow on the spline node points. The tangent constraint can 
be removed by clicking the Remove Tangent Condition In the spline edit dialog. 

- To adjust the arrow direction while only changing the arrow length, or the tension of tangent 
condition, drag the arrow while holding down the Shift key. 

- To adjust the arrow length while only changing its direction, drag the arrow while holding 
down the Ctrl key. 
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Remove Tangent Condition – Removes all edited tangent conditions. 

Remove Current Tangent Condition – Removes selected tangent conditions. 

Delete Constraint – Removes selected constraints from the list. 

Fix – Fixes a spline. This option does not edit tangent conditions. When the Fix constraint is 
given to a spline, the spline will get full constraints. 

 

 
 

B. How to draw splines in Mesh Sketch mode 
1. Go to Insert > Mesh Sketch or click the icon in the toolbar to enter the Mesh Sketch 

mode. 
Create section polylines. For more information, see Insert > Mesh Sketch. 

 
 

2. Hide the mesh to make only section polylines visible in the Model View. 

 
3. Go to Tools > Sketch Entities > Spline or click the icon in the toolbar. 
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4. Check the Fit Polyline option and select section polylines. 

  
 

Note:  

The Fit Polyline option is only available in the Mesh Sketch mode. 

 
 

5. Increase No. Of Interpolation Points to 40. 

 
 

6. Confirm the preview spline by clicking the Accept Fitting button or by double-clicking 
the left mouse button. 
 

7. Click the OK button to complete the command. 
 
 

Options in Detail 

Fit Polyline – Creates a spline by fitting to section polylines that are a section segment from a 
mesh or point cloud. This option is only available in the Mesh Sketch mode. 

  
 

Note:  

To accept a fitting, click the Accept Fitting button  or double-click the left mouse button. To cancel 

a fitting, click the Cancel Fitting button . To clear a selection, click the Clear Selection button . 

 
Fitting Options – Specifies fitting options. 
 

No. Of Interpolation Point – Specifies the number of interpolation points in a spline. 
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Note:  

A smaller number of interpolation points may not accurately capture the shape of a section 
polyline, so an adaptable number of interpolation points can be used. 

  

3 Points 10 Points 
 

 
Smoothness – Specifies the overall smoothness level of a spline by moving the slider 
between Min. and Max. Smoothness is related to the curvature of a spline. 

  

Smoothness: Min Smoothness: Max 
 

Merge Range – Specifies the merging range of segment polylines. To make a smooth 
spline from overlapped segment polylines, set a larger value than the width of selected 
segment polylines. 

  

Merge Range: 0.5 Merge Range: 0.05 
 

Local Smoothness – Specifies a local smoothness level of a spline by moving the slider 
between Min. and Max. 

 
Section Segment Polyline 

  

Local Smoothness: Min Local Smoothness: Max 
 
For Construction – Creates a spline for construction. The construction spline can be used as a 
reference for drawing other sketch entities or as a guide curve for constructing loft or sweep 
features. For more information, see Insert > Solid > Sweep or Insert > Solid > Loft. 

 
 

Normal Spline For Construction Spline 
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Dynamic View Change – Traces the last selected point in the 2D Sketch View so that the last 
selected position is always in the center of the screen. 

 
 

See Also 

Tools > Sketch Entities > Ellipse 
Tools > Sketch Entities > Partial Ellipse 
Tools > Sketch Entities > Parabola 
 
 
 

Tools > Sketch Entities > Centerline 
 

What 

The Centerline command draws lines for construction. 

 
 
 

Why 

The Centerline command is useful for: 

• Drawing lines for construction on a base sketch plane 

• Creating construction lines that can be used as a reference for drawing other sketch entities or 
an axis for constructing revolved features 

 
 

How to Use 

How to draw centerlines 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to 

draw sketches on the base sketch plane in the Sketch mode. For more information, 
see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Centerline or click the icon in the toolbar. 
 

3. Pick a starting and ending point to create a centerline. 
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4. Click the right mouse button to complete the construction. 

 
5. Click the OK button to complete the command. 

 
 

Options in Detail 

Start – Shows the starting position of a line to be generated. 
 
End – Shows the ending position of a line to be generated. 
 
For Construction – Creates a line used for constructing a solid or surface body that cannot be 
used for a profile. This option is checked on by default. To create a normal line, check this option 
off. 

  

Centerline Normal Line 
 

 
 

See Also 

Tools > Sketch Entities > Line 
 
 
 

Tools > Sketch Entities > Point 
 

What 

The Point command adds a point on a base sketch plane. 

 
 
 

Why 
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The Point command is useful for: 

• Adding points on base sketch plane 

• Creating a point that can be used as a reference for drawing other sketch entities or a reference 
point for constructing geometric features 

 
 

How to Use 

How to add points 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to 

draw sketches on in the Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Point or click the icon in the toolbar. 
 

3. Select a point. 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 

Position – Shows the position of a point to be generated 
 
X – Shows the X coordinate of a point. 
 
Y – Shows the Y coordinate of a point. 

 
 

See Also 

Insert > Ref.Geometry > Point 
 
 
 

Tools > Sketch Entities > Text 
 

What 

The Text command adds text on a base sketch plane. 
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Why 

The Text command is useful for: 

• Add text sketches on a base sketch plane 

• Engraving text, symbols, or pattern shapes on features 

 
 

How to Use 

How to add text 
1. Go to Insert > Sketch or click the icon in the toolbar. Select a base sketch plane to draw 

sketches on in the Mesh Sketch mode. For more information, see Insert > Sketch. 
 

2. Go to Tools > Sketch Entities > Text or click the icon in the toolbar. 
 

3. Type text in the Text box and click Enter to see a preview. 

 
 

4. Adjust the size of text by specifying the Height, Width Ratio, and Space Ratio options. 
 

Note:  

The size of text can be interactively adjusted by manipulating the control points in the Model 
View. 

 
 

5. Click the OK button to complete the command. 
 
 

Options in Detail 

Text – Inputs text. 



Geomagic Design X | Menu  759 
 

 
Size – Specifies the size of text. 
 

Height – Specifies the height of text. The height can be adjusted by manipulating the green 
control points in the Model View. 
 
Width Ratio – Specifies the width ratio of text. The width ratio can be adjusted by 
manipulating the red control points in the Model View. 

 
Space Ratio – Specifies the ratio between each letter. 
 

Font – Specifies a font style. 
 
Position & Align – Specifies the position of text and aligns it to a specific axis or curve. 
 

Position – Shows the center position of text. The center point of text can be adjusted by 
dragging the text box in the Model View. 
 
Flip Horizontal – Flips text horizontally. 

  
 
Flip Vertical – Flip text vertically. 

  
 
Along A Curve – Aligns text along a curve. A Ref. Vector, Curve or Edge can be selected as a 
guide curve. 

 
 
 

See Also 

Tools > Sketch Entities > Line 
Tools > Sketch Entities > Circle  
Tools > Sketch Entities > Tangent Arc 
Tools > Sketch Entities > Spline 
 
 
 

Tools > Sketch Entities > By Fitting Polyline 
 

What 

The By Fitting Polyline command creates lines, arcs or circles by fitting section polylines on a base 
sketch plane. This command is available in the Mesh Sketch mode only. 



Geomagic Design X | Menu  760 
 

 
 
 

Why 

The By Fitting Polyline command is useful for: 

• Creating lines, arcs or circles by simultaneously fitting them to a section polyline. 

 
 

How to Use 

How to create circle or arc sketch entities by fitting section polylines 
in the Mesh Sketch mode 
1. Go to Insert > Mesh Sketch or click on the icon in the toolbar to enter the Mesh 

Sketch mode. 
Create section polylines. For more information, see Insert > Mesh Sketch. 
 

2. Go to Tools > Sketch Entities > By Fitting Polyline or click on the icon in the toolbar. 
 

3. Choose the Circle option. Select circular section polylines and click the Accept Fitting 
button to accept the preview. 

 
 

4. Using the same way procedure as Step 3, complete remaining circular section 
polylines. 

 
 

5. Click the OK button to complete the command. 
 
 

Options in Detail 
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Fitting – Fits a sketch entity to a current segment type. 
 

Note:  

A segment type is divided into line and circle types. When the type of a selected segment is detected as 
a circle, a sketch entity can be fitted to circle or arc. 

 
Fit Circle Type Segment To – Choose a fitting type for circular type segments. 
 

Circle – Defines the target fitting type as a circle. 

 
 

Arc - Defines the target fitting type as an arc. 

 
 
 

See Also 

Tools > Sketch Entities > Line 
Tools > Sketch Entities > Circle  
Tools > Sketch Entities > Centerpoint Arc 
  
 
 
 

Tools > Sketch Entities > By Import 
 

What 

The By Import command imports 2D CAD drawing files as sketch entities onto a base sketch plane. 
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Why 

The By Import command is useful for: 

• Importing 2D CAD drawing file as sketch entities onto a base sketch plane. 

 
 

How to Use 

How to import 2D CAD drawing files as sketch entities onto a base 
sketch plane 
1. Go to Tools > Sketch Entities > By Import in the menu. 

 
2. Select a 2D CAD drawing file in the DXF, IGES, STEP, or VDA file formats. 

 
3. Define size and position. 

  
 

4. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Flip Horizontally – Flips an imported sketch horizontally. 
 
Flip Vertically – Flips an imported sketch vertically. 
 
Anchor – Moves an imported sketch to an existing sketch entity by using anchor points. Pick 
two points on an imported sketch and the existing sketch to match them. If matching points 
need to be offset in the X and Y directions, specify the values in the Offset From Target option. 
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Before Applying an Anchor 
 

 

After Applying an Anchor 
 
Align – Aligns an imported sketch to an existing model by matching lines. Select a line on an 
imported sketch as a Moving Line and select a linear entity on the existing model as a Target 
Line. 

 

Before Align 
 

 

After Align 
 

Rotation From Target – Rotates an imported sketch using a target as a rotational point. 
This option is available after a Moving Line and a Target Line are defined. 

 
Scale – Specifies a scale factor used to scale an imported sketch. 
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See Also 

Tools > Sketch Entities > Line 
Tools > Sketch Entities > Circle  
Tools > Sketch Entities > Centerpoint Arc 
 
 
 

7.5.7. Tools > Sketch Tools 
 
The Sketch Tools menu features various commands used to edit sketch entities such as Fillet, 
Chamfer, Trim, for completely constructing sketch profile. 
 
The Sketch Tools menu provide 2 sets of sketch edit tools, a set of useful pattern copy tools, and a 
set of converting tools used to: 
 
 

Modify Sketch Entities 

• Fillet 

Modifies sketch entities by adding a tangent arc in between the sketch entities 

• Chamfer 

Modifies sketch entities by adding an angled line in between the sketch entities 

• Offset 

Offsets sketch entities by a specified distance 

• Convert Entities 

Converts other entities into sketch entities 

• Silhouette 

Converts outer boundaries of features into sketch entities 

 
 

Edit Sketch Entities 

• Trim 

Trims sketch entities 

• Extend 

Extends sketch entities 

• Split 

Splits a sketch entity into multiple parts 

• Mirror 

Mirrors a part of a sketch entity 
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• Resize 

Resizes a sketch entity 

• Merge 

Merges sketch entities into a single sketch entity 

 
 

Adding Patterned Sketch Entities 

• Linear Pattern 

Creates linear patterns from sketch entities 

• Circular Pattern 

Creates circular patterns from sketch entities 

 
 

Converting Sketch Entities 

• Fit To Spline 

Converts sketch entities into splines 

• Text To Splines 

Converts text sketch entities into splines 

• Insert Polyline 

Inserts a Ref.Polyline onto a base sketch plane as a section polyline 

 
 
 

Tools > Sketch Tools > Fillet 
 

What 

The Fillet command modifies sketch entities by adding a tangent arc in between sketch entities. 

 
 
 

Why 
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The Fillet command is useful for: 

• Modifying sketch entities by adding a tangent arc in between the sketch entities 

• Constructing a sketch profile for adding rounded features when creating a surface or solid body 

 
 

How to Use 

How to modify sketch entities by adding a tangent arc in between the 
sketch entities 
1. Go to Tools > Sketch Tools > Fillet or click the icon in the toolbar. 

 
 

2. Check the Specify Value option and specify 10mm as the fillet value. 
 

3. Select sketch entities to add a fillet between by a specified radius. 

 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 

Specify Value – Adds a fillet radius between selected sketch entities. To fillet between splines a 
specified fillet radius is required. 
 

Note:  

The Fillet command interactively adds fillets by dragging a tangent arc to be generated. Select a first 
sketch entity and select a second sketch entity while holding the left mouse button and drag the 
tangent arc to interactively add fillet. 

 
 
Add Dimension – Adds dimensions after filleting. 
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Without Add Dimension With Add Dimension 
 

Note:  

Once placed, dimensions can be removed if necessary. 
 

 
 

See Also 

Tools > Sketch Entities > Tangent Arc 
Tools > Sketch Tools > Chamfer 
 
 
 

Tools > Sketch Tools > Chamfer 
 

What 

The Chamfer command modifies sketch entities by adding an angled line between the sketch 
entities. 

 
 
 

Why 

The Chamfer command is useful for: 

• Modifying sketch entities by adding an angled line between the sketch entities 

 
 

How to Use 

How to modify sketch entities by adding angled line in between the 
sketch entities 
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1. Go to Tools > Sketch Tools > Chamfer or click on the icon in the toolbar. 
 

2. Choose Distance-Distance as the chamfer type.  
 

3. Select sketch entities to add chamfer to between the sketch entities. 

 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 

Distance-Distance – Adds chamfer by using distances. 

 
 
Distance-Angle – Adds chamfer by angle and distance. 

 
 
Specify Value – Specifies the position values for a chamfer to be placed. When this option is 
disabled, the chamfer will be placed at the position of selected sketch entities. 
 

Distance1 – Specifies the distance of a chamfer from the first selected sketch entity. 
 

Distance2 – Specifies the distance of a chamfer from the second selected sketch entity. 
 

Angle – Specifies an angle of a chamfer from the first selected sketch entity. 
 
 

See Also 

Tools > Sketch Entities > Line 
Tools > Sketch Tools > Fillet 
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Tools > Sketch Tools > Offset 
 

What 

The Offset command offsets sketch entities by a specified distance. 

 
 
 

Why 

The Offset command is useful for: 

• Offsetting sketch entities by a specified distance 

• Constructing sketch profiles for creating solid bodies with constant thickness 

 
 

How to Use 

How to offset sketch entities by a specified distance 
1. Go to Tools > Sketch Tools > Offset or click the icon in the toolbar. 

 
2. Select sketch entities as target Profiles. 

 
3. Specify 5mm as the Offset Distance and choose the Direction 1 option. 

 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 
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Select Entities 

Profiles – Select sketch entities. When sketch entities are connected by a coincidence constraint, 
those sketches will be offset as a sketch loop. 
 

Note:  

The offset command is unavailable for splines, ellipses and parabola sketch entities. 

 
 

Options 

Distance – Specifies an offset distance. 
 
Direction – Specifies an offset direction. 
 

Direction 1 – Selects the default positive direction to offset. 
 
Direction 2 – Selects the opposite, negative direction from Direction1. 
 
Both Side – Offsets sketch entities in both two directions. 
 

Cap Ends – Closes the top and bottom sides of an offset using lines or arcs. This option is 
available when the Both Side option is used. 

  

Cap Ends: Arcs Cap Ends: Lines 
 

More Options 

Remove Original Sketch – Removes original sketch entities after offsetting. 
 
 

See Also 

Tools > Sketch Tools > Extend 
 
 
 

Tools > Sketch Tools > Convert Entities 
 

What 

The Convert Entities command converts entities into sketch entities by projecting them onto a base 
sketch plane. 
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Why 

The Convert Entities command is useful for: 

• Converting other entities into sketch entities using a base sketch plane 

 
 

How to Use 

How to convert other entities into sketch entities 
1. Go to Tools > Sketch Tools > Convert Entities or click the icon in the toolbar. 

 
2. Select an edge of a body as a target Entities. 

 
 

3. Click the OK button to complete the command. Check that the selected edges are 
converted into sketch entities on the base sketch plane. 

 
 
 

Options in Detail 
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Entities – Selects entities that are needed to be converted into sketch entities. Curve points, 
Ref.Points, Ref.Vectors, Curves, Vertices, and Edges can be target entities. 
 

Note:  

The Convert Entities command can be directly used in the pop-up menu. Select other entities, click the 
right mouse button and choose the Covert Entities option in the pop-up menu to convert selected 
entities into sketch entities. 

 

 

Note:  

Sketch entities converted by the Convert Entities command are fixed and cannot be modified directly. 
To edit the converted sketch entities, double-click them after converting entities into sketch entities and 
deleting the Converted constraints by using the Delete Constraint button. 

 
 

 
 

See Also 

Tools > Sketch Tools > Silhouette 
 
 
 

Tools > Sketch Tools > Silhouette 
 

What 

The Silhouette command converts outer boundaries of features into sketch entities on a base 
sketch plane. 
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Why 

The Silhouette command is useful for: 

• Converting outer boundaries of features into sketch entities on a base sketch plane. 

 
 

How to Use 

How to convert outer boundary of features into sketch entities 
1. Go to Tools > Sketch Tools > Silhouette in the menu. 

 
2. Select a body. Check the preview sketches. 

 
 

3. Click the OK button to complete the command. Check that the outer boundary of the 
selected body is converted into sketch entities on the base sketch plane. 

 
 
 

Options in Detail 

Entities – Selects faces or solid/surface bodies as target Entities. 
 
 

See Also 

Tools > Sketch Tools > Convert Entities 
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Tools > Sketch Tools > Trim 
 

What 

The Trim command trims sketch entities. 

 
 
 

Why 

The Trim command is useful for: 

• Trimming sketch entities and removing unnecessary parts of sketch entities 

 
 

How to Use 

A. How to trim sketch entities by using the Power Trim method 
1. Go to Tools > Sketch Tools >Trim in the menu. 

 
 

2. Choose the Power Trim method and click-drag the left mouse button over sketch 
entities to remove unnecessary parts. 

 
 

3. Check that the sketch entities are trimmed. Click the OK button to complete the 
command. 
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B. How to trim sketch entities by using the Corner Trim method 
1. Go to Tools > Sketch Tools >Trim or click the icon in the toolbar. 

 
 

2. Choose the Corner Trim method and select the upper horizontal and vertical lines to 
extend those lines at their intersection point. The result will be highlighted when 
selecting a second line. 

 
 

Note:  

The Corner Trim method can also be used by click-dragging. 

 
 

3. Check the results. 

 
 

4. Select the lower horizontal and vertical line to extend those lines at their intersection 
point. The result will be highlighted when selecting a second line depending on where 
the mouse cursor is placed. 
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5. Check the results. The results assume that the second line was selected when the mouse 
cursor was placed in the right side of the vertical line. 

 
 
 

Options in Detail 

Power Trim – Trims multiple and adjacent sketch entities by click-dragging the left mouse button 
across sketch entities. 

  

Before Power Trim After Power Trim 
 
Corner Trim – Extends sketch entities so that they can be intersected with each other and trims 
sketch entities. 

  

Before Corner Trim After Corner Trim 
 

 
 

See Also 

Tools > Sketch Tools > Extend 
Tools > Sketch Tools > Split 
 
 
 

Tools > Sketch Tools > Extend 
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What 

The Extend command extends a sketch entity until it meets another sketch entity. 

 
 
 

Why 

The Extend command is useful for: 

• Extending a sketch entity until it meets another sketch entity 

 
 

How to Use 

How to extend a sketch entity 
1. Go to Tools > Sketch Tools > Extend or click the icon in the toolbar. 

 
 

2. Hover the mouse cursor over a sketch entity and check the preview. 

 
 

3. Click on the highlighted sketch entity to extend it. 
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See Also 

Tools > Sketch Tools > Resize 
 
 
 

Tools > Sketch Tools > Split 
 

What 

The Split command splits a sketch entity into multiple parts. 

 
 
 

Why 

The Split command is useful for: 

• Splitting a sketch entity into multiple parts 

 
 

How to Use 

How to split a sketch entity into multiple parts 
1. Go to Tools > Sketch Tools > Split or click the icon in the toolbar. 

 
 

2. Hover the mouse cursor over a sketch entity and check the position to be split. 

 
 

3. Click a specific position on the highlighted sketch entity and check the results. 
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See Also 

Tools > Sketch Tools > Trim 
 
 
 

Tools > Sketch Tools > Mirror 
 

What 

The Mirror command mirrors a part of a sketch entity. 

 
 
 

Why 

The Mirror command is useful for: 

• Mirroring a part of a sketch entity 

• Copying sketch entities symmetrically 

 
 

How to Use 

How to mirror a part of a sketch entity 
1. Go to Tools > Sketch Tools > Mirror or click the icon in the toolbar. 
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2. Select a line as a Symmetry Line and target entities to be mirrored as Entities. 

 
 

3. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Symmetry Line – Selects a symmetry line to use during mirroring. 
 
Entities – Selects sketch entities to be mirrored. 

 
 

See Also 

Tools > 3D Sketch Tools > Mirror 
 
 
 

Tools > Sketch Tools > Resize 
 

What 

The Resize command resizes a sketch entity. 
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Why 

The Resize command is useful for: 

• Resizing the length of a sketch entity while maintaining its direction 

 
 

How to Use 

How to resize a sketch entity 
1. Go to Tools > Sketch Tools > Resize or click the icon in the toolbar. 

 
 

2. Select a starting or an ending point of a sketch entity and click-drag it to resize its 
length. 

 
 

3. Click the OK button to complete the command. 

 
 
 

See Also 
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Tools > Sketch Tools > Extend 
 
 
 

Tools > Sketch Tools > Merge 
 

What 

The Merge command merges multiple sketch entities into a single sketch entity. 

 
 
 

Why 

The Merge command is useful for: 

• Merging separated sketch entities into a single sketch entity 

• Joining split sketch entities created by the Auto Sketch command 

 
 

How to Use 

How to merges multiple sketch entities into a single sketch entity 
1. Go to Tools > Sketch Tools > Merge or click the icon in the toolbar. 

 
 

2. Select split sketch entities. 

 
 

3. Click the OK button to complete the command. 
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Options in Detail 

Entities – Selects split sketch entities to merge them into a single sketch entity. 
 

Note:  

When select entities are split and connected, they will be merged and the points at the split position 
will be removed. When a set of separated sketch entities are selected as target entities, an averaged 
sketch entities will be created from them. 

This command merges separated sketch entities into a single sketch entity when the results of using 
the Auto Sketch command are messy and complex. 

 

 

 
 

 
 

See Also 

Tools > 3D Sketch Tools > Merge 
 
 
 

Tools > Sketch Tools > Linear Pattern 
 

What 

The Linear Pattern command creates linear patterns from sketch entities. 
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Why 

The Linear Pattern command is useful for: 

• Creating multiple instances of sketch entities with uniform distances along one or two linear 
paths 

 
 

How to Use 

How to create linear patterns from sketch entities 
1. Go to Tools > Sketch Tools > Linear Pattern or click the icon in the toolbar. 

 
2. Select a sketch entity to be patterned. 

  
 

3. Specify the No. of Instances and the Spacing under Direction 1. 
 

4. Specify the No. of Instances and the Spacing under Direction 2. 

  
 

5. Click the OK button to complete the command. 
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Options in Detail 

Select Entities 

Entities – Selects sketch entities to be patterned. 

Options 

Direction1 – Specifies parameters that can be used for creating patterned instances along 
Direction1. 

  
 

Note:  

The U axis of a base sketch plane is used as Direction 1 by default. 

 
No. of Instances – Specifies the number of instances to be patterned. 
 

 

 

 

No. of Instances: 3 No. of Instances: 5 
 
Spacing – Specifies the distance between instances. 

 
 
Angle – Specifies the angle between Direction 1 and the U axis of a base sketch plane. 
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Note:  

The value can be set by manually measuring the angle with the Measure Angle button . 

To measure the angle between sketch entities, click the Measure Angle button  and select 
two sketch entities. 

 
Direction2 – Specifies parameters that can be used for creating patterned instances along 
Direction2. 

 
 

Note:  

The V axis of a base sketch plane is used as Direction 2 by default. 

 
No. of Instances – Refer to the sub-option in the Direction 1. 
 
Spacing – Refer to the sub-option in the Direction 1. 
 
Angle – Refer to the sub-option in the Direction 1. 

 
 

See Also 

Tools > Sketch Tools > Circular Pattern 
 
 
 

Tools > Sketch Tools > Circular Pattern 
 

What 

The Circular Pattern command creates circular patterns from sketch entities. 
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Why 

The Circular Pattern command is useful for: 

• Creating multiple instances of sketch entities with uniform spacing along a circular angle from 
an anchor point 

 
 

How to Use 

How to create circular patterns from sketch entities 
1. Go to Tools > Sketch Tools > Circular Pattern or click the icon in the toolbar. 

 
2. Select sketch entities to be patterned. 

 
3. Specify the offset distance for Base X and Base Y. Base X and Base Y determines the 

origin position of a circular pattern. 
 

4. Specify the No. of Instances and the Total Angle. 

  

Pattern created with Angle 180 Pattern created with Angle 360 
 
 

5. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Select Entities 

Entities – Selects sketch entities to be patterned. 
 

Options 

Base X – Specifies the offset distance from the origin position of a base sketch plane along the 
U axis. 
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Base Y – Specifies the offset distance from the origin position of a base sketch plane along the V 
axis.  

 
 
No. Of Instances – Specifies the number of instances to be patterned. 

  

No. of Instances: 5 No of Instances: 7 
 
Total Angle – Specifies the total angle in which a pattern should be created. To reverse the angle 
direction, click the Reverse button . 

  

Total Angle: 360 No of Instances: 180 
 

Note:  

The value can be set by manually measuring the angle with the Measure Angle button . 

To measure the angle between sketch entities, click the Measure Angle button   and select two 
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sketch entities. 
 

 
 

See Also 

Tools > Sketch Tools > Linear Pattern 
 
 
 

Tools > Sketch Tools > Fit To Spline 
 

What 

The Fit To Spline command converts sketch entities into splines. 

 
 
 

Why 

The Fit To Spline command is useful for: 

• Converting sketch entities into splines 

• Removing edges from a modeled feature based on sketch entities 

 
 

How to Use 

How to convert sketch entities into splines 
1
. 

Go to Tools > Sketch Tools > Fit To Spline or click the icon in the toolbar. 

 
 

2
. 

Select sketch entities and check the Remove Original Entities option to remove 
original target sketch entities. 
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3
. 

Click the OK button to complete the command. 

 
 

Note:  

When an extrude feature is generated by using sketch entities the Fit To Spline command 
converts the sketch entities into splines removes the edges that occurs when an extruded 
feature is generated. For more information, see Insert > Solid > Extrude or Insert > Surface > 
Extrude. 

 
 

Extrusion from sketch entities consisted of 
arcs and lines 

Extrusion from spline 
 

 

 
 

Options in Detail 

Fit Tolerance – Specifies the maximum deviation that is allowed when an original sketch entities 
is converted to spline. 
 
Remove Original Entities – Removes original sketch entities. 
 
Entities – Selects sketch entities. 

Note:  

Disjoined entities can also be converted into a spline by adding lines between the original sketch 
entities. 

   
Original Entities Selecting Entities Fit Spline Result 
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See Also 

Tools > Sketch Tools > Text To Spline 
 
 
 

Tools > Sketch Tools > Text To Splines 
 

What 

The Text To Splines command converts text sketch entities into splines. 

 
 
 

Why 

The Text To Splines command is useful for: 

• Converting text sketch entities into splines 

• Manually modifying the shape of text 

 
 

How to Use 

How to convert text sketch entities into splines 
1. Go to Tools > Sketch Tools > Text To Splines or click the icon in the toolbar. 

 
2. Select a text sketch entity. 

 
3. Click the OK button to complete the command. Check that the text is converted into 

splines. 
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Options in Detail 

Texts – Selects texts to convert into splines. 
 
 

See Also 

Tools > Sketch Tools > Fit To Spline 
 
 
 

Tools > Sketch Tools > Insert Polyline 
 

What 

The Insert Polyline command inserts a Ref.Polyline onto a base sketch plane as a section polyline. 

 
 
 

Why 

The Insert Polyline command is useful for: 

• Inserting a Ref.Polyline onto a base sketch plane as a section polyline 

• Converting design intent such as a bead line, silhouette, etc into a section polyline and drawing 
sketch entities based on the converted section polyline 

 
 

How to Use 

How to Insert a Ref.Polyline onto a base sketch plane as a section 
polyline 
1. Go to Insert > Mesh Sketch or click on the icon in the toolbar to enter the Mesh 

Sketch mode and select a base sketch plane. For more information, see Insert > Mesh 
Sketch. 
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2. Click the OK button. 

 
3. Go to Tools> Sketch Tools > Insert Polyline or click the icon in the toolbar. Select a 

Ref.Polyline. 
 

4. Click the OK button to complete the command. Check that the Ref.Polyline is 
converted into a section polyline. 

 
 
 

Options in Detail 

Ref.Polyline – Selects a Ref.Polyline to insert onto a current base sketch plane as a section polyline. 
 

Note:  

To select a Ref.Polyline as a target entity, the Ref.Polyline needs to be prepared before inserting into a 
section polyline. Create a Ref.Polyline by using Insert > Ref.Geometry > Polyline command before 
entering the Mesh Sketch mode. For more information, see Insert > Ref.Geometry > Polyline. 

 

 
 

See Also 

Insert > Ref.Geometry > Polyline 
 
 
 

7.5.8. Tools > Sketch Options 
 
The Sketch Options menu features various commands used to draw sketch entities on a base sketch 
plane are provided in Sketch Options menu. The options can be toggled on or off while drawing 
sketch entities. 
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Tools > Sketch Options > Snap On Entities 
 

What 

The Snap On Entities option snaps sketch entities being created onto other sketch entities with 
constraints. 

 
 
 

Why 

The Snap On Entities command is useful for: 

• Snapping sketch entities being created onto other sketch entities 

 
 

How to Use Snap 

How to snap sketch entities to other sketch entities when drawing 
1. Go to Tools > Sketch Options > Snap On Entity or toggle the icon on in the menu. This 

functionality is enabled by default. 
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2. Go to Tools > Sketch Entities > Line or click the icon in the toolbar. Move the mouse 
cursor over a line to find the middle position. 

 
 

Note:  

The  icon indicates the middle position of a line. 

 
 

3. Pick an end point where a perpendicular and horizontal constraints icon is shown. 

 
 

Note:  

The   icon indicates that a created sketch entity can be set with perpendicular and 
horizontal constraints. 

 
 

4. Click the OK button to complete the command. 

 
 

Note:  

Clicking the right mouse button on a blank area in the 2D Sketch View will directly access the 
Snap On Entities command in the pop-up menu. 
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Tools > Sketch Options > Snap On Polylines 
 

What 

The Snap On Polylines option snaps 2D entities being created onto section polylines. 

 
 
 

Why 

The Snap On Polylines command is useful for: 

• To snap sketch entities on section polylines. 

 
 

How to Use 

How to draw sketch entities snapped to a section polyline 
1. Go to Tools > Sketch Options > Snap On Polylines or toggle the icon on in the 

toolbar. This functionality is enabled by default. 

 
 

2. Go to Tools > Sketch Entities > 3 Point Arc or click the icon in the toolbar to create an 
arc. Move the mouse cursor until the snap to polyline icon is displayed. Pick a point on 
the section polyline. 

 
 

Note:  
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The  icon indicates that a created sketch entity can be snapped to a polyline. 

 
 

3. Pick a second point on the section polyline. 

 
 

4. Pick a third and final point to complete the arc. Click the OK button to finish the 
command. 

 
 

Note:  

Clicking the right mouse button on a blank area in the 2D Sketch View will directly access the 
Snap On Polylines command in the pop-up menu. 

 
 

 
 

See Also 

Tools > Sketch Options > Smartsnap 
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Tools > Sketch Options > Smartsnap 
 

What 

The Smartsnap option snaps 2D entities onto section polylines. 

 
 
 

Why 

The Smartsnap command is useful for: 

• Roughly and quickly draw 2D entities onto section polylines. 

 
 

How to Use 

How to draw sketch entities using Smartsnap 
1. Go to Tools > Sketch Options > Smartsnap or toggle the icon on in the toolbar. 

 
 

2. Go to Tools > Sketch Entities > Line and pick a starting point. Fitting target polylines 
will be displayed in yellow during the creation of a line. 

 
Note:  

The Smartsnap function can also be used by pressing the Shift key while drawing sketches 
without toggling the Smartsnap sketch option. 
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3. Pick the ending point to complete a line. The line will be attached to the polyline. 

 
 

4. Using the same method, create the remaining lines. 

 
 

See Also 

Tools > Sketch Options > Snap On Polylines 
 
 
 

7.5.9. Tools > Smart Dimension 
 

What 

The Smart Dimension command sets dimensions such as Distance, Angle, and Radius on sketch 
entities. 
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Why 

The Smart Dimension command is useful for: 

• Setting dimensions on sketch entities 

 
 

How to Use 

How to set dimensions on sketch entities 
1. Go to Tools > Smart Dimension or click the icon in the toolbar. 

 
2. Click a line of a sketch entity to create a distance measurement for it and drag the 

measurement to a desired location. 

 
 

3. Click two lines on the side to measure the angle between them and drag the 
measurement to a desired location. 

 
 

4. Click an arc to measure the radius and drag the measurement to a desired location. 

 
 

5. Click the center of an arc and a bottom line to measure the distance between them 
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and drag the measurement to a desired location. 

 
 

6. Double-click a dimension and directly edit the value to change the value of sketch 
entities by a specific amount. 

 
 
 

Options in Detail 

Value – Specifies the value of a dimension. 
 

Note:  

A distance can be measured with different results according to the location of the annotation. 

  

 
Driven – Sets the dimension as a driven dimension so that it can be dynamically changed 
depending on changes of other dimensions. When dimensions are defined around the sketch 
and become as over-constrained, this option is useful to make dimension as flexible changed. 
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Note:  

This option can be set when entering editing mode by double-clicking the specified dimension. 
 

 
 
 

7.5.10. Tools > 3D Sketch Entities 
 
The 3D Sketch Entities menu features various commands used to draw various 3D sketch entities 
such as Line, Pencil, Section, and Boundary. 
 
The 3D Sketch Entities menu provides 3 sets of sketch edit tools used to: 
 
 

Create 3D Sketch Entities 

• Spline 

Creates 3D curves on mesh or in free 3D space 

• Pencil 

Manually draw splines on 3D mesh 

• Section 

Creates section curves on mesh and solid surface bodies 

• Intersection 

Creates intersection splines between bodies 

• Boundary 

Extracts curves from the boundary of a mesh 

 
 

Create 3D Sketch Entities Using Other Objects 

• Surface UV Curves 

Creates 3D curves on a face along its U and V directions 

• Fit From Points 

Creates 3D curves from points or region boundaries by fitting to them 

 
 

Create Curves From Mesh Features 

• Trace Feature Line 

Automatically extracts character lines from mesh 

• Extract Feature Curves 
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Detects and extracts 3D lines from areas of high curvature 

• Create Curve Network 

Generates a 3D curve network on a mesh 

 
 
 

Tools > 3D Sketch Entities > Spline 
 

What 

The Spline command is used to create a 3D curve on mesh or in free 3D space. This command is 
available in both 3D Sketch mode and 3D Mesh Sketch mode. 

 

 

 
Example of Splines on mesh Example of a spline in 3D space 

 
 

Why 

The Spline command is useful for: 

• Creating a curve network for a boundary fitted surface 

• Creating a path for a swept or lofted body 

• Creating an original user-designed shape from scratch instead of copying the shape of an 
existing object 

• Working with highly curved 3D features such as a corkscrew feature 

• Working with freeform shapes that require more manual control than an automated tool can 
provide 

• Splitting a section made out of lines and splines to create new enclosed sections 

 
 

How to Use 

A. How to create a Spline and alter it in 3D Mesh Sketch Mode 
1. Go to Tools > 3D Sketch Entities > Spline, or click the icon in 3D Mesh Sketch mode. 

 
2. Select a point on a mesh to place a spline. Create extra nodes to further define the shape 
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by adding a node with a left mouse click. 
 

 
 

3. To finish a spline you can either right-click, double left-click, or press the Enter button 
on the keyboard. Click OK when the spline has been completed. 
 

 
 

4. When the mouse cursor is hovered over a node the selection area will be shown in a red 
circle. Hold down the Alt key on the keyboard and move the mouse from left to right to 
change the size of the selection area. 
 

 
 

5. If further altering of the spline is desired, select a node by left-clicking on it and dragging 
it to a desired located then release the mouse button. 
 

 
 

6. When more or less interpolation points are desired for the spline use the Rebuild 
command found in the toolbar. In this example the number of interpolation points has 
been set to 30. 
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B. How to create a Spline in 3D space in 3D Sketch Mode 
1. Go to Tools > 3D Sketch Entities > Spline, or click icon in the 3D Sketch mode. 

 
2. Select a base plane. For this example use the Top base plane. 

 

 
 

3. Left-click to begin drawing a spline. The first click will create the first node of the spline. 
 

 
 

4.  Without clicking anywhere else in the model view, click the Base Plane option again and 
select a perpendicular base plane, in this case, the Front base plane. 

 
 

5.  Click again to place another node of the spline on the perpendicular plane. Doing this 
allows the spline to first be aligned to the Top plane and then aligned to the Front plane 
mid-spline. 
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6. Finish the spline by switching back to the Top base plane and double-left click, right 
click, or press the Enter key on the keyboard to finish the spline. The spline will curve 
based on where the nodes were placed. Click OK to finish the command. 

 
 

Note:  

When a spline is drawn on a mesh in 3D Sketch mode the snap function will automatically be 
enabled. If snapping to mesh is not desired, use the Alt key while creating the spline. 

 

 
 

Options in Detail 

Base Plane – Select base planes. 
 
Generate Intermediate Points – Automatically creates intermediate points between picked 
points to reduce deviation. 

  
Enable Option Disable Option 

 
Join At Intersection Points – Automatically creates intersection points between intersecting 
curves. The Tolerance range can be set to determine if curves intersect or not. 
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Enable Option Disable Option 
 

Tolerance – Sets the tolerance range. 
 
Refit To Feature Lines – Searches for feature lines around picked points to use to create a spline 
and refits the spline to those features. 

  

Enable Option Disable Option 
 
Snap On Curvature Flow – Snaps a spline to a feature curvature while drawing the spline. 
 
Snap On Assistance Vector – Enable to snap a point of curve on an assistance vector that is 
automatically extracted from target body entity when drawing a curve in the Model View. Dot-
lined assistance vectors will be displayed when hovering the mouse curser on body faces or 
edges. 

 
 

Note:  

The Snap On Assistance Vector option is useful for creating a curve that has a specific directional 
property, such as perpendicular, parallel, and tangent, from a target entity. 

 

 
 

See Also 

Tools > 3D Sketch Entities > Pencil 
 
 
 

Tools > 3D Sketch Entities > Pencil 
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What 

The Pencil command is used to manually draw splines on 3D mesh. It can only be used in 3D Mesh 
Sketch mode. 

 
 
 

Why 

The Pencil command is useful for: 

• Sketching on models that have irregular features or areas that require precise manual control 

 
 

How to Use 

How to draw a line on mesh 
1. Click Tools > 3D Sketch Entities > Pencil in the 3D Mesh Sketch mode. 

 
 

2. Draw lines using the pencil. 

 
 

3. Click OK to complete the command. 
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Options in Detail 

Smoothness – Defines the smoothness of a curve. The option slider can be set between Min 
and Max. 
 
Interpolation Pts. Sampling Distance – Specifies the distance between node points of a 
spline. 

  

Sampling Distance: 1mm Sampling Distance: 5mm 
 
Merge Strokes – Merges drawn strokes. 

  

Sampling Distance: 1mm Sampling Distance: 5mm 
 
Refit To Feature Lines – Tries to find and fit feature lines when drawing with the pencil tool. 

  

Sampling Distance: 1mm Sampling Distance: 5mm 
 

Search Radius – Changes the radius distance for searching for feature lines around a 
drawn stroke. 

 
 

See Also 

Tools > 3D Sketch Entities > Spline 
 
 
 

Tools > 3D Sketch Entities > Section 
 

What 

The Section command is used to create section curves on mesh and solid surface bodies. This 
command is available in both 3D Sketch mode and 3D Mesh Sketch Mode. 
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Why 

The Section command is useful for: 

• Creating a curve network for a boundary fitted surface 

• Creating a path for a swept or lofted body 

• Making a profile of a model to simplify in making a lofted body 

 
 

How to Use 

How to create a model profile in 3D Sketch mode 
1. Enter 3D Sketch mode and go to Tools > 3D Sketch Entities > Section, or click on the 

icon in the toolbar.  

 
 

2. Click on the mesh to select the entire model as the Target Entity. This will select all 
entities available. Click the Next Stage button to proceed. 
 

3. Go to the N-Division Between Planes method and select the Right plane as the 
reference plane for the Base Plane input box. Set the No. Of Sections option to 7 and 
click OK. 

.  
 

4. The model will be sectioned into seven sections of equal length. 
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5. Exit the 3D Sketch mode and hide the mesh to see the created sections. 

 
 
 

Options in Detail 

Methods 

The following methods are available: 

• Draw Line On Screen 

Creates sections from a line. 

• Select Plane 

Creates sections from an intersecting plane. 

• N-Division Between Planes 

Creates sections based on a chosen base plane. 

• N-Division Along Curve 

Creates sections based on a chosen curve. 

• Radial 

Creates sections based radial segments. 

• Cylindrical 

Creates sections based on cylindrical segments. 

• Conical 

Creates sections based on conical segments. 

 
Draw Line On Screen – Creates sectional curves by drawing lines on the screen. 

  

Cutting Line Resulting Section Spline 
 

Note:  

The Shift key can be used to draw horizontal or vertical lines. Multiple cutting lines can be created at 
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one time by using the Draw Line On Screen method. The Undo command or Ctrl + Z keyboard shortcut 
will delete the last created cutting line. 

 
N-Division Between Planes – Creates a specified number of sections based on chosen base 
planes. 

 
 

N-Division Resulting Section Spline 
 
Distance Between Sections – Sets the distance between sections. 
 

No. of Sections – Sets the total number of sections. 
 
Equal Spacing – Creates an equal amount of space between all sections. 
 

No. of Sections – Sets the total number of sections to be created which includes the 
two base planes selected for the option. 

 
Show Section Base Geometry – Shows the base geometry of the section. 
 

N-Division Along Curve – Creates the specified number of sections with respect to the curve. 
 

Uniform – Creates multiple sections by either a total number of sections or by equal 
distances. 
 

No. of Sections – Uses a set number of sections as the criteria. 
 
Equal Spacing – Uses equal spacing as the criteria. 

 
Show Section Base Geometry – Shows the base geometry of the section. 

 
Curvature – Creates more sections in areas of higher curvature. 
 

No. of Sections – Uses a set number of sections as the criteria. 
  
Show Section Base Geometry – Shows the base geometry of the section. 

 
Pick Points – Creates sections manually by picking points on a curve. To cancel the last 
picked point the Undo keyboard shortcut Ctrl + Z can be used. 
 

Show Section Base Geometry – Shows the base geometry of the section. 
 

Radial – Creates virtual radial sections and generates section curves from them. 
 
Axis – Chooses an axis. 
 
Base Plane – Chooses a base plane. 
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Flip Start Plane – Flips the starting plane the opposite direction. 
 

No. of Sections – Sets the number of sections. 
 
Total Angle – Sets the total angle value of a radial section. 
 
Equal Spacing – Sets equal spacing between sections. 
 
Show Section Base Geometry – Shows the base geometry of a section. 
 

Cylindrical – Creates cylindrical sections and generates section curves. 
 
Axis – Chooses an axis. 
 
Base Plane – Chooses a base plane. 
 
Flip Start Plane – Flips the starting plane the opposite direction. 
 

No. of Sections – Sets a number of sections. 
 
Total Angle – Sets a total angle value. 
 
Radius Interval – Sets the distance between sections. 
 
Base Radius – Sets the base radius of a starting section. 
 
Height – Sets the height of a cylindrical area. 
 
Section Inside – Sets the creation direction from the base radius. 
 
Show Section Base Geometry – Shows the base geometry of the section. 
 

Conical – Creates conical sections and generates section curves from them. 
 
Axis – Chooses an axis. 
 
Base Plane – Chooses a base plane. 
 
Base Position – Specifies X, Y, or Z as a base position. 
 
Flip Start Plane – Flips the starting plane the opposite direction. 
 

No. of Sections – Sets the number of sections. 
 
Total Angle – Sets a total angle value. 
 
Radius Interval – Sets a radius interval. 
 
Bottom Radius – Sets a value for a bottom radius. 
 
Top Radius – Sets a value for a top radius. 
 
Apex Angle – Sets a value for a slope. 
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Height – Sets a value for height. 
 
Section Inside – Sets the value for a creation direction. 
 
Show Section Base Geometry – Shows section cylinders. 

 
 

See Also 

Tools > 3D Sketch Entities > Intersection 
 
 
 

Tools > 3D Sketch Entities > Intersection 
 

What 

The Intersection command is used to create intersection splines between bodies. It can only be 
used in 3D Sketch mode. 

 
 
 

Why 

The Intersection command is useful for: 

• Finding the boundaries where two entities meet  

 
 

How to Use 

How to find an intersection for two entities 
1. Go to Tools > 3D Sketch Entities > Intersection, or click on the icon in 3D Sketch 

mode. 
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2. Select target Tool Bodies and Target Bodies. The Tool Bodies will be the bodies that 
are used as the base bodies and the Target Bodies will be the bodies that the 
intersections using the Tool Bodies are found on. 

 
 

3. Click OK to complete the command. The intersection between the bodies will be 
created. 

 
 
 

Options in Detail 

Tool Bodies – Select tool bodies. 
 
Target Bodies – Select target bodies. 

 
 
 
 

Tools > 3D Sketch Entities > Boundary 
 

What 

The Boundary command is used to extract curves from the boundary of a mesh. This command is 
available in both 3D Sketch mode and 3D Mesh Sketch mode. 
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Why 

The Boundary command is useful for: 

• Creating a path for a swept or lofted body 

• Finding the boundary of a model that is irregularly shaped  

 
 

How to Use 

How to find boundary for an entity 
1. Go to Tools > 3D Sketch Entities > Boundary, or click on the icon in 3D Mesh Sketch 

or 3D Sketch mode. 

 
 

2. Select the Curves From Boundaries option and choose an outside boundary on the 
model for the Boundaries input box. 

 
 

3. Click OK to extract the selected boundary as a spline. If only a part of the boundary is 
desired to be extracted then the Interactively Split Curve Segments From a Single 
Boundary option can be used to manually pick the starting and ending points of the 
boundary. 
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Boundary as a spline Split curve segment from a boundary 
 

 
 

Options in Detail 

Curves From Boundaries – Creates 3D spline curves on selected mesh boundaries. 
 
Interactively Split Curve Segments From a Single Boundary – Creates a partial boundary 
curve by picking a starting and ending point on a boundary. 
 
Boundaries – Selects boundaries on a mesh. 
 
Smoothness – Defines the smoothness of a boundary curve by using a value between a Min 
and Max limits. 

  

Min. Smoothness Max. Smoothness 
 
Offset – Creates an offset curve from a boundary. 

 
 
 

See Also 

Tools > 3D Sketch Entities > Fit From Points 
Tools > 3D Sketch Entities > Create Curve Network 
 
 
 

Tools > 3D Sketch Entities > Surface UV Curves 
 

What 

The Surface UV Curves command is used to create 3D curves on a face along its U and V directions. 
This command is available only in 3D Sketch mode. 



Geomagic Design X | Menu  818 
 

 
 
 

Why 

The Surface UV Curves command is useful for: 

• Creating 3D curve networks on curved faces that are relatively uniform and follow the U and V 
directions 

 
 

How to Use 

How to find set a UV Curves 
1. Go to Tools > 3D Sketch Entities > Surface UV Curve or click on the icon in the 3D 

Sketch Mode. 

 
 

2. Select a position on a face. 

 
 

3. Click OK to finish the command. 

 
 
 

Options in Detail 
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Parameter Direction – Chooses the U, V, or both the U and V directions for creating curves. 
 
Make Curve Editable – Created curves will have node points that are editable. 

 
 

Make Node At UV Curves Intersection – Creates intersection nodes at the intersection 
point of the U and V curves. 

 
 
 

See Also 

Tools > 3D Sketch Entities > Spline 
Tools > 3D Sketch Entities > Section 
 
 
 

Tools > 3D Sketch Entities > Fit From Points 
 

What 

The Fit From Points command is used to create 3D curves from points or region boundaries by 
fitting to them. This command is available in both 3D Sketch mode and 3D Mesh Sketch mode. 

 
 
 

Why 

The Fit From Points command is useful for: 

• Generating analytic curves such as circles, slots and rectangles from point data 
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• Generating freeform curves from point data 

• Generation of curves on region boundaries and character lines of a model 

 
 

How to Use 

How to extract feature shapes using the Fit From Points command 
1. Enter Mesh mode to extract boundary vertices from a mesh. 

 
 

2. Go to Select > Boundary Entities and change the Type To Select option to Poly-
Vertices and select all boundaries. Click OK. 

 
 

3. Go to Edit > Copy to copy selected boundary vertices. Exit the Mesh mode. 
 

4. Go to Edit > Paste. A new mesh will be created. 

 
 

5. Select the new mesh and enter the 3D Mesh Sketch mode. 
 

6. Go to Tools > 3D Sketch Entities > Fit From Points and select points. 

 
 

7. Click OK to complete the command. Curves will be extracted from the slot and circle 
shapes. 
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Options in Detail 

Target – Select poly-vertices or region boundaries for fitting curves. 

 
Fitting curve from points 

 

 

Fitting curve from region boundaries 
 
Split Target – Splits a fitting curve. Click the button and pick the starting and ending points for 
the splitting position on the preview curve and a split point will be added. 

 
 

Fitting Options 

Fitting Shape – Generates a fitting curves from several shapes: Auto, Circle, Slot, Rectangle 
Polygon, Line and Freeform. 
 

Fitting Shape – Chooses the type of shape for the fitting curve. 

  

Auto 
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Circle 
 

  

Slot 
 

  

Rectangle 
 

  

Polygon 
 

  

Freeform 
 
Allowable Tolerance – Fits a curve to a shape within a given value. The Auto Estimate button 

 computes the value automatically. 
 

More Options 

Fitting Type – Creates a best-fitted value by the least square fitting method when the Best Fit 
option is selected. The least squares method is the approximate solution from distributed data. 
The Min. Bound option finds the smallest radial distance value between a pair of concentric 
circles and Max. Bound finds the largest value. 
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Least Square Method Best Fit Min / Max Boundary  

from Minimum Separation 
 
Remove Outlier – Removes outlier data from the fitting type using the N*Sigma, Ratio (%), or 
Absolute Distance algorithms. 
 
Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all selected 
data will be used. When the ratio is 50%, half of the selected data will be used. 
 
Use Only Effective Data – Uses only effective data when fitting. Effective data is the actual data 
points used in fitting after sampling and outlier removal. 
 
Rounded Corner – Rounds corners of rectangular shapes. 
 
No. Of Edges – Sets the number of edges created. 
 
Smoothness – Controls the smoothness of extracted curves. 

 
 

See Also 

Tools > 3D Sketch Entities > Boundary 
Tools > 3D Sketch Entities > Create Curve Network 
 
 
 

Tools > 3D Sketch Entities > Trace Feature Line 
 

What 

The Trace Feature Line command is used to automatically extract character lines from mesh. This 
command is only available in 3D Mesh Sketch mode. 
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Why 

The Trace Feature Line command is useful for: 

• Automatically extracting a line from a model that might be difficult to do manually 

 
 

How to Use 

How to extract a feature line from mesh 
1. Go to Tools > 3D Sketch Entities > Trace Feature Line, or click the icon in 3D Mesh 

Sketch mode. 

 
 

2. Select a poly-vertex to extract a feature line. 

 
 

3. A preview curve will be generated. 

 
 

4. Clicking OK will extract the feature curve as a spline. If only a part of the feature line is 
desired to be extracted then the starting and ending points can be selected. 
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5. Click OK or double click on the curve to complete the command. 

 
 
 

Options in Detail 

Seed Poly-Vertex – Picks a poly-vertex on the mesh to extract a feature line. 
 
Search Depth – Adjusts the depth of the feature line. A value between 1 and 5 can be inputted 
or selected with a slider bar. The larger the depth, the more character lines can be found, but a 
larger depth may include noisy character lines. 
 
Smoothness – Specifies the smoothness of a feature line. A value between Min and Max. can 
be specified. When a high smoothness value is chosen, the resulting curve will be smoother but 
may lose accuracy. 

  

Min. Smoothness Max. Smoothness 
 

 
 

See Also 

Tools > 3D Sketch Entities > Extract Feature Curves 
Tools > 3D Sketch Entities > Create Curve Network 
 
 
 

Tools > 3D Sketch Entities > Extract Feature Curves 
 

What 

The Extract Feature Curve command is used to detect and extract 3D lines from areas of high 
curvature. This command is only available in 3D Mesh Sketch mode. 



Geomagic Design X | Menu  826 
 

 
 
 

Why 

The Extract Feature Curve command is useful for: 

• Extracting feature lines from areas that have high degrees of variable curvature 

 

Note:  

It is more efficient to use a mesh that has had the Decimate command applied to it rather than a dense 
mesh for the Extract Feature Curve tool. 

 
 

How to Use 

How to extract a feature curve from mesh 
1. Go to Tools > 3D Sketch Entities > Extract Feature Curves, or click the icon in 3D Mesh 

Sketch mode. 

 
 

2. Adjust the Detection Sensitivity and Loop Size Level options and click the Next Stage 
button. 
 

3. Adjust the Smoothness option and click OK to finish the command. 

 
 
 

Options in Detail 

Stages 



Geomagic Design X | Menu  827 
 

This command consists of the following stages: 

• Set Properties 

Sets the Detection Sensitivity and Loop Size Level options. 

• Preview 

Sets the Smoothness and previews the feature curve. 

 
 

Stage 1/2 – Set Properties 

Set Properties – Sets the Detection Sensitivity and Loop Size Level options for the command. 
 

Detection Sensitivity – Determines the sensitivity used to extract feature curves. For 
low curvature models, set the Sensitivity to high and for high curvature model set the 
Sensitivity to low. 

  

0 Detection Sensitivity 10 Detection Sensitivity 
 

Loop Size Level – Removes noisy curves. If the application unexpectedly creates many 
small loops, increase the value of the Loop Size Level option. 

  

0 Loop Size Level 10 Loop Size Level 
 

Stage 2/2 – Preview 

Smoothness – Specifies the smoothness of a feature line. A value between Min and Max. can be 
specified. If a high smoothness value is chosen, the resulting curve will be smoother but may 
lose accuracy. 

  

Min. Smoothness Max. Smoothness 
 

 
 

See Also 

Tools > 3D Sketch Entities > Fit From Points 
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Tools > 3D Sketch Entities > Trace Feature Line 
Tools > 3D Sketch Entities > Create Curve Network 
 
 
 

Tools > 3D Sketch Entities > Create Curve Network 
 

What 

The Create Curve Network command is used to generate a 3D curve network on a mesh. This 
command is only available in 3D Mesh Sketch mode. 

 
 
 

Why 

The Create Curve Network command is useful for: 

• Quickly creating a 3D curve network that follows character features to enclose a mesh 

• Generating a 3D curve network to use with the Boundary Fit Surface command 

 
 

How to Use 

How to create a curve network from mesh 
1. Go to Tools > 3D Sketch Entities > Create Curve Network, or click the icon in the 

toolbar in 3D Mesh Sketch mode. 

 
 

2. Adjust the slider of the Level of Patch Complexity option to Less. 
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3. Click the Next Stage button. A preview of the curve network will be displayed. 

 
 

4. The Deform command can be used to adjust a curve if it needs to be smoothed. 

  
 

Note:  

The editing zone can be resized by using the Alt key while dragging the mouse left or right. 

 

  
 
 

5. Click OK to complete the command. 

 
 
 

Options in Detail 

Stages 

This command consists of the following stages: 

• Feature Detection 

Used to detect features for creating a curve network 

• Curve Network Editing 

Edit a created curve network 
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Stage 1/2 – Feature Detection 

Level of Patch Complexity – Adjusts the level of patch complexity in a mesh using the slider. 
The number of curve loops will be increased by adjusting towards "More". 
 
Optimize Patch Network – Optimizes the patch shape for creating a curve network. 
 

Stage 2/2 – Curve Network Editing 

Deform(D) – Deforms a curve by selecting and dragging nodes. The shortcut key of this method 
is D. 

  

Before Deform After Deform 
 
Split(S) – Splits a curve loop to generate more loops by picking a point on a curve and picking a 
second point on another curve displayed in green. The shortcut key of this method is S. 

  

Before Split After Split 
 
Slide(E) – Slides a starting or ending point of a curve to another curve. The shortcut key of this 
method is E. 

  

Before Detach And Move After Detach And Move 
 
Merge(G) – Merges curve loops in the network with another green-colored loops highlighted as 
being able to be merged. The shortcut key of this method is G. 
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Before Merge After Merge 
 
Remove(R) – Removes a curve. The shortcut key of this method is R. 

  

Before Remove After Remove 
 
Swap Y and T Junction (W) – Swaps the properties of a Y junction and a T junction. Splines able 
to be swap will be displayed in green. When a green spline is selected, the T junction mark will 
be swap to the Y junction. The shortcut key of this method is W. 
 
Y junction consists of three curves and T junction consists of two curves. 

  

Y Junction T Junction 
 
If a curve loop is consist of Y and T junction but T junction is located at a corner of a rectangle, 
the rectangle does not consist of right four edges. By swapping Y and T junction this rectangle 
can have correct four edges.  

  

Before Swap After Swap 
 
Show Erroneous Network – Highlights erroneous curves (gaps between curves or twisted 
curves expected to be generated error surface patches) in red. The thin red curve shows errors 
created when fitting or sewing. The thick red curve shows errors created when generating 
surfaces. Erroneous curves can be navigated through by clicking the Previous  or Next  
buttons. 
 
Show Nodes And T-junctions – Displays interesting nodes and T junction on curve loops. 
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Show Nodes and T Junctions Hide Nodes and T Junctions 
 
Deform With Stiffening Around Crossing Nodes – Maintains tangency after deforming curves 
around an intersecting node, otherwise, sharp edges will be formed. 

   
With Option Without Option 

 

 
 

See Also 

Tools > 3D Sketch Entities > Boundary 
Tools > 3D Sketch Entities > Fit From Points 
Tools > 3D Sketch Entities > Trace Feature Line 
Tools > 3D Sketch Entities > Extract Feature Curves 
 
 
 

7.5.11. Tools > 3D Sketch Tools 
 
The 3D Sketch Tools menu features various commands used to edit 3D sketch entities such as 
Offset, Project, Smooth, and Trim. 
 
 
The 3D Sketch Tools menu provides 3 sets of sketch edit tools used to: 
 
 

Modify 3D Sketch Entities 

• Offset 

Modifies sketch entities by adding a tangent arc in between the sketch entities 

• Project 

Modifies sketch entities by adding an angled line in between the sketch entities 

• Mirror 

Offsets sketch entities by a specified distance 

• Convert Entities 

Converts other entities into sketch entities 
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Edit 3D Sketch Entities 

• Smooth 

Trims sketch entities 

• Trim 

Extends sketch entities 

• Extend 

Extends sketch entities 

• Split 

Splits a sketch entity into multiple parts 

• Match 

Mirrors a part of a sketch entity 

• Merge 

Merges sketch entities into a single sketch entity 

 
 

Adding Patterned 3D Sketch Entities 

• Insert Node 

Creates linear patterns from sketch entities 

• Remove Node 

Creates circular patterns from sketch entities 

• Remove Constraint 

Creates circular patterns from sketch entities 

 
 
 

Tools > 3D Sketch Tools > Offset 
 

What 

The Offset command is used to offset existing curves or lines. 
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Why 

The Offset command is useful for: 

• Offsetting a line or a curve to create lines or curves with the same properties and shape. 

 
 

How to Use 

How to offset a curve on a mesh 
1. Go to Tools > 3D Sketch Tools > Offset, or click the icon in the toolbar. 

 
2. Select a curve to offset. 

 
3. Specify the distance desired for the offset curve. Direction1 creates a curve in a 

direction from the existing curve. Direction2 creates a curve in the other direction. Both 
Directions creates both curves. 

 
 

Offset curve in Direction1 Offset curve in Both Directions 
 

 
 

Options in Detail 

Base Entity – Selects base entities. 
 
Curves – Selects curves to offset. 
 
Distance – Sets the distance of the offset. 
 
Direction1 – Creates a curve in a first direction from the original curve. 
 
Direction2 – Creates a curve in a second direction from the original curve. 
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Both Directions – Creates two curves in both directions from the original curve. 
 

More Options 

Remove Original Curves – Removes the original curve after the offset is completed. 
 
Offset Curve Deviation – Connects curves within a given deviation value. 

  

Tolerance: 0.01 Tolerance: 0.1 
 

 
 

See Also 

Tools > Sketch Tools > Offset  
 
 
 

Tools > 3D Sketch Tools > Project 
 

What 

The Project command is used to project curves or nodes onto a selected entity. 

 
 
 

Why 

The Project command is useful for: 

• Creating a copy of a line onto an entity 

 
 

How to Use 
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How to project a curve onto a surface 
1. Go to Tools > 3D Sketch Tools > Project or click the icon in the toolbar. This command 

can only be used in 3D Sketch Mode. 

 
 

2. Select a target curve and a body as the target entity. 

 
 

3. Change the Projection Method option to Along Vector and select a reference plane. 

 
 

4. Click OK to complete the command. 

 
 
 

Options in Detail 

Curves / Nodes – Selects curves or nodes to project. 
 
Target Entity – Selects target entity to project the target curve onto. 
 
Project Duplicated Curve – Retains an original curve. 
 

Projection Method 

Min. Distance – Projects a curve to a minimum distance. 
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Along Vector – Projects a curve in a selected direction. A ref. plane, vector, curve or edge can 
be used. 
 

Tangent – Selects an entity to use. 
 

 
 
Allowable Deviation – Sets a deviation value between a projected curve and a target entity. 

 
 
 

Tools > 3D Sketch Tools > Mirror 
 

What 

The Mirror command is used to mirror 3D curves. 

 
 
 

Why 

The Mirror command is useful for: 

• Creating a mirrored copy of a 3D curve 
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Note:  

A curve mirrored in 3D Mesh Sketch mode will be projected onto the mesh. 

 
 

How to Use 

How to mirror a curve 
1. Go to Tools > 3D Sketch Tools > Mirror, or click the icon in the toolbar. 

  
 

2. Select a Symmetry Plane and Curves as the entities that will be mirrored.  

 
 

3. Click OK to complete the command. 
 
 

Options in Detail 

Symmetry Plane – Selects a ref. plane or planar face as a Symmetry Plane. 
 
Curves – Select curves to mirror. 
 
Remove Original Curves – Removes original curves after mirroring. 

 
 

See Also 

Tools > Sketch Tools > Mirror 
 
 
 

Tools > 3D Sketch Tools > Convert Entities 
 



Geomagic Design X | Menu  839 
 

What 

The Convert Entities command is used to convert entities such as sketches, edges, and polylines 
into 3D curves. 

 
 
 

Why 

The Convert Entities command is useful for: 

• Creating a 3D curve out of a 2D entity 

 

Note:  

The Convert Entities tool available in 3D Mesh Sketch mode has a few differences from the Convert 
Entities tool found in the 3D Sketch Tools menu. The differences are: 

- There are no relationships between the target entity and converted curves in this mode 

- A converted curve will be projected onto a mesh and registered as a Mesh 3D curve 

 
 

How to Use 

How to convert an entity 
1. Go to Tools > 3D Sketch Tools > Convert Entities, or click the icon in the toolbar. 

  
 

2. Select edges to convert. 

 
 

3. Click OK to complete the command. A 3D curve will be generated. 
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Options in Detail 

Entities – Selects entities to convert. Entities can be polylines, curves on a 2D Sketch or edges. 
Curves converted from polylines in the Sketch mode have constraints so that if changes are 
made, the converted curves will also change. 

 
 

Note:  

A spline that is black contains constraints. To remove constraints use the Remove Constraints 
command. 

 
Fitting Accuracy – Sets the percentage of fitting accuracy when converting polylines. 

  

Accuracy: Loose Accuracy: Tight 
 

Note:  

The Smooth command regenerates intersection points between curves. The parameters for 
intersection points can be set in the Join tool palette. 

 
 

 
 

See Also 

Tools > Sketch Tools > Convert Entities  
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Tools > 3D Sketch Tools > Smooth 
 

What 

The Smooth command is used to smooth curves. 

 
 
 

Why 

The Smooth command is useful for: 

• Smoothing irregular curves 

• Smoothing a portion of a curve 

• Saving time over smoothing curves manually 

 
 

How to Use 

How to smooth a curve 
1. Go to Tools > 3D Sketch Tools> Smooth or click the icon in the toolbar. 

 
2. Select a curve and adjust the Smoothness setting. Click OK to complete the command. 

 

 

 

Before Smoothing After Smoothing 
 

 
 

Options in Detail 

Methods 

All Range – Applies smoothing to a selected curve. 
 
Partial Range – Determines the strength of the smoothing procedure. 

Sub Options 

Curves – Selects curves to smooth. 
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Smoothness – Sets a level of smoothness from Min. to Max. 
 
 
 

Tools > 3D Sketch Tools > Trim 
 

What 

The Trim command is used to trim curves. 

 
 
 

Why 

The Trim command is useful for: 

• Trimming away unwanted sections of a curve  

• Combining curves 

 
 

How to Use 

How to trim curves 
1. Go to Tools > 3D Sketch Tools > Trim, or click the icon in the toolbar. 

 
 

2. Select curves. Click OK to complete the command.  
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Options in Detail 

Methods 

Pick Curve Portion To Trim – Trims selected curves. 

 
 
Trim Short Portion Of Curves – Trims the short portions from selected curves. 

 
 
Curves – Selects curves to trim. 
 
Portion Rate – Sets the ratio of short curves compared to an original curve length. 
 
Intersection Tolerance – Determines whether curves intersect or not by setting the tolerance 
for gaps between curves. 

 
 

See Also 

Tools > Sketch Tools > Trim  
 
 
 

Tools > 3D Sketch Tools > Extend 
 

What 

The Extend command is used to extend 3D curves and lines. 
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Why 

The Extend tool is useful for: 

• Extending a 3D curve or line  

 

Note:  

Extending a curve in 3D Mesh Sketch mode will follow mesh data. To extend a curve in a tangential 
direction without following the mesh, copy the curve in the 3D Mesh Sketch mode into the 3D Sketch 
mode and then apply the Extend command. 

 
 

How to Use 

How to extend a curve 
1. Go to Tools > 3D Sketch Tools > Extend or click the icon in the toolbar. 

 
 

2. Select a curve to extend and click-drag the arrow on the screen. To extend a curve in 
both directions click on the curve itself, or to extend in only one direction click on the 
end of the curve in the desired direction. 

 
 

3. Click OK to complete the command. 
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Options in Detail 

Curves – Selects curves to extend 

Options 

Shape – Selects the shape of an extension. 
 

Tangent – Extends a curve in a tangential direction from a starting position. 
 

Curvature – Extends a curve in a curvature direction from a starting position. 
 

Reflective – Extends a curve as a reflection of the original shape. 
 
Distance – Sets a distance to extend. 

 
 

See Also 

Tools > Sketch Tools > Extend  
 
 
 

Tools > 3D Sketch Tools > Split 
 

What 

The Split command is used to divide a curve. 

 
 
 

Why 

The Split command useful for: 
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• Dividing a curve by creating a node if one does not exist 

 
 

How to Use 

How to use the Split command to create nodes on a curve 
1. Go to Tools > 3D Sketch Tools > Split or click the icon in the toolbar. 

 
 

2. Pick points on the curve to split and click OK. The curve will now have nodes where the 
split command was used. 

 
 

Note:  

The Split command can move the seam position of a closed curve. A split position on a closed 
curved will become the new seam point. 

 

  

Original Seam Point Changed Seam Point 
 

 
 

Options in Detail 

Pick Points – Splits a curve at a picked point. 
 
Curves At Intersection Points – Splits a curve at an intersecting point. 
 
Plane Or Face Intersection Points – Splits a curve on intersecting positions with other planes 
or faces. 
 
Curves – Selects curves to split. 
 

Intersection Tolerance – Sets the tolerance for splitting curves at an intersection point. 
 

Tool Entity – Selects tool entity. 
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See Also 

Tools > Sketch Tools > Split  
 
 
 

Tools > 3D Sketch Tools > Match 
 

What 

The Match command is used to match tangencies and curvatures between a curve and another 
entity. 

 
 
 

Why 

The Match command is useful for: 

• Creating areas that a scanner might not be able to get data for 

 
 

How to Use 

How to extract a curve from two solid faces 
1. Click the 3D Sketch mode icon. 

 
2. Go to Tools > 3D Sketch Tools > Match or click the icon in the toolbar. 

 
 

3. Select a Curve to match and a body edge as the Target Entity. 
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4. Click OK to match the selected curves. 

 
 

5. Apply the matching process in steps 2-4 again on the other side of the model to 
complete the match. 

 
 
 

Options in Detail 

Tangent – Makes a tangency (G1) connection to the target entity. 
 
Curvature – Makes a curvature (C2) connection to the target entity. 
 
Orthogonal – Makes an orthogonal connection to the target entity. Only reference planes and 
faces can be used for this method. 
 
Curve – Selects a curve to match. 
 
Target Entity – Selects an entity to use as a matching reference. The target entity can be a ref. 
vector, ref. plane, curve, edge, or face. 
 

 

 
Curve to Ref. Vector Curve to Ref. Plane 
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Curve to Curve Curve to Edge 
  

 

 

Curve to Face  
 
Average – Modifies a target curve to create a smooth connection. 

  
Disable Average Enable Average 

 

Note:  

A matched constraint will be shown with blue arrows. To remove constraints, click the Remove 

Contraint button  on the toolbar and select the constraints in the list box. 
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Tools > 3D Sketch Tools > Merge 
 

What 

The Merge command is used to merge separate curves to form a single curve. 

 
 
 

Why 

The Merge command is useful for: 

• Merging separate lines into one line 

 
 

How to Use 

How to merge curves 
1. Go to Tools > 3D Sketch Tools > Merge or click the icon in the toolbar. 

 
 

2. Select curves to merge. 

 
 

3. Click OK to complete the command and merge the selected curves. 

 
 



Geomagic Design X | Menu  851 
 

 

Options in Detail 

Methods 

2 Curve Ends – Connects the ends of two curves. 
 
Average Multiple Curves – Combines neighboring curves to generate a single averaged curve. 

More Options 

Curves – Selects curves to merge. 
 
Fix Shape – Preserves the original shape of curves. This option can be used to preserve a sharp 
edge after merging and is available only in 3D Sketch mode. 

   
Original Curves Disable Option Enable Option 

 
Smoothness – Sets the smoothness when averaging multiple curves. 
 
Merge Range – Merges the values between curves. 

 
 

See Also 

Tools > Sketch Tools > Merge  
 
 
 
 

Tools > 3D Sketch Tools > Insert Node 
 

What 

The Insert Node command is used to insert a node onto a curve or line. 
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Why 

The Insert Node command is useful for: 

• Creating a break in a line 

• Creating a node to connect another line to 

 
 

How to Use 

How to insert a node 
1. Go to Tools > 3D Sketch Tools > Insert Node or click on the icon in the toolbar. 

 
 

2. Click on a curve to insert nodes. Click OK to finish the command. 

 
 

Note:  

A node can be added onto a line or curve by dragging an existing node while holding down 
the Ctrl key on the keyboard. 

 

 
 

 
 

See Also 

Tools > 3D Sketch Tools > Remove Node 
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Tools > 3D Sketch Tools > Remove Node 
 

What 

The Remove Node command is used to remove a node from a curve or line. 

 
 
 

Why 

The Remove Node command is useful for: 

• Removing nodes in a line 

 
 

How to use 

How to remove a node 
1. Go to Tools > 3D Sketch Tools > Remove Node or click on the icon in the toolbar. 

 
2. Select nodes to remove. 

  

Before Node Removal After Node Removal 
 

Note:  

A node can be removed by pressing the Delete key on the keyboard. 
 

 
 

See Also 

Tools > 3D Sketch Tools > Insert Node  
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Tools > 3D Sketch Tools > Remove Constraint 
 

What 

The Remove Constraint command is used to remove existing constraints on curves and nodes. 

 
 
 

Why 

The Remove Constraint command is useful for: 

• Removing constraints on curves and nodes 

• Removing temporary created constraints to make modeling easier 

 
 

How to Use 

How to remove constraints on a curve 
1. Go to Tools > 3D Sketch Tools > Remove Constraint or click the icon in the toolbar. 

 
 

2. Select a curve and all constraints on the curve will be displayed. 

 
 

3. Select constraints to be removed and click OK to complete the command. Constraints 
will be removed and the converted curve will be displayed in blue. 
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Options in Detail 

Curve / Nodes – Selects curves or nodes to remove constraints. 
 
Constraints To Remove – Shows a list of constraints that can be removed by selecting the 
constraint in the list box and clicking the Delete button on the keyboard. 
 

Note:  

Constraints can also be removed by using the Trash Can icon that will appear next to a constraint when 
selected. 

 
No. Of Interpolation Points – Sets the number of interpolation points and regenerates the curve 
when removing constraints from an imported curve. 

 
 

7.5.12. Tools > Body Tools 
 
The Body Tools menu features methods to deal with surfaces. 
 
 
 

Tools > Body Tools > Find Defect 
 

What 

The Find Defect command is used to detect defects on solid and surface bodies. 

 
 
 

Why 

The Find Defect command is useful for: 

• Detecting defects that are too small to see manually 

• Finding the location of defects 

• Finding self-intersected or discontinuous faces 
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How to Use 

How to find defects on a solid body 
1. Go to Tools > Body Tools > Find Defect or click the icon in the toolbar. 

 
 

2. Select a body and check the Self Intersection Test and Face Continuity Test options 
to set the defect detection parameters. Click the Next Stage button to continue to the 
next step. 
 

3. Defective faces that self-intersect or have continuity issues will be displayed on the 
model in a different color. 

 
 
 

Options in Detail 

Bodies – Selects bodies to inspect. 
 
Self Intersection Test – Detects self-intersecting faces. 
 
Face Continuity Test – Detect discontinuous faces. 

 
 

See Also 

Tools > Body Tools > Find Defect 
 
 
 

7.5.13. Tools > Align 
 
The Align Tools menu features methods to align mesh data to global or user defined coordinates 
or original CAD data. 
 
The Align Tools menu provides 3 sets of alignment tools used to: 
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Align by Wizards 

• Wizard 

Aligns a mesh to a desired set of coordinates 

• Interactive Alignment 

Interactively aligns a mesh using one of several available methods 

 
 

Align by Fitting 

• Quick Fit 

Roughly aligns a mesh to a solid body by matching principal axis 

• Best Fit 

Registers a scan to a body as accurately as possible by utilizing the overlapping regions between 
them 

 
 

Align by Datums 

• Datum Match 

Registers a scan to a body by using datums 

 
 
 

Tools > Align > Wizard 
 

What 

The Align Wizard command is used to align a mesh to a desired set of coordinates. 

 
 
 

Why 
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The Align Wizard command is useful for: 

• Finding and choosing suitable candidate alignments 

• Extracting alignments from mesh features 

 
 

How to Use 

How to find and select a coordinate candidate 
1. Go to Tools > Align > Wizard or click the icon in the toolbar. 

 
 

Note:  

A mesh needs regions before executing the Align Wizard command. Regions can be created 
by using the Auto Segment command in the Region Group mode. 

 
 

2. Select a mesh and click the Next Step icon. The application will show candidate 
coordinates for the mesh. 

 
 

3. Select Coordinate 1 and click the OK button to align to that coordinate and finish the 
command. 

 
 
 

Options in Detail 
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Stages 

This command consists of the following stages: 

• Moving Mesh 

Select a mesh or point cloud to align 

• Candidate 

Chooses a candidate coordinate. The ideal coordinate is listed at the top of the list box. 

 
 

Stage 1/2 – Moving Mesh 

Moving Mesh – Selects a mesh or point cloud to align. 
 

Stage 2/2 – Candidate 

Candidate – Chooses a candidate coordinate. 
 

Max. Num Of Candidate – Controls the maximum number of candidate coordinates. 

 
 

Max. Number of Candidates Min. Number of Candidates 
 

 
 

See Also 

Tools > Align > Interactive Alignment 
Tools > Align > Quick Fit 
Tools > Align > Best Fit 
Tools > Align > Datum Match 
 
 
 
 

Tools > Align > Interactive Alignment 
 

What 

The Interactive Alignment command is used to interactively align a mesh using one of several 
available methods. 



Geomagic Design X | Menu  860 
 

 
 
 

Why 

The Interactive Alignment command is useful for: 

• Manually aligning a model using one of two different alignment types 

 
 

How to Use 

How to use the X-Y-Z interactive alignment method 
1. Go to Tools > Align > Interactive Alignment or click the icon in the toolbar. 

 
 

Note:  

A mesh needs regions before executing the Interactive Alignment command. Regions can 
be created by using the Auto Segment command in the Region Group mode. 

 
 

2. Select a mesh and click the Next Stage button to divide the Model View vertically into 
two views. The left view is the Source and the right view is the Reference. Choose the 
X-Y-Z method. 
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3. Click the Plane button and select the bottom planar region. 

 
 

4. Click the Vector button and select a side region that perpendicular to the previously 
selected region. 

 
 

5. Click the Position button and select the side region perpendicular to the previously 
selected region. 

 
 

6. Click OK. Each perpendicular face is now aligned to the reference planes. 
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Options in Detail 

Stages 

This tool consists of the following stages: 

• Moving Entities 

Select a mesh or point cloud to align 

• Moving 

3-2-1 and X-Y-Z are the available alignment methods in this step. The Target can be set to 
either Coordinate or X-Y-Z. 

 
 

Stage 1/2 – Choosing Moving Entities 

This stage is for choosing the Moving Entities to align. The chosen entities can be aligned to the 
global origin. 
 
Moving Entities – Selects meshes or point clouds to align. 
 
Pre-align With Global Origin – Transforms mesh to the global origin. The application will find 
the minimal bounding box of the mesh and set the longest and the shortest direction to the X-
axis and Z-axis respectively, aligning to the global coordinate. 

 
 

Stage 2/2 – Moving Alignment Method 

The 3-2-1 and X-Y-Z alignment methods are available in this step as well as the ability to set the 
Position, Axis X, Axis Y and Axis Z parameters for the alignment. 
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Note:  

Scans can be manually aligned using the manipulators in the Model view. The scans can be transformed 
by dragging the X, Y, and Z directional arrows, or rotated by dragging the appropriate circle. Entities 
selected as a Plane or a Vector will have constraint directions and axes dimmed in grey. 

 

 
 

Moving 

3-2-1 – Alignment using entities on the mesh as a moving plane, moving vector, and moving 
position. The Flip button   reverses the direction of the selection. 
 

Plane – Sets an entity as the moving plane. 
 

Vector – Sets an entity as the moving vector. 
 

Position – Sets an entity as the moving position. 
 
X-Y-Z – Alignment using entities as moving points and axes. The Flip button  reverses the 
direction of the selection. 
 

Position – Sets an entity as the moving position. 
 

Axis X – Sets an entity as the moving X axis. 
 

Axis Y – Sets an entity as the moving Y axis. 
 

Axis Z – Sets an entity as the moving Z axis. 
 
 

X-Y-Z 

Coordinate – Alignment using target coordinates. 
 

To – Sets the coordinate to align to. 
 
X-Y-Z – Alignment using entities as points and axes. The Flip button  reverses the direction of 
the selection. 
 

Position – Sets an entity as the target position. 
 

Axis X – Sets an entity as the target X axis. 
 

Axis Y – Sets an entity as the target Y axis. 
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Axis Z – Sets an entity as the target Z axis. 
 
 

See Also 

Tools > Align > Wizard 
Tools > Align > Quick Fit 
Tools > Align > Best Fit 
Tools > Align > Datum Match 
 
 
 

Tools > Align > Quick Fit 
 

What 

The Quick Fit command is used to roughly align a mesh to a solid body by matching principal axis. 

 
 
 

Why 

The Quick Fit command is useful for: 

• Comparing an original scan to a CAD model 

 
 

How to Use 

How to use the Quick Fit command to align a mesh to a solid body 
1. Go to Tools > Align > Quick Fit or click the icon in the toolbar. 
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2. Select a mesh as the Moving Entities and a body as the Target Body. 
 

3. The Best Fit Alignment command will automatically execute after the Quick Fit 
command. Use the default setting and click the OK button to finish the command. The 
mesh will now be aligned to the solid body. 

 
 
 

Options in Detail 

Moving Entities – Selects a mesh or point cloud to align. 
 
Target Body – Selects a body to align. 
 

More Options 

Run Best Fit Alignment – Automatically applies Best Fit alignment. 
 
 

See Also 

Tools > Align > Wizard 
Tools > Align > Interactive Alignment 
Tools > Align > Best Fit 
Tools > Align > Datum Match 
 
 
 

Tools > Align > Best Fit  
 

What 

The Best Fit command registers a scan to a body as accurately as possible by utilizing the 
overlapping regions between them. 
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Why 

The Best Fit command is useful for: 

• Comparing an original scan to a CAD model 

 
 

How to Use 

How to use the Best Fit command to align a mesh to a solid body 
1. Go to Tools > Align > Best Fit or click the icon in the toolbar. 

 
 

2. Select a mesh as the Moving Entities and a body as the Target Body. 
 

3. Click OK to complete the command. 

 
 
 

Options in Detail 

Method 

Global – Applies the Best Fit alignment command to an entire mesh. 
 
Partial – Aligns features of scan data with a body. Faces on the body can be used as Reference 
targets. 
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Before Alignment After Partial Alignment 

 
 

Selection 

Moving Entities – Selects a mesh or point cloud. 
 
Target Body – Selects a solid or surface body. 
 

Best Fit Options 

Max. Distance – Sets the maximum distance between alignment entities. 
 
Sampling Ratio – Samples data points by a specified value. When the ratio is 100%, all selected 
data will be used. When the ratio is 50%, half of the selected data will be used. 
 
Max. Iteration Count – Limits the number of times a registration can reiterate. 
 
Max. Average Deviation – Sets deviation criteria to determine if registration results are 
acceptable and can be manually input, automatically calculated, or intelligently decided by the 
application wizard. 
 
Compensate Offset – Compensates for the deviation from an offset between the design data 
and the scan data. 

  

Before Alignment Compensate Offset: 2 
 
 

Constraint Options 

Anchor Type – Defines the reference position for constraints of translation or rotation. Selects 
the type of anchor used in the command. If the Scan Data Center option is selected, the center 
of the bounding box for selected scan data is shown and used as the anchor point. If the Model 
Center option is selected, the center of the target model will be used as an anchor point. If Local 
Coordinate is selected, you can define custom coordinate as the anchor point. If the Global 
Origin option is selected, the origin point in the global coordinate will be used as the anchor 
point. 
 
Lock Translation/Rotation – Limits movement and rotation in each direction while scan data 
is aligned. 
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More Options 

Ignore Outlier – Ignores irregular data during alignment. 
 
 

See Also 

Tools > Align > Wizard 
Tools > Align > Interactive Alignment 
Tools > Align > Quick Fit 
Tools > Align > Datum Match 
 
 
 

Tools > Align > Datum Match 
 

What 

The Datum Match command registers a scan to a body by using datums. 

 
 
 

Why 

The Datum Match command is useful for: 

• Comparing an original scan to a CAD model 

• Aligning a scan coordinate system to the global coordinate system or another specific 
coordinate system 

 
 

How to Use 

How to use the Datum Match command to align a mesh to a solid body 
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1. Go to Tools > Align > Datum Match or click the icon in the toolbar. 

 
 

Note:  

A mesh needs regions before executing the Datum Match command. Regions can be created 
by using the Auto Segment command in the Region Group mode. 

 
 

2. Select a mesh and click the Next Stage button. 
 

3. Select the large cylindrical region on the mesh and select the matching region in the 
design data and click the Flip button. 
 

  

Cylinder on Mesh Data Cylinder on Design Data 
 
 

4. The cylinders will be matched to one another. 

 
Cylinder on Mesh Data 

 

5. Select the planar region on the mesh and design data. 
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Plane on Mesh Data Plane on Design Data 

 
 

6. Click OK to finish the command. 

 
 
 

Options in Detail 

Stages 

This tool consists of 2 stages: 

• Moving Entities 

Selects a mesh or point cloud to align 

• Datum Pairs 

Selects pairs of datums from a mesh and body to align 

 
 

Stage 1/2 – Moving Entities 

Moving Mesh – Selects a mesh or point cloud to align. 
 

Stage 2/2 – Datum Pairs 

Datum Pairs – Selects datum pairs to match and align. 
 

See Also 

Tools > Align > Wizard 
Tools > Align > Interactive Alignment 
Tools > Align > Quick Fit 
Tools > Align > Best Fit 
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7.6. Measure 
 
The Measure menu features functions to measure a distance between plane-plane, plane-line, 
plane-point, line-line, line-point and point-point. 
It also provides methods to measure an angle between plane-plane, plane-line, plane-point-point, 
line-line, line-point-point and point-point-point. The radius of an entity can be measured as well. 
 
The Measure menu provides tools used to: 
 
 

Measure 

• Distance 

Measure the distance between entities 

• Angle 

Measure the angle between two edges or three picked points 

• Radius 

Measure the radius of an edge or three picked points 

• Section 

Temporarily create sections on a mesh and body to measure the deviation between them 

• Mesh Deviations 

Show the deviation between point clouds and meshes using a defined color map 

 
 
 

7.6.1. Measure > Distance  
 

What 

The Distance command measures the distance between entities. 
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Why 

The Distance command is useful for: 

• Comparing distances between plane-plane 

• Comparing distances between plane-line 

• Comparing distances between plane-point 

• Comparing distances between line-line 

• Comparing distances between line-point 

• Comparing distances between point-point 

 

Note:  

Plane-plane, line-line and plane-line measurements should be parallel. 

 
 

How to Use 

How to find the distance between two edges 
1. Go to Measure > Distance or click the icon in the toolbar. 

 
 

2. To measure the distance between two cylinders, click the cylinder edges. When doing a 
mouse-over a measurement the measured entities will be shown. 
 

 
 

Note:  

To pick a position on a line or a plane, hold down the Ctrl button on the keyboard while 
clicking. 

 

 
 

Options in Detail 

Methods 

Linear – Measures distances between entities with the Auto method automatically assessing 
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entity types. 
 
Along Faces – Measures distance along the surface of a model between two points. 

 
 

Axis Align 

No Align – Calculates the direct distance between entities. 

 
 
X Axis Align – Calculates the distance in the X direction. 

 
 
Y Axis Align – Calculates the distance in the Y direction. 

 
 
Z Axis Align – Calculates the distance in the Z direction. 
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See Also 

Tools > Sketch Entities 
 
 
 

7.6.2. Measure > Angle  
 

What 

The Angle command measures the angle between two edges or three picked points. 

 
 
 

Why 

The Angle command is useful for: 

• Comparing angles between plane-plane 

• Comparing angles between plane-line 

• Comparing angles between plane-point 

• Comparing angles between line-line 

• Comparing angles between line-point-point 

• Comparing angles between point-point-point 

 

Note:  

Angles between parallel entities cannot be measured. 

 
 

How to Use 

How to find the angle between two edges 
1. Go to Measure > Angle or click on the icon in the toolbar. 
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2. Select two edges to measure the angle. Click OK to finish the command. When doing a 
mouse-over a measurement the measured entities will be shown. 

 
 

Note:  

To pick a position on a line or a plane, hold down the Ctrl button on the keyboard while 
clicking. 

 

 
 

See Also 

Tools > Sketch Entities 
 
 
 

7.6.3. Measure > Radius 
 

What 

The Radius command measures the radius of an edge or three picked points. 
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Why 

The Radius command is useful for: 

• Finding the radius of a circle 

• Comparing angles between point-point-point 

 
 

How to Use 

How to find the radius of an edge 
1. Go to Measure > Radius or click the icon in the toolbar. 

 
 

2. Select an edge to measure a radius from. Click OK to finish the command. When doing 
a mouse-over a measurement the measured entities will be shown. 
 

 
 
 

Options in Detail 

Methods 

Auto – Automatically finds a radius based on a feature shape 
 
3 Points – Finds a radius based on three selected points. 

 
 

See Also 

Tools > Sketch Entities 
 
 
 

7.6.4. Measure > Section 
 

What 



Geomagic Design X | Menu  877 
 

The Section command temporarily creates sections on a mesh and body to measure the deviation 
between them. 

 
 
 

Why 

The Section command is useful for: 

• Checking the deviation between reverse engineered models and original mesh 

 
 

How to Use 

How to find sectional differences between a body and a mesh 
1. Go to Measure > Section or click the icon in the toolbar. 

 
 

2. Select a mesh and a solid body as the Target Entity and click the Next Stage button. 
 

 
 

3. Choose the Select Plane option and select a base plane. 
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4. Choose the Min Distance option under Measure Method to find the minimum 
distance between the body and mesh. Select a point on the body section and then pick 
the scan section to get the distance. 

 
 

5. Click OK to finish the command. 
 
 

Options in Detail 

Select Entities 

This tool consists of 2 stages : 

• Target Entity 

Selects an entity to section 

• Section Type 

Chooses a candidate coordinate 

 
 

Stage 1/2 – Target Entity 

Target Entity – Selects a target entity to measure. 
 

Stage 2/2 – Section Type 

Draw Line On Screen – Draws a line on the screen that creates a virtual cutting line used to 
measure a section. 
 
Select Plane – Selects a plane to use as a cutting plane for measuring a section. 
 

Base Planes – Selects a base plane. 
 
N-Division Between Planes – Uses N-Divisions between planes to measure a section. 
 

Base Plane – Selects a base plane. 
 
N-Division Along Curve – Uses N-Division along a curve to measure a section. 
 

Path Curve – Selects a path curve. 
 
Radial – Uses a radius to measure a section. 
 

Axis – Selects an axis. 
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Base Plane – Selects a base plane. 

 
Cylindrical – Uses a cylinder to measure a section. 
 

Axis – Selects an axis. 
 

Base Plane – Selects a base plane. 
 
Conical – Uses a cone to measure a section. 
 

Axis – Selects an axis. 
 

Base Plane – Selects a base plane. 
 

Sub Methods 

Uniform – Creates uniform sections based on set distance between sections or set number of 
sections. 

 
Curvature – Creates a higher concentration of sections in higher curvature areas. 

 
Pick Points – Creates sections based on manually picked points. 
 

Options 

Flip Start Plane – Flips the direction of the starting plane. 
 
No. Of Sections – Sets the number of sections. 
 
Distance Between Sections – Sets the distance between sections. 
 
Equal Spacing – Sets the spacing between sections at an equal amount. 
 
Total Angle – Sets the total angle of a cylindrical and conical section. 
 
Show Section Base Geometry – Shows the base geometry for sections. 
 
Radius Interval – Sets the total radius interval of a cylindrical and conical section. 
 
Bottom Radius – Sets the total bottom radius of a conical section. 
 
Top Radius – Sets the total top radius of a conical section. 
 
Apex Angle – Sets the angle of the apex for a conical section. 
 
Base Radius – Sets the base radius for a cylindrical section. 
 
Height – Sets the total height for a cylindrical and conical section. 
 
Section Inside – Sets sections inside the base geometry 
 

Note:  
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If the option is unchecked, the sections will be set outside of the base geometry. 

 
Base Position – Sets the base position for a conical section 
 

Top – Sets the base position to the Top. 
 

Center – Sets the base position to the Center. 
 

Bottom – Sets the base position to the Bottom. 
 

Position – Sets the X, Y, and Z position for a conical section. 
 

X – Sets the X position. 
 
Y – Sets the Y position. 
 
Z – Sets the Z position. 

 

Measure Method 

Distance By Picking – Measures the distance between two selected points. 
 
Min. Distance – Measures the minimum distance from a selected point to a section. The two 
selected entities should be on the same plane. 
 
Normal Distance – Measures the distance from the normal direction from selected point to a 
section. The two selected entities should be on the same plane. 
 
Section Property – Shows the properties of a selected section. Only a scan section can be 
selected. 
 

Create Ref. Plane 

Planar Sections – Selects planar sections for the creation of a Ref. Plane at the position of a 
sectional plane that will remain after exiting the Section command. 
 

Create Ref. Polyline 

Sections – Selects sections for the creation of a Ref. Polyline at the position of a sectional plane 
that will remain after exiting the Section command. 

 
 

See Also 

Tools > Sketch Entities 
 
 
 

7.6.5. Measure > Mesh Deviations 
 

What 
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The Mesh Deviations command shows the deviation between point clouds and meshes using a 
defined color map. 

 
 
 

Why 

The Mesh Deviations command is useful for: 

• Checking the deviation between many meshes and point clouds 

 
 

How to Use 

How to find deviation between meshes 
1. After pre-aligning mesh using the Align Between Scan Data command, go to Measure 

> Mesh Deviations or click the icon in the toolbar. 

 
 

2. Select all meshes as Target Entities. Click the Next Stage button. 
 

Note:  

Histogram and Entity Thumbnails View windows will automatically open. Check the results 
in the windows.  

 

The results will be recorded in the Console window.  If needed, copy the results and paste it 
into other applications. For more information, see Console page. 
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3. In the Accuracy Analyzer(TM) panel check the Avg. Deviation option and uncheck the 
Hide Allowable Tolerance option. 

 

 
 
 

4. Click Cancel to exit the command. 
 
 

Options in Detail 

Stages 

This tool consists of 2 stages : 

• Target Entities and References 

Selects an entities and References for deviation analysis 

• Deviation Analysis 

Chooses a candidate coordinate. The ideal coordinate is listed at the top of the list box. 

 
 

Stage 1/2 – Target Entities and References 
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Target Entities – Chooses target entities. 
 
References – Chooses reference entities. 
 

Stage 2/2 – Deviation Analysis 

There are no options for this stage. However, deviations between target entities and target 
entities, and target entities and references can be analyzed by using the Accuracy Analyzer™ 
panel. 
 

Accuracy Analyzer ™ Panel 

Type – Creates a color map will be calculated with Max. Deviation, Min. Deviation or Avg. 
Deviation when comparing three or more meshes. 

 
 

None – No deviation will be analyzed. 
 

Max. Deviation – Maximum allowed deviation will be analyzed. 
 

Min. Deviation – Minimum allowed deviation will be analyzed. 
 

Avg. Deviation – Averages of the max. and min. deviation will be analyzed. 
 
Deviation Option – Sets options for deviation analysis. 
 

Max. Dev. – Sets the Max. Dev. limit in mm. 
 
Signed – Shows the deviation color map as positive and negative distances. 
 
Unsigned – Shows the deviation color map as an absolute distance. 

 
Allowable Tolerance – Sets the range of allowable deviation. 

 
Low – Sets the minimum allowable deviation. 
 
High – Sets the maximum allowable deviation. 
 
Color – Sets the color bar range for deviations. 
 
Hide Allowable Tolerance – Hides deviation that does not exceed the minimum or 
maximum allowable deviation. 
 

Auto Adjust Color Bar Range – Sets the color bar range automatically. 
 
 



Geomagic Design X | Menu  884 
 

See Also 

Docking Bars > Accuracy Analyzer 
 
 
 

7.7. View 
 
The View menu features commands to change how a model is displayed, change and split 
viewpoints, as well as other viewing related functions. 
 
The View menu provides tools used to: 
 
 

Manage Visibility 

• Visibility 

Select different entity types to display or hide 

 
 

Zoom 

• Zoom 

Zoom an area of interest, fit a model to a screen, or use the picture-in-picture (PIP) function 

 
 

Manage Mesh Display Mode 

• Mesh Display Mode 

Set how meshes are displayed in the model view 

 
 

Manage Body Display Mode 

• Body Display Mode 

Set how solid surfaces and bodies are displayed in the model view 

 
 

Manage Viewpoints 

• Viewpoint 

Sets how a model is displayed in the model view 
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Manage Viewports 

• Viewports 

Set the number of viewing windows and how they are displayed 

 
 

Manage Light Properties 

• Light Properties 

Set the global lighting properties such as color and point of origin within the model view 

 
 

Clip a View 

• View Clip 

Cut away a part of a model using cutting planes or a box to view inside of it 

 
 

Walk Through a Model 

• Walk-through 

Set the view to a first-person camera view to “walk-through” a model 

 
 
 

7.7.1. View > Visibility 
 
The Visibility menu features methods to show or hide entities in the Model View. 
 
 

Global Control 

• Show Selected Only 

Display only selected entities 

• Show All 

Show all entities 

• Hide All 

Hide all entities 

 
 

Individual Control 

• Meshes 
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Show or hide meshes 

• Regions 

Show or hide regions 

• Point Clouds 

Show or hide point clouds 

• Surface Bodies 

Show or hide surface bodies 

• Sketches 

Show or hide sketches 

• 3D Sketches 

Show or hide 3D sketches 

• Ref. Points 

Show or hide reference points 

• Ref. Vector 

Show or hide reference vectors 

• Ref. Planes 

Show or hide reference planes 

• Ref. Polylines 

Show or hide reference polylines 

• Ref. Coordinates 

Show or hide reference coordinates 

 
 
 

View > Visibility > Show Selected Only 
 

What 

The Show Selected Only command displays only selected entities in the Model View. 
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Why 

The Show Selected Only command is useful for: 

• Focusing on only specific entities 

 

Note:  

This command will be unavailable and dimmed if no entities have been selected. 

 
 

How to Use 

How to show or hide selected entities 
1. Select entities. Go to View > Visibility > Show Selected Only or click the icon in the 

toolbar. 
 
 

See Also 

View > Visibility > Show All 
View > Visibility > Hide All  
 
 
 

View > Visibility > Show All 
 

What 

The Show All command shows all entities in the Model View. 

 
 
 

Why 

The Show All command is useful for: 
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• Quickly showing all hidden entities 

 
 

How to Use 

How to show all entities 
1. Go to View > Visibility > Show All or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Hide All 
 
 
 

View > Visibility > Hide All 
 

What 

The Hide All command hides all entities in the Model View. 

 
 
 

Why 

The Hide All command is useful for: 

• Quickly hiding all visible entities 

 
 

How to Use 

How to hide all entities 
1. Go to View > Visibility > Hide All or click the icon in the toolbar. 
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See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
 
 
 

View > Visibility > Meshes 
 

What 

The View Meshes command displays or hides all meshes in the Model View. 

 
 
 

Why 

The View Meshes command is useful for: 

• Viewing all meshes at one time 

• Hiding all meshes at one time 

 
 

How to Use 

How to show or hide all meshes 
1. Go to View > Visibility > Meshes or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
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View > Visibility > Regions 
View > Visibility > Point Clouds 
View > Visibility > Surface Bodies 
View > Visibility > Solid Bodies 
View > Visibility > Sketches 
View > Visibility > 3D Sketches 
 
 
 

View > Visibility > Regions 
 

What 

The View > Visibility > Regions command displays or hides all regions in the Model view. 

 
 
 

Why 

The View Regions command is useful for: 

• Viewing all regions at one time 

• Hiding all regions at one time 

 
 

How to Use 

How to show or hide all regions 
1. Go to View > Visibility > Regions or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
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View > Visibility > Meshes 
View > Visibility > Point Clouds 
View > Visibility > Surface Bodies 
View > Visibility > Solid Bodies 
View > Visibility > Sketches 
View > Visibility > 3D Sketches 
 
 
 

View > Visibility > Point Clouds 
 

What 

The View Point Clouds command displays or hides all point clouds in the Model View. 

 
 
 

Why 

The View Point Clouds command is useful for: 

• Viewing all point clouds at one time 

• Hiding all point clouds at one time 

 
 

How to Use 

How show or hide all point clouds 
1. Go to View > Visibility > Point Clouds or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
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View > Visibility > Meshes 
View > Visibility > Regions 
View > Visibility > Surface Bodies 
View > Visibility > Solid Bodies 
View > Visibility > Sketches 
View > Visibility > 3D Sketches 
 
 
 

View > Visibility > Surface Bodies 
 

What 

The View Surface Bodies command displays or hides all Surface Bodies in the Model View. 

 
 
 

Why 

The View Surface Bodies command is useful for: 

• Viewing all Surface Bodies clouds at one time 

• Hiding all Surface Bodies at one time 

 
 

How to Use 

How show or hide all surface bodies 
1. Go to View > Visibility > Surface Bodies or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Meshes 
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View > Visibility > Regions 
View > Visibility > Point Clouds 
View > Visibility > Solid Bodies 
View > Visibility > Sketches 
View > Visibility > 3D Sketches 
 
 
 

View > Visibility > Solid Bodies 
 

What 

The View Solid Bodies command displays or hides all Solid Bodies in the Model View. 

 
 
 

Why 

The View Solid Bodies command is useful for: 

• Viewing all Solid Bodies at one time 

• Hiding all Solid Bodies at one time 

 
 

How to Use 

How show or hide all solid bodies 
1. Go to View > Visibility > Solid Bodies or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Meshes 
View > Visibility > Regions 
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View > Visibility > Point Clouds 
View > Visibility > Surface Bodies 
View > Visibility > Sketches 
View > Visibility > 3D Sketches 
 
 
 

View > Visibility > Sketches 
 

What 

The View Sketches command displays or hides all Sketches in the Model View. 

 
 
 

Why 

The View Sketches command is useful for: 

• Viewing all Sketches at one time 

• Hiding all Sketches at one time 

 
 

How to Use 

How show or hide all sketches 
1. Go to View > Visibility > Sketches or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Meshes 
View > Visibility > Regions 
View > Visibility > Point Clouds 



Geomagic Design X | Menu  895 
 

View > Visibility > Surface Bodies 
View > Visibility > Solid Bodies 
View > Visibility > 3D Sketches 
 
 
 

View > Visibility > 3D Sketches 
 

What 

The View 3D Sketches command displays or hides all 3D Sketches in the Model View. 

 
 
 

Why 

The View 3D Sketches command is useful for: 

• Viewing all 3D Sketches at one time 

• Hiding all 3D Sketches at one time 

 
 

How to Use 

How show or hide all 3D sketches 
1. Go to View > Visibility > 3D Sketches or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Meshes 
View > Visibility > Regions 
View > Visibility > Point Clouds 
View > Visibility > Surface Bodies 
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View > Visibility > Solid Bodies 
View > Visibility > Sketches 
 
 
 

View > Visibility > Ref. Points 
 

What 

The View Ref. Points command displays or hides all Ref. Points in the Model View. 

 
 
 

Why 

The View Ref. Points command is useful for: 

• Viewing all Ref. Points at one time 

• Hiding all Ref. Points at one time 

 
 

How to Use 

How show or hide all ref. points 
1. Go to View > Visibility > Ref. Points or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Ref.Vector 
View > Visibility > Ref.Planes 
View > Visibility > Ref.Polylines 
View > Visibility > Ref.Coordinates 
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View > Visibility > Ref. Vector 
 

What 

The View Ref. Vector command displays or hides all Ref. Vectors in the Model View. 

 
 
 

Why 

The View Ref. Vector command is useful for: 

• Viewing all Ref. Vectors at one time 

• Hiding all Ref. Vectors at one time 

 
 

How to Use 

How show or hide all ref. vectors 
1. Go to View > Visibility > Ref. Vector or click on the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Ref.Points 
View > Visibility > Ref.Planes 
View > Visibility > Ref.Polylines 
View > Visibility > Ref.Coordinates 
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View > Visibility > Ref. Planes 
 

What 

The View Ref. Planes command displays or hides all Ref. Planes in the Model View. 

 
 
 

Why 

The View Ref. Planes command is useful for: 

• Viewing all Ref. Planes at one time 

• Hiding all Ref. Planes at one time 

 
 

How to Use 

How show or hide all ref. planes 
1. Go to View > Visibility > Ref. Planes or click on the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Ref.Points 
View > Visibility > Ref.Vector 
View > Visibility > Ref.Polylines 
View > Visibility > Ref.Coordinates 
 
 
 

View > Visibility > Ref. Polylines 
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What 

The View Ref. Polylines command displays or hides all Ref. Polylines in the Model View. 

 
 
 

Why 

The View Ref. Polylines command is useful for: 

• Viewing all Ref. Polylines at one time 

• Hiding all Ref. Polylines at one time 

 
 

How to Use 

How show or hide all ref. polylines 
1. Go to View > Visibility > Ref. Polyline or click on the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Ref.Points 
View > Visibility > Ref.Vector 
View > Visibility > Ref.Planes 
View > Visibility > Ref.Coordinates 
 
 
 

View > Visibility > Ref. Coordinates 
 

What 

The View Ref. Coordinates command displays or hides all Ref. Coordinates in the Model View. 
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Why 

The View Ref. Coordinates command is useful for: 

• Viewing all Ref. Coordinates at one time 

• Hiding all Ref. Coordinates at one time 

 
 

How to Use 

How show or hide all ref. coordinates 
1. Go to View > Visibility > Ref. Coordinates or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Ref.Points 
View > Visibility > Ref.Vector 
View > Visibility > Ref.Planes 
View > Visibility > Ref.Polylines 
 
 
 

View > Visibility > Measurements 
 

What 

The Measurements command displays or hides all measurement entities in the Model View. 
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Why 

The Measurements command is useful for: 

• Viewing all measurement entities at one time 

• Hiding all measurement entities at one time 

 
 

How to Use 

How show or hide all measurements 
1. Go to View > Visibility > Measurements or click the icon in the toolbar. 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Ref.Points 
View > Visibility > Ref.Vector 
View > Visibility > Ref.Planes 
View > Visibility > Ref.Polylines 
 
 
 

View > Visibility > Smart Visibility 
 

What 

The Smart Visibility command intelligently offers a proper visibility method according to various 
modeling situations. 
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Within Mode 

Smart Visibility will control the visibility of following entity types within each mode: 

• Scan Data (Mesh / Point Cloud) 

• Body (Solid / Surface) 

• 2D Sketch 

• 3D Sketch 

Mode Visibility Remark 
Default Mode 4 States:  

Current State / Scan Only / Scan Data 
+ Body / Body Only 

 

Mesh Mode 3 States: 
Current State / Current Mesh Only / 
All Meshes 

If poly-face does not exist in current 
mesh, Current Mesh Only state will 
be skipped. 

Point Cloud Mode 2 States: 
Current State / Point Cloud Only 

 

Mesh Sketch Mode 4 States: 
Current State / 2D Sketch Only / Mesh 
+ 2D Sketch / Body + 2D Sketch 

Body for using Convert Entity 
command 

2D Sketch Mode 4 States: 
Current State / 2D Sketch Only / Body 
+ 2D Sketch / Mesh + 2D Sketch 

Body for using Convert Entity 
command 

3D Mesh Sketch Mode 2 States: 
Current State / Current Mesh + 3D 
Sketch 

 

3D Sketch Mode 4 States: 
Current State / Body + 3D Sketch / 
Mesh + Body + 3D Sketch / Mesh + 
3D Sketch 

 

 

Note:  

Region, Ref.Geometry, and Measurement entity types are excluded from this control, but Ref.Plane, 
Ref.Polyline, Ref.Coordinate and Measurement entity types can be controlled once by Smart Visibility in 
Mesh Sketch mode and 2D Sketch mode. 

If you manually change the visibility as a specific entity type by using the Visibility tools other than using 
the Smart Visibility tool, then the Current State will be updated as the modified state and the visibility 
circulation will be restarted by the Smart Visibility tool. Plus, if the Current State is identical with any pre-
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defined state, the Current State will be skipped. This rule will also be applied within modeling command 
and Modeling Wizard. 

 
 

Within Modeling Command and Modeling Wizard 

Smart Visibility will control the visibility of following entity types within each Modeling command 
and Modeling Wizard: 

• Scan Data (Mesh / Point Cloud) 

• Region (including Mesh Visibility) 

• Body (Solid / Surface) 

• 2D Sketch 

• 3D Sketch 

 
Mode Visibility Remark 

Extrude, Revolve, 
Sweep, Loft 

4 States:  
Current State / Preview Only / Scan Data + 
Preview / Body + Preview 

 

Primitives 2 States: 
Current State / Region Only or (In Preview 
stage) Region + Preview / Preview Only 

Primitives only work with 
Regions. 

Modeling Wizards 3 States (In 1st Stage): 
Current State / Region Only / Body + 
Region 

 

3 States (In 2nd Stage): 
Region + Preview / Region + Body + 
Preview / Body + Preview 

 

Note:  

The other commands not described in above will follow the behavior of Default Mode. 

 
 

Why 

The Smart Visibility command is useful for: 

• Quickly hide other multiple entities 

• Quickly show only desired entities in current modeling status 

 
 

How to Use 

How to use Smart Visibility 
1. Go to View > Visibility > Smart Visibility or click the icon in the toolbar. 

 
2. Check changes. 

 
3.  Go to View > Visibility > Smart Visibility or click the icon in the toolbar again to change 
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the visibility. 
 

 
 

See Also 

View > Visibility > Show Selected Only 
View > Visibility > Show All 
View > Visibility > Hide All 
View > Visibility > Ref.Points 
View > Visibility > Ref.Vector 
View > Visibility > Ref.Planes 
View > Visibility > Ref.Polylines 
 
 
 

7.7.2. View > Zoom 
 
The Zoom menu features methods to control zooming entities on Model View. 
 
The Zoom menu is divided into 2 tool groups used to: 
 
 

Zoom View 

• Area 

Zoom in on a specific area 

• Previous Area 

Display the previous area 

• Fit 

Fit all entities into the model view 

 
 

Create Picture-In-Picture 

• PIP 

Create a zoomed view within the model view 

 
 
 

View > Zoom > Area 
 

What 

The Zoom Area command zooms into a manually selected rectangular area. 
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Why 

The Zoom Area command is useful for: 

• Zooming in on specific areas of a model 

 
 

How to Use 

How to zoom in on an area 
1. Go to View > Zoom > Area or use the Shift+Z keyboard shortcut. 

 
2. Drag-select a rectangular region over the model. 

 

Note:  

The Zoom Area command is active until another command runs or the command is ran again. 
To go back to a previous viewing area use the View > Zoom > Previous Area command. 

 

 
 
 

See Also 
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View > Zoom > Previous Area 
View > Zoom > Fit 
View > Zoom > PIP  
  
 
 

View > Zoom > Previous Area 
 

What 

The Zoom Previous Area command restores the viewing window to the previous view. 

 
 
 

Why 

The Zoom Previous Area command is useful for: 

• Zooming to a previous view 

 
 

How to Use 

How to zoom to a previous area 
1. Go to View > Zoom > Previous Area or click the icon in the toolbar. The Shift + X 

keyboard shortcut can also be used. 
 

Note:  

The history of the Zoom Previous Area command is stacked when the Zoom Area command 
is executed: however it is unavailable until the Zoom Area command has been executed first. 

 

 
 

See Also 

View > Zoom > Area  
View > Zoom > Fit 
View > Zoom > PIP  
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View > Zoom > Fit 
 

What 

The Zoom Fit command fits a model into the viewing window. 

 
 
 

Why 

The Zoom Fit command is useful for: 

• Zooming a model to fit to the viewing window 

 
 

How to Use 

How to fit a model to the model view 
1. Go to View > Zoom > Fit or click the icon in the toolbar. The Ctrl + F keyboard shortcut 

can also be used. 
 

Note:  

The history of the Zoom Previous Area command is stacked when the Zoom Area command is 
executed: however it is unavailable until the Zoom Area command has been executed first. 

 

 
 

See Also 

View > Zoom > Area  
View > Zoom > Previous Area 
View > Zoom > PIP  
 
 
 

View > Zoom > PIP 
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What 

The Zoom PIP command creates a pop-up window that zooms onto a specific position. 

 
 

Event Short Cut / Action 

Window Toggle Ctrl + W 

Close Window Esc 

Move Ctrl + Left Mouse Button 

Window Size Ctrl + Mouse Wheel 

Magnification Mouse Wheel 
 

 Fix Center of Window 

 
Compensate Center (Click and drag the position that you want to 
set the center of the window) 

 Close Window 

 Edit Window Size 

 
 

Why 

The Zoom Fit command is useful for: 

• Zooming into precise areas without zooming the entire entity 

 
 

How to Use 

How to zoom using the PIP function 
1. Go to View > Zoom > PIP or click the icon in the toolbar. The Ctrl + W keyboard shortcut 

can also be used. 
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See Also 

View > Zoom > Area  
View > Zoom > Previous Area 
View > Zoom > Fit 
 
 
 

7.7.3. View > Mesh Display Mode 
 

What 

The Mesh Display Mode sets the display mode of a mesh by utilizing the following mode types: 

• Point Set – Draws only poly vertices 

• Wireframe – Draws only the edges of faces 

• Shaded – Draws shaded faces 

• Shaded With Edges – Draws shaded faces with edges 

• Texture – Draws textures 

• Curvature – Draws curvature flow on the mesh 

• Region – Draws regions 

• Geometry Type – Draws each geometry type (such as planes, spheres, revolutions, and 
freeforms, etc) in the same color  

• Transparent – Draws transparent mesh 

 

 
 

  

Point Set: F5 Wireframe: F6 
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Shaded: F7 Shaded With Edges: F8 
 

  
Texture Curvature 

 

  
Region: F9 Geometry Type 

 

 

 

Transparent  
 
 

Why 

The Mesh Display Mode is useful for: 

• Displaying mesh using one of the available display filters 

 
 

How to Use 



Geomagic Design X | Menu  911 
 

How to select a mesh display mode 
1. Go to View > Mesh Display Mode > Point Set / Wireframe / Shaded / Shaded With 

Edge or click the icon in the toolbar. 
 

See Also 

Docking Bars > Display  
 
 
 

7.7.4. View > Body Display Mode 
 

What 

The Body Display Mode sets the display mode of a surface or solid body by utilizing the following 
mode types: 

• Wireframe – Draws only the edges of bodies 

• Hidden Line – Draws all hidden lines on a body as dotted lines 

• Shaded – Draws all shaded faces 

• Shaded With Edges – Draws shaded faces with edges 

• Transparent – Draws transparent bodies 

 

 
 

  

Wireframe Hidden Line 
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Shaded Shaded With Edges 
 

 

 

Transparent  
 
 

Why 

The Body Display Mode is useful for: 

• Displaying bodies using one of the available display filters 

 
 

How to Use 

How to select a body display mode 
1. Go to View > Body Display Mode > Wireframe / Hidden Line / Shaded / Shaded With 

Edge or click the icon in the toolbar. 
 

See Also 

Docking Bars > Display  
 
 
 

7.7.5. View > Viewpoint 
 

What 

The Viewpoint commands set the view direction as one of seven pre-defined views and can also be 
used to rotate, flip and align a model’s view. 
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Front Back 
 

  

Left Right 
 

  

Top Bottom 
 

 

 

Isometric Bottom 
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Rotate CCW 

 

 
Rotate CW 

 

 

Flip 
 
Align View 
Sets the view direction in the Model View by selecting an entity and aligning to it. 

 
Before Align View 

 
After Align View 

 

Note:  

The Align View function can be reversed by holding the Ctrl button on the keyboard while using the 
function. 
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Why 

The Viewpoint command is useful for: 

• Setting the viewpoint of a model in the model view 

 
 

How to Use 

How to select a viewpoint 
1. Go to View > Viewpoint > Front / Back / Left / Right / Top / Bottom / Isometric or click 

the icon in the toolbar. 
 

See Also 

Docking Bars > Display  
 
 
 

7.7.6. View > Viewport 
 

What 

The Viewport commands set the viewing window a pre-set view layout, each having its own 
properties. 
 

 
 

 
1 View – Displays one view. 
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2 Vertical Views – Displays the view into two vertical panes. 

 
 
2 Horizontal Views – Displays the view into two horizontal panes. 

 
 
3 Left – Horizontal Views – Displays the view into three panes: two split panes on the left 
side and one full horizontal pane on the right side. 



Geomagic Design X | Menu  917 
 

 
 
3 Right – Horizontal Views – Displays the view into three panes: two split panes on the 
right side and one full horizontal pane on the left side. 

 
 
3 Top–Vertical Views – Displays the view into three panes: two split panes on the top half 
and one full horizontal pane on the bottom half. 

 
 
3 Bottom–Vertical Views – Displays the view into three panes: two split panes on the 
bottom half and one full horizontal pane on the top half. 
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4 Views - Displays the view into four equal sized panes. 

 
 
 

Why 

The Viewport command is useful for: 

• Setting the viewport window mode in the model view 

 
 

How to Use 

How to select a viewport 
1. Go to View > Viewport > 1 View / 2 Vertical Views / 2 Horizontal Views / 3 Left – 

Horizontal Views / 3 Right – Horizontal Views / 3 Top – Vertical Views / 3 Bottom – 
Vertical Views / 4 Views or click the icon in the toolbar. 

 
 
 

7.7.7. View > Light Properties 
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What 

The Light Properties command enables changing of the direction or the color of a light source. 

 
 
 

Why 

The Light Properties command is useful for: 

• Customizing the lighting conditions of the viewing area 

 
 

How to Use 

How to set light properties 
1. Go to View > Light Properties or click on the icon in the toolbar. 

 
 

2. Drag light sources to desired positions in the model view. The shadow will change while 
the light source is altered. 
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3. Click OK to complete the command. 
 
 

Options in Detail 

Methods 

Light – Sets the color of each light source. 
 

Light 1 – Sets the color of light 1. 
 
Light 2 – Sets the color of light 2. 
 
Light 3 – Sets the color of light 3. 
 
Light 4 – Sets the color of light 4. 
 

Reset – Resets all light settings back to default. 
 
 

See Also 

Docking Bars > Display  
 
 
 

7.7.8. View > View Clip 
 

What 

The View Clip command enables viewing of a model by clipping away a part of it. 
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Why 

The View Clip command is useful for: 

• Clipping away an area of a model to inspect it 

 
 

How to Use 

How to clip a view 
1. Go to View > View Clip or click the icon in the toolbar. 

 
2. Select the Inside Box option and a bounding box used to select the clipping area will 

appear. 

 
 

3. The dimensions of the box can be adjusted by dragging the blue arrows or the green 
points. 
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4. Click OK to complete the command. 
 
 

Options in Detail 

Methods 

Use View Clip – Toggles the view clip on or off. 
 
Below Plane – Defines a cutting plane and clips all model data above it. The Position and 
Normal Direction options of the plane can be defined unless the View Align option is used, in 
which case the normal of the plane aligns to the screen direction. 
 
Between Two Planes – Defines two cutting planes and clips all model data outside of the two 
planes. The Position or Normal Direction options of the plane can be defined unless the View 
Align option is used, in which case the normal of the plane aligns to the screen direction. The 
Depth option can be used to set the distance between two preview planes. 
 
Inside Box – Defines a cutting box and clips all model data outside of the box. The box can be 
resized in the Model View. 
 
Reset – Resets view clipping to default. 
 

Plane Options 

Position – Sets the position of the view clip plane. 
 

X – Sets the X position. 
 

Y – Sets the Y position. 
 

Z – Sets the Z position. 
 
Normal Direction – Sets the direction of the normal. 
 

X – Sets the X position. 
 

Y – Sets the Y position. 
 

Z – Sets the Z position. 
 

View Align – Aligns the normal direction to the global coordinates. 
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See Also 

Docking Bars > Display  
 
 
 

7.7.9. View > Walk Through 
 

What 

The Walk-through command enables the free movement of the viewpoint inside a model. 

 
 
 

Why 

The Walk-through command is useful for: 

• Moving a virtual camera through a model 

• Viewing the inside of a complex model like a scan of a building 

 
 

How to Use 

How to walk-through a model 
1. Note:  

The Walk-through command will be dimmed if the current viewpoint is at the top or the 
bottom of a model. To enable the function the model must be rotated to a side view. 

 
Upon executing the Walk-through command the Projection Method setting in the 
Display tab will automatically be changed to Perspective.  
 
The Point Shader option can be set to the Depth method which hides points away from 
the viewpoint. 
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2. Controlling the camera is identical to controlling the Pan function in the default viewing 

mode and can be activated by using the Ctrl + right mouse button (or left and right 
mouse button together) in the selection mode . Alternatively, the Ctrl + Left, Right, 
Up, Down shortcut keys can be used. 
 

3. Controlling the shift is identical to controlling the Zoom function in the default viewing 
mode and can be activated by using Shift + right mouse button in the selection mode 

. Alternatively, the Shift + Up, Down shortcut keys can be used. 
 

4. Rotating the camera is identical to the Rotate function in the default viewing mode and 
can be activated by using the right mouse button in the selection mode  . 
Alternatively, the Left, Right, Up, and Down keys on the keyboard can be used. 

 
 
 

7.8. Add-Ins 
 
The Add-Ins menu has various functions that are used to handle point clouds and polygons to 
generate complete polygon data. 
 
The Add-Ins menu is divided into 2 tool groups used to: 
 
 

Import and Register Scan Data 

• Import and Split 

Split scan data by the number of vertices or number of meshes while importing ASC, STL, OBJ, 
and PLY file formats 

• IGES Point Importer 

Import point cloud data formatted in the IGES file format 

• Register Target 

Align target scan data files automatically using alignment spheres 

 
 

Modify Scan Data 

• Delete Poly-Faces 

Quickly remove poly-faces without entering the Mesh mode 

• Trim Mesh 

Cut off regions surrounded by reference curves on a mesh or align poly-edges along reference 
curves 

• Flatten/Deform 

Flatten and deform mesh to generate a new mesh in a desired shape 
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7.8.1. Add-Ins > Import & Split 
 

What 

The Import & Split command splits scan data by the number of vertices or number of meshes while 
importing ASC, STL, OBJ, and PLY file formats. If data files are too large to import at one time this 
command features the Suppress option in the Import dialog box which separates the file and loads 
them onto the hard disk drive one at a time. 

 
 
 

Why 

The Import & Split command is useful for: 

• Importing large scan files 

 
 

Options in Detail 

Methods 

Split By Number Of Vertices – Splits a file based on number of vertices. 
 
Split By Number Of Meshes (or Point Clouds) – Splits a file based on number of meshes or 
point clouds. 
 
Overlap Ratio Among Meshes (or Point Clouds) (%) – Sets the overlap ratio between meshes 
or point clouds. 
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See Also 

Insert > Import  
 
 
 

7.8.2. Add-Ins > IGES Point Importer 
 

What 

The IGES Point Importer command imports point data formatted in the IGES file format. 
 
 

Why 

The IGES Point Importer command is useful for: 

• Importing IGES files 

• Importing large IGES files instead of using the Insert > Import command 

 
 

See Also 

Insert > Import  
 
 
 

7.8.3. Add-Ins > Register Target 
 

What 

The Register Target command roughly aligns meshes by matching target alignment spheres. 
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Why 

The Register Target command is useful for: 

• Combining multiple scans that are too large for one scan 

• Combining multiple scans that require the use of target alignment spheres 

 
 

How to Use 

How to align multiple scans by matching target alignment spheres 
1. Go to Add-Ins > Register Target or click on the icon in the toolbar. 

 
2. Select all meshes as Meshes targets. 

 

. 
 

3. Click the Magic Wand button to automatically get the ball size. When scan data is rough, 
the tolerance value can be increased. When scan data is smooth, the tolerance value can 
be decrease to help accurately find spheres. 
 

4. Click the OK button to complete the command. 

 
 
 

Options in Detail 

Methods 

Find Target Automatically – Automatically finds targets spheres on scan data. This option is 
available only for meshes. 
 
Set Target Manually – Directly defines targets by picking a seed point on a spherical area and 
registering each scan shot by matching extracted targets. 
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Selection Methods 

Scan Data – Select meshes or point clouds. 
 
Shared Scan Folder – Selects a folder to align files from. 
 

Select Share Folder – Chooses a designated shared scan folder. 
 

Ball Radius 

Acceptable Tolerance – Specifies the allowable tolerance for the radius of target spheres. 
 
Min. Size Of Cluster – Specifies the minimum number of poly-faces/vertices of a target sphere. 
 
Max. Size Of Cluster – Specifies the maximum number of poly-faces/vertices of a target sphere. 
 

More Options 

Ignore Spike Faces – Ignores spiky faces on targets. 
 
Use Curvature – Separates regions by curvature. 
 

Note:  

Target spheres must be disconnected from the rest of the scan to be found automatically, or 
manually located. 

 

 
 

See Also 

Tools > Scan Tools > Align Between Scan Data 
 
 
 

7.8.4. Add-Ins > Delete Poly-Faces 
 

What 

The Delete Poly-Faces command quickly removes poly-faces without entering the Mesh mode. 
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Why 

The Delete Poly-Faces command is useful for: 

• Deleting individual irregular poly-faces from multiple meshes at a time 

• Deleting extraneous poly-faces from scan data 

 
 

How to Use 

How to delete poly-faces from scan data 
1. Go to Add-Ins > Delete Poly-Faces or click the icon in the toolbar. 

 
 

2. Select poly-faces to remove. 

 
 

3. Click the Delete Selected Entities button or press the Delete key. 

 
 

4. Click the OK button to complete the command. 
 
 

Options in Detail 

Deleting 

Select Poly-Faces – Selects poly-faces to delete. 
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See Also 

Edit > Delete  
 
 
 

7.8.5. Add-Ins > Trim Mesh 
 

What 

The Trim Mesh command cuts off regions surrounded by reference curves on a mesh or aligns poly-
edges along reference curves. This function functions similarly as the Tools > Mesh Tools > Trim 
command, but can trim a mesh without entering the Mesh mode. 

 
 
 

Why 

The Trim Mesh command is useful for: 

• Deleting unwanted areas of mesh 

• Deleting extraneous mesh from scan data 

• Using child curve features to cut the mesh 

 
 

How to Use 

A. How to trim meshes from scan data using the By Curve method 
1. Go to Add-Ins > Trim Mesh or click the icon in the toolbar. 

 
 

2. Select the By Curve method. Choose a Mesh and Curves. Set the Method to Split Poly-
Faces. 
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. 
 

3. Click the Next Stage button. 

 
 

4. Click the OK button to complete the command. 

 
 
 

B. How to trim meshes from scan data using the By Custom Path 
method 
1. Go to Add-Ins > Trim Mesh or click the icon in the toolbar. 

 
 

2. Select the By Custom Path method. Created the desired path. 

. 
 

3. Click the Next Stage button. 
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4. Select the remaining Region and click the OK button to complete the command. 

 
 
 

Options in Detail 

Methods 

By Custom Path – Trims a mesh using a custom path. 

   

Drawing Custom Path Undo Path Close Path 
 
By Curve – You can trim a mesh with existing close curves. 
 
Trim Path – Undo, close and discard paths. 
 

Curve Options 

Mesh – Selects mesh. 
 
Curves – Selects Curves. 
 
Method – Selects the method. 
 

Rearrange Poly-Vertices – Trims by projecting nearby poly-vertices onto selected curves. 



Geomagic Design X | Menu  933 
 

  
 

Split Poly-Faces – Trims by dividing poly-faces with selected curves at intersecting 
position between poly-edges and curves. 

  
 

Max. Curve To Poly-Vertex Distance – Sets the maximum allowable distance from 
a curve to a poly vertex. 

 
Max. Edge Splitting Ratio – Sets the maximum allowable splitting ratio of edges. 
 

Remaining Region 

Remaining Region – Selects what regions will remain. 
 
 

See Also 

Tools > Mesh Tools > Trim 
 
 
 

7.8.6. Add-Ins > Flatten / Deform  
 

What 

The Flatten / Deform command flattens and deforms mesh to generate a new mesh in a desired 
shape. 

 
 
 

Why 
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The Flatten / Deform command is useful for: 

• Flattening damaged mesh 

• Flattening high curvature areas 

• Flattening a bent shape 

• Flattening to preserve a shape 

• Deforming to create a desired shape 

 
 

How to Use 

How to flatten a mesh 
1. Go to Add-Ins > Flatten And Deform or click on the icon in the toolbar. 

 
2. Choose the Flatten method and select a mesh as the Input Mesh. 

 

 

ISO View Side View 
 

3. Choose the Select Seed Poly Faces option under Driving Surface. 
 

4. Click the Select Poly-Faces button and select a point on an area of curvature on the 
mesh. 

 
 

5. Click the Extend button to automatically select the entire bent area. 

 
 

6. Set the flatten direction. For this example the XY direction is used. 
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7. Click OK to complete the command. 

  

Before After 
 

 
 

Options in Detail 

Methods 

Flatten – Flattens a bent area while preserving features. 

 
 
Deform – Deforms a flat area to a desired shape while preserving features. 

 
 
Flexible Registration – First flattens then deforms a target area while preserving features. 
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Input Mesh 

Select Mesh – Selects a mesh 
 

Driving Surface 

Select Initial Template – Chooses the Select Initial Template driving surface method. 
 

Select Initial Template – Selects initial template to use. 
 
Select Seed Poly-Faces – Chooses the Select Seed Poly-Faces driving surface method. 
 

Angle – Sets the angle of selected seed poly-faces 
 
Select Poly-Faces – Selects poly-faces for a driving surface. 

 

Direction 

Select Plane – Selects a plane to use as a directional plane 
 
XY – Sets the direction as XY. 
 
YZ – Sets the direction as YZ. 
 
ZX – Sets the direction as ZX. 
 
Offset – Offsets the directional plane by a set distance. 
 

Target Template 

Select Target Template – Selects a target template. 
 
 
 

7.8.7. Add-Ins > Target AutoMatch BETA  
 

What 

The Target AutoMatch BETA command aligns scan data automatically based on the target 
information of scan shots. It checks a specified data folder for scan shots as they are created and 
imports and aligns data in real-time. Scan data can also be aligned to either nominal target points 
or with other scan data that has corresponding target points. 
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Why 

The Target AutoMatch BETA command is useful for: 

• Matching multiple scans of the same part using target scan balls 

• Matching multiple scans in real time 

• Using a single ASCII converter template to align multiple scans to each other 

 
 

How to Use 

How to Target AutoMatch multiple scan files 
1. Go to Add-Ins > Target AutoMatch BETA. 

 
2. Click the Open button next to Data Folder and select the desired folder. 

 
 

3. Click the Open button next to Setup ASCII Converter Template and choose a .txt file. 
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4. Click the Start button next to Continuous Folder Audit to begin processing in real-
time. 

 
 

5. The scan data will be matched by their scan data balls. Click the Stop button to end real-
time matching. 

 
 

6. The Statistics for the final matched model will be displayed. Click the OK button. 
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7. Click OK to complete the command. 

  
Before After 

 

 
 

Options in Detail 

Continuous Folder Audit 

Start – Begins matching scan data from a selected target data folder. 
 
Stop – Stops matching scan data from a selected target data folder. 
 

Setting 

Data Folder – Selects a target data folder 
 
Matching Tolerance – Sets the tolerance threshold of target information on all scan data files to 
each other. 
 

Reference 

Nominal Target Points / Reference Scan – Selects nominal target points or reference scan data 
that other scan data files will be matched to. 
 

Moving 

Scan – Shows what file types are being moved 
 

Import Options – Selects import options. 
 

Point Cloud – Sets point cloud options. 
 

Include Vertex Normal – Used to include the vertex normal information for 
scan data 

 
Sampling Ratio – Sets the ratio for sampling of scan data from 1/1, 1/4, 1/9, 
1/16, 1/25, 1/36, 1/49, and 1/64. 

 
Mesh – Sets mesh options. 

 
Suppress Mesh – Suppress any mesh in scan data files. 

 
Common – Sets common options. 
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Include Texture – Sets texture options in scan data. 

 
None – Excludes textures. 

 
As It Is – Uses existing textures as set in scan data files. 

 
As Color Points – Sets the existing textures as color points. 

 
Target Points – Sets the target points to use for matching scan data files. 
 

Target File Format – Selects the target file format for setting target points. 
 

Ascii Points Files – Selects Ascii Points files (*.asc, *xyz and *.txt). 
 

Custom Extension – Sets a custom extension. 
 

Unit 

Nominal Target Unit – Selects the unit for the nominal target. 
 
Scan Unit – Selects the unit for scan data. 
 
Target Unit – Selects the unit for the target data. 

 
 
 

7.9. Help 
 

Help > Context 

The Help > Context menu loads the contents and index table of the help file into the Help 
window. When a specific item is double-clicked, the context will appear in the Help tab of the 
working window. To access documentation on a specific operation while a dialog tree is floating, 
press the F1 key while in that operation. 
 

Help > Quick Start Guide 

Going to Help > Quick Start Guide loads the quick start guide into the Help window. The purpose 
of the quick start guide is to give a “quick start” understanding of the modeling processes in the 
application. By working through the tutorial procedures, the fundamentals of the application can 
be learned. 
 

Help > Tutorial 

Going to Help > Tutorial loads the Tutorial that is installed with software. 
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Help > Release Note 

Going to Help > Release Note loads the release note for that version of the application that shows 
the new and enhanced functions and fixed bugs in the current version and previous versions. 
 

Help > Check For Update  

Going to Help > Check For Update checks the version of the application installed on your 
machine and downloads the latest patch files if any exist. 
 

Note:  

There are two methods to update the application: 

1. Letting the application automatically check when it is started. 

2. Manually using the Help > Check For Update command. 

 

Help > License Information 

Going to Help > License Information displays the current license information, like license type 
and expiry date. 
 

Help > Activate License 

The Help > Activate License command activates a current license. Follow the on screen 
instructions to complete the activation. 
 

Help > Deactivate License 

The Help > Deactivate License command can be used to deactivate your current license. Follow 
the on screen instructions to complete the deactivation. 
 

Help > Launch Performance Profiler 

Going to Help > Launch Performance Profiler runs a utility which analyzes the graphic driver, 
memory, processor speed, etc. of a PC and sets the best values in the Hardware tab in the 
Preferences. After performing the Performance Profiler the resulting file will be saved as an .htm 
document in the installation folder with the name of the PC. This document contains the hardware 
specifications of your system. 
 

Note: 

The Performance Profiler can also be found in the Windows’ Start menu, but this command doesn’t 
save the results as an .htm file and its calculation speed is quicker than in the version found in the Help 
menu. If a system setting, for example a new graphic card has been installed, use the Performance 
Profiler in the Windows’ Start menu to get the system information and register changed settings to the 
application. 
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When running the Performance Profiler, it is better to close all other applications for accurate results. 
The profiler takes about 2 or 3 minutes to complete the performance evaluation. 

 
 

Help > Support 

Going to Help > Support loads the Support tab which connects to the solution center. The Online 
Support Page in the Support tab can be searched for information. The support tab provides helpful 
information such as the latest tutorials, FAQs, and technical tips. As well, feedback for Geomagic 
products can be sent.  
The Online Support Page can be accessed by going to: 
https://rapidform.zendesk.com/home 
 

Help > About 

The Help > About menu displays a window including information about the application, such as 
the version of the product, the product ID and copyright information. Click the window to close it. 
 
  

https://rapidform.zendesk.com/home
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8. Glossary 
This chapter explains the definition of terms used in Geomagic Design X. The following sections 
define many of the basic terms and concepts you should know in order to use Geomagic effectively. 
 

A 

ASME Y14.5M-1994  

The national standard for dimensioning and tolerancing in the United States. ASME stands for The 
American Society of Mechanical Engineers. The Y14.5 is the standard number. "M" is to indicate the 
measurement standard is metric, and 1994 is the date the standard was officially approved. 
 

Aspect Ratio 

Ratio of width to height. 
 

Axis 

A straight virtual line that creates a basis for rotation. It can be used to create revolving features or 
patterns. An axis can be made in various ways. It can be created by drawing a line, extracting from a 
cylindrical feature, and by intersecting two planes. 
 
 

B 

Basic Dimension 

A numerical value used to describe a theoretically exact size, true profile, orientation, or location of 
a feature or datum target. 
 
Bitmap  
A Bitmap is a pixel by pixel image. 
 

Boundary 

A series of poly-edges that form the borders of a model or an internal hole 
 

Bounding Box 

A bounding box is a rectangular box that fully encloses mesh data. It is oriented to the world 
coordinate system.  
 

Boundary Edge 

A boundary edge is a poly-edge of a polygon that is not shared with another polygon. 
 

Base 
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The first solid feature of a part. Additional features are usually built from here. 
 

Body 

A 3D object. It is composed of one or more components. When a body contains more than one 
component, it is a disjointed body. 
 

Boolean 

A Boolean is operations that are used to combine bodies by uniting, subtracting and intersecting to 
create new bodies. 
 
 

C 

CAD 

Computer Aided Design. 
 

Control Points 

A set of points that parameterize and control the shape of a NURBS curve or surface. 
 

Curvature 

This is a mathematically-defined term which refers to the amount of roundness located at a point 
on a curve or surface. If a curve is flat, then its curvature is zero. As the curve becomes more rounded, 
the radius of curvature goes down and the curvature goes up. Curvature 'k' = 1 / rho, where rho is 
defined as the radius of curvature. These two values ('k' and 'rho') are inversely related. 
 

Curve 

A curve is a mathematical function that describes the path of a point moving through space. In the 
application, curves are displayed by sampling the mathematical description of the curve at specified 
intervals, then drawing line segments between these sample points. 
 

Centerline 

A centerline marks an axis of symmetry in a sketch or drawing in a phantom font. 
 

Chamfer 

Related to a blend. Instead of modifying an edge by smoothing it over, the edge is shaved with a flat 
cutter, creating two new sharp edges and an extra face, the surface of which is a plane, cone or B-
surface. 
 

Closed profile 

A closed profile is a sketch or sketch entity with no exposed endpoints. It can be a circle, a polygon, 
or shape composed by lines and arcs. 
 

Cut 
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To remove a part from a body or from scan data, surface bodies, planes, or lines can be used to trim 
off a target feature. 
 

Continuity 

The continuity between the patches of a B-surface or segments of a B-surface can be of various levels:  
 

‘C' Continuity for curves and surfaces:  

C0 means that the positions are continuous in both magnitude and direction  
C1 means that the positions and first derivatives are continuous in both magnitude and direction  
C2 means that the positions and first and second derivatives are continuous in both magnitude and 
direction  
 

'G' Continuity for curves:  

G0 means that the positions are continuous in direction but not necessarily in magnitude  
G1 means that the positions and first derivatives are continuous in direction but not necessarily in 
magnitude  
G2 means that the positions and first and second derivatives are continuous in direction but not 
necessarily in magnitude  
 

'G' Continuity for surfaces:  

G0 means that the positions are continuous in direction but not necessarily in magnitude  
G1 means that the positions and surface normals are continuous in direction but not necessarily in 
magnitude  
G2 means that the positions, surface normals, and curvatures are continuous in direction but not 
necessarily in magnitude 
 
 

D 

Datum 

A theoretical exact point, axis, or plane derived from the true geometric counterpart of a specified 
datum feature. A datum is the origin from which the location or geometric characteristics of the 
features of a part are established. 
Situation features are used to define the position and/or orientation of a tolerance zone, or to define 
the position and/or orientation of the virtual conditions (in the case of complementary requirements, 
e.g. maximum material requirement).  
 

Datum Feature  

A feature of a part that is used to establish a datum. 
 

Datum Reference Frame 

A datum system is an ordered list of at least one datums and at most three datums, which may be 
single or common datums. They are a set of symbols and rules that communicate to the user who is 
drawing on how dimensional measurements are to be made. 
 

Datum Target 
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A specified point, line, or area on a part used to establish a datum. It can also be a portion of an 
integral feature (surface) which can be a point, a line or an area. 
 

Decimation 

An operation that reduces the number of entities in an object. It attempts to preserve the object's 
overall shape and sharp features while simplifying it. 
 

Derived Feature 

A derived feature is the center point, median line or median surface from one or more integral 
features. 
 

Dimension 

A numerical value expressed in appropriate units of measurement and used to define the size, 
location, orientation, form, or other geometric characteristics of a part. 
 

Drag-select 

The selection of entities by moving the mouse while holding down the left mouse button. 
 

Draft 

Draft is incorporated into the wall of a mold so that the opening of the cavity is wider than its base. 
Draft allows for easier ejection of the part from the mold. 
 
 

E 

Extrude 

An extrude is the shape created by moving a profile along a path that is line. 
 

Entity 

An entity is an item in the model which can be accessed by the application. 
 
 

F 

Features 

A general term applied to a physical portion of a part, such as a surface, pin, tab, hole or slot. 
 

Fillet 

A fillet is an operation that rounds a corner of a profile or an edge of a solid / surface to a specified 
radius. 
 
 

G 
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Guide curve 

A guide curve is either a 2D or 3D curve. It is used to generate the outer shape of a sweep or loft 
feature. 
 

Geometries 

Geometries are the points, curves and surfaces which specify the shape and position of an element. 
 
 

H 

Healing 

A series of functions whose purpose is to correct geometric abnormalities contained within a model. 
Common functions may include: surface simplification (mapping spline surfaces to analytic shapes 
such as planes, cylinders, cones, etc.), poly-face stitching, and poly-edge gap repair. More advanced 
functions may include the ability to merge coincident vertices, repair self-intersections, and reduce 
and/or redeploy curve and surface control nodes. Programs typically perform healing on geometry 
that you import through neutral formats such as IGES, STEP, and SAT with problems caused by 
conditions ranging from imprecise geometric definitions to poor entity mapping to poorly written 
translator code. 
 
 

I 

IGES 

Initial Graphics Exchange Specification, a standard for exchanging geometric information 
 

Interpolation 

The process of defining a curve (or surface) that passes through a set of points. 
 

Iso-Lines 

An isoline is a curve parameterized by one of the surface parameters (u,v) while the other surface 
parameter is fixed. Isolines provide a simple means to display a surface. By fixing the ‘u’ parameter of 
surface, the iso-u lines of the form c(v) = s(u0,v) are produced, and by fixing the v parameter, the iso-
v lines of the form c(u) = s(u,v0) are produced. 
 

L 

Light 

A source used to illuminate a model. In the application, there are 4 lights you can use. They are used 
to display mesh data with Shaded or Transparent rendering modes. The position of each light source 
is shown in the following picture. 
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LMB 

Left Mouse Button 
 

Loop 

A fundamental item of topology representing one boundary of a face as a closed and connected set 
of edges. 
 

Loft 

The loft command connects several sectional profiles and then generates a smooth feature. 
 
 

M 

Mouse Drag 

Moving the mouse while pressing and holding a mouse button. 
 

Mirror 

The mirror command generates symmetric features across a plane or planar face. In the sketch mode, 
a line is used instead of a plane.  
 
 

N 

Noise 

Noise is erroneous data resulting from the scanning process, is usually represented as unnecessary 
points in 3D point cloud. 
 

Normal 

A surface normal at a point on a surface is a vector which is locally perpendicular to the surface. 
Normal describes a unit vector. 
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NURBS 

Non-Uniform Rational B-Spline. This is a type of spline where curves pass close to, but not through 
control points or knots and is used in spline-based modeling. Also commonly used to describe 
NURBS surfaces; which are surfaces comprised of a number of splines in two directions (U and V). 
 
 

P 

Parallel Projection view 

Parallel Projection view shows a model without any parallax. 
 

Parallelism 

Parallelism is the condition that results when a surface, axis or center plane is exactly parallel to a 
datum. 
 

Path 

A path is an element composed of lines or curves used to generate a sweep or loft feature. 
 

Pattern 

A pattern is a series of features from a selected seed feature. If the seed entity is changed, the other 
instances in the pattern update. 
 

Plane 

A plane is a flat construction geometry which can be used as the basis of 2D sketches, mirror planes, 
cutting a model, etc. 
 

Point 

A point is a single point construction geometry, which can be used to create other objects. 
 

Poly-edge 

A line connecting two adjacent vertices on a polygon. 
 

Polygonal model 

A model composed of polygonal faces.  
 

Poly-face 

A poly-face is a flat N-sided face composed of N vertices. The application only allows 3-sided faces 
which are three poly-edges connected by vertices. 
 

Polyline 
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A collection of line segments, connected end to end. 
 

Poly-Vertex 

A point at which two or more lines or poly-edges intersect. Vertices can be selected for sketching, 
dimensioning, and many other operations. 
 

Primitives 

Pre-defined basic objects, either 2D or 3D, i.e., circle, square, arc, plane or sphere, cube, cylinder, cone, 
torus, and various polyhedrons. 
 

Profile 

A sketch entity or a group of edges on a body that is used to create a loft body, an extrude body and 
so on. 
 
 

R 

Region Groups 

Region groups are user-defined geometric feature areas on a mesh. They can be used to extract 
design intent from a scanned object and to helps users create surface or solid bodies based on 
geometric information from a target mesh. 
 

RMB 

Right Mouse Button. 
 

Reference Geometry 

Basic geometrical elements, such as planes, axes, and coordinate systems. Reference geometry is 
not a body but used to assist in creating features. 
 

Revolve  

A feature can be generated by revolving sketched profiles around a centerline. 
 

Rollback 

Enables a model to be returned to a previous point in a construction history. Changes made to a 
feature are reflected in subsequent features once Rolled Forward. This command is commonly used 
to change the parameters of previous features. 
 
 

S 

SAT 

A file format for 3D solid geometry that is native for any ACIS modeling software developed by 
Spatial Technology Corp. 
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STL 

Stereo Lithography file format. Contains polygonal mesh data defined by vertex, and connections 
between them. Can be written in ASCII (text) or binary. 
 

Surface 

A surface is used to describe the skin of a 3D geometric element. 
 

Sweep 

A feature is generated by moving a profile (section) along a path. 
 

Spline 

A 2D or 3D curve consisting of several control points. 
 

Sketch 

A group of sketch entities (lines, arcs, splines, etc) drawn on a plane or planar face. A 3D sketch is a 
non-planar entity and can be used as a path for a sweep or loft feature. 
 
 

T 

Tessellation 

Tessellation is the process of subdividing a surface into smaller shapes. Tessellation is used to convert 
a Solid, Surface, or Reference object into a polygonal mesh. To create object surface patterns, 
tessellation breaks down the surface of an object into manageable polygons. Triangles are 
frequently used in drawing graphical objects because computer hardware can easily manipulate 
and calculate them.  
 

3-2-1 Rule 

A rule that defines the minimum number of points of contact required for a part datum feature with 
its primary, secondary, and tertiary datum planes. 
 

Toggle 

To switch from one setting to another. The term toggle implies that there are only two possible 
settings and that you are switching from the current setting to the other setting. 
 

Tolerance 

The value that features of a part are permitted to vary from the specified dimension. 
 

Toolbar 

Movable palette of tools that performs operations 
 

Tangent arc 
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An arc that is tangent to another entity, such as a line and an arc. 
 
 

U 

UV 

Instead of X and Y coordinates, the U and V coordinates are used as a base coordinate system for 
representing a 2D-based work space or entity. 
 
 

V 

Viewports 

Windows that display 3D views of models. 
 
 

W 

Wireframe 

One of the display methods for solid and surface bodies. In this mode only the body edges are 
displayed and the faces are hidden. 
 

World Coordinates 

In 3D space, World Coordinates are a rectangular Cartesian coordinate system used to define the 
location of models, lights, cameras, etc. It is independent of viewpoint and display. The origin of the 
world coordinate system is (0, 0, 0). 
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